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				Introduction

				Adobe software has always been highly respected for creative design and development. Adobe creates tools that allow you to produce amazing designs and creations with ease. The Adobe Creative Suite 6 (CS6) Design & Web Premium is the company’s latest release of sophisticated and professional-level software that bundles many separate programs as a suite. Each program in the suite works individually, or you can integrate the programs by using Adobe Bridge, an independent program that helps you control file management with thumbnails and metadata and other organizational tools.

				You can use the Adobe CS6 Design & Web Premium programs to create a wide range of products, from illustrations, page layouts, websites, photographic compositions, video, and 3D images. Integrating the CS6 programs extends the possibilities for you as a designer. Don’t worry about the programs being too difficult to figure out — just come up with your ideas and start creating!

				About This Book

				Adobe Creative Suite 6 Design & Web Premium All-in-One For Dummies is written in a thorough and fun way to show you the basic steps of how to use each program included in the suite. You find out how to use each program individually and how to work with the programs together, extending your projects even further. You find out just how easy it is to use the programs by following simple steps so that you can discover the power of the Adobe software. You’ll be up and running in no time!

				Here are some things you can do with this book:

				[image: check.png] Create page layouts with text, drawings, and images in InDesign.

				[image: check.png] Make illustrations using drawing tools with Illustrator.

				[image: check.png] Manipulate photographs by using filters and drawing or color correction tools with Photoshop.

				[image: check.png] Create PDF (Portable Document Format) documents with Adobe Acrobat or other programs.

				[image: check.png] Create web pages and put them online with Dreamweaver.

				[image: check.png] Create animations and videos with Flash.

				[image: check.png] Create web images, rollovers, image maps, and slices with Fireworks.

				You discover the basics of how to create all these different kinds of things throughout the chapters in this book in fun, hands-on examples and clear explanations, getting you up to speed quickly!

				Foolish Assumptions

				You don’t need to know much before picking up this book and getting started with the Design & Web Premium suite. All you have to know is how to use a computer in a very basic way. If you can turn on the computer and use a mouse, you’re ready for this book. A bit of knowledge about basic computer operations and using software helps, but it isn’t necessary. We show you how to open, save, create, and manipulate files using the CS6 programs so that you can start working with the programs quickly. The most important ingredient to have is your imagination and creativity — we show you how to get started with the rest.

				Conventions Used in This Book

				Adobe CS6 Design & Web Premium is available for both Windows and the Macintosh. We cover both platforms in this book. When the keys you need to press or the menu choices you need to make differ between Windows and the Mac, we let you know by including instructions for both platforms. For example:

				[image: check.png] Press the Alt (Windows) or Option (Mac) key.

				[image: check.png] Choose Edit⇒Preferences⇒General (Windows) or InDesign⇒Preferences⇒General (Mac).

				The programs in Design & Web Premium Suite often require you to press and hold down a key (or keys) on the keyboard and then click or drag with the mouse. For brevity’s sake, we shorten this action by naming the key you need to hold down and adding a click or drag, like this:

				[image: check.png] Shift-click to select multiple files.

				[image: check.png] Move the object by Ctrl-dragging (Windows) or [image: maccmd]-dragging (Mac).

				Here are the formatting conventions used in this book:

				[image: check.png] Bold: We use bold to indicate when you should type something or to highlight an action in a step list. For example, the action required to open a dialog box would appear in bold in a step list.

				[image: check.png] Code font: We use this computerese font to show you web addresses (URLs), e-mail addresses, and bits of HTML code. For example, you type a URL into a browser window to access a web page, such as www.google.com.

				[image: check.png] Italics: We use italics to highlight a new term, which we then define. For example, filters may be a new term to you. The word itself is italicized and is followed by a definition to explain what the word means.

				What You Don’t Have to Read

				This book is pretty thick; you may wonder whether you have to read it from cover to cover. You don’t have to read every page of this book to discover how to use the programs in the Design & Web Premium Suite. Luckily, you can choose bits and pieces that mean the most to you and will help you finish a project you may be working on. Perhaps you’re interested in creating a technical drawing and putting it online. You can choose to read a couple chapters in Book III on Illustrator and then skip ahead to Book VI on Dreamweaver and just read the relevant chapters or sections on each subject. Later, you may want to place some associated PDF documents online, so read a few chapters in Book V on Acrobat or Book II on exporting InDesign documents. Find out how to create animations for the web and video in Book VII covering Flash.

				You don’t have to read everything on each page, either. You can treat many of the icons in this book as bonus material. Icons supplement the material in each chapter with additional information that may interest or help you with your work. The Technical Stuff icons are helpful if you want to find out a bit more about technical aspects of using the program or your computer, but don’t feel that you need to read these icon paragraphs if technicalities don’t interest you.

				How This Book Is Organized

				Adobe Creative Suite 6 Design & Web Premium All-in-One For Dummies is split into eight quick-reference guides, or minibooks. You don’t have to read these minibooks sequentially, and you don’t even have to read all the sections in any particular chapter. You can use the table of contents and the index to find the information you need and quickly get your answer. In the following sections, we briefly describe what you find in each minibook.

				Book I: Adobe Creative Suite 6 Basics

				Book I shows you how to use the features in Design Premium programs that are similar across all the programs described in this book. You discover the menus, panels, and tools that are similar or work the same way in most of the CS6 programs. You also find out how to import and export and use common commands in each program. If you’re wondering about what shortcuts and common tools you can use in the programs to speed up your workflow, this minibook has tips and tricks you’ll find quite useful. The similarities in all the programs are helpful because they make using the programs that much easier.

				Book II: InDesign CS6

				Book II describes how to use InDesign CS6 to create simple page layouts with text, images, and drawings. Hands-on steps show you how to use the drawing tools in InDesign to create illustrations and also use other menus and tools to add text and pictures. Importing stories and illustrations into InDesign is an important part of the process, so you find out how this task is done effectively as well. Book II shows you how easily you can create effective page layouts with this powerful and professional design program.

				Book III: Illustrator CS6

				Book III starts with the fundamentals of Adobe Illustrator CS6 to help you create useful and interesting illustrations. Check out this minibook to discover how to take advantage of features that have been around for many versions of Illustrator, such as the Pen tool, as well as new and exciting features, such as vector tracing. See how to take advantage of the Appearance panel and save time by creating graphical styles, templates, and symbols. Pick up hard-to-find keyboard shortcuts that can help reduce the time you spend mousing around for menu items and tools.

				Book IV: Photoshop CS6

				Book IV on Photoshop CS6 is aimed to help you achieve good imagery, starting with basics that even advanced users may have missed along the way. In this minibook, you find out how to color correct images like a pro and use tools to keep images at the right resolution and size, no matter whether the image is intended for print or the web.

				This minibook also shows you how to integrate new features in Photoshop, such as the new layer, text style and brush tips features, as well as inform you of the new 3D tools. By the time you’re finished with this minibook, you’ll feel like you can perform magic on just about any image.

				Book V: Acrobat X

				Adobe Acrobat X is a powerful viewing and editing program that allows you to share documents with colleagues, clients, and production personnel, such as printers and web-page designers. Book V shows you how you can save time and money previously spent on couriers and overnight shipping by taking advantage of annotation capabilities. Discover features that even advanced users may have missed along the way and see how you can feel comfortable about using PDF as a file format of choice.

				Book VI: Dreamweaver CS6

				Book VI shows you how creating a website in Dreamweaver CS6 can be easy and fun. Take advantage of the tools and features in Dreamweaver to make and maintain a clean and usable site. Discover how to take advantage of improved Cascading Style Sheets (CSS) capabilities as well as exciting rollover and action features that add interactivity to your site. In the past, these functions required lots of hand-coding and tape on the glasses, but now you can be a designer and create interactivity easily in Dreamweaver — no hand-coding or pocket protectors required.

				Book VII: Flash Professional CS6 and Edge

				Find out how to create interactive animations for the web and video with Flash CS6. Start with the basics, such as creating simple animations with tweening, all the way up to animations that allow for user interaction. This Timeline-based program may be different from anything you’ve ever worked with, but Flash is sure to be an exciting program to discover.

				Book VIII: Fireworks CS6

				As the newest addition to the suite, Fireworks CS6 offers you the capabilities you need to create virtually any sort of web graphic. By using Fireworks, you can optimize (prepare for the web) images and graphics as well as create cool rollover effects and sliced graphics. Find out in Book VIII how to spice up your website with buttons, image maps, and more!

				Icons Used in This Book

				What’s a For Dummies book without icons pointing you in the direction of truly helpful information that’s sure to speed you along your way? Here we briefly describe each icon we use in this book.

				[image: tip.eps]	The Tip icon points out helpful information that’s likely to make your job easier.

				[image: remember.eps]	This icon marks a generally interesting and useful fact — something you may want to remember for later use.

				[image: warning_bomb.eps]	The Warning icon highlights lurking danger. When we use this icon, we’re telling you to pay attention and proceed with caution.

				[image: technicalstuff.eps]	When you see this icon, you know that there’s techie-type material nearby. If you’re not feeling technical-minded, you can skip this information.

				Where to Go from Here

				Adobe Creative Suite 6 Design & Web Premium All-in-One For Dummies is designed so that you can read a chapter or section out of order, depending on what subjects you’re most interested in. Where you go from here is entirely up to you!

				Book I is a great place to start reading if you’ve never used Adobe products or if you’re new to design-based software. Discovering the common terminology, menus, and panels can be quite helpful for later chapters that use the terms and commands regularly!

				Many of the files that are referenced in this book are available right in the application sample folders that come with Creative Suite 6. The path locations are defined when they are referenced, making it easy to find and use them in the provided step-by-step examples. In addition to these sample files, you can find tips and tricks and more files for you to experiment with and investigate at www.agitraining.com/dummies.

				Occasionally, we have updates to our technology books. If this book does have any technical updates, they’ll be posted at www.dummies.com/go/adobecs6aiofd/updates.

				Please note that some special symbols used in this eBook may not display properly on all eReader devices. If you have trouble determining any symbol, please call Wiley Product Technical Support at 800-762-2974. Outside of the United States, please call 317-572-3993.  You can also contact Wiley Product Technical Support at www.wiley.com/techsupport.
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				Chapter 1: Introducing Adobe Creative Suite 6

				In This Chapter

				[image: check.png] Looking over InDesign CS6

				[image: check.png] Drawing with Illustrator CS6

				[image: check.png] Introducing Photoshop CS6

				[image: check.png] Getting started with Acrobat X

				[image: check.png] Creating websites with Dreamweaver CS6

				[image: check.png] Getting into Flash Professional CS6 

				[image: check.png] Getting fired up with Fireworks CS6

				[image: check.png] Putting Adobe Bridge into your workflow

				[image: check.png] Integrating the programs in Adobe CS6

				With the Adobe Creative Suite 6 (CS6) Design Premium release, you’re equipped with the tools you need to be creative for printed documents, online documents (including e-books), and interactive applications.

				The diverse software in Adobe CS6 Design Premium enables you to create everything from an interactive e-commerce website to a printed book. Each piece of software in the Adobe Creative Suite works on its own as a robust tool. Combine all the applications, including Adobe Bridge, and you have a dynamic workflow that just can’t be matched.

				In this minibook, you see the many features that are consistent among the applications in the suite. You find consistencies in color, file formats, and text editing as well as general preferences for rulers and guides throughout all applications in CS6. This minibook also shows you where to find the new features and how to save time by taking advantage of them.

				In this chapter, you meet each of the components in Adobe CS6 Design Premium and discover what you can create with each of these powerful tools.

				Introducing InDesign CS6

				InDesign is a diverse and feature-rich page layout program. With InDesign, you can create beautifully laid-out page designs. You can also execute complete control over your images and export them to interactive documents, such as Acrobat PDF. You can use InDesign to

				[image: check.png] Use images, text, and even rich media to create unique layouts and designs.

				[image: check.png] Import native files from Photoshop and Illustrator to help build rich layouts in InDesign that take advantage of transparency and blending modes.

				[image: check.png] Export your work as an entire book, including chapters, sections, automatically numbered pages, and more.

				[image: check.png] Create interactive PDF documents.

				[image: check.png] Create drawings with the basic drawing tools included in the software.

				InDesign caters to the layout professional, but it’s easy enough for even beginners to use. You can import text from word processing programs (such as Microsoft Word, Notepad, or Adobe InCopy) as well as tables (say, from Microsoft Excel) into your documents and place them alongside existing artwork and images to create a layout. In a nutshell, importing, arranging, and exporting work are common processes when working with InDesign. Throughout the entire process, you have a large amount of control over your work, whether you’re working on a simple one-page brochure or an entire book of 800-plus pages.

				If you’re already using InDesign, read Book II, Chapter 1 to find out  about some of the new features InDesign CS6 has, including the ability to export epubs.

				Using Illustrator CS6

				Adobe Illustrator is the industry’s leading vector-based graphics software. Aimed at everyone from graphics professionals to web users, Illustrator allows you to design layouts, logos for print, or vector-based images that can be imported into other programs, such as Photoshop, InDesign, or even Flash. Adobe also enables you to easily and quickly create files by saving Illustrator documents as templates (so that you can efficiently reuse designs) and using a predefined library and document size.

				Illustrator also integrates with the other products in the Adobe Creative Suite by allowing you to create PDF documents easily within Illustrator. In addition, you can use Illustrator files in Photoshop, InDesign, and the Adobe special effects program, After Effects. Illustrator allows you to beef up your rich interactive documents by introducing Flash features that give you the tools you need to build exciting interactive designs in Flash.

				Here are some of the things you can create and do in Illustrator:

				[image: check.png] Create technical drawings (floor plans or architectural sketches, for example), logos, illustrations, posters, packaging, and web graphics.

				[image: check.png] Add effects, such as drop shadows and Gaussian blurs, to vector images.

				[image: check.png] Enhance artwork by creating your own custom brushes.

				[image: check.png] Align text along a path so that it bends in an interesting way.

				[image: check.png] Lay out text into multicolumn brochures — text automatically flows from one column to the next.

				[image: check.png] Create charts and graphs using graphing tools.

				[image: check.png] Create gradients that can be imported and edited into other programs, such as InDesign.

				[image: check.png] Create documents quickly and easily using existing templates and included stock graphics in Illustrator.

				[image: check.png] Save a drawing in almost any graphic format, including the Adobe PDF, PSD, EPS, TIFF, GIF, JPEG, and SVG formats.

				[image: check.png] Save your Illustrator files for the Web by using the Save for Web dialog box, which allows you to output GIF, HTML, and JPEG files.

				[image: check.png] Save Illustrator files as secure PDF files with 128-bit encryption.

				[image: check.png] Export assets as symbols to Flash.

				Illustrator has new features for you to investigate, many of them integrated in the chapters in Book III. Find out about new tools, including features to help you use patterns. Find additional features by reading Book III, Chapter 1.

				Getting Started with Photoshop CS6

				Photoshop is the industry standard software for web designers, video professionals, and photographers who need to manipulate bitmap images. Using Photoshop, you can manage and edit images by correcting color, editing photos by hand, and even combining several photos to create interesting and unique effects. Alternatively, you can use Photoshop as a painting program, where you can artistically create images and graphics. Photoshop even includes a file browser that lets you easily manage your images by assigning keywords or allowing you to search the images based on metadata.

				Photoshop allows you to create complex text layouts by placing text along a path or within shapes. You can edit the text after it has been placed along a path; you can even edit the text in other programs, such as Illustrator CS6. Join text and images into unique designs or page layouts.

				Sharing images from Photoshop is easy to do. You can share multiple images in a PDF file, create an attractive photo gallery for the web with a few clicks of the mouse, or upload images to an online photo service. You can preview multiple filters (effects) at once without having to apply each filter separately. Photoshop CS6 also supports various artistic brush styles, such as wet and dry brush effects and charcoal and pastel effects. Photoshop also has some great features for scanning. You can scan multiple images at a time, and Photoshop can straighten each photo and save it as an individual file.

				It’s hard to believe that Photoshop can be improved on, but Adobe has done it again in Adobe Photoshop CS6. Book IV shows you the diverse capabilities of Photoshop. From drawing and painting to image color correction, Photoshop has many uses for print and web design alike.

				Working with Acrobat X

				Acrobat X Professional is aimed at both business and creative professionals and provides an incredibly useful way of sharing, securing, and reviewing the documents you create in your Design Premium Suite applications.

				Portable Document Format (PDF) is the file format used by Adobe Acrobat. It’s used primarily as an independent method for sharing files. This format allows users who create files on either Macintosh or PC systems to share files with each other and with users of handheld devices or Unix computers. PDF files generally start out as other documents — whether from a word processor or a sophisticated page layout and design program.

				Although PDF files can be read on many different computer systems using the free Adobe Reader, users with the Professional or Standard version of Adobe Acrobat can do much more with PDF files. With your version of Acrobat, you can create PDF documents, add security to them, use review and commenting tools, edit documents, and build PDF forms.

				Use Acrobat to perform any of the following tasks:

				[image: check.png] Create interactive forms that can be filled out online.

				[image: check.png] Allow users to embed comments within the PDF files to provide feedback. Comments can then be compiled from multiple reviewers and viewed in a single summary.

				[image: check.png] Create PDF files that can include MP3 audio, video, SWF, and even  3D files.

				[image: check.png] Combine multiple files into a single PDF and include headers and footers as well as watermarks.

				[image: check.png] Create secure documents with encryption.

				[image: check.png] Take advantage of an intuitive user interface. You can now complete tasks faster with a streamlined user interface, new customizable toolbars, and a Getting Started page to visually direct you to commonly used features. In other words, you get an interface more in line with what you may see in the rest of the Creative Suite products.

				[image: check.png] Combine multiple files into a searchable, sortable PDF package that maintains the individual security settings and digital signatures of each included PDF document.

				[image: check.png] Use auto-recognize to automatically locate form fields in static PDF documents and convert them to interactive fields that can be filled electronically by anyone using Adobe Reader software. 

				[image: check.png] Manage shared reviews — without IT assistance — to allow review  participants to see one another’s comments and track the status of  the review. Shared reviews are possible through Acrobat Connect,  formerly Breeze.

				[image: check.png] Enable advanced features in Adobe Reader to enable anyone using free Adobe Reader software to participate in document reviews, fill and save electronic forms offline, and digitally sign documents.

				[image: check.png] Permanently remove metadata, hidden layers, and other concealed information and use redaction tools to permanently delete sensitive text, illustrations, or other content.

				[image: check.png] Save your PDF to Microsoft Word. This feature is a treasure! You can take advantage of improved functionality for saving Adobe PDF files  as Microsoft Word documents, retaining the layout, fonts, formatting, and tables.

				[image: check.png] Enjoy improved performance and support for AutoCAD. Using AutoCAD, you can now more rapidly convert AutoCAD drawing files into compact, accurate PDF documents, without the need for the native desktop  application.

				Want to discover other great Acrobat improvements? Read Book V to find out all about Acrobat and PDF creation.

				Introducing Dreamweaver CS6

				Dreamweaver CS6 is used to create professional websites quickly and efficiently, without the need to know or understand HTML (HyperText Markup Language). You can work with a visual authoring workspace (commonly known as Design view), or you can work in an environment where you work with the code. Dreamweaver enables you to set up entire websites of multiple pages on your hard drive, test them, and then upload them to a web server. With the Dreamweaver integration capabilities, you can create pages easily that contain imagery from Adobe Illustrator, Photoshop, and Flash.

				Dreamweaver also has built-in support for CSS (Cascading Style Sheets), a language that allows you to format your web pages and control text attributes, such as color, size, and style of text. CSS gives you control over the layout of the elements on your web pages.

				Go to Book VI to find out how to use Dreamweaver CS6 to create exciting websites that include text, images, and multimedia. Read Book VI, Chapter 1 to discover all the new features in Dreamweaver, including an improved interface, faster CSS integration, and improved features that will help you develop for mobile and html5.

				Welcoming You to Fireworks CS6

				In the Design Premium suite, you have a tool for creating web graphics. Fireworks is a much needed tool in the Creative Suite package because it offers features that were available in ImageReady in the CS2 suite.

				You may wonder why Fireworks is included in the Design Premium suite when it already includes two other image editing programs, Photoshop and Illustrator. Among other things, Fireworks is useful for mocking up web page designs, making it quick and easy to design a web page layout and web applications. Fireworks also enables you to edit both bitmap and vector images.

				Use Fireworks to

				[image: check.png] Compare file formats before exporting web graphics.

				[image: check.png] Create animations, rollovers, and pop-up windows.

				[image: check.png] Create sliced images that use HTML tables or CSS (Cascading Style Sheets).

				[image: check.png] Make wireframes or mock up a website using the template and pages features.

				Find out more in Book VIII about the helpful web creation tools in Fireworks.

				Crossing the Adobe Bridge

				Adobe Bridge is truly an incredible application, especially with the CS6 release, because the processing speed is greatly improved and new features are available, including the ability to take advantage of the new Mini Bridge in several of the CS6 applications, such as Photoshop and InDesign.

				Mini Bridge works much like the full launch of Adobe Bridge, but it stays present like a panel, allowing you to quickly and easily access your files at any time.

				You can find out more about Adobe Bridge and Mini Bridge in Chapter 5 of this minibook.

				Integrating Software

				With so many great pieces of software in a single package, it’s only natural that you’ll want to start using the programs together to build exciting projects. You may want to design a book using InDesign (with photos edited in Photoshop and drawings created in Illustrator) and then create a website for that content in Dreamweaver. Similarly, you may want to take a complex PDF file and make it into something that everyone can view online. Or you might create a symbol or Flash text in Illustrator and complete the animation in Flash. All tools in the Adobe Creative Suite are built to work together, and achieving these tasks suddenly becomes much easier to do because the products are integrated.

				Integrating software is typically advantageous to anyone. Integration allows you to streamline the workflow among programs and sometimes team members. Tools exist that let you drop native images into Dreamweaver, InDesign, Illustrator, and Flash. With Adobe Bridge, you can view files and investigate specific information about them, such as color mode and file size, before selecting them for placement.

				Acquiring Assets for this Book

				Many of the files that are referenced in this book are available right in the application sample folders that come with Creative Suite 6. The path locations are defined when they are referenced, making it easy to find and use them in the provided step-by-step examples. In addition to these sample files, you can find tips and tricks and more files for you to experiment with and investigate at www.agitraining.com/dummies.

				

			

			
		

	
		
			
				Chapter 2: Using Common  Menus and Commands

				In This Chapter

				[image: check.png] Discovering common menus and dialog boxes

				[image: check.png] Addressing CS6 alerts

				[image: check.png] Working with common menu options

				[image: check.png] Understanding contextual menus

				[image: check.png] Speeding up your workflow with shortcuts

				[image: check.png] Changing preferences

				When you work with Adobe Creative Suite 6 Design Premium, you may notice that many menus, commands, and options are similar across its various programs. Discovering how to use menus and dialog boxes is essential to using the programs in the Creative Suite.

				You may already be familiar with using dialog boxes and menus from other software packages. The way you use these elements is much the same for any program. Some specific keyboard shortcuts are the same across programs, even ones made by different software companies. This consistency makes finding out how to use the commands and options easy. This chapter provides an overview of some of the common menus, dialog boxes, options, commands, and preferences that exist in most or all of the programs in Adobe CS6 Design Premium.

				Discovering Common Menus

				When you work with programs in Adobe CS6 Design Premium, you probably notice that many of the menus on the main menu bar are the same. And then you probably see that these menus often contain many of the same commands across each program. These menus are somewhat similar to other graphics programs you may have used. Similar functionality makes finding certain commands easy, even when you’re completely new to the software you’re using.

				Menus contain options and commands that control particular parts or functions of each program. You may have the option of opening a dialog box, which is used to enter settings or preferences or to add something to a document. A menu may also contain commands that perform a particular action. For example, you may save the file as a result of selecting a particular command in a menu. Menus that commonly appear in the CS6 programs are described in this list:

				[image: check.png] File: Contains many commands that control the overall document, such as creating, opening, saving, printing, and setting general properties for the document. The File menu may also include options for importing or exporting data into or from the current document.

				[image: check.png] Edit: Contains options and commands for editing the current document. Commands include copying, pasting, and selecting as well as options for opening preferences and setting dialog boxes that are used to control parts of the document. Commands for spell-checking and transforming objects are also common parts of the Edit menu.

				[image: check.png] View: Contains options for changing the level of magnification of the document. The View menu also sometimes includes options for viewing the workspace in different ways, showing rules, grids, or guides, and turning snapping on and off. Snapping helps with precise placement of selection edges, cropping marquees, slices, shapes, and paths

				[image: check.png] Window: Contains options primarily used to open or close whatever panels are available in the program. You can also choose how to view the workspace and save a favorite arrangement of the workspace.

				[image: check.png] Help: Contains the option to open the Help documentation that’s included with the program. This menu may also include information about updating the software, registration, and tutorials.

				Adobe Design Premium on the Mac has an additional menu that bears the name of the program itself. This menu includes options for showing or hiding the program on the screen, setting preferences, and opening documents that provide information about the software.

				Figure 2-1 shows a menu in Photoshop that contains many common options to control the program.

				Notice that more menus are available in the programs than are in the previous list. Each program has additional program-specific menus determined by the needs of whichever software you’re using. For example, you can use the Photoshop Image menu to resize the image or document, rotate the canvas, and duplicate the image, among other functions. InDesign has a Layout menu you can use to navigate the document, edit page numbering, and access controls for creating and editing the document’s table of contents. Which additional menus exist in each program is determined by what the software is designed to do; we discuss these menus where appropriate throughout this book.

					

				
					Figure 2-1: Menus in Photoshop let you choose and control different options.

				

					[image: 9781118168608-fg010201.tif]

				Using Dialog Boxes

				A dialog box is a window that contains a combination of options formatted as drop-down lists, panes, text fields, option buttons, check boxes, and buttons that enable you to change settings and enter information or data as necessary. You use dialog boxes to control the software or your document in various ways. For example, when you open a new file, you typically use the Open dialog box to select a file to open. When you save a file, you use the Save As dialog box to select a location for saving the file, to name the file, and to execute the Save command.

				Some dialog boxes also include tabs. These dialog boxes may need to contain many settings of different types that are organized into several sections by using tabs. A dialog box typically has a button that executes the particular command and one that cancels and closes the dialog box without doing anything. Figure 2-2 shows a common dialog box.

				A dialog box in Windows is a lot like a dialog box you find on the Mac. Dialog boxes perform similar tasks and include the same elements to enter or select information. For example, here are some tasks you perform by using dialog boxes:

				[image: check.png] Save a new version of a file.

				[image: check.png] Specify printing or page-setup options.

				[image: check.png] Set up preferences for the software you’re using.

				[image: check.png] Check the spelling of text in a document.

				[image: check.png] Open a new document.

				[image: remember.eps]	You can’t use the program you’re working with until the dialog box is closed. When you have a dialog box open in the program you’re using, the window pops up on the screen. Before you can begin working with the program again, you have to close the dialog box. You can close it by making your choices and clicking a button (such as Save or OK) when you’re finished or by clicking the Cancel button to close it without making any changes.

					

				
					Figure 2-2: Using a dialog box to change filter settings.

				

					[image: 9781118168608-fg010202.eps]

				Encountering Alerts

				Alerts, which are common on any operating system and in most programs, are similar to dialog boxes in that they’re small windows that contain information. However, alerts are different from dialog boxes because you can’t edit the information in them. Alerts are designed simply to tell you something and give you one or more options that you select by clicking a button. For example, an alert may indicate that you can’t select a particular option. Usually you see an OK button to click to acknowledge and close the alert. You may see other buttons on the alert, such as a button to cancel what you were doing or one that opens a dialog box. Figure 2-3 shows a typical alert.

					

				
					Figure 2-3: A simple choice: OK or cancel.

				

					[image: 9781118168608-fg010203.eps]

				[image: tip.eps]	You can sometimes use an alert to confirm an action before executing it. Sometimes an alert window also offers the option (typically in the form of a check box) of not showing the alert or warning again. You may want to select this option if you repeatedly perform an action that shows the warning and you don’t need to see the warning every time.

				Getting to Know Common Menu Options

				Various menu options are typically available in each of the CS6 Design Premium programs. However, within each of these menus, several other options are available. Some of them open dialog boxes — this type of option is typically indicated by an ellipsis that follows the menu option, as shown in Figure 2-4.

					

				
					Figure 2-4: Choosing a menu option with an ellipsis opens a dialog box.

				

					[image: 9781118168608-fg010204.tif]

				The following menu options are found in several CS6 programs, and these commands either perform similar (or the same) functions or they open similar dialog boxes:

				[image: check.png] New: Creates a brand-new document in the native file format. For example, in InDesign, a new INDD (the extension for InDesign documents) file is created by choosing File⇒New⇒Document. You can sometimes choose the type of new file you want to create.

				[image: check.png] Open: Opens a dialog box where you can choose a (supported) file to open on your hard drive or a disk.

				[image: check.png] Close: Closes the current document. If it has unsaved changes, you’re prompted to save those changes first.

				[image: check.png] Save: Saves the changes you’ve made to the current document.

				[image: check.png] Save As: Saves a new copy of the current document.

				[image: check.png] Import: Imports a file, such as an image or sound file, into the current document.

				[image: check.png] Export: Exports the current data to a specified file format. You can sometimes select several kinds of file formats to save the current  data in.

				[image: check.png] Copy: Copies the selected data to the computer’s Clipboard.

				[image: check.png] Paste: Pastes the data from the Clipboard into the current document.

				[image: check.png] Undo: Undoes the most recent task you performed in the program. For example, if you just created a rectangle, the rectangle is removed from the document.

				[image: check.png] Redo: Repeats the steps you applied the Undo command to. For example, if you removed that rectangle you created, the Redo command adds it back to the document.

				[image: check.png] Zoom In: Magnifies the document so that you can view and edit its contents closely.

				[image: check.png] Zoom Out: Scales the view smaller so that you can see more of the document at a time.

				[image: check.png] Help: Opens the Help documentation for the current program.

				About Contextual Menus

				The contextual menu is an incredibly useful, quick way to make selections or issue commands, and it’s available in all kinds of programs. Contextual menus include some of the most useful commands you may find yourself choosing repeatedly.

				A contextual menu is similar to the menu types we describe in the previous sections; however, it’s context-sensitive and opens when you right-click (Windows) or Control-click (Mac) something in the program. Contextual means that which options appear on the menu depends on which object or item you right-click (Windows) or Control-click (Mac).

				For example, if you open a contextual menu when the cursor is over an image, commands involving the image are listed on the menu. However, if you right-click (Windows) or Control-click (Mac) the document’s background, you typically see options that affect the entire document instead of just a particular element within it. You can therefore select common commands specifically for the item you’ve selected. Figure 2-5 shows a contextual menu that appears when you right-click (Windows) or Control-click (Mac) an object in Photoshop.

				[image: remember.eps]	The tool you select in the Tools panel may affect which contextual menus you can access in a document. You may have to select the Selection tool first to access certain menus. If you want to open a contextual menu for a particular item in the document, make sure that the object is selected before you right-click (Windows) or Control-click (Mac).

				[image: tip.eps]	If you’re using a Mac, you can right-click to open a contextual menu if you have a two-button mouse hooked up to your Mac. Otherwise, you press Control-click to open a contextual menu.

					

				
					Figure 2-5: Open a contextual menu in Windows by right-clicking an image or object.

				

					[image: 9781118168608-fg010205.tif]

				Using Common Keyboard Shortcuts

				Shortcuts are key combinations that enable you to quickly and efficiently execute commands, such as save or open files or copy and paste objects. Many of these shortcuts are listed on the menus discussed in previous sections. If the menu option has a key combination listed next to it, you can press that combination to access the command rather than use the menu to select it. Figure 2-6 shows shortcuts associated with a menu item.

					

				
					Figure 2-6: Shortcuts are shown next to their associated commands.

				

					[image: 9781118168608-fg010206.eps]

				For example, if you open the File menu, next to the Save option is Ctrl+S (Windows) or [image: maccmd]+S (Mac). Rather than choose File⇒Save, you can press  the shortcut keys to save your file. It’s a quick way to execute a particular command.

				[image: tip.eps]	Some commonly used shortcuts in the Adobe Creative Suite 6 Design Premium programs are listed in Table 2-1.

				Table 2-1	Common Keyboard Shortcuts

				
					
						
								
								Command

							
								
								Windows Shortcut

							
								
								Mac Shortcut

							
						

						
								
								New

							
								
								Ctrl+N

							
								
								[image: maccmd]+N

							
						

						
								
								Open

							
								
								Ctrl+O

							
								
								[image: maccmd]+O

							
						

						
								
								Save

							
								
								Ctrl+S

							
								
								[image: maccmd]+S

							
						

						
						
								
								Undo

							
								
								Ctrl+Z

							
								
								[image: maccmd]+Z

							
						

						
								
								Redo

							
								
								Shift+Ctrl+Z

							
								
								Shift+[image: maccmd]+Z

							
						

						
								
								Copy

							
								
								Ctrl+C

							
								
								[image: maccmd]+C

							
						

						
								
								Paste

							
								
								Ctrl+V

							
								
								[image: maccmd]+V

							
						

						
								
								Print

							
								
								Ctrl+P

							
								
								[image: maccmd]+P

							
						

						
								
								Preferences (General)

							
								
								Ctrl+K

							
								
								[image: maccmd]+K

							
						

						
								
								Help

							
								
								F1 or sometimes Ctrl+?

							
								
								F1 or sometimes [image: maccmd]+?

							
						

					
				

				Many additional shortcuts are available in each program in the CS6 programs, and not all are listed on menus. You can find these shortcuts throughout the documentation provided with each program. Memorizing  the shortcuts can take some time, but the time you save in the long run is worth it.

				Changing Your Preferences

				Setting your preferences is important when you’re working with new software. Understanding what your preferences can do for you gives you a good idea about what the software does. All programs in the Design Premium Suite have different preferences; however, the way the Preferences dialog box works in each program is the same.

				You can open the Preferences dialog box in each program by choosing Edit⇒Preferences (Windows) or Program Name⇒Preferences⇒General (Mac). The Preferences dialog box opens, as shown in Figure 2-7. Click an item in the list on the left side of the dialog box to navigate from one topic to the next.

					

				
					Figure 2-7: Click an item on the left to navigate among topics.

				

					[image: 9781118168608-fg010207.eps]

				The Preferences dialog box contains a great number of settings you can control by entering values into text fields using drop-down lists, buttons, check boxes, sliders, and other, similar controls. Preferences can be quite detailed. However, you don’t have to know what each preference does or even change any of them: Most dialog boxes containing preferences are quite detailed in outlining which features the preferences control and are therefore intuitive to use. Adobe also sometimes includes a Description area near the bottom of the dialog box. When you hover the mouse over a particular control, a description of that control appears in the Description area.

				In some Preferences dialog boxes, a list box on the left side of the dialog box contains the categories of preferences you can change. When you finish changing the settings in that topic, select a new topic from the list and change the settings for another topic.

				In some programs, not all settings you can modify are in the Preferences dialog box. For example, in Illustrator, you can change the color settings by choosing Edit⇒Color Settings to open the Color Settings dialog box. When you hover the mouse pointer over a particular drop-down list or button, a description of that control appears at the bottom of this extremely useful dialog box.

				[image: tip.eps]	By launching Adobe Bridge (described in Chapter 5 of this minibook) and choosing Edit⇒Creative Suite Color Settings, you can change your color  preferences across all Design Premium programs at one time, as shown in Figure 2-8.

					

				
					Figure 2-8: Change all color settings at one time using Adobe Bridge.

				

					[image: 9781118168608-fg010208.eps]

				In many CS6 programs, you have the option to specify your main preferences for the overall document, such as setting up page dimensions, number of pages in the document, or page orientation (landscape or portrait). You can access these kinds of options by choosing the following command in each program:

				[image: check.png] File⇒New: Dreamweaver

				[image: check.png] File⇒Document Setup: Illustrator and InDesign

				[image: check.png] Image⇒Image Size: Photoshop

				Figure 2-9 shows the Image Size dialog box.

					

				
					Figure 2-9: The Image Size dialog box.

				

					[image: 9781118168608-fg010209.eps]

				

				

				

			

			
		

	
		
			
				Chapter 3: Exploring  Common Panels

				In This Chapter

				[image: check.png] Exploring the synchronized workspace

				[image: check.png] Manipulating panels in the workspace

				[image: check.png] Discovering different kinds of panels

				[image: check.png] Getting to know the common panels in Adobe CS6

				The panel is an integral part of working with most of the programs in Adobe Creative Suite 6 (CS6) because it contains many of the controls and tools you use when you’re creating or editing a document.

				The basic functionality of panels is quite similar across the programs in Adobe Creative Suite, and the purpose of all panels is the same. Panels offer a great deal of flexibility in how you organize the workspace and the parts of it you use. The task you use each program for and the level of expertise you have may affect which panels you have open at a given moment. This chapter gives you an overview of how to work with the panels you find in Adobe CS6.

				Understanding the Synchronized Workspace

				One thing you immediately notice when opening applications in the Creative Suite is the synchronized workspace. All the applications look similar and have the same set of features to help you organize your workspace.

				The tools in InDesign, Illustrator, and Photoshop appear on a space-saving, single-column toolbar, and panels (described in detail in the next section) are arranged in convenient, self-adjusting docks that you can widen to full size or narrow so that the panels are collapsed to icons.

				Here are some pointers to help you navigate the workspace in the Creative Suite applications:

				[image: check.png] To expand tools to two columns, click the right-facing double arrows on the gray bar at the top of the Tools panel, as you see in Figure 3-1

				[image: check.png] To collapse tools to a single column, click the left-facing double arrows on the gray bar at the top of the Tools panel.

				[image: check.png] To expand a docked panel, simply click the icon in the docking area, as shown in Figure 3-2. The panel you selected expands but goes away when you select a different panel.

						If you have difficulty identifying the panel, you can choose the panel you want from the Window menu.

				[image: check.png] To expand all docked panels, click the left-facing double-arrow icon at the top of the docking area; put away the panels by clicking the right-facing double-arrow icon in the gray bar above them.

				[image: check.png] To undock a panel, simply click the tab (where the panel name is located) and drag it out of the docking area. You can re-dock the panel by dragging the panel back into the docking area.

					

				
					Figure 3-1: Click the arrows at the top of the Tools panel to show tools in two columns or one column.

				

					[image: 9781118168608-fg010301.tif]

					

				
					Figure 3-2:  Click an icon to collapse or expand the panel.

				

					[image: 9781118168608-fg010302.eps]

				Using Panels in the Workspace

				Panels are small windows in a program that contain controls, such as sliders, menus, buttons, and text fields, that you can use to change the settings or attributes of a selection or an entire document. Panels may also include information about a section or about the document itself. You can use this information or change the settings in a panel to modify the selected object or the document you’re working on.

				Whether you’re working on a Windows machine or on a Mac, panels are similar in the way they look and work. Here are the basic instructions for working with panels:

				[image: check.png] Open a panel: Open a panel in a Creative Suite program by using the Window menu: Choose Window and then select the name of a panel. For example, to open the Swatches panel (which is similar in many programs in the suite), choose Window⇒Swatches.

				[image: check.png] Close a panel: If you need to open or close a panel’s tab or panel altogether, just choose Window⇒Panel’s Tab Name. Sometimes a panel  contains a close button (an X button in Windows or the red button on  a Mac), which you can click to close the panel.

				[image: check.png] Organize the workspace: All Creative Suite programs now offer options for workspace organization. You can return to the default workspace, which restores panels to their original locations, by choosing Window⇒Workspace⇒Default. You can also open frequently used panels, position them where you want, and save a customized workspace by choosing Window⇒Workspace⇒Save (or New) Workspace. Name the workspace and click OK; the saved workspace is now a menu item that you can open by choosing Window⇒Workspace⇒Your Saved Workspace’s Name.

				[image: tip.eps]		You can also choose from a wide range of included presets designed for a variety of specialized tasks.

				[image: check.png] Access the panel menu: Panels have a panel menu, which opens when you click the arrow in the upper-right corner of the panel, as shown in Figure 3-3. The panel menu contains a bunch of options you can select that relate to the selected tab when you click the panel menu. When you select an option from the panel menu, it may execute an action or open a dialog box. Sometimes a panel menu has just a few options, but particular panels may have a bunch of related functionality and therefore have many options on the panel menu.

				[image: check.png] Minimize/maximize: All you need to do to minimize a selected panel  is click the Collapse to Icons double-arrow button on the title bar of  the panel (if it’s available). If the panel is undocked, you can also  double-click the tab itself in the panel. This action either partially or fully minimizes the panel. If it only partially minimizes, double-clicking the tab again fully minimizes it. Double-clicking the active tab when it’s minimized maximizes the panel again.

						Panels that partially minimize give you the opportunity to work with panels that have differing amounts of information, which simplifies the workspace while maximizing your screen real estate.

					

				
					Figure 3-3: Displaying the panel menu.

				

					[image: 9781118168608-fg010303.tif]

				Most panels contain tabs, which help you organize information and controls in a program into groupings. Panel tabs contain a particular kind of information about a part of the program; a single panel may contain several tabs. The name on the tab usually gives you a hint about the type of function it controls or displays information about, and it’s located at the top of the panel. Inactive tabs are dimmed.

				Moving panels

				You can move panels all around the workspace, and you can add or remove single tabs from a panel. Each panel snaps to other panels, which makes it easier to arrange panels alongside each other. Panels can overlap each other as well. To snap panels to each other, drag the panel to a new location onscreen, as shown in Figure 3-4; you see the top bar of the panel become shaded, indicating that it’s becoming part of another panel’s group.

					

				
					Figure 3-4: To move a panel, drag it by its tab.

				

					[image: 9781118168608-fg010304.eps]

				[image: tip.eps]	Group similar tabs by moving them into a single grouped panel. Accessing different functions in your document becomes a lot easier because then you have less searching to do to find related functions for a task. If you want to return to the original workspace, you can choose Reset Workspace from the Window menu in the Workspace category.

				[image: tip.eps]	You can hide all panels by pressing the Tab key. Press it again to reveal all panels you’ve hidden.

				Looking at common panels

				Many panels are similar across programs in the Creative Suite. Although not every panel has exactly the same content in every program it’s in, many have extremely similar content. You use these panels in similar ways, no matter which program or operating system you’re using.

				[image: remember.eps]	Acrobat doesn’t contain numerous panels, like other programs in the Creative Suite. Instead, Acrobat relies mainly (but not entirely) on a system of menus and toolbars filled with buttons and drop-down lists. In Acrobat, you can open dialog boxes that contain a bunch of settings you can enter for your documents.

				The following panels are available in most, but not all, Creative Suite programs. This list describes what you can do with each one:

				[image: check.png] Color: Select or mix colors for use in the document you’re working on. You can use different color modes and several ways of mixing or choosing colors in the Colors panel.

				[image: check.png] Info: See information about the document itself or a particular selection you’ve made. The Info panel includes information on the size, positioning, and rotation of selected objects. You can’t enter data into the Info panel: It only displays information without accepting it, so you have to use the Transform panel (described in this list) to make these modifications, if necessary.

				[image: check.png] Swatches: Create a swatch library, which can be saved and imported into other documents or other programs. You can store on the Swatches panel any colors and gradients you use repeatedly. 

				[image: check.png] Tools: You use this important panel, sometimes called the toolbox (and not available in all Creative Suite programs), to select tools — such as the Pencil, Brush, or Pen — to use in creating objects in a document.

				[image: check.png] Layers: Display and select layers, change the layer order, and select items on a particular layer.

				[image: check.png] Align: Align selected objects to each other or align them in relation to the document itself so that you can arrange objects precisely.

				[image: check.png] Stroke: Select strokes and change their attributes, such as color, width/weight, style, and cap. The program you’re using determines which attributes you can change.

				[image: check.png] Transform: Display and change the shear (skew), rotation, position, and size of a selected object in the document. You can enter new values for each transformation.

				[image: check.png] Character: Select fonts, font size, character spacing, and other settings related to using type in your documents.

				

			

		

	
		
			
				Chapter 4: Using Common Extensions and Filters

				In This Chapter

				[image: check.png] Discovering the real purpose of filters and extensions

				[image: check.png] Using common extensions and filters in Adobe CS6

				Extensions, also known as plug-ins, are pieces of software installed or saved on your computer that work as add-ons to existing programs. For example, you may be able to use an extension to integrate with a different program, help add usefulness to a program (such as the ability to create 3D text), change the appearance of an object in your software, or add a 3D effect to a video file. You can use filters to change parts of a document. Even if you haven’t used Photoshop, you’re probably already familiar with some popular Photoshop filters, such as Watercolor and Emboss, used for artistic effects. This chapter shows you common plug-ins, extensions, and filters, as well as how to use them in the Creative Suite.

				Looking at Common Extensions and Filters

				Extensions are sometimes used for similar tasks in several programs and are designed to enhance a program’s existing capabilities. Extensions and filters can also dramatically speed up the creative process. At the mere click of a button, you can add to your project an amazing effect that may have taken many hours to accomplish without the plug-in.

				Additional filters and plug-ins for the programs are available or linked from the Adobe website. You can also easily find plug-ins for downloading from the web. A search yields many results for these packages. A good place  to start is at the Adobe Marketplace & Exchange: www.adobe.com/ cfusion/exchange. You can then download and install a wealth of  tools for all Creative Suite applications.

				[image: tip.eps]	The Photoshop filter is probably the most common type of add-on you find online. Some filters you have to purchase before downloading and using them; however, some are free.

				Installing extensions

				You can install extensions in a few different ways. Sometimes you use an executable file: Double-click the file on your hard drive, and it automatically installs the software. This process is a lot like installing any other program on your computer, such as the programs in the Creative Suite itself.

				Sometimes individual files need to be placed in a folder first. In that case, you need to find the Plug-Ins folder on your computer in the install directory of the program the plug-in or filter works with. For example, if your plug-in works with InDesign on Windows, you have to find the directory C:\Program Files\Adobe\InDesign CS6\Plug-Ins. You then copy and paste or move the files you downloaded into this directory on your hard drive. If your plug-in works with Photoshop on the Mac, find this folder on your hard drive: Applications\Adobe Photoshop CS6\Plug-Ins. Then copy and paste or move the files into the folder.

				You can also take advantage of the Adobe Extension Manager CS6 application, installed automatically with the default CS6 installation. Locate Extension Manager in your Programs (Windows) or Applications (Mac) folder and double-click to launch it. Select the application for which you want to install the extension, click the Install button to locate the extension you want to install, and click the Select button —  you’re on your way!

				If you’re unsure how to install a plug-in, locate instructions for the software that explain how to install the plug-in on your computer. You can find instructions on the manufacturer’s website or bundled with the plug-in file in a text file (usually named readme.txt).



				Plugging into InDesign

				There are many plug-ins available in InDesign that allow you to extend the feature set that already exists. Here are some of the things you can do with additional plug-ins in InDesign:

				[image: check.png] Lay out spreads correctly for a printer.

				[image: check.png] Create sophisticated indexes and tables of contents.

				[image: check.png] Create advanced cross references within your documents.

				[image: check.png] Create page previews and thumbnails of your documents.

				Other filters created for InDesign can help import certain content, such as text. Text formatting often gets lost when you import content into InDesign. Filters can help you retain this original formatting when you’re importing text. These plug-ins and filters are just a small sample of what’s available for InDesign. In all likelihood, developers will create many more plug-ins for the software.

				Adding on to Photoshop

				Photoshop has many preinstalled plug-ins and filters that increase the program’s functionality. You can find additional filters and also plug-ins to add new features that inevitably add interesting effects to your documents. One plug-in, for example, installs a number of filters in Photoshop. By using the filters and plug-ins you find for Photoshop, you can

				[image: check.png] Remove blemishes and scratches from photos using special tools.

				[image: check.png] Create 3D text, objects, and effects by using several different plug-ins. Effects include more realistic drop shadows, bevels, and embossments than the ones already available in Photoshop.

				[image: check.png] Use special masking tools to create amazing selections of difficult items such as fur and hair.

				[image: check.png] Use one of thousands of special effects (made by many companies) to enhance and modify images.

				[image: check.png] Add a frame from a library to place around favorite images.

				This list describes only some of the tasks you can perform using the available Photoshop plug-ins, which commonly comprise a set of numerous bundled filters.

				Many plug-ins have custom interfaces you can use to specify settings, including sliders, text fields, and buttons and usually a thumbnail preview of how the filter is affecting the image. These interfaces vary greatly in style and number of features but are usually fairly intuitive and easy to use.

				Using Illustrator plug-ins

				You can find many tools to extend the capabilities of Illustrator. Plug-ins are available that enable you to take 3D illustration further than standard 3D features allow. You can create forms from drawings and also turn 3D files into line drawings. Other plug-ins, ranging from simple to quite complex, let you

				[image: check.png] Organize font sets.

				[image: check.png] Add common symbols, such as road signage, to use in documents. Symbols are organized into libraries that you can use directly in the Illustrator workspace.

				[image: check.png] Import computer-aided design (CAD) files into documents.

				[image: check.png] Create interactive documents.

				[image: check.png] Handle patterns geared toward creating textures and backgrounds.

				You can enhance Illustrator capabilities after you download and install a few plug-ins. Simple projects become much more interesting or complex when you merely enter a value and click a button.

				[image: tip.eps]	A fun item to download and install into Illustrator is a custom brush. You can then have a wider array of brushes to work with when you create drawings and illustrations. Styles, usually obtained for free, are also available for you to install in Illustrator. You can even download and install custom brushes for Photoshop.

				Adding capabilities to Acrobat

				Several Acrobat plug-ins help speed and diversify project workflow. Some available plug-ins are designed to help you

				[image: check.png] Add new stamps to documents.

				[image: check.png] Add features such as page numbering and watermarks.

				[image: check.png] Streamline productivity by offering solutions for batch processing.

				[image: check.png] Convert file formats to diversify the kinds of documents you can create in Acrobat.

				[image: check.png] Work with and fix — quickly and efficiently — the Portable Document Format (PDF) in prepress.

				Many plug-ins available for Acrobat enable you to batch-process (all at one time) the pages in a document. Many plug-ins for Acrobat help save lots of time when you’re creating PDF files. Plug-ins are usually designed to be easy to use and can thus save you from having to perform a tedious and repetitive task.

				Plug-ins for Acrobat are available from the Adobe website and from numerous third-party websites.

				Extending Dreamweaver

				Dreamweaver offers you a quick and easy way to make web pages, but you can add more tools to Dreamweaver to diversify the types of tasks the program can do. These extensions (essentially, plug-ins) also speed the process of creating websites. Some available Dreamweaver plug-ins let you

				[image: check.png] Add e-commerce modules to a website automatically.

				[image: check.png] Create professional vertical and horizontal menus by using DHTML (Dynamic HTML) and CSS (Cascading Style Sheets).

				[image: check.png] Add a calendar pop-up.

				[image: check.png] Add PayPal to your website.

				Using Filters and Plug-Ins

				You can install plug-ins and filters in your Creative Suite programs. For example, a filter can enhance an existing photo in an exciting way. After you install into Photoshop or Illustrator a plug-in that includes a bunch of additional filters, check out what the filter can do to your photos.

				Install some filters for Photoshop (or Illustrator or any other program in the suite). After you complete the installation and restart your computer, if necessary, open Photoshop and locate the Filter menu option. (New filters are available on this menu.)

				To use a filter or plug-in after installing it, follow these steps:

					1.	Open a file in the appropriate program so that you can try your new filter or plug-in.

						For example, if you downloaded a Photoshop plug-in that added a new filter, open an interesting photo that you want to apply an effect to in Photoshop. Choose a photo that has many colors or a lot of contrast to work with.

					2.	Choose a filter from the Filter menu.

						Select a filter that you installed from the Filter menu. You may also find that a plug-in created a new menu item in the program — in that case, use the new menu item to apply the effect.

					3.	Modify the filter’s (or plug-in’s) settings, if necessary, and click OK to apply the effect.

						Sometimes you see a thumbnail preview to assess how the filter changes the image. For some filters and plug-ins, you even use a custom interface to manipulate the document. You can then change the settings accordingly until you’re happy with the modifications to be applied.

					4.	Look at the image or document after you choose and apply the filter or plug-in.

						Your image or file is updated immediately. If you’re unhappy with the results, you can either undo your changes by choosing Edit⇒Undo or reapply the filter or plug-in.

				[image: warning_bomb.eps]	Though filters add a great deal of interest and variety to documents, you can easily suffer from filter overload when using them. You can use filters in many different ways in the Design Premium suite, and some ways (and even the filters themselves) are considered better than others. Experiment freely with filters — just make sure that you don’t use too many on one part of an image when you’re creating a final project. For example, if you bevel and emboss a particular letter in a few different ways, that character can become illegible. Similarly, adding a huge drop shadow can distract the eye from other parts of the text.

				[image: tip.eps]	Know what you intend to accomplish with your document before you start creating it. If you set out to create a project with a particular design in mind, you can sometimes achieve better results. Try drawing your ideas on paper first, writing down notes about the effect you want to achieve, and thinking about the plug-ins you want to use to create it. Use one filter at a time, and make sure that you like the results before moving on. The alternative is to continue adding filters to achieve a particular result when you aren’t quite sure which effect you’re after or how to create it.

				Plug-ins that help you create graphics for HTML5

				So what is HTML5 and what is all the hype about? HTML5 is the fifth revision of the HTML standard (created in 1990), and it’s still under development. The core aim of HTML5 is to improve the language with support for the latest multimedia, such as videos and animation while keeping the language easily read by humans and devices, such as your computer or phone.

				HTML5 Pack

				Adobe offers Adobe Illustrator and Dreamweaver HTML5 Packs to provide support for HTML5 and CSS3, extends SVG capability in Adobe Illustrator CS6, and helps you design content for HTML5. The extension provides support for a set of currently implemented HTML5 features. Locate these HTML5 packs on www.adobelabs.com, or by following the URL http://labs.adobe.com/technologies/illustrator_html5 for Adobe Illustrator, and http://labs.adobe.com/downloads/html5pack.html for Dreamweaver. Instructions as to where to place the plug-ins are online.

				AI2 Canvas

				Another plug in that does a great job converting Adobe Illustrator files to HTML5 is the AI2Canvas plug-in. You can find this extension at http://visitmix.com/work/ai2canvas.

				The AI2Canvas plug-in enables Adobe Illustrator to export vector and bitmap artwork directly into an HTML5 canvas.

				A canvas element is a drawable region defined in HTML code with height and width attributes. Using JavaScript, a developer can access that region through a full set of drawing functions, allowing them to use the canvas to create animations, games, and more.

				Using the AI2Canvas plug-in you can create animations in which your vector objects follow a path, rotate, and fade, among other things. By extending the HTML and JavaScript code created with the AI2canvas plug-in, you can also trigger events to your animations to take your artwork beyond the basics. 

				Understand that layers will be exported to JavaScript functions, so make sure that you name your layers with clean descriptive names. After you create your graphics, you can choose File⇒Export and select Canvas. Find more information about naming and organizing Illustrator documents in Book III, Chapter 7.

				

			

			
		

	
		
			
				Chapter 5: Importing  and Exporting

				In This Chapter

				[image: check.png] Integrating Adobe Bridge into your workflow

				[image: check.png] Importing content

				[image: check.png] Moving files from one CS6 application to another

				[image: check.png] Exporting content out of your documents

				[image: check.png] Exporting content from CS6 programs

				Because the Creative Suite is such an integrated tool, you’ll almost always be in the process of cutting, pasting, importing and exporting content from one application to another.

				Content that you might import and export include images, text, word files, 3D objects, and more. You may find that you need to go through the process of exporting files in order for them to be recognized by other applications. Non-Adobe applications will even recognize your files from the Creative Suite applications if you save them in the right format. In this chapter, you find out how to get your files in and out of your various applications, starting with a separate application that comes with the Creative Suite, named Adobe Bridge.

				Discovering the Adobe Bridge Application

				The Adobe Bridge application helps you organize and manage your assets, such as pictures, text, and movie and audio files, as well as non-Adobe applications such as Word or Excel files. Adobe Bridge acts like a hub for the Creative Suite; for example, by choosing to open files using the Bridge interface, you can browse directories quickly and see thumbnail previews of files, as shown in Figure 5-1. You can even use the Filter panel to help find files and view metadata to your file, including important information such as keywords and copyright details.

					

				
					Figure 5-1: The Adobe Bridge workspace.

				

					[image: 9781118168608-fg010501.eps]

				Bridge not only makes a great deal of information accessible, but it can also be used as a central resource for all your Help needs.

				[image: remember.eps]	If you installed the Adobe programs separately (not using the Creative Suite installer), the program on your machine may be lacking some features. If you notice that you don’t have access to features mentioned in this chapter, check to see whether all the CS6 applications are installed or run the CS6 installer again.

				Accessing the Bridge software

				Knowing where to locate the Adobe Bridge application is helpful. Bridge should already be in your system if you completed a standard installation of any product in the entire suite. If you don’t find Adobe Bridge installed, go back and choose to install it using your original installation media. After you install the Bridge software, you can open it in one of three ways:

				[image: check.png] Access the Bridge software with the directory system of your computer. Navigate to C:\Program Files\Adobe\Adobe Bridge CS6\Adobe Bridge CS6 (Windows) or Hard Drive\Applications\Adobe Bridge CS6\Adobe Bridge CS6 (Mac).

				[image: check.png] Depending upon the application, you can click the Go to Bridge button on the Application bar. (The Application bar in InDesign is shown in Figure 5-2.)

					

				
					Figure 5-2: To open Bridge, click the Go to Bridge button.

				

					[image: 9781118168608-fg010502.tif]

				[image: check.png] If you don’t see the Go to Bridge icon, you can choose File⇒Browse in Bridge. Launch into Bridge from any of the applications included in the Creative Suite.

				[image: check.png] In Photoshop, you can choose Window⇒Extensions⇒Mini Bridge to open the Mini Bridge panel across the bottom of the default Essentials workspace. Mini Bridge is essentially a miniature version of Adobe Bridge, as shown in Figure 5-3.

					

				
					Figure 5-3: Open the Mini Bridge application in Photoshop CS6.

				

					[image: 9781118168608-fg010503.eps]

				Navigating in Adobe Bridge

				To navigate Bridge, simply click on the Folders panel in the upper-left corner to choose the folder you want to view. Watch as previews are created and automatically replace the standard file format icon.

				[image: tip.eps]	Adobe Bridge may take a fair amount of time to build the preview the first time you use it, so be patient. Either choose Tools⇒Cache⇒Build and Export Cache to save this data or choose Tools⇒Cache⇒Purge Cache to free up  file space.

				Select an individual file by clicking it once (twice opens it) or select multiple files by Ctrl-clicking (Windows) or [image: maccmd]-clicking (Mac).

				With one or more files selected, you can

				[image: check.png] Relocate the files to another location by dragging them to a folder in the Folders panel in the upper-left corner. Use Bridge as a central filing system. Using the commands on the File menu, you can create new folders and delete or move files or groups of files.

				[image: check.png] Read metadata in the Metadata panel in the lower-right corner. The metadata includes important Camera Data (EXIF) information such as Camera, Flash, and F-stop. See Figure 5-4.

				[image: check.png] Enter your own metadata for any item listed by clicking the pencil icon, shown in Figure 5-5.

					

				
					Figure 5-4: Use the Metadata panel to find important information about your selected image.

				

					[image: 9781118168608-fg010504.tif]

					

				
					Figure 5-5: Look for the pencil icon to determine which metadata you can edit yourself.

				

					[image: 9781118168608-fg010505.tif]

				[image: check.png] Use the Keywords panel, shown in Figure 5-6, to enter your own keywords, which can help you find your images later.

				[image: check.png] Choose Edit⇒Find or use the Filter panel to locate your files within Bridge by entering criteria, such as Keywords, Description, Date Created, and more.

				[image: check.png] Create image stacks. You can select many files in Bridge by holding down the Ctrl key (Windows) or [image: maccmd] key (Mac) and clicking multiple files. You can then choose Stacks⇒Group as Stack or use the keyboard shortcut Ctrl+G (Windows) or [image: maccmd]+G (Mac). It stacks the images into one compact thumbnail, as shown in Figure 5-7.

						The number of images in the stack is shown in the upper-left corner of the image stack. To reopen the stack, click the stack number; to close the stack, click the stack number again. If you no longer want the stack, you can choose Stacks⇒Ungroup from Stack or use the keyboard shortcut Ctrl+Shift+G (Windows) or [image: maccmd]+Shift+G (Mac).

				[image: check.png] Check under the Tools menu for application-specific tools, such as Photomerge (merging panoramic images), Live Trace (tracing images as vector images), and PDF Presentation.

					

				
					Figure 5-6:  The Keywords panel can help you locate images.

				

					[image: 9781118168608-fg010506.tif]

					

				
					Figure 5-7:  Stack similar images to help keep files organized.

				

					[image: 9781118168608-fg010507.eps]

				Managing color

				Using Bridge for color management is a timesaver and a production boost! You can adjust color settings across the board in all Creative Suite applications right in Adobe Bridge. Create consistent color choices in all Creative Suite applications by using the synchronized color-management controls that Adobe Bridge offers.

				Choose Edit⇒Creative Suite Color Settings to choose a color management setting that remains consistent throughout all Creative Suite applications, as shown in Figure 5-8. Read more about color correction in Book IV, Chapter 7.

					

				
					Figure 5-8: Use color settings to synchronize color management policies in Adobe Bridge.

				

					[image: 9781118168608-fg010508.eps]

				[image: tip.eps]	The setting for Joe’s Press, shown in Figure 5-7, was created in Adobe Photoshop. If your printer can send you the Joe’s Press color settings, you can load them using the Suite Color Settings dialog box in Photoshop and then make them accessible to all your CS5 applications by selecting the settings in Adobe Bridge.

				Importing Files into a Document

				Importing files works similarly, no matter which program you’re working with. Importing content is more important in some programs than others. A program such as InDesign relies on importing content into a document that’s then incorporated into a page layout. However, in programs such as Photoshop, importing content is much less important because you frequently start out editing an image you open in Photoshop. In the following sections, we take a look at importing content into each program.

				Placing content in InDesign

				When working in InDesign, you need to import images and text for many of your design layouts. When you choose File⇒Place, you can select text or image files from your hard drive or network. You can also choose sound and video files that you can use when you’re creating PDF documents for electronic distribution. After you choose a file to import, a new cursor icon appears, with a thumbnail preview of your image. This preview shows up when you place the cursor over the page or pasteboard. Place the imported content by clicking on the page where you want the upper-left corner of the image to be positioned.

				When you import different kinds of images, you see the Place dialog box, in which you can select a variety of options for importing selected content. However, to access additional settings, you must select the Show Import Options check box in the Place dialog box. In Figure 5-9, you see the additional options that appear when an image is placed.

				Choose File⇒Place and select a file to import. Select the Show Import Options check box and click the Open button. The Image Import Options dialog box appears with options specific to the type of file you’re importing. For example, if you’re importing a bitmap image (say, a JPEG), you can choose how you want the bitmap to appear, whether it contains a background or color management information, and other, similar options.

				When you import text information, you may lose some text formatting that was made in the original file. Anything that InDesign doesn’t understand isn’t imported into the document. Column and margin information also typically aren’t retained when you import text. However, some plug-ins that are available help remedy the situation to some extent.

					

				
					Figure 5-9:  When importing text and graphics, you can see additional options.

				

					[image: 9781118168608-fg010509.eps]

				[image: tip.eps]	You can use the Launch Bridge button in the center of the Application bar in InDesign to open Adobe Bridge. Then simply drag and drop the images you want to use directly from Bridge.

				Adding content to a Photoshop file

				In Photoshop, you can choose to open an image to work with or import content into a document that’s open already. Choose File⇒Place to import AI, EPS, PDP, or PDF files. These files import into a new layer in the document, and you can then use tools to manipulate the imported content, as shown in Figure 5-10.

					

				
					Figure 5-10: Imported content is placed on a new layer.

				

					[image: 9781118168608-fg010510.tif]

				[image: tip.eps]	Your placed Illustrator file is embedded, by default, into the Photoshop file. (You can read about the Smart Object feature in Book IV, Chapter 9.) Double-click the placed artwork layer to open and edit the embedded Illustrator file. After you save the file, the changes are immediately reflected in Photoshop. Note that your original file isn’t changed.

				[image: tip.eps]	If you want to import images from your digital camera directly into Adobe Bridge, choose File⇒Get Photos from Camera.

				Placing files into Illustrator

				Illustrator lets you place images and other forms of data in a new document. You can import Photoshop, PDF, image, and vector files by choosing File⇒Place. The Place dialog box opens, and you can choose a file to import. Click Place to import the file. An Import dialog box may appear at this point, depending on the type of file you’re importing. This dialog box offers several options for choosing a way to import the content into Illustrator. For example, you can sometimes choose between flattening layers or retaining layers when you import a file containing layers.

				Encapsulated PostScript (EPS) is a commonly used file format for saving vector drawings (although it can be used for other file types as well). Because this file format is used in many programs, you may find other people giving you these files to work with. To import an EPS document, you also choose File⇒Place; after you import an EPS document into Illustrator, the file is converted to Illustrator objects but isn’t editable. To edit the EPS object, choose File⇒Open to open the file, or click the Edit Original button in the Links panel.

				You can also import text files into Illustrator. Microsoft Word, TXT (text only), RTF (Rich Text Format), and Unicode, among other text documents, are all supported by Illustrator, and you can import them by choosing File⇒Place. When you import the text file, you may be prompted to choose the character set used for the text.

				You can not only use the Place command for importing files but also copy and paste from other programs. You can select part of an image in Photoshop and copy it to the Clipboard by pressing Ctrl+C (Windows) or [image: maccmd]+C (Mac) and then pasting it into the Illustrator document.

				[image: remember.eps]	Use the Place command whenever possible to avoid losing quality in the content you’re importing. Also, transparency isn’t supported from one application to another when you copy and paste, but it is when you use Place.

				[image: technicalstuff.eps]	When you have particular plug-ins installed, you can import additional file types, such as CAD files, into Illustrator.

				Adding to Acrobat

				Adobe Acrobat is primarily a tool for sharing completed documents — you’ll complete most document construction and editing in other programs, such as InDesign or Illustrator. However, you can import several kinds of data into PDF documents, and you can do some creative things when you place data into PDF files as well:

				[image: check.png] Comments: The most useful and common items to import into an Adobe PDF file are comments made using the review and markup tools provided by Adobe Acrobat. By importing comments into a PDF file, you can consolidate suggestions and input from several reviewers (people editing a document) into a single document. This feature makes the reviewing process easier when many people are working on a single document. To import someone’s comments into a PDF, select the Comments button, and then from the Comments List section click on the panel menu in the upper-right corner and select Import Data File. When the Import Comments dialog box appears, locate the comments file that you want to Import and click Open.

						If you’re reviewing a document, you can also export select Export All to Data File from the Comments panel menu to export only the comments rather than send the document owner the entire PDF file.

				[image: check.png] Form data: You can import form data into a PDF document by clicking on the Tools button, selecting Forms, and then selecting More Form Options⇒Manage Form Data⇒Import Data. The data you import can be generated by exporting the form data from another PDF form, or it can come from a delimited text file. You can then share form data between forms or from a database.

				[image: check.png] Trusted identities: If you share digitally signed files or secured files with another Acrobat user, you can import the public version of that person’s signature file into your list of trusted users with whom you share files. To import the identity of a user, choose Tools⇒Sign & Certify⇒More Sign & Certify⇒Manage Trusted Identities, and in the Manage Trusted Identities dialog box that appears, click the Add Contacts button.

				[image: check.png] Multimedia files: If you’ve ever had the urge to add a movie or sound file to your PDF documents, you’re in luck. By selecting Tools⇒Content⇒Add or Edit Interactive Object⇒Multimedia, you can identify the location on the page where you want the file to appear and then choose whether to embed the multimedia file (compatible with Acrobat 6 or later) or create a link to the file (compatible with Acrobat 5 and earlier).

				[image: check.png] Buttons: Creating buttons to turn pages, print a document, or go to a website makes your PDF files easier to use. Adding custom button images, such as pictures of arrows or a printer icon, makes your document unique. Use the Button tool, located by clicking on Tools⇒Content⇒Button to create the location of the button and then select the graphic file to be used as the image on the button. The image file you use must first be converted to a PDF graphic.

				[image: check.png] Preflight information: If you’re creating a PDF file to be sent to a commercial printer for reproduction, you may want to preflight the file to ensure that it meets the specifications and needs of the printer and has all the necessary assets (such as fonts and images) that it needs to print correctly. If your printer has supplied a preflight profile for Acrobat, you can import the profile to ensure that Acrobat checks for the elements your printer has requested, such as certain font types or color specifications. Import a preflight profile by choosing Tools⇒Print Production⇒In the Preflight window that opens, choose Options⇒Import Preflight Profile. If you do not see the Production Tools panel, choose View⇒Tools⇒Print Production, and select Preflight from the list of production tools.

				Importing into Dreamweaver

				In Dreamweaver, you can import several different kinds of files into a site you’re creating:

				[image: check.png] Insert images and other media such as Flash, FlashPaper, and Flash Video by using the Insert menu item.

				[image: check.png] Import XML files and XHTML documents exported from InDesign.

				[image: check.png] Cut and paste a layered file in Photoshop. Simply choose Edit⇒Copy Merged and paste the file directly into Dreamweaver. An Image Preview window opens (see Figure 5-11), and you can then optimize the image for the web. Choose your settings and click OK. (You can read about the best settings for web imagery in Book IV, Chapter 10.)

					

				
					Figure 5-11: The Image Preview window opens when a native PSD file is pasted into a Dream-weaver page.

				

					[image: 9781118168608-fg010511.tif]

				Exporting Your Documents

				Exporting content from Adobe Creative Suite documents is important if you’re transferring content into other programs, placing the document where it’s publicly available and where it needs to be opened on other computers. Adobe Creative Suite offers you the flexibility of allowing you to export a document as many different file formats.

				[image: technicalstuff.eps]	Other programs sometimes accept native Adobe documents as files you can import. For example, Adobe Flash CS6 can import Illustrator AI files, Photoshop PSD files, and PDF documents.

				Exporting from InDesign

				In InDesign, you can export pages or a book as several file types. Most notably, you can export layouts as PDF documents, which anyone who has the free Adobe Reader installed can view. InDesign can also export to other image and vector formats, such as EPS and JPEG. An InDesign document can also export to SVG (Scalable Vector Graphics) and XML (Extensible Markup Language), which is useful when you export documents for the web. InDesign has a handy feature to package your work for Dreamweaver: By choosing File⇒Export for Dreamweaver, you can export a project you’re working on and have it ready for page creation in Dreamweaver.

				If you select File⇒Export and take a look at the Save as Type drop-down  list, you’ll see a large amount of export selections available, including EPub and HTML5 options. Check out Chapter 8 of Book II to find out more about these features. 

				Exporting content from Photoshop

				If you’re working in the creative field, you’ll export many files from Adobe Photoshop, from simple .png or .jpg files to more complex sliced images that are exported with HTML and CSS content. If you’re interested in 3D and video, you’ll be happy to know that you can export to a wide range of video and 3D formats as well. In this brief overview, we discuss a few such formats. However, make sure that you refer to Book IV for more complete instructions.

				Keep in mind that if you’re working within the Creative Suite applications then you’ll most likely not need to export any content, because most of the applications recognize the native .psd format. For instance, paths and masks in a Photoshop Document can be read in both InDesign and Illustrator.

				Here’s another interesting export option, one that takes advantage of Flash in a browser: Export your Photoshop file by using the Zoomify feature. This useful feature can export a large file to a smaller, more compact SWF file. This file can be easily sent by e-mail and opened using the free Flash Player, which almost everyone already has installed.

				To use Zoomify, follow these steps:

					1.	Choose File⇒Export⇒Zoomify.

					2.	Click Folder in the Output Location section of the Zoomify dialog box and choose a folder location for your SWF file.

					3.	Choose the quality and size and then click OK.

						The Zoomify Preview window appears. (See Figure 5-12.) Use this window to zoom in to see detail.

						You can then retrieve the files that were created in your destination folder and post them online or attach them to an e-mail message.

					

				
					Figure 5-12: The image before it rebuilds after zooming in, and the image after it rebuilds.

				

					[image: 9781118168608-fg010512.tif]

				Exporting Illustrator files

				Illustrator supports exporting to many different file formats. You can export files in a long list of image formats. Choose File⇒Export, and the Export dialog box opens. Click the Save As Type (Windows) or Format (Mac) drop-down list to view the exportable file formats.

				After you choose a file type to export to, a second dialog box may appear, allowing you to enter a bunch of settings for the exported file.

				Try choosing the Flash SWF file format when you export a file. A second dialog box opens that includes many settings, such as options to generate an HTML page, save each layer as a separate SWF document, and preserve editability (when possible). The options that are available when you export a document depend on the type of file format to which you’re exporting.

				Exporting Acrobat content

				Acrobat lets you export certain parts of a PDF document you’re working on. For example, you may be using form data — the data that’s filled into a form made of text fields and so on — in one of your files. You can export this data from Acrobat and then send it online, which is helpful because PDF documents tend to be rather large for the web. Therefore, only a small amount of formatted data is sent online, not a huge PDF file.

				You can also export parts of an Acrobat document to use in other programs. You can export comments in a PDF to a Microsoft Word file that was used to create the PDF by selecting the Comments button, clicking on the Comments panel menu, and then selecting Export to Word. You can also export comments to an AutoCAD file (assuming that it was used to create the PDF). In both cases, you need the original document that was used to generate the PDF file in order to successfully import the comments.

				Exporting Dreamweaver content

				In Dreamweaver, you can export your sites so that they’re prepared for publishing and ready to be placed on a live website. The site you’re working on in Dreamweaver is exported to your hard drive before you put it somewhere on a server. The HTML styles used in a site you’re working on can be exported and saved as an XML document, which in turn can be reused if necessary. These files can then be imported into another Dreamweaver project you’re working on. You can also take advantage of File⇒Convert, which provides options so that you can convert your Dreamweaver file into other versions of HTML. Find out more about Dreamweaver in the Book 6.

				

			

		

	
		
			
				Chapter 6: Handling Graphics, Paths, Text, and Fonts

				In This Chapter

				[image: check.png] Livening up your documents with graphics

				[image: check.png] Getting control of paths and strokes

				[image: check.png] Getting the scoop on text and font fundamentals

				[image: check.png] Creating a layout

				Graphics, paths, text, and fonts are all integral parts of creating documents with Adobe Creative Suite. You must know how to handle each element in your documents and how to make these elements successfully work together. Discovering the different ways you can work with images, text, and drawings is the fun part!

				Whether you’re designing websites or creating a brochure layout, you can use these elements on their own or together, and you’ll likely find out something new every time you work with them. A layout can include text, images, and drawings but sometimes includes more. If you’re creating documents for the web or creating PDF (Portable Document Format) files with multimedia elements, you may be working with sound, animation, and video alongside text, images, and illustrations.

				Using Graphics in Your Documents

				A graphic can be an image, a drawing, or a vector object. You can create graphics manually by making marks on a page or create them electronically using software. You can display graphics in many formats, such as on a computer screen, projected on a wall, or printed in a magazine or book.

				Computer graphics come in many forms, grouped by the way they’re created electronically. Bitmap and vector graphics are formed in different ways to achieve the result you use in your documents.

				Working with bitmap images

				Bitmap images are pictures made up of many tiny squares, or bits, on an invisible grid. When these dots are next to each other, the picture is formed, depending on where and how the colors are arranged on the grid. If you zoom in far enough, you can even see the blocky dots, or pixels, that make up the image. At 400 percent zoom, notice how the image in Figure 6-1 is made of large squares. However, when you look at most bitmap images at their true sizes, you don’t even see pixels.

					

				
					Figure 6-1: A bitmap image is created from pixels.

				

					[image: 9781118168608-fg010601.tif]

				The bitmap is a useful way to display photographs and apply effects to text. When you paint or create detailed graphics, you frequently use bitmaps. However, remember that images can lose quality if you scale them (change their size). Resizing pixels causes the image to lose definition and quality. Most problems occur when an image is enlarged. Common kinds of bitmap files are BMP, GIF, JPEG, PICT, and TIFF. You can read more about bitmaps in Book IV.

				Discovering vector graphics

				A vector image (or graphic or drawing) is quite different from a bitmap image. A vector image is created by a series of mathematical calculations or code that describes how the image should be formed. These calculations tell the computer how the lines should display and render on the page. Some of the file formats that support vector graphics include, .eps, .ai, .pdf, .psd, and .svg.

				Vector images are usually smaller files than bitmap graphics because the mathematical information required to make the calculations to create the vector image is usually smaller in file size than the information that it takes to make up each pixel of a bitmap. (Compression can lessen a bitmap’s file size, but it’s usually larger and slower to display.)

				For this reason and because vectors are helpful in scaling an image, as shown in Figure 6-2, these graphics are well suited for the web.

					

				
					Figure 6-2: A vector image is smooth at any zoom level.

				

					[image: 9781118168608-fg010602.tif]

				Scaling is easy to do when you’re using vectors because the program needs to modify the calculations only slightly to make the image larger or smaller. This means the file size won’t change, and the scaling is very quick. You can scale the image on a web page to fill the browser window, whatever size it is, or make the image huge for a large banner. The quality doesn’t degrade, and the file size remains the same.

				[image: remember.eps]	Vectors aren’t always perfect for the web. A bitmap is frequently the best way to display a photograph because if you change a bitmap image into a vector drawing (which is possible if you use tools), you lose too much of the photograph’s detail for many purposes. Also, certain effects, such as the drop shadow, are best displayed as bitmap images.

				Working with Paths and Strokes

				Paths are the vector lines and outlines you create in a document. You can use paths to outline an image, separate areas of text, or be part of an illustration you create. You typically make paths using a Line tool or a Pen tool or the shape tools. You can use these tools to create paths of different shapes and sizes. You also can use tools to modify the color and size of strokes (the actual line that makes up a path).

				You can use paths to create clipping paths and paths for text. Clipping paths are used to mask (or hide) elements on a page. You define that mask with paths to create a shape for the area you need to hide. Clipping paths can even be saved in a file and imported into a different design pattern. A common workflow is to create an image in Photoshop CS6 with a clipping path and import the image into InDesign. Because InDesign can interpret the clipping path, you can automatically remove the area you want to mask.

				When you want to create text that flows along a path, begin by creating a new path and then use the Type On a Path tool to type text directly on that path. For example, in Illustrator, you create a path with the Pen tool and then select the Type On a Path tool in the Tools panel. If you click the tool on the path you created, you can type new text along that path.

				If you have an existing path, you can select the Type tool and cross over the select path. The Type tool cursor changes to indicate that it’s loaded as a Type On a Path tool, as shown in Figure 6-3. Click on the path, and the type is attached to the path.

					

				
					Figure 6-3: The Type tool cursor changes when you cross over an active path.

				

					[image: 9781118168608-fg010603.tif]

				A stroke is the color, width, and style of the line that makes up the path you create. You might draw a line with the Pen tool, and the line making up that path is the stroke. However, that path can also have no stroke (represented as a diagonal line in the Tools, Swatches, and Stroke & Color panels), which means that you don’t see the path itself. However, you may see a color or pattern filling that stroke (the fill), as shown in Figure 6-4.

					

				
					Figure 6-4: This path has a fill but no stroke applied to it.

				

					[image: 9781118168608-fg010604.tif]

				You can change the color, width, style (or type), and shape of a stroke by using controls and tools in the Tools panel and the Stroke panel in Illustrator and InDesign. You can also therefore create dashed or solid strokes of different patterns that are wide or narrow. Some strokes are shown in Figure 6-5.

					

				
					Figure 6-5:  Paths that have different strokes can add a creative flair.

				

					[image: 9781118168608-fg010605.tif]

				Adding Text

				You may add text to your projects for different reasons. Text is frequently used to educate and inform people who read it, and this kind of document is a lot different from ones that use text for artistic purposes only. For example, if you’re creating an article, you may place the text in columns on the page under a large title at the top. At other times, you may use text as a creative element or even as an object instead of a letter. Alternatively, you may be laying out a web page and use the text for both a creative element in an animation and the content on pages that make up the website.

				You can add text to a document by using the Text tool or by importing the text from another source, such as Microsoft Word. You can create a single line of text in a text field or large blocks of text with or without columns. Text fields can be rotated and resized, and you can change the color, font face, orientation, and character size of the text.

				Text can also be placed on a path, as we mention briefly in the earlier section “Working with Paths and Strokes.” You can then add text to your documents in a different way because you can draw a path and have the text follow it. Paths are particularly useful for headings on a page, footers, and artistic works that use text as one of their elements.

				Using fonts

				A font refers to the typeface of a set of characters. You can set the font to be a number of sizes, such as the miniscule size 2 or the gargantuan size 200. Fonts are given names, such as Times New Roman or Comic Sans.

				You may also hear about the glyph, which is an actual character. For example, S is a glyph. A set of glyphs make up a font. You can view glyphs in the Glyph panel in Illustrator (choose Window⇒Type⇒Glyphs), which is especially useful when you’re using fonts such as Wingdings that are made of pictures instead of letters and numbers.

				The fonts you use can make a huge difference to the look, feel, and style of your documents. Whether you’re working on a layout for a magazine article or creating a digital piece of art, the kinds of fonts you use help the feel of the work.

				Two major groupings for fonts exist, as illustrated in Figure 6-6:

				[image: check.png] Serif: Each character has a small line that intersects the end of each line, such as the feet on the letters rif in serif.

				[image: check.png] Sans serif: A character has no small, intersecting line at the end of a line.

					

				
					Figure 6-6: Serif and sans serif fonts.

				

					[image: 9781118168608-fg010606.tif]

				Sometimes sans serif fonts feel more modern, whereas serif sometimes looks more historical, formal, or literary. (This topic is, of course, all a matter of opinion.) Take a moment to look at how text is used around the web and in books, magazines, advertisements, and even the newspaper. How text is commonly used greatly affects how other people view your work and find the overall feel of it. Finding an appropriate font is sometimes a challenging design task, but it can also be fun.

				Discovering types of fonts

				Although you can find a gazillion fonts for free on the Internet, be concerned about the quality of your finished product. Typically, people in the professional graphics industry use PostScript fonts, and preferably OpenType fonts, which are more reliable when printing, as compared to TrueType fonts, which may reflow when printing to different resolutions.

					[image: check.png] [image: 9781118168608-ma001.tif] TrueType: Like other digital typefaces, the TrueType font file contains information, such as outlines, hinting instructions, and character mappings (which characters are included in the font). Available for both the Mac and Windows formats, the TrueType fonts designed for each operating system have slight differences; therefore, Mac and Windows users can’t share TrueType fonts.

					[image: check.png] [image: 9781118168608-ma002.tif] PostScript (Type 1): The scalable PostScript font system is compatible with PostScript printers; users can see fonts on the screen the same way the fonts would be printed. Type 1 font files consist of two files: a screen font with bitmap information for onscreen display and a file with outline information for printing. For high-end printing, both parts of the Type 1 font files (Printer and Screen fonts) must be included with the file. Because of differences in their structure, Mac and Windows PostScript Type 1 fonts aren’t cross-platform compatible.

					[image: check.png] [image: 9781118168608-ma003.tif] OpenType: The OpenType font technology was created in a joint effort between Adobe and Microsoft and is an extension of the TrueType font format that can also contain PostScript data. OpenType fonts are cross-platform — the same font file works under both Macintosh and Windows operating systems. This digital type format offers extended character sets and more advanced typographic controls. As with TrueType, a single file contains all the outline, metric, and bitmap data for an OpenType font. Although any program that supports TrueType fonts can use OpenType fonts, not all non-Adobe programs can access the full features of the OpenType font format. You can find the symbols on the Font menus of many of the CS6 programs representing the type of font.

				Using text and fonts on the web

				Using text and fonts on the web is a difficult task at times. When you use fonts in a web page, system fonts are used to display text. You usually specify a font or a group of fonts to use on each page, and the fonts that are installed on the visitor’s computer are used to display the text. The problem arises if you use (or want to use) fonts that aren’t installed on the visitor’s computer. For example, if you use the Papyrus font and the visitor doesn’t have that font, a different font is substituted and the page looks completely different as a result.

				When you’re using Dreamweaver to create websites, you can set up a set of fonts that you want to use on each page. These fonts are similar in how they look, and if one of the fonts isn’t available, the next font is used instead. Among the fonts in the set, at least one of them should be installed on the visitor’s computer, to ensure that your pages will look similar to your original layout.

				[image: tip.eps]	You can use Photoshop and Illustrator to create an image using any font installed on your computer and then save that image for the web. (Choose File⇒Save for Web.) Then you can place that image in your web page with Dreamweaver. This option is best used for small amounts of text — say, for buttons on a navigation bar, headings to separate areas of text, or a customized banner at the top of a web page.

				The Fundamentals of Page Layout

				Page layout incorporates the many elements we discuss earlier in this chapter, mainly text and images (and sometimes other forms of multimedia), to create a design on a page. When you’re creating a page design, you must consider how people view a layout, such as how the eye moves across the page to take in the flow of information. Also consider how the elements are arranged and how much empty space surrounds them.

				Two main kinds of page layout are discussed in this book: print and web layouts. Both formats require you to work with many of the same elements.

				Deciding which Creative Suite programs to use

				Many differences exist between preparing a layout for the web and preparing it for print; however, you’ll find that you use many of the same tools  for both, and a great deal of information crosses over between the two  mediums.

				Image manipulation for the web is frequently done in Photoshop. It’s also the standard program for manipulating and correcting images intended for print. You can even design a page for print and also put it online by using the Export XHTML/Dreamweaver command in InDesign.

				However, you have to make certain considerations when you post information online. Navigation, usability, file size, dimensions, and computer capabilities are considerations for the web that aren’t a concern when you’re working for print. However, resolution, colors, and cropping (to name a few) are considerations of someone designing a piece for print, which aren’t concerns for the web.

				Another option for creating web page layout is to use Adobe Fireworks, included in the Creative Suite. Fireworks not only helps you create web graphics, but also provides excellent prototyping tools for the web. Using Fireworks, you can establish styles, build a master page, and even apply interactivity to your pages. Building multiple page prototypes with hyperlinks is a cinch using Fireworks.

				Designing a layout for print

				When you design a page layout for print, you have to factor in the size and type of paper that will be used. Sometimes, you create letterhead with certain elements on the page that remain the same, whereas other elements (the main content) differ from page to page. You can also create page layouts that serve as templates for a book and use particular elements (such as bullets or sidebars) repeatedly in varying ways throughout the pages. Page size, font size, and image resolution are all important considerations in print.

				[image: technicalstuff.eps]	Onscreen image resolution is measured in pixels per inch (ppi), which refers to the number of pixels that are within 1 inch onscreen. The printed resolution of an image is measured in dots per inch (dpi) — a dot of ink is printed for each pixel. A higher dpi means that the image is clearer and has finer detail, which is extremely important for print. Printed images almost always use a higher resolution than onscreen images, so you may find that an image that measures 4 x 4 inches onscreen (at 72 ppi) prints at less than 1 x 1 inch (at 300 dpi). Read more about resolution in Book IV, Chapter 6.

				Templates are available for page layouts that factor in common dimensions of paper and help you lay out content into defined areas. Many kinds of templates are available online, and you can download them sometimes for free; others are available for a small or modest fee depending on the template. For example, if you’re creating a brochure, you may have to think about where the page will be folded and how to orient images and text so that they’re facing the correct way when someone reads the brochure.

				Here are a few issues to think about when you’re laying out a page:

				[image: check.png] Use a grid and snapping-to-align elements whenever possible. If certain elements on your page aren’t aligned, you should have a good reason.

				[image: check.png] The eye travels in the direction of the elements on the page. For example, if a picture of a person is facing away from the center of a spread, the eye travels in that direction. Make sure that the eye travels to the important elements on the page.

				[image: check.png] Follow a grid. Although it’s not absolutely necessary to follow a grid, using a layout grid can help you better organize your content, whether you are planning a printed piece or an online one. For more information about following grids see www.thegridsystem.org.

				Choosing a web page layout

				Layout for the web is quite different from layout for print. However, many of the same issues arise in both print and web layout, such as keeping text legible and flowing across the page (or screen) in an intelligent way. In web layouts, navigation and usability open a few doors for issues you should consider when planning a web page:

				[image: check.png] Usability: A usable site is accessible to most, if not all, of your visitors. Visitors must be able to access your content easily because the text is legible, the file formats work on their computers, and they can find content on your site. Also, visitors who have physical challenges, such as sight or reading problems, can use software on their computers so that the website is read or described aloud to them.

				[image: check.png] Revision: The best way to build a successful site is with lots of planning and sketching. If it has been a while since you’ve broken out a pencil and sketchpad, make a habit of keeping them handy now. By jotting down the needs of the typical user, you can determine which information needs to be most accessible and prominent on the page. You can then start mapping out your ideas in sketch form. Sketching allows you to iterate (come up with new versions) over and over again without feeling committed to any one idea. Work out the user’s experience on your site before you start building your pages. You’ll not only save days of time, but have a much more successful site as well.

				[image: check.png] Size: File size should always be kept to a minimum, which may mean changing the size of your layout. If many parts of your design require large images, you may need to change the design completely to reduce file size. Also, you need to design the page with the average user’s monitors in mind. If a visitor’s monitor is set to a resolution of 800 x 600, your site scrolls horizontally if it’s designed any larger than 780 pixels wide. Most web surfers dislike this horizontal scrolling effect, so you must consider the dimensions of visitors’ displays when designing sites.

						Rearranging content. Nowadays there are many methods for automatically scaling and rearranging content. Read Book VI on Adobe Dreamweaver, most importantly Chapter 8, “Creating CSS Layouts,” to find out more about dynamically adjusting your site according to User needs using Cascading Styles Sheets.

				[image: check.png] Navigation: Users have to navigate the pages on your site. To help them do so, you need to create links to those pages by using buttons, text links, menus, and other screen elements. Making navigational controls easy to find and use takes some forethought and planning. Be sure  that navigation is a big part of the plan when designing the layout of your site.

				You have to think not only about usability and navigation but also the different kinds of computers accessing the page and how people from all over the world may try to access your page. If you need your page to be universal, you may need to translate it into different languages and use different character sets. (This statement applies to print also, if you’re designing a page that requires a special character set other than the ones you regularly use.)

				Because you may be using multimedia (such as images and animation) alongside text, you’re constrained to the dimensions and color limitations of a computer monitor and have to think about both file size and scrolling.

				

			

			
		

	
		
			
				Chapter 7: Using Color

				In This Chapter

				[image: check.png] Discovering color modes

				[image: check.png] Finding out about swatches

				[image: check.png] Using color for print

				[image: check.png] Using color on the 

				Using color in documents is one of the most important considerations in creating your projects. The colors you use, the mode you use them in, and even the way you select colors make a difference in the way you create a document and the final output of that document. Even though you can create a document that looks the same on a monitor in different color modes, how that file prints on paper is a different matter. Color is quite a broad subject, and in this chapter you find out the basic facts about how color affects the projects you work on.

				Figuring out the kinds of colors you’re using is important, and this decision is greatly determined by the kind of output you’ve planned for the document. Different color modes are appropriate for work for the web and work you’re having professionally printed. Monitors and printers have different modes for color, so you need to work with your files in different color modes (although you can change the mode after you start working on a file, if necessary).

				You may also be in situations where particular colors are required in your work. You may be working with specific colors that a company needs in order to match its logo or creating an image that replicates how a building should be painted with specific colors of paint. You may need to use particular Pantone colors or color mixes — if not for the printing process, then for the purpose of matching a client’s needs.

				In this chapter, we introduce you to color modes and how to use them. You discover new terminology and how to find, mix, and add colors to your documents in the Creative Suite.

				Looking at Color Modes and Channels

				Several color modes are available for use in Creative Suite applications. When you start a new document in Photoshop and Illustrator, you can choose the color mode you want to work in. In fact, both Photoshop and Illustrator help you by letting you choose a color mode in the New Document dialog box. The choice you make affects how colors are created. You can change the color mode later by choosing File⇒Document Color Mode in Illustrator or Image⇒Mode in Photoshop.

				If you’re working with print, generally you use CMYK mode. If you’re working on files to be displayed on a monitor, RGB is the right choice.

				Using RGB

				RGB (Red, Green, Blue) is the color mode used for onscreen presentation, such as an image displayed on the web or a broadcast design for TV. Each color displayed onscreen has a certain level (between 0 and 100 percent) of red, green, and blue to create the color. In a Color panel, you can either use sliders to set the level in values, as shown in Figure 7-1, or enter a percentage into a text field (such as in CMYK Color mode).

					

				
					Figure 7-1: Creating colors with the sliders in RGB mode.

				

					[image: 9781118168608-fg010701.eps]

					[image: 9781118168608-ma004.tif]	Note the exclamation point on the Color panel, which is the Out of Gamut symbol. It indicates that this color wouldn’t reproduce correctly in CMYK mode. You can click the CMYK warning exclamation point to convert to a color that’s suitable for the CMYK gamut. Color is discussed in Book IV, Chapter 3, including more details about how you can adjust the Color Settings dialog box.

				When you create a web page, the color is represented as a hexadecimal number, which starts with a pound sign (#) followed by three pairs of letters and numbers (A through F and 0 through 9) — the first pair for red, the second pair for green, and the last pair for blue. The lowest value (the least amount of the color) in a hexadecimal number is 0 (zero), and the highest value (the greatest amount of the color) is F. For example, #000000 is black, #FFFFFF is white, #FF0000 is red, and #CCCCCC is light gray. To see what  a particular hexadecimal color looks like, go to Webmonkey at www.webmonkey.com/reference/Color_Charts.

				Working with CMYK

				RGB (Red, Green, Blue) color mode is the color standard for monitors and the web, and CMYK — Cyan, Magenta, Yellow, and Key (or Black) — is the standard color mode for print media, particularly in commercial printing such as what a service provider does.

				The CMYK color scheme is based on pigment (a substance used as coloring) color separation, and it describes how light reflects off pigments. When you work with this color mode, you create black by adding the maximum values of cyan, magenta, and yellow all at one time. You can create different levels of gray by combining equal, but not maximum, amounts of cyan, magenta, and yellow. White is simply the absence of all color. Many color printers now work by using the CMYK color model and can simulate almost any color by printing two colors very close to each other; however, some at-home desktop printer models made by Epson, Hewlett-Packard (HP), and Canon use their own color systems to print your work.

				Saving in grayscale

				You’ve seen a lot of grayscale images (color images displayed or printed in black and white) because the pictures in this book were printed in grayscale. Grayscale refers to the different shades of gray that can be used when printing using only black ink on a white page. Halftone patterns are created when an image uses dots of varying diameter or when an image uses many small dots in the same area to simulate different shades of gray. Halftone patterns help simulate different color values by adding dots to simulate shadows and gradients between colors.

				Looking at color channels

				When you work with an image in Photoshop, the image has at least one (but typically more) color channels. A color channel stores information about a particular color in a selected image. For example, an RGB image has three color channels: one that handles the reds (R), one for handling green information (G), and the last for information about the blues (B). See Figure 7-2.

				You can have, in addition to the three color channels, an alpha channel, which can hold the transparency information about a particular image. If you’re working with a file format that supports transparency, you can add and use the alpha channel to save alpha information. Some file formats that support transparency are .png, .tiff, .gif, .dcs, .eps and the native .ai, and .psd formats.

				You can also use an alpha channel to save a selection. By choosing Select⇒Save Selection in Photoshop, you create an alpha channel with your selection saved to it. You can choose Select⇒Load Selection and choose the channel to reload your selection at any time.

					

				
					Figure 7-2:  This RGB file is created from a Red, Green, and Blue channel.

				

					[image: 9781118168608-fg010702.tif]

				In Photoshop, you can access the channels in your image by choosing Windows⇒Channels. When the Channels panel opens, you can toggle the  visibility of each icon by clicking the eye icon next to each channel. (Refer  to Figure 7-2.)

				Choosing Colors

				When you create a document, you may have to consider which colors you use, or you may have the freedom to use an unlimited number of colors. If you print your documents, you can choose a specific set of colors to use. You may be restricted to only the two colors in a company logo, or you may have to print in grayscale. Finding the colors you need to use in each program is important — and then figuring out how to access those colors repeatedly in a document saves you a great deal of time.

				Using swatches

				A swatch is a good way to choose a color, particularly when you intend to print a document. The Swatches panel in Creative Suite programs contains colors and sometimes gradients. (The Swatches panel, shown in Figure 7-3, is from Illustrator.) You can create libraries of swatches that contain colors you can use repeatedly across several documents.

					

				
					Figure 7-3: Swatches panels are similar in most CS6 applications.

				

					[image: 9781118168608-fg010703.eps]

				You can choose libraries of swatches from the panel menu or load and save swatch libraries. You can customize a swatch library by adding or deleting colors.

				Mixing colors

					[image: 9781118168608-ma004.tif]	A color mixer, found in the Color panel, helps you choose colors. You can use the Eyedropper tool to choose a color or, if you prefer, enter values for each hue or percentage. You can use one of several color modes in the programs you use, which offers you a lot of flexibility for all your projects.

				Follow these steps to choose a color in a specified color mode:

					1.	In a program that has a Color panel, choose Window⇒Color to open the Color panel (if it’s not open already).

						The Color panel is available in Illustrator, InDesign, and Photoshop.

					2.	Click the Color panel menu to choose a new color mode.

						Open this menu by clicking the arrow button in the upper-right corner of the Color panel.

					3.	Choose the RGB color mode from the panel menu that opens.

						The panel switches to RGB color mode.

					4.	In the Color panel, click either the Fill box (solid square) or the Stroke box (hollow square) to choose the color you want to change.

						If you click the Fill box, you can modify the color of a fill (the color inside a shape). If you click the Stroke box, you can modify the color of a stroke (the outline of a shape or a line).

					5.	Use the sliders in the Color panel to change the color values.

						You can also change the percentage values to the right of each slider.

					6.	After you choose a color you’re happy with, return to your document and create a new shape that uses the color.

				[image: tip.eps]	Hold down the Shift key when adjusting any one-color slider and the other color sliders adjust proportionally to provide you with various tints from your original.

				Using Color on the Web

				In the past, you had to consciously choose which colors you used on the web. Some computer monitors were limited in the number of colors they could display. Nowadays, color monitors are much more advanced and can handle a full range of colors, so images on the web are much more likely to be properly displayed.

				[image: technicalstuff.eps]	Though this statement doesn’t have to do with color, Macintosh and Windows computers usually display your work differently because of gamma differences on these machines. Generally speaking, colors on a Mac appear lighter, and colors on a PC look darker. 

				Even though most computers can handle a full range of colors, you may have to consider color limitations. If you’re designing a site specifically targeted at old computers or a certain user base, you may have to limit colors to the 256 web-safe colors, which means that any other colors used are approximated, which can look poor. If your site will likely be viewed by users with older computers, consider these suggestions:

				[image: check.png] Use a web-safe palette of 216 colors to design websites with those older displays in mind so that you know what the pages will look like. This number is 216 instead of 256 because the lower number is compatible with both Mac and Windows computers. You can access this panel, usually known as Web-Safe Palette or Web-Safe RGB, from the Swatches panel menu in Illustrator and Photoshop.

				[image: check.png] Avoid using gradients, if possible. They use a wide range of colors (many unsupported in a limited web panel).

				[image: check.png] Avoid dithering if you can. A color that’s approximated because it can’t be handled by someone’s computer is dithered — the computer tries to use two or more colors to achieve the one you specified, causing a typically displeasing granular appearance. So a limited number of colors can have a negative effect on an image; notice the granular appearance on what should be the shape of a face in Figure 7-4.

					

				
					Figure 7-4: The shading in the face is dithered.

				

					[image: 9781118168608-fg010704.tif]

				If you keep the preceding suggestion list in mind, you’re ready to start designing for the web! Remember also that you don’t have to worry about using the web-safe palette of colors if you’re designing primarily for more up-to-date computers.

				

				

				

				

			

			
		

	
		
			
				Chapter 8: Printing Documents

				In This Chapter

				[image: check.png] Understanding color and black-and-white printing

				[image: check.png] Choosing a printer

				[image: check.png] Outputting your work

				You can print documents in many ways in Adobe Creative Suite 6. Similarly, you can print many different kinds of documents. You can create anything from a CD-ROM sticker to a 300-page book to a T-shirt iron-on transfer using the programs you find in the Creative Suite. Whatever you’re working on, knowing the options that are available for printing your work is a good idea. Knowing the kinds of printers you can work with, what to buy (and from where) in order to use them, and how to save your work help improve the quality of the print job when you’ve finished your work.

				Choosing Printers

				When it comes to printers, you encounter hundreds of options at a great variety of prices. Printers can differ greatly in the areas of quality, cost of maintenance, and the speed at which the printer can print. Some inkjet printers excel at printing full-color photos but don’t print text well; a low-end or medium-end laser printer may print black-and-white documents at good speed and quality but can’t print in color.

				Using consumer printers

				The most common type of consumer (home) printer is now an inkjet printer, which works by spraying ink stored in cartridges onto a sheet of paper while it passes through the printer. This type of printer is common in households because it’s the least expensive type of color printer. It’s also versatile. You can walk into virtually any computer store and buy a color inkjet printer (which can print résumés, photos, and brochures) for a low price.

				[image: warning_bomb.eps]	The lone drawback of inkjet printers is that they can be expensive to maintain in the long run. Depending on how much you print, you may need to replace the black or color cartridges often, which can get costly and quickly exceed the cost of the printer itself.

				Looking at professional printers

				Professional printers typically have a more rounded feature set compared to consumer printers. Professional printers can either be inkjet or laser printers and can even perform multiple functions within the office. Not surprisingly, printers that have several roles within the office are often referred to as multifunction or all-in-one printers and typically also include scanning, photocopying, or faxing capabilities in addition to printing. These all-in-one units are useful in small offices and home offices because they save the consumer some money while providing access to a variety of useful tools.

				Laser printers have several benefits: They typically produce a higher quality printout and print pages faster than inkjet printers, as well as produce a clean, professional-looking document. You can also print more pages per ink cartridge, saving you money in consumable items.

				Buying a Printer

				Some common features to look for when purchasing a printer (either consumer or professional) are

				[image: check.png] Speed: Printers are rated in pages per minute (PPM). Low-end inkjet printers typically print about 12 or fewer PPM when printing black-and-white pages. When you’re printing color documents, the number of pages printed per minute is less.

				[image: check.png] Color: Almost all inkjet printers can print in color, but many print only in black and white. Color printers can be expensive to maintain because most inkjet printers have one cartridge for black ink and a second cartridge for colored inks. When one color runs out, you’re forced to replace the entire cartridge or else none of the colors will look right when you print the document. Color laser printers are available, although they’re usually very expensive.

				[image: check.png] Resolution: Similar to monitors, a printer’s quality can be rated in resolution. Higher resolution means images and text appear crisper. Low-end or older inkjet printers may print only a maximum of 600 dpi (dots per inch), which is more than fine for text but may be low if you want to print high-quality photographs.

				[image: check.png] Connectivity: You can connect a printer to your computer in three ways. Older printers typically connect to your system using a parallel (36-pin) port, whereas newer printers often offer both parallel and USB (Universal Serial Bus) connections. The third way of connecting to a printer is by connecting a printer to your network, although this option is usually seen only on professional printers.

				[image: check.png] Duplexing: Another feature to consider is duplexing, the ability to print on both sides of a sheet of paper without having to manually flip the piece of paper and place it back in the paper tray.

				Printing Your Work

				When it comes to printing, countless options and settings can affect the final result of your document. Whether you’re printing banners, business cards, T-shirt iron-on transfers, or lost-cat posters, you must be aware of several factors, such as paper quality, printer quality, and ink usage. You also have to decide whether to print to documents yourself at home or take them to a professional printing business to get the work done.

				Although RGB (Red, Green, Blue) is the color standard for the web, CMYK (Cyan, Magenta, Yellow, and Key [or Black]) is the standard in print. For information about using the RGB and CMYK color modes in the Creative Suite, see Chapter 7 of this minibook.

				Choosing where and how to print

				You can choose from several options when it comes to printing your files. You can take your digital files to a printing service provider, which is an establishment that prints electronic documents (such as FedEx Office), or even print the files yourself at home on your inkjet or laser printer. Each option has several advantages and disadvantages. Depending on how many copies and the number of colors, having files printed professionally can be cost prohibitive. Having files printed by a professional print house, however, almost always means that the print quality will be much better than if the document were printed on a low-end inkjet printer.

				Naturally, if you’re only printing flyers to distribute around the neighborhood, you may not need high-quality output, and a home inkjet or laser printer would be more than adequate. However, printing documents professionally may be cheaper than printing them at home if you’re going to use up large amounts of black ink or perhaps one or two cartridges of toner.

				If you’re using an inkjet printer, often you can get an average of 400 to 600 pages of black text before you need to replace a cartridge; a laser printer prints around 2,500 to 4,000 pages before you need to purchase new toner. Simply using a laser printer can save hundreds of dollars a year, depending on the number of pages you need to print and whether you need to print in color. If you need to print in color, many color laser printers are available (although they can be expensive). Entry-level color laser printers can cost around $500; some high-end color laser printers can cost more than $10,000. In comparison, black-and-white laser printers can cost as little as $100. So unless you plan to print lots of documents, outsourcing your printing to a service provider may be the best solution.

				[image: remember.eps]	The kind of printer you use (such as a commercial or PostScript printer or a low-cost household inkjet) makes a great difference in the quality of output. Some illustrations or layouts will look a lot better when printed commercially depending on what’s in your document.

				Looking at paper

				Before printing your documents, consider the type of paper that’s best for the job. If you’re printing on glossy paper, make sure that the paper works with your printer type. Although most glossy paper works fine in inkjet or laser printers, some brands or types of paper may not.

				[image: tip.eps]	Always double-check paper when purchasing it to make sure that it won’t damage your printer. The kinds of printers supported by the type of paper are listed on the paper’s packaging.

				One benefit to using glossy paper is that it has a finish similar to photo paper finish, which can make your printouts appear to have a higher quality.

				Using good paper can result in photos that have richer colors and show more detail. When purchasing printer paper, here are some important characteristics to look for:

				[image: check.png] Brightness: Refers to how bright the paper is. Higher numbers mean the paper looks brighter and cleaner.

				[image: check.png] Weight: Refers to how heavy the paper is. Higher weights mean a thicker, more durable piece of paper.

				[image: check.png] Opacity: Refers to how translucent, or transparent, the paper is. If the paper is too thin, too much light can pass through it; also, you may be able to see the ink through the other side of the page (which can be a problem if you want to print on both sides of the sheet). Opacity relates to weight, in that a heavier sheet of paper would be thicker and allow less light to pass through it.

				[image: check.png] Texture: Refers to the smoothness or roughness of the surface of the paper. Texture can provide dramatic differences between inkjet and laser printers. Inkjet printers spray ink onto a page, so having a slightly textured surface to print on can be beneficial because the texture allows ink to dry somewhat faster and bleed a little less, making the finished product look a little sharper. When you’re using a laser printer, the opposite is true. Having a smooth, flat surface for the toner to transfer onto produces better results.

				Remember that you may not always print on 81⁄2-x-11-inch paper (also referred to as Letter or A4). Many printers also allow you to print on envelopes, labels, stickers, business cards, and even iron-on transfers. You can use iron-on transfers to create your own T-shirts with your company logo or shirts with your face on the front. Some newer printers even allow you to print directly onto the surface of a CD-ROM. You can even purchase small printers designed solely to print standard-size photographs.

				Another important note is the difference in paper sizes globally. Whereas the United States and Canada use inches to measure paper, the rest of the globe uses a metric system based on an ISO (International Organization for Standardization) standard.

				The North American Letter format may be replaced by the ISO A4 format. The other differences between the U.S. and Canadian systems from the ISO is that the ISO paper sizes always follow a set ratio, whereas the U.S. and Canadian systems uses two different aspect ratios.

				Saving files for a professional  printer or service provider

				When working with a professional print service provider, make sure to find out which file formats it accepts. Almost all print service providers accept files created using an Adobe program (Illustrator, Photoshop, InDesign, or Acrobat, for example) as well as files created using QuarkXPress, CorelDRAW, or other professional-level programs. Also confirm which version and operating system the service provider accepts because you may be required to save your files so that they’re compatible with whichever version of software the service provider uses.

				You may want to export your work to a universal file format, such as PDF (Portable Document Format), if your service provider doesn’t accept native InDesign or QuarkXPress files. In fact, exporting as a PDF is an intelligent choice. When you create a PDF (with the correct settings), you essentially package up all you need to print your file correctly.

				For most of your applications, you can choose File⇒Export or File⇒Save  and select PDF, but if you are sending your output to a professional printer we recommend you print to a PDF following these steps:

					1.	Choose File⇒Print and select Postscript File from the Printer drop-down list, as shown in Figure 8-1.

					2.	Choose PDF for the PPD.

					3.	In the options on the left side of the Print dialog box, click Setup  to view a preview of your page art in the lower-left corner. (See  Figure 8-2.)

					4.	Confirm that your page art is positioned correctly in the document window. 

						If your art is incorrectly positioned, change it accordingly.

					

				
					Figure 8-1: Print to a PostScript file and then open in Adobe Distiller.

				

					[image: 9781118168608-fg010801.eps]

					

				
					Figure 8-2: Make sure that the document fits in the print area.

				

					[image: 9781118168608-fg010802.eps]

					5.	In the options on the left side, choose Marks and Bleeds. Turn on crop marks and registration marks if needed. Click Save to save your changes as a Postscript file.

					6.	Launch Adobe Distiller (which is in the Adobe Acrobat application folder installed with the Creative Suite) and choose File⇒Open to open your PostScript file.

					7.	For a high resolution output, select Press Quality from the Default Settings drop-down list, as you see in Figure 8-3.

					

				
					Figure 8-3: For a high-resolution PD choose Press Quality in Adobe Distiller.

				

					[image: 9781118168608-fg010803.eps]

				Distiller automatically converts the file to a PDF based on your present settings. Read more about PDF options in Book V, Chapter 2.

				Printing at home

				When you’re ready to print your documents, you can open the Print dialog box and then specify a number of settings depending on which kind of printer you’ve installed. For this example, Adobe Distiller is used.

				Though you can simply save a Photoshop PDF from the regular Save menu, we walk you through the steps of creating a PDF file from the Photoshop Print dialog box. Using the Print dialog box, you can take advantage of additional options that aren’t available on the Save menu, such as the ability to preview printed documents, scale images, and apply color settings.

				To print a file as a PDF from Photoshop CS6, follow these steps:

					1.	Choose File⇒Print.

						The Print dialog box opens, as shown in Figure 8-4.

				[image: remember.eps]		The Print dialog box differs, depending on which program you’re using. In this dialog box, Photoshop allows you to change the scale of the image by entering a value in the Scale text box or selecting and dragging a handle on the preview image on the left side.

					2.	From the Printer drop-down list, select Adobe PDF.

						If you want to choose the settings for an installed printer, you can also select it here.

					3.	If necessary, scale the image to fit by selecting the Scale to Fit Media check box and then click the Print Settings button.

						A second Print dialog box appears, as shown in Figure 8-5.

					4.	Select the quality of PDF that you want to create from the Default Settings drop-down list.

					5.	(Optional) If you want to see your PDF file right after it’s created, choose View Adobe PDF Results.

					6.	Click OK.

						You return to the Print dialog box.

					7.	Click Print.

						The Save PDF File As dialog box appears.

					

				
					Figure 8-4: The Print dialog box in Photoshop CS6 for Windows.

				

					[image: 9781118168608-fg010804.eps]

					

				
					Figure 8-5:  The secondary Print dialog box in Photoshop CS6.
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					8.	Enter a name for the PDF, navigate to the location where you want to save the file, and click Save.

						The document is saved as a PDF file.

				Because most printers have custom interfaces for defining settings, you may need to consult your printer’s documentation for detailed information on using the printer’s features.
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				Chapter 1: Introducing InDesign CS6

				In This Chapter

				[image: check.png] Opening InDesign

				[image: check.png] Creating new documents

				[image: check.png] Looking at and setting up the workspace

				[image: check.png] Creating your first publication

				InDesign is a sophisticated page-layout program. You can use it to create professional-looking documents, including newsletters, books, and magazines. You can also use it to create documents for distribution on a tablet such as an iPad, and even documents that include interactivity or videos. InDesign has evolved into a tool that lets you publish content to just about any device or in print. For example, using InDesign you can create a document and distribute content in print and then add hyperlinks and video and export it to PDF or HTML.

				As powerful an application as InDesign is, you’d think it would be difficult to use, but you’ll find that creating most basic documents is a snap. This minibook shows you how to use InDesign to make creative page layouts. In this chapter, you discover the InDesign interface and start your first publication.

				Getting Started with InDesign CS6

				InDesign is used for creating page layouts that include type, graphics (such as fills and strokes), and images. The InDesign document you see in Figure 1-1 includes elements from Adobe Illustrator (logos) and Photoshop (images). If this file were to be exported as a PDF or an HTML file, it could include video or interactive buttons.

				In the following sections, you get familiar with creating and opening documents in InDesign. In Chapters 2 through 8 in this minibook, you see how to add various elements to your pages.

					

				
					Figure 1-1: A sample page layout created using InDesign CS6.

				

					[image: 9781118168608-fg020101.tif]

				Creating a new publication

				After you launch InDesign, you can create a new InDesign document. Just follow these steps to create a new publication:

					1.	Choose File⇒New⇒Document.

						The New Document dialog box opens, as shown in Figure 1-2.

					2.	Select whether you’re designing a Print, Web, or Digital Publishing (digital document) from the Intent drop-down menu.

					3.	Enter a value in the Number of Pages text field for the number of pages in the document.

						This value can be between 1 and 9999. If you aren’t sure how many pages will be in your document, take a guess. You can easily add pages later using the Pages panel. (See the section, “Pages panel,” later in this chapter.)

					4.	For this example, select the Facing Pages check box to have the pages arranged as spreads with left and right pages.

						With this option selected, pages in your document are arranged in pairs, so you have spreads, which are facing or adjacent pages in a layout. For example, you select this option if you’re creating a publication that will be arranged like a book or magazine. If you deselect this option, pages are arranged individually, which is a good choice for a single-page flyer or a document with only a front and back side.

					

				
					Figure 1-2: Setting up a new document with InDesign CS6.

				

					[image: 9781118168608-fg020102.eps]

					5.	Choose a page size for the document from the Page Size drop- down list.

						The page size should be set to the size of paper you intend to print on or the size at which the content will be displayed. The Width and Height values below this drop-down list change, depending on the size you choose.

						You can also enter your own settings to create a custom size. The Orientation setting changes from Portrait (tall) to Landscape (wide) based on the settings you enter in the Width and Height fields of the Page Size section.

				[image: tip.eps]		The Intent selection you make determines the choices in the Page Size drop-down list. If you select Web for the Intent, you can choose from various screen resolutions, whereas if you select Digital Publishing, you can select from various popular tablet sizes, such as the iPad, NOOK,  or Kindle.

				[image: tip.eps]		You can enter page sizes using most common forms of measurement or just use the appropriate abbreviation. For example, you enter 8 in for 8 inches or 15 cm for 15 centimeters. You can use most forms of measurement in all InDesign dialog boxes and panels; just make sure to specify the form of measurement you want to use. When creating web or digital documents, these values switch to pixels.

					6.	Choose a number for the columns on the page.

						This step creates guides for columns that do not print or display in  the completed project. These guides help you organize your pages as you create them. You can also enter a value in the Gutter field, which specifies the space between each of the columns. For more information about using columns in page layout, see Chapter 3 of this minibook.

					7.	Choose values for the page margins.

						Notice the Make All Settings the Same button, which is a chain icon, in the middle of the four text fields where you enter margin values. Click this button to set all margins to the same value.

						If you see Top, Bottom, Inside, and Outside, you’re specifying margins for a page layout that has facing pages, which you specified earlier. If you see Top, Bottom, Left, and Right, you’re creating a page layout without facing pages. The inside margins refer to the margins at the middle of the spread, and the outside margins refer to the outer left and right margins of a book or magazine. You can set the Inside setting to accommodate the binding of a book, which may need wider margins than the outside.

				[image: tip.eps]		If you use the same settings repeatedly, saving those settings as a preset is a good idea. Get your settings the way you want them, and then click the Save Preset button in the New Document dialog box before you click OK. Enter a name for the preset, and then click OK. After you save your settings, you can select settings from the Document Preset drop-down list (refer to the top of Figure 1-2) whenever you create a new document.

					8.	When you’re finished, click OK.

						After you click OK in the New Document dialog box, the new document is created with the settings you just specified.

				Margins, columns, orientation, and page size are discussed in more detail in Chapter 3 of this minibook.

				Opening an existing publication

				You may have InDesign files on your hard drive that you created or have saved from another source. To open existing InDesign documents (files that end with .indd), follow these steps:

					1.	Choose File⇒Open.

						The Open dialog box appears.

					2.	Browse your hard drive and select a file to open.

						Select a file by clicking the document’s title. To select more than one document, press Ctrl ([image: maccmd] on the Mac) while you click the filenames.

					3.	Click the Open button to open the file.

						The file opens in the workspace.

				Looking at the document setup

				If you need to change the size of your pages or the number of pages in a document that’s already open in the workspace, you can make those changes in the Document Setup dialog box. To access and modify settings in the Document Setup dialog box, follow these steps:

					1.	Choose File⇒Document Setup.

						The Document Setup dialog box opens.

						Note: You can change the value in the Number of Pages text field if you need the number of pages in your document to be greater than or less than the current value.

						The number of pages in your document updates after you close  this dialog box. You can also add more pages by choosing Layout⇒Pages⇒Insert Pages to insert several pages, or Layout⇒Pages⇒Add Page to add a single page, or by using the Pages panel.

					2.	Select a new option from the Page Size drop-down list or manually enter values into the Width and Height text fields to change the  page size.

						You can also click the up and down arrows in the Width and Height text fields to choose a new value.

					3.	Click the Portrait or Landscape button to change the page orientation.

						The page orientation updates in the workspace after you close this dialog box.

					4.	Click OK when you finish changing your document setup.

						The modifications are applied to the open document.

				[image: tip.eps]		If you make changes to the Document Setup dialog box when you have no documents open, the changes become the default settings for all new documents you create.

				Touring the Workspace

				Just like the other applications in the CS6 Suite, InDesign has a standardized layout. Using panels that can be docked and a single-row Tools panel, you can keep much more space open in your work area.

				The InDesign workspace, or user interface, includes a large number of tools and panels — but most users use only a few. You’ll likely use several panels over and over again, so you should keep them easily accessible. In the default user workspace, many of these panels are already docked to the right. Figure 1-3 shows how the InDesign workspace layout looks on a Windows computer. The Windows workspace is nearly identical to the Macintosh version of InDesign.

					

				
					Figure 1-3:  The InDesign Windows default workspace.

				

					[image: 9781118168608-fg020103.eps]

				Here are the elements that create the InDesign workspace:

				[image: check.png] Page: The main area of the InDesign workspace is a page. It’s the area that’s printed or exported when you finish making a layout.

				[image: check.png] Master pages: You can define how certain text elements and graphics appear in an entire document (or just portions of it) by using a master page. It’s much like a template for your document because you can reuse elements throughout the pages. For example, if you have an element you want on each page (such as page numbering), you can create it on the master page. If you need to change an element on the master page, you can change it at any time and your changes are reflected on every page that the master page is applied to. You access master pages in the Pages panel. (You find out more about master pages in Chapter 3 of this minibook.)

				[image: check.png] Spread: A spread refers to a set of two or more pages that will be printed side by side. You usually see spreads in magazines and books when you open them — just like the book you’re holding now. If your document has only a single page — front and back, or with only one side — you will not see a spread in the InDesign document window. InDesign will display only the one page, or, for a two-sided page, both pages (if you reduce the magnification).

				[image: check.png] Pasteboard: The pasteboard is the area around the edge of a page. You can use the pasteboard to store objects until you’re ready to put them into your layout. Pasteboards aren’t shared between pages or spreads. For example, if you have certain elements placed on a pasteboard for pages 4 and 5, you can’t access these elements when you’re working on pages 8 and 9 — so each page or spread has its own pasteboard.

				Tools

				The Tools panel is where you find tools to edit, manipulate, or select elements in your document, as well as tools to make adjustments to pages. Simply use the cursor and click a tool to select it. See Figure 1-4 for the default Tools panel layout.

				[image: tip.eps]	If you decide that a single row of tools just isn’t for you, you can go back to an older version’s Tools panel by clicking the two arrows in the gray bar at the top of the Tools panel. If you want to relocate the tools, click the silver bar at the top of the tools, under the double arrows, and drag the tools panel to a new location.

				You find out more about these tools and how to use them in the related chapters of this minibook. For example, we discuss the drawing tools in Chapter 4 of this minibook.

					

				
					Figure 1-4:  The Tools panel contains tools for creating, selecting, and editing elements and adjusting pages.
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				With the tools in the Tools panel, you can do the following:

				[image: check.png] Create stunning new content on a page using drawing, frame, and  text tools.

				[image: check.png] Select existing content on a page to move or edit.

				[image: check.png] View the page in different ways by moving (panning) and magnifying the page or spread.

				[image: check.png] Edit existing objects, such as shapes, lines, and text. Use the Selection tool to select existing objects so that you can change them.

				When a tool has a small arrow next to the button’s icon, more tools are hiding behind it. When you click the tool and hold down the mouse button, a menu opens that shows you other available tools. While pressing the mouse button, move the cursor to the tool you want and release the mouse button after it’s highlighted.

				Menus

				The menus on the main menu bar are used to access some of the main commands and control the user interface of InDesign. They also allow you to open and close panels used to edit and make settings for the publication.

				InDesign menu commands such as New, Open, and Save are similar to most other applications you’re probably familiar with. The InDesign menus also include commands that are especially used for page layout, such as Insert with Placeholder Text. For more information on using menus, see Book I, Chapter 2. Remember to refer to the common commands and shortcuts that are also detailed in that chapter.

				The InDesign main menu has the following options:

				[image: check.png] File: This menu includes some of the basic commands to create, open, and save documents. It also includes the Place command to import new content and many options to control document settings, exporting documents, and printing.

				[image: check.png] Edit: You can access many commands for editing and controlling selections in this menu — such as copying and keyboard shortcuts. The dictionary and spell checker are on this menu, too.

				[image: check.png] Layout: Use this menu to create guides. These options help you lay elements on the page accurately and properly align them. Use the menu to navigate the document’s pages and spreads.

				[image: check.png] Type: From this menu, you can select fonts and control characters in the layout. You can access the many settings related to text from this menu, which opens the associated panel where you make the changes.

				[image: check.png] Object: You can modify the look and placement of objects on the page with this menu. Which options are available on this menu depends on which element you’ve selected in the workspace, such as a text field or an image.

				[image: check.png] Table: Use this menu to create, set up, modify, and control tables on  the page.

				[image: check.png] View: You can modify the view of the page from this menu, including zooming in and out, as well as work with guides, rulers, or grids to help you lay out elements.

				[image: check.png] Window: Use this menu to open and close panels or switch between open documents.

				[image: check.png] Help: This menu is where you can access the Help documents for InDesign and configure any plug-ins you have installed.

				Panels

				In the default layout, you see a large area for the document. To the right of the document are several panels that snap to the edge of the workspace —  panels that are attached to the edge of the workspace are considered docked. Panels are used to control the publication and edit elements on pages. Panels can be maximized, minimized, moved around, or closed  altogether.

				To expand a panel, you can simply click the panel name and it expands. The panels you expand are automatically collapsed again when a different panel is selected.

				If you’d rather work with all panels expanded, simply click the left-facing double arrows on the gray bar above the panels. You can collapse all the panels again by clicking the right-facing double arrows on the gray bar above the expanded panels.

				Even though some InDesign panels perform different functions, similar panels are grouped together depending on what they’re used for. You can change the groupings by clicking and dragging a panel’s tab into another grouping.

				Some panels change when you’re manipulating specific types of content on an InDesign page. Throughout Chapters 2 through 8 of this minibook, you discover these specific panels as you create layouts. For now, we briefly show you two general InDesign panels: Control and Pages.

				Control panel

				The Control panel is used to edit just about any element you have selected in InDesign, as shown for the Type tool in Figure 1-5. This panel is context sensitive, so it changes depending on which element you’ve selected on a page. For example, if you have selected text on the page, the Control panel displays options allowing you to edit the text. If you have a shape selected, the panel displays options allowing you to modify the shape.

					

				
					Figure 1-5: The Control panel, when the Type tool is active.
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				Figure 1-6 shows the Control panel when a frame is selected using the Selection tool. The Control panel menu allows you to select options for the frame.

					

				
				
					Figure 1-6: The Control panel, when a frame is selected using the Selection tool.
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				Pages panel

				You can control pages by using the Pages panel, as shown in Figure 1-7. This panel allows you to arrange, add, and delete pages in your document. If you are creating electronic documents, you can also use the pages panel for creating alternate layouts for vertical and horizontal displays on a tablet. You can also navigate among pages with this panel, which we discuss further in Chapter 3 of this minibook.

				[image: tip.eps]	You can also add and delete pages by choosing Layout⇒Pages, and  even use a keyboard shortcut to add pages, Ctrl+Shift+P (Windows) or [image: maccmd]+Shift+P (Mac).

					

				
					Figure 1-7: Use the Pages panel to add, delete, and move pages, as well as create alternate layouts for tablet displays.

				

					[image: 9781118168608-fg020107.eps]

				[image: remember.eps]	You can hide all open panels (including the Control panel) by pressing the Tab key; press Tab for them to return to view. In InDesign CS6, you can leave tools and panels hidden and access them when you want by moving the cursor to the left or right side of the work area. Pause when you see a tinted vertical gray bar appear, and the tools or panels (depending on which side of the workspace you’re in) reappear! By the way, they go away again after you leave the area.

				You can navigate the document’s pages by using the left- and right-arrow buttons on either side of the page number in the lower-left corner of the document window. You can also move to a specific page by entering a page number into the page field and pressing Enter or by selecting the page from the drop-down list in the lower-left corner of the document window.

				Contextual menus

				Contextual menus (or context menus) are menus that pop up when you right-click (Windows) or Control-click (Mac) the mouse. Contextual menus change depending on which element you click and which tool you’re using. If you have no elements selected, the contextual menu opens for the overall InDesign document, allowing you to select options such as Zoom, Paste, Rulers, and Guides. If you have an element selected, your options include transforming, modifying, and editing the object.

				[image: remember.eps]	Contextual menus are context sensitive (hence the name!). Remember to select an element on the page before you right-click or Control-click to open the contextual menu. If you don’t select the object first, the menu that displays is for the document instead of for an object.

				You can find out more about editing and transforming elements in Chapters 2 and 3 of this minibook.

				Setting Up the Workspace

				Workspace settings are important because they help you quickly create the type of layout you need. Overall document settings control elements such as grids or guides that help you align elements on the page. Neither guides nor grids print when you print your document.

				Showing and hiding grids and guides

				Grids and guides are onscreen lines that help you with your layout but that, by default, don’t appear when printing. A document grid is applied across the entire document page area. Use the document grid when you need to divide a document into sections to achieve your intended design. You can have objects on a page align to the document grid, which helps you accurately line-up or space objects on your page. 

				Another type of grid is the baseline grid, which runs horizontally across the page. Use the baseline grid to make sure that text in different columns is aligned, thus creating a cleaner page layout. 

				[image: remember.eps]	The document grid is used for aligning elements on the page, and the baseline grid is used for aligning the bottom of text across multiple columns.

				[image: check.png] To show or hide the document grid, choose View⇒Grids & Guides⇒Show (or Hide) Document Grid.

				[image: check.png] To show or hide the baseline grid, choose View⇒Grids & Guides⇒Show (or Hide) Baseline Grid.

				You can immediately see the difference between these two kinds of grids.

				Guides can be placed anywhere on the page (or pasteboard) and are used to accurately position objects in a layout. Unlike grids, guides are typically created individually. Use them to align specific objects — such as the tops of several images — that appear across a page. Objects can snap to guides just like they can snap to a grid.

				To create a guide and show or hide guides, follow these steps:

					1.	Make sure that rulers are visible by choosing View⇒Show Rulers.

						Rulers appear in the workspace. If you already have rulers visible, the option View⇒Hide Rulers is on the View menu. Don’t hide the rulers.

					2.	Move the cursor to a horizontal or vertical ruler.

						Make sure that the cursor is over a ruler.

					3.	Click the ruler and drag the mouse toward the page.

						A ruler guide shows on the page as a line.

					4.	Release the mouse where you want the guide.

						You just created a ruler guide!

					5.	To hide the guide, choose View⇒Grids & Guides⇒Hide Guides.

						This step hides the guide you created but doesn’t delete it. You can make the guide reappear easily in the next step.

					6.	To see the guide again, choose View⇒Grids & Guides⇒Show Guides.

						The guide you created is shown on the page again.

				[image: tip.eps]	You can edit the color of the ruler guide you created by positioning the mouse over it, clicking once to select it, and then right-clicking (Windows) or Control-clicking it (Mac) and selecting a new color from the Ruler Guides option.

				You can find out more about the different kinds of guides and how to use them in page layout in Chapter 3 of this minibook.

				[image: tip.eps]	You can also control the color of the guides and grid in your preferences. Access them by choosing Edit⇒Preferences⇒Grids (Windows) or InDesign⇒Preferences⇒Grids (Mac). When the Preferences dialog box opens, you can change the color and spacing of the lines. Click Guides & Pasteboards in the list on the left to change the color settings for guides.

				Snapping to a grid or a guide

				You can have elements on the page snap to a grid or a guide. Grid or guide snapping is useful so that you don’t have to eyeball the alignment of several elements to one another, because they’re precisely aligned to a grid or guide. To make sure that this setting is enabled, choose View⇒Grids & Guides⇒Snap to Document Grid or View⇒Grids & Guides⇒Snap to Guides. If these options are already selected, clicking them will turn them off.

				Using Smart Guides

				Give yourself an added hand when aligning objects on the InDesign page with Smart Guides. Illustrator and Photoshop users may be familiar with these interactive guides, but if you’re not, read on to discover how you can take advantage of them.

				You can experiment with this capability by creating two objects in an InDesign document. It doesn’t matter which object or shape — any will do!

				With the Selection tool, click and slowly drag one object in a circular motion around the other. You’ll notice guides appear and disappear, indicating when the objects are aligned either on the top, center, or bottom of the other object, as shown in Figure 1-8.

					

				
					Figure 1-8:  Click and drag one shape around another to see the interaction with Smart Guides.

				

					[image: 9781118168608-fg020108.tif]

				As a default, pink guides appear when you align an object with the center of the page, as shown in Figure 1-9.

					

				
					Figure 1-9: Know when your object is at the exact center of the page when a guide crosshair appears.

				

					[image: 9781118168608-fg020109.tif]

				[image: tip.eps]	You can see a print preview of your document by clicking the Preview Mode button at the bottom of the Tools panel. When you click this button, all object bounding boxes, guides, and the grid disappear.

				Customizing menus

				InDesign has many menus and many choices under each menu. It’s likely you’ll need to use only some of these menu choices. If you discover that you’re wading through many menu items to find the items you need, you can customize InDesign to hide menu items you don’t use.

				To customize your InDesign menus, follow these steps:

					1.	Choose Edit⇒Menus.

						The Menu Customization window opens.

					2.	In the Application Menu Command column, click the triangle next to the menu(s) you want to customize.

						For example, if you never expect to import XML, which is located under the File menu, click the triangle to the left of the File menu to display this menu item. 

					3.	Click the eye icon next to the menu item that you want to hide.

						Or if you want to highlight a menu item, click the color column to the right of the eye icon to add a color to the menu choice.

					4.	Click the Save As button at the top of the window to save the menu customization set. Enter a name for your customized menu set, click OK to save the name, and then click OK again to close the Menu Customization window.

						The customized menus are saved. To return to the original default menus, or to further customize the menus, choose Edit⇒Menus at any time you’re working using InDesign.

				Saving a custom workspace

				You’ve seen that InDesign has a number of panels. If you find that you’re using some panels more than others, you can have InDesign remember the grouping of panels you use most frequently, including which ones are visible and which ones are hidden — InDesign calls this a workspace. The next time you want a certain group of panels open together, you can return to the workspace you previously saved. The workspace isn’t attached to a particular document, so you can have one workspace for editing text and another for working with a layout.

				To save a custom workspace, follow these steps:

					1.	Have the InDesign workspace configured in the way you want to save it — with any panels open that you might want to access together.

						The open panels will be saved as a custom workspace.

					2.	Choose Window⇒Workspace⇒New Workspace.

						The New Workspace dialog box opens.

					3.	Choose whether to save the panel menu locations or any menus that have been customized. Type a new name for the workspace in the Name text field.

						Enter a name that reflects the type of work you do in that workspace, such as text editing or layout.

					4.	Click OK.

						The custom workspace is saved. The name you entered for your workspace is displayed on the Workspaces menu.

				To access your workspace, choose Window⇒Workspace⇒Your Workspace (where Your Workspace is the name you gave the workspace in Step 3).

				You can delete the workspace if you no longer want it saved. Simply choose Window⇒Workspace⇒Delete Workspace.

				Working with Documents

				After you’re comfortable getting around the InDesign workspace, you’re ready to begin working with a new document. After you’ve started working on a document, you should find out how to import content from other programs and to save that document on your hard drive. A lot of the content you use when creating layouts with InDesign is imported from other programs — both Creative Suite applications like Photoshop and Illustrator, and non-Creative Suite applications like Microsoft Word and Excel. You use InDesign to organize, modify, and integrate text and graphics into a layout. To begin, we show you the steps needed to import content and save new files.

				We show you how to open new and existing documents earlier in this chapter, in the sections “Creating a new publication” and “Opening an existing publication.”

				[image: technicalstuff.eps]	You may also be working with a template, which is a layout you reuse by applying it to a document that requires a particular predesigned format. For example, a company may use a template for its official letterhead because every new letter requires the same page format and design. InDesign templates use the .indt file extension.

				Importing new content

				You can use many different kinds of content in an InDesign document because you can import many supported file types. You can import text, formatted tables, and graphics that help you create an effective layout. This capability makes integration with many different programs easy.

				Follow these steps to import an image file into InDesign (in this example, we import a bitmap graphic file):

					1.	Choose File⇒New⇒Document.

						The New Document dialog box appears.

					2.	Review the settings, make any changes depending upon the size and type of document you want to create, and then click OK.

						A new document opens. Feel free to alter the settings to change the number of pages, page size, and intent before clicking OK.

					3.	Choose File⇒Place.

						The Place dialog box opens, enabling you to browse the contents of your hard drive for supported files. If you were to select the Show Import Options check box, another dialog box opens before the file imports. Leave this option deselected for now.

					4.	Click the file you want to import, and then click Open.

						Certain files, such as bitmap photo, graphic, and PDF files, show a thumbnail preview at the bottom of the dialog box.

						When you click Open, the Place dialog box closes and the cursor becomes an upside-down L.

					5.	Click the location on the page where you want the upper left corner of the imported file (for example, an image) to appear.

						The imported file is placed on the page.

				[image: tip.eps]	Click and drag to place the file into a specific frame size, or if you’ve created an empty frame on the page, clicking on top of the frame causes the object being imported — whether it’s text or an image — to be placed inside the frame.

				[image: tip.eps]	You can Ctrl-click (Windows) or [image: maccmd]-click (Mac) to place multiple files. After you select the images and click OK, each click places an image on the page, or you can hold down the Shift+Ctrl (Windows) or Shift+[image: maccmd] (Mac) while dragging a rectangle to have all selected images placed, spaced evenly, in a grid.

				Note that when you’re placing multiple images, you can see a thumbnail of each image before it’s placed. You can also scroll through the loaded images by pressing the arrow keys on your keyboard.

				For general information about importing and exporting using the Adobe Creative Suite, check out Book I, Chapter 5. For more information on importing different kinds of file formats, such as text, images, spreadsheets, and PDFs, see Chapters 2 and 3 in this minibook.

				Viewing content

				You can view elements in several different ways on your document’s pages. For example, sometimes you need to see objects on a page close up so  that you can make precise edits. InDesign offers several ways to navigate documents:

				[image: check.png] Scroll bars: You can use the scroll bars to move pages around.  The scroll bars are located below and to the right of the pasteboard. Click a scroll bar handle and drag it left and right or up and down.

				[image: check.png] Zoom: Zoom in or out from the document to increase or decrease the display of your document. Select the Zoom tool (the magnifying glass icon) from the Tools panel and click anywhere on the page to zoom in. Press the Alt (Windows) or Option (Mac) key and click to zoom out.

				[image: check.png] Hand tool: Use the Hand tool to move the page around. This tool is perhaps the best and quickest way to move pages around and navigate documents. Select the Hand tool by pressing the spacebar and then click and drag to move around the pasteboard.

				[image: check.png] Keyboard: Press Ctrl++ (plus sign) or [image: maccmd]++ (plus sign) to zoom in using the keyboard; replace the plus sign with the minus sign to zoom out.

				Saving your publication

				Even the best computers and applications fail from time to time, so you don’t want to lose your hard work unnecessarily. Saving a publication often is important so that you don’t lose any work if your computer or software crashes or the power goes out.

				To save a file, choose File⇒Save or press Ctrl+S (Windows) or [image: maccmd]+S (Mac).

				You may also want to save different versions of your files. You may want to do this if you’re experimenting with different design options, for example, and you want to retain earlier versions of your files. To do this, use the Save As command, which makes creating different versions of documents easy.

				[image: remember.eps]	Choose File⇒Save before proceeding if you want the current document to save the revisions you’ve made since you last saved the file. All new additions to the document are made in the new version of the file.

				To save a new version of the current document and then continue working on the new document, follow these steps:

					1.	Choose File⇒Save As.

						The Save As dialog box opens.

					2.	Choose the directory you want to save the file in.

					3.	In the File Name text field, enter a new name for the document.

						This step saves a new version of the file. Consider a naming scheme  at this point. If your file is myLayout.indd, you might call it my Layout02.indd to signify the second version of the file. Future  files can then increase the number for each new version.

					4.	Click the Save button when you’re finished.

						This step saves the document in the chosen directory with a new name.

				The File⇒Save As command is also used for other means. You may want to save your design as a template. After you create the template, choose File⇒Save As, and then choose InDesign CS6 Template from the Save As Type (Windows) or Format (Mac) drop-down list.

				You can also choose File⇒Save a Copy. This command saves with a new name a copy of the current state of the document you’re working on, but you then continue working on the original document. Both commands are useful for saving incremental versions of a project you’re working on.

				To find out more about working with files, go to Chapter 7 of this minibook.

			

			
		

	
		
			
				Chapter 2: Working with  Text and Text Frames

				In This Chapter

				[image: check.png] Understanding text and frames in a publication

				[image: check.png] Adding and importing text

				[image: check.png] Exploring text frame options

				[image: check.png] Changing paragraph settings

				[image: check.png] Editing with text editors and spell checking

				[image: check.png] Working with tables

				[image: check.png] Creating and editing text on a path

				Most of the documents you create contain text, so it’s important to know how to format, style, and control text in your layouts. Text is made up of characters, and the characters are styled in specific fonts. If you want to find out more about fonts and typefaces, check out Book I, Chapter 6.

				This chapter explains how to create, edit, and style text by using InDesign. You get started by editing and manipulating text placed inside text frames — containers on the page that hold text content. The most important concepts you can take away from this chapter are how to add text to documents and then change the text so that it looks the way you want on the page. In Chapter 3 of this minibook, find out how to create effective layouts that contain both text and graphics so that your audience is encouraged to read everything you create.

				Understanding Text, Font, and Frames

				Text is usually integral to a publication because it contains specific information you want or need to convey to an audience. Understanding the terminology that appears in the following pages is important. Text and font are quite different from each other:

				[image: check.png] Text: The letters, words, sentences, and paragraphs making up content in the text frames in your publication.

				[image: check.png] Font: The particular design forming a set of characters used to style text. You can find thousands of styles of fonts from many manufacturers, and many are included in the Creative Suite 6 when you install it on your computer.

				Frames resemble containers that are used to hold content. You can use two kinds of frames in a publication:

				[image: check.png] Text: Contains text on the page in your InDesign document. You can link text frames so that text flows from one text frame to another, and you can have text wrap around graphic frames.

				[image: check.png] Graphic: Holds an image that you place in your publication.

				When you create frames using InDesign, they can contain either text or graphics — so the methods for creating both types of frames are identical. InDesign automatically changes frames to adapt to content, so you can use both the frame and shape tools for designing your layout and creating frames that will contain text or graphics.

				Creating and Using Text Frames

				Text frames contain any text you add to a publication. You can create a new text frame in many different ways. In InDesign, you can add text to creative shapes you draw, thereby changing them into text frames. Creating and using text frames in a publication is important because you typically use a lot of text. Throughout the following subsections, we show you how to create text frames in different but important ways using three different tools. If you need a guide to the tools, check out Chapter 1 of this minibook.

				[image: tip.eps]	Text frames are sometimes automatically created when you import text into a publication. You find out how to do this in the “Importing text” section, later in this chapter.

				Creating text frames with the Type tool

				You can use the Type tool to create a text frame. If you use the Type tool and click the page, nothing happens unless you’ve first created a frame to hold the text. Here’s how to create a text frame by using the Type tool:

						1.	[image: 9781118168608-ma120.tif] Select the Type tool in the Tools panel and place the tool over the page.

						The Type tool cursor is an I-bar. Move the cursor to the spot where you want to place the upper-left corner of the text frame.

					2.	Drag diagonally to create a text frame.

						When you click, the mouse has a cross-like appearance. When you drag, an outline of the text frame appears, giving you a reference to its dimensions, as shown in Figure 2-1.

					

				
					Figure 2-1: Using the Type tool, drag to create a text frame.

				

					[image: 9781118168608-fg020201.tif]

					3.	Release the mouse button when the frame is the correct size.

						The text frame is created and an insertion point is placed in the upper left corner of the frame. You can start typing on the keyboard to enter text or import text from another source. (See the later section, “Importing text.”)

				Creating text frames with the Frame tool

				You can use the Frame tool to create frames that are rectangular, oval, or polygonal. Then, after you’ve placed the frame on the page, you can turn it into a text frame or use it as a graphic frame or simply a design object on the page. To create a new text frame with the Frame tool, follow these steps:

					1.	Choose the Frame tool from the Tools panel and drag diagonally to create a new frame.

						A new frame is created on the page.

					2.	Select the Type tool and click inside the frame.

						The X across the frame disappears, and the frame is now a text frame instead of a graphic frame.

					3.	Choose the Selection tool and use it to move the text frame.

						You can move the text frame if you click within the frame using the Selection tool and drag it to a new location.

				Creating text frames from a shape

				If you have an interesting shape that you’ve created with the drawing tools or copied and pasted from Illustrator, you can easily change the shape into a text frame so that it can be filled with text. Just follow these steps:

					1.	Use the Pen tool, Pencil tool, or a Shape tool to create a shape with a stroke color and no fill. Or, copy and paste artwork from Illustrator.

						A shape is created on the page that doesn’t have a solid color for the fill. 

					2.	Select the Type tool from the Tools panel.

						The Type tool becomes active.

					3.	Click inside the shape you created in Step 1 and enter some text or import text. (See the section “Importing text,” later in this chapter.)

						This step changes the shape into a text frame. Notice how the text is confined within the shape as you type.

				Adding Text to Your Publication

				In the previous section’s step lists, you find out how to add text by simply clicking in the text frame and typing new content, but you can also add text to publications in other ways. Doing so is particularly useful when you use other applications to create and edit documents containing text.

				Importing text

				You can import text you’ve created or edited using other software, such as Adobe InCopy or Microsoft Word or Excel. Importing edited text is a typical workflow activity when creating a publication, because dedicated text- editing software is often used to edit manuscripts before layout.

				To import text into InDesign, follow these steps:

					1.	Choose File⇒Place.

						The Place dialog box opens. Choose an importable file (such as a Word document, an InCopy story, or a plain text file) by browsing your hard drive.

					2.	Select a document to import and click the Open button.

						The Place Text icon, the cursor arrow, and a thumbnail image of the text appear. Move the cursor around the page to the spot where you want the upper-left corner of the text frame to be created when the document is imported.

					3.	Click to place the imported text.

						This step creates a text frame and imports the text.

				[image: tip.eps]	If you select a text frame before importing text, the text is automatically placed inside the text frame — so, in this case, you wouldn’t have to use the cursor to place the text. You can move the text frame anywhere on the page after the text is added or resize the frame, if necessary.

				Controlling text flow

				Control the flow of the text by using these simple modifier keys while  placing text:

				[image: check.png] Choose File⇒Place, select the file you want to import, and click Open. Hold down the Shift key and, when the loaded cursor turns into a curvy arrow, click the document. The text is imported and automatically flows from one column to another or from page to page until it runs out. InDesign even creates pages, if needed.

				[image: check.png] Choose File⇒Place, select the file you want to import, and click Open. Hold down the Alt (Windows) or Option (Mac) key. Then click and drag a text area. (Don’t release the Alt key or Option key!) As you continue clicking and dragging additional text frames, your text flows from one text frame to another until you run out of copy.

				[image: tip.eps]	If you select the Show Import Options check box in the Place window, a second window appears in which you can choose to remove styles and formatting from text and tables. This action brings in clean, unformatted text  to edit.

				Adding placeholder text

				Suppose that you’re creating a publication but the text you need to import into it isn’t ready to import into InDesign — perhaps the text is still being created or edited. Rather than wait for the final text, you can use placeholder text and continue to create your publication’s layout. Placeholder text is commonly used to temporarily fill a document with text. The text looks a lot like normal blocks of text, which is more natural than trying to paste the same few words repeatedly to fill up a text frame. However, placeholder text isn’t in any particular language, because it’s just being used as filler.

				InDesign can add placeholder text into a text frame automatically. Here’s how:

					1.	Create a frame on the page by selecting the Type tool and dragging diagonally to create a text frame.

					2.	Choose Type⇒Fill with Placeholder Text.

						The text frame is automatically filled with characters and words, similar to the one shown in Figure 2-2.

					

				
					Figure 2-2:  The text frame, filled with placeholder text.

				

					[image: 9781118168608-fg020202.tif]

				Copying and pasting text

				You can move text from one application into a publication by copying and pasting the text directly into InDesign. If you select and copy text in another program, you can paste it directly into InDesign from your computer’s Clipboard. Here’s how:

					1.	Highlight the text you want to use in your publication and press Ctrl+C (Windows) or [image: maccmd]+C (Mac) to copy the text.

						When you copy text, it sits on the Clipboard (until it’s replaced by something new), and you can transfer this information into InDesign.

					2.	Open InDesign and press Ctrl+V (Windows) or [image: maccmd]+V (Mac) to create a new text frame and paste the text into it.

						A new text frame appears centered on the page with your selected text inside it.

				[image: tip.eps]	You can also click in a text frame and press Ctrl+V (Windows) or [image: maccmd]+V (Mac) to paste text from the Clipboard directly into an existing frame. You can do the same thing with an image.

				All you need to do is double-click a text frame if you want to access or edit some text or type or paste it into the frame.

				Looking at Text Frame Options

				In the previous sections of this chapter, we show you how to create text frames and enter text into them. In the following sections, we show you how to organize text frames in your publication and achieve the results you need. Controlling text frames so that they do what you need them to do is a matter of knowing how they work after you put text in them.

				InDesign gives you a lot of control over the text in your publications. Changing text frame options allows you to change the way text is placed inside a frame. Changing these kinds of settings is sometimes important when you’re working with particular kinds of fonts. (To read more about fonts, check out Book I, Chapter 6.)

				The text frame contextual menu contains many options for working with the text frame. You use this menu to perform basic commands, such as copy and paste, fill the text frame with placeholder text, make transformations, add or modify strokes, and change the frame type. Access the text frame contextual menu by right-clicking (Windows) or Control-clicking (Mac) a text frame. You can also find most of these options on the Type and Object menus.

				Changing text frame options

				To change text frame options that control the look of the text within the frame, follow these steps:

					1.	Create a rectangular text frame on the page, select the frame, and choose Object⇒Text Frame Options.

						You can also press Ctrl+B (Windows) or [image: maccmd]+B (Mac) or use the text frame’s contextual menu to open the Text Frame Options dialog box.

						You can tell that a text frame is selected when it has handles around its bounding box.

						The Text Frame Options dialog box appears, showing you the current settings for the selected text frame.

					2.	Select the Preview check box to automatically view updates.

						Now any changes you make in the dialog box are instantly updated on the page, so you can make changes and see how they’ll look before you apply them.

					3.	In the Inset Spacing area of the dialog box, change the Top, Bottom, Left, and Right values.

						These values are used to inset text from the edges of the text frame. The text is pushed inside the frame edge by the value you set.

						You can also indent text, which we discuss in the section “Indenting your text,” later in this chapter. You can choose in this dialog box how to align the text vertically (Top, Center, Bottom, or Justify). You can align the text to the top or bottom of the text frame, center it vertically in the frame, or evenly space the lines in the frame from top to bottom (Justify).

					4.	When you finish making changes in this dialog box, click OK.

						The changes you made are applied to the text frame.

				Using and modifying columns

				You can specify that the document contain a certain number of columns on the page when you create a new publication. Using columns allows you to snap new text frames to columns so that they’re properly spaced on the page. You can even modify the size of the gutter, which is the spacing between columns.

				You can also create columns within a single text frame by using the Text Frame Options dialog box. You can add as many as 40 columns in a single text frame. If you already have text in a frame, it’s automatically divided among the columns you add. You can choose from three types of columns when creating a layout with text using InDesign:

				[image: check.png] Use Fixed Number when you know exactly how many columns you want to appear in a text frame.

				[image: check.png] Use Fixed Width when you know the exact width of columns that will appear in a text frame. If the text frame becomes larger or smaller, the number of columns may increase or decrease.

				[image: check.png] Use Flexible Width if you want the width of columns to vary depending upon the size of the text frame. With Flexible Width, InDesign adds or reduces the number of columns as needed depending upon the width of the text frame.

				The following steps show you how to add columns to a text frame on a page:

					1.	Create a rectangular text frame on the page.

						Use the Text or Frame tool to create the text frame. You can create columns in text frames that are rectangular, oval, or even freehand shapes drawn on the page.

					2.	After you create the text frame, the cursor is automatically placed inside of the frame, and you can now enter some text.

						You can type some text, paste text copied from another document, or add placeholder text by choosing Type⇒Fill with Placeholder Text.

					3.	With the text frame still selected, choose Object⇒Text Frame Options.

						In the Text Frame Options dialog box that opens, you may wish to select the Preview check box to immediately view the changes your settings make to the frame on the page.

					4.	In the Columns section, change the value in the Number text field.

						In this example, we entered 2 in the Number text field. The selected text frame divides the text in the frame into two columns. If you selected the Preview checkbox, when you click in a different text field in the dialog box, the text frame updates on the page to reflect the new value setting.

					5.	Change the width of the columns by entering a new value in the Width text field.

						The width of the columns is automatically set, depending on the width of the text frame you created. We entered 10 (picas) in the Width text field for this example. The text frame changes size depending on the width you set in this column. 

					6.	Change the value in the Gutter text field.

						The gutter value controls the amount of space between columns. If the gutter is too wide, change the value in the Gutter text field to a lower number. We entered 0p5 in the Gutter text field for this example to change the gutter width to half a point.

					7.	When you finish, click OK to apply the changes.

						The changes are applied to the text frame you modified.

				After you create columns in a text frame, you can resize the frame by using the handles on its bounding box, detailed in the later section “Resizing and moving the text frame.” The columns resize as necessary to divide the text frame into the number of columns you specified in the Text Frame Options dialog box. If you select the Fixed Column Width check box in the Text Frame Options dialog box, your text frames are always the width you specify, no matter how you resize the text frame. When you resize the text frame, the frame snaps to the designated fixed width.

				[image: tip.eps]	You can also change the number of columns in the Control panel after selecting the text frame with the Selection tool, or by using the paragraph options in the Control panel while using the Type tool.

				Modifying and Connecting Text Frames on a Page

				Making modifications to text frames and then connecting them to other text frames in a publication so that the story can continue on a separate page is vital in most publications. You typically work with stories of many paragraphs that need to continue on different pages in the document.

				When you have a text frame on the page, you need to be able to change the size, position, and linking of the frame. You need to link the frame to other frames on the page so that the text can flow between them — which is important if you’re creating a layout that contains a lot of text.

				If you paste more text content than is visible in the text frame, the text still exists beyond the boundaries of the text frame — so if you have a text frame that’s 20 lines tall but you paste in 50 lines of text, the last 30 lines are cropped off. You need to resize the text frame or have the text flow to another frame in order to see the rest of the text you pasted. You can tell that the frame has more content when you see a small plus sign (+) in a special handle in the text frame’s bounding box.

				Resizing and moving the text frame

				When creating layouts, you regularly resize text frames and move them around the document while you figure out how you want the page layout to look. You can resize and move a text frame by following these steps:

					1.	Use the Selection tool to select a text frame on the page.

						A bounding box with handles appears on the page. If the text frame has more text than it can show at the current size, a small red box with a red plus sign appears in the lower right corner of the bounding box. 

					2.	Drag one of the handles to resize the text frame.

						The frame updates automatically on the page while you drag the handles, as shown in Figure 2-3. Change the width or height by dragging the handles at the center of each side of the frame, or change the height and the width at the same time by dragging a corner handle.

						Shift-drag a corner handle to scale the text frame proportionally.

					3.	When you’re finished resizing the text frame, click the middle of a selected frame and move it around the page.

						If you click within the frame once and drag it, you move the frame around the page. An outline of the frame follows the cursor and represents the spot where the frame is placed if you release the mouse button. Simply release the frame when you finish moving it.

					

				
					Figure 2-3: Resize a text frame by dragging its handles.

				

					[image: 9781118168608-fg020203.tif]

				[image: remember.eps]	If you’re using guides or grids on the page, the text frame snaps to them. Also, if you opened a document with columns, the text frame snaps to the columns when you drag the frame close to the column guidelines. You can find out about guides, grids, and snapping in Chapter 3 of this minibook.

				You can also use the Transform panel to change the location and dimensions of a text frame. If the Transform panel isn’t already open, choose Window⇒Object and Layout⇒Transform to open it. Then follow these steps:

					1.	Change the values in the X and Y text fields.

						Enter 1 in both the X and Y text fields to move the text frame to the upper-left corner of the page.

						The X and Y coordinates (location) of the text frame update to 1,1. The small square in the middle or along the edge of the text is the reference point of the text frame: The X and Y coordinates you set match the position of this point.

					[image: 9781118168608-ma007.tif]		Change the reference point by clicking any point in the reference point indicator in the upper left corner of the control panel.

					2.	Change the values in the W and H text fields.

						For this example, we entered 35 (picas) in the W and H text fields. The text frame’s width and height change to the dimensions you specify. Using the Transform panel to change the width and height is ideal if you need to set an exact measurement for the frame.

				[image: tip.eps]	You can not only resize and move text frames but also change their shapes. Select a text frame and choose the Direct Selection tool from the Tools panel. You can then select the corners on the text frame and move them to reshape the text frame.

				Threading text frames

				Understanding how to thread text frames together is important if you plan to build page layouts with a lot of text. Threading occurs when text frames are arranged so that the text in one frame continues in a second text frame. Threading is useful for most layouts because you can’t always include all text in a single frame.

				First, take a look at some of the related terminology because Adobe has given some special names to text frames that are linked. Figure 2-4 shows some of the icons we refer to in the following list:

					

				
					Figure 2-4: Threaded text between two linked text frames.

				

					[image: 9781118168608-fg020204.eps]

				[image: check.png] Flowing: Describes text starting in one frame and continuing in a second frame.

				[image: check.png] Threading: Describes two text frames that have text flowing from the first frame to the second.

				[image: check.png] Story: The name of a group of sentences and paragraphs in threaded text frames.

				[image: check.png] In port: An icon on the upper-left side of a text frame’s bounding box indicating that a frame is the first one in a story or has text flowing in from another frame. An In port icon has a story flowing into it if it contains a small arrow; otherwise, the In port icon is empty.

				[image: check.png] Out port: An icon on the lower-right side of the text frame’s bounding box indicating that a frame has text flowing out of it. The Out port icon contains a small arrow if the frame is threaded to another frame; an empty Out port icon signifies that the frame isn’t connected to another text frame.

						If a text frame isn’t connected to another frame and has overset text (more text than can be displayed in a text frame), the Out port shows a small red plus sign (+) icon.

				Find a block of text that you want to thread (for best results, use one that has formed sentences as opposed to placeholder text), and then follow these steps:

					1.	Copy some text on the Clipboard, such as from the InDesign Help files, a page loaded in a web browser window, or a Word, Notepad, or SimpleText document.

						The type of content you’re pasting doesn’t matter. You only need to make sure the text is at least a few paragraphs long so that you have enough text to flow between frames.

						In Figure 2-4, you can see the text thread represented by a line connecting one text frame to another. InDesign shows you text threads if you choose View⇒Extras⇒Show Text Threads.

					2.	Use the Type tool to create two text frames on a page.

						The text frames can be above or beside one another, similar to the layout shown in Figure 2-5.

					

				
					Figure 2-5: Two frames on the page; the first contains text.

				

					[image: 9781118168608-fg020205.tif]

					3.	Using the Text tool, click in the first text frame, which is above or to the left of the second text frame.

						The blinking insertion point that appears in the first text frame lets you know that you can enter or paste text into the frame.

					4.	Press Ctrl+V (Windows) or [image: maccmd]+V (Mac) to paste the text into the text frame.

						The text you’ve copied to the Clipboard enters into the frame. If you’ve pasted enough text, you see the overset text icon (a red plus sign) on the lower right side of the text frame. (Refer to Figure 2-5.) If you don’t see the overset text icon, use the Paste command a second time so that more text is entered into the frame.

					5.	Click the overset text icon with the Selection tool.

						The cursor changes to the loaded text icon so that you can select or create another text frame to thread the story.

					6.	Move the cursor over the second text frame and click.

						The cursor changes to the thread text icon when it hovers over the second text frame. When you click the second text frame, the two frames are threaded because the text continues in the second frame.

				You can continue creating frames and threading them. You can thread them on the same page or on subsequent pages.

				You can unthread text as well, which means that you’re breaking the link between two text frames. You can rearrange the frames used to thread text, such as changing the page the story continues on when it’s threaded to a second text frame. Break the connection by double-clicking the In port icon or the Out port icon of the text frame that you want to unthread. The frame is then unthreaded (but no text is deleted).

				[image: tip.eps]	If your document doesn’t have multiple pages in it, choose Layout⇒Pages⇒Insert Pages. Indicate the number of pages to add, and then click OK when you’re finished. Now you can click through the pages using the Page Field control at the bottom of the workspace and create a new text frame into which you can link your text.

				Adding a page jump number

				If your document has multiple pages, you can add a page jump number (text that indicates where the story continues if it jumps to a text frame on another page) to an existing file. Before you start, make sure that a story threads between text frames on two different pages, and then follow these steps:

					1.	Create a new text frame on the first page and type continued on page.

					2.	Use the Selection tool to select the text frame you just created.

					3.	Move the text frame so that it slightly overlaps the text frame containing the story.

						Let InDesign know what text frame it’s tracking the story from or to. Overlap the two text frames (and keep them overlapped), as shown in Figure 2-6, so that InDesign knows to associate these text frames (the continued-notice text frame and the story text frame) with each other.

					

				
					Figure 2-6: Slightly overlap the two text frames when creating a page jump, so that the page jump is associated with a specific story.

					
				

					[image: 9781118168608-fg020206.tif]

				[image: tip.eps]		You can then group these two text frames (so that they move together). Choose Object⇒Group with both text frames selected. (Shift-click with the Selection tool to select both text frames.)

					4.	Double-click the new text frame, which contains the text continued on page, to place the insertion point at the spot where you want the page number to be inserted.

						The page number is inserted at the insertion point, so make sure that a space appears after the preceding character.

					5.	Choose Type⇒Insert Special Character⇒Markers⇒Next Page Number.

						A number is added into the text frame. The number is sensitive to the location of the next threaded text frame, so if you move the second text frame, the page number updates automatically.

				[image: tip.eps]	You can repeat these steps at the spot where the story is continued from —  just choose Type⇒Insert Special Character⇒Markers⇒Previous Page Number in Step 5 instead.

				Understanding Paragraph Settings

				You can change the settings for an entire text frame or a single paragraph in a text frame in several ways. You can use the Paragraph panel to make adjustments to a single paragraph or to an entire text frame’s indentation, justification, and alignment. Open the Paragraph panel by choosing Window⇒Type & Tables⇒Paragraph.

				[image: tip.eps]	If you want changes in the Paragraph panel to span across all text frames you create, don’t select any paragraph or text frame before making the changes; instead, first select the entire text frame or frames on the page. Then the selections you make in the Paragraph panel affect all paragraphs in the selected text frames, not just one paragraph. If you want the selections you make in the Paragraph panel to affect just one paragraph within a text frame, select that paragraph first by using the Type tool, and then make  your changes.

				Indenting your text

				You can indent a paragraph in a story by using the Paragraph panel. Indentation moves the paragraph away from the edges of the text frame’s bounding box. Here’s how to modify indentation:

					1.	Create a text frame on the page and fill it with text.

						You can fill the text frame by typing text, copying and pasting text, or inserting placeholder text by choosing Text⇒Fill with Placeholder Text.

					2.	Make sure that the insertion point is blinking in the text frame in the paragraph you want to change or use the Selection tool to select the text frame.

					3.	Choose Window⇒Type & Tables⇒Paragraph to open the Paragraph panel.

						The Paragraph panel opens, showing the text frame’s current settings. See Figure 2-7 to find out the name of each setting control.

					

				
					Figure 2-7:  The Paragraph panel.

				

					[image: 9781118168608-fg020207.eps]

					4.	Change the value in the Left Indent text field and press Enter. 

				[image: tip.eps]		The larger the number, the greater the indent. You can specify the unit of measurement as you enter the text by entering in for inches or pt for points, using any forms of measurement InDesign supports.

					5.	Change the value in the First Line Left Indent text field and press Enter.

				[image: tip.eps]	To change all paragraphs in a story, click the insertion point in a paragraph and choose Edit⇒Select All before changing settings.

				Text alignment and justification

				You can use the alignment and justification buttons in the Paragraph panel to format text frames:

				[image: check.png] Align helps you left-, center-, or right-align text with the edges of the text frames.

				[image: check.png] Justification lets you space text in relation to the edges of the text frame, and it lets you justify the final line of text in the paragraph.

				To align or justify a block of text, click the Align or Justify button, respectively. (Refer to Figure 2-7 to see the Align and Justify buttons in the Paragraph panel.)

				Saving a paragraph style

				Do you ever go to all the trouble of finding just the right indent, font, or spacing to use in your copy, just to find that you have to apply those attributes a hundred times to complete your project? Or, have you ever decided that the indent is too much? Wouldn’t it be nice to change one indent text box and have it update all other occurrences? You can do this using paragraph styles in InDesign.

				To create a paragraph style, follow these steps:

					1.	Create a text frame, add text, and apply a first-line indent of any size you want.

						Select some text — you don’t have to select it all.

					2.	Choose Window⇒Styles⇒Paragraph Styles.

						The Paragraph Styles panel opens.

					3.	From the Paragraph Styles panel menu, choose New Paragraph Style.

						The New Paragraph Style dialog box opens. Note that every attribute, font, size, and indent is already recorded in this unnamed style. You don’t have to do anything at this point other than name the style.

					4.	Change the name from Paragraph Style 1 to something more appropriate, such as BodyCopy, and click OK.

						Your style is created! After you click OK, the dialog box closes and the new style is added to the Paragraph Styles panel list. You can modify the settings by double-clicking the style name in the Paragraph Styles panel. You can apply the style to other text frames by selecting the frame and clicking the style in the Paragraph Styles panel.

				[image: technicalstuff.eps]	If you want to change an existing style, the New Paragraph Style dialog box has several different areas in a large list on the left side. Select an item in the list to view and change its associated paragraph properties on the right side of the dialog box to update all instances of that paragraph style.

				[image: tip.eps]	You can import paragraph styles from other documents or from a file on your hard drive, which is particularly useful when you need to use a particular set of styles for a template. To import paragraph styles, choose Load Paragraph Styles from the Paragraph Styles panel menu. A dialog box prompts you to browse your hard drive for a file. Select the file to load and click OK.

				Editing Stories

				Your documents likely contain all sorts of text, and some of that text may need to be edited. InDesign has a built-in story editor for editing text. This feature can be useful when it’s inconvenient or impossible to open another text editor to make changes.

				[image: tip.eps]	InDesign also integrates with another Adobe product: InCopy. It’s a text editor that’s similar to Microsoft Word but has integration capabilities with InDesign for streamlined page layout. If you work in IT or in editorial management and have some users who only write and others who only handle layout, you might want to have a look at InCopy as a possible text editor.

				Using the story editor

				The InDesign story editor lets you view a story outside tiny columns and format the text as necessary. To open the story editor to edit a piece of text, follow these steps:

					1.	Find a piece of text that you want to edit and select the text frame with the Selection tool.

						A bounding box with handles appears around the text frame.

					2.	Choose Edit⇒Edit in Story Editor or use the keyboard shortcut Ctrl+Y (Windows) or [image: maccmd]+Y (Mac).

						The story editor opens in a new window directly in the InDesign  workspace.

					3.	Edit the story in the window as necessary and click the Close button when you finish.

						Your story appears in one block of text. Any paragraph styles you apply to the text in the story editor are noted in an Information pane on the left side of the workspace.

				[image: tip.eps]	Notice in Figure 2-8 that you can see tables in the story editor. Click the small table icon to collapse and expand the table in the story editor.

					

				
					Figure 2-8: You can see text and tables in the story editor.

				

					[image: 9781118168608-fg020208.eps]

				[image: tip.eps]	If you want to make text edits but would like to keep the original text unchanged, you can choose Type⇒Track Changes⇒Track Changes in Current Story. The original text remains in the story editor along with your marked changes, but in layout mode only the edited text appears. Later you (or an editor) can use the Track Changes command to accept or reject text edits using the Story Editor.

				Checking for correct spelling

				Typos and spelling errors are easy to make. Therefore, you must check for incorrect spelling in a document before you print or export it to a PDF. Here’s how to check for spelling in InDesign:

					1.	Choose Edit⇒Spelling⇒Check Spelling.

					2.	In the Check Spelling dialog box that appears, choose a selection to search from the Search drop-down list, and then click the Start button.

						The spell check automatically starts searching the story or document.

					3.	Choose from three options:

					•	Click the Skip button to ignore a misspelled word.

					•	Select a suggested spelling correction from the list in the Suggested Corrections pane and click the Change button.

					•	Click Ignore All to ignore any more instances of that word.

						The spelling is corrected in the text frame and moves to the next spelling error.

					4.	Click the Done button to stop the spell check; otherwise, click OK when InDesign alerts you that the spell check is done.

				Using custom spelling dictionaries

				You can easily add words, such as proper nouns, to your dictionary by clicking the Add button.

				You can create a user dictionary or add user dictionaries from previous InDesign versions, from files that others have sent you, or from a server. The dictionary you add is used for all your InDesign documents.

				Follow these steps to create your own, custom dictionary:

					1.	Choose Edit⇒Preferences⇒Dictionary (Windows) or InDesign⇒Preferences⇒Dictionary (Mac).

						The Preferences dialog box appears with the Dictionary section visible.

					2.	From the Language drop-down list, select the language of your  dictionary.

					3.	Click the New User Dictionary button below the Language drop- down list.

					4.	Specify the name and location of the user dictionary, and then  click OK.

				[image: tip.eps]	If you want to see when a spelling error occurs without opening the Check Spelling dialog box, choose Edit⇒Spelling⇒Dynamic Spelling. Unknown words are then highlighted. To correct the spelling, right-click (Windows) or [image: maccmd]-click (Mac) and select the correct spelling from the contextual menu or add the word to your dictionary.

				Using Tables

				A table is made of columns and rows, which divide a table into cells. You see tables every day on television, in books and magazines, and all over the web. In fact, a calendar is a table: All the days in a month are shown down a column, every week is a row, and each day is a cell. You can use tables for many different tasks, such as listing products, employees, or events.

				The following list describes the components of a table and how to modify them in InDesign:

				[image: check.png] Rows: Extend horizontally across a table. You can modify the height of  a row.

				[image: check.png] Columns: Are vertical in a table. You can modify the width of a column.

				[image: check.png] Cells: A text frame. You can enter information into this frame and format it like any other text frame in InDesign.

				Creating tables

				The easiest way to create a table is to have data ready to go. (Mind you, this isn’t the only way.) But flowing in existing data is the most dynamic way of seeing what InDesign can do with tables.

				Follow these steps to experiment with the table feature:

					1.	Create a text area and insert tabbed copy into it.

						The example uses dates for an event:

	[image: /Table tbun020201]

				
				
				
						Notice that the text was simply keyed in by pressing the Tab key between every new entry. The text doesn’t even need to be lined up.

					2.	Select the text and choose Table⇒Convert Text to Table.

						The Convert Text to Table Options dialog box appears. You can select columns there or let the tabs in your text determine columns. You can find out more about table styles in the later section “Creating table styles.”

				[image: tip.eps]		You can assign a table style at the same time you convert text to a table.

					3.	Click OK to accept the default settings.

					4.	Hold down the Shift key and use your mouse to click and grab the outside right border to stretch the table in or out.

						The cells proportionally accommodate the new table size.

					5.	Click and drag across the top three cells and then choose Table⇒Merge Cells to merge them together.

				To create a new table without existing text, follow these steps:

					1.	Create a new text frame with the Type tool.

						The insertion point should be blinking in the new text frame you create. If it isn’t blinking, or if you created a new frame another way, double-click the text frame so that the insertion point (I-bar) is active. You can’t create a table unless the insertion point is active in the text frame.

					2.	Choose Table⇒Insert Table.

					3.	In the Insert Table dialog box that opens, enter the number of rows and columns you want to add to the table in the Rows and Columns text fields, and then click OK.

						For example, we created a table with six rows and three columns.

				Editing table settings

				You can control many settings for tables. InDesign lets you change the text, fill, and stroke properties for each cell or for the table itself. Because of this flexibility, you can create fully customized tables to display information in an intuitive and creative way. In this section, we show you some basic options for editing tables.

				To start editing table settings, follow these steps:

					1.	Select the table you want to make changes to by clicking in a cell.

					2.	Choose Table⇒Table Options⇒Table Setup.

						The Table Options dialog box opens with the Table Setup tab selected. The dialog box contains several tabs that contain settings you can change for different parts of the table.

						From the Table Setup tab, you edit the columns and rows, border, and spacing and specify how column or row strokes are rendered in relation to each other. For example, we changed the number of rows and columns and changed the table border weight to a 3-point stroke.

					3.	Select the Preview check box at the bottom of the dialog box.

						The Preview opens so that you can view the changes you make on the page while you’re using the dialog box.

					4.	Click the Row Strokes tab and change the options.

						For this example, we selected Every Second Row from the Alternating Pattern drop-down list, changed the Table Border Weight option to 2, and changed the Color property for the first row to C=15, M=100, Y=100, K=0 (the CMYK equivalent of red).

						This step causes every second row to have a red, 2-point stroke. You can also click the Column Strokes tab to change the properties for column strokes. The two tabs work the same way.

					5.	Click the Fills tab and change the options.

						For this example, we selected Every Other Row from the Alternating Pattern drop-down list, changed the Color property to the same CMYK equivalent of red, and left the Tint at the default of 20 percent. This step changes the first row and every other row to a red tint.

					6.	Click OK.

						The changes you made in the Table Options dialog box are applied to the table.

					7.	Click a table cell so that the insertion point is blinking.

						The table cell is selected.

					8.	Find an image you can copy to the Clipboard and then press Ctrl+C (Windows) or [image: maccmd]+C (Mac) to copy the image.

					9.	Return to InDesign and paste the image into the table cell by pressing Ctrl+V (Windows) or [image: maccmd]+V (Mac).

						The image appears in the table cell, and the height or width (or both)  of the cell changes based on the dimensions of the image. Make sure that the insertion point is active in the cell if you have problems pasting the image.

				You can not only change the table itself but also customize the cells within it. Choose Table⇒Cell Options⇒Text to open the Cell Options dialog box. You can also make changes to each cell by using the Paragraph panel. Similarly, you can change the number of rows and columns and their widths and heights from the Tables panel. Open the Tables panel by choosing Window⇒Type & Tables⇒Table.

				[image: technicalstuff.eps]	InDesign lets you import tables from other programs, such as Excel. If you want to import a spreadsheet, choose File⇒Place. The spreadsheet is imported into InDesign as a table that you can further edit as necessary.

				Creating table styles

				If you’ve spent time customizing strokes, fills, and spacing for your table, you certainly want to save it as a style. Creating a table style lets you reuse your table setup for future tables. To create a table style, follow these steps:

					1.	Make a table look the way you want.

						The easiest way to create a table style is to complete the table setup and make a table look the way you want it at completion.

					2.	Select the table.

						Click and drag to select it with the text tool.

					3.	Choose Window⇒Styles⇒Table Styles.

						The Table Styles panel appears.

					4.	Hold down the Alt (Windows) or Option (Mac) key and click the Create New Style button at the bottom of the Table Styles panel.

						The New Table Style dialog box appears.

					5.	Name the style and click OK.

						Your table attributes are saved as a style.

				If you want to edit table style attributes, you can simply double-click the named style in the Table Styles panel. (Make sure nothing is selected.)

				Looking at Text on a Path

				You can create some interesting effects with text on a path. Using the Type On a Path tool, you can have text curve along a line or shape. This feature is particularly useful when you want to create interesting titling effects on  a page.

				To create text on a path, follow these steps:

					1.	Use the Pen tool to create a path on the page.

						Create at least one curve on the path after you create it. (See Chapter 4 of this minibook to find out how to wield the Pen tool with confidence.)

					2.	Click and hold the Type tool to select the Type On a Path tool.

					3.	Move the cursor near the path you created.

						When you move the cursor near a path, a plus sign (+) symbol appears next to the cursor, and you can click and start typing on the path.

					4.	Click when you see the + icon and type some text on the path.

						An insertion point appears at the beginning of the path after you click, and you can then add text along the path. You select type on a path as you would normally select other text — by dragging over the text to highlight it.

				To change properties for type on a path, you can use the Type On a Path Options dialog box, which you open by choosing Type⇒Type On a Path⇒Options. In the Type On a Path Options dialog box, you can use effects to modify the way each character is placed on the path. You can also flip the text, change character spacing, and change character alignment to the path in the Align drop-down list or to the stroke of the path in the To Path drop-down list. Play with the settings to see how they affect your type. Click OK to apply changes; to undo anything you don’t like, press Ctrl+Z or [image: maccmd]+Z.

				[image: tip.eps]	To hide the path while keeping the text visible, set the stroke weight for the path to 0 pt.

			

			
		

	
		
			
				Chapter 3: Understanding  Page Layout

				In This Chapter

				[image: check.png] Working with and importing image files

				[image: check.png] Selecting images on the page

				[image: check.png] Knowing page layout settings

				[image: check.png] Using text and graphics in your layouts

				[image: check.png] Working with pages

				[image: check.png] Using master pages and spreads

				This chapter shows you how to put graphics and text together so that you can start creating page layouts. Interesting and creative page layouts help draw attention to the pictures and words contained within the publication. An interesting layout motivates more members of the audience to read the text you place on a page.

				Importing Images

				You can add many kinds of image files to an InDesign document. Some of the most common are AI, PSD, PDF, JPG, PNG, and TIF. Images are imported into graphic frames. You can create the frames before importing, or if you don’t have a frame, InDesign creates one for you instantly when you add the image to the page.

				When you import an image into your InDesign layout, the original image is still needed when you print or export the final document. You use special controls to keep track of the linked image and to work on specific settings, such as those that modify the quality and color. You also find additional settings at the time you import an image, which you access using the Image Import Options dialog box. In the “Importing other InDesign documents” section, later in this chapter, you find out how to change various import options.

				For now, follow these steps to import an image into your InDesign layout:

					1.	Make sure that nothing on the page is selected.

						If an object on the page is selected, click an empty area so that everything is deselected before you proceed.

					2.	Choose File⇒Place.

						The Place dialog box opens, where you can browse your hard drive for image files to import. You can use this dialog box to import various kinds of files into InDesign, not just images.

					3.	Select the image you want to import and click Open.

						The Place dialog box closes and the cursor displays a thumbnail of the image you selected.

				[image: tip.eps]		You can import multiple images at a time into an InDesign layout. Simply hold down the Ctrl (Windows) or [image: maccmd] (Mac) key and select multiple files in the Place dialog box.

					4.	Move the cursor to wherever you want the upper-left corner of the first image to be placed on the page, and then click the mouse.

						If you’ve selected multiple images, you can use the left and right arrow keys to navigate the thumbnail images in your loaded cursor before clicking on the page. After you click on the page, the next image is placed, until there are no more images to place.

						Images are imported and placed into the publication inside a graphic frame. You can resize, move, and modify the image by using the Selection or Direct Selection tool or modify the frame and image together by using the Selection tool.

				[image: tip.eps]	When placing multiple images you can place all the selected images in one step — space them evenly in a grid by pressing the Shift+Ctrl (Windows) or Shift+[image: maccmd] (Mac) keys while dragging a rectangle using your mouse.

				Don’t worry if the image is imported and is too large for the layout or needs to be cropped. For more information about selecting graphic frames and modifying them, check out Chapter 4 of this minibook. To find out about importing and working with text and stories, also see Chapter 2 of this  minibook.

				[image: tip.eps]	It’s sometimes easier to create an empty graphic frame and then add an image to it than to import the image and create the frame at the same time. You can create an empty frame and even set fitting properties before you import an image — so that the image fits correctly at the time you import it. To set the fitting properties in a blank frame, choose Object⇒Fitting⇒Frame Fitting Options.

				Importing PDFs

				You can import PDF files to place them as images in InDesign layouts. When importing, you can preview and crop the pages by using the Place PDF dialog box. (Choose File⇒Place, select the Show Import Options check box, and then click Open.) You import one page at a time, so you need to use the Forward and Back buttons displayed under the preview to select a page to place. Also, you can’t import any video, sound, or buttons, and you can’t edit the PDF after it’s imported into InDesign — so it is more like importing a static image such as a JPEG file.

				The Place PDF dialog box offers the following options:

				[image: check.png] Crop To: You can crop the page you’re importing using this drop-down list. Some options may be unavailable because they depend on what’s in the PDF you’re importing. The hatched outline in the preview shows you the crop marks.

				[image: check.png] Transparent Background: Selecting this check box makes the PDF background transparent so that elements on the InDesign page show through. The PDF background is imported as solid white if this option isn’t selected.

				[image: tip.eps]	If your monitor is large enough for you to view your document window and folders on your computer, you can click and drag image files directly into your layout, bypassing the Place command altogether.

				Importing other InDesign documents

				You can place one InDesign document inside another. This feature might sound a bit odd, but it has many uses. For example, if you have a page from a book that you want to promote in a catalog, you can import an image of the book page to place into a catalog — all without converting the book page into some type of image format. This strategy not only removes a step but also creates a higher-quality version of the image being placed into InDesign.

				Here’s how to take advantage of this feature:

					1.	With a document open, choose File⇒Place or use the keyboard shortcut Ctrl+D (Windows) or [image: maccmd]+D (Mac).

						The Place dialog box appears.

					2.	Select the Show Import Options check box at the bottom of the Place dialog box.

					3.	Navigate to an InDesign file and double-click to open it.

						The Place InDesign Document dialog box appears, as shown in Figure 3-1,  offering you the opportunity to choose which page or pages you want  to place.

					

				
					Figure 3-1: Choose pages to import in the Place InDesign Document dialog box.

				

					[image: 9781118168608-fg020301.tif]

					4.	Click OK.

					5.	Click the page to place the document.

						If you’re placing a document with multiple pages, click again to place each additional page.

				Linking and Embedding Images

				You can have images that you import either linked to your document or embedded in your document. Here’s the difference between linking and embedding:

				[image: check.png] Linking: The image that appears in the InDesign document is a preview of the image stored somewhere else on your computer or network. If the file you linked to your InDesign document is changed, it must be updated.

				[image: check.png] Embedding: The image is copied into and saved within the InDesign document itself. It doesn’t matter where the original file is located or whether you alter the file, because an embedded image is copied and saved directly within the InDesign document.

				When you print or export a document, InDesign uses the linked images to generate the information necessary to create a high-quality printed document, a PDF file, or an image for posting on the web. InDesign keeps track of linked files and alerts you if any of them are moved or changed. You can update links for an image by selecting the image in the Links panel and choosing Update Link or Relink from the Links panel menu. You’re prompted to find that file on your hard drive so that the file can be linked to the new location. And, if you send your InDesign file to someone else, make sure to also send its linked files along with the document. You can gain a better understanding of this process in Chapter 8 of this minibook.

				[image: remember.eps]	If you choose to embed images rather than link to images, your publication’s file size increases because of the extra data that’s being stored within it.

				To find out which files are embedded or linked, look at the Links panel. (See Figure 3-2.) Choose Window⇒Links to open the panel and see whether any linked or embedded images are listed in the panel.

				You can choose to embed a file by using the Links panel menu. Click the triangle in the upper right corner to access the panel menu and select Embed Link if you want a linked file to be embedded within the document. Alternatively, choose Unembed Link from the Link panel menu to link a file rather than have it embedded in the document. We recommend linking to all images so that your files don’t become too large and because it provides you with flexibility to manipulate the image files separately.

					

				
					Figure 3-2: The Links panel keeps track of all images used in your documents.

				

					[image: 9781118168608-fg020302.eps]

				Setting Image Quality and Display

				You can select quality settings that determine how images are displayed when they’re part of an InDesign layout. These settings may help speed up your work if your computer is older or slower, or if you have many images. Displaying images at a higher resolution can give you a better idea of the finished print project and may avoid the need to print the project several times for proofing. These settings are applicable only to how you see the images while using InDesign to create a document — they don’t impact the final printed or exported product.

				To change the image display quality, choose Edit⇒Preferences⇒Display Performance (Windows) or InDesign⇒Preferences⇒Display Performance (Mac). You can then select one of the following settings from the Default View drop-down list:

				[image: check.png] Fast: To optimize performance, the entire image or graphic is  grayed out.

				[image: check.png] Typical (Default): This setting tends to make bitmaps look a little blocky, particularly if you zoom in. The speed of zooming in and out is increased if you select this option. InDesign uses a preview that it created (or that was already imported with the file) to display the image on the screen.

				[image: check.png] High Quality: The original image is used to display onscreen. You can preview an accurate depiction of the final layout, but you may find that InDesign runs slowly when you use this option.

				Notice the difference among these settings in Figure 3-3.

					

				
					Figure 3-3: From left to right: Fast Display, Typical Display, and High Quality Display.

				

					[image: 9781118168608-fg020303.tif]

				[image: tip.eps]	To change the display for an individual image, select the graphic frame and choose View⇒Display Performance. Then choose one of the three options from the submenu.

				Selecting Images

				After you import an image into a document, you can select images in several different ways with the Selection or Direct Selection tools. It’s useful to use the different methods depending upon whether you want to select and edit just the graphic frame or just the image inside it.

				To select and then edit an image on the page, follow these steps:

					1.	Place an image on a page by importing it into InDesign.

						The image is placed within a graphic frame.

					2.	With the Selection tool, drag one of the corner handles on the graphic frame in towards the center of the frame.

						The graphic frame is resized but not the image. The image appears  to be cropped because you resized the graphic frame — though the image remains the same size within the frame, as shown in the center  of Figure 3-4.

					3.	Choose Edit⇒Undo or press Ctrl+Z (Windows) or [image: maccmd]+Z (Mac) to undo changes to the image.

						The image returns to its original appearance on the page.

					

				
					Figure 3-4: The original image in a graphic frame (left); inside a resized frame (center); and repositioning an image within the frame (right).

				

					[image: 9781118168608-fg020304.tif]

					4.	Continue to use the Selection tool to click the center of the picture where a circle appears and move the picture within the frame.

						The frame remains the same size, but its content is relocated. You can also use the Selection tool to move the frame and contents together by clicking anywhere within the frame; however, it is good practice to click on the center section because this works with both the Selection and Direct Selection tools.

					5.	Switch to the Direct Selection tool, and then click within the image and drag to move the image within the graphic frame-bounding box.

						A hand appears when you move the cursor over the graphic; when you move the image just past the edge of the graphic frame boundaries, that part of the image is no longer visible — it doesn’t print and doesn’t show when exported.

				[image: tip.eps]	When you reposition a graphic within a frame, the entire image appears. Areas outside the frame appear ghosted, as shown in the image on the right in Figure 3-3. Seeing the dimmed image allows you to crop more effectively.

				[image: tip.eps]	You can set the frame or image to resize by choosing Object⇒Fitting and selecting an option. You can even set this fitting before you place an image, which is especially helpful when creating templates. Resize before an image is placed by choosing Object⇒Fitting⇒Frame Fitting Options.

				The Links panel can help you find images within documents, open images so that you can edit them, and view important information about selected images. Figure 3-4 can help you navigate the Links panel and work with your images more effectively.

				Manipulating Text and Graphics in a Layout

				InDesign offers many tools that help you work with text and graphics together in a layout. From the tools in the Tools panel to commands to panel options, InDesign offers you an immense amount of control over the manipulation of graphics and text in a spread.

				Page orientation and size

				When you create a new document, you can set its page orientation and size. If you ever need to change your settings after you’ve created a document, choose File⇒Document Setup and change the following options, which affect all pages in your document:

				[image: check.png] Page Orientation: Select either Landscape or Portrait. One of the first things you decide on when you create a new document is how to orient the pages. A landscape page is wider than it is tall; a portrait orientation is taller than it is wide.

				[image: check.png] Page Size: Choose from many standardized preset sizes, such as Letter, Legal, and Tabloid. Alternatively, you can set a custom page size for the document. Make sure to properly set the page size so that it fits the kind of paper you need to print on.

				[image: tip.eps]	You can also use the pages panel to adjust the size of individual pages and make some pages a different size. This topic is covered later in this chapter, in the section “Working with Pages and the Pages Panel.”

				Margins, columns, and gutters

				Margins, columns, and gutters help divide a page for layout and confine its dimensions:

				[image: check.png] Margin: The area between the edge of the page and the main printed area. Together, the four margins (top, bottom, left, and right) look like a rectangle around the page’s perimeter. Margins don’t print when you print or export the publication.

				[image: check.png] Column: Divide a page into sections used for laying out text and graphics on a page. A page has at least one column when you start, which is between the margins. You can add column guides, represented by a pair of lines separated by a gutter area. Column guides aren’t printed when you print or export the publication.

				[image: check.png] Gutter: The space between two columns on the page. A gutter prevents columns from running together. You can define the gutter’s width by choosing Object⇒Text Frame Options; see Chapter 2 of this minibook for more information.

				You can set margins and columns when you create a new document, which we discuss in Chapter 1 of this minibook. However, you can also modify margins and columns after the document has been created and specify different values for each page. You can modify the gutter, which is the width of the space between each column.

				You can change margins and columns by setting new values in the Margins and Columns dialog box. Choose Layout⇒Margins and Columns, and then modify each individual page.

				[image: remember.eps]	Margins and columns are useful for placing and aligning elements on a page. These guides can have objects snap to them, enabling you to accurately align multiple objects on a page.

				Using guides and snapping

				Using guides when you’re creating page layouts is a good idea because guides help you more precisely align elements on a page and position objects in the layout. Aligning objects by eyeballing them is difficult because you often can’t tell whether an object is out of alignment by a small amount unless you zoom in to a large percentage.

				[image: remember.eps]	Make sure that snapping is enabled by choosing View⇒Grids and Guides⇒Snap to Guides. Snapping makes guides and grids useful. When you drag the object close to the grid, the object attaches to the guideline like it’s a magnet. Aligning an object to a guide is easy after you create a guide, and you’ll notice that InDesign displays temporary guides when you move an object near another object or near a guide.

				Because guides are useful in creating a layout, check out the following kinds, available in InDesign (see Figure 3-5):

					

				
					Figure 3-5: Column guides, margin guides, and ruler guides help create a layout.

				

					[image: 9781118168608-fg020305.eps]

				[image: check.png] Column guides: Evenly distribute a page into columns and can be used to align text frames in a document. These guides are set when you open a new document in InDesign that contains more than one column. Column guides can also be adjusted after a document is created by choosing Layout ⇒Margins and Columns.

				[image: check.png] Margin guides: Define the area between the edge of the page and the main printable area. (We discuss these guides in the previous section.)

				[image: check.png] Ruler guides: Manually defined and can be used to align graphics, measure objects, or specify the location of a particular asset you want to lay out. See Chapter 1 of this minibook for details about adding ruler guides to the workspace.

				[image: check.png] Smart guides: As previously mentioned, smart guides offer the ability to align objects on an InDesign page to other objects or even to the page. Smart Object alignment allows for easy snapping to page item centers or edges or page centers. In addition to snapping, Smart Guides give feedback to the user indicating the object to which you are snapping.

				[image: check.png] Liquid guides: Liquid guides are useful when creating layouts that will be displayed on a variety of tablets. They are discussed more in Chapter 8 of this minibook.

				To find out how to show and hide grids and guides, see Chapter 1 of this minibook.

				[image: tip.eps]	With InDesign CS6 you can delete all guides at once by right-clicking the ruler (Windows) or Control-clicking the ruler (Mac) and selecting Delete All Guides on Spread from the contextual menu.

				Locking objects and guides

				You can lock in place elements such as objects and guides. This feature is particularly useful after you’ve carefully aligned elements on a page. Locking objects or guides prevents you from accidentally moving them from that position.

				To lock an element, follow these steps:

					1.	Use a drawing tool to create an object on a page, and then select the object with the Selection tool.

						A bounding box with handles appears when the object is selected.

					2.	Choose Object⇒Lock.

						The object is locked in position. Now when you try to use the Selection or Direct Selection tools to move the object, it doesn’t move from its current position.

				To lock guides in place, follow these steps:

					1.	Drag a couple of ruler guides to the page by clicking within a ruler and dragging toward the page.

						A line appears on the page. (If rulers aren’t visible around the pasteboard, choose View⇒Rulers.)

					2.	Drag a ruler guide to a new location, if needed; when you’re happy with the ruler guides’ placements, choose View⇒Grids & Guides⇒Lock Guides.

						All guides in the workspace are locked. If you try selecting a guide and moving it, the guide remains in its present position and cannot  be moved. If you have any column guides on the page, they’re locked  as well.

				[image: tip.eps]	Use layers in your publications for organizing different types of content, including guides. Layers are a lot like transparencies that lie on top of each other, so they can be used for stacking elements on a page. For example, you may want to stack graphics or arrange similar items (such as images or text) on the same layer. Each layer has its own bounding box color, which helps you determine which item is on which corresponding layer. For more information on layers in general, see Book III, Chapter 8.

				Merging Text and Graphics

				When you have text and graphics together on a page, they should flow and work with each other to create an aesthetic layout. Luckily, you can work with text wrap to achieve a visual flow between text and graphics. In this section, you find out how to wrap text around images and graphics in your publications.

				Wrapping objects with text

				Images can have text wrapped around them, as shown in Figure 3-6. Wrapping is a typical feature of page layout in print and on the web. You can choose different text wrap options by using the Text Wrap panel, which you open by choosing Window⇒Text Wrap. Use the five buttons at the top of the panel to specify which kind of text wrapping to use for the selected object. Below the buttons are text fields where you can enter offset values for the text wrap. The fields are grayed out if the option isn’t available.

					

				
					Figure 3-6: You can wrap text around images in InDesign in several ways.

				

					[image: 9781118168608-fg020306.eps]

				You use the drop-down list at the bottom of the Text Wrap panel to choose from various contour options. The following list describes what happens when you click one of these buttons to wrap text around an object’s shape:

				[image: check.png] No Text Wrap: Use the default setting or to remove any text wrapping from the selected object.

				[image: check.png] Wrap around Bounding Box: Wrap text around all sides of the bounding box of the object.

				[image: check.png] Wrap around Object Shape: Wrap text around the edges of an object.

				[image: check.png] Jump Object: Make the text wrapping around the image jump from above the image to below it, with no text wrapping to the left or right of the object in the column.

				[image: check.png] Jump to Next Column: Make text end above the image and then jump to the next column. No text is wrapped to the left or right of the image.

				[image: check.png] Offset: Enter offset values for text wrapping on all sides of the object.

				[image: check.png] Wrap Options: Select an option to determine on which sides of the object text will wrap.

				[image: check.png] Contour Options: Select a contour from this drop-down list, which tells InDesign how the edges of the image are determined. You can choose from various vector paths or the edges to be detected around an object or image with transparency.

				[image: check.png] Top Offset: Enter a value for the top offset modifier to offset the text wrapping around the object.

				To add text wrapping to an object (a drawing or an image), follow these steps:

					1.	Create a text frame on the page.

						Add text to the text frame by typing text, pasting text from elsewhere, or filling the frame with placeholder text. This text wraps around the image, so make sure that the text frame is slightly larger than the graphic frame you’ll use.

					2.	Use the Selection tool to select a graphic frame on the page and move it over the text frame.

						Bounding box handles appear around the edges of the image or graphic.

					3.	Choose Window⇒Text Wrap to open the Text Wrap panel.

						The Text Wrap panel opens.

					4.	With the graphic frame still selected, click the Wrap around Object Shape button.

						The text wraps around the image instead of hiding behind it.

					5.	If you’re working with an image that has a transparent background, select Detect Edges or Alpha Channel from the Contour Options drop-down list.

						The text wraps around the edges of the image — refer to the (c) Wrap around Object Shape example in Figure 3-6.

				Modifying a text wrap

				If you’ve applied a text wrap around an object (as we show you how to do in the preceding section), you can then modify that text wrap. If you have an image with a transparent background around which you’ve wrapped text, InDesign created a path around the edge of the image; if you have a shape you created with the drawing tools, InDesign automatically uses those paths to wrap text around.

				[image: warning_bomb.eps]	Before proceeding with the following steps, be sure that the object uses the Wrap around Object Shape text wrap. (If not, open the Text Wrap panel  and click the Wrap around Object Shape button to apply text wrapping.) Remember to choose Detect Edges if you’re using an image with a transparent background.

				To modify the path around an image with text wrapping, using the Direct Selection tool, follow these steps:

					1.	Select the object by using the Direct Selection tool.

						The image is selected, and you can see the path around the object.

					2.	Click to select one of the anchor points on the text wrap path by using the Direct Selection tool; then click and drag the point to move it.

						The path is modified according to how you move the point. (For more about manipulating paths, take a look at Chapter 4 of this minibook.) The text wrapping immediately changes, based on the modifications you make to the path around the object.

					3.	Select the Delete Anchor Point tool from the Tools panel and delete an anchor point.

						The path changes again, and the text wrapping modifies around the object accordingly.

				[image: remember.eps]	You can also use the Offset values in the Text Wrap panel to determine the distance between the wrapping text and the edge of the object. Simply increase the values to move the text farther from the object’s edge.

				Working with Pages and the Pages Panel

				The page is the central part of any publication — it’s where the visible part of your publication is created. Navigating and controlling pages is an important part of working in InDesign. The Pages panel allows you to select, adjust, move, and navigate pages in a publication. When you use default settings, pages are created as facing pages, which means that they’re laid out as two-page pairs, or spreads. Otherwise, pages are laid out individually. Whether a page is part of a spread or a single page is reflected in the Pages panel, but the option is specified when you create a new document and can be changed in the Document Setup window.

				The Pages panel, which you open by choosing Window⇒Pages, also lets you add new pages to the document, duplicate pages, delete a page, or change the size of a page. The pages panel, shown in Figure 3-7, contains two main areas: the master pages (upper) section and the (lower) section containing the document’s pages.

					

				
					Figure 3-7: The Pages panel with page previews.

				

					[image: 9781118168608-fg020307.eps]

				To discover more about master pages and how they differ from regular pages in your document, see the “Using Master Spreads in Page Layout” section, later in this chapter.

				Selecting and moving pages

				Use the Pages panel to select a page or spread in your publication. Select a page by clicking the page. If you Ctrl-click (Windows) or [image: maccmd]-click (Mac) pages, you can select more than one page at a time. The Pages panel also lets you move pages to a new position in the document: Select a page in the document pages area of the panel, and then drag it wherever you want to move the page. A small line and changed cursor indicate where the page will be moved. You can move a page so that it’s between two pages in a spread; a hollow line indicates where you’re moving the page. If you move a page after a spread, a solid line appears. Release the mouse button to move the page to the new location.

				Adding and deleting pages

				You can also add new pages to the publication by using the Pages panel. To add a new page, follow these steps:

					1.	Choose Window⇒Pages to open the Pages panel.

						The Pages panel opens.

					2.	Click the Create New Page button.

						A new page is added to the document.

				[image: tip.eps]		Alt-click (Windows) or Options-click (Mac OS) the Create New Page button and you can then specify the exact number of pages to add and the location of these new pages.

					3.	Select a page in the Pages panel.

						The selected page is highlighted in the Pages panel.

					4.	Click the Create New Page button again.

						A new page is added following the selected page.

				[image: tip.eps]	To delete a page, select it in the Pages panel and click the Delete Selected Pages button. The selected page is removed from the document.

				You can also add, delete, and move pages and more without the Pages panel by choosing Layout⇒Pages.

				Numbering your pages

				When you’re working with longer documents, adding page numbers before you print or export the publication is a good idea. You don’t have to add them manually: A special InDesign tool lets you number pages automatically. This tool is particularly useful when you move pages around the document. You don’t have to keep track of updating the numbering when you make these kinds of edits.

				To number pages, follow these steps:

					1.	Using the Type tool, create a text frame on the page where you want the page number to be added.

					2.	Choose Type⇒Insert Special Character⇒Markers⇒Current Page Number.

						The current page number appears in the text frame you selected. If you added the page number to a master page, the master page’s letter appears in the field instead.

				If you want page numbers to appear on all pages in the document, add the text frame to a master page. Remember that page numbers are added only to the pages in your document that are associated with that master page. If you want to add page numbers to the left and right sides of a book or magazine, you need to repeat this process on the left and right sides of the master pages. Remember that if you add the page only on a document page — and not on a master — the page number is added to only that single page.

				[image: tip.eps]	To modify automatic-numbering settings, choose Layout⇒Numbering and Section Options. You can choose to have numbering start from a specific number or use a different style, such as Roman numerals.

				Using Master Spreads in Page Layout

				Master pages are a lot like templates you use to format page layouts. The settings, such as margins and columns, are applied to each layout that the master page is applied to. If you put a page number on a master page, the number also appears on every page that uses the layout. You can have more than one master page in a single publication, and you can choose which pages use a particular master page.

				A master page or spread typically contains parts of a layout that are applied to many pages. The master page has elements that are used on many pages, such as page numbering, text frames to enter text into, background images, or a heading that’s used on every page. You can’t edit the items you have on a master page on the pages assigned to it — you can edit those items only on the master page.

				[image: remember.eps]	Master pages are lettered. The first master page is the A-Master by default. If you create a second master page, it’s the B-Master by default. When you create a new publication, the A-Master is applied to all pages you initially open in the document. You can add pages at the end that don’t have a master page applied to them.

				Creating master pages and applying them to your publication enables you to create a reusable format for it, which can dramatically speed your workflow when you put together documents with InDesign.

				Creating a master spread

				You may need more than one master page or master spread for a document. You may have another series of pages that need a unique format. In this situation, you need to create a second master page. You can create a master page or a master spread from any other page in the publication, or you can create a new one with the Pages panel.

				To create a master page by using a page in the publication, do one of the  following:

				[image: check.png] Choose New Master from the Page panel’s menu, and then click OK. A blank master page is created.

				[image: check.png] Drag a page from the pages section of the panel into the master page section of the Pages panel. The document page turns into a master page.

				[image: warning_bomb.eps]	If the page you’re trying to drag into the master pages section is part of a spread, select both pages in the spread before you drag it into the master pages section. You can drag individual pages into the master page section only if they’re not part of a spread.

				Applying, removing, and deleting master pages

				After you create a master page, you can apply it to a page. You can also remove a page from a master page layout and delete a master page altogether:

				[image: check.png] To add master page formatting to a page or spread in a publication: In the Pages panel, drag the master page you want to use from the master page section on top of the page you want to format in the document pages section. When you drag the master page on top of the page, it has a thick outline around it. Release the mouse button when you see this outline, and the formatting is applied to the page.

				[image: check.png] To remove any master page applied to a document page: In the Pages panel, drag the None page from the master area in the Pages panel to that document page. You may need to use the scroll bar in the master pages area of the Pages panel to find the None page.

				[image: check.png] To delete a master page: In the Pages panel, select the unwanted master page, and then choose Delete Master Page from the panel menu.

				[image: warning_bomb.eps]		This action permanently deletes the master page — you can’t get it  back — so think carefully before deleting a master page.

				Changing individual page sizes

				Using the Pages panel, you can change the size of individual pages in a document, which is useful if you have one page that folds out and is larger than others. Or, maybe you want to create a single document that includes a business card, an envelope, and a letterhead.

				To change the size of individual pages using the Pages panel, follow these steps:

					1.	In the Pages panel, click to select the page you want to modify.

					2.	Click the Edit Page Size button at the bottom of the Pages panel and select the new size.

					3.	Repeat the process to adjust the size for any pages you want to modify.

						When you’re done editing the size of the pages, continue to work  on their design and layout like you would work on any other pages.  The only difference is that some pages in your document may be a different size.

				[image: tip.eps]	You can also use the Pages panel to create alternative layouts for display on various tablet devices. These alternative layouts are discussed in Chapter 8 of this minibook.

				

			

			
		

	
		
			
				Chapter 4: Drawing in InDesign

				In This Chapter

				[image: check.png] Discovering the drawing tools

				[image: check.png] Drawing and editing shapes and paths

				[image: check.png] Introducing corner effects

				[image: check.png] Working with fills and layers

				Many of the tools you find in the InDesign Tools panel are used for drawing lines and shapes on a page, so you have several different ways of creating interesting drawings for your publications. You can create anything from basic shapes to intricate drawings inside InDesign, instead of having to use a drawing program such as Illustrator. Even though InDesign doesn’t replace Illustrator (see Book III), which has many more versatile drawing tools and options for creating intricate drawings, InDesign is adequate for simple drawing tasks. In this chapter, you discover how to use  the most popular InDesign drawing tools and how to add colorful fills to illustrations.

				Even if you don’t think you’ll be drawing using InDesign, you should still take a look at the sections “Modifying Frame Corners” and “Using Fills,” later in this chapter, before jumping ahead.

				Getting Started with Drawing

				When you’re creating a document, you may want drawn shapes and paths to be a part of the layout. For example, you may want to have a star shape for a yearbook page about a talent show or to run text along a path. Whatever it is you need to do, you can draw shapes and paths to get the job done.

				Paths and shapes

				Paths can take a few different formats. They can either be open or closed and with or without a stroke:

				[image: check.png] Path: The outline of a shape or an object. Paths can be closed and have no gaps, or they can be open like a line on the page. You can draw freeform paths, such as squiggles on a page, freely by hand.

				[image: check.png] Stroke: A line style and thickness that you apply to a path. A stroke can look like a line or like an outline of a shape.

				Figure 4-1 shows the different kinds of paths and strokes you can create.

				Paths contain points where the direction of the path can change. (You can find out more about points in the later section “Points and segments.”) You can make paths by using freeform drawing tools, such as the Pen or Pencil tools, or by using the basic shape tools, such as Ellipse, Rectangle, Polygon, or Line.

				The shape tools create paths in a predefined way so that you can make basic geometric shapes, such as a star or an ellipse. All you need to do is select the shape tool and drag the cursor on the page, and the shape is automatically drawn. Creating shapes this way is a lot easier than trying to create them manually by using the Pen or Pencil tool. Figure 4-2 shows shapes drawn with the shape tools found in the Tools panel.

				You can change shapes into freeform paths, like those drawn with the Pencil or Pen tools. Similarly, you can make freeform paths into basic shapes. Therefore, you don’t need to worry about which tool you initially choose.

					

				
					Figure 4-1: Different kinds of paths and strokes created in InDesign.

				

					[image: 9781118168608-fg020401.eps]

					

				
					Figure 4-2: You can create many shapes with the basic shape tools.

				

					[image: 9781118168608-fg020402.eps]

				[image: tip.eps]	We created the stars and starburst shown in Figure 4-2 by double-clicking the Polygon tool and changing the options. Read more about the Polygon tool in the “Drawing Shapes” section, later in this chapter.

				Points and segments

				Paths are made up of points and segments:

				[image: check.png] Point: Where the path changes somehow, such as a change in direction. Many points along a path can be joined with segments. Points are sometimes called anchor points. You can create two kinds of points:

					•	Corner points: Have a straight line between them. Shapes such as squares and stars have corner points.

					•	Curve points: Occur along a curved path. Circles or snaking paths have lots of curve points.

				[image: check.png] Segment: A line or curve connecting two points — similar to  connect-the-dots.

				Figure 4-3 shows corner points and curve points joined by segments.

					

				
					Figure 4-3:  Points are joined by line segments.

				

					[image: 9781118168608-fg020403.eps]

				Getting to Know the Tools of the Trade

				The following subsections introduce you to tools that you’ll probably use most often when creating drawings in your publications. When you draw with these tools, you’re using strokes and fills to make designs. The following subsections show you what these common tools can do to help you create basic or complex illustrations in InDesign.

				The Pencil tool

					[image: 9781118168608-ma421.tif]	The Pencil tool is used to draw simple or complex shapes on a page. Because the Pencil tool is a freeform tool, you can freely drag it all over the page and create lines or shapes, instead of having them automatically made for you, such as when you use basic shape tools. The Pencil tool is an intuitive and easy tool to use. You find out how to use it in the later section “Drawing Freeform Paths.”

				The Pen tool

					[image: 9781118168608-ma411.tif]	You use the Pen tool to create complex shapes on the page. The Pen tool works with other tools, such as the Add, Remove, and Convert Point tools. The Pen tool works by adding and editing points along a path, thereby manipulating the segments that join them.

				Drawing with the Pen tool isn’t easy at first. In fact, it takes many people a considerable amount of time to use this tool well. Don’t become frustrated if you don’t get used to it right away — the Pen tool can take some practice to get it to do what you want. You find out how to use the Pen tool in the “Drawing Freeform Paths” section, later in this chapter.

				Basic shapes and frame shapes

				Basic shapes are preformed shapes that you can add to a document by using tools in the Tools panel. The basic shape tools include the Line, Rectangle, Ellipse, and Polygon tools.

				You can also draw these shapes and turn them into frames (containers that hold content in a document). You can use a frame as a text frame or as a graphic frame used to hold pictures and text. Draw a basic shape and then convert it to a graphic or text frame by choosing Object⇒Content⇒Text or Object⇒Content⇒Graphic. We discuss graphic frames and text frames in more detail in Chapter 2 of this minibook.

				[image: technicalstuff.eps]	The frame and shape tools look the same and can even act the same. Both can hold text and images, but look out! By default, shapes created with the shape tools have a 1-point black stroke around them. Many folks don’t see these strokes on the screen but later discover them surrounding their text boxes when they print. Stick with the frame tools, and you’ll be fine.

				Drawing Shapes

				InDesign allows you to create basic shapes in a document. You can easily create a basic shape by following these steps:

					1.	Create a new document by choosing File⇒New.

					2.	When the New Document dialog box appears, click OK.

						A new document opens.

					3.	Select the Rectangle tool in the Tools panel.

					4.	Click anywhere on the page and drag the mouse diagonally.

						When the rectangle is the dimension you want, release the mouse button. You’ve created a rectangle.

				That’s all you need to do to create a basic shape. You can also use these steps with the other basic shape tools (the Line, Ellipse, and Polygon tools) to create other basic shapes. To access the other basic shapes from the Tools panel, follow these steps:

						1.	[image: 9781118168608-ma405.tif]Click the Rectangle tool and hold down the mouse button.

						A menu that contains all the basic shapes opens.

					2.	Release the mouse button.

						The menu remains open, and you can mouse over the menu items.  Each menu item becomes highlighted when the mouse pointer is placed over it.

					3.	Select a basic shape tool by clicking a highlighted menu item.

						The new basic shape tool is now active. Follow the preceding set of steps to create basic shapes by using any of these tools.

				[image: tip.eps]	To draw a square shape, use the Rectangle tool and press the Shift key while you drag the mouse on the page. The sides of the shape are all drawn at the same length, so you create a perfect square. You can also use the Shift key with the Ellipse tool if you want a perfect circle — just hold down Shift while you’re using the Ellipse tool. Release the mouse before the Shift key to ensure that this constrain shape trick works!

				Creating a shape with exact dimensions

				Dragging on the page to create a shape is easy, but making a shape with precise dimensions using this method requires a few more steps. If you want to make a shape that’s a specific size, follow these steps:

					1.	Select the Rectangle tool or the Ellipse tool.

						The tool is highlighted in the Tools panel.

					2.	Click anywhere on the page, but don’t drag the cursor.

						This point becomes the upper-left corner of the Rectangle or Ellipse bounding box (the rectangle that defines the object’s vertical and horizontal dimensions). After you click to place a corner, the Rectangle or Ellipse dialog box appears.

					3.	In the Width and Height text fields, enter the dimensions for creating the shape.

					4.	Click OK.

						The shape is created on the page, with the upper-left corner at the place where you initially clicked the page.

				Using the Polygon tool

				A polygon is a shape that has many sides. For example, a square is a polygon with four sides, but the Polygon tool enables you to choose the number of sides you want for the polygon you create. When you’re using the Polygon tool, you may not want to create a shape with the default number of sides. You can change these settings before you start drawing the shape.

				To customize the shape of a polygon, follow these steps:

					1.	Select the Polygon tool in the Tools panel by selecting the Rectangle tool and holding down the mouse button until the menu pops up.

					2.	Double-click the Polygon tool in the Tools panel.

						The Polygon dialog box opens, as shown at the bottom of Figure 4-4.

					3.	In the Number of Sides text field, enter the number of sides you want the new polygon to have.

					

				
					Figure 4-4: Change the star inset percentage to create different kinds of shapes.

				

					[image: 9781118168608-fg020404.tif]

						To create a star instead of a polygon, enter a number in the Star Inset text field for the percentage of the star inset you want the new shape  to have.

						A higher percentage means that the sides are inset farther toward the center of the polygon, creating a star. If you want a regular polygon and not a star, enter 0 in the Star Inset text field. If you want a star, enter 50%; for a starburst, enter 25%.

					4.	Click OK.

					5.	Move the cursor to the page and click and drag to create a new  polygon or star.

						Your new polygon or star appears on the page.

				Figure 4-4 shows what a few different polygons and stars with different settings look like.

				Editing Basic Shapes

				You can edit basic shapes using several panels in InDesign and therefore create original shapes and craft exactly the kind of design you require in a page layout. You aren’t stuck with predetermined shapes, such as a square or an oval. You can make these forms take on much more complicated or original shapes.

				You can edit basic shapes in InDesign in only a few ways. You can edit shapes and manipulate their appearance in other ways. We cover some of these ways, such as editing fills, in the later section “Using Fills.”

				Changing the size with the Transform panel

				You can change the size of a shape by using the Transform panel.  Here’s how:

						1.	[image: 9781118168608-ma406.tif] With the Selection tool (the solid black arrow tool that’s used to select objects), select the shape you want to resize.

						When the shape is selected, a bounding box appears around it. You can see a selected shape in Figure 4-5.

					

				
					Figure 4-5: A selected shape with the bounding box visible.

				

					[image: 9781118168608-fg020405.eps]

					2.	Open the Transform panel by choosing Window⇒Object and Layout⇒Transform.

					3.	In the Transform panel that appears, enter different number values in the W and H fields to change the size of the shape.

						The shape automatically changes size on the page to the new size dimensions you specify in the Transform panel.

				Changing the size with the Free Transform tool

					[image: 9781118168608-ma408.tif]	Easily resize objects in InDesign by using the Free Transform tool.

				To resize a selected object with the Free Transform tool, follow these steps:

					1.	Make sure that only the object you want to resize is selected.

				[image: tip.eps]		Group multiple objects if you want to resize several objects simultaneously. To group objects, select one object and Shift-click to add it to the selection, and then press Ctrl+G (Windows) or [image: maccmd]+G (Mac).

					2.	Select the Free Transform tool.

						A bounding box appears around the selected objects.

					3.	Click any corner point and drag to resize the object.

				[image: tip.eps]		Hold down the Shift key while dragging to keep the objects constrained proportionally as you resize.

				Changing the stroke of a shape

				You can change the stroke of shapes you’ve created. The stroke is the outline that appears around the edge of the shape. The stroke can range from no stroke to a very thick stroke, and it’s measured in point sizes. Even if a shape has a stroke set to 0 points, it still has a stroke — you just can’t see it.

				Follow these steps to edit the stroke of your shapes:

					1.	Select a shape on the page.

						A bounding box appears around the selected shape.

					2.	Select a new width for the Stroke by using the Stroke Weight drop-down list in the Control panel.

						As soon as a value is selected, the stroke automatically changes on the page. This number is measured in points. You use some of the other options in the following step list.

				You can click in the Stroke text field and manually enter a numerical value for the stroke width. The higher the number you enter, the thicker the stroke. You can also change the style of the stroke from the Control panel by following these steps:

					1.	With a basic shape selected, select the stroke type from the drop-down list in the Control panel and select a new line.

						As soon as a value is selected, the stroke automatically changes.

					2.	Choose a new line weight from the Stroke Weight drop-down list.

						For example, we chose 10 points. The shape updates automatically on the page.

				[image: tip.eps]	If you want to create custom dashes, you can see more options by choosing Window⇒Stroke. Choose the panel menu in the upper right corner of the panel and select Stroke Styles, and then create a new style. You can define the dash and gap size. Enter one value for an even dash or several numbers for custom dashes for maps, diagrams, fold marks, and more! Your custom stroke appears in the Stroke panel after you create it.

				Add special ends to the lines with the Start and End drop-down lists. For example, you can add an arrowhead or a large circle to the beginning or end of the stroke. The Cap and Join buttons allow you to choose the shape of the line ends and how they join with other paths when you’re working with complex paths or shapes. For more information on creating and editing lines and strokes, see Book I, Chapter 6.

				Changing the shear value

				You can change the shear of a shape by using the Transform panel. Skew and shear mean the same thing: The shape is slanted, so you create the appearance of some form of perspective for the skewed or sheared element. This transformation is useful if you want to create the illusion of depth on  a page.

				Follow these simple steps to skew a shape:

					1.	With a basic shape selected, choose Window⇒Object & Layout⇒Transform.

					2.	Select a value from the Shear drop-down list in the lower-right corner of the Transform panel.

						After you select a new value, the shape skews (or shears), depending on what value you select. Manually entering a numerical value into this field also skews the shape.

				Rotating a shape

				You can change the rotation of a shape by using the Transform panel. The process of rotating a shape is similar to skewing a shape (see the preceding section):

					1.	With a basic shape selected, choose Window⇒Object & Layout⇒Transform.

						The Transform panel opens.

					2.	Select a value from the Rotation drop-down list.

						After you select a new value, the shape rotates automatically, based on the rotation angle you specified. You can also manually enter a value into the text field.

				Drawing Freeform Paths

				You can use different tools to draw paths. For example, you can use the Pencil tool to draw freeform paths. These kinds of paths typically look like lines, and you can use the Pencil and Pen tools to create simple or complex paths.

				Using the Pencil tool

				The Pencil tool is perhaps the easiest tool to use when drawing freeform paths. (See Figure 4-6.)

					

				
					Figure 4-6:  This freeform drawing was created with the Pencil tool.

				

					[image: 9781118168608-fg020406.tif]

				Follow these steps to get started:

					1.	To create a new document, choose File⇒New, and then click OK in the New Document dialog box that appears.

						2.	[image: 9781118168608-ma421.tif] Select the Pencil tool in the Tools panel.

					3.	Drag the cursor around the page.

						You’ve created a new path by using the Pencil tool.

				Using the Pen tool

				Using the Pen tool is different from using the Pencil tool. When you start out, the Pen tool may seem a bit complicated — but after you get the hang of it, using it isn’t hard after all. The Pen tool uses points to create a particular path. You can edit these points to change the segments between them. Gaining control of these points can take a bit of practice.

				To create points and segments on a page, follow these steps:

					1.	Close any existing documents and create a new document by choosing File⇒New Document.

					2.	Click OK in the New Document dialog box that appears.

						A new document opens with the default settings.

						3.	[image: 9781118168608-ma411.tif] Select the Pen tool in the Tools panel.

					4.	Click anywhere on the page, and then click a second location.

						You’ve created a new path with two points and one segment joining them.

					5.	Ctrl-click (Windows) or [image: maccmd]-click (Mac) an empty part of the page to deselect the current path.

						After you deselect the path, you can create a new path or add new points to the path you just created.

					6.	Add a new point to a selected segment by hovering the mouse over the line and clicking.

						A small plus (+) icon appears next to the Pen tool cursor. You can also do the same thing by selecting the Add Anchor Point tool (located on the menu that flies out when you click and hold the Pen icon in the Tools panel).

					7.	Repeat Step 6, but this time click a new location on a line segment and drag away from the line.

						This step creates a curved path. The segments change and curve depending on where the points are located along the path. The point you created is a curve point.

				For more information about working with the Pen tool, check out Book III, Chapter 5.

				Editing Freeform Paths

				Even the best artists sometimes need to make changes or delete parts of their work. If you’ve made mistakes or change your mind about a drawing, follow the steps in this section to make changes.

				To change a path segment, select a point with the Direct Selection tool. When a point is selected, it appears solid; unselected points appear hollow.

				[image: tip.eps]	Select the Direct Selection tool by pressing the A key.

				All you need to do to select a point is use the cursor to click the point itself. Then you can use the handles that appear when the point is selected to modify the segments. Follow these steps:

					1.	Select the Direct Selection tool from the Tools panel, and then click a point.

						The selected point appears solid. If you select a curve point, handles extend from it.

						A curved point and a corner point edit differently when you select and drag them. Curve points have handles that extend from the point, but corner points don’t.

					2.	Drag the point where you want it; to edit a curve point, click a handle end and drag the handle left or right.

						The path changes, depending on how you drag the handles.

				Suppose that you want to make a corner point a curve point. You can do just that with the Convert Direction Point tool. To understand how the Convert Direction Point tool works best, you should have a path that contains both straight and curved segments. Follow these steps to change a corner point into a curved point and vice versa:

					1.	Select the Convert Direction Point tool.

						This tool resides on a menu under the Pen tool in the Tools panel. Hold down the mouse button over the Pen tool icon until a menu appears; select the Convert Direction Point tool from the menu.

					2.	Click a curved point with the Convert Direction Point tool.

						The point you click changes into a corner point, which changes the path’s appearance.

					3.	Click and drag a corner point with the Convert Direction Point tool.

						The point is modified as a curved point. This step changes the appearance of the path again.

				This tool is handy when you need to alter the way a path changes direction. If you need to manipulate a point in a different way, you may need to change its type by using the Convert Direction Point tool.

				Modifying Frame Corners 

				You can use corner effects on basic shapes to customize the shape’s look. Corner effects are useful for adding an interesting look to borders. You can be quite creative with some of the shapes you apply effects to or by applying more than one effect to a single shape. Here’s how to create a corner effect on a rectangle:

					1.	Select the Rectangle tool and create a new rectangle anywhere on  the page.

						Hold the Shift key when using the Rectangle tool if you want to create  a square.

					2.	With the Selection tool, select the shape, and then choose Object⇒Corner Options.

						The Corner Options dialog box opens.

					3.	Click OK.

						The corner option is applied to the shape.

				[image: tip.eps]	To adjust corner effects visually, use the Selection tool to click and select a frame. With the frame selected, click the yellow box that appears towards the top of the right edge of the frame. After clicking the yellow box, each corner handle becomes yellow, and can be dragged horizontally left or right to create a rounded corner. 

				Using Fills

				A fill is located inside a path. You can fill paths and shapes with several different kinds of colors, transparent colors, or even gradients. Fills can help you achieve artistic effects and illusions of depth or add interest to a page design.

				You may have already created a fill. The Tools panel contains two swatches: one for the stroke (a hollow square) and one for the fill (a solid box). (Refer to Chapter 1 of this minibook to locate the Fill and Stroke boxes.) If the Fill box contains a color, your shape has a fill when it’s created. If the Fill box has a red line through it, the shape is created without a fill.

				Creating basic fills

				You can create a basic fill in several different ways. One of the most common ways is to specify a color in the Fill swatch before you create a new shape. To create a shape with a fill, follow these steps:

					1.	Make sure that the Fill box is selected so that you aren’t adding color to the stroke instead.

					2.	Open the Color panel by choosing Window⇒Color⇒Color.

					3.	Select a color in the Color panel.

						You can enter values into the CMYK (Cyan, Magenta, Yellow, Black) fields manually or by using the sliders. Alternatively, you can use the Eyedropper tool to select a color from the color ramp at the bottom of the Color panel. For more information on color modes, such as CMYK and RGB, see Book I, Chapter 7.

				[image: tip.eps]		Use the Color panel menu to select different color modes if CMYK isn’t already selected. Click and hold the arrow button and select CMYK from the Color panel menu.

						The Fill box in the Tools panel is updated with the new color you’ve selected in the Color panel.

					4.	Create a new shape on the page.

						Select a shape tool and drag on the page to create a shape. The shape is filled with the fill color you chose.

				[image: tip.eps]	As in the other Creative Suite 6 applications, you can create tints of a color built with CMYK by holding down the Shift key while dragging any color’s slider. All color sliders then move proportionally.

				You can also choose to use color swatches to select a fill color by using the Swatches panel. (Choose Window⇒Color⇒Swatches to open the Swatches panel.) Create a new color swatch (of the present color) by clicking the New Swatch button at the bottom of the panel. Double-click the new swatch to add new color properties by using sliders to set CMYK color values or by entering numbers into each text field.

				Perhaps you already have a shape without a fill and you want to add a fill to it, or maybe you want to change the color of an existing fill. Select the shape and, with the Fill box in the Tools panel selected, select a color from the Color or Swatches panel. A new fill color is applied to the shape.

				[image: tip.eps]	You can drag and drop a swatch color to fill a shape on a page, even if  that shape isn’t selected. Open the Swatches panel by choosing Window⇒Color⇒Swatches, and then drag the color swatch over to the shape. Release the mouse button, and the fill color is applied automatically to the shape.

				Making transparent fills

				Fills that are partially transparent can create some interesting effects for the layout of your document. You can set transparency to more than one element on the page and layer those elements to create the illusion of depth and stacking.

				Follow these steps to apply transparency to an element on the page:

					1.	Using the Selection tool, select a shape on the page.

						A bounding box appears around the selected shape.

					2.	Open the Effects panel by choosing Window⇒Effects.

					3.	Use the Opacity slider to specify how transparent the shape appears.

						Click the arrow to open the slider or click in the text field to manually enter a value using the keyboard. The effect is immediately applied to the selected shape.

					4.	Select Stroke or Fill in the Effects panel to apply a separate opacity to each one.

				Looking at gradients

				A gradient is the color transition from one color (or no color) to a different color. Gradients can have two or more colors in the transition.

				Gradients can add interesting effects to shapes, including 3D effects. Sometimes you can use a gradient to achieve glowing effects or the effect of light hitting a surface. The two kinds of gradients available in InDesign are radial and linear, as shown in Figure 4-7 and described in this list:

				[image: check.png] Radial: A transition of colors in a circular fashion from a center point radiating outward

				[image: check.png] Linear: A transition of colors along a straight path

				You can apply a gradient to a stroke or a fill or even to text. To apply a gradient to a stroke, simply select the stroke instead of the fill.

				[image: warning_bomb.eps]	Even though you can apply a gradient to the stroke of live text, you’ll create a printing nightmare — use these features sparingly!

					

				
					Figure 4-7: A linear gradient (top) and radial gradient (bottom).

				

					[image: 9781118168608-fg020407.eps]

				Here’s how to add a gradient fill to a shape:

					1.	With the Selection tool, select the object you want to apply a gradient to and then choose Window⇒Color⇒Swatches.

						The Swatches panel opens.

					2.	Choose New Gradient Swatch from the Swatches panel menu.

						The New Gradient Swatch dialog box opens. (See Figure 4-8.)

					

				
					Figure 4-8: The New Gradient Swatch dialog box.

				

					[image: 9781118168608-fg020408.eps]

					3.	Type a new name for the swatch in the Swatch Name field.

						Sometimes, giving the swatch a descriptive name, such as one indicating what the swatch is being used for, is helpful.

					4.	Select Linear or Radial from the Type drop-down list.

						This option determines the type of gradient the swatch creates every time you use it. We selected Radial from the drop-down list. (See Figure 4-8.)

					5.	Manipulate the gradient stops below the Gradient Ramp to position each color in the gradient.

						Gradient stops are the color chips located below the Gradient Ramp. You can move the diamond shape above the Gradient Ramp to determine the center point of the gradient. You can select each gradient stop to change the color and move them around to edit the gradient. When the gradient stops are selected, you can change the color values in the Stop Color area by using sliders or entering values in each CMYK text field.

				[image: tip.eps]		You can add a new color to the gradient by clicking the area between gradient stops. Then you can edit the new stop, just like you edit the others. To remove the gradient stop, drag the stop away from the Gradient Ramp.

					6.	Click OK.

						The gradient swatch is created and applied to the selected object.

				[image: remember.eps]	To edit a gradient, double-click the gradient’s swatch. This step opens the Gradient Options dialog box, where you can modify the settings made in the New Gradient Swatch dialog box.

				Removing fills

				Removing fills is even easier than creating them. Follow these steps:

					1.	Select the shape with the Selection tool.

						A bounding box appears around the shape.

					2.	Click the Fill box in the Tools panel.

					3.	Click the Apply None button, located below the Fill box.

						The button is white with a red line through it. The fill is removed from the selected shape and the Fill box changes to No Fill. You also see the None fill on the Swatches and Color panels.

						If you’re using a single-row Tools panel, you don’t see the Apply None button unless you click and hold down the Apply Gradient (or Apply Color) button because the button is hidden beneath it.

				Adding Layers

				Layers are like transparent sheets stacked on top of one another. If you add layers to a drawing, you can create the appearance that graphics are stacked on top of one another. The Layers panel allows you to create new layers, delete layers you don’t need, or even rearrange layers to change the stacking order. Use layers to create alternative versions of InDesign files, or just to replace logos.

				Here’s how to work with layers in InDesign:

					1.	Open the Layers panel by choosing Window⇒Layers.

						This panel allows you to create, delete, and arrange layers.

					2.	Draw a shape on the page using a shape tool.

						Create the shape anywhere on the page and make it large enough so that you can easily stack another shape on top of part of it.

					3.	Click the Create New Layer button in the Layers panel to create a new layer.

						A new layer is stacked on top of the selected layer and becomes the active layer.

				[image: tip.eps]		Double-click a layer to give it an appropriate name or, even better, hold down the Alt (Windows) or Option (Mac) key and click the New Layer button to open the Layer Options dialog box before the layer is created.

				[image: warning_bomb.eps]		Make sure that the layer you want to create content on is selected before you start modifying the layer. You can tell which layer is selected because it’s always highlighted in the Layers panel. You can easily but accidentally add content to the incorrect layer if you don’t check this panel frequently. (If you add an item to the wrong layer, you can always cut and paste items to the correct layer.)

					4.	Make sure that a shape tool is still selected, and then create a shape on the new layer by dragging the cursor so that part of the new shape covers the shape you created in Step 2.

						The new shape is stacked on top of the shape you created in Step 2.

				For more information about working with layers, refer to Book III, Chapter 8. 

				

			

			
		

	
		
			
				Chapter 5: Understanding Color

				In This Chapter

				[image: check.png] Using color in page layout

				[image: check.png] Looking at color controls and models

				[image: check.png] Discovering swatches and swatch libraries

				Color can be an important part of designs you create. Advertisements often rely on color to relay brands or effective messages — think of the package delivery company based on brown or a soft drink company known for its red cans and bottles. Color can enhance your message and, when used consistently, helps create a brand identity. When you use color, you will want it to appear correctly, whether you’re printing or generating electronic documents. In this chapter, you find out some of the fundamental aspects of working with color and the basic instructions on how to prepare documents for printing.

				[image: tip.eps]	For more information on general subjects about color, see Book I, Chapters 7 and 8, which cover subjects such as color modes, inks, and printers, and basic color correction across the programs in the Adobe Creative Suite.

				Selecting Color with Color Controls

				You have several different color modes and options to choose when working in InDesign. In Chapter 4 of this minibook, we show you how to add color to drawings with the Color panel. In this section, we cover using the Color panel to choose colors and apply them to the elements on your page. In this chapter, you discover how to save colors as swatches so you can easily reuse them.

				You should use swatches whenever possible because they use named colors that a service provider can match exactly. A swatch can have exactly the same appearance as any color you choose that’s unnamed, but a swatch establishes a link between the color on the page and the name of a color, such as a Pantone color number. Discover more about these kinds of color in the later section “Using Color Swatches and Libraries.”

				You can use these color controls for choosing colors for selections in a document:

				[image: check.png] Stroke color: Choose colors for strokes and paths in InDesign. A hollow box represents the Stroke color control.

				[image: check.png] Fill color: Choose colors for filling shapes. A solid square box represents the Fill color control.

						You can toggle between the Fill and Stroke color controls by clicking them. Alternatively, you can press X on the keyboard to toggle between selected controls.

				[image: check.png] Text color: When you’re working with text, a different color control becomes active. The Text color control is visible and displays the selected text color. Text can have both the stroke and fill colored.

				To apply colors to selections, you can click the Apply color button below the color controls in the Tools panel. Alternatively, you can select and click a color swatch.

				[image: remember.eps]	The default colors in InDesign are a black stroke and no fill color. Restore the default colors at any time by pressing D. This shortcut works while using any tool, except the Type tool.

				Understanding Color Models

				You can use any of three kinds of color models in InDesign: CMYK (Cyan, Magenta, Yellow, Black), RGB (Red, Green, Blue), and LAB colors (Lightness and A and B for the color-opponent dimensions of the color space). A color model is a system used for representing each color as a set of numbers or letters (or both). The best color model to use depends on how you plan to print or display your document:

				[image: check.png] If you’re creating a PDF that will be distributed electronically and probably not printed, use the RGB color model. RGB is how colors are displayed on a computer monitor.

				[image: check.png] You must use the CMYK color model if you’re working with process color. Instead of having inks that match specified colors, you have four ink colors layered to simulate a particular color. Note that the colors on the monitor may differ from the ones that are printed. Sample swatch books and numbers can help you determine which colors you need to use in a document to match colors printed in the end.

				[image: check.png] If you know that the document needs to be printed by professionals who determine what each color is before it’s printed, it doesn’t matter whether you use CMYK, RGB, or Pantone colors. In many cases, CMYK colors give you a more accurate representation of what can be printed, because RGB colors are often more vivid and bright on your monitor.

				For more information on color models, check out Book I, Chapter 7. This chapter explains how colors are determined in the different color modes.

				Using Color Swatches and Libraries

				The Swatches panel and swatch libraries help you choose, save, and apply colors in your documents. The colors you use in a document can vary greatly. For example, one publication you make with InDesign may be for a newsletter that has only two colors; another may be a catalog printing with CMYK along with a separate spot color. For each document, you should customize the available swatches so you can work more efficiently.

				The Swatches panel

				You can create, apply, and edit colors from the Swatches panel. In addition to using this panel to create and edit tints and gradients and then apply them to objects on a page, you can also create and save solid colors. Choose Window⇒Color⇒Swatches to open or expand the Swatches panel.

				To create a new color swatch to use in a document, follow these steps:

					1.	Click the downward facing arrow located in the upper right corner of the Swatches Panel to open the Swatches panel menu; choose New Color Swatch.

						The New Color Swatch dialog box opens.

					2.	Type a new name for the color swatch or leave the color named by color values.

						The colors in the Swatches panel are named by their color values as  a default.

						The name you choose is displayed next to the color swatch when it’s entered into the panel.

					3.	Choose the color type from the Color Type drop-down list.

						Are you using a spot color, Pantone, for example, or Process, which is used when printing a color with Cyan, Magenta, Yellow, and Black (CMYK)?

					4.	Choose the color mode.

						From the Color Mode drop-down list, select a color mode. For this example, we use CMYK. Many of the other choices you see are prebuilt color libraries for various systems.

					5.	Create the color by using the color sliders.

						Note that if you start with Black, you have to adjust that slider to the left to see the other colors.

				[image: warning_bomb.eps]		If you choose a spot color, such as Pantone, to select a color you will be presented with a list of available color swatches instead of the color sliders.

					6.	Click OK or Add.

						Click Add if you want to continue adding colors to the Swatches panel or click OK if this color is the only one you’re adding. The color or colors are added to the Swatches panel. If you clicked Add, click OK when you’re done adding color swatches.

				[image: tip.eps]	You can make changes to the swatch by selecting it in the Swatches panel and then choosing Swatch Options from the panel menu, or by simply  double-clicking it in the Swatches panel.

				Swatch libraries

				Swatch libraries, also known as color libraries, are standardized sets of named colors that help you because they’re the most commonly and frequently used sets of color swatches. You can avoid trying to mix your own colors, which can be a difficult or tedious process to get right. For example, InDesign includes a swatch library for Pantone spot colors and a different library for Pantone process colors. These libraries are quite useful if you’re working with either color set. If you skipped over it, you may want to review the earlier section “Understanding Color Models,” where we explain the difference between spot and process colors.

				To choose a swatch from a swatch library, follow these steps:

					1.	Choose New Color Swatch from the Swatches panel menu.

						The New Color Swatch dialog box opens.

					2.	Choose the color type you want to work with from the Color Type drop-down list.

						Choose from Process or Spot Color types.

					3.	Select a color library from the Color Mode drop-down list.

						The drop-down list contains a list of color swatch libraries to choose from, such as Pantone Process Coated or TRUMATCH. After choosing a swatch set, the library opens and appears in the dialog box. For this example, we chose standard, solid-coated Pantone. If you’re looking for the standard numbered Pantone colors, this set is the easiest to choose from. The Pantone solid-coated library of swatches loads.

					4.	Pick a swatch from the library.

						Type a Pantone number, if you have one, in the Pantone text box. Most companies have set Pantone colors that they use for consistency. You can also scroll and click a swatch in the library’s list of colors, shown in Figure 5-1.

					

				
					Figure 5-1: Choose a color from the swatch library to add it to the Swatches panel.

				

					[image: 9781118168608-fg020501.eps]

				[image: warning_bomb.eps]		Picking Pantone colors using your color monitor isn’t easy. Your monitor doesn’t provide the most accurate representation of a color or show you how a color will print. If you plan to print your document in large volume, or if color is critical, we suggest spending a few dollars to get a color swatch book from Pantone. We use the Pantone Color Bridge Set. For more details about this guide, go to www.pantone.com and search for Color Bridge.

					5.	Click the Add button.

						This step adds the swatch to your list of color swatches in the Swatches panel. You can add as many color swatches as you like.

					6.	When you finish adding swatches, click the OK button.

						After you add a new color, the swatch is added to the list of swatches in the swatches panel and is ready to use in your project. Look in the swatches panel to see the newly added colors.

				

			

			
		

	
		
			
				Chapter 6: Clipping Paths, Alignment, and Object Transformation

				In This Chapter

				[image: check.png] Transforming objects with the Transform panel

				[image: check.png] Transforming objects with the Free Transform tool

				[image: check.png] Rotating and scaling objects

				[image: check.png] Shearing and reflecting objects

				[image: check.png] Adding a clipping path

				[image: check.png] Aligning and distributing objects in a layout

				In this chapter, you discover several different ways to manipulate and arrange objects on a page. You find out how to use the Transform panel and other tools in the Tools panel to transform objects on page layouts. You can make the same transformation in many different ways in InDesign, so for each way you can transform an object, we show you a couple different ways to do the same job.

				Aligning and distributing objects and images helps you organize elements logically on a page. In this chapter, you find out how to align objects by using the Align panel. In Chapter 4 of this minibook, we touch on vector paths. This chapter provides more information about clipping paths. We show you how to create a new path to use as a clipping path for an image in your document.

				Working with Transformations

				Chapter 4 of this minibook shows you how to transform graphic objects by skewing them. You can manipulate objects in InDesign in many other ways. You can transform an object by selecting an individual object and choosing the Transform panel which is available by clicking Window⇒Object & Layout⇒Transform, or by using the Free Transform tool to visually adjust objects.

				Looking at the Transform panel

				The Transform panel, shown in Figure 6-1, is extremely useful for changing the way an image or graphic looks and also for changing the scale, rotation, or skew of selected objects. You can choose from a range of values for some of these modifiers or manually set your own by typing them.

					

				
					Figure 6-1:  The Transform panel makes it easy to resize, rotate, and reposition selected objects.

				

					[image: 9781118168608-fg020601.eps]

				The Transform panel offers the following information and functionality:

				[image: check.png] Reference point: Indicates which handle is the reference for any transformations you make. For example, if you reset the X and Y coordinates, the reference point is set to this position. In Figure 6-1, the reference point is in the center, as indicated by the solid square.

				[image: check.png] Position: Change these values to reset the X and Y coordinate position of the selected object.

				[image: check.png] Size: The W and H text fields are used to change the current dimensions of the object.

				[image: check.png] Scale: Enter or choose a percentage from the Scale X Percentage and Scale Y Percentage drop-down lists to scale (resize) the object on either of these axes.

				[image: check.png] Constraining proportions: Click the Constrain Proportions button to maintain the current proportions of the object being scaled.

				[image: check.png] Shearing: Enter or choose a negative or positive number to modify the shearing angle (skew) of the selected object.

				[image: check.png] Rotation angle: Set a negative value to rotate the object clockwise; a positive value rotates the object counterclockwise.

				When you’re scaling, shearing, or rotating an object in your layout, it transforms based on the reference point in the Transform panel. For example, when you rotate an object, InDesign considers the reference point to be the center point of the rotation.

				Click a new reference point square in the Transform panel to change the reference point of the graphic to the equivalent bounding box handle of the selected object.

				Using the Free Transform tool

					[image: 9781118168608-ma008.tif]	The multipurpose Free Transform tool lets you transform objects in different ways. Using the Free Transform tool, you can move, rotate, shear, reflect, and scale objects.

				The functions of the Free Transform Tool are represented in InDesign by different cursors, as shown in Figure 6-2.

					

				
					Figure 6-2: Different cursors indicate options for using the Transform tool.

				

					[image: 9781118168608-fg020602.eps]

				To move an object by using the Free Transform tool, follow these steps:

					1.	Use the Selection tool to select an object on the page.

						You can use an object that’s already on the page or create a new shape by using the drawing tools. When the object is selected, you see handles around its edges.

					2.	Select the Free Transform tool from the Tools panel.

						The cursor changes to the Free Transform tool.

					3.	Move the cursor over the middle of the selected object.

						The cursor changes its appearance to indicate that you can drag to move the object. (Refer to Figure 6-2.) If you move the cursor outside the edges of the object, the cursor changes when other tools, such as rotate, scale, and shear, become active.

					4.	Drag the object to a different location.

						The object is moved to a new location on the page.

				Rotating objects

				You can rotate an object by using the Free Transform tool or the Transform panel. Use the panel to enter a specific degree that you want the object to rotate. The Free Transform tool lets you visually manipulate the object on the page.

				To rotate an image by using the Free Transform tool, follow these steps:

					1.	Select an object on the page with the Selection tool.

						Handles appear around the edges of the object. You can rotate any object on the page.

					2.	Select the Free Transform tool in the Tools panel and move it near the handle of an object outside the bounding box.

						The cursor changes when you move it close to the handle of an object. For rotation, you must keep the cursor just outside the object.

					3.	When the cursor changes to the rotate cursor, drag to rotate the object.

						Drag the cursor until the object is rotated the correct amount.

				Alternatively, you can use the Rotate tool to spin an object by following these steps:

					1.	With the object selected, select the Rotate tool in the Tools panel by clicking and holding the arrow in the lower corner of the Free Transform tool, then move the cursor near the object.

						The cursor looks similar to a cross hair.

					2.	Click the cursor anywhere on the page near the object.

						The point that the object rotates around is set on the page.

					3.	Drag the cursor outside the object.

						The object rotates around the reference point you set on the page. Hold the Shift key if you want to rotate in 45-degree increments.

				You can also rotate objects by using the Transform panel. Here’s how:

					1.	Select an object on the page with the Selection tool.

						The bounding box with handles appears around the selected object.

					2.	If the Transform panel isn’t open, choose Window⇒Object & Layout⇒Transform.

						The Transform panel appears.

					3.	Select a value from the Rotation Angle drop-down list or click the text field and enter a percentage.

						The object rotates to the degree you set in the Transform panel. Negative angles (in degrees) rotate the image clockwise, and positive angles (in degrees) rotate the image counterclockwise.

				Scaling objects

					[image: 9781118168608-ma223.tif]	You can scale objects by using the Transform panel (refer to Figure 6-1), the 

				
					
				
				[image: 9781118168608-ma008.tif] Scale tool, or the Free Transform tool. Use the Transform panel to set exact width and height dimensions that you want to scale the object to, just as you can set exact percentages for rotating.

				To scale an object by using the Free Transform tool or the Scale tool, follow these steps:

					1.	Select an object on the page.

						A bounding box appears around the object.

					2.	Select the Free Transform tool or the Scale tool from the Tools panel.

					3.	Move the cursor directly over a corner handle.

						The cursor changes into a double-ended arrow. (Refer to Figure 6-2.)

					4.	Drag outward to increase the size of the object; drag inward to decrease the size of the object.

				[image: tip.eps]		If you want to scale the image proportionally, hold down the Shift key while you drag.

					5.	Release the mouse button when the object is scaled to the correct size.

				To resize an object using the Transform panel, select the object and enter new values into the W and H text fields in the panel. The object then resizes to those exact dimensions.

				Shearing objects

				Shearing an object means that you’re skewing it horizontally, slanting it to the left or right. A sheared object may appear to have perspective or depth because of this modification. You use the Shear tool to create a shearing effect, as shown in Figure 6-3.

					

				
					Figure 6-3: The original image is on the left, and the sheared image is on the right.

				

					[image: 9781118168608-fg020603.tif]

				Follow these steps to shear an object:

					1.	Select an object on the page.

						The bounding box appears around the object that’s selected.

						2.	[image: 9781118168608-ma010.tif] Choose the Shear tool in the Tools panel by clicking and holding the Free Transform tool.

						The cursor changes so that it looks similar to a cross hair. Click the corner of the object that you want to shear from, and a cross hair appears, as shown in Figure 6-3.

					3.	Click anywhere above or below the object and drag.

						The selected object shears depending on which direction you drag. Press the Shift key while you drag to shear an object in 45-degree  increments.

				[image: tip.eps]	To shear objects with the Free Transform tool, begin dragging a handle and then hold down Ctrl+Alt (Windows) or [image: maccmd]+Option (Mac) while dragging.

				You can also enter an exact value into the Transform panel to shear an object. Select the object and then enter a positive or negative value in the panel representing the amount of slant you want to apply to the object.

				[image: tip.eps]	You can apply shear by choosing Object⇒Transform⇒Shear to display the Shear dialog box.

				Reflecting objects

				You can reflect objects to create mirror images by using the Transform panel menu. The menu provides several additional options for manipulating objects.

				Follow these steps to reflect an object:

					1.	Select an object on the page and then choose Window⇒Object & Layout⇒Transform to open the Transform panel or open it from the Window menu.

						The object’s bounding box and handles appear. The Transform panel shows the current values of the selected object.

					2.	Click the panel menu in the Transform panel.

						The menu opens, revealing many options available for manipulating the object.

					3.	Select Flip Horizontal from the Transform panel menu.

						The object on the page flips on its horizontal axis. You can repeat this step with other reflection options in the menu, such as Flip Vertical.

				[image: tip.eps]	You can also reflect objects with the Free Transform tool by dragging a corner handle past the opposite end of the object. The object reflects on  its axis.

				Understanding Clipping Paths

				Clipping paths allow you to create a path that crops a part of an image based on the path, such as removing the background area of an image. This shape can be one you create using InDesign, or you can import an image that already has a clipping path. InDesign can also use an existing alpha or mask layer, such as one created using Photoshop or Fireworks, and treat it like a clipping path. Clipping paths are useful when you want to block out areas of an image and have text wrap around the leftover image.

				You can create a clipping path directly in InDesign by using a drawing tool, such as the Pen tool. You use the tool to create a shape and then paste an image into this shape on the page. If you expect you’ll want to re-use the clipping path and the image in the future, create the path in Photoshop and save it as part of the image instead. See the Photoshop minibook for more details on how to do this.

				Here’s a quick way to remove the background of an image using InDesign:

					1.	Choose File⇒Place and browse to locate and open an image.

						2.	[image: 9781118168608-ma216.tif] With the Pen tool, create a path right on top of the image.

						The path should be created so that it can contain the image.

					3.	With the Selection tool, click to select the image and then choose File⇒Cut.

					4.	Select the shape you created in Step 1 and choose Edit⇒Paste Into.

						The image is pasted into the selected shape you drew with the Pen tool.

				If an image placed into your InDesign layout already includes a clipping path, you can choose to use it by selecting Show Import Options at the time you place the image into your layout.

				If that image contains multiple paths, you can choose which path to use by selecting Object⇒Clipping Path⇒Options, and then selecting either Alpha Channel or Clipping Path from the Type menu, depending upon what is used in the image.

				If an image you import into your layout was photographed against a solid background — such as a picture of a product for a catalog that was taken against a white background — you can have InDesign create a clipping path for that image. Here’s how:

					1.	Using the Selection tool, click to select an image on your page that has a solid background, such as a white background.

					2.	Choose Object⇒Clipping Path⇒Options.

					3.	In the Clipping Path dialog box, click the Type drop-down menu and choose Detect Edges. Adjust the threshold slider until the background surrounding the image disappears.

					4.	Click OK.

						The path is created so that the image is visible and the background has been removed. The image can be placed over any other object, and it will reveal any items behind it. 

				[image: tip.eps]		For a clipping path to reveal objects behind it, the object with the clipping path needs to be at the top-most layer or the top-most object within its layer. You can check this by selecting the object and choosing Object⇒Arrange⇒Bring to Front and also using the layers panel, available by choosing Window⇒Layers.

				Arranging Objects on the Page

				In other chapters of this minibook, we show you how to arrange objects on the page. However, you can arrange text or objects in a few other ways. This section covers the additional ways you can arrange objects, which gives you more control over the placement of elements in your document.

				Aligning objects

				In CS6, you can align visually without the need for any extra tools or panels. If you keep Smart Guides activated (they’re on by default), when you use the Selection tool to select and move objects around a page, guides appear automatically. These guides appear when the selected object is aligned with other objects on the page or with the page itself. If viewing these pesky guides starts to bother you, choose Edit⇒Preferences⇒Guides & Pasteboard (Windows) or InDesign⇒Guides & Pasteboard (Mac) and turn off the four options underneath the Smart Guide Options heading.

				You can also align objects on a page by using the Align panel: Choose Window⇒Object & Layout⇒Align. This panel gives you control over the way elements align to one another or to the overall page. The Align panel has many buttons to control selected objects. Mouse over a button to see its tooltip describe how that button aligns elements.

				[image: tip.eps]	If you’re not sure what each button does after reading the associated tooltip, look at the icon on the button. The icon is sometimes helpful in depicting what the Align button does to selected objects.

				Here’s how to align elements on the page:

					1.	Select several objects on the page with the Selection tool.

						Hold the Shift key while clicking each object to select several objects.

						Each object is selected when you click it on the page. If you don’t have a few objects on a page, quickly create a couple new objects by using the drawing tools.

					2.	Choose Window⇒Object & Layout⇒Align.

						The Align panel opens.

					3.	Select the kind of alignment you want to apply to the selected objects.

						Try clicking the Align Vertical Centers button. Each selected object aligns to the vertical center point on the page.

				Distributing objects

				In the preceding step list, we show you how to align a few objects on a page, which is easy enough. However, what if the objects you’re aligning aren’t distributed evenly? Maybe their centers are lined up but there’s a large gap between two of the images and a narrow gap between the other ones. In that case, you need to distribute objects and align them. Distribute objects on the page to space them relative to the page or to each other in different ways. Here’s how:

					1.	Select objects on a page that are neither aligned nor evenly distributed by using the Selection tool while holding the Shift key.

						The objects are selected when you click each one. All objects you select will be aligned to each other on the page.

					2.	If the Align panel isn’t open, choose Window⇒Object & Layout⇒Align.

						The Align panel opens.

					3.	Click the Distribute Horizontal Centers button and then click the Align Vertical Centers button directly above it on the Align panel.

				The selected objects are distributed evenly and aligned horizontally on  the page.

				Don’t forget about the cool Multiple Place feature: It lets you distribute and align on the fly! Try this handy option to place several images at one time:

					1.	Choose File⇒Place.

					2.	Press Ctrl (Windows) or [image: maccmd] (Mac), select multiple images, and then click the Open button.

					3.	Before clicking to place the images, hold down Ctrl+Shift (Windows) or [image: maccmd]+Shift (Mac).

						The cursor appears as a grid, as shown in Figure 6-4.

					4.	Click and drag to create the rectangle that you want your images aligned to and distributed within.

						The images are aligned and distributed automatically, as shown in Figure 6-5.

					

				
					Figure 6-4:  Place multiple images by holding down Ctrl+Shift (Windows) or [image: maccmd]+Shift (Mac) and dragging.

				

					[image: 9781118168608-fg020604.tif]

					

				
					Figure 6-5: Images are aligned and distributed automatic- ally when placed.

				

					[image: 9781118168608-fg020605.tif]

			

			

		

	
		
			
				Chapter 7: Exporting to PDF, Flash, and Printing

				In This Chapter

				[image: check.png] Checking (preflighting) documents

				[image: check.png] Packaging documents for delivery

				[image: check.png] Understanding file formats

				[image: check.png] Exporting to different file formats

				[image: check.png] Printing documents

				In addition to printing, you can also export InDesign documents into several different kinds of file formats. In this chapter, we take a closer look at the preparations for delivering a file to a print vendor as well as many of the different kinds of files you can create electronically from an InDesign document. (We cover HTML, ePub, and digital document export in the next chapter.) Before you print a document, it’s good to make sure you have everything you need, so we start by looking at the preflight option.

				Preflight: Preparing Your Documents for Printing

				The Preflight feature in InDesign helps confirm that everything you need to print your document is ready and available. It also provides information about the document you’re printing, such as listing its fonts, print settings, and inks used. Using Preflight can help you determine whether your InDesign document has unlinked images or missing fonts before printing it. Here’s how to use the preflight option:

					1.	Choose Window⇒Output⇒Preflight.

						The Preflight panel opens. The Summary screen shows you all  current images and fonts in the document, based on an analysis of  that document.

					2.	Make sure the On check box is selected and the Profile is set to [Basic] (working). 

						These settings provide a basic preflight of the document, confirming that all images and fonts are available for printing, and that nothing unusual exists in the color that might cause common printing errors.

					3.	If any errors are noted in the document, click the page number listed to the right of the error in the preflight window to view the error.

						Common errors, such as missing fonts and overset text (text that doesn’t fit completely into a text frame) are all listed in the Preflight panel, and can generally be corrected easily with a little time. It’s much better to fix errors before you print them!

				[image: tip.eps]	When the preflight option is turned on, a small green or red circle appears along the bottom left corner of the document window. Green indicates that the document is preflighted and no errors are reported, whereas red indicates a possible error. You can simply click the circle along the bottom-left corner of the document window to open the Preflight panel and investigate any possible errors.

				Packaging Your Documents

				If you need to deliver your documents to a print service provider or to another designer, you’ll want to give them everything they need to continue working on the InDesign file. This is where the Package command is helpful. Package gathers copies of all images and fonts used in the document along with a copy of the InDesign document itself into a single folder that you can easily deliver to a print service provider or to a colleague. You can even use this option to archive completed jobs, to make sure that all necessary elements are stored together. Here’s how:

					1.	Choose File⇒Package.

						The Package dialog box opens. The Summary screen shows you all current images and fonts in the document, based on an analysis of that document.

					2.	Click Fonts in the list on the left side of the dialog box.

						Any fonts in your document are listed on this screen. Select fonts from this list and click the Find Font button to discover where they’re located. These fonts are saved directly into the package folder when you finish.

					3.	Click Links and Images in the list on the left side of the dialog box.

						The Links and Images screen lists the images within your document. Find the image, update it, and repair links before packing the file. If any images aren’t properly linked, your document is incomplete and prints with pictures missing.

					4.	When you’re finished, click the Package button at the bottom of the dialog box.

						Your document and all its associated files are saved into a folder. You’re given the opportunity to name the folder and specify a location on your hard drive.

				[image: tip.eps]	If you’re taking a file to a professional print service provider, you can give them your original InDesign document or you can create a high-quality PDF file suitable for printing. It’s a good idea to ask your print service provider about the file type they prefer to receive. By providing an InDesign file, you give them a chance to fine-tune the document before printing, and if you provide a PDF, the document has limited capabilities for editing. Different print vendors prefer to receive different file types.

				Understanding File Formats

				The kind of file you decide to create by exporting depends on your needs. The first thing to determine is where you’ll use the exported file. For example, you might need to

				[image: check.png] Put an image of your InDesign document or page on the web

				[image: check.png] Send an entire document to someone who doesn’t have InDesign but wants to receive it by e-mail

				[image: check.png] Import the content into a different program, such as Macromedia Flash or Adobe Illustrator

				[image: check.png] Take a particular kind of file somewhere else to print it

				Exporting InDesign documents lets you make them “portable” so that they can be used in different ways — such as on the web or in another program. You can choose from the many file formats InDesign supports, and you can control many settings related to the files you create.

				Some of the file formats you can create from InDesign are listed in Table 7-1.

				Table 7-1	File Formats

				
					
						
								
								File Format

							
								
								Description

							
						

						
								
								JPEG (Joint Photographic Experts Group), PNG (Portable Network Graphics)

							
								
								Either of these commonly used formats for compressed images is a good choice for creating a picture of an InDesign page to post on a website. This is only a picture and is good for something like a thumbnail image representing a document. Don’t use this if you want someone to actually read the InDesign file on the web — for that you’ll want to export to HTML or PDF. This is simply a picture preview of what a document page looks like.

							
						

						
						
								
								EPS (Encapsulated PostScript)

							
								
								A self-contained image file that contains high-resolution printing information about all the text and graphics used on a page. This format is commonly used for high-quality printing when you need to have an image of an InDesign page used within another document — such as a picture of a book cover created with InDesign that needs to appear in a promotional catalog — so that you can use an EPS of the book cover in your layout.

							
						

						
								
								XML (Extensible Markup Language)

							
								
								Lets you separate the content from the layout so that all the content on a page can be repurposed and used in different ways — online or in print. Corporations commonly use XML for storing their product data when they have a large amount of information — such as thousands of items in a catalog.

							
						

						
								
								FLA and SWF

							
								
								Use the FLA (Flash) file format if you want to take your InDesign document into Flash, add interactivity to it, and continue to edit the document. Use the SWF (ShockWave Flash) format to deliver the PDF for viewing in a web browser as an SWF file for viewing (but not editing). Note that many web browsers no longer support the SWF file format, so use this option only if you are certain the recipient is able to view the file. 

							
						

						
								
								PDF (Portable Document Format)

							
								
								Used to exchange documents with users on different computer systems and operating systems. This format is used extensively for distributing files such as e-books and brochures. You may need to distribute the file to a wide audience or to a service provider for printing. Anyone who has installed Adobe Reader (also known as Acrobat Reader) on a computer can view your document. You can export PDFs designed for printing by selecting PDF (Print). Select PDF (Interactive) if your PDF contains hyperlinks or movies and will be distributed on-line instead of being printed.

							
						

						
								
								Rich or Plain text (text files)

							
								
								Can include formatting (Rich) or plain text only (Plain). A text file is a simple way to export content. If you need the text from your document only to incorporate or send elsewhere, you can export it as plain (Text Only), tagged, or rich text. If you need to send a document to someone who doesn’t have InDesign, exporting it as text may be a good option.

							
						

						
								
								EPUB

							
								
								Use the ePub file format to create electronic books that can be read using an electronic book reader, including devices such as the nook or iPad, or using any eBook reader software. With additional conversion, this file can also be read on the Amazon Kindle.

							
						

						
						
								
								HTML

							
								
								Use the HTML file format to export a document as HTML (HyperText Markup Language), which is the language used by web browsers. Documents exported using this option typically require some HTML editing for formatting and design, which you can do using Adobe Dreamweaver.

							
						

						
								
								IDML

							
								
								Use the InDesign Markup Language option to export InDesign documents in a format that can be read by earlier versions of InDesign. For example, if you have a colleague using InDesign CS5 and you want to provide them with your document, but you are using InDesign CS6, export the document using the IDML option and they will be able to open it. If you simply save the file, the older version of InDesign is not able to open the document.

							
						

					
				

				[image: remember.eps]	JPEG, PDF, and EPS files can be exported from InDesign and then imported into other software programs. You can export these images for use in print after they’re imported into a different graphics program, or you can use the images on the web. It all depends on how you set up the document for export and the settings you use.

				After determining in which file format to export your file, take a look at how to export these files and the different kinds of settings you can control when doing so. The rest of this chapter shows you how to export different file types from InDesign.

				Exporting Publications

				You can export publications from the Export dialog box. After you open it by choosing File⇒Export, you can choose the file format, name, and location. After specifying a name and location and a format to export to, click Save. A new dialog box opens, where you can make settings specific to the file format you picked. We discuss in the following sections some of the most common file formats you’re likely to use for export.

				Exporting PDF documents for printing

				Create a PDF file of your document if you want to make sure what you created is exactly what a viewer sees — even if they don’t have InDesign. A PDF file also limits the editing capabilities, making it unlikely your document will be changed. If you choose to export a PDF document, you have many options to customize the document you’re exporting. You can control the amount of compression in the document, the marks and bleeds it has in InDesign, and its security settings. Here’s how to export to PDF:

					1.	Choose File⇒Export.

						The Export dialog box opens.

					2.	Choose a location in which to save the file and then enter a new  filename.

						Browse to a location on your hard drive using the Save In drop-down list (if you’re using Windows) and name the file in the File Name text field. If you’re using a Mac, name the file in the Save As text field and select a location from the Where drop-down list.

					3.	Select Adobe PDF (Print) from the Save As Type (Windows) or Format (Mac) drop-down list at the bottom of the Export window.

					4.	Click Save.

						The Export PDF dialog box appears with the General options screen open.

					5.	Choose a preset from the Preset drop-down list.

						These presets are easy to use. If you’re familiar with Adobe Acrobat and the Adobe Distiller functions, they’re the same. (For more detailed information about what each setting does, see Book V.)

				[image: tip.eps]		The presets on the Preset drop-down list automatically change the individual export settings of a document. For example, you can select Smallest File Size from the list if you’re displaying your work online or select High Quality Print if you plan for the PDF to be printed on home printers. Select Press Quality if you intend to have the PDF professionally printed.

					6.	Leave the Standard drop-down list at None.

						Leave it at None unless, of course, you know about the PDF/X standards used for sharing advertisements. (For more on PDF/X, see Book III.)

					7.	Select a range of pages to export by typing the start page (and then a hyphen) and the end page in the Range text box.

						You can also export nonconsecutive pages by separating the page numbers with a comma.

						By default, all pages are exported.

					8.	Choose a compatibility setting for the PDF from the Compatibility drop-down list.

						Compatibility settings determine which kind of reader is required in order to view the document. Setting compatibility to Acrobat 5 (PDF 1.4) ensures that a wide audience can view your PDF files. Some older PDF readers may not be able to interpret certain features in your document if you choose compatibility for a higher version. The current version of Acrobat that ships with Adobe Creative Suite 6 is Acrobat X (or 10). Setting this value to Acrobat 5 or later ensures that anyone who has installed Adobe Reader or Acrobat in the past 10 years will be able to view the PDF file.

					9.	Choose whether to embed thumbnails and whether to optimize the document, and then choose which kinds of elements to include in the file by selecting the check box to the left of the options in the Include section.

						Other settings specify the inclusion of bookmarks, links, and other elements in the file. Unless you’ve added any of these elements, you don’t need to worry about selecting these options. You may want to embed thumbnail previews, but Acrobat creates thumbnails automatically when the file is opened, so this can add to the file size unnecessarily.

				[image: technicalstuff.eps]		Click Security in the list on the left of the Export PDF dialog box to open the Security screen, where you can specify passwords to open the document. You can also choose a password that’s required to print or modify the PDF file.

					10.	Click the Export button to export the file.

						The file is saved to the location you specified in Step 2.

				Exporting EPS files

				From InDesign, you can export EPS files, which are useful for importing into other programs. EPS files are single-page graphics files, which means that each exported InDesign page is saved as a separate EPS file. 

				[image: tip.eps]	You have no need to export an EPS file to place an InDesign file into another InDesign file! If you’re creating classified pages or any page that contains other InDesign pages, you can save yourself a few steps by simply choosing File⇒Place and selecting the InDesign file. InDesign can import InDesign files into a layout, or even PDFs — so the only reason to export to EPS is to create a picture for an older software or database that doesn’t work with newer file formats.

				Here’s how to export EPS files:

					1.	Choose File⇒Export.

						The Export dialog box opens.

					2.	Select a location on your hard drive to save the EPS files, enter a new filename, and select EPS from the Save As Type (Windows) or Format (Mac) drop-down list; click Save.

						The Export EPS dialog box opens.

					3.	Choose a page or range of pages to export.

						Select the All Pages option to export all pages or select the Ranges option and enter a range of pages. If you want spreads to export as one file, select the Spreads radio button.

						If you’re creating more than one EPS file (for example, exporting more than one page of your InDesign document), the file is saved with the filename, an underscore, and then the page number. For example, page 7 of a cats.indd file would be saved as cats_7.eps in the designated location.

					4.	From the Color drop-down list, select a color mode; from the Embed Fonts drop-down list, select how to embed fonts.

						From the Color drop-down list, select Leave Unchanged to retain the color mode you’re using for the InDesign document. You can also change the color mode to CMYK (Cyan, Magenta, Yellow, Black), Gray (grayscale), or RGB (Red, Green, Blue). For more information on color modes, flip back to Chapter 5 of this minibook.

						From the Embed Fonts drop-down list, select Subset to embed only the characters used in the file. If you select Complete, all fonts in the file are loaded when you print the file. Selecting None means that a reference to where the font is located is written into the file.

					5.	Choose whether you want a preview to be generated for the file by choosing from the Preview drop-down list.

						A preview (a small thumbnail image) is useful if an EPS file can’t be displayed. For example, if you’re browsing a library of images, you see a small thumbnail image of the EPS file; so whether or not you use the image or open it on your computer, you can see what the file looks like. From the Preview drop-down list, you can select TIFF to generate a preview; select None if you don’t want a preview to be created.

					6.	Click the Export button to export the files.

						The files are saved to the location you designated in Step 2.

				Exporting JPEG and PNG files

				You can export JPEG and PNG files from an InDesign document. These file formats are commonly used in web publishing and are useful if you need to place a picture of an InDesign document or page online. You can export as a JPEG or PNG image either a single object on the selected page or export entire pages and spreads. JPEG and PNG files allow you to effectively compress full color or black-and-white images, which is useful if you need a picture of an InDesign page to appear on the web.

				To export a JPEG or PNG image, follow these steps:

					1.	Select an object on a page or make sure that no object is selected if you want to export a page or spread.

					2.	Choose File⇒Export.

						The Export dialog box opens.

					3.	Type a filename, locate the spot where you want to save the file on your hard drive, and select either JPEG or PNG from the Save As Type (Windows) or Format (Mac) drop-down list; click Save.

						The Export JPEG or PNG dialog box opens.

					4.	If you want to export a page, select the Page option and enter the page number; if you want to export the selected object, make sure that the Selection option is selected.

						The Selection option is available only if a selection was made in Step 1.

					5.	Choose an image quality and format to export by selecting from the Image Quality and Format Method drop-down lists.

						The Image Quality drop-down list controls the amount of compression that’s used when you export a JPEG or PNG file. Choose from these options:

					•	Maximum: Creates an image with the largest file size and highest quality

					•	High: Creates an image with a larger file size and high quality

					•	Medium: Creates an image with medium file size and medium quality

					•	Low: Creates a smaller file of lesser quality because it includes less image information

						These options don’t appear if you are creating a PNG image.

						If you select the Baseline format from the Format Method drop-down list, the entire image has to be downloaded before it’s displayed in a web browser. Select Progressive to show the image in a progressively complete display as it downloads in a web browser. 

					6.	Click the Export button.

						The file is exported and saved to the location you specified in Step 3.

				Exporting to Flash 

				Using InDesign CS6, you can export an InDesign document as a Flash Professional file (FLA) that can be edited in Flash CS6, or as a Flash Player (SWF) file that can be viewed (but not edited).

				[image: remember.eps]	Many modern web browsers do not support Flash, including the browsers on the Apple iPhone, iPad, and Windows Phone. Microsoft has announced that the next-generation Internet Explorer browser will not support plug-ins such as Flash. Because the Flash file format is currently on the decline, you should carefully consider whether you want to export to Flash at all. We suggest you review other options for exporting digital documents, which we cover in the next chapter in this minibook. However, because Flash export is still an available option, we cover it here.

				To export to the Flash Player (SWF) format, follow these steps:

					1.	Choose File⇒Export.

						The Export dialog box appears.

					2.	Choose a location to save the files, enter a new filename, and choose Flash Player (SWF) from the Save As Type (Windows) or Format (Mac) drop-down list.

				[image: tip.eps]		If you need to include video, audio, animation, or complex interactivity, export the file in Flash CS6 Professional (FLA) format because you can then use Flash Professional to modify and edit the file until it meets your exact needs. While the SWF format will quickly create a SWF version of your document which can be viewed online, it doesn’t provide you with an option to refine and edit your choices after exporting. To create an FLA file that can be edited using Flash CS6 Professional, choose Flash CS6 Professional (FLA) as the export choice instead of Flash Player (SWF).

						In the Export SWF dialog box, shown in Figure 7-1, you can set the output size, specify pages to include, and make various conversion and compression choices.

					

				
					Figure 7-1: Choose the export options to export a file in the SWF format.

				

					[image: 9781118168608-fg020701.eps]

					3.	Choose the size you want for the exported file.

						Select the Scale option and leave the drop-down list at 100% if you don’t want to change the size of the exported file. Otherwise, select the Fit To option and select from the drop-down list or select the Width option and enter your own dimensions in the Width and Height drop-down lists.

					4.	Select which page or pages you want to export.

						Select the All Pages option to export the entire document; select  Range and enter a page number if you want to export only a specific page or pages. 

					5.	Select the Interactivity options you want by choosing whether  you want to include all interactive options or only those that affect appearance.

					6.	Choose whether you want an interactive page curl to appear at the top corner of the document page.

					7.	Click OK to export your InDesign document as a Flash file.

				Exporting text files

				You can extract text from an InDesign document so that it can be edited or used elsewhere. The text formats vary slightly depending on the text in your document.

				To export text, follow these steps:

					1.	Select the Text tool from the toolbox and select some text within a text frame in your document, or place the cursor within a text frame where you want to export all the text.

						The cursor must be in a text frame in order to export text.

					2.	Choose File⇒Export.

						The Export dialog box opens.

					3.	Enter a filename, select a location to save the file in, and select Text Only from the Save As Type (Windows) or Format (Mac) drop-down list; click Save.

						The Text Export Options dialog box opens.

					4.	Choose a platform and encoding for the export.

						Select either PC or Macintosh from the Platform drop-down list to set the PC or Mac operating system compatibility. Select an encoding method for the platform you choose from the Encoding drop-down list; you can choose either Default Platform or Unicode.

						The universal character-encoding standard Unicode is compatible with major operating systems. Encoding, which refers to how characters are represented in a digital format, is essentially a set of rules that determines how the character set is represented by associating each character with a particular code sequence.

					5.	Click the Export button.

						The file is exported and saved to the location you specified in Step 3.

				Printing Your Work

				You can print your work from an InDesign document in many different ways, with many kinds of printers and processes. You can either use your home or office printer, or you can take your work to a professional printing service. Both printers and printing services vary in the quality of production they can offer you.

				The following subsections look at the different ways you can set up a document for printing and the kinds of issues you may encounter during this process.

				Understanding bleed

				If you want an image or span of color to go to the edge of a page, without any white margins, you bleed it off the edge of the document. Bleeding extends the print area slightly beyond the edge of the page into the area that will be cut and removed during the printing process. (Professional printers sometimes print your documents on a larger page size than necessary, and then trim off the extra paper.) You can bleed your own work, too. While you’re designing, you can turn on crop and bleed marks to show where the page needs to be trimmed to make sure that the image bleeds far enough off the edge of the page area. We cover this topic in the next section.

				Doing it yourself: Printing and  proofing at home or the office

				Because many InDesign documents are designed to be professionally printed, the available print settings are quite robust. Just because they are robust doesn’t make them complicated, though. We demystify the settings for you here:

				Choose File⇒Print to open the Print dialog box. Choose the printer you intend to use from the Printer drop-down menu. If you don’t have a printer, choose Adobe PDF from the Printer drop-down menu to follow-along with the steps below.

				Many printing options are available in the list on the left side of the Print dialog box. Clicking an item causes the dialog box to change, displaying the settings you can change for the selected item. Click each of the items below to better understand these common printing options:

				[image: check.png] General: Set the number of copies of the document you want to print and the range of pages to print. You can select the Reverse Order check box to print from the last to first page. Select an option from the Sequence drop-down list to print only even or odd pages instead of all pages. If you’re working with spreads that need to be printed on a single page, select the Spreads radio button.

				[image: check.png] Setup: Define the paper size, orientation (portrait or landscape), and scale. You can scale a page so that it’s as much as 1,000 percent of its original size or as little as 1 percent. You can (optionally) constrain the scale of the width and height so that the page remains at the same ratio. The Page Position drop-down list is useful when you’re using paper that’s larger than the document you’ve created. This option helps you center the document on larger paper.

				[image: check.png] Marks and Bleed: Turn on or off many of the printing marks in the document, such as crop, bleed, and registration marks. For example, you may want to show these marks if a bleed extends past the boundaries of the page and you need to show where to crop each page. You see a preview of what the page looks like when printed, and you can select options to print page information (such as filename and date) on each page.

				[image: check.png] Output: Choose how to print pages — for example, as a separation or a composite, using which inks (if you’re using separations), or with or without trapping. InDesign can separate and print documents as plates (which are used in commercial printing) from settings you specify.

				[image: check.png] Graphics: Control how graphics and fonts in the document are printed. The Send Data drop-down list controls bitmap images and specifies how much of the data from these images is sent to the printer. Here are some other options available when printing:

					•	All: Sends all bitmap data. Use this for the highest quality printing, but it may take a long time for your jobs to print if you’re using high-resolution images.

					•	Optimized Subsampling: Sends as much image data as the printer can handle. Use this if you are having difficulty with printing high quality images when using the All option.

					•	Proxy: Prints lower-quality images mostly to preview them.

					•	None: Prints placeholder boxes with an X through them. This option lets you quickly print a proof of a layout to just get a quick understanding of a page design.

				[image: check.png] Color Management: Choose how you want color handled when it’s output. If you have profiles loaded in your system for your output devices, you can select the profiles here. Color management is more commonly used by commercial print vendors and vendors with critical color needs. It’s a complex topic — entire books are available on the subject of color management — and we don’t have space to cover it in depth here.

				[image: check.png] Advanced: Determine how you want images to be sent to the printer. If you are unfamiliar with Open Prepress Interface (OPI), you can leave this setting at the default. Also known as image-swapping technology, the OPI process allows low-resolution images inserted into InDesign to be swapped with the high-resolution version for output. It’s a highly specialized setting used by commercial print vendors — such as catalog print vendors — that work with a large number of images.

						Flattening needs to be addressed if you use a drop shadow, feather an object in InDesign, or apply transparency to any objects, even if they were created in Photoshop or Illustrator.

						Use the preset Medium Resolution for desktop printers and High Resolution for professional press output.

				[image: check.png] Summary: You can’t make modifications but you can see a good overview of all your print settings.

				[image: tip.eps]	After you finish your settings, click the Save Preset button if you want to save the changes you’ve made. If you think you may print other documents with these settings repeatedly, using the Save Preset feature can be a great timesaver.

				After you click the Save Preset button, the Save Preset dialog box opens, where you can enter a new name to save the settings. The next time you print a document, you can select the saved preset from the Print Preset drop-down list in the Print dialog box.

				Click the Print button at the bottom of the Print dialog box when you’re ready to print the document.

				

			

		

	
		
			
				Chapter 8: Creating Digital Documents using HTML  and EPUB

				In This Chapter

				[image: check.png] Digital document essentials

				[image: check.png] Alternate layouts for varying devices

				[image: check.png] Inserting HTML objects

				[image: check.png] Exporting to HTML

				[image: check.png] Exporting to EPUB

				InDesign was built more than a decade ago as a tool for creating printed documents — not for creating digital documents and electronic books. With InDesign CS6, however, Adobe added the ability to create digital documents for distribution on tablets, e-readers, and on the web. The overwhelming majority of the new features added to CS6 are focused on creating digital documents.

				Because publishing on tablets is relatively new, the workflows, tools, and features are still in their infancy. In some cases we find the process a bit clumsy — and the tools added to InDesign feel like an afterthought — but unless you want to learn to code HTML5 and CSS3, the Creative Suite 6 tools are your best bet for getting your content delivered onto a tablet or e-reading device.

				Digital documents can be optimized to appear on a variety of devices, and in different formats. In this chapter, we discuss two such formats:

				[image: check.png] HTML: HTML is emerging as the standard way to distribute electronic versions of documents that are distributed on the web, as web pages, replacing PDF and SWF (Flash) for two primary reasons:

					•	Unlike PDF and Flash, HTML can be displayed on any device with a web browser.

					•	The emerging standards of HTML5 and CSS3 allow for content to be customized depending upon the device or browser being used to view the document. For example, a different layout can exist for vertical and horizontal display.

				[image: check.png] EPUB: Although HTML is becoming the favorite way to distribute documents in a web browser, the standard for electronic books that can be viewed on-line and off-line is EPUB, and in this chapter we also look at creating documents for distribution using the EPUB format.

				Adapting Content for Digital Distribution

				Creating a digital document requires more than just selecting an output  type and pressing the Export button. To make effective documents, you must design them according to the needs of the device upon which they will be viewed.

				To do this, you can either design the document’s layout for specific devices, such as an iPad vertical or iPad horizontal layout, using alternate layouts. Alternatively, using Liquid Layout you can create a set of rules that adapt the layout to work on various devices.

				Creating Digital Documents

				These days, you should intentionally design your documents for digital distribution. If you must adapt a print document for electronic distribution, you should save a copy of the original InDesign document and work on the copy as a dedicated electronic document. Creating an EPUB allows you to distribute books to e-reading devices such as the nook, Kindle, and iPad.

				To convert an existing print document to a digital document layout, follow these steps:

					1.	Open the existing document and choose File⇒Save As and name the copy of the document.

						Choose a name that relates to your intended distribution. Consider including terms such as EPUB or iPad in the filename so you can distinguish the electronic version from the print version.

				[image: tip.eps]		If you’re creating an EPUB document for a book that uses primarily text and will be viewed on many readers, you can stop after step 1, because you do not need to specify layout details or device details for specific devices. For EPUB documents that require highly formatted layouts, continue with the following steps.

					2.	Choose File ⇒Document Setup. In the Document Setup window, choose Digital Publishing from the Intent drop-down menu, and select the desired Page Size and orientation (vertical or horizontal).

					3.	Click OK to close the Document Setup window and then choose File⇒Save to save these changes.

					4.	Scroll through the document and make adjustments to the layout based upon the available page size. Use the Selection tool to move objects and use the Pages panel to add pages as needed.

				[image: tip.eps]		If you want to create the print document and electronic document at the same time, and to link the content so that changes in one are reflected in the other, choose File⇒Copy and Place. This command creates a duplicate copy of your content in a file that is linked to your original file.

					5.	Choose Window⇒Articles to open the Articles panel. Use the Selection tool to drag items from your layout into the Articles panel, defining the order in which they will be displayed in an EPUB. If you have something that you don’t want to include in the digital version of the book, simply don’t drag it into the Articles Panel. Save your document after dragging all elements to be exported to the Articles panel.

				Creating Alternate Layouts

				You can create separate horizontal and vertical layouts for your document in the Pages panel. When you export your document to HTML, the document will include information in the Cascading Style Sheets (CSS) that adapts the layout based upon the way it is being viewed.

				To create an alternate layout, follow these steps:

					1.	In the Pages panel, click to select an existing page that you want to adapt for a different layout.

						For example, if you have a horizontal layout, and you want to also create a vertical version of the layout, click the horizontal layout.

					2.	In the Pages panel menu, choose Create Alternate Layout. Name the alternate layout, specify the page attributes, and then click OK.

						A new page is created with the alternate layout and the content from the original page is duplicated and linked onto the duplicate page.

					3.	Modify the layout of page elements on the alternate layout as needed.

				[image: tip.eps]		Notice that any text frames and image frames that were duplicated onto the alternate layout also contain a link symbol in the upper-left corner. This indicates that the text and images on the alternate layout are linked to the original. Changes made to the items in the original layout are reflected on the alternate layout. If an item in the alternative layout is different from the original layout, a yellow triangle appears instead of the link symbol. Double-click the yellow triangle and the item in the alternative layout is then synchronized with the original layout.

				Creating Liquid Layouts

				Adobe is experimenting with the idea of using InDesign as a tool for creating layouts that can be adapted to the web. They’ve done this by creating a new feature called Liquid Layout, which is borrowed from the idea of Responsive Design in the web design community. The Liquid Layout feature helps create HTML pages and CSS that adapt to various web browsers and mobile devices.

				To use Liquid Layout, follow these steps:

					1.	Choose the Page Tool and click to select any page that contains some content.

						This tells InDesign how each page should be adapted when it is exported to HTML.

					2.	In the Control Strip, choose Liquid Page Rule. Select the Scale option to retain all content on your page, even at a smaller page size.

					3.	Test the Liquid Layout by continuing to use the Page tool to click and drag the page handles and seeing how the objects on the page are modified. If you selected the Scale option, the page objects should all reduce in size as you reduce the size of the page using the Page tool, simulating how the page should look on a mobile web browser.

				Other digital document features

				Use these features to add interactivity to your digital documents:

				[image: check.png] Animation panel: Use the Animation panel to apply animation to objects on your page. For example, you can have an object fade in as the page appears, or fade out and disappear. Access this panel by choosing Window⇒Interactive⇒Animation, and apply animation to individual objects by selecting them and choosing an animation option from the Preset drop-down menu in the Animation panel.

				[image: check.png] Timing Panel: Use the Timing panel to modify animations you have created using the Animation panel. Access this panel by choosing Window⇒Interactive⇒Timing. Use the Event drop-down list to specify when an object’s animation occurs, and use the Delay option to specify if the animation should wait before it occurs.

				[image: check.png] Buttons and Forms: Use this panel to convert text or images to buttons that become interactive when the InDesign document is exported to PDF. Access this panel by choosing Window⇒Interactive⇒Buttons and Forms. Buttons can have actions associated with them, so that something occurs when they are clicked. For example, when clicked, a button can play a movie or sound, navigate to a specific page, or print a form. You can also use this panel to convert text frames to text fields, making it possible to create PDF forms using InDesign.

				Exporting HTML

				Exporting an InDesign document to HTML allows you to share the document on the web so that it can be viewed on a variety of devices. The HTML file created by InDesign can also easily be edited. Just open the file using Dreamweaver. (See Book VI for more on how to use Dreamweaver to open and edit HTML pages.)

				To export an InDesign document to HTML, follow these steps:

					1.	With an InDesign document open, choose File⇒Export.

						The Export dialog box appears.

					2.	From the Save as Type (Windows) or Format (Mac) drop-down list, select HTML. Then find a location on your hard drive or network for the document to be saved. Enter a name for the html file in the File Name portion of the Export dialog box.

					3.	Click the Save button.

						The HTML Export Options dialog box appears with the General options available for editing. In this dialog box, you can determine whether you’re exporting only the selection (if you had something selected) or the entire document. You can also map how to handle bullets.

					4.	Select Image in the left column to see options for saving optimized images.

						Leave the Image Conversion drop-down list set to Automatic to let InDesign decide whether an image is best saved as a GIF or JPEG file or you can specify the format you prefer for all images. This conversion is needed because the file formats used within InDesign may not work within many web browsers.

					5.	Select Advanced in the left column to determine how Cascading Style Sheets (CSS) are handled — whether you want to use them, or whether you want them to reference (link to) an external CSS style.

						For more information on CSS, see Book VI.

					6.	Return to the General tab along the left side and select View HTML after Exporting if you want the file to open in your default web browser. Then click the Export button.

						The file is exported. If you selected View HTML after Exporting, the file opens in your browser. Otherwise, you can now open and edit the HTML file directly in Dreamweaver.

				Exporting EPUB

				Books displayed using iBooks, Nook devices, Kobo readers, or Sony eReaders all use the EPUB file format. Books displayed on the Kindle begin as EPUB files but undergo an additional conversion process into Amazon’s proprietary Kindle format. The bottom line — if you want to create electronic books, you need to know about creating EPUB files. Here’s how to create an EPUB using InDesign:

					1.	With an InDesign document open, choose File⇒Export.

						The Export dialog box appears.

					2.	From the Save as Type (Windows) or Format (Mac) drop-down list , select EPUB and then find a location on your hard drive or network for the document to be saved. Enter a name for the EPUB file in the File Name portion of the Export dialog box.

					3.	Click the Save button.

						The EPUB Export Options dialog box appears with the General options available for editing. Here is an overview of essential settings in the General tab when creating an EPUB:

					•	Version: If you are exporting an EPUB that contains multimedia, choose EPUB 3.0. Otherwise, you can use the EPUB 2.0.1. Although Adobe offers a proprietary EPUB 3.0 with layout option, this isn’t compatible with most popular reading devices and should be avoided unless you have a specific need to export using this format.

					•	Cover: If you want InDesign to generate the cover image displayed for the EPUB, choose whether it should use the first page of the document or choose a specific image file to use instead if the cover artwork is stored separately on your hard drive or network.

					•	TOC Style: Choose Default if you want InDesign to automatically generate a table of contents that will be used by readers to more easily navigate the EPUB file.

					•	Margins: Specify any padding you want between the text and the outside edge of the reading device

					•	View EPUB after exporting: Causes the EPUB to open and be displayed in the default EPUB reader after InDesign generates the EPUB file.

					4.	Click the Image tab in the EPUB Export Options dialog box.

						In the Image tab, specify the resolution that images should be set at when created for the EPUB. Also specify the location of images on the page, and any space that should be placed before or after images.

					5.	Click the Advanced tab

						Make these adjustments as needed in the Advanced tab before creating the EPUB:

					•	Split Document: If you want to split a long document into individual chapters, choose the Paragraph Style to determine where each section should be divided. Otherwise, keep this at the default option of Do Not Split.

					•	EPUB Metadata: Document metadata is used by EPUB readers to describe the book title, publisher, ISBN, and other information. You can enter the Publisher here and the ISBN number for your book in the Unique ID field.

					•	CSS Options: If you have created Cascading Style Sheets (CSS) to control the formatting for your EPUB files, you can add a style sheet. Otherwise, you can have InDesign add style definitions and create a CSS file by selecting the Include Style Definitions check box. Under this same option, deselect Include Embeddable Fonts because many electronic reading devices ignore them, and some electronic book stores will reject files that contain embedded fonts.

				[image: tip.eps]		Additional document metadata can be entered in the Document Information field. Access this by choosing File⇒Document Information.

					6.	Click the OK button

						The EPUB is generated. If you selected the View EPUB after Exporting check box, the EPUB file opens using your default EPUB reader.

				[image: technicalstuff.eps]		If the EPUB Export Options dialog box looks similar to the HTML Export window, it is because EPUBs actually use HTML as their foundation. Electronic book readers are essentially specialized browsers designed to display books formatted using HTML and CSS. All the HTML and CSS content for an EPUB file is contained within compressed folder named with the EPUB file extension.
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				Chapter 1: What’s New in Illustrator CS6

				In This Chapter

				[image: check.png] Understanding the advantages of the new 64-bit processing

				[image: check.png] Exploring the new user interface

				[image: check.png] Tracing images like a pro

				[image: check.png] Using the new Pattern Options panel

				[image: check.png] Applying gradients to strokes

				Adobe Illustrator has changed its look for the better and has added some important new features. This chapter shows you all the latest and greatest features in Illustrator CS6, from its new tracing features and pattern options, to applying gradients on strokes, and much more.

				Taking Advantage of the Processing Upgrade

				Adobe Illustrator CS6 is now available with a 64-bit implementation on Windows. This means that general processing is faster, and more RAM (Random Access Memory) can be made available to Illustrator, which reduces the occurrences of out-of-memory errors and allows you to  work faster.

				Keep in mind that all modern Macintoshes are 64-bit, so Mac users can take advantage of this increased processing speed immediately. Windows users will have either a 32-bit or a 64-bit installation and should take care to install the proper version.

				[image: remember.eps]	Random Access Memory (RAM) is temporary memory that provides space for your computer to read and write data. It’s usually referred to as the computer’s memory. The more RAM you have in your computer, the better — more RAM reduces the number of times your computer must read data from your hard drive. Because RAM is many times faster than the memory on a hard drive, more RAM allows your computer to work considerably faster.

				Working with the New User Interface 

				As with many of the other applications in the Creative Suite, Adobe developers improved the look of Illustrator by modernizing the style to create a new look and feel. First of all, note the new darker application interface, as shown in Figure 1-1. Note also that the text is much easier to read. 

					

				
					Figure 1-1:  The new user interface in Adobe Illustrator CS6.

				

					[image: 9781118168608-fg030101.tif]

				In addition, the new user interface now gives you the ability to change  layer, swatch, and symbol names right in the panels, which takes redundant steps out of your workflow. Adobe developers have added several more improvements — we point them out to you as they arise in the rest of this minibook.

				If the interface seems too dark for you, you can adjust the brightness by  following these steps:

					1.	Choose Edit⇒Preferences⇒User Interface.

					2.	Select a brightness preset from the Brightness drop-down list or use the Brightness slider to adjust the brightness. (See Figure 1-2.)

				[image: tip.eps]		If you’re a seasoned Illustrator user who prefers to leave objects off the artboard (main page), you may want to select the White radio button in the Canvas Color area. Selecting this option gives you better visibility of the objects that are off the live artboard.

					3.	Click OK.

					

				
					Figure 1-2: With the Brightness slider, you can control the lightness or darkness of your Illustrator user interface.

				

					[image: 9781118168608-fg030102.eps]

				Tracing Bitmap Artwork Like Never Before

				Because vector art is scalable, more precise, and generally smaller in file size, it has always been the preferred format for most graphic professionals. To help these professionals, Adobe added the tracing option several versions ago, which converted most bitmap (raster) artwork to vector art. The original implementation was successful, but it had some limitations: Text didn’t always convert to vector correctly, or an inordinate amount of anchor points were created during conversion. Now you can use the new and improved Image Trace feature in Illustrator CS6 to accurately convert your bitmap artwork into vector without these limitations.

				After placing an image onto the Illustrator artboard, you have a choice of selecting default trace settings right in the Control panel, or you can access a vast array of options by choosing Window⇒Image Trace, as shown with the Advanced options expanded in Figure 1-3.

				By using the Image Trace options, you can change the amount of detail, fidelity, control the color palette, and more. One of the biggest improvements is the ability to change the type of tracing from Abutting to Overlapping, allowing you to create close objects that can easily be repositioned later, as shown in Figure 1-4.

				We tell you how to use the new Image Trace options in Chapter 5.

					

				
					Figure 1-3: Convert bitmap objects to vector by using new and improved tracing options.

				

					[image: 9781118168608-fg030103.eps]

					

				
					Figure 1-4: Change your method of tracing to Abutting or Overlapping by using the Image Trace options. 

				

					[image: 9781118168608-fg030104.eps]

				Using Pattern Options

				In previous versions of Adobe Illustrator, simple patterns were relatively easy to create. You could create objects that were to be part of a pattern, select and drag them into the Swatches panel, and then apply the pattern as an object’s fill or stroke. The difficulty would arise when you had a need to create a repeating pattern for fabric, wallpaper, or other objects requiring precise repeats. Pattern Options to the rescue! Using the new Pattern Options panel (see Figure 1-5), you can now test your pattern repeats in a separate pattern mode, as well as edit the contents. This method of testing offers you the opportunity to experiment quickly with your patterns until you see the results you’re looking for. See Figure 1-5, where the Tile Type has been changed to Brick by Row; the new pattern result is shown in Figure 1-6.

					

				
					Figure 1-5: Create custom repeats and feel in control of the repeats using the new Pattern Options feature.

				

					[image: 9781118168608-fg030105.eps]

					

				
					Figure 1-6: Experiment with offsets and even edit pattern contents in the Pattern Options mode.

				

					[image: 9781118168608-fg030106.tif]

				The Pattern Options feature gives you the ability to change the tile bounds, change the type of repeating pattern from the standard stacking repeat to a brick or hexagonal repeat. This new feature is worth investing some time in because its capabilities will astound you. (We explain how to use the new pattern features in Chapter 9.)

				Applying Gradients to Strokes

				Experienced Illustrator users have wanted the ability to apply gradients to strokes for years, and now the feature is included in Illustrator CS6. All you have to do is select Stroke from the Control panel and choose a gradient from your Swatches panel. (See Figure 1-7.)

					

				
					Figure 1-7: You can now apply gradients to strokes.

				

					[image: 9781118168608-fg030107.eps]

				Follow these steps to apply a gradient to a stroke:

					1.	Select the object that you want to apply a stroke to, or select the Rectangle tool and click and drag a rectangle shape on the artboard.

					2.	Locate Stroke Weight in the Control panel and select a size that’s  visible.

						In this example, we selected 7 pts.

					3.	Using the Control panel, click on Stroke and select the Green, Yellow, Orange gradient as shown in Figure 1-8.

						The gradient is applied to the stroke.

					

				
					Figure 1-8: Applying the gradient to the stroke using the Stroke control.

				

					[image: 9781118168608-fg030108.tif]

					4.	Select Window⇒Gradient to change settings on your gradient. You can experiment in this window by changing the gradient to Radial or changing the angle and offset.

				[image: tip.eps]		You can also use the Gradient window to change how the gradient is applied to the stroke as shown in Figures 1-9, 1-10, 1-11, and 1-12.

				[image: remember.eps]		Keep in mind that at this time you can change the angle and distance of your gradient stroke only in the Gradient panel. The Gradient tool works fine for gradient fills, but not for strokes. (We explain more about using gradients in Adobe Illustrator in Chapter 9.)

					

				
					Figure 1-9: Use the Gradient panel to customize how the gradient is applied to the stroke.
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					Figure 1-10: Applying gradient within stroke.
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					Figure 1-11: Applying gradient along stroke.
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					Figure 1-12: Applying gradient across stroke.
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				Discovering More New Features 

				Our objective is to show you not only what the new features in Illustrator CS6 are, but also how you can take advantage of them in your workflow. Many of the new features in Illustrator CS6 are discussed throughout the other chapters in this minibook, where we can show you how to use them. 

				

			

		

	
		
			
				Chapter 2: Discovering  Illustrator CS6

				In This Chapter

				[image: check.png] Knowing when to use Illustrator

				[image: check.png] Looking around the Document window

				[image: check.png] Opening and creating documents

				[image: check.png] Checking out the tools and panels

				[image: check.png] Changing your view

				[image: check.png] Zooming in and out

				Adobe Illustrator goes hand in hand with other Adobe products but serves its own, unique purpose. Although Illustrator can create multiple-page artwork (with artboards), it isn’t meant to create lengthy documents with repeated headers, footers, and page numbers. Those types of files are more appropriate for applications such as InDesign. Typically, you wouldn’t create artwork from Illustrator that’s made from pixels, such as images edited or created in Photoshop. Illustrator is generally used to create vector logos, illustrations, maps, packages, labels, signage, web art, and more. (See the nearby “Vector graphics” sidebar for more information.)

				This chapter gets you started with Illustrator and helps you understand when Illustrator is the tool best suited for creating your art.

				Deciding When to Use Illustrator CS6

				How do you draw a line in the sand and decide to create graphics in Illustrator rather than in Photoshop? By using Illustrator, you gain these benefits:

				[image: check.png] Illustrator can save and export graphics into most file formats. By choosing to save or export, you can create a file that can be used in most other applications. For instance, Illustrator files can be saved as .bmp, .jpg, .pdf, .svg, .tiff, and even .swf (Flash) files, to name  a few.

				Vector graphics

				Vector graphics are made up of lines and curves defined by mathematical objects called vectors. Because the paths (the lines and curves) are defined mathematically, you can move, resize, or change the color of vector objects without losing quality in the graphic.

				Vector graphics are resolution-independent: They can be scaled to any size and printed at any resolution without losing detail. On the other hand, a predetermined number of pixels create bitmap graphics, so you can’t scale (resize) them easily — if you scale them smaller, you throw out pixels; if you scale  them larger, you end up with a blocky, jagged picture.

				The following figure shows the differences between an enlarged vector graphic (top; notice the smooth edges) and an enlarged bitmap graphic (bottom; note the jagged edges). Many designers create company logos as vectors to avoid problems with scaling: A vector graphic logo maintains its high-quality appearance at any size.


				
					[image: 9781118168608-sb030201.tif]

			
	
				
				
				[image: check.png] Illustrator files are easily integrated into other Adobe applications. You can save Illustrator files in their native format and open or place them in other Adobe applications such as Dreamweaver, Fireworks, Flash, InDesign, and Photoshop. You can also save Illustrator artwork as .pdf (Portable Document Format) files. It lets anyone using the free Acrobat Reader software open and view the file but maintain editing capabilities when the file is opened later in Illustrator.

				[image: check.png] Illustrator artwork is reusable because the resolution of vector artwork isn’t determined until output. In other words, if you print to a 600 dpi (dots per inch) printer, the artwork is printed at 600 dpi; print to a 2,400 dpi printer and the artwork prints at 2,400 dpi. Illustrator graphics are quite different from the bitmap images you create or edit in Photoshop, where resolution is determined as soon as you scan, take a picture, or create a new bitmap (created from pixels) document.

				[image: check.png] Illustrator has limitless scalability. You can create vector artwork in Illustrator and scale it to the size of your thumb or to the size of a barn, and either way, it still looks good. See the nearby sidebar “Vector graphics” for more information.

				Creating a New Document

				To create a new document in Illustrator, follow these steps:

					1.	Choose File⇒New.

						The New Document dialog box appears, as shown in Figure 2-1. You use it to determine the new document’s profile, size, measurement unit, color mode, and page orientation as well as the number of artboards (pages) you want in the document.

					

				
					Figure 2-1: Creating a new document in Illustrator.

				

					[image: 9781118168608-fg030201.eps]

					2.	Enter a name for your new file in the Name text field.

						You can determine the name of the file now or later when you save the document.

					3.	Choose a profile from the New Document Profile drop-down list.

						Selecting the correct profile sets up preferences, such as resolution and colors, correctly. Click the Advanced down arrow (in the lower-left corner of the New Document dialog box) to see which settings are selected for each profile and to change them if necessary.

					4.	In the Number of Artboards text box, enter the number of artboards you want in the document.

						If you want a single page document, leave this setting at 1. Creating a document with multiple artboards is discussed later in this chapter, in the section “Creating multiple artboards.”

					5.	Enter in the Spacing text box the amount of space to leave between artboards.

						If you want pages to abut, enter 0 (zero) or enter additional values if you want a little space between each artboard. If you’re adding artboards, you can enter in the Columns text box the number of columns of artboards you want arranged in the document.

					6.	Select from the Size drop-down list or type measurements in the Width and Height text fields to set the size of the document page.

						You can select from several standard sizes in the Size drop-down list  or enter your own measurements in the Width and Height text fields. Note that several web sizes are listed first, followed by other typical paper sizes.

					7.	Select from the Units drop-down list to select the type of measurement you’re most comfortable with.

						Your selection sets all measurement boxes and rulers to the increments you choose: points, picas, inches, millimeters, centimeters, or pixels.

					8.	Pick the orientation for the artboard.

						The artboard is your canvas for creating artwork in Illustrator. You can choose between Portrait (the short sides of the artboard on the top and bottom) and Landscape (the long sides of the artboard on the top and bottom).

					9.	Add values in the Bleed text boxes, if necessary.

						A bleed value is the amount of image area that extends beyond the artboard. To print from edge to edge, enter a value for the bleed. Keep in mind that most desktop printers need a grip area, which is the part of the page that a printer needs to grab on to the paper. It typically forces any image area near the edge of a page to not print. Bleeds are typically used in jobs to be printed from a press.

					10.	When you’re finished making selections, click OK.

						One or more Illustrator artboards appear.

				Need a Design Boost? Try a Template

				[image: tip.eps]	In the New Document dialog box, click the Templates button to get a jump-start with professional designs already created as Illustrator templates. Start with a simple template for a CD cover, as shown in Figure 2-2, or start your brochure, business cards, or flyers with a template that includes imagery, text, and professional layouts.

					

				
					Figure 2-2: Precreated templates lead to successful designs.
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				Opening an Existing Document

				It’s a good idea to familiarize yourself with the workspace before starting to work in Adobe Illustrator, but to do this you will want to have a document open. In this section, you jump right in by opening an existing document. Here’s how:

					1.	Launch Adobe Illustrator CS6.

						Keep in mind that when you launch Illustrator CS6 for the first time, a Welcome screen appears, giving you various options. 

				[image: tip.eps]		You can select the Don’t Show Again check box if you don’t want to see the Welcome screen at launch.

					2.	Choose File⇒Open and select a file in the Open dialog box. (If you’re at the Welcome screen, instead click the Open icon and then browse to locate a file to open.)

						For this exercise, open one of the sample files packaged with the Illustrator application, such as Loyal Order of Wormword in the Sample Art folder. The path to the file is C:\Programs\Adobe\Adobe Illustrator CS6\Cool Extras\Sample Files\Sample Art (Windows) or Applications\Adobe Illustrator CS6\Cool Extras\Sample Files\Sample Art (Mac). If you followed the instructions in the section on acquiring assets for this book in Book I and copied over to your computer the CS6Dummies folder from the Dummies Asset site, you can access the Adobe_Illustrator_Assets and open the file named AI_Sample. Keep this file open so that you can follow along with the explanation of the workspace in the next section.

				Taking a Look at the Document Window

				To investigate the work area (shown in Figure 2-3) and become truly familiar with Illustrator, have a document open, like the AI_Sample file you were directed to in the last section, or create a new document and take a look around. In the Illustrator work area, a total of 227 inches in width and height help create your artwork (and all artboards). That’s helpful, but it also leaves enough space to lose objects! The following list explains the tools you work with as you create artwork in Illustrator:

				[image: check.png] Imageable area: If you’re planning to print your Illustrator document choose View⇒Show Print Tiling. A dotted line appears which marks the printing area on the page. Many printers can’t print all the way to the edges of the paper, so the imageable area is determined by the printer you set in the Print dialog box. If you don’t want to see the print tiling, choose View⇒Hide Print Tiling.

						You can move the imageable area around on your page by using the Print Tiling tool. See the nearby sidebar, “The Print Tiling tool,” for more on this tool.

					

				
					Figure 2-3:  The Illustrator work area.

					
				

					[image: 9781118168608-fg030203.tif]

				[image: check.png] Artboard: This area, bounded by solid lines, represents the entire region that can contain printable artwork. By default, the artboard is the same size as the page, but it can be enlarged or reduced. The U.S. default artboard size is 8.5 x 11 inches, but it can be set as large as  227 x 227 inches. If you’re using the default settings for Illustrator, the edge of the artboard is indicated by a transition from a white to a medium grey canvas.

				[image: check.png] Scratch area: This area outside the artboards extends to the edge of  the 227-inch square window. The scratch area represents a space on which you can create, edit, and store elements of artwork before moving them onto the artboard. Objects placed onto the scratch area are  visible onscreen, but they don’t print. However, objects in the scratch area appear if the document is saved and placed as an image in other applications.

				[image: tip.eps]		If you’re having a difficult time seeing your items in the scratch area, choose Edit⇒Preferences⇒User Interface and select White for the Canvas color.

				Taking Advantage of Artboards

				As you already discovered, the page itself is referred to as the artboard. The options available to you when using artboards include the following:

				[image: check.png] You can have multiple artboards in one document, creating essentially a multipage document.

				[image: check.png] You can name and rearrange artboards by using the Artboard panel.

				[image: check.png] You can copy entire artboards, allowing you to quickly create multiple versions for your artwork.

				[image: check.png] You can use artboards to define a print area, eliminating the need to use the Print Tiling tool.

				Creating multiple artboards

				To create a document with multiple artboards, follow these steps:

					1.	Launch Adobe Illustrator CS6 and choose File⇒New.

						The New Document dialog box appears, as shown in Figure 2-4.

					

				
					Figure 2-4: Add multiple artboards right from the start.

				

					[image: 9781118168608-fg030204.eps]

					2.	Specify the number of artboards to start with by entering a number in the Number of Artboards text box.

						In our example, we added four artboards.

					3.	To specify how to arrange the artboard, click a grid or row arrangement icon to the right of the Number of Artboards text box, as shown in Figure 2-5.

					

				
					Figure 2-5: Choose how you want the artboards arranged.
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				The Print Tiling tool

				Use the Print Tiling tool to move the printable area of your page to a different location.  For example, if your printer can print only on paper that’s 8.5 x 11 inches or smaller but  the page size is 11 x 17, you can use the Print Tiling tool (a hidden tool accessed by holding down the mouse button on the Hand tool) to indicate which part of the page you want to print. Follow these steps to use the Print Tiling tool:

					1.	When adjusting page boundaries, choose View⇒Fit in Window so that you can see all your artwork.

					2.	Hold down the mouse button on the Hand tool to select the hidden Print Tiling tool.

						The pointer becomes a dotted cross when you move it to the active window.

					3.	Position the mouse pointer over the artboard and click and drag the page to a new location.

						While you drag, the Print Tiling tool acts as though you’re moving the page from its lower left corner. Two gray rectangles are displayed. The outer rectangle represents the page size, and the inner rectangle represents the printable area of a page. You can move the page anywhere on the artboard; just remember that any part of a page that extends past the printable area boundary will not print.



						Using these grid boxes, you can

					•	Specify how many rows and columns to use.

					•	Change the direction of the layout from left to right or right to left.

					4.	Enter an amount in the Spacing text box to determine the distance between artboards.

						Enter 0 (zero) if you want the artboards to butt against each other, or a higher value if you want some space between them.

					5.	Click OK to create your new document. (See Figure 2-6.)

					

				
					Figure 2-6: A document created using four artboards.

				

					[image: 9781118168608-fg030206.tif]

				Exploring enhanced artboard features

				After you create multiple artboards, choose Window⇒Artboards to see a panel with artboards listed individually, as shown in Figure 2-7.

				Here are some swell things you can do to artboards from the Artboard panel:

				[image: check.png] Navigate to a specific artboard. Just double-click the artboard’s number.

				[image: check.png] Rearrange artboards. Drag the artboards inside the Artboard panel to reorganize their stacking order.

				[image: check.png] Delete an artboard. Drag it to the trashcan icon.

				[image: check.png] Copy an existing artboard. Drag it to the New Artboard icon.

				[image: check.png] Create a new artboard. Click the New Artboard icon.

				[image: check.png] Edit additional artboard options, such as size and orientation by selecting Artboard Options from the panel menu. The Artboard options appear as you see in Figure 2-8. Keep in mind that each artboard can be a different size than others in the same document.

				[image: check.png] Rename an artboard. Double-click the Artboard name right in the Artboards panel, type a new name, and then press the Tab key.

					

				
					Figure 2-7: The new Artboard panel, keeping your project organized.

				

					[image: 9781118168608-fg030207.eps]

					

				
					Figure 2-8: Edit existing artboards by using the Artboard Options dialog box.
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				Printing a document with multiple artboards

				Pay close attention before you print a document with multiple artboards, or else you may print needless pages. To control which artboards are printed, follow these steps:

					1.	Choose File⇒Print.

						The Print dialog box appears, as shown in Figure 2-9.

					2.	Click the arrows underneath the Preview box in the lower-left corner to preview the artboards.

					3.	After you decide which artboards to print, enter them into the Range text box.

						To print all artboards, select the All radio button; otherwise, enter a consecutive range such as 1–3 in the Range text box. You can also print nonconsecutive pages by separating them with commas — enter 1, 3, 4 to print only artboards 1, 3, and 4.

					4.	Click Print to print the selected artboards.

				[image: tip.eps]	If you want to define an artboard within an artboard, select the Artboard tool and then hold down the Shift key when dragging out a new artboard.

					

				
					Figure 2-9: Printing a document with multiple artboards.
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				Becoming Familiar with the Tools

				As you begin using Illustrator, you’ll find it helpful to be familiar with its tools. Tools are used to create, select, and manipulate objects in Illustrator. The tools should be visible as a default, but if not, you can access them by choosing Window⇒Tools.

				Table 2-1 lists the tools that we show you how to use throughout this minibook. Hover the cursor over the tool in the Tools panel to see the name of  the tool in a tooltip. In parentheses on the tooltip (and noted in Column 2 of Table 2-1) is the keyboard command you can use to access that tool. When you see a small triangle at the lower right corner of the tool icon, it contains additional, hidden tools. Select the tool and hold the mouse button to see them.

		[image: /Table tb030201a]

		[image: /Table tb030201b]

				
				
				Checking Out the Panels

				The standardized interface in Adobe Creative Suite is a useful boost for users because the Illustrator panel system is similar to all other products in the suite. This consistency makes working and finding tools and features easier.

				When you first open Illustrator, notice that some panels may have been reduced to icons on the right. To select a panel, click the appropriate icon, and the panel appears.

				If all you see is an icon, how do you know which icon brings up which panel? Good question. If you’re hunting around for the appropriate panels, you can

				[image: check.png] Choose Window⇒Name of Panel.

				[image: check.png] Position your mouse on the left side of the icons and, when you see the double-arrow icon, click and drag to the left. The panel names appear.

				[image: check.png] Click the Expand Panels button on the gray bar at the top of the icons, as shown in Figure 2-10. The panels expand so that you can see their contents and names.

					

				
					Figure 2-10: Expand the panels to see more options.

				

					[image: 9781118168608-fg030210.tif]

				The panels you see as a default are docked together. To dock a panel means that, for organizational purposes, the panel is attached in the docking area.

				You can arrange panels to make them more helpful for production. You may choose to have only certain panels visible while working. Here’s the lowdown on using Illustrator panels:

				[image: check.png] To see additional options for each panel (because some options are hidden), click the panel menu in the upper-right corner of the panel. (See Figure 2-11.)

				[image: check.png] To move a panel group, click and drag above the tabbed panel name.

				[image: check.png] To rearrange or separate a panel from its group, drag the panel’s tab. Dragging a tab outside the docking area creates a new, separate panel.

				[image: check.png] To move a tab to another panel, drag the tab to that panel.

					

				
					Figure 2-11:  Many panels have additional menu options.

				

					[image: 9781118168608-fg030211.tif]

				Look out for those panels — they can take over your screen! Some panels, but not all, can be resized. A panel that you can resize has an active lower-right corner (denoted by three small lines). To change the size of a panel, drag its lower-right corner (Windows) or drag the size box in the lower-right corner of the panel (Mac).

				[image: tip.eps]	As you become more efficient, you may find it helpful to reduce the clutter on your screen by hiding all panels except the ones necessary for your  work. You can save your own panel configuration by choosing Window⇒Workspace⇒Save Workspace. Choose Window⇒Workspace⇒Essentials to return to the default workspace.

				Changing Views

				When you’re working in Illustrator, precision is important, but you also want to see how the artwork looks. Whether for the web or print, Illustrator offers several ways in which to view your artwork:

				[image: check.png] Preview and Outline views: By default, Illustrator shows Preview view, where you see colors, stroke widths, images, and patterns as they should appear when printed or completed for onscreen presentation. Sometimes this view can become a nuisance, especially if you’re trying to create a corner point by connecting two thick lines. At times like this, or whenever you want the strokes and fills reduced to the underlying structure, choose View⇒Outline. You now see the outline of the illustration, shown in Figure 2-12.

				[image: check.png] Pixel view: If you don’t want to be surprised when your artwork appears in your web browser, use Pixel view. This view, shown in Figure 2-13, maintains the vectors of your artwork but shows how the pixels will appear when the image is viewed onscreen, as though it’s on the web.

					

				
					Figure 2-12: Preview mode (left) and Outline mode (right).

				

					[image: 9781118168608-fg030212.eps]

					

				
					Figure 2-13:  See how your artwork translates into pixels in Pixel view.

				

					[image: 9781118168608-fg030213.eps]

				[image: tip.eps]		Pixel view is helpful for previewing the look of text onscreen — some fonts just don’t look good as pixels, especially if the text is small. In  Pixel view, you can review fonts until you find one that’s easily readable as pixels.

				[image: check.png] Overprint view: For people in print production, the Overprint preview can be a real timesaver. Choose Window⇒Attributes to bring up the Attributes panel, which you can use to set the fill and stroke colors to overprint. This view creates additional colors when printing and aids printers when trapping abutting colors.

						Trapping is the slight overprint of a lighter color into a darker color to correct for press misregistration — that is, when the printed colors don’t align exactly. When several colors are printed on one piece, the likelihood of perfect alignment is slim! Setting a stroke to Overprint on the Window⇒Attributes panel is one solution. With Overprint selected, the stroke is overprinted on the nearby colors. This mixing of color produces an additional color but is less obvious to the viewer than a white space created by misregistration. Select Overprint to see the result of overprinting in Overprint view, as shown in Figure 2-14.

					

				
					Figure 2-14: Use the Overprint view to see how overlapping colors will appear.

				

					[image: 9781118168608-fg030214.tif]

				Navigating the Work Area with Zoom Controls

				You can navigate the work area efficiently by using the Hand tool and the various zoom controls. You can change the magnification of the artboard in several ways, including using menu items, the Zoom tool, and keyboard commands. Choose the method you feel most comfortable with:

					[image: check.png] [image: 9781118168608-ma038.tif] Hand tool: Scroll around the Document window by using the scrollbars or the Hand tool. The Hand tool lets you scroll by dragging. You can imagine that you’re pushing a piece of paper around on your desk when you use the Hand tool.

						Hold down the spacebar to temporarily access the Hand tool while any tool (except the Type tool) is selected. Holding down the spacebar while the Type tool is selected gives you only spaces!

				[image: check.png] View menu: Using the View menu, you can easily select the magnification you want by using Zoom In, Zoom Out, Fit in Window (especially useful when you’re lost in the scratch area), and Actual Size (provides a 100 percent view of your artwork).

					[image: check.png] [image: 9781118168608-ma039.tif] Zoom tool: Using the Zoom tool, you can click the Document window to zoom in; to zoom out, Alt-click (Windows) or Option-click (Mac). Double-click with the Zoom tool to quickly resize the Document window to 100 percent. Control which elements are visible when using the Zoom tool by clicking and dragging over the area you want zoomed into.

				[image: check.png] Keyboard shortcuts: Even if you normally dislike using keyboard shortcuts, you may change your mind about using them for magnification. They make sense and are easy to use and remember. Table 2-2 lists the most popular keyboard shortcuts to change magnification.

				[image: tip.eps]		The shortcuts in Table 2-2 require a little coordination to use, but they give you more control in your zoom. While holding down the keys, drag from the upper-left corner to the lower-right corner of the area you want to zoom to. A marquee appears while you’re dragging; when you release the mouse button, the selected area zooms to the size of your window. The Zoom Out command doesn’t give you much control; it simply zooms back out, much like the commands in Table 2-3.

				Table 2-2	Magnification Keyboard Shortcuts

				
					
						
								
								Command

							
								
								Windows Shortcut

							
								
								Mac Shortcut

							
						

						
								
								Actual Size

							
								
								Ctrl+1

							
								
								[image: maccmd]+1

							
						

						
								
								Fit in Window

							
								
								Ctrl+0 (zero)

							
								
								[image: maccmd]+0 (zero)

							
						

						
								
								Zoom In

							
								
								Ctrl++ (plus)

							
								
								[image: maccmd]++ (plus)

							
						

						
								
								Zoom Out

							
								
								Ctrl+– (minus)

							
								
								[image: maccmd]+– (minus)

							
						

						
								
								Hand tool

							
								
								Spacebar

							
								
								Spacebar

							
						

					
				

				Table 2-3	Zoom Keyboard Shortcuts

				
					
						
								
								Command

							
								
								Windows Shortcut

							
								
								Mac Shortcut

							
						

						
								
								Zoom In to Selected Area

							
								
								Ctrl+spacebar+drag

							
								
								[image: maccmd]+spacebar+drag

							
						

						
								
								Zoom Out

							
								
								Ctrl+Alt+spacebar

							
								
								[image: maccmd]+Option+spacebar

							
						

					
				

			

			
		

	
		
			
				Chapter 3: Using the  Selection Tools

				In This Chapter

				[image: check.png] Knowing the anchor points, bounding boxes, and selection tools

				[image: check.png] Working with a selection

				[image: check.png] Grouping and ungrouping selections

				[image: check.png] Constraining movement and cloning objects

				If someone has been coaching you in using Adobe Illustrator, you may have heard the old line “You have to select it to affect it,” meaning that if you want to apply a change to an object in Illustrator, you must have that object selected or no change will occur. Although making selections may sound simple, it can become tricky when you’re working on complicated artwork. This chapter shows you the tools that will help save you editing time when working in Adobe Illustrator.

				Getting to Know the Selection Tools

				In the following sections, you take a quick tour of anchor points (integral to the world of selections), the bounding box, and, of course, the selection tools. (Yes, Illustrator has several selection tools.)

				[image: tip.eps]	See our website at www.agitraining.com/dummies to find files that you can practice with in this section.

				Anchor points

				To understand selections, you must first understand how Illustrator works with anchor points, which act like handles and can be individually selected and moved to other locations. You essentially use the anchor points to drag objects or parts of objects around the workspace. After you place anchor points on an object, you can create strokes or paths from the anchor points.

				You can select several anchor points at the same time, as shown in Figure 3-1, or only one, as shown in Figure 3-2. Selecting all anchor points in an object lets you move the entire object without changing the anchor points in relationship to one another. You can tell which anchor points are selected and active because they appear as solid boxes.

					

				
					Figure 3-1: Multiple anchor points are selected.

				

					[image: 9781118168608-fg030301.tif]

					

				
					Figure 3-2: One anchor point is selected.

				

					[image: 9781118168608-fg030302.tif]

				Bounding boxes

				As a default, Illustrator shows a bounding box when an object is selected with the Selection tool. (Figure 3-1 shows a bounding box.) This feature can be helpful if you understand its function but confusing if you don’t know how to use it.

				By dragging on the handles, you can use the bounding box for quick transforms, such as scaling and rotating. To rotate, you pass the mouse cursor (without clicking) outside a handle until you see a rotate symbol and  then drag.

				If the bounding box bothers you, you can turn off the feature by choosing View⇒Hide Bounding Box.

				Selection tools

				Illustrator CS6 offers five main selection tools:

					[image: check.png] [image: 9781118168608-ma006.tif] Selection: Selects entire objects or groups. This tool activates all anchor points in an object or group at the same time, allowing you to move an object without changing its shape.

					[image: check.png] [image: 9781118168608-ma012.tif] Direct Selection: Selects individual points.

					[image: check.png] [image: 9781118168608-ma013.tif] Group Selection: Hidden in the Direct Selection tool in the Tools panel and used to select items within a group. This tool adds grouped items as you click objects in the order in which they were grouped. This selection tool becomes more useful to you as you find out about grouping objects in Illustrator.

					[image: check.png] [image: 9781118168608-ma014.tif] Magic Wand: Use the Magic Wand tool to select objects with like values, such as fill and stroke colors, based on a tolerance and stroke weight. Change the options of this tool by double-clicking it.

					[image: check.png] [image: 9781118168608-ma015.tif] Lasso: Use the Lasso tool to click and drag around anchor points you want to select.

				You can select an object with the Selection tool by using one of three main methods:

				[image: check.png] Click the object’s path.

				[image: check.png] Click an anchor point of the object.

				[image: check.png] Drag a marquee around part or all of an object. (In a later section named “Using a marquee to select an object,” we discuss using the marquee method.)

				Working with Selections

				After you gain an understanding about the basics of selections, you’ll probably be eager to try some techniques. In the following sections, you see the basics: Make a selection, work with anchor points and the marquee, make multiple selections, and of course, save your work.

				[image: technicalstuff.eps]	Smart guides, turned on by default in Illustrator CS6, can help you make accurate selections. These guides are visible as you’re drawing. They display names such as anchor point and path, and they highlight paths when you’re lined up with endpoints or center points. You can come to love these helpful aids, but if you don’t want to see them, simply choose View⇒Smart Guides or press the keyboard shortcut Ctrl+U (Windows) or [image: maccmd]+U (Mac) to toggle the smart guides off and on.

				Creating a selection

				To work with selections, you need to have something on the page in Illustrator. Follow these steps to make a selection:

					1.	Create a new page in Adobe Illustrator. (Any size or profile is okay.)

						Alternatively, you can open an existing illustration; see Chapter 2 of this minibook for instructions. Skip to Step 3 if you’re working with an existing illustration.

					2.	If you’re starting from a new page, create an object to work with.

						For example, click and hold down the Rectangle tool to select the Star tool. Then click and drag from the upper left to the lower right to create a star shape.

						Exact size doesn’t matter, but make it large enough that you can see it. To start over, choose Edit⇒Undo or press Ctrl+Z (Windows) or [image: maccmd]+Z (Mac).

						As a default, all shapes start with a black stroke and a white fill. (See Figure 3-3.) If yours isn’t black and white, press D, which changes the selected object to the default colors.

				[image: tip.eps]		You can see the width and height of your object while you click and drag. If you don’t want those values to display, choose Edit⇒Preferences⇒Smart Guides (Windows) or Illustrator⇒Preferences⇒Smart Guides (Mac) and deselect the Measurements Labels check box.

					

				
					Figure 3-3: A shape created by a star tool.

				

					[image: 9781118168608-fg030303.tif]

					3.	Using the Selection tool, click the object to make sure it’s active.

						All anchor points are solid, indicating that they’re all active. (See Figure 3-3.) You see, as a default, many additional points you can use to transform your selected object.

					4.	Click and drag the shape to another location.

						All anchor points travel together.

					5.	When you’re finished relocating your selection, press Ctrl+D (Windows) or [image: maccmd]+D (Mac) to deactivate your selection.

						You can also use one of these three alternative methods to deactivate your selection:

					•	Choose Select⇒Deselect.

					•	Ctrl+click (Windows) or [image: maccmd]-click (Mac) anywhere on the page.

					•	Use the keyboard shortcut Ctrl+Shift+A (Windows) or [image: maccmd]+Shift+A (Mac).

				[image: tip.eps]	To select an object behind another, use the Select-behind keyboard shortcut. Simply place the cursor over the area where you know that the object (to be selected) is located and press Ctrl+click (Windows) or [image: maccmd]+click (Mac OS).

				Selecting an anchor point

				When you have a selection to work with (see the numbered list), you can deselect all active anchor points and then make just one anchor point active. Follow these steps:

					1.	Choose Select⇒Deselect to make sure the object isn’t selected.

					2.	Select the Direct Selection tool (the white arrow) from the Tools panel.

					3.	Click one anchor point.

						Only one anchor point (the one you clicked) is solid, and the others are hollow, as shown in Figure 3-4.

					

				
					Figure 3-4: Select only one anchor point.

				

					[image: 9781118168608-fg030304.tif]

					4.	Click and drag that solid anchor point with the Direct Selection tool.

						Only that solid anchor point moves.

				[image: tip.eps]	Note that an anchor point enlarges when you cross over it with the Direct Selection tool. This enlargement is a big break for people who typically have to squint to see where the anchor points are positioned.

				Using a marquee to select an object

				Sometimes you can more easily surround the object you want to select by dragging the mouse to create a marquee. Follow these steps to select an object by creating a marquee:

					1.	Choose the Selection tool.

					2.	Click outside the object and drag over a small part of it, as shown in Figure 3-5.

						The entire object becomes selected.

					

				
					Figure 3-5:  Select an entire object with the Selection tool.

				

					[image: 9781118168608-fg030305.tif]

				You can also select only one anchor point in an object by using the marquee method:

					1.	Choose Select⇒Deselect to make sure the object isn’t selected and then choose the Direct Selection tool.

					2.	Click outside a corner of the object and drag over only the anchor point you want to select.

						Notice that only that anchor point is active, which can be a sight-saver when you’re trying to select individual points. (See Figure 3-6.)

					

				
					Figure 3-6:  Select individual anchor points with the Direct Selection tool.

				

					[image: 9781118168608-fg030306.tif]

				[image: tip.eps]	You can use this method to cross over just the two top points or side anchor points to activate multiple anchor points as well.

				Selecting multiple objects

				If you have multiple items on a page, you can select them by using one of these methods:

				[image: check.png] Select one object or anchor point and then hold down the Shift key and click another object or anchor point. Depending on which selection tool you’re using, you select either all anchor points on an object (Selection tool) or additional anchor points only (Direct Selection tool).

						You can use the Shift key to deactivate an object as well. Shift+click a selected object to deselect it.

				[image: check.png] Choose Select⇒All or press Ctrl+A (Windows) or [image: maccmd]+A (Mac).

				[image: check.png] Use the marquee selection technique and drag outside and over the objects. When you use this technique with the Selection tool, all anchor points in the objects are selected; when using the Direct Selection tool, only the points you drag over are selected.

				Saving a selection

				Spending way too much time trying to make your selections? Illustrator comes to the rescue with the Save Selection feature. After you have a selection that you may need again, choose Select⇒Save Selection and name the selection. The selection now appears at the bottom of the Select menu. To change the name or delete the saved selection, choose Select⇒Edit Selection. This selection is saved with the document.

				Grouping and Ungrouping

				Keep objects together by grouping them. The Group function is handy when you’re creating something from multiple objects, such as a logo. Using the Group function, you can ensure that all objects that make up the logo stay together when you move, rotate, scale, or copy it.

				Creating a group

				Follow these steps to create a group:

					1.	If you aren’t already working with an illustration that contains a bunch of objects, create several objects on a new page — anywhere, any size.

						For example, select the Rectangle tool and click and drag the page several times to create additional rectangles.

					2.	Select the first object with the Selection tool and then hold down the Shift key and click a second object.

					3.	Choose Object⇒Group or press Ctrl+G (Windows) or [image: maccmd]+G (Mac).

					4.	Choose Select⇒Deselect and then click one of the objects with the Selection tool.

						Both objects become selected.

					5.	While the first two objects are still selected, Shift+click a third object.

					6.	With all three objects selected, choose Object⇒Group again.

						Illustrator remembers the grouping order. To prove it, choose Select⇒Deselect to deselect the group and switch to the Group Selection tool. (Hold down the mouse button on the Direct Selection tool to access the Group Selection tool.)

					7.	With the Group Selection tool, click the first object; all anchor points become active. Click the first object again; the second object becomes selected. Click the first object again, and the third object becomes selected.

						The Group Selection tool activates the objects in the order you grouped them. After you group the objects, you can treat them as a single object.

				To ungroup objects, choose Object⇒Ungroup or use the keyboard shortcut Ctrl+Shift+G (Windows) or [image: maccmd]+Shift+G (Mac). In a situation where you group objects twice (because you added an object to the group, for example), you have to choose Ungroup twice.

				Using Isolation mode

				When you use Isolation mode in Illustrator, you can easily select and edit objects in a group without disturbing other parts of your artwork. Simply double-click a group, and it opens in a separate Isolation mode, where all objects outside the group are dimmed and inactive. Do the work you need to do on the group and exit from Isolation mode by clicking the arrow to the left of Group in the upper-left corner of the window, shown in Figure 3-7.

					[image: 9781118168608-ma040.tif]	Click the Isolate Selected Object button in the Control panel to quickly access the Isolation mode.

					

				
					Figure 3-7: In Isolation mode, you can edit group contents without disturbing other artwork.

					
				

					[image: 9781118168608-fg030307.tif]

				Manipulating Selected Objects

				In the following list, you discover a few other cool things you can do with selected objects:

				[image: check.png] Move selected objects: When an object is selected, you can drag it to any location on the page, but what if you only want to nudge it a bit? To nudge an item one pixel at a time, select it with the Selection tool and press the left-, right-, up-, or down-arrow key to reposition the object. Hold down the Shift key as you press an arrow key to move an object by ten pixels at a time.

				[image: check.png] Constrain movement: Want to move an object over to the other side of the page without changing its alignment? Constrain something by selecting an object with the Selection tool and dragging the item and then holding down the Shift key before you release the mouse button. By pressing the Shift key mid-drag, you constrain the movement to 45-, 90-, or 180-degree angles!

				[image: check.png] Clone selected objects: Use the Selection tool to easily clone (duplicate) an item and move it to a new location. To clone an item, simply select it with the Selection tool and then hold down the Alt key (Windows) or Option key (Mac). Look for the cursor to change to two arrows (see Figure 3-8) and then drag the item to another location on the page. Notice that the original object is left intact and that a copy of the object has been created and moved.

				[image: check.png] Constrain the clone: By Alt+dragging (Windows) or Option+dragging (Mac) an item and then pressing Shift, you can clone the item and keep it aligned with the original. 

				[image: remember.eps]		Don’t hold down the Shift key until you’re in the process of dragging the item; otherwise, pressing Shift deselects the original object.

						After you clone an object to a new location, try this neat trick to create multiple objects the same distance apart from each other by using the Transform Again command: Choose Object⇒Transform⇒Transform Again or press Ctrl+D (Windows) or [image: maccmd]+D (Mac) to have another object cloned the exact distance as the first cloned object. (See Figure 3-9.) We discuss transformations in more detail in Chapter 10 of this minibook.

					

				
					Figure 3-8: Drag the double arrow to clone an object.

				

					[image: 9781118168608-fg030308.tif]

					

				
					Figure 3-9: Using the Transform Again command.

				

					[image: 9781118168608-fg030309.tif]

				[image: check.png] Use the Select menu: By using the Select menu, you can gain additional selection controls, such as choosing Select⇒Inverse, which allows you to select one object and then turn your selection inside out. Also, choosing the Select⇒Same option lets you select one object and then select additional objects on the page based on similarities in color, fill, stroke, and other special attributes.

					[image: 9781118168608-ma240.tif]		Take advantage of the Select Similar button on the Control panel to easily access that feature. Notice that in Figure 3-10 you can hold down the arrow to the right of the Select Similar button to choose which similarities should be considered to make the selection.

					

				
					Figure 3-10: Define the similarities you want your selections based on.

				

					[image: 9781118168608-fg030310.tif]

			

		

	
		
			
				Chapter 4: Creating Basic Shapes

				In This Chapter

				[image: check.png] Using rectangles, ellipses, stars, and polygons

				[image: check.png] Resizing shapes after creation

				[image: check.png] Creating shapes

				Shapes, shapes, shapes — they’re everywhere in Illustrator. Basic shapes, such as squares, circles, polygons, and stars, are used in all types of illustrations. With the right know-how and the right shape tools, you can easily create these shapes exactly the way you want. In this chapter, you find out how to use these tools to control a shape’s outcome, create shapes based on precise measurements, and change the number of points a star has.

				The Basic Shape Tools

				The only visible shape tool in the Tools panel is, as a default, the Rectangle tool. If you click and hold down that tool, you can access the Rounded Rectangle, Ellipse, Polygon, and Star tools, shown in Figure 4-1. (Although you see the Flare tool, it isn’t a basic shape.)

					

				
					Figure 4-1: Basic shape tools.

				

					[image: 9781118168608-fg030401.tif]

				[image: tip.eps]	You can tear off this tool set so that you don’t have to find the hidden shapes later. Click and hold the Rectangle tool and drag to the arrow on the far right side, and then release the mouse button. These tools are now on a free-floating toolbar that you can drag to another location.

				Creating rectangles and ellipses

				Rectangles and ellipses are the most fundamental shapes you can create. (See Figure 4-2.) To create a rectangle shape freehand, select the Rectangle tool and simply click the page where you want the shape to appear. Then drag diagonally toward the opposite side, drag your mouse the distance you want the shape to be in size, and release the mouse button. You can drag up or down. You do the same to create a circle or oval by using the Ellipse tool.

					

				
					Figure 4-2:  Click and drag diagonally to create a shape.

				

					[image: 9781118168608-fg030402.eps]

					[image: 9781118168608-ma006.tif]	After you create the shape, adjust its size and position by using the Selection tool. Reposition the shape by clicking the selected object and dragging. Resize the object by grabbing a handle and adjusting in or out. To adjust two sides together, grab a corner handle. To resize a shape proportionally, Shift+drag a corner handle.

				Using the Rounded Rectangle tool

				You can create a rounded rectangle by using one of two methods:

				[image: check.png] Click and drag freehand to create the rounded rectangle shape.

				[image: check.png] Click the artboard once to open the Rounded Rectangle dialog box, where you can enter values to define the shape.

				The difference between these two methods is that when you open the Rounded Rectangle dialog box (see Figure 4-3), you can enter a value in the Corner Radius text field, which determines how much rounding is applied to the corners of the shape.

					

				
					Figure 4-3: Customize the size of a rounded rectangle.

				

					[image: 9781118168608-fg030403.tif]

				[image: tip.eps]	Change the rounded corner visually by pressing the up and down keys on your keyboard while you’re dragging out the Rounded Rectangle shape on the artboard.

				The smaller the value, the less rounded the corners; the higher the value, the more rounded the corners. Be careful: You can round a rectangle’s corners so much that it becomes an ellipse!

				Using the Polygon tool

				You create stars and polygons in much the same way as you create rectangles and ellipses. Select the Polygon tool and click and drag from one corner to another to create the default six-sided polygon shape. You can also select the Polygon tool and click once on the artboard to change the Polygon tool options in the Polygon dialog box.

				You can change the polygon shape by entering new values in the Radius and Sides text fields, as shown in Figure 4-4. The radius is determined from the center to the edge of the polygon. The value for the number of sides can range from 3 (making triangles a breeze to create) to 1,000. Whoa — a polygon with 1,000 sides would look like a circle unless it was the size of Texas!

					

				
					Figure 4-4: Creating a polygon shape.

				

					[image: 9781118168608-fg030404.tif]

				Using the Star tool

				To create a star shape, select the Star tool from the Tools panel. (Remember that it may hide under other shape tools.) If you click the artboard once to open the Star dialog box, you see three text fields in which you can enter values to customize your star shape:

				[image: check.png] Radius 1: Distance from the outer points to the center of the star

				[image: check.png] Radius 2: Distance from the inner points to the center of the star

				[image: check.png] Points: Number of points that comprise the star

				The closer together the Radius 1 and Radius 2 values are to each other, the shorter the points on your star. In other words, you can go from a starburst to a seal of approval by entering values that are close in the Radius 1 and Radius 2 text fields, as shown in Figure 4-5.

					

				
					Figure 4-5: Radius 1 and Radius 2 are closer to each other in the star on the bottom.

				

					[image: 9781118168608-fg030405.eps]

				Resizing Shapes

				You often need a shape to be an exact size (for example, 2 x 3 inches). After you create a shape, the best way to resize it to exact measurements is to use the Transform panel, shown in Figure 4-6. Have the object selected and then choose Window⇒Transform to open the Transform panel. Note that on this panel you can enter values to place an object in the X and Y fields as well as enter values in the width (W) and height (H) text fields to determine the exact size of an object.

				In many Adobe Illustrator panels, you may see measurement increments consisting of points, picas, millimeters, centimeters, or inches, which can be confusing and maybe even intimidating. But you can control which measurement increments to use.

					

				
					Figure 4-6: Precisely set the size of a shape.

				

					[image: 9781118168608-fg030406.tif]

				[image: tip.eps]	Show rulers by choosing View⇒Rulers⇒Show Rulers or press Ctrl+R (Windows) or [image: maccmd]+R (Mac). Then right-click (Windows) or Control-click (Mac) the ruler to change the measurement increment to an increment you’re more familiar with. Using the contextual menu that appears, you can change the measurement increment directly on the document.

				Alternatively, you can simply type the number followed by a measurement extension into the width and height text fields in the Transform panel (refer to Figure 4-6) and the measurement converts properly for you. Table 4-1 lists the extensions you can use.

				Table 4-1	Measurement Extensions

				
					
						
								
								Extension

							
								
								Measurement Unit

							
						

						
								
								in (or “)

							
								
								Inch

							
						

						
								
								Pt

							
								
								Point

							
						

						
								
								mm

							
								
								Millimeter

							
						

						
								
								pp

							
								
								Pica

							
						

					
				

				[image: tip.eps]	If you don’t want to bother creating a freehand shape and then changing its size, select the Shape tool and click the artboard. The Options dialog box specific to the shape you’re creating appears, and you can type values into the Width and Height text fields.

				If you accidentally click and drag, you end up with a tiny shape on your page. Don’t fret. Simply get rid of the small shape by selecting it and pressing the Delete key, and then you can try again.

				Tips for Creating Shapes

				The following simple tips can improve your skills at creating basic shapes in Illustrator:

				[image: check.png] Press and hold the Shift key while dragging with the Rectangle or Ellipse tool to create a perfect square or circle. This trick is also helpful when you’re using the Polygon and Star tools — holding down the Shift key constrains them so that they’re straight. (See Figure 4-7.)

				[image: check.png] Create a shape from the center out by holding down the Alt (Windows) or Option (Mac) key while dragging. Hold down Alt+Shift (Windows) or Option+Shift (Mac) to pull a constrained shape out from the center.

					

				
					Figure 4-7: Use the Shift key to constrain a shape while you create it.

				

					[image: 9781118168608-fg030407.tif]

				[image: check.png] When entering values in a shape dialog box, you can click either the Width or Height text to match the other value. In Figure 4-8, we entered the value 4 in the Height text box and then clicked the word Width to make the values match.

					

				
					Figure 4-8: Match values easily.

				

					[image: 9781118168608-fg030408.tif]

				[image: check.png] When creating a star or polygon shape by clicking and dragging, if you keep the mouse button down, you can then press the up- or down-arrow key to interactively add points or sides to your shape.

				Creating advanced shapes

				At times, it may be wise to use advanced tools in Illustrator to create unique shapes. The Pathfinder panel is an incredible tool you can use to combine, knock out (eliminate one shape from another), and even create shapes from other intersected shapes.

				You use the Pathfinder panel, shown in Figure 4-9, to combine objects into new shapes. To use the Pathfinder panel, choose Window⇒Pathfinder.

					

				
					Figure 4-9: Combine objects into new shapes.

				

					[image: 9781118168608-fg030409.eps]

				Across the top row of the Pathfinder panel are the Shape modes, which let you control the interaction between selected shapes. You can choose from the Shape modes listed in Table 4-2.

				Table 4-2	Shape Modes

				
					
						
								
								Button

							
								
								Mode

							
								
								What You Can Do with It

							
						

						
								
								[image: 9781118168608-ma042.tif]

							
								
								Add to Shape Area

							
								
								Unite selected shapes into one shape.

							
						

						
								
								[image: 9781118168608-ma043.tif]

							
								
								Subtract from Shape Area

							
								
								Cut out the topmost shape from the underlying shape.

							
						

						
								
								[image: 9781118168608-ma044.tif]

							
								
								Intersect Shape Areas

							
								
								Use the area of the topmost shape to clip the underlying shape as a mask would.

							
						

						
								
								[image: 9781118168608-ma045.tif]

							
								
								Exclude Overlapping Shape Areas

							
								
								Use the area of the shape to invert the underlying shape, turning filled regions into holes and vice versa.

							
						

					
				

				[image: tip.eps]	If you like the result from using Exclude Overlapping Shapes mode, you can also create a similar effect by selecting several shapes and choosing Object⇒Compound Path⇒Make. This command “punches” the topmost shapes from the bottom shape.

				[image: tip.eps]	The shapes remain separate so that you can still adjust them, which is helpful if you like to tweak your artwork (but it drives some people crazy). You can turn the result of using the Shape Mode buttons into one shape by either clicking the Expand button after selecting Shape mode or holding down the Alt key (Windows) or Option key (Mac) when clicking a Shape Mode button.

				Using the Pathfinders

				Pathfinders are the buttons at the bottom of the Pathfinder panel that let you create new shapes from overlapping objects. Table 4-3 summarizes what each Pathfinder does.

				Table 4-3	The Pathfinders

				
					
						
								
								Button

							
								
								Mode

							
								
								What You Can Do with It

							
						

						
								
								[image: 9781118168608-ma046.tif]

							
								
								Divide

							
								
								Divide all shapes into their own individual shapes. This tool is quite useful when you’re trying to create custom shapes.

							
						

						
								
								[image: 9781118168608-ma047.tif]

							
								
								Trim

							
								
								Remove the part of a filled object that’s hidden.

							
						

						
						
								
								[image: 9781118168608-ma048.tif]

							
								
								Merge

							
								
								Remove the part of a filled object that’s hidden. Also, remove any strokes and merge any adjoining or overlapping objects filled with the same color.

							
						

						
								
								[image: 9781118168608-ma049.tif]

							
								
								Crop

							
								
								Delete all parts of the artwork that fall outside the boundary of the topmost object. You can also remove any strokes. If you want strokes to remain when using this feature, select them and choose Object⇒Path⇒Outline Stroke.

							
						

						
								
								[image: 9781118168608-ma050.tif]

							
								
								Outline

							
								
								Divide an object into its shape’s line segments, or edges. This tool is useful for preparing artwork that needs a trap for overprinting objects.

							
						

						
								
								[image: 9781118168608-ma051.tif]

							
								
								Minus Back

							
								
								Delete an object that’s in the back of frontmost object.

							
						

					
				

				Using the Shape Builder tool

				New in Illustrator CS5, you can intuitively combine, edit, and fill shapes on your artboard. Follow these steps to create your own unique shape using the Shape Builder tool:

					1.	Create several overlapping shapes.

					2.	Select the shapes that you want to combine.

						3.	[image: 9781118168608-ma028.tif] Select the Shape Builder tool and then click and drag across the selected shapes, as shown on the left in Figure 4-10. 

					

				
					Figure 4-10: Create several shapes in order to use the Shape Builder tool.

				

					[image: 9781118168608-fg030410.eps]

						The selected shapes are combined into one shape, as shown on the right in Figure 4-10.

						The Shape Builder tool also enables merging objects, breaking overlapping shapes, subtracting areas, and more. 

					4.	Create another shape that overlaps your new combined shape.

					5.	Using the Selection tool, select both shapes.

					6.	Select the Shape Builder tool again.

					7.	Hold down the Alt (Windows) or Option (Mac) key and click and drag across the newly added shape, as shown in Figure 4-11. 

						It’s subtracted from the underlying shape.

					

				
					Figure 4-11:  Use the Shape Builder tool to subtract from another shape.

				

					[image: 9781118168608-fg030411.tif]

					[image: 9781118168608-ma041.tif]	Coloring fills and strokes is easier now, too. When you’re finished making your shape, you can use the Live Paint Bucket tool that is hidden in the Shape Builder tool to intuitively fill your shape with color.

				

			

			
		

	
		
			
				Chapter 5: Using the Pen  Tool and Placing Images

				In This Chapter

				[image: check.png] Familiarizing yourself with the Pen tool

				[image: check.png] Creating paths, closed shapes, and curves

				[image: check.png] Using the hidden Pen tools

				[image: check.png] Tracing some artwork

				[image: check.png] Placing images in Illustrator CS6

				[image: check.png] Using the Image Trace feature

				You’ve seen illustrations that you know are made from paths, but how do you make your own? In this chapter, we show you how to use the Pen tool to create paths and closed shapes.

				[image: remember.eps]	Using the Pen tool requires a little more coordination than using other Illustrator tools. Fortunately, Adobe Illustrator CS6 includes new features to help make using the Pen tool a little easier. After you master the Pen tool, the possibilities for creating illustrations are unlimited. Read this chapter to build your skills using the most popular feature in graphical software: the Bézier curve.

				Pen Tool Fundamentals

					[image: 9781118168608-ma016.tif]	You can use the Pen tool to create all sorts of elements, such as straight lines, curves, and closed shapes, which you can then incorporate into  illustrations:

				[image: check.png] Bézier curve: Originally developed by Pierre Bézier in the 1970s for CAD/CAM operations, the Bézier curve (shown in Figure 5-1) became the underpinnings of the entire Adobe PostScript drawing model. You can control the depth and size of a Bézier curve by using direction lines.

				[image: check.png] Anchor point: You can use anchor points to control the shape of a path or an object. Anchor points are created automatically when using shape tools. You can manually create anchor points by clicking from point to point with the Pen tool.

					

				
					Figure 5-1:  Bézier curves are controlled by direction lines.

				

					[image: 9781118168608-fg030501.eps]

				[image: check.png] Direction line: These lines are essentially the handles you use on curved points to adjust the depth and angle of curved paths.

				[image: check.png] Closed shape: When a path is created, it becomes a closed shape when the start point joins the endpoint.

				[image: check.png] Simple path: A path consists of one or more straight or curved segments. Anchor points mark the endpoints of the path segments.

				In the next section, we show you how to control the anchor points.

				Creating a straight line

				A basic function of the Pen tool is to create a simple path. You can create a simple, straight line with the Pen tool by following these steps:

					1.	Press D or click the small black-and-white color swatches at the bottom of the Tools panel.

						You revert to the default colors of a black stroke and a white fill. With black as a stroke, you can see your path clearly.

				[image: tip.eps]		The trick of pressing D to change the foreground and background colors to the default of black and white also works in Photoshop and InDesign.

					2.	Click the Fill swatch, at the bottom of the Tools panel, to ensure that the Fill swatch is in front of the Stroke swatch, and then press the forward slash (/) key to change the fill to None.

					3.	Open a new blank page and select the Pen tool.

						Notice that when you move the mouse over the artboard, the Pen cursor appears with an X beside it, indicating that you’re creating the first anchor point of a path.

					4.	Click the artboard to create the first anchor point of a line.

						The X disappears.

				[image: warning_bomb.eps]		Avoid dragging the mouse or you’ll end up creating a curve rather than a straight segment.

					5.	Click anywhere else on the document to create the ending anchor point of the line.

						Illustrator creates a path between the two anchor points. Essentially, the path looks like a line segment with an anchor point at each end. (See Figure 5-2.)

					

				
					Figure 5-2: A path connected by two anchor points.

				

					[image: 9781118168608-fg030502.tif]

				To make a correction to a line you created with the Pen tool (as described in the preceding step list), follow these steps:

					1.	Choose Select⇒Deselect to make sure that no objects are selected.

					2.	Select the Direct Selection tool from the Tools panel.

						Notice the helpful feature that enlarges the anchor point when you pass over it with the Direct Selection tool.

					3.	Click an anchor to select one point on the line.

						Notice that the selected anchor point is solid and the other is hollow. Solid indicates that the anchor point you clicked is active whereas hollow is inactive.

					4.	Click and drag the anchor point with the Direct Selection tool.

						The selected anchor point moves, changing the direction of the path while not affecting the other anchor point.

				[image: remember.eps]	Use the Direct Selection tool (press A to use the keyboard shortcut to select the Direct Selection tool) to make corrections to paths.

				Make sure that only the anchor point you want to change is active. If the entire path is selected, all anchor points are solid. If only one anchor point is selected, all but that one point will be hollow.

				Creating a constrained straight line

				In this section, we show you how to create a real straight line — one that’s on multiples of a 45-degree angle. Illustrator makes it easy; just follow these steps:

					1.	Select the Pen tool and click the artboard anywhere to place an anchor point.

					2.	Hold down the Shift key and click another location to place the ending anchor point.

						Notice that when you’re holding down the Shift key, the line snaps to a multiple of 45 degrees.

				[image: remember.eps]	Release the mouse button before you release the Shift key or else the line pops out of alignment.

				Creating a curve

				In this section, you see how to use the Bézier path to create a curved segment. We don’t guarantee that you’ll love this process — not at first, anyway. But after you know how to use a Bézier path, you’ll likely find it useful. To create a Bézier path, follow these steps:

					1.	Starting with a blank artboard, select the Pen tool and click the artboard anywhere to place the first anchor point.

					2.	Click someplace else to place the ending anchor point — don’t let go of the mouse button — and then drag the cursor until a direction line appears.

						If you look closely, you see that anchor points are square and that direction lines have circles at the end, as shown in Figure 5-3.

					

				
					Figure 5-3: Click and drag with the Pen tool to create a curved path.

				

					[image: 9781118168608-fg030503.tif]

					3.	Drag the direction line closer to the anchor point to flatten the curve; drag farther away from the anchor point to increase the curve, as shown in Figure 5-4.

					4.	When you’re happy with the curve, release the mouse button.

					

				
					Figure 5-4: Adding curve to the curve.

				

					[image: 9781118168608-fg030504.eps]

				You’ve created an open path, or a path that doesn’t form a closed shape. We show you in the next section how to reconnect to the starting point of the path to make a closed shape.

				To alter a curved segment after you create it, follow these steps:

					1.	Choose Select⇒Deselect to ensure that no objects are selected.

					2.	Choose the Direct Selection tool and click the last anchor point  created.

						If the direction lines aren’t already visible, they appear.

				[image: tip.eps]		If you have difficulty selecting the anchor point, drag a marquee around it with the Direct Selection tool.

					3.	Click precisely at the end of one of the direction lines; drag the direction line to change the curve.

				Reconnecting to an existing path

				Creating one segment is fine if you want just a line or an arch. But if you want to create a shape, you need to add more anchor points to the original segment. If you want to fill your shape with a color or a gradient, you need to close it, which means that you need to eventually return to the starting anchor point.

				To add segments to your path and create a closed shape, follow these steps:

					1.	Create a segment (straight or curved).

						We show you how in the preceding sections of this chapter.

						You can continue from this point, clicking and adding anchor points until you eventually close the shape. For this example, you deselect the path so that you can discover how to continue adding to paths that have already been created. Knowing how to edit existing paths is extremely helpful when you need to make adjustments to artwork.

					2.	With the Pen tool selected, move the cursor over an end anchor point on the deselected path.

					3.	Click when you see the Pen icon with a forward slash to connect your next segment.

						The forward slash indicates that you’re connecting to this path.

					4.	Click someplace else to create the next anchor point in the path; drag the mouse if you want to create a curved segment.

					5.	Click to place additional anchor points, dragging as needed to curve those segments.

						Remember that you want to close this shape, so place the anchor points so that you can eventually come back to the first anchor point.

						The shape shown in Figure 5-5 is a result of adding several linked anchor points.

					

				
					Figure 5-5: Adding anchor points to create a shape.

				

					[image: 9781118168608-fg030505.tif]

					6.	When you return to the first anchor point, move the cursor over it and click when the close icon (a small, hollow circle) appears, as shown in Figure 5-6.

						The shape now has no end points.

					

				
					Figure 5-6: Click when the close path icon appears.

				

					[image: 9781118168608-fg030506.eps]

				Controlling curves

				After you feel comfortable creating curves and paths, take control of those curves so that you can create them with a greater degree of precision. The following steps walk you through the manual method for changing the direction of anchor points and reveal a helpful keyboard shortcut to make controlling paths a little more fluid. At the end of this section, we introduce new tools that you may also want to take advantage of to help you get control of the Pen tool.

				To control a curve, follow these steps:

					1.	Create a new document and then choose View⇒Show Grid to show a series of horizontal and vertical rules that act as guides.

						If it helps, use the Zoom tool to zoom in to the document.

					2.	With the Pen tool, click an intersection of any of these lines in the middle area of the page to place the initial anchor point and drag upward.

						Let go but don’t click when the direction line has extended to the horizontal grid line above it, as shown in Figure 5-7a.

					3.	Click to place the second anchor point on the intersection of the grid directly to the right of your initial point; drag the direction line to the grid line directly below it, as shown in Figure 5-7b.

				[image: tip.eps]		If you have difficulty keeping the direction line straight, hold down the Shift key to constrain it.

					4.	Choose Select⇒Deselect to deselect your curve.

						Congratulations! You’ve created a controlled curve. In these steps, we created an arch that’s going up, so we first clicked and dragged up. Likewise, to create a downward arch, you must click and drag down. Using the grid, try to create a downward arch like the one shown in Figure 5-7c.

					

				
					Figure 5-7: Creating a controlled Bézier curve.

				

					[image: 9781118168608-fg030507.eps]

				Creating a corner point

				To change the direction of a path from being a curve to a corner, you have to create a corner point, shown on the right in Figure 5-8. A corner point has no direction lines and allows for a sharp directional change in a path.

					

				
					Figure 5-8: Smooth versus corner points.

				

					[image: 9781118168608-fg030508.eps]

				You can switch from the Pen tool to the Convert Anchor Point tool to change a smooth anchor point into a corner point, but that process is time-consuming. An easier way is to press the Alt (Windows) or Option (Mac) key — the Pen tool temporarily changes into the Convert Anchor Point tool — while clicking the anchor point.

				To change a smooth anchor point into a corner point by using the shortcut method, follow these steps:

					1.	Create an upward arch.

						We show you how in the preceding section, “Controlling the curves.” (Refer to Figure 5-7b.)

					2.	Hold down the Alt (Windows) or Option (Mac) key and position the cursor over the last anchor point (the last point that you created with the Pen tool).

						3.	[image: 9781118168608-ma053.tif] When the cursor changes to a caret (that’s the Convert Anchor Point tool), click and drag until the direction line is up to the grid line above, as shown on the left in Figure 5-9.

					4.	Release the Alt (Windows) or Option (Mac) key and the mouse button, move the cursor to the grid line to the right, and click and drag down.

					

				
					Figure 5-9: Converting from smooth to corner.

				

					[image: 9781118168608-fg030509.eps]

				The Hidden Pen Tools

				Hold down the Pen tool icon in the Tools panel to access additional tools: the Add Anchor Point, Delete Anchor Point, and Convert Anchor Point tools, shown in Table 5-1. In the preceding section, we show you how to create a corner point by using the shortcut method, by pressing the Alt (Windows) or Option (Mac) key to access the Convert Anchor Point tool. You may feel more comfortable switching to that tool when you need to convert a point, but switching tools can be more time-consuming.

				Table 5-1	The Hidden Pen Tools

				
					
						
								
								Icon

							
								
								Tool

							
						

						
								
								[image: 9781118168608-ma016.tif]

							
								
								Pen

							
						

						
								
								[image: 9781118168608-ma054.tif]

							
								
								Add Anchor Point

							
						

						
								
								[image: 9781118168608-ma052.tif]

							
								
								Delete Anchor Point

							
						

						
								
								[image: 9781118168608-ma053.tif]

							
								
								Convert Anchor Point

							
						

					
				

				[image: tip.eps]	Even though you can use a hidden tool to delete and add anchor points, Illustrator automatically does this as a default when you’re using the Pen tool. When you move the cursor over an anchor point by using the Pen tool, a minus icon appears. To delete that anchor point, simply click. Likewise, when you move the cursor over a part of the path that doesn’t contain anchor points, a plus icon appears. Simply click to add an anchor point.

				If you prefer to use the tools dedicated to adding and deleting anchor points, choose Edit⇒Preferences⇒General (Windows) or Illustrator⇒Preferences⇒General (Mac); in the Preferences dialog box that appears, select the Disable Auto Add/Delete check box. Then, when you want to add or delete an anchor point, select the appropriate tool and click the path.

				Adding tools to help make paths

				Some Pen tool modifiers are available in the Control panel in Illustrator CS6. You can take advantage of them for many Pen tool uses, but using keyboard shortcuts to switch the Pen tool to its various options is probably still faster. If you’re resistant to contorting your fingers while trying to create a path, you should appreciate these tools.

					[image: 9781118168608-ma016.tif]	To see the Control panel tools, select the Pen tool and start creating a path. Notice that the Control panel has a series of buttons available, shown in Figure 5-10.

					

				
					Figure 5-10: Control panel tools for easy editing.

				

					[image: 9781118168608-fg030510.eps]

				Using the Eraser tool

				All users will love the Eraser tool! You can use it to quickly remove areas of artwork as easily as you erase pixels in Photoshop by stroking with your mouse over any shape or set of shapes.

				New paths are automatically created along the edges of the erasure, even preserving its smoothness, as shown in Figure 5-11.

				By double-clicking the Eraser tool, you can define the diameter, angle, and roundness of your eraser. (See Figure 5-12.) If you’re using a drawing tablet, you can even set Wacom tablet interaction parameters, such as Pressure and Tilt.

				If you want to erase more than a single selected object, use Isolation mode to segregate grouped objects for editing. Remember that in order to enter this mode, you simply double-click a group of items. You can then use the eraser on all objects in that group at one time without disturbing the rest of your design.

					

				
					Figure 5-11: The Eraser tool deletes sections of a path.

				

					[image: 9781118168608-fg030511.eps]

					

				
					Figure 5-12: Double-click the Eraser tool to set various tool options.

				

					[image: 9781118168608-fg030512.eps]

				Tracing Artwork

				You can use a template layer to trace an image manually. A template layer is a locked, dimmed layer you can use to draw over placed images with the Pen tool, much like you would do with a piece of onion skin paper over the top of an image.

				Creating a template layer

				Just follow these steps to create a template layer:

					1.	Take a scanned image or logo and save it in a format that Illustrator can import from your image-editing program, such as Photoshop.

						Typically, you save the image as an .eps, a .tif, or a native .psd (Photoshop) file.

					2.	Choose File⇒Place to open the Place dialog box.

					3.	In the Place dialog box, locate the saved image; then select the Template check box and click Place.

						Note that the Template check box is located at the bottom of the  dialog box.

						Selecting the Template check box tells Illustrator to lock down the scanned image on a layer. Essentially, you can’t reposition or edit your image.

						After you click Place, a template layer is automatically created for you, and another layer is waiting for you to create your path. The newly created top layer resembles a piece of tracing paper that has been placed on top of the scanned image.

					4.	Re-create the image by tracing over it with the Pen tool.

					5.	When you’re done, turn off the visibility of the placed image by clicking the Visibility icon to the left of the template layer.

						You now have a path you can use in place of the image, which is useful  if you’re creating an illustration of an image or are digitally re-creating  a logo.

				For more about layers, check out Chapter 8 of this minibook.

				[image: tip.eps]	Keep practicing to become more comfortable with clicking and dragging, flowing with the direction line pointing the way you want the path to be created; everything will fall into place.

				Using Image Trace

				With the Image Trace feature, you can take raster (bitmap) artwork and automatically trace it to convert it into vector artwork. This means that you can take scans of sketches, illustrations, and even photographs, and convert them into vector artwork that can be edited in Illustrator. The Image Trace feature is not totally new — in previous versions it was known as Live Trace —  but with CS6 it has been greatly improved. Additional options have been added, and you can easily access those options and “test” your trace using the new Image Trace panel. Follow these steps to try out this improved  feature:

					1.	Choose File⇒Place and place a scan or raster illustration that you want to convert to vector paths.

						Immediately after placing, you see that the Control panel now has additional buttons available, as shown in Figure 5-13.

					

				
					Figure 5-13: Image Trace Control panel features.

				

					[image: 9781118168608-fg030513.eps]

				[image: tip.eps]		Even though you can click on Image Trace immediately, you may want to consider selecting Window ⇒ Image Trace to access the Image Trace panel, which offers you more options and the opportunity to test your selections in advance.

					[image: 9781118168608-ma271.tif]		You can also click on the Image Trace Panel icon in the Control panel to open the Image Trace panel.

					2.	Click on the Preset drop-down menu to select a preset most similar to the artwork you want to convert. 

						Many of the presets are defined according to the type of artwork that you are tracing — such as a sketch, technical drawing, or photograph. (See Figure 5-14.) The 3 Color, 6 Color, and 16 Color options are useful when converting a photograph to a vector image.

					3.	Check the Preview box to see the results of your preset selection.

						At this point you might be happy with the result. If so, you can click on Trace in the Image Trace button and be done with this task. If not, leave Preview checked and continue on to Step 4 to work with some of the Advanced options.

					4.	Expand the Advanced section and note the additional path options available there:

					•	Paths determines how accurate a representation of the original art the path trace will be. The higher the percentage the more accurate the tracing. (See Figure 5-15.) Be careful with this feature — if you set  the percentage too high, you can end up with more anchor points then necessary. By default, this setting is at 50%, which should work for most of your artwork.

					

				
					Figure 5-14: Select a preset that best fits your placed image.

				

					[image: 9781118168608-fg030514.eps]

					

				
					Figure 5-15:  The image on the left has a low path tolerance of 0%. The image on the right has a high path tolerance  of 100%. 

				

					[image: 9781118168608-fg030515.eps]

					•	Corner determines how the Image Trace traces corners. A lower percentage produces a more rounded corner; a higher amount a sharper corner. (See Figure 5-16.) Again, the default setting (75%) works for most cases.

					

				
					Figure 5-16: On the left, a traced image with the corner setting at 0%. On the right, a traced image with a corner setting of 100%.

				

					[image: 9781118168608-fg030516.eps]

					•	Noise determines the minimum details size Image Trace can reproduce. The default of 100 pixels tends to work well. This provides you an area that will be recognized by the Image Trace feature of about 10 pixels x 10 pixels. You might have to play with this setting a bit to see what works best for your image.

				Changing the View

				Can’t see the results of your trace? Keep in mind that you can change the view. Just select the traced image and click on the View drop-down menu in the Control panel. Using this you can turn off and on the view for the original image as well as the tracing results.

				[image: remember.eps]	Image Trace is a memory-intensive feature and your computer may take a little more time than normal to preview each preset.

				See Chapter 9 of this minibook for more information on painting fills and strokes.

				Other Details You Should Know about Placing Images

				In the preceding section, you discover how to place an image as a template. But what if you want to place an image to be used in an illustration file? Simply choose File⇒Place.

				Click an image once to see its Link check box. If you keep the check box selected, the image is linked to the original file, which is helpful if you plan to reference the file several times in the illustration (it saves file space) or edit the original and have it update the placed image in Illustrator. This option is usually selected by people in the prepress industry who want to have access to the original image file. Just remember to send the image with the Illustrator file if it’s to be printed or used someplace other than on your computer.

				If you deselect the Link check box, the image is embedded into the Illustrator file. This option keeps the filing system cleaner but doesn’t leave much room to edit the original image later. In certain instances, such as when you want an image to become a symbol (see Chapter 11 of this minibook), the image will have to be embedded, but most functions work with both linked and unlinked files.

				Using Photoshop Layer Comps

				The Layer Comps feature in Photoshop lets you set the visibility, appearance, and position of layers. You can take advantage of this useful organizational tool in other Adobe products. Read more about Photoshop in Book IV.

				You can place in Illustrator a .psd (Photoshop) image that has saved Layer Comps and choose which layer comp set you want visible.

				

			

			
		

	
		
			
				Chapter 6: Using Type  in Illustrator

				In This Chapter

				[image: check.png] Using the Type tools

				[image: check.png] Getting to know text areas

				[image: check.png] Manipulating text along paths and within shapes

				[image: check.png] Assigning font styles

				[image: check.png] Discovering the Character, Control, and Paragraph panels

				[image: check.png] Saving time with text utilities

				One of Illustrator’s strongest areas is manipulating text. Whether you’re using Illustrator to create logos, business cards, or type to be used on the web, you have everything you need to create professional-looking text.

				In this chapter, you meet the Type tools and discover a few basic (and more advanced) text-editing tricks that you can take advantage of. You then find out about other text tools, such as the Character and Paragraph panels. At the end of this chapter, you get the quick-and-dirty lowdown on the Illustrator text utilities. These utilities can save you loads of time, so don’t skip this section.

				Working with Type

				You can do all sorts of cool things with type, from the simplest tasks of creating a line of text and dealing with text overflow to more complicated tricks such as placing text along paths and wrapping text around objects.

				Figure 6-1 shows the Type tools with an example of what you can do with each one. Click and hold the Type tool to see the hidden tools. The different tools give you the ability to be creative and also accommodate foreign languages.

					

				
					Figure 6-1: The Type tools.

				

					[image: 9781118168608-fg030601.eps]

				Creating text areas

				A text area is a region that you define. Text, when inserted in this region, is constrained within the shape. To create a text area, click and drag with the Type tool.

				[image: tip.eps]	As you create and finish typing in a text area, you may want to quickly click and drag to create a new text area elsewhere on your artboard. Unfortunately, Illustrator doesn’t allow you to do that. You do have two options that will help you to create multiple text boxes quickly on your  artboard:

				[image: check.png] Choose Select⇒Deselect and then create another area.

				[image: check.png] Hold down the Ctrl (Windows) or [image: maccmd] (Mac) key, and click anywhere on the artboard outside of the active text area. By clicking, you deactivate the current text box so that you can click and drag out a new text area.

				Creating a line of text

				To create a simple line of text, select the Type tool and click the artboard. A blinking insertion point appears. You can now start typing. With this method, the line of type goes on forever (even beyond the end of the Scratch area) until you press Enter (Windows) or Return (Mac) to start a new line of text. This excess length is fine if you just need short lines of text for callouts or captions, for example, but it doesn’t work well if you’re creating a label or anything else that has large amounts of copy.

				[image: warning_bomb.eps]	Many new users click and drag an ever-so-small text area that doesn’t allow room for even one letter. If you accidentally do this, switch to the Selection tool, delete the active type area, and then click to create a new text insertion point.

				Flowing text into an area

				Select the Type tool and then drag on the artboard to create a text area. The cursor appears in the text area; text you type flows automatically to the next line when it reaches the edge of the text area. You can also switch to the Selection tool and adjust the width and height of the text area with the handles.

				[image: tip.eps]	Need an exact size for a text area? With the Type tool selected, drag to create a text area of any size. Then choose Window⇒Transform to view the Transform panel. Type an exact width measurement in the W text field and an exact height measurement in the H text field.

				Dealing with text overflow

				Watch out for excess text! If you create a text area that’s too small to hold all the text you want to put into it, a red plus sign appears in the lower-right corner, as shown in Figure 6-2.

					

				
					Figure 6-2:  The plus icon indicates that text is overflowing.

				

					[image: 9781118168608-fg030602.eps]

				When Illustrator indicates that you have too much text for the text area, you have several options:

				[image: check.png] Make the text area larger by switching to the Selection tool and dragging the handles.

				[image: check.png] Make the text smaller until you no longer see the overflow indicator.

				[image: check.png] Thread this text area (link it to another), which is a topic covered later in this chapter, in the “Threading text into shapes” section.

				Creating columns of text with the Area Type tool

				The easiest and most practical way to create rows and columns of text is to use the area type options in Adobe Illustrator. This feature lets you create rows and columns from any text area. You can have only rows, only columns (much like columns of text in a newspaper), or even both.

					1.	Select the Type tool and drag on the artboard to create a text area.

					2.	Choose Type⇒Area Type Options.

						The Area Type Options dialog box appears, as shown in Figure 6-3. At the end of this section, a list explains all options in the Area Type Options dialog box.

					

				
					Figure 6-3:  The Area Type Options dialog box lets you create columns of text.

				

					[image: 9781118168608-fg030603.eps]

					3.	In the Area Type Options dialog box, enter a width and height in the Width and Height text fields.

						The Width and Height text fields contain the height and width of your entire text area. In Figure 6-3, 200 pt is in the Width text field and 200 pt is in the Height text field.

					4.	In the Columns area, enter the number of columns you want to create in the Number text field, the span distance in the Span text field, and the gutter space in the Gutter text field.

						The span specifies the height of individual rows and the width of individual columns. The gutter is the space between columns and is automatically set for you, but you can change it to any value you like.

					5.	Click OK.

				When you create two or more columns of text from the Area Type Options dialog box, text flows to the next column when you reach the end of the previous column, as shown in Figure 6-4.

					

				
					Figure 6-4: One column of text flows into the next.

				

					[image: 9781118168608-fg030604.tif]

				[image: tip.eps]	The following list breaks down the other options available in the Area Type Options dialog box (refer to Figure 6-3):

				[image: check.png] Width and Height: The present width and height of the entire text area.

				[image: check.png] Number: The number of rows and/or columns that you want the text area to contain.

				[image: check.png] Span: The height of individual rows and the width of individual columns.

				[image: check.png] Fixed: Determines what happens to the span of rows and columns if you resize the type area. When this check box is selected, resizing the area can change the number of rows and columns but not their width. Leave this option deselected if you want to resize the entire text area and have the columns automatically resize with it.

				[image: check.png] Gutter: The empty space between rows or columns.

				[image: check.png] Inset Spacing: The distance from the edges of the text area.

				[image: check.png] First Baseline: Where you want the first line of text to appear. The default Ascent option starts your text normally at the top. If you want to put in a fixed size, such as 50 points from the top, select Fixed from the drop-down list and enter 50 pt in the Min text field.

				[image: check.png] Text Flow: The direction in which you read the text as it flows to another row or column. You can choose to have the text flow horizontally (across rows) or vertically (down columns).

				Threading text into shapes

				Create custom columns of text that are in different shapes and sizes by threading closed shapes together. This technique, of flowing text from one shape to another, works with rectangles, circles, stars, or any other closed shape and can lead to some creative text areas.

				Follow these steps to thread text into shapes:

					1.	Create any shape, any size.

						For this example, we’ve created a circle.

					2.	Create another shape (it can be any shape) someplace else on the page.

					3.	With the Selection tool, select one shape and Shift-click the other to make just those two shapes active.

					4.	Choose Type⇒Threaded Text⇒Create.

						A threading line appears, as shown in Figure 6-5, indicating the direction of the threaded text.

					5.	Select the Type tool, click the top of the first shape to start the threading, and start typing.

						Continue typing until the text flows over into the other shape.

					

				
					Figure 6-5: Threaded text areas flow from one area to another.

				

					[image: 9781118168608-fg030605.tif]

				If you no longer want the text to be threaded, choose Type⇒Threaded Text⇒Remove Threading, which eliminates all threading from the text shapes. To remove one or more, but not all, shapes from the threading, select the shape you want to remove from the threading and choose Type⇒Threaded Text⇒Release Selection.

				Wrapping text

				Wrapping text isn’t quite the same as wrapping a present — it’s easier! A text wrap forces text to wrap around a graphic, as shown in Figure 6-6. This feature can add a bit of creativity to any piece.

					

				
					Figure 6-6: The graphic is forcing the text to wrap around it.

				

					[image: 9781118168608-fg030606.tif]

				First, create a text area and either enter text or paste text into it. Then place an image that you can wrap the text around. Follow these steps to wrap text around another object or group of objects:

					1.	Select the wrap object.

						This object is the one you want the text to wrap around.

					2.	Make sure that the wrap object is on top of the text you want to wrap around it by choosing Object⇒Arrange⇒Bring to Front.

				[image: remember.eps]		If you’re working in layers (which we discuss in Chapter 8 of this minibook), make sure that the wrap object is on the top layer.

					3.	Choose Object⇒Text Wrap⇒Make.

						An outline of the wrap area is visible.

					4.	Adjust the wrap area by choosing Object⇒Text Wrap⇒Text Wrap Options.

						The Text Wrap Options dialog box appears, as shown in Figure 6-7.

						You have these options:

					•	Offset: Specifies the amount of space between the text and the wrap object. You can enter a positive or negative value.

					•	Invert Wrap: Wraps the text on the inside of the wrap object instead of around it.

					

				
					Figure 6-7: Adjust the distance of the text wrap from the object.

				

					[image: 9781118168608-fg030607.tif]

					5.	When you finish making selections, click OK.

				If you want to change the text wrap at a later point, select the object and choose Object⇒Text Wrap⇒Text Wrap Options. Make your changes and click OK.

				If you want to unwrap text from an object, select the wrap object and choose Object⇒Text Wrap⇒Release.

				Outlining text

				Illustrator gives you the opportunity to change text into outlines or artwork. Basically, you change the text into an object, so you can no longer edit that text by typing. The plus side is that it saves you the trouble of sending fonts to everyone who wants to use the file. Turning text into outlines makes it appear as though your text was created with the Pen tool. You want to use this tool when creating logos that will be used frequently by other people or artwork that you may not have control over.

				To turn text into an outline, follow these steps:

					1.	Type some text on your page.

						For this example, just type a word (say, your name) and make sure that the font size is at least 36 points. You want to have it large enough to see the effect of outlining it.

					2.	Switch to the Selection tool and choose Type⇒Create Outlines.

						You can also use the keyboard command Ctrl+Shift+O (Windows) or [image: maccmd]+Shift+O (Mac).

						The text is now grouped together in outline form.

					3.	If you’re being creative, or just particular, and want to move individual letters, use the Group Select tool or choose Object⇒Ungroup to separate the letters, as shown in Figure 6-8.

					

				
					Figure 6-8: Letters converted to outlines.

				

					[image: 9781118168608-fg030608.tif]

				[image: warning_bomb.eps]	When you convert type to outlines, the type loses its hints, which are the instructions built into fonts to adjust their shape so that your system displays or prints them in the best way based on their size. Without hints, letters such as lowercase e or a might fill in as the letter forms are reduced in size. Make sure that the text is the approximate size it might be used at before creating outlines. Because the text loses the hints, try not to create outlines on text smaller than 10 points.

				Putting text on a path, in a closed shape,  or on the path of a shape

				Wow — that’s some heading, huh? You’ve probably seen text following a swirly path or inside a shape. Maybe you think that accomplishing such a task is too intimidating to even attempt. In this section, we show you just how easy these tasks are! Some Type tools are dedicated to putting type on a path or a shape (refer to Figure 6-1), but we think you’ll find that the key modifiers we show you in the following sections are easier to use.

				Creating text on a path

				Follow these steps to put type on a path:

					1.	Create a path with the Pen, Line, or Pencil tool.

						Don’t worry if it has a stroke or fill applied.

					2.	Select the Type tool and simply cross over the start of the path.

					3.	When an I-bar with a squiggle appears (which indicates that the text will run along the path), click.

						The stroke and fill of the path immediately change to None.

					4.	Start typing, and the text runs on the path.

					5.	Choose Window⇒Type⇒Paragraph and change the alignment in the Paragraph panel to reposition where the text falls on the path.

						Alternatively, switch to the Selection tool and drag the first of the three I-bars that appears, as shown in Figure 6-9. This allows you to freely move the text on that path. The path in Figure 6-9 was created with the Pen tool.

				[image: tip.eps]	Flip the text to the other side of a path by clicking and dragging the I-bar under or over the path.

					

				
					Figure 6-9: Use the Selection tool to drag the I-bar to adjust the text.

				

					[image: 9781118168608-fg030609.tif]

				Creating text in a closed shape

				Putting text inside a shape can add spunk to a layout. This feature allows you to custom-create a closed shape with the shape tools or the Pen tool and flow text into it. Follow these steps to add text inside a shape:

					1.	Create a closed shape — a circle or an oval, for example.

					2.	Select the Type tool and cross over the path of the closed shape.

					3.	When you see the I-bar swell or become rounded, click inside the shape.

					4.	Start typing, and the text is contained inside the shape.

				Text on the path of a closed shape

				Perhaps you want text to run around the edge of a shape instead of inside it. Follow these steps to have text created on the path of a closed shape:

					1.	Create a closed shape, such as a circle.

					2.	Select the Type tool and cross over the path of the circle.

					3.	Don’t click when you see the I-bar swell up; hold down the Alt (Windows) or Option (Mac) key instead.

						The icon changes into the squiggle I-bar you see when creating text on a path.

					4.	When the squiggle line appears, click.

					5.	Start typing, and the text flows around the path of the shape, as shown in Figure 6-10.

					

				
					Figure 6-10: Holding down the Alt or Option key flows text around a closed shape.

				

					[image: 9781118168608-fg030610.eps]

						To change the origin of the text or move it around, use the alignment options in the Paragraph panel or switch to the Selection tool and drag the I-bar to a new location on the path.

						You can drag the I-bar in and out of the shape to flip the text so that it appears on the outside or inside of the path.

				Assigning Font Styles

				After you have text on your page, you’ll often want to change it to be more interesting than the typical 12-point Times font. Formatting text in Illustrator isn’t only simple, but you can also do it multiple ways. In the following list, we name and define some basic type components (see Figure 6-11):

					

				
					Figure 6-11: Components of type.

				

					[image: 9781118168608-fg030611.eps]

				[image: check.png] Font: A complete set of characters, letters, and symbols of a particular typeface design.

				[image: check.png] X height: The height of type, based on the height of the small x in that type family.

				[image: check.png] Kerning: The space between two letters. Often used for letters in larger type that need to be pulled closer together, such as W i. Kern a little to slide the i in a little closer to the W, maybe even moving into the space occupied by the W, as shown in Figure 6-12. Kerning doesn’t distort the text; it only increases or decreases the space between two letters.

				[image: check.png] Leading: Space between the lines of text.

				[image: check.png] Tracking: The space between multiple letters. Designers like to use this technique to spread out words by increasing the space between letters. Adjusting the tracking doesn’t distort text; it increases or decreases the space between the letters, as shown in Figure 6-13.

				[image: tip.eps]		Pretty good tracking and kerning has already been determined in most fonts. You don’t need to bother with these settings unless you’re tweaking text for a more customized look.

				[image: check.png] Baseline: The line that type sits on. The baseline doesn’t include descenders, type that extends down, like lowercase y and g. You adjust the baseline for trademark signs or mathematical formulas, as shown in Figure 6-14.

					

				
					Figure 6-12: Before kerning (left) and after (right).

				

					[image: 9781118168608-fg030612.eps]

					

				
					Figure 6-13: Tracking set at 0 (top) and 300 (bottom).

				

					[image: 9781118168608-fg030613.eps]

					

				
					Figure 6-14: Adjust the baseline for superscript.

				

					[image: 9781118168608-fg030614.eps]

				[image: tip.eps]	The keyboard shortcuts for type shown in Table 6-1 work with Adobe Illustrator, InDesign, and Photoshop.

				Table 6-1	Keyboard Shortcuts for Type

				
					
						
								
								Command

							
								
								Windows 

							
								
								Mac

							
						

						
								
								Align left, right, or center

							
								
								Shift+Ctrl+L, R, or C

							
								
								Shift+[image: maccmd]+L, R, or C

							
						

						
								
								Justify

							
								
								Shift+Ctrl+J

							
								
								Shift+[image: maccmd]+J

							
						

						
								
								Insert soft return

							
								
								Shift+Enter

							
								
								Shift+Return

							
						

						
								
								Reset horizontal scale to 100 percent

							
								
								Shift+Ctrl+X

							
								
								Shift+[image: maccmd]+X

							
						

						
								
								Increase or decrease point size

							
								
								Shift+Ctrl+> or <

							
								
								Shift+[image: maccmd]+> or <

							
						

						
								
								Increase or decrease leading

							
								
								Alt+[image: uparrow] or [image: down]

							
								
								Option+[image: uparrow] or [image: down]

							
						

						
								
								Set leading to the font size

							
								
								Double-click the leading icon in the Character panel

							
								
								Double-click the leading icon in the Character panel

							
						

						
								
								Reset tracking or kerning to 0

							
								
								Alt+Ctrl+Q

							
								
								Option+[image: maccmd]+Q

							
						

						
								
								Add or remove space (kerning) between two characters

							
								
								Alt+→ or ←

							
								
								Option+→ or ←

							
						

						
								
								Add or remove space (kerning) between characters by 5 times the increment value

							
								
								Alt+Ctrl+→ or ←

							
								
								Option+[image: maccmd]+→ or ←

							
						

						
								
								Add or remove space (kerning) between selected words

							
								
								Alt+← or →

							
								
								Option+← or →

							
						

						
								
								Add or remove space (kerning) between words by 5 times the increment value

							
								
								Shift+Alt+Ctrl+\ or Backspace

							
								
								Shift+Option+[image: maccmd]+\ or Backspace

							
						

						
								
								Increase or decrease baseline shift

							
								
								Alt+Shift+[image: uparrow] or [image: down]

							
								
								Option+Shift+[image: uparrow] or [image: down]

							
						

					
				

				Using the Character Panel

				To visualize changes you’re making to text and to see characteristics that are already selected, choose Window⇒Type⇒Character or press Ctrl+T (Windows) or [image: maccmd]+T (Mac), which opens the Character panel. Click the triangle in the upper-right corner to see a panel menu of additional options. Choose Show Options, and additional type attributes appear, such as baseline shift, underline, and strikethrough.

				[image: tip.eps]	Pressing Ctrl+T (Windows) or [image: maccmd]+T (Mac) is a toggle switch to either show or hide the Character panel. If you don’t see the Character panel appear at first, you may have hidden it by pressing the keyboard shortcut. Just try it again.

				The following list explains the options in the Character panel (see Figure 6-15):

					

				
					Figure 6-15: The Character panel shows additional options.

				

					[image: 9781118168608-fg030615.eps]

				[image: check.png] Font: Select the font you want to use from this drop-down list.

				[image: tip.eps]		In the Windows version, you can click and drag across the font name in the Character panel or Control panel, and press the up- or down-arrow key to automatically switch to the next font above or below on the font list. Do this while you have text selected to see the text change live!

				[image: check.png] Set font style: Select the style (for example, Bold, Italic, or Bold Italic) from this drop-down list. The choices here are limited by the fonts you have loaded. In other words, if you have only Times regular loaded in your system, you don’t have the choice to bold or italicize it.

				[image: check.png] Type size: Set the size of the type in this combo box. Average readable type is 12-point; headlines can vary from 18 points and up.

				[image: check.png] Leading: Select how much space you want between the lines of text in this combo box. Illustrator uses the professional typesetting method of including the type size in the total leading. In other words, if you have 12-point and want it double-spaced, set the leading at 24 points.

				[image: check.png] Kerning: To use this combo box, you first need to place the cursor between two letters. Then, to push the letters farther apart from each other, you can click the up arrow or type a value; to decrease the spacing between the letters, type a lower value, even negative numbers, or click the down arrow.

				[image: check.png] Tracking: Use the Tracking combo box by selecting multiple letters and increasing or decreasing the space between them all at once by clicking the up or down arrows or by typing a positive or negative value.

				[image: check.png] Horizontal scale: Distort selected text by stretching it horizontally. Enter a positive number to increase the size of the letters; enter a negative number to decrease the size.

				[image: check.png] Vertical scale: Distort selected text vertically. Enter a positive number to increase the size of the letters; enter a negative number to decrease the size.

				[image: warning_bomb.eps]		Using horizontal or vertical scaling to make text look like condensed type often doesn’t give good results. When you distort text, the nice thick and thin characteristics of the typeface also become distorted and can produce weird effects.

				[image: check.png] Baseline shift: Use baseline shift for trademark signs and mathematical formulas that require selected characters to be moved above or below the baseline.

				[image: check.png] Character rotation: Rotate just the selected text by entering an angle in this text field or by clicking the up or down arrows.

				[image: check.png] Rotate: Choose to rotate selected text on any angle.

				[image: check.png] Underline and strikethrough: These simple text attributes underline and strikethrough selected text.

				[image: check.png] Language: Select a language from this drop-down list. Note: The language you specify here is used by Illustrator’s spell checker and hyphenation feature. We discuss these features in the later section “Text Utilities: Your Key to Efficiency.”

				Using the Control Panel

				Use the Control panel to quickly access your Type tools and Type panels. Note in Figure 6-16 that when you have active text, hyperlinked text buttons allow you to quickly access panels, such as the Character and Paragraph panels. You can also use this Control panel as a quick and easy way to select the font, size, alignment, color, and transparency.

					

				
					Figure 6-16: Control panel type functions.

				

					[image: 9781118168608-fg030616.tif]

				Using the Paragraph Panel

				Access the Paragraph panel quickly by clicking the Paragraph hyperlink in the Control panel or by choosing Window⇒Type⇒Paragraph. This panel, shown in Figure 6-17, has all the attributes that apply to an entire paragraph (such as alignment and indents, which we discuss in the next two sections, and hyphenation, which we discuss later in this chapter). For example, you can’t flush left one word in a paragraph — when you click the Flush Left button, the entire paragraph flushes left. To see additional options in the Paragraph panel, click the triangle in the upper-right corner of the panel (the panel menu) and choose Show Options.

					

				
					Figure 6-17:  Use this panel to open typographic controls that apply to paragraphs.

				

					[image: 9781118168608-fg030617.eps]

				Alignment

				You can choose any of the following alignment methods by clicking the appropriate button on the Paragraph panel:

				[image: check.png] Flush Left: All text is flush to the left with a ragged edge on the right. This is the most common way to align text.

				[image: check.png] Center: All text is centered.

				[image: check.png] Flush Right: All text is flush to the right and ragged on the left.

				[image: check.png] Justify with the Last Line Aligned Left: Right and left edges are both straight, with the last line left-aligned.

				[image: check.png] Justify with the Last Line Aligned Center: Right and left edges are both straight, with the last line centered.

				[image: check.png] Justify with the Last Line Aligned Right: Right and left edges are both straight, with the last line right-aligned.

				[image: check.png] Justify All Lines: In this forced justification method, the last line is stretched the entire column width, no matter how short it is. This alignment is used in many publications, but it can create some awful results.

				Indentation

				You can choose from the following methods of indentation:

				[image: check.png] First Line Indent: Indents the first line of every paragraph. In other words, every time you press the Enter (Windows) or Return (Mac) key, this spacing is created.

						To avoid first-line indents and space after from occurring — if you just want to break a line in a specific place, for example — create a line  break or a soft return by pressing Shift+Enter (Windows) or  Shift+Return (Mac).

				[image: check.png] Right Indent: Indents from the right side of the column of text.

				[image: check.png] Left Indent: Indents from the left side of the column of text.

					[image: 9781118168608-ma032.tif]	Use the Eyedropper tool to copy the character, paragraph, fill, and stroke attributes. Select the text you want, select the Eyedropper tool, and click the text once with the attributes you want to apply to the selected text.

				By default, the Eyedropper affects all attributes of a type selection, including appearance attributes. To customize the attributes affected by these tools, double-click the Eyedropper tool to open the Eyedropper dialog box.

				Text Utilities: Your Key to Efficiency

				After you have text in an Illustrator document, you may need to perform various tasks within that text, such as search for a word to replace with another word, check your spelling and grammar, save and create your own styles, or change the case of a block of text. You’re in luck because Illustrator provides various text utilities that enable you to easily and efficiently perform all these otherwise tedious tasks. In the following sections, we give you a quick tour of these utilities.

				Find and Replace

				Generally, artwork created in Illustrator isn’t text heavy, but the fact that Illustrator has a Find and Replace feature can be a huge help. Use the Find and Replace dialog box (choose Edit⇒Find and Replace) to search for words that need to be changed, such as changing Smyth to Smith, or to locate items that may be difficult to find otherwise. This feature works much like all other search-and-replace methods.

				Spell checker

				Can you believe there was a time when Illustrator didn’t have a spell checker? Thankfully, it does now — and its simple design makes it easy  to use.

				To use the spell checker, choose Edit⇒Check Spelling and then click the Start button in the dialog box that appears. The spell checker works much like the spell checker in Microsoft Word or other popular applications: When a misspelled word is found, you’re offered a list of replacements. You can choose to fix that instance, fix all instances, ignore the misspelling, or add the word to the dictionary.

				If you click the arrow to the left of Options, you can set other specifications, such as whether you want to look for letter case issues or have the spell checker note repeated words.

				Note: The spell checker uses whatever language you specify in the Character panel. We discuss this panel in the earlier section “Using the Character Panel.”

				[image: tip.eps]	If you work in a specialized industry that uses loads of custom words, save yourself time by choosing Edit⇒Edit Custom Dictionary and then adding your own words. We recommend that you do so before you’re ready to spell check a document so that the spell checker doesn’t flag the custom words later (which slows you down).

				The Hyphenation feature

				Nothing is worse than trying to read severely hyphenated copy. Most designers either use hyphenation as little as possible or avoid it altogether by turning off the Hyphenation feature.

				Here are a few things you should know about customizing your hyphenation settings if you decide to use this feature:

				[image: check.png] Turning the Hyphenation feature on or off: Activate or deactivate the feature in the Hyphenation dialog box (see Figure 6-18); open this dialog box by choosing Window⇒Type⇒Paragraph, clicking the arrow in the upper-right corner of the Paragraph panel to access the panel menu, and then choosing Hyphenation from the list of options that appears. If you won’t use the Hyphenation feature, turn it off by deselecting the Hyphenation check box at the top of the Hyphenation dialog box.

				[image: tip.eps]		You can also simply click the Paragraph hyperlink in the Control panel to access the Paragraph panel.

				[image: check.png] Setting specifications in the Hyphenation dialog box: Set specifications in the dialog box that determine the length of words to hyphenate, the number of hyphens to be used in a single document, whether to hyphenate capitalized words, and how words should be hyphenated. The Before Last setting is useful, for example, if you don’t want to have a word, such as liquidated hyphenated as liquidat-ed. Type 3 in the Before Last text field and Illustrator won’t hyphenate words if it leaves only two letters on the next line.

					

				
					Figure 6-18: Customizing hyphenation settings.

				

					[image: 9781118168608-fg030618.eps]

				[image: check.png] Setting the Hyphenation Limit and Hyphenation Zone: They’re not diets or worlds in another dimension — the Hyphenation Limit setting enables you to limit the number of hyphens in a row. For example, type 2 in the Hyphenation Limit text field so that you never see more than two hyphenated words in a row. The Hyphenation Zone text field enables you to set up an area of hyphenation based on a measurement. For example, you can specify 1 inch to allow for only one hyphenation every inch. You can also use the slider to determine whether you want better spacing or fewer hyphens. This slider works only with the Single-Line Composer (the default).

				The Find Font feature

				If you work in production, you’ll love the Find Font feature, which enables you to list all fonts in a file that contains text and then search for and replace fonts (including the font’s type style) by name. You do so from the Find Font dialog box (see Figure 6-19), opened by choosing Type⇒Find Font. Select the font you want to replace from the Fonts in Document list. Next, select a font from the Replace with Font From list. Note that the font must already appear in the document. Click the Change button to replace the font (or click the Change All button to replace all instances of the font) and then click OK. That’s it!

				This cool feature enables you to replace fonts with fonts from the current working document or from your entire system. Select System from the Replace with Font From drop-down list to choose from all fonts loaded in your system.

					

				
					Figure 6-19: Use the Find Font dialog box to find and replace typefaces.

				

					[image: 9781118168608-fg030619.eps]

				The Change Case feature

				Doesn’t it drive you crazy when you type an entire paragraph before  discovering that you somehow pressed the Caps Lock key? Fix it fast by selecting the text, choosing Type⇒Change Case, and then choosing one of these options:

				[image: check.png] Uppercase: Makes the selected text all uppercase

				[image: check.png] Lowercase: Makes the selected text all lowercase

				[image: check.png] Title Case: Capitalizes the first letter in each word

				[image: check.png] Sentence Case: Capitalizes just the first letter in selected sentences

				In Illustrator, you use the same type engine used by InDesign for high-quality text control. You’re working, as a default, in what’s referred to as Single- Line Composer. Select Single or Every Line composer from the Paragraph panel menu.

				The options include the following:

				[image: check.png] Single-Line Composer: Useful if you prefer to have manual control over how lines break. In fact, this method had been in place in the past. The Single-Line Composer option doesn’t take the entire paragraph into consideration when expanding letter space and word spacing, so justified text can sometimes look odd in its entire form. (See Figure 6-19.)

				[image: check.png] Every-Line Composer: A professional way of setting text; many factors are taken into account as far as spacing is concerned, and spacing  is based on the entire paragraph. With this method, you see few  spacing issues that create strange effects, such as the ones on the  left in Figure 6-20.

					

				
					Figure 6-20: Single-Line Composer (left) and Every-Line Composer (right).

				

					[image: 9781118168608-fg030620.eps]

				Text styles

				A text style is a saved set of text attributes, such as font and size. Creating text styles keeps you consistent and saves you time by enabling you to efficiently implement changes in one step rather than have to select the text attributes for each instance of that style of text (say, a heading or caption). So when you’re finally happy with the way your headlines appear and how the body copy looks or when your boss asks whether the body copy can be a smidgen smaller (hmm, how much is a smidgen?), you can confidently answer, “Sure!”

				If you’ve created styles, changing a text attribute is simple. What’s more, the change is applied at once to all text using that style. Otherwise, you would have to make the attribute change to every occurrence of body text, which could take a long time if your text is spread out.

				Illustrator offers two types of text styles:

				[image: check.png] Character: Saves attributes for individual selected text. If you want just the word New in a line of text to be red, 20-point Arial, you can save it as a character style. Then, when you apply it, the attributes apply to only the selected text (and not to the entire line or paragraph).

				[image: check.png] Paragraph: Saves attributes for an entire paragraph. A span of text is considered a paragraph until it reaches a hard return or paragraph break. Note that pressing Shift+Enter (Windows) or Shift+Return (Mac) is considered a soft return, and paragraph styles continue to apply beyond the soft return.

				You can create character and paragraph styles in many ways, but we show you the easiest and most direct methods in the following subsections.

				Creating character styles

				Create a character style when you want individual sections of text to be treated differently from other text in the paragraph. So rather than repeatedly apply a style manually, you create and implement a character style. To do so, open a document containing text and follow these steps:

					1.	Set up text with the text attributes you want included in the character style in the Character and Paragraph panels and then choose Window⇒Type⇒Character Styles.

						The Character Styles panel opens.

						2.	[image: 9781118168608-ma055.tif] Select the text from Step 1 and Alt-click (Windows) or Option-click (Mac) the New Style button (the dog-eared page icon) at the bottom of the Character Styles panel.

					3.	In the Character Styles Options dialog box that appears, name your style and click OK.

						Illustrator records which attributes have been applied already to the selected text and builds a style from them.

					4.	Create another text area by choosing Select⇒Deselect and using the Type tool to drag out a new text area.

						We discuss using the Type tool in the earlier section “Creating  text areas.”

					5.	Change the font and size to dramatically different choices from your saved style and type some text.

					6.	Select some (not all) of the new text and then Alt-click (Windows) or Option-click (Mac) the style name in the Character Styles panel.

						Alt-click (Windows) or Option-click (Mac) to eliminate any attributes that weren’t part of the saved style. The attributes of the saved character style are applied to the selected text.

				[image: tip.eps]	When you create a new panel item (any panel) in Adobe Illustrator, InDesign, or Photoshop, we recommend that you get in the habit of Alt-clicking (Windows) or Option-clicking (Mac) the New Style button. This habit allows you to name the item (style, layer, or swatch, for example) while adding it to the panel.

				Creating paragraph styles

				Paragraph styles include attributes that are applied to an entire paragraph. What constitutes a paragraph is all text that falls before a hard return (you create a hard return when you press Enter in Windows or Return on the Mac), so this could be one line of text for a headline or ten lines in a body text paragraph.

				To create a paragraph style, open a document that contains text or open a new document and add text to it; then follow these steps:

					1.	Choose Window⇒Type⇒Paragraph Styles to open the Paragraph Styles panel.

					2.	Find a paragraph of text that has the same text attributes throughout it and put your cursor anywhere in that paragraph.

						You don’t even have to select the whole paragraph!

					3.	Alt-click (Windows) or Option-click (Mac) the Create New Style button (the dog-eared icon at the bottom of the Paragraph panel) to create a new paragraph style; give your new style a name.

						Your new style now appears in the Paragraph Styles panel list of styles.

					4.	Create a paragraph of text elsewhere in your document and make its attributes different from the text in Step 2.

					5.	Put your cursor anywhere in the new paragraph and Alt-click (Windows) or Option-click (Mac) your named style in the Paragraph Styles panel.

						The attributes from the style are applied to the entire paragraph.

				Updating styles

				When you use existing text to build styles, reselect the text and assign the style. In other words, if you put the cursor in the original text whose attributes were saved as a style, it doesn’t have a style assigned to it in the Styles panel. Assign the style by selecting the text or paragraph and clicking the appropriate style listed in the Styles panel. By doing so, you ensure that any future updates to that style apply to that original text and to all other instances.

				To update a style, simply select its name in either the Character or Paragraph Styles panel. Choose Options from the panel menu, which you access by clicking the arrow in the upper-right corner of the panel. In the resulting dialog box (see Figure 6-21), make changes by clicking the main attribute on the left and then updating the choices on the right. After you do so, all tagged styles are updated.

					

				
					Figure 6-21: Updating a paragraph style.

				

					[image: 9781118168608-fg030621.eps]

				[image: warning_bomb.eps]	Documents created in older versions of Adobe Illustrator (Version 10 or earlier) contain legacy text, which is text using the older text engine. When these files are opened, you see a warning dialog box. If you click the Update button, any text on the document will most likely reflow, causing line breaks, leading, and other types of spacing to change.

				Click the OK button to update the file after it’s opened to lock down the text. If necessary, you can use the Type tool to click a selected text area to update only the contained text. Another Warning dialog box appears that gives you the opportunity to update selected text, copy the text object, or cancel the text tool selection. This method is the best way to see which changes are occurring so that you can catch any spacing issues right off the bat. See Figure 6-22 for samples of the three options in the warning dialog box.

					

				
					Figure 6-22: Original text (left), updated text (middle), and text object copied (right).

				

					[image: 9781118168608-fg030622.eps]

				[image: remember.eps]	If you click Copy the Text Object, you can use the underlying locked copy to adjust the new text flow to match the old. Throw away the legacy text layer by clicking and dragging it to the trash icon in the Layers panel, or click the visibility eye icon to the left of the Legacy Text layer to hide it when you’re finished.

				

			

		

	
		
			
				Chapter 7: Organizing  Your Illustrations

				In This Chapter

				[image: check.png] Using rulers

				[image: check.png] Using ruler and custom guides

				[image: check.png] Working with the Transform panel for placement

				[image: check.png] Changing ruler origin

				[image: check.png] Rearranging, hiding, and locking objects

				[image: check.png] Masking objects

				You can know about all the neat special effects in Illustrator, but if you have no strong organization skills, you can become exasperated when things just don’t work as you expect them to. In this chapter, we focus on a few organizational tricks of the trade.

				Setting Ruler Increments

				Using rulers to help accurately place objects in an illustration sounds simple (and it is), but not knowing how to effectively use the rulers in Illustrator can drive you over the edge.

				To view rulers in Illustrator, choose View⇒Rulers⇒Show Rulers or press Ctrl+R (Windows) or [image: maccmd]+R (Mac). When the rulers appear, their default measurement setting is the point (or whichever measurement increment was last set up in the preferences).

				To change the ruler increment to the measurement system you prefer, use one of these methods:

				[image: check.png] Create a new document and select a measurement unit in the New Document dialog box.

				[image: check.png] Right-click (Windows) or Control-click (Mac) the horizontal or vertical ruler and pick a measurement increment.

				[image: check.png] Choose Edit⇒Preferences⇒Units (Windows) or Illustrator⇒Preferences⇒Units and Display Performance (Mac) to open  the Preferences dialog box.

				[image: remember.eps]		Change the ruler unit only by using the General drop-down list in the Preferences dialog box. If you change the measurement unit on the Stroke and Type tabs, you can end up with 12-inch type rather than that dainty 12-point type you were expecting.

				[image: remember.eps]		Setting general preferences changes them in all future documents.

				[image: check.png] Choose File⇒Document Setup to change the measurement unit for only the document you’re working on.

				Using Guides

				Guides can help you create more accurate illustrations. After a guide is created, you can turn its visibility off or on quickly with the View menu. You can use two kinds of guides in Illustrator:

				[image: check.png] Ruler guides: You create these straight-line guides by clicking the ruler and dragging out to the artboard.

				[image: check.png] Custom guides: These guides, created from Illustrator objects such as shapes or paths, are helpful for replicating the exact angle of a path, as shown in Figure 7-1.

					

				
					Figure 7-1:  Turn selected paths and shapes into custom guides.

				

					[image: 9781118168608-fg030701.tif]

				Creating a ruler guide

				A ruler guide is the easiest guide to create: Click the vertical or horizontal ruler anywhere and drag it to the artboard, as shown in Figure 7-2. By default, the horizontal ruler creates horizontal guides (no kidding), and the vertical ruler creates vertical guides. You can press Alt+drag (Windows)  or Option+drag (Mac) to change the orientation of the guide. The vertical ruler then creates a horizontal guide, and the horizontal ruler then creates  a vertical guide.

					

				
					Figure 7-2: Click the ruler and drag out a guide.

				

					[image: 9781118168608-fg030702.tif]

				Creating a custom guide

				Create a custom guide by selecting a path or a shape and choosing View⇒Guides⇒Make Guides. The selected object turns into a nonprinting guide.  Changing a path into a guide isn’t a permanent change. Choose View⇒Guides⇒Release Guides to turn guides back into paths.

				Using the Transform Panel for Placement

				Placing shapes and paths precisely where you want them can be difficult even if you have steady hands. Save yourself some aggravation by using the Transform panel to achieve this. Type x, y coordinates in the Transform panel to position objects exactly where you want them.

				[image: tip.eps]	In Adobe Illustrator and InDesign, the Reference Point Indicator icon is on the left side of the Transform panel. Click the handle of the icon to change the point of reference. To measure from the upper-left corner, click the indicator on the handle there. If you want to know the exact center of an object, click the center point in the indicator. The point of reference is the spot on the object that falls at the x, y coordinates, which specify the placement of the selected object:

				[image: check.png] x coordinate: From left to right

				[image: check.png] y coordinate: From top to bottom

				Changing the Ruler Origin

				In Adobe Illustrator, InDesign, and Photoshop, you can change the ruler origin, which defines the start of a printing area of an image.

				To change the ruler origin, follow these steps:

					1.	Move the pointer to the upper-left corner of the rulers where the rulers intersect, as shown in Figure 7-3.

					

				
					Figure 7-3: Changing the ruler’s origin.

				

					[image: 9781118168608-fg030703.tif]

					2.	Drag the pointer to the spot where you want the new ruler origin.

						While you drag, a cross hair in the window and in the rulers indicates where the new ruler origin will be placed.

				[image: tip.eps]	You can restore the original ruler origin by double-clicking the ruler  intersection.

				Thinking about Object Arrangement

				Just like the stacks of paper on your desk, new objects in Illustrator are placed on top of existing objects. Change their order by choosing the Object⇒Arrange menu options.

				The easiest choices are to bring an object to the front or send it to the back. The results of sending forward or backward can be unnerving if you don’t know the exact order in which objects were created. The illustration in Figure 7-4 shows that we rearranged objects by using four available choices. Figure 7-5 shows the result of each choice.

					

				
					Figure 7-4: Objects in their original positions.

				

					[image: 9781118168608-fg030704.eps]

				To change the stacking order, select the object (or objects) whose placement you want to change and then choose one of these commands:

				[image: check.png] Object⇒Arrange⇒Bring to Front: Moves the selected object to the top of the painting order. In Figure 7-5a, the square is brought in front by using the Bring to Front command.

				[image: check.png] Object⇒Arrange⇒Bring Forward: Moves a selected object in front of the object created just before it or one level closer to the front. In Figure 7-5b, the circle is moved in front of the square by using the Bring Forward command.

				[image: check.png] Object⇒Arrange⇒Send Backward: Moves a selected object so that it falls under the object created just before it or one level back. In Figure 7-5c, the triangle is sent backward so that it’s just under the circle.

				[image: check.png] Object⇒Arrange⇒Send to Back: Moves a selected object to the bottom of the painting order. In Figure 7-5d, the triangle is placed on the bottom by using the Send to Back command.

					

				
					Figure 7-5: Rearranging objects.

				

					[image: 9781118168608-fg030705.eps]

				Hiding Objects

				Seasoned Illustrator users love the Hide command. Use it when the object you want to select is stuck behind something else or when you need to select one object and another repeatedly activates instead.

				A good opportunity to use the Hide command is when you’re creating text inside a shape. In Chapter 6 of this minibook, we show you that as soon as you turn a shape into a text area, the fill and stroke attributes turn into None. Follow these steps to hide a shape:

					1.	Create a shape.

						For this example, we created an ellipse.

					2.	Click the Fill color box at the bottom of the Illustrator Tools panel and then choose Window⇒Swatches.

						The Swatches panel appears.

					3.	In the Swatches panel, choose a color for the fill.

						In this example, yellow is selected. The stroke doesn’t matter; this one is set to None.

						Clicking a shape with the Type tool converts the shape to a text area and converts the fill and stroke to None. To have a colored shape remain, you must hide a copy.

					4.	After selecting a colored shape, choose Edit⇒Copy; alternatively, you can press Ctrl+C (Windows) or [image: maccmd]+C (Mac).

						This step makes a copy of your shape.

					5.	Choose Edit⇒Paste in Back or press Ctrl+B (Windows) or [image: maccmd]+B (Mac).

						This step puts a copy of your shape exactly in back of the original.

					6.	Choose Object⇒Hide or press Ctrl+3 (Windows) or [image: maccmd]+3 (Mac).

						The copy of the shape is now hidden; what you see is your original shape.

					7.	Switch to the Type tool by selecting it in the Tools panel or pressing T.

					8.	Use the cursor to cross over the edge of the shape and change it to the Area Type tool.

						You use the Area Type tool to type text in a shape.

					9.	When you see the type insertion cursor swell up, as shown in Figure 7-6, click the edge of the shape.

					

				
					Figure 7-6: The type insertion cursor on the edge of a shape.

				

					[image: 9781118168608-fg030706.tif]

						The insertion point is now blinking inside the shape, and the fill and stroke attributes of the shape have been changed to None.

					10.	Type some text, as shown in Figure 7-7.

					

				
					Figure 7-7:  Type directly in the shape.

				

					[image: 9781118168608-fg030707.tif]

					11.	When you finish entering text, choose Object⇒Show All or press Ctrl+Alt+3 (Windows) or [image: maccmd]+Option+3 (Mac).

						The colored shape reappears with the text in the middle of it, as shown in Figure 7-8.

					

				
					Figure 7-8: The hidden shape reappears behind the text.

				

					[image: 9781118168608-fg030708.tif]

				Use the Hide command anytime you want to tuck away objects for later use. We promise: Nothing hidden in Illustrator will be lost. Just use the Show All command and any hidden objects are revealed, exactly where you left them. (Too bad the Show All command can’t reveal where you left your car keys!)

				Locking Objects

				Being able to lock items is handy when you’re building an illustration. The Lock command not only locks down objects you don’t want to change, but also drives anyone crazy who tries to edit your files. In fact, we mention locking mainly to help preserve your sanity. Sometimes you need to make simple adjustments to another designer’s artwork and can’t, unless the objects are first unlocked. Follow these instructions:

				[image: check.png] To lock an object: Choose Object⇒Lock or press Ctrl+2 (Windows) or [image: maccmd]+2 (Mac) to lock an object so that you can’t select it, move it, or change its attributes.

				[image: check.png] To unlock an object: Choose Object⇒Unlock All or press Ctrl+Alt+2 (Windows) or [image: maccmd]+Option+2 (Mac). Then you can make changes to it.

				You can also lock and hide objects with layers. See Chapter 8 in this minibook for more information about using layers.

				Creating a Clipping Mask

				Creating a clipping mask may sound complex, but it’s easy and highlights some topics in this chapter, such as arranging objects. Similar to peering through a hole in a piece of paper to the objects underneath it, a clipping mask allows a topmost object to define the selected shapes underneath it; with a clipping mask, however, the area around the defining shape is transparent, as shown in Figure 7-9.

					

				
					Figure 7-9: Some items using the clipping mask feature.

				

					[image: 9781118168608-fg030709.eps]

				You may recall what a film mask looks like — it’s black to block out the picture and clear where you want to view an image, as shown in Figure 7-10.

					

				
					Figure 7-10:  A conventional film mask.

				

					[image: 9781118168608-fg030710.eps]

				The clipping mask feature uses the same principle as the conventional film mask. It hides the area outside the mask area. To create a clipping mask, follow these steps:

					1.	Choose File⇒Place to place an image.

						Masks work with objects created in Illustrator and with objects placed (scanned or otherwise imported) there. 

					2.	Create the item you want to use as a mask by using the Pen tool to create a shape or a closed path.

						For example, in Figure 7-11, the circle is the mask. (The photo underneath it is the placed image from Step 1.) The circle is placed where  the mask will be created. The shape’s color, fill, and stroke values  don’t matter because they automatically change to None when you create a mask.

						Note: When creating a clipping mask, make sure that the object to be used as a mask is a closed shape and is at the top of the stacking order.

					

				
					Figure 7-11: Position the mask shape over the object.

				

					[image: 9781118168608-fg030711.tif]

					3.	Use the Selection tool to select the placed image and the shape.

						Shift-click to add an object to the selection.

					4.	Choose Object⇒Clipping Mask⇒Make.

						Alternatively, you can use the keyboard shortcut Ctrl+7 (Windows) or [image: maccmd]+7 (Mac) to create the clipping mask.

						Ta-da! You created the clipping mask. Masked items are grouped,  but you can use the Direct Selection tool to move the image or mask individually.

					5.	To turn off the clipping mask, choose Object⇒Clipping Mask⇒Release.

				[image: tip.eps]	You can also use text as a clipping mask: Type a word and ensure that it’s positioned over an image or another Illustrator object (or objects). Then select both the text and the object and choose Object⇒Clipping Mask⇒Make.

				Creating a Clipping Path Using  the New Draw Inside Button

					[image: 9781118168608-ma177.tif]	You can use the Draw Inside button to create a clipping path. The button is at the bottom of the Tools panel. Just follow these steps:

					1.	Select your artwork and choose Edit⇒Copy or Cut.

						In Figure 7-12, the artwork to the right has been cut to fit into the  star image.

					

				
					Figure 7-12:  Select artwork and copy or paste it.

				

					[image: 9781118168608-fg030712.tif]

					2.	Select the artwork that you want to “paste into” existing artwork and then click the Draw Inside button.

					3.	Choose Edit⇒Paste.

						The artwork is pasted inside the shape, as shown in Figure 7-13.

				[image: tip.eps]		After you have pasted your artwork, you can use the Direct Selection tool to reposition it.

					

				
					Figure 7-13: Create a clipping path by using the Draw Inside button at the bottom of the Tools panel.

				

					[image: 9781118168608-fg030713.tif]

				

				

				

			

		

	
		
			
				Chapter 8: Using Layers

				In This Chapter

				[image: check.png] Working with layers

				[image: check.png] Using layers for a selection

				[image: check.png] Changing the stacking order of a layer

				[image: check.png] Moving and cloning objects to another layer

				[image: check.png] Hiding and locking layers

				This chapter shows you just how simple it is to use layers and how helpful layers can be when you’re producing complex artwork. Layers are similar to clear pages stacked on top of your artwork: You can place content (text, shapes, and other objects) on a layer, lift up a layer, remove a layer, hide and show layers, or lock a layer so that you can’t edit its content. The incredible Layer feature can help you:

				[image: check.png] Organize the painting (stacking) order of objects.

				[image: check.png] Activate objects that would otherwise be difficult to select by using either the Selection or Direct Selection tool.

				[image: check.png] Lock items that you don’t want to reposition or change.

				[image: check.png] Hide items until you need them.

				[image: check.png] Repurpose objects for artwork variations. For example, a company’s business cards use the same logo and company address, but the name and contact information change for each person. In this case, placing the logo and company address on one layer and the person’s name and contact information on another layer lets you easily create a new business card by just changing the person’s name and contact details.

				Creating New Layers

				When you create a new Illustrator document, you automatically start with a single layer. To understand how layers work, you create a new file and follow some steps to create new layers and place objects on them:

					1.	Choose File⇒New and select Print from the Profile drop-down list,  click OK.

					2.	If the Layers panel isn’t already visible (see Figure 8-1), choose Window⇒Layers.

					

				
					Figure 8-1: The Layers panel.

				

					[image: 9781118168608-fg030801.tif]

					3.	Using the Rectangle tool, click and drag anywhere on the artboard to create a rectangle.

						The size doesn’t matter.

					4.	Click the Fill button in the Control panel and select any color for the shape from the Color Picker that appears, as shown in Figure 8-2.

						The Fill button is the swatch with an arrow on the left side of the Control panel.

						This fill color makes the rectangle easier to identify later.

					

				
					Figure 8-2: Select any color from the Fill Color Picker.

				

					[image: 9781118168608-fg030802.tif]

						The blue handle color that appears on the active shape matches the blue color bar you see in the Layers panel on the left side of the layer name and the small selection square to the right of the radio button. The small selection square on the right disappears if you choose Select⇒Deselect. You use that square to see which layer a selected object is on.

						Notice in Figure 8-3 that you’ve added a shape to this layer, so an arrow appears to the left of the layer name. This arrow indicates that you now have a sublayer, which is essentially a layer within a layer. Click the arrow to expand the layer and show any sublayers nested underneath it; sublayers are automatically created when you add objects, which helps when you’re making difficult selections.

					

				
					Figure 8-3: Adding objects to a layer automatically creates sublayers.

				

					[image: 9781118168608-fg030803.eps]

					5.	Alt-click (Windows) or Option-click (Mac) the Create New Layer button at the bottom of the Layers panel to create a new layer.

						The Layer Options dialog box appears (see Figure 8-4), and you can use it to name a layer and change the selection color. You don’t have to hold down the Alt or Option key when making a new layer, but if you don’t, you don’t have the opportunity to name the layer as you create it.

					

				
					Figure 8-4: Creating a new layer.

				

					[image: 9781118168608-fg030804.tif]

					6.	Enter a name for the new layer in the Name text box and click OK.

						In Figure 8-4, we entered circle because it’s the shape we add in Step 6.

						If you want to stay organized, you can name the original layer square by double-clicking Layer 1. Just make sure that you click the circle layer again to make it the active layer.

						A new layer is added to the top of the stack in the Layers panel.

					7.	Make a shape on the new layer and overlap the shape you created in Step 2. (See Figure 8-5.)

						In this example, we created a circle, as shown in Figure 8-5.

					

				
					Figure 8-5: A circle on the new layer overlaps the square on its underlying layer.

				

					[image: 9781118168608-fg030805.tif]

					8.	Change the fill color for your new shape.

						Look at the selection handles on the circle that you just created: They change to a different color, indicating that you’re on a different layer. The different handle colors are for organizational purposes only and aren’t printed.

					9.	Just to be different this time, choose New Layer from the panel menu.

						The Layer Options dialog box appears.

					10.	(Optional) In the Layer Options dialog box, change the color of  the selection handles by selecting an option from the Color drop- down list.

						You can also hide or lock the contents of the layer.

					11.	Enter a name for this new layer in the Name text field, click OK, and then create a shape on it.

						For the example shown in Figure 8-6, we entered star into the Name text box and used the Star tool to create a star on the new layer.

					

				
					Figure 8-6: Create a new layer by using the panel menu.

				

					[image: 9781118168608-fg030806.tif]

					12.	Again, change the fill color of your newest shape so that it’s different from the other shapes.

					13.	Use the Selection tool to move the new shape so that it overlaps the others slightly.

				[image: tip.eps]	You can open the Options dialog box for any existing layer by choosing Options for Layer (Named Layer) from the panel menu in the Layers panel, or by double-clicking on a layer in the Layers panel.

				You’ve created new layers and now have a file that you can use to practice working with layers.

				Using Layers for Selections

				When you have a selected object on a layer, a color selection square appears to the right of the named layer. If you select the radio button directly to the right of the layer’s name in the Layers panel, as shown in Figure 8-7, all objects are selected on that layer.

					

				
					Figure 8-7: Selecting the entire contents of a layer.

				

					[image: 9781118168608-fg030807.tif]

				Sublayers have their own radio buttons. If sublayers are visible, you can use the same technique to select objects that may be buried behind others.

				[image: tip.eps]	If you think you’ll be selecting sublayers frequently, double-click the default name and type a more descriptive name for that layer.

				Changing the Layer Stacking Order

				In Chapter 7 of this minibook, we tell you about the Object⇒Arrange feature in Illustrator; with layers, this process becomes slightly more complicated. Each layer has its own painting order, the order in which you see the layers. To move a layer (and thereby change the stacking order of the layers), click and drag that layer until you see the black insertion line where you want the layer to be moved.

				As you add shapes to a layer, a sublayer is created, and it has its own little stacking order that’s separate from other layers. In other words, if you choose to send an object to the back and it’s on the top layer, it goes only to the back of that layer and is still in front of any objects on layers beneath it.

				[image: remember.eps]	Understanding how the stacking order affects the illustration is probably the most confusing part about layers. Just remember that in order for an object to appear behind everything else, it has to be on the bottom layer (and at the bottom of all objects on that bottom layer); for an object to appear in front of everything else, it has to be on the topmost layer.

				Moving and Cloning Objects

				To move a selected object from one layer to another, click the small color-selection square (shown in Figure 8-8) to the right of the layer’s radio button in the Layers panel, drag the object to the target layer, and release. That’s all there is to moving an object from one layer to another.

					

				
					Figure 8-8:  Drag the small square icon to move the selected object to another layer.

				

					[image: 9781118168608-fg030808.tif]

				You can also clone an item, or make a copy of it while you move the copy to another layer. Clone an object by Alt+dragging (Windows) or Option+dragging (Mac) the color selection square to another layer. A plus sign appears while you drag (so you know that you’re making a clone of the object). Release when you reach the cloned object’s target layer.

				[image: tip.eps]	Choose Paste Remembers Layers from the Layers panel to have Illustrator automatically remember which layer you copied an object from. No matter which layer is active, Illustrator always pastes the object back on the original layer it was copied from.

				Hiding Layers

				To the left of each layer in the Layers panel is an eye icon — a visibility toggle button. Simply clicking the eye icon hides the layer (the eye disappears, denoting that this layer is hidden). Click the empty square (where the eye icon was) to show the layer again.

				Alt-click (Windows) or Option-click (Mac) an eye icon to hide all layers except the one you click; Alt-click (Windows) or Option-click (Mac) the eye icon to show all layers again.

				Ctrl-click (Windows) or [image: maccmd]-click (Mac) the eye icon to turn just the selected layer into Outline view. In Outline view, all you see are the outlines of the  artwork with no stroke widths or fill colors. The rest of your artwork remains in Preview mode, with strokes and fills visible. This tricky technique is helpful when you’re looking for stray points or need to close paths. Ctrl-click (Windows) or [image: maccmd]-click (Mac) the eye icon again to return the layer to Preview mode.

				Locking Layers

				Lock layers by clicking the empty square to the right of the Visibility (eye) icon. A padlock icon appears so that you know the layer is now locked. Locking a layer prevents you from making changes to the objects on that layer. Click the padlock to unlock the layer.

				

			

			
		

	
		
			
				Chapter 9: Livening Up Illustrations with Color

				In This Chapter

				[image: check.png] Choosing a color mode

				[image: check.png] Using the Swatches and Color panels

				[image: check.png] Working with strokes and fills

				[image: check.png] Changing the stroke width and type

				[image: check.png] Saving and editing colors

				[image: check.png] Discovering patterns

				[image: check.png] Taking advantage of gradients and meshes

				[image: check.png] Copying color attributes

				[image: check.png] Using the Live Paint feature

				This chapter is all about making your illustrations come alive with color. We show you how to create new colors, patterns, and gradients as well as how to edit existing colors and save custom colors. We also explain how to apply and edit color attributes to many objects at the same time.

				Choosing a Document Profile

				Every time you create a new file you choose a document profile, as you see in Figure 9-1. This profile determines the default settings from which you create your document. Some of the settings established here are the artboard size, units of measure, color mode, resolution, and more.

				Illustrator 6 offers several profiles, and they fall into two basic categories: onscreen and print.

				The following New Document profiles are used for onscreen display:

				[image: check.png] Print:This profile provides preset options for size and resoluton defaults that are optimized for rint graphics. The colors in the Swatches panel are in CMYK, as well as gradients and patterns. 

				[image: check.png] Web: This profile provides preset options, such as size and resolution, that are optimized for output to the web.

					

				
					Figure 9-1:  Use the New Document profiles to start with the right colors, resolution, measure-ment units, artboard size, and more.

				

					[image: 9781118168608-fg030901.tif]

				[image: check.png] Devices: This profile ensures a small file size and uses a resolution that is preset for a specific mobile device. You can choose your device from the Size menu.

				[image: check.png] Video and Film: This profile provides several preset video- and film-specific crop area sizes. Illustrator also creates only square pixel files so that the sizes are interpreted correctly in video applications.

				[image: check.png] Flash Builder: This profile creates an FXG document in RGB mode with an 800 x 600 px artboard by default. Align New Objects to Pixel Grid is enabled for new art in the document and the Raster Effects Resolution is set to 72 ppi. It also has Swatches, Symbols, Graphic Styles, and Brushes designed for Flash Catalyst and Flash Professional workflows.

				[image: tip.eps]		Align New Objects to Pixel Grid, found under the Advanced section in the New Document window, is an option that you can turn on when creating a new document in Adobe Illustrator. This option nudges pixels to start aligned on a pixel grid so as to produce crisp straight lines. This feature is great for online graphics.

				The following profiles are used for print display:

				[image: check.png] Print: By default this profile uses a letter-size artboard, but it provides a variety of other preset print sizes to choose from. A document created with this profile is also set to a default resolution of 300 dpi. Use this profile if you plan to send your file to a commercial printer.

				[image: check.png] Basic CMYK Document: Like the Print profile, this uses a letter-size artboard by default but provides a variety of other sizes to choose from. Use this profile if you plan to send a document to multiple types of media. 

				[image: tip.eps]		You can change the color mode at any time without losing information by choosing File⇒Document Color Mode.

				Using the Swatches Panel

				Accessing color from the Control panel is probably the easiest way to make color choices: You can use the Fill and Stroke drop-down lists to quickly access the Swatches panel, shown in Figure 9-2, and at the same time ensure that the color is applied to either the fill or stroke. How many times have you mixed up colors and assigned the stroke color to the fill or vice versa?

					

				
					Figure 9-2: Use these buttons to quickly access color options.

				

					[image: 9781118168608-fg030902.eps]

				You can also access the Swatches panel, which you open by choosing Window⇒Swatches. Although limited in choice, its basic colors, patterns, and gradients are ready to go. You can use the buttons at the bottom of the Swatches panel (see Figure 9-2) to quickly open color libraries, select kinds of colors to view, access swatch options, create color groups, add new swatches, and delete selected swatches.

				You may notice some odd color swatches — for example, the cross hair and the diagonal line.

					[image: 9781118168608-ma255.tif]	The cross hair represents the Registration color. Use this swatch only when creating custom crop marks or printer marks. The Registration color looks black, but it’s created from 100 percent of all colors. This way, when artwork is separated, the crop mark appears on all color separations.

					[image: 9781118168608-ma256.tif]	The diagonal line represents None. Use this option if you want no fill  or stroke.

				Applying Color to the Fill and Stroke

				Illustrator objects are created from fills (the inside) and strokes (border or path). Look at the bottom of the Tools panel for the Fill and Stroke color boxes. If you’re applying color to the fill, the Fill color box must be forward in the Tools panel. If you’re applying color to the stroke, the Stroke color box must be forward.

				Table 9-1 lists keyboard shortcuts that can be a tremendous help to you when applying colors to fills and strokes.

				Table 9-1	Color Keyboard Shortcuts

				
					
						
								
								Function

							
								
								Keyboard Shortcut

							
						

						
								
								Switch the Fill or Stroke color box position

							
								
								X

							
						

						
								
								Inverse the Fill and the Stroke color boxes

							
								
								Shift+X

							
						

						
								
								Default (black stroke, white fill)

							
								
								D

							
						

						
								
								None

							
								
								/

							
						

						
								
								Last color used

							
								
								<

							
						

						
								
								Last gradient used

							
								
								>

							
						

						
								
								Color Picker

							
								
								Double-click the Fill or Stroke color box

							
						

					
				

				[image: tip.eps]	Try this trick: Drag a color from the Swatches panel to the Fill or Stroke color box. This action applies the color to the color box that you dragged to. It doesn’t matter which is forward!

				To apply a fill color to an existing shape, drag the swatch directly to the  shape. Select a swatch, hold down Alt+Shift+Ctrl (Windows) or Option+ Shift+[image: maccmd] (Mac), and drag a color to a shape to apply that color to the stroke.

				Changing the Width and Type of a Stroke

				Access the Stroke panel by clicking the Stroke hyperlink in the Control panel. In the Stroke panel, shown in Figure 9-3, you can choose to change the Width height by clicking and selecting a preset width from the Width drop-down menu, or you can type in a value. You can also customize the caps (the end of a line), joins (the end points of a path or dash), and the miter limit (the length of a point). The Stroke panel also enables you to turn a path into a dashed line.

				In the Stroke panel options, you can choose to align the stroke on the center (default) of a path, the inside of a path, and the outside of a path. Figure 9-4 shows the results.

					

				
					Figure 9-3: The Stroke panel options.

				

					[image: 9781118168608-fg030903.tif]

					

				
					Figure 9-4: The Align Stroke options affect the placement of the stroke.

				

					[image: 9781118168608-fg030904.eps]

				This feature is especially helpful when stroking outlined text. Refer to  Figure 9-4 to compare text with the traditional centered stroke, as compared with the option for aligning the stroke outside of a path.

				[image: technicalstuff.eps]	You can’t adjust the alignment of a stroke on text unless you change the text to outlines first. Select the text with the Selection tool and choose Type⇒Create Outlines to enable the Align Stroke options.

				You can also customize the following aspects of a stroke from the Stroke panel by clicking the buttons we describe:

				[image: check.png] Cap Options: The endpoints of a path or dash

					•	Butt Cap: Makes the ends of stroked lines square

					•	Round Cap: Makes the ends of stroked lines semicircular

					•	Projecting Cap: Makes the ends of stroked lines square and extends half the line width beyond the end of the line

				[image: check.png] Join Options: How corner points appear

					•	Miter Join: Makes stroked lines with pointed corners

					•	Round Join: Makes stroked lines with rounded corners

					•	Bevel Join: Makes stroked lines with squared corners

				[image: check.png] Dashed Lines: Regularly spaced lines, based on values you set

				[image: tip.eps]		To create a dashed line, specify a dash sequence by entering the lengths of dashes and the gaps between them in the Dash Pattern text fields. (See Figure 9-5.) The numbers entered are repeated in sequence so that after you set up the pattern, you don’t need to fill in all the text fields. In other words, if you want an evenly spaced dashed stroke, just type the same number in the first and second text fields and all dashes and spaces will be the same length (say, 12 points). Change that number to 12 in the first text field and 24 in the next to create a larger space between dashes.

				[image: tip.eps]		Click the Aligns Dashes button to create improved corners for your dashed object,

				[image: check.png] Arrowhead: Arrowheads have been surprisingly difficult for new users to locate and use in previous versions of Illustrator. In CS6, you can just open the Stroke dialog box, shown in Figure 9-6, and use simple drop-down lists to set start and end times to your arrowhead as well as the scale.

					

				
					Figure 9-5: Setting up a dashed stroke.

				

					[image: 9781118168608-fg030905.tif]

					

				
					Figure 9-6:  Use the Stroke dialog box to create arrow­heads.

					
				

					[image: 9781118168608-fg030906.tif]

				Using the Color Panel

				The Color panel (choose Window⇒Color) offers another method for choosing color. You must custom-pick a color using values on the color ramp. You see as a default only the color ramp — the large color well spanning the panel. If you don’t see all color options, choose Show Options from the Color panel’s panel menu. (Click the triangle in the upper-right corner to access the panel menu.)

				[image: tip.eps]	If you ever want to create tints of a CMYK color but aren’t quite sure how to adjust individual color sliders, just hold down the Shift key while adjusting the color slider of any color. Then watch as all colors move to a relative position at the same time!

				As shown in Figure 9-7, the panel menu offers many other choices. Even though you may be in RGB or CMYK color mode, you can still choose to build colors in Grayscale, RGB, HSB (Hue, Saturation, Brightness), CMYK, or Web Safe RGB. Choosing Invert or Complement from the panel menu reverses the color of the selected object or changes it to a complementary color, respectively. You can also choose the Fill and Stroke color boxes in the upper-left corner of the Color panel.

					

				
					Figure 9-7: Different color models are available in the Color panel.

				

					[image: 9781118168608-fg030907.tif]

				You see the infamous cube-and-exclamation-point in the Color panels in most Adobe software. The cube warns you that the color you’ve selected isn’t one of the 216 nondithering, web-safe colors, and the exclamation point warns you that your color isn’t within the CMYK print gamut. In other words, if you see the exclamation point in the Color panel, don’t expect the cool electric blue you see onscreen to print correctly — it may print as  dark purple!

				[image: tip.eps]	Click the cube or exclamation point symbols when you see them to select the closet color in the web-safe or CMYK color gamut.

				Saving Colors

				Saving your colors not only keeps you consistent, but also makes future edits easier. Any time you build a color, drag it from the Color panel (or the Tools panel) to the Swatches panel to save it as a color swatch for future use. You can also select an object that uses the color and click the New Swatch button at the bottom of the Swatches panel. (Refer to Figure 9-2 to see this button.) To save a color and name it at the same time, Alt-click (Windows) or Option-click (Mac) the New Swatch icon. The New Swatch dialog box opens, allowing you to name and edit the color, if you want. By double-clicking a swatch in the Swatches panel, you can access the options at any time.

				A color in the Swatches panel is available only in the document in which it was created. Read the next section on custom libraries to see how to import swatches from saved documents.

				Building and using custom libraries

				When you save a color in the Swatches panel, you’re essentially saving it to your own custom library. You import the Swatches panel from one document into another by using the Libraries feature.

				Retrieve colors saved in a document’s Swatches panel by clicking the Swatch Libraries menu button at the bottom of the Swatches panel and selecting Other Library. You can also access swatch libraries, including those in other documents, by choosing Window⇒Swatch Libraries⇒Other Library. Locate the saved document and click Open. A panel appears with the document name, as shown in Figure 9-8. You can’t edit the colors in this panel, but you can use the colors in this panel by double-clicking a swatch (which adds it to the Swatch panel) or dragging it to the current document’s Swatches panel where it can be edited.

				[image: tip.eps]	You can also click the Swatch Libraries button to access color libraries for Pantone colors, web colors, and some neat creative colors, such as jewel tones and metals.

					

				
					Figure 9-8: An imported custom swatch library.

				

					[image: 9781118168608-fg030908.eps]

				Using the Color Guide and color groups

				Perhaps you failed at color selection in art class or just don’t feel that you pick colors that work well together. Fortunately, you can use the Color Guide to find colors and save them to organized color groups in your Swatches panel. You can create color schemes based on 23 classic color-harmony rules, such as the Complementary, Analogous, Monochromatic, and Triad options, or you can create custom harmony rules.

				Sounds complicated, doesn’t it? Fortunately, all you have to do is choose a base color and then see which variations you come up with according to rules you choose. Give it a try:

					1.	Choose Window⇒Color Guide. Click on the tab and drag the Color Guide panel away from the docking area so that it does not go away when you select another panel.

						The Color Guide appears, as shown in Figure 9-9.

					

				
					Figure 9-9: The Color Guide panel identifies related colors.

				

					[image: 9781118168608-fg030909.eps]

					2.	Select a color from the Swatches panel. If it isn’t visible, choose Window⇒Swatches.

						Immediately, the Color Guide panel kicks in to provide you with colors related to your original swatch.

					3.	Change the harmony rules by clicking the Edit or Apply Colors button at the bottom of the Color Guide panel.

						The Recolor Artwork dialog box, shown in Figure 9-10, appears.

						You can spend days experimenting in the Recolor Artwork dialog box; for the scope of this book, however, you dive into changing simple  harmony rules. 

					4.	To change the Harmony Rules, click the Harmony Rules arrow to the right of the color bar.

						A drop-down list appears with many choices for selecting colors, as shown in Figure 9-11. 

					5.	Select a color harmony to see your artwork recolored.

					

				
					Figure 9-10: Choose and save color groups in the Recolor Artwork dialog box.

				

					[image: 9781118168608-fg030910.eps]

					

				
					Figure 9-11: Make a selection from the Harmony Rule drop-down list.

				

					[image: 9781118168608-fg030911.tif]

					6.	Save your color selection as a color group by clicking the New Color Group icon, located at the top-right of the dialog box.

						If you like, you can rename the color group by double-clicking the group name in the Color Group text field in the Recolor Artwork dialog box.

					7.	Click OK.

						The color group is added to the Swatches panel.

				[image: tip.eps]	You don’t have to use the Recolor Artwork dialog box to save a group of colors. You can Ctrl-click (Windows) or [image: maccmd]-click (Mac) to select multiple colors and then click the New Color Group button at the bottom of the Swatches panel.

				Adding Pantone colors

				If you’re looking for the typical swatches numbered in the Pantone Matching System (PMS), click the Swatch Libraries menu button at the bottom of the Swatches panel. From the drop-down list, select Color Books and then Pantone Solid Coated or whatever Pantone library you want to access.

				Colors in the Pantone numbering system are often referred to as PMS 485 or PMS 201 or whatever number the color has been designated. You can locate the numbered swatch by typing the number into the Find text field of the Pantone panel, as shown in Figure 9-12. When that number’s corresponding color is highlighted in the panel, click it to add it to your Swatches panel. Many users find it easier to see colored swatches by using List view. Choose Small List View or Large List View from the panel menu.

					

				
					Figure 9-12: Use the Find text box to locate Pantone colors.

				

					[image: 9781118168608-fg030912.tif]

				Editing Colors

				Edit colors in the Swatches panel by using the Swatch Options dialog box (shown in Figure 9-13), which you access by double-clicking the color or choosing Swatch Options from the Swatches panel menu.

				Use the Swatch Options dialog box to:

				[image: check.png] Change color values: Change the values in a color by using the sliders or typing values in the color text fields. Being able to enter exact color values is especially helpful if you’re given a color build to match. Select the Preview check box to see results as you make the changes.

				[image: check.png] Use global colors: If you plan to use a color frequently, select the Global check box. If it’s selected and you use the swatch throughout the artwork, you have to change the swatch options only one time and then all instances of that color are updated.

					

				
					Figure 9-13: Edit a color swatch in the Swatch Options dialog box.

				

					[image: 9781118168608-fg030913.eps]

				One important option to note in the Swatch Options dialog box is the Color Type drop-down list. You have two choices: spot color and process color. What’s the difference?

				[image: check.png] Spot color: A color that isn’t broken down into the CMYK values. Spot colors are used for 1 or 2 color print runs or when precise color matching is important.

						Suppose that you’re printing 20,000 catalogs and decide to run only 2 colors: red and black. If you pick spot colors, the catalogs have to be run through the press only two times: once for black and once for red. If red were a process color, however, it would be created from a combination of cyan, magenta, yellow, and black inks, and the catalogs would need to be run through the press four times in order to build that color. Plus, if you went to a print service and asked for red, what color would you get — fire engine red, maroon, or a light and delicate pinkish red? But if the red you pick is PMS 485, your printer in Kutztown, Pennsylvania, can then print the same color of red on your brochure as the printer making your business cards in Woburn, Massachusetts.

				[image: check.png] Process color: A color that’s built from four colors (cyan, magenta, yellow, and black); used for multicolor jobs.

						For example, you would use process colors to send an ad to a 4-color magazine. Its printers certainly want to use the same inks they’re already running, and using a spot color would require another run through the presses in addition to the runs for the cyan, magenta, yellow, and black plates. In this case, you convert to process colors any spot colors created in corporate logos or similar projects.

				Choose the Spot Colors option from the Swatches panel menu to choose whether you want spot colors changed to Lab or CMYK values:

				[image: check.png] Choose Lab to produce the best possible CMYK conversion for the actual spot color when using a color-calibrated workflow.

				[image: check.png] Choose CMYK (the default) to see the manufacturer’s standard recommended conversion of spot colors to process. Results can vary depending on printing conditions.

				Building and Editing Patterns

				Using patterns can be as simple or as complicated as you want. If you become familiar with the basic concepts, you can take off in all sorts of creative directions. To build a simple pattern, start by creating the artwork you want to use as a pattern on your artboard — polka dots, smiley faces, wavy lines or whatever. Then select all components of the pattern and drag them to the Swatches panel. That’s it — you made a pattern! Use the pattern by selecting it as the fill or stroke of an object.

				[image: remember.eps]	You can’t use patterns in artwork that will then be saved as a pattern. If you have a pattern in your artwork and try to drag it into the Swatches panel, Illustrator kicks it back out with no error message. On a good note, you can drag text directly into the Swatches panel to become a pattern.

				You can update patterns you created or patterns that already reside in the Swatches panel. To edit an existing pattern, follow these steps:

					1.	Click the pattern swatch in the Swatches panel and drag it to the  artboard.

					2.	Deselect the pattern and use the Direct Selection make changes to the pattern.

						Keep making changes until you’re happy with the result.

					3.	To update the pattern with your new edited version, use the Selection tool to select all pattern elements and Alt+drag (Windows) or Option+drag (Mac) the new pattern over the existing pattern swatch in the Swatches panel.

					4.	When a black border appears around the existing pattern, release the mouse button.

						All instances of the pattern in your illustration are updated.

				[image: tip.eps]	To add some space between tiles, as shown in Figure 9-14, create a bounding box by drawing a rectangle shape with no fill or stroke (representing the repeat you want to create). Send the rectangle behind the other objects in the pattern and drag all objects, including the bounding box, to the Swatches panel.

					[image: 9781118168608-ma025.tif]	Transformations are covered in detail in Chapter 10 of this minibook, but some specific transform features apply to patterns. To scale a pattern, but not the object it’s filling, double-click the Scale tool, shown in the margin. In the Scale dialog box that appears, type the value that you want to scale and deselect all options except Transform Patterns, as shown in Figure 9-15. This method works for the Rotate tool as well.

					

				
					Figure 9-14: A pattern with a transparent bounding box.

				

					[image: 9781118168608-fg030914.eps]

					

				
					Figure 9-15: Choose to scale or rotate only the pattern, not the object.

				

					[image: 9781118168608-fg030915.eps]

				Advanced Pattern Editing

				In Illustrator CS6, you have more control over patterns than ever before. The previous section tells you how to start your pattern, but what if you want to create the perfect repeat? Or what if you want to align your repeated tile in a different offset — like stacking bricks — instead of just tiling one pattern right next to the other? With Illustrator CS6, you can!

				These steps show you how to take advantage of the new, powerful Pattern editor. To do so, first create your pattern art by following the steps outlined in the previous section. If you don’t have a pattern available, you can use one of the default patterns or locate a sample pattern file at www. agitraining.com/dummies have your pattern, follow these steps:

					1.	After you add the pattern to the Swatches panel, double-click the swatch. The Pattern Options panel appears, and the artboard switches to Pattern Editor Preview mode, as shown in Figure 9-16.

					2.	Click Save a Copy in the upper-left corner of the screen.

					3.	When the New Pattern dialog box appears, type a name to keep a copy of your original Pattern swatch. Click OK.

						Keep in mind that the Save a Copy feature allows you to keep a copy of your original pattern swatch, but you’ll still be editing your original pattern. (See Figure 9-16.) 

						When you click OK, a dialog box appears, indicating that you’ve just created a copy of your original pattern swatch.

					4.	Press OK again.

					5.	Locate the Pattern Options panel and change the name of your pattern, if you want.

						In this example we changed the pattern name to Fish_Brick, to save a copy before the tile is going to be changed.

					6.	Click open the Tile Type drop-down menu and select Brick by Row, as shown in Figure 9-17. 

						The artboard displays the change in the pattern repeat.

					

				
					Figure 9-16: Pattern options allow you to edit pattern art, change the offset, and more.

				

					[image: 9781118168608-fg030916.eps]

					

				
					Figure 9-17: Change the Tile Type using the Pattern Options panel.

				

					[image: 9781118168608-fg030917.eps]

					7.	If you want, you change the default Brick Offset by opening that drop-down list and selecting another option.

					8.	You can also edit the size of the repeat by manually entering a size in the Width and Height textboxes, as show in Figure 9-18. 

				[image: remember.eps]		Keep in mind that you can return to the original size by selecting the Size Tile to Art check box below at any time.

					

				
					Figure 9-18: Change the size of the repeat tile using the Width and Height textboxes.

				

					[image: 9781118168608-fg030918.tif]

					9.	Change the type of overlap — that is, which item is on top of the stacking order — by using the Overlap section in the Pattern Options panel, as shown in Figure 9-19.

					10.	(Optional) Make further adjustments to the pattern and edit the artwork if needed.

						In the lower section of the Pattern Options panel you can control the visual look of the pattern preview you’re seeing, from the amount of copies that you see, to how dimmed the non-original pattern tiles appear.

						You can edit your artwork using the drawing and editing tools, just like you would if you weren’t in the Pattern Editor Preview mode. You can see that a pen path is being created in Figure 9-20, and the change is reflected in all the pattern tiles instantaneously.

					11.	When you’re finished making changes to your pattern, click Done, located to the right of Save a Copy at the top of the editing window.

					

				
					Figure 9-19: Use the Overlap controls to change which part of the pattern is on the top of the stacking order.

				

					[image: 9781118168608-fg030919.eps]

					

				
					Figure 9-20: Add and edit artwork right in the pattern editing preview mode.

				

					[image: 9781118168608-fg030920.tif]

				

				Working with Gradients

				Create gradients for smooth metallic effects or just to add dimension to illustrations. If you’re not sure which swatches are considered gradients, choose Gradient from the Show Swatch Kinds button at the bottom of the Swatches panel. (Refer to Figure 9-2.)

				After the Gradient (shown in Figure 9-21) is applied, you can access the Gradient panel for further options by choosing Window⇒Gradient. If the Gradient options aren’t visible, choose Show Options from the Gradient panel menu to see more options.

					

				
					Figure 9-21:  The Gradient panel.

				

					[image: 9781118168608-fg030921.eps]

				On the Gradient panel, use the Type drop-down list to select a Radial gradient (one that radiates from the center point) or a Linear gradient (one that follows a linear path).

				Use the Gradient tool to change the direction and distance of a gradient blend:

					1.	Select an object and apply any existing gradient from the Swatches panel to its fill.

					2.	Choose the Gradient tool (press G) and drag in the direction you want the gradient to go.

						Drag a long path for a smooth, long gradient. Drag a short path for a short, more defined gradient.

				[image: tip.eps]	Before following the next steps, it would be a good idea to undock your Color panel. Click the Color tab on the Color panel and drag it out to the artboard, essentially separating it from the rest of the panel group.

				To create a new gradient, follow these steps:

					1.	Click the Linear Gradient swatch in the Swatches panel, as shown in Figure 9-22, to reach a good base point.

					2.	Notice the Gradient Slider that appears at the bottom of the Gradient panel. On the left and right side of the slider, you see color stops. Click the left color stop on the Gradient Slider to see that this white color stop is set to 100% opacity, as shown in Figure 9-23.

					

				
					Figure 9-22:  Select the Linear Gradient swatch from the Swatches panel.

				

					[image: 9781118168608-fg030922.eps]

					

				
					Figure 9-23: Click the color stop to activate it.

				

					[image: 9781118168608-fg030923.eps]

					3.	Click the right black color stop to see that it is also set to 100% opacity. 

						When a color stop is active, the triangle on top turns solid.

					4.	If necessary, choose Window⇒Color to access the Color panel. If the ramp on the Color panel is displaying a black-to-white ramp, click the triangle in the upper-right corner to open the panel menu and choose RGB or CMYK colors. 

						This step provides you with additional colors.

					5.	Click the color ramp (across the bottom) in the Color panel to pick a random color (or enter values in the text fields to select a specific color) for the active color stop in the Gradient panel.

					6.	In the Gradient panel, click the right color stop and change the Opacity to 50%, as shown in Figure 9-24.

					7.	With the right color stop still selected, click another color in the color ramp in the Colors panel.

					

				
					Figure 9-24: Change the opacity of the right color stop to 50%.

				

					[image: 9781118168608-fg030924.eps]

				To add color stops, click beneath the gradient ramp and then choose a color from the Color panel. You can also drag a swatch from the Swatches panel to add a new color to the gradient. To remove a color stop, drag it off the Gradient panel.

				[image: tip.eps]	You can click the gradient ramp to add colors and also to change the opacity of that location of the ramp by entering values in the Opacity text box. This technique is a helpful way to create stripes and other reflective gradients.

				Using the Gradient tool

					[image: 9781118168608-ma031.tif]	Take advantage of the Gradient tool to adjust the length and direction of the gradient that you apply to objects. To use the Gradient tool, simply select the object that has the gradient applied to it and then click and drag. A color ramp appears, indicating the length and direction of your gradient, as shown in Figure 9-25.

					

				
					Figure 9-25: Use the Gradient tool to change the direction and length of your gradient.

				

					[image: 9781118168608-fg030925.tif]

				You can also use the Gradient tool to apply and change colors on the color ramp. To use the Gradient tool, follow these steps:

					1.	Apply a gradient to an object.

					2.	Select the Gradient tool (or press G) and click and drag to define the length and direction of the gradient.

						Drag a long path for a smooth, long gradient. Drag a short path for a short, more defined gradient.

					3.	Hover over the gradient ramp (on top of the object) as shown in Figure 9-26. 

						The color ramp appears with the color stops visible. 

					4.	Double-click the color stop to open the color panel.

					5.	Select another color and then click outside the Color panel when you’re finished editing the gradient ramp.

					

				
					Figure 9-26: Use the Gradient tool change the color stops.

				

					[image: 9781118168608-fg030926.eps]

				Apply a gradient to a stroke

				New in Illustrator CS6, you can apply a gradient to a stroke. To apply a gradient to a stroke, follow these steps:

					1.	Make sure that you have the stroke of an object selected. You may want to increase the stroke to a larger point size so that you can see the gradient that you will apply a little better.

						You can do this by bringing forward the stroke at the bottom of the toolbar, or you can click Stroke in the Control panel and then select a gradient from the Swatches menu that appears.

					2.	Choose a gradient from the Swatches panel.

						The gradient is applied.

				[image: tip.eps]		You can’t change the direction or distance of a gradient applied to a stroke with the Gradient tool. To make these changes, choose Windows⇒Gradient and use the angle (for the direction) and the Gradient slider to change the span of the color stops, as you see in Figure 9-27.

					

				
					Figure 9-27: To edit a gradient on a stroke you must use the Gradient panel.

				

					[image: 9781118168608-fg030927.tif]

				Using transparency in gradient meshes

				The Gradient Mesh tool helps you to create incredible photo-realistic illustrations using meshes you build on vector objects. If you’ve already discovered the Gradient Mesh tool, you know how useful this tool is. If you add in the transparency feature, and the number of ways you can use it skyrockets.

				Follow these simple steps to try the new transparency feature:

					1.	Choose a solid color for your fill and no stroke.

					2.	Create a shape.

						In our example, we created a circle.

					3.	Choose Object⇒Create Gradient Mesh and leave the default of 4 Rows and 4 Columns, Appearance, Flat, as shown in Figure 9-28. Click OK.

					

				
					Figure 9-28: Choose how many rows and columns you want to start your mesh with.

				

					[image: 9781118168608-fg030928.eps]

						A gradient mesh appears in your shape with multiple mesh nodes.

					4.	Using the Direct Selection tool, click an individual node.

					5.	Either choose another color to create a blending effect from one color to another or choose Window⇒Transparency and decrease the value of the transparency drop-down list.

						The individual node becomes transparent based on the value you select.

				Copying Color Attributes

					[image: 9781118168608-ma032.tif]	Wouldn’t it be helpful if you had tools that could record the fill and stroke attributes and apply them to other shapes? You’re in luck — the Eyedropper tool can do just that. Copy the fill and stroke of an object and apply it to another object by using the Eyedropper tool:

					1.	Create several shapes with different fill and stroke attributes or open an existing file that contains several different objects.

					2.	Select the Eyedropper tool and click a shape that has attributes you want to copy.

					3.	Alt-click (Windows) or Option-click (Mac) another object to apply those attributes.

				Not only is this technique simple, but you can also change which attributes the Eyedropper applies. Do so by double-clicking the Eyedropper tool; in the dialog box that appears, select only the attributes you want to copy.

				Painting Made Easy: The Live Paint Feature

					[image: 9781118168608-ma057.tif]	Don’t worry about filling closed shapes or letting fills escape from objects with gaps into unwanted areas. Using the Live Paint feature, you can create the image you want and fill in regions with color. The Live Paint bucket automatically detects regions composed of independent intersecting paths and fills them accordingly. The paint within a given region remains live and flows automatically if any paths are moved.

				If you want to give it a try, follow these steps to put together an example to experiment with:

					1.	Use the Ellipse tool to create a circle on your page.

						Make the circle large enough to accommodate two or three inner circles.

					2.	Press D (and nothing else).

						As long as you aren’t using the Type tool, you revert to the default colors of a black stroke and a white fill.

					3.	Double-click the Scale tool and enter 75% in the Uniform Scale text box.

					4.	Press the Copy button and then click OK.

						You see a smaller circle inside the original.

					5.	Press Ctrl+D (Windows) or [image: maccmd]+D (Mac) to duplicate the transformation and create another circle inside the last one.

					6.	Choose Select⇒All or press Ctrl+A (Windows) or [image: maccmd]+A (Mac) to activate the circles you just created.

					7.	Make sure that the Fill swatch is forward.

						The Fill swatch is at the bottom of the Tools panel.

					8.	Use the Swatches or Color panel and choose any fill color.

					9.	Using the Selection tool, select all the circles. Next, click on the Live Paint Bucket tool, which is hidden under the Shape Builder tool, and click on the selection. 

						This turns the selected objects into a Live Paint Group. Now when you move the Live Paint Bucket tool over them again, the different regions become highlighted, indicating they are ready to paint.

						See how the different regions become highlighted?

					10.	Click when the region you want to fill is activated.

						Now try it with other fill colors in different regions, as shown in  Figure 9-29.

					

				
					Figure 9-29: Painting objects with the Live Paint feature.

				

					[image: 9781118168608-fg030929.tif]

				A companion feature to the Live Paint Bucket is support for gap detection. With this feature in its arsenal, Illustrator automatically and dynamically detects and closes small to large gaps that may be part of the artwork. You can determine whether you want paint to flow across region gap boundaries by using the Gap Options dialog box, accessible by choosing Object⇒Live Paint⇒Gap Options. 

				[image: technicalstuff.eps]	Before you save a file for an older version of Illustrator that uses the Live Paint feature, first select the occurrences of Live Paint and choose Object⇒Expand. When the Expand dialog box appears, leave the options at their defaults and click OK. This setting breaks down the Live Paint objects to individual shapes, which older versions of Illustrator can understand.

			

		

	
		
			
				Chapter 10: Using the Transform and Distortion Tools

				In This Chapter

				[image: check.png] Discovering transformation methods

				[image: check.png] Putting the Transform tools to work

				[image: check.png] Becoming familiar with the Liquify tools

				[image: check.png] Distorting, warping, and otherwise reshaping objects

				Transformations you can give to objects in Illustrator include scaling, rotating, skewing, and distorting. In this chapter, we show you how to use the general Transform tools as well as some of the neat Liquify and Envelope Distort features available in Illustrator.

				Working with Transformations

				Using just the Selection tool, you can scale and rotate a selected object. Drag the bounding box handles to resize the object, shown in Figure 10-1, or move outside a handle and then, when the cursor changes to a flippy arrow (a curved arrow with arrowheads on both ends), drag to rotate the object.

					

				
					Figure 10-1: Use the bounding box to resize or rotate a selected object.

				

					[image: 9781118168608-fg031001.tif]

				[image: tip.eps]	If you want to scale proportionally, hold down the Shift key while you drag to resize. To rotate an object at 45 degree increments, hold down the Shift key while you’re rotating.

				When you use the bounding box to rotate a selection, the bounding box rotates with the object, but its handles show the object’s original orientation, as shown in Figure 10-2. The orientation can help you keep track of the original placement but can also interfere when you’re building additional artwork. To reset the bounding box so that it’s straight at the new orientation, choose Object⇒Transform⇒Reset Bounding Box.

					

				
					Figure 10-2:  The bounding box in its original position and after it has been reset.

				

					[image: 9781118168608-fg031002.eps]

				[image: technicalstuff.eps]	When you scale, rotate, or use any other type of transformation in Illustrator, the final location becomes the zero point. In other applications, such as InDesign, you can rotate an object by any number of degrees (45 degrees, for example) and later enter 0 for the rotation angle in the Transform panel or in the Rotate dialog box to return the object to its original position. In Illustrator, if you enter 0 for the rotation angle to return a rotated object to its original position, the object doesn’t change its position. To return the object to the previous position in Illustrator, you have to enter the negative of the number you originally entered to rotate the object, so you would enter –45 for the degree of rotation in this example.

				Transforming an object

				The Rotate, Reflect, Scale, and Shear tools all use the same basic steps to perform transformations. Read on for those basic steps and then follow some individual examples of the most often used Transform tools. The following sections show five ways to transform an object: one for an arbitrary transformation and four others for exact transformations based on a numeric amount you enter.

				Arbitrary transformation method

				Because this transformation method is arbitrary, you’re eyeballing the transformation of an object — in other words, you don’t have an exact percentage or angle in mind, and you want to freely transform the object until it looks right. Just follow these steps:

					1.	Select an object and then choose a Transform tool (Rotate, Reflect, Scale, or Shear).

					2.	Click the artboard once.

						Be careful where you click because the click determines the point of reference, or axis point, for the transformation. In Figure 10-3, the click put the axis point above the right ear. The image is rotated on the axis created at that point.

					

				
					Figure 10-3: The first mouse click creates the axis point.

				

					[image: 9781118168608-fg031003.eps]

					3.	Drag in one smooth movement.

						Just drag until you create the transformation you want.

				[image: tip.eps]	Hold down the Alt (Windows) or Option (Mac) key when dragging to clone a newly transformed item while keeping the original object intact. This trick is especially helpful when you’re using the Reflect tool.

				Exact transformation methods

				In the methods in this section, we show you how to perform transformations using specific numeric information:

				Exact transformation method 1 — using the tool’s dialog box:

					1.	Select an object and then choose the Rotate, Reflect, Scale, or  Shear tool.

					2.	Double-click the Transform tool in the Tools panel.

						A dialog box specific to your chosen tool appears, as shown in Figure 10-4. In this example, we selected and then double-clicked the Rotate tool to open the Rotate dialog box.

					

				
					Figure 10-4: Double-click a Transform tool to open its dialog box.

				

					[image: 9781118168608-fg031004.eps]

					3.	Type an angle, a scaled amount, or a percentage in the appropriate text field. 

						In Figure 10-4, 45 degrees is entered.

					4.	Select the Preview check box to see the effect of the transformation before you click OK; click the Copy button instead of OK to keep the original object intact and transform a copy.

				Exact transformation method 2 — using the reference point:

					1.	Select an object and then choose the Rotate, Reflect, Scale, or Shear tool.

					2.	Alt-click (Windows) or Option-click (Mac) wherever you want to place the reference point.

					3.	In the Transform tool dialog box that appears, enter values and click OK or click the Copy button to apply the transformation.

						This method is the best one to use if you need to rotate an object an exact amount on a defined axis.

				Exact transformation method 3 — using the Transform menu:

					1.	Select an object and then choose a transform option from the Object⇒Transform menu.

						The appropriate transform dialog box appears.

					2.	Enter some values and click OK or the Copy button.

				Exact transformation method 4 — using the Transform panel:

					1.	Select an object and choose Window⇒Transform to access the Transform panel, shown in Figure 10-5.

					2.	Set your options.

					

				
					Figure 10-5: Enter values on the Transform panel.

				

					[image: 9781118168608-fg031005.tif]

				Though using the Transform panel is probably the easiest way to go, it doesn’t give you the option of specifying an exact reference point (by clicking your mouse button) or other options that apply to the individual Transform tools. Keep in mind that by using the square grid on the left side of the grid you can select a point of reference for your object. By using this grid you can measure from the corners of center points of an object.

				Aligning to the Grid using the Transform panel

				Chapter 9 discusses the Align New Objects to Pixel Grid feature as a method to keep your onscreen graphics crisp and clean on the edges. If you’ve already created your document (without selecting the Align New Objects to Pixel Grid check box in the New Document window), you can align your artwork to the grid at any time by selecting an object(s) and selecting the Align New Objects to Pixel Grid option from the panel menu of the Transform panel, as shown in Figure 10-6.

					

				
					Figure 10-6: You can choose to align selected objects to the pixel grid using the Transform panel.

				

					[image: 9781118168608-fg031006.tif]

				Using the Transform tools

				In the following sections, we show you how to use some of the most popular Transform tools to create transformations.

				The Reflect tool

				Nothing in life is perfectly symmetrical, right? Maybe not, but objects not created symmetrically in Illustrator can look off-kilter. Using the Reflect tool, you can reflect an object to create an exact mirrored shape of it; just follow these steps:

					1.	Open a new document in Illustrator and type some text or create an object.

						If you want to reflect text, make sure that you use at least 60-point type so that you can easily see it.

						2.	[image: 9781118168608-ma058.tif] Select the Reflect tool (hidden under the Rotate tool) and click the object; if you’re using text, click in the middle of the text baseline.

						This step sets the reference point for the reflection.

					3.	Alt+Shift+drag (Windows) or Option+Shift+drag (Mac) and release when the object or text is reflecting itself, as shown in Figure 10-7.

						This step not only clones the reflected object or text, but also snaps it to 45 degree angles.

					

				
					Figure 10-7:  The completed reflection.

				

					[image: 9781118168608-fg031007.tif]

				The Scale tool

				Using the Scale tool, you can scale an object proportionally or non-uniformly. Most people like to be scaled non-uniformly — maybe a little taller, a little thinner — but on with the topic. Follow these steps to see the Scale tool in action:

					1.	Create a shape and give it no fill and a 5-point black stroke.

						For this example, we created a circle. See Chapter 4 of this minibook if you need a reminder on how to do it.

						2.	[image: 9781118168608-ma025.tif] Select the shape and double-click the Scale tool.

						The Scale dialog box appears.

					3.	Type a number in the Scale text field (in the Uniform section) and click the Copy button.

						We entered 125 in the Scale text field to increase the size of the object by 125 percent.

					4.	Press Ctrl+D (Windows) or [image: maccmd]+D (Mac) to repeat the transformation as many times as you want.

						Every time you press Ctrl+D (Windows) or [image: maccmd]+D (Mac), the shape is copied and sized by the percentage you entered in the Scale text field. This trick, especially handy with circles, creates an instant bull’s-eye!

				To experiment with the Scale tool, create different shapes in Step 1 and enter different values in Step 3. Remember that if you type 50% in the Scale text field, the object is made smaller; surpass 100 percent — say, to 150 percent — to make the object larger. Leaving the Scale text field at 100 percent has no effect on the object.

				The Shear tool

					[image: 9781118168608-ma059.tif]	The Shear tool lets you shear an object by selecting an axis and dragging to set a shear angle, as shown in Figure 10-8.

				The axis is always the center of the object unless you use method 1 or 2 from the earlier section “Exact transformation methods.” Use the Shear tool in combination with the Rotate tool to give an object perspective.

					

				
					Figure 10-8: Create perspective with the Shear tool.

				

					[image: 9781118168608-fg031008.eps]

				The Reshape tool

				The Reshape tool lets you select anchor points and sections of paths and adjust them in one direction. You determine that direction by dragging an anchor point with the Reshape tool selected.

					[image: 9781118168608-ma060.tif]	The Reshape tool works differently from the other Transform tools. To use it, follow these steps:

					1.	Select just the anchor points on the paths that you want to reshape. Deselect any points that you want to remain in place.

					2.	Select the Reshape tool (hidden under the Scale tool) and position the cursor over the anchor point you want to modify; click the anchor point.

						If you click a path segment, a highlighted anchor point with a square around it is added to the path.

					3.	Shift-click more anchor points or path segments to act as selection points.

						You can highlight an unlimited number of anchor points or path  segments.

					4.	Drag the highlighted anchor points to adjust the path.

				The Free Transform tool

					[image: 9781118168608-ma027.tif]	You use the Free Transform tool in much the same way as you use the bounding box. (See the earlier section “Working with Transformations.”) This tool is necessary only if you choose View⇒Hide Bounding Box but want free transform capabilities.

				Creating Distortions

				You can bend objects — make them wavy, gooey, or spiky — by creating simple to complex distortions with the Liquify tools and the Envelope Distort features.

				The Liquify tools

				The Liquify tools can accomplish all sorts of creative or wacky (depending on how you look at it) distortions to your objects. 

				[image: tip.eps]	A number of keyboard shortcuts are available for the Width tool. (See  Table 10-1.) In addition to these shortcuts, you can globally adjust the stroke weight for all the width points by specifying the stroke weight in the Weight drop-down list of the Stroke panel.

				Table 10-1	Width Tool Keyboard Shortcuts

				
					
						
								
								Width tool function

							
								
								Windows

							
								
								Mac OS

							
						

						
								
								Create non-uniform widths 

							
								
								Alt+drag

							
								
								Opt+drag 

							
						

						
								
								Create a copy of the width point 

							
								
								Alt+drag the width point 

							
								
								Opt+drag the width point

							
						

						
								
								Copy and move all the points along the path

							
								
								Alt+Shift+drag 

							
								
								Opt+Shift+drag

							
						

						
								
								Change the position of  multiple width points

							
								
								Shift+drag

							
								
								Shift+drag

							
						

						
								
								Select multiple width points 

							
								
								Shift+click

							
								
								Shift+click

							
						

						
								
								Delete selected width points 

							
								
								Delete

							
								
								Delete

							
						

						
								
								Deselect a width point 

							
								
								Esc

							
								
								Esc

							
						

					
				

				You can choose from eight Liquify tools. Even though we define them for you in Table 10-2, you should experiment with these tools to understand their full capabilities. Here are some tips:

				[image: check.png] A variety of Liquify tools are available by holding down the mouse button on the default selection, the Width tool. If you use the tools frequently, drag to the arrow at the end of the tools. You can then position the tools anywhere in your work area.

				[image: check.png] Double-click any Liquify tool to open a dialog box specific to the selected tool.

				[image: check.png] When a Liquify tool is selected, the brush size appears. Adjust the diameter and shape of the Liquify tool by holding down the Alt (Windows) or Option (Mac) key while dragging the brush shape smaller or larger. Press the Shift key to constrain the shape to a circle.

				Table 10-2	The Liquify Tools

				
					
						
								
								Icon

							
								
								Tool Name

							
								
								What It Does to an Object

							
						

						
								
								[image: 9781118168608-ma026.tif]

							
								
								Width

							
								
								Increases the stroke width or height when you click and drag a path.

							
						

						
								
								[image: 9781118168608-ma061.tif]

							
								
								Warp

							
								
								Molds it with the movement of the cursor. (Pretend that you’re pushing through dough with this tool.)

							
						

						
								
								[image: 9781118168608-ma062.tif]

							
								
								Twirl

							
								
								Creates swirling distortions within it.

							
						

						
								
								[image: 9781118168608-ma063.tif]

							
								
								Pucker

							
								
								Deflates it.

							
						

						
								
								[image: 9781118168608-ma064.tif]

							
								
								Bloat

							
								
								Inflates it.

							
						

						
								
								[image: 9781118168608-ma065.tif]

							
								
								Scallop

							
								
								Adds curved details to its outline. (Think of a seashell with scalloped edges.)

							
						

						
								
								[image: 9781118168608-ma066.tif]

							
								
								Crystallize

							
								
								Adds many spiked details to the outline of an object, such as crystals on a rock.

							
						

						
								
								[image: 9781118168608-ma067.tif]

							
								
								Wrinkle

							
								
								Adds wrinkle-like details to the outline of an object.

							
						

					
				

					[image: 9781118168608-ma026.tif]	Using the Width tool, cross over a selected path. When a hollow square appears, click and drag outward (or inward), and the stroke width at that location is adjusted. See Figure 10-9.

					

				
					Figure 10-9: Use the new Width tool.

				

					[image: 9781118168608-fg031009.tif]

				If you want a little more accuracy, you can double-click the stroke by using the Width tool and create, modify, or delete the width point by using the Width Point Edit dialog box, shown in Figure 10-10.

					

				
					Figure 10-10: Customize the Width tool in this dialog box.

				

					[image: 9781118168608-fg031010.tif]

				[image: tip.eps]	To create a discontinuous width point, just create two width points on a stroke with different stroke widths and then drag one width point on to the other width point to create a discontinuous width point for the stroke.

				Using the Envelope Distort command

				Use the Envelope Distort command to arch text and apply other creative distortions to an Illustrator object. To use the Envelope Distort command, you can use a preset warp (the easiest method), a grid, or a top object to determine the amount and type of distortion. In this section, we discuss all three methods.

				Using the preset warps

				Experimenting with warp presets is a little more interesting if you have a word or an object selected before trying them out. To warp an object or some text to a preset style, follow these steps:

					1.	Select the text or object that you want to distort and then choose Object⇒Envelope Distort⇒Make with Warp.

						The Warp Options dialog box appears.

					2.	Select a warp style from the Style drop-down list and then specify any other options you want.

					3.	Click OK to apply the distortion.

				[image: tip.eps]	If you want to experiment with warping but also want to revert to the original at any time, choose Effect⇒Warp. You later change or delete the warp effect by double-clicking it in the Appearance panel or by dragging the effect to the trash can in the Appearance panel. Find out more in Chapter 12 of this minibook about exciting effects you can apply to objects.

				Reshaping with a mesh grid

				You can assign a grid to an object so that you can drag different points and create your own, custom distortion, as shown in Figure 10-11.

					

				
					Figure 10-11: Custom distortion using a mesh grid.

				

					[image: 9781118168608-fg031011.eps]

				Follow these steps to apply a mesh grid:

					1.	Using the Select tool, select the text or object that you want to distort and then choose Object⇒Envelope Distort⇒Make with Mesh.

						The Envelope Mesh dialog box appears.

					2.	Specify the number of rows and columns you want the mesh to contain and then click OK.

					3.	Drag any anchor point on the mesh grid with the Direct Selection tool to reshape the object.

				[image: tip.eps]	To delete anchor points on the mesh grid, select an anchor point by using the Direct Selection tool and press the Delete key.

					[image: 9781118168608-ma030.tif]	You can also use the Mesh tool to edit and delete points when using a mesh grid on objects.

				Reshaping an object with a different object

				To form letters into the shape of an oval or to distort selected objects into another object, use this technique:

					1.	Create text that you want to distort.

					2.	Create the object you want to use as the envelope (the object to be used to define the distortion).

					3.	Choose Object⇒Arrange to ensure that the envelope object is on top, as shown in Figure 10-12.

					

				
					Figure 10-12: Position the shape over the text.

				

					[image: 9781118168608-fg031012.eps]

					4.	Select the text and Shift-click to select the envelope object.

					5.	Choose Object⇒Envelope Distort⇒Make with Top Object.

				The underlying object is distorted to fit the shape of the top (envelope) object.

				[image: tip.eps]	Choose Effect⇒Distort and Transform⇒Free Distort to take advantage of the Free Distort dialog box, shown in Figure 10-13. You can edit or undo effects at any time by clicking or deleting the Free Distort effect from the Appearance menu.

					

				
					Figure 10-13: Distort an object from the Free Distort dialog box.

				

					[image: 9781118168608-fg031013.eps]

			

		

	
		
			
				Chapter 11: Working with Transparency and Special  Effects Tools

				In This Chapter

				[image: check.png] Adding dimension with the Mesh tool

				[image: check.png] Getting to know the Blend tool

				[image: check.png] Using the Symbol Sprayer tool

				[image: check.png] Discovering transparency, blend modes, and opacity masks

				This chapter is full of neat things you can do using some of the more advanced features in Adobe Illustrator. These special effects tools can help you create art that makes an impact: Discover how to make your art look like a painting with the Gradient Mesh tool, create morph-like blends with the Blend tool, become a graffiti artist by trying out the Symbol Sprayer tool, and see what’s underneath objects by using transparency.

				The Mesh Tool

				If you’re creating art in Illustrator that requires solid colors or continuous patterns, you can achieve those results quite easily. But if you’re working on an element that requires continuous tones, such as a person’s face, you turn to the handy Mesh tool to create smooth tonal variations in your illustration. Choose to blend one color into another and then use the Mesh tool to adjust your blend. Now in Illustrator CS6, you can apply varying levels of transparency to these mesh points.

				The Mesh tool can be as complex or simple as you want. Create intense illustrations that look like they were painted with an airbrush or just use the tool to give dimension to an object, as in the illustration shown in Figure 11-1.

				We show you how to create a gradient mesh in two ways: Clicking gives you a little more freedom to put mesh points where you want them, and manually setting the number of rows and columns in the mesh is more precise.

					

				
					Figure 11-1: Mesh tool illustrations can be complex or simple.

				

					[image: 9781118168608-fg031101.eps]

				[image: tip.eps]	You can change the color in mesh points by choosing the Direct Selection tool and either clicking a mesh point and picking a fill color or clicking in the center of a mesh area and choosing a fill. Whether you select the mesh point (see the left side of Figure 11-2) or the area between the mesh points (see the right side of Figure 11-2), it changes the painting result. To add a mesh point without changing to the current fill color, Shift-click anywhere in a filled vector object.

					

				
					Figure 11-2:  The mesh point changes the painting result.

				

					[image: 9781118168608-fg031102.eps]

				To create a gradient mesh by clicking, follow these steps:

					1.	Create any shape by using the shape tools. Make sure the shape has a solid color; any color will do.

					2.	Deselect all objects by choosing Select⇒Deselect.

					3.	Select a fill color that you want to apply as a mesh point to an object.

						For example, if you want to add a shaded white spot to a red circle, choose white for the fill color.

						4.	[image: 9781118168608-ma030.tif] Select the Mesh tool (the keyboard shortcut is U) and click anywhere in a filled vector object.

						The object is converted to a mesh object.

					5.	Click the object as many times as you want to add more mesh points.

				To create a gradient mesh by setting the number of rows and columns, follow these steps:

					1.	Select an object.

					2.	Choose Object⇒Create Gradient Mesh.

						The Create Gradient Mesh dialog box appears.

					3.	Set the number of rows and columns of mesh lines to create on the object by entering numbers in the Rows and Columns text fields.

					4.	Choose the direction of the highlight from the Appearance drop- down list.

						The direction of the highlight determines which way the gradient flows (see Figure 11-3); you have these choices:

					•	Flat: Applies the object’s original color evenly across the surface, resulting in no highlight

					•	To Center: Creates a highlight in the center of the object

					•	To Edge: Creates a highlight on the edges of the object

					5.	Enter a percentage of white highlight to apply to the mesh object in the Highlight text field.

					6.	Click OK to apply the gradient mesh to the object.

					

				
					Figure 11-3: Choose a highlight direction.

				

					[image: 9781118168608-fg031103.tif]

				You can select individual or multiple mesh points and apply varying levels  of transparency to them. Follow these steps to apply transparency to a  gradient mesh:

					1.	Select a shape tool and click and drag to the artboard to add the shape to your document.

					2.	Give the shape a solid fill (any color) and no stroke.

					3.	Choose the Mesh tool and click anywhere in the object.

						This step adds a mesh point to your object.

					4.	Choose Window⇒Transparency and select a percent from the Opacity drop-down list or type in any other value you want in the Opacity  text field.

						As you can see in Figure 11-4, an illustration was sent behind the object to demonstrate transparency in the object.

					

				
					Figure 11-4:  The transparency of these mesh points varies.

				

					[image: 9781118168608-fg031104.tif]

				The Blend Tool

					[image: 9781118168608-ma033.tif]	Use the Blend tool (located in the main Illustrator Tools panel) to transform one object to another to create interesting morphed artwork or to create shaded objects. Using the Blend tool, you can give illustrations a rendered look by blending from one color to another or create an even number of shapes from one point to another. Figure 11-5 shows examples of what you can do with this tool.

					

				
					Figure 11-5:  Some objects using the Blend tool.

				

					[image: 9781118168608-fg031105.tif]

				Creating a blend

				Creating a blend isn’t difficult, and as you get used to it you can take the process even further, to create incredibly realistic effects. Follow these steps to create a simple blend from one rectangle size to another, creating an algorithmic stripe pattern (a rectangle of one height blended to a rectangle of another height):

					1.	Create a rectangle.

						Size doesn’t matter in this example; just be sure that you can see a difference in shapes when you blend. We’re using a rectangle that measures roughly 4 x 1 inches.

					2.	Give your shape a fill and assign None to the stroke.

						You can use other settings, but we recommend keeping it simple if you’re still new to working with blends.

					3.	Using the Selection tool, click the rectangle and Alt+drag (Windows) or Option+drag (Mac) toward the bottom of the artboard to clone your shape; press the Shift key before you release the mouse button to make sure that the cloned shape stays perfectly aligned with the original shape.

					4.	Reduce the cloned shape to about half its original height by using the Transform panel.

						If the Transform panel isn’t visible, choose Window⇒Transform.

						Alternatively, you can hold down the Shift key and drag the lower-middle bounding box handle, shown in Figure 11-6.

					

				
					Figure 11-6: Reduce the size of the cloned shape.

				

					[image: 9781118168608-fg031106.eps]

					5.	In the swatches panel (choose Window⇒Swatches), change the cloned shape’s fill to a different color but keep the stroke set to None.

						Changing the color just helps you see the blend effect a little better.

					6.	Using the Blend tool, click the original shape and then click the cloned shape.

						As a default action, the Blend tool creates a smooth blend that transitions from one color to another, as shown in Figure 11-7. To change the blend effect, experiment with the Blend Options dialog box.

					

				
					Figure 11-7: Creating a smooth transition between rectangles.

				

					[image: 9781118168608-fg031107.eps]

				Setting Blend options

				You can change the way a blend appears by using the Blend Options dialog box: Choose Object⇒Blend⇒Blend Options. From the Spacing drop-down list, change the blend to one of these options:

				[image: check.png] Smooth Color: Blend steps are calculated to provide the optimum number of steps for a smooth transition.

				[image: check.png] Specified Steps: Determine the number of steps in a blend by typing a number in the text field to the right of the drop-down list.

				[image: check.png] Specified Distance: Control the distance between steps in the blend by typing a number in the text field to the right of the drop-down list.

				You can also choose between two orientation options:

				[image: check.png] Align to Page: Orients the blend perpendicular to the x-axis of the page.

				[image: check.png] Align to Path: Orients the blend perpendicular to the path. You probably won’t see a difference when changing orientation unless you’ve edited the blend path.

				[image: tip.eps]	You can easily access the Blend tool options by selecting a blended object and double-clicking the Blend tool in the Tools panel.

				If you’re feeling adventurous, try changing a smooth blend (such as the one you create in the preceding step list) into a logarithmic blend. In the Blend Options dialog box, select Specified Steps from the Spacing drop-down list and change the value to 5. This change creates the blend in 5 steps rather than in the more than 200 steps that may have been necessary to create the smooth blend.

				Here are a few more tips to help you become more comfortable using blends. You can

				[image: check.png] Blend between an unlimited number of objects, colors, opacities,  or gradients.

				[image: check.png] Edit blends directly with tools, such as Selection, Rotate, or Scale.

				[image: check.png] Switch to the Direct Selection tool and edit the blend path by dragging anchor points. A straight path is created between blended objects when the blend is first applied.

				[image: check.png] Edit blends that you created by moving, resizing, deleting, or adding objects. After you make editing changes, the artwork is blended again automatically.

				The Symbol Sprayer Tool

				The super Symbol Sprayer tool is one you must experiment with in order to understand its full potential. In a nutshell, it works like a can of spray paint that sprays, rather than paints, symbols — objects that, in Illustrator, can be either vector- or pixel-based. Each symbol is an instance.

				Exploring the symbol tools

				Illustrator comes with a library of symbols ready for use in the symbols panel. (If the symbols panel isn’t visible, choose Window⇒Symbols.) Use this panel as a storage bin or library to save repeatedly used artwork or to create your own symbols to apply as instances in your artwork, like blades of grass or stars in the sky. You can then use the symbolism tools, described in Table 11-1, to adjust and change the appearance of the symbol instances.

				Table 11-1	The Symbol Tools

				
					
						
								
								Icon

							
								
								Tool Name

							
								
								What You Can Do with It

							
						

						
								
								[image: 9781118168608-ma034.tif]

							
								
								Symbol Sprayer

							
								
								Create a set of symbol instances.

							
						

						
								
								[image: 9781118168608-ma068.tif]

							
								
								Symbol Shifter

							
								
								Move symbol instances around; can also change the relative paint order of symbol instances.

							
						

						
						
								
								[image: 9781118168608-ma069.tif]

							
								
								Symbol Scruncher

							
								
								Pull apart, or put together, symbol instances.

							
						

						
								
								[image: 9781118168608-ma070.tif]

							
								
								Symbol Sizer

							
								
								Increase or decrease the size of symbol instances.

							
						

						
								
								[image: 9781118168608-ma071.tif]

							
								
								Symbol Spinner

							
								
								Orient the symbol instances in a set. Symbol instances located near the cursor spin in the direction you move the cursor.

							
						

						
								
								[image: 9781118168608-ma072.tif]

							
								
								Symbol Stainer

							
								
								Colorize symbol instances.

							
						

						
								
								[image: 9781118168608-ma073.tif]

							
								
								Symbol Screener

							
								
								Increase or decrease the transparency of the symbol instances in a set.

							
						

						
								
								[image: 9781118168608-ma074.tif]

							
								
								Symbol Styler

							
								
								Apply or remove a graphic style from a symbol instance.

							
						

					
				

				[image: tip.eps]	Press the Alt (Windows) or Option (Mac) key to reduce the effect of the symbolism tools. In other words, if you’re using the Symbol Sizer tool, you click and hold to make the symbol instances larger; hold down the Alt (Windows) or Option (Mac) key to make the symbol instances smaller.

				You can also selectively choose the symbols you want to effect with the  Symbolism tools by activating them in the Symbols panel. Ctrl-click (Windows)  or [image: maccmd]-click (Mac) multiple symbols to change them at the same time.

				[image: technicalstuff.eps]	Just about anything can be a symbol, including placed objects and objects with patterns and gradients. If you’re going to use placed images as symbols, however, choose File⇒Place and deselect the Linked check box in the Place dialog box.

				Creating and spraying symbols on the artboard

				To create a symbol, select the object and drag it to the Symbols panel or click the New Symbol button at the bottom of the Symbols panel. Yes, it’s that easy. Then use the Symbol Sprayer tool to apply the symbol instance on the artboard by following these steps:

					1.	Select the symbol instance in the Symbols panel.

						Either create your own symbol or use one of the default symbols supplied in the panel.

					2.	Drag with the Symbol Sprayer tool, spraying the symbol on the artboard. (See Figure 11-8.)

						That’s it. You can increase or reduce the area affected by the Symbol Sprayer tool by pressing the bracket keys. Press ] repeatedly to enlarge the application area for the symbol or press [ to make it smaller.

					

				
					Figure 11-8: Using the Symbol Sprayer tool to create fish.

				

					[image: 9781118168608-fg031108.tif]

				Note that you can access all sorts of symbol libraries from the Symbols panel menu. Find 3D, nature, map, flower, and even hair and fur symbol collections by selecting Open Symbol Library.

				[image: tip.eps]	If you want to store artwork that you frequently need to access, simply drag selected objects to the Symbols panel or Alt-click (Windows) or Option-click (Mac) the New Symbol button to name and store the artwork. Retrieve the artwork later by dragging it from the Symbols panel to the artboard. In fact, you can drag any symbol out to your artboard to change or use it in your own artwork. To release the symbol back into its original art elements, choose Object⇒Expand. In the Expand dialog box, click OK to restore  the defaults.

				Transparency

				Using transparency can add a new level to your illustrations. The transparency feature does exactly what its name implies — changes an object to make it transparent so that what’s underneath that object is visible to varying degrees. You can use the Transparency panel for simple applications of transparency to show through to underlying objects or for more complex artwork using opacity masks, which can control the visibility of selected objects.

				Choosing Window⇒Transparency opens the Transparency panel, where you can apply different levels of transparency to objects. To do so, create an arrangement of objects that intersect, select the topmost object, and then change the transparency level of the object in the Transparency panel, by either selecting a percentage from the Opacity drop-down list or entering a value of less than 100 in the Opacity text field.

				Blend modes

				A blending mode determines how the resulting transparency will look. To achieve different blending effects, you choose different blend modes from the Blend Mode drop-down list in the Transparency panel.

				[image: tip.eps]	Truly, the best way to find out what all these modes do is to create two overlapping shapes and start experimenting. Give the shapes differently colored fills (but note that many blending modes don’t work with black-and-white fills). Then select the topmost object and change the opacity to anything other than 0 or 100% and change the blending mode by selecting an option from the Blend Mode drop-down list in the Transparency panel. You see all sorts of neat effects and might even pick a few favorites.

				We define each blend mode in the following list, but we’ll say it again: The best way to see what each mode does is to apply them — so start experimenting.

				[image: check.png] Normal: Creates no interaction with underlying colors.

				[image: check.png] Darken: Replaces only the areas that are lighter than the blend color. Areas darker than the blend color don’t change.

				[image: check.png] Multiply: Creates an effect similar to drawing on the page with magic markers, or like the colored film you see on theater lights.

				[image: check.png] Color Burn: Darkens the base color to reflect the blend color. If you’re using white, no change occurs.

				[image: check.png] Lighten: Replaces only the areas that are darker than the blend color. Areas lighter than the blend color don’t change.

				[image: check.png] Screen: Multiplies the inverse of the underlying colors. The resulting color is always a lighter color.

				[image: check.png] Color Dodge: Brightens the underlying color to reflect the blend color. If you’re using black, there’s no change.

				[image: check.png] Overlay: Multiplies or screens the colors, depending on the base color.

				[image: check.png] Soft Light: Darkens or lightens colors, depending on the blend color. The effect is similar to shining a diffused spotlight on the artwork.

				[image: check.png] Hard Light: Multiplies or screens colors, depending on the blend color. The effect is similar to shining a harsh spotlight on the artwork.

				[image: check.png] Difference: Subtracts either the blend color from the base color or the base color from the blend color, depending on which has the greater brightness value. The effect is similar to a color negative.

				[image: check.png] Exclusion: Creates an effect similar to, but with less contrast than, Difference mode.

				[image: check.png] Hue: Applies the hue (color) of the blend object to underlying objects but keeps the underlying shading, or luminosity.

				[image: check.png] Saturation: Applies the saturation of the blend color but uses the luminance and hue of the base color.

				[image: check.png] Color: Applies the blend object’s color to the underlying objects but preserves the gray levels in the artwork; works well for tinting objects or changing their color.

				[image: check.png] Luminosity: Creates a resulting color with the hue and saturation of the base color and the luminance of the blend color. This mode is essentially the opposite of Color mode.

				Opacity masks

				Just like in Photoshop, you can use masks to make more interesting artwork in Illustrator. Create an opacity mask from the topmost object in a selection of objects or by drawing a mask on a single object. The mask uses the grayscale of the selected object as its opacity mask. Black areas are transparent; shades of gray are semitransparent, depending on the amount of gray; white areas are opaque. Figure 11-9 shows the effect of using an opacity mask.

					

				
					Figure 11-9: An opacity mask converts the topmost object into a mask that then masks out the underlying objects.

				

					[image: 9781118168608-fg031109.eps]

				To create an opacity mask, follow these steps:

					1.	Open the Transparency panel menu.

					2.	Make sure that the Blend Mode drop-down list is set to Normal.

					3.	Create a shape anywhere on the artboard or open a document that has artwork on it.

						We’re using a circle, but the shape doesn’t matter. Make sure that the artwork has a fill. A solid color helps you see the effect.

					4.	Open the Symbols panel (choose Window⇒Symbols Panel) and drag a symbol to the artboard.

						In this example, we’re using the drums symbol.

					5.	Using the Selection tool, enlarge your symbol so that it fills the shape. 

						See the image on the left in Figure 11-10.

					

				
					Figure 11-10: Creating an opacity mask.

				

					[image: 9781118168608-fg031110.eps]

					6.	Select both the symbol and the shape and then click the Make  Mask button 

						See the image on the right in Figure 11-10.

						The symbol turns into a mask, showing varying levels of the underlying box of the newly created mask, depending on the original color value. To delete an opacity mask, click the Release button.

				Click the right thumbnail (which represents the mask) in the Transparency panel, and a black border appears around it, indicating that it’s active. You can move the items on the mask or even create items to be added to the mask. The mask works just like the regular artboard, except that anything done on the mask side is used only as an opacity mask. To work on the regular artboard, click the left thumbnail.

			

		

	
		
			
				Chapter 12: Using Filters  and Effects

				In This Chapter

				[image: check.png] Applying effects

				[image: check.png] Getting to know the Appearance panel

				[image: check.png] Discovering graphic styles

				[image: check.png] Making artwork 3D

				[image: check.png] Playing with additional fills and strokes

				[image: check.png] Creating the illusion of space and distance with the Perspective Grid

				Effects give you the opportunity to make jazzy changes to your Illustrator objects, such as add drop shadows and squiggling artwork. You can even use Photoshop filters directly in Illustrator. In this chapter, you find out how to apply, save, and edit effects; you also take a quick tour of the Appearance panel (your trusty sidekick when performing these tasks).

				Working with Effects

				If you’re an Adobe Illustrator user from any version before CS4, you might be wondering where the Filter menu is. (If you’re just starting to use Illustrator, you don’t need to know about, or even care about, this major change.) All items that appeared on the Filter menu are now on the Effects menu.

				Filters apply permanent changes to artwork, referred to as destructive changes, because after you save and close the file, you can’t undo the results for the filter. On the other hand, effects are quite different: They’re connected dynamically to objects. You can apply, change, and even remove effects at any time from the Appearance panel. (Choose Window⇒Appearance.)

				Understanding the Appearance panel

				You can apply multiple effects to one object and even copy them to multiple objects, which is when a good working knowledge of the Appearance panel is necessary. If it isn’t visible, choose Window⇒Appearance to open the Appearance panel, shown in Figure 12-1, alongside an object with several effects applied to it.

				If you have no effects applied, you see as a default only a fill and a stroke listed in the Appearance panel. As you create effects, they’re added to this list. You can add more strokes and fills to the list; you find out why that ability is so useful in the following sections.

					

				
					Figure 12-1: Discover how useful the Appearance panel can be.

				

					[image: 9781118168608-fg031201.tif]

				Applying an effect

				In this section, you see how to apply an effect. You can choose from many effects, and they’re all applied in much the same manner. In this example we create an interesting effect for a border.

				Follow these steps to apply an effect:

					1.	Make sure that your Appearance panel is visible. Choose Window⇒Appearance and click and drag the panel out of the dock area so that it doesn’t collapse while you’re working.

					2.	Select the Rectangle tool and click and drag a rectangle out on the  artboard.

						Any size artboard is fine for this example.

					3.	Using Stroke in the Control panel, change the stroke to 3 pt.

					4.	Using Stroke Color in the Control panel, assign any color except the default color of black.

					5.	Notice in the Appearance panel that you can select the Stroke and the Fill. By selecting one or the other, you can apply an effect to just the stroke or the fill. In this example, select Stroke.

					6.	Choose Effect⇒Distort and Transform⇒Zig Zag.

						Choose the settings that work well to make your straight border appear as a zigzag. In Figure 12-2, we selected Smooth to round out the points of the zigzag effect.

					

				
					Figure 12-2: Convert a straight path into a zigzag using the Zig Zag effect.

				

					[image: 9781118168608-fg031202.tif]

				[image: remember.eps]	Effects are linked dynamically to the object they’re applied to. They can be scaled, modified, and even deleted with no harm done to the original object.

				Adding a Drop Shadow effect

				Creating a drop shadow is a quick and easy way to add dimension and a bit of sophistication to your artwork. The interaction between the object with the drop shadow and the underlying objects can create an interesting look. To add the Drop Shadow effect to an illustration, follow these steps:

					1.	Select the object (or objects) to apply the drop shadow to. 

						If you like, you can continue using the rectangle you worked with in the previous section.

					2.	In the Appearance panel, make sure that Stroke is selected.

					3.	Choose Effect⇒Stylize⇒Drop Shadow.

					4.	In the Drop Shadow dialog box that appears, as shown in Figure 12-3, select the Preview check box in the lower-left corner.

					

				
					Figure 12-3: The Drop Shadow dialog box gives the effect’s options and preview.

				

					[image: 9781118168608-fg031203.tif]

						You now see the drop shadow applied as you make changes.

					5.	Choose from the following options in the dialog box:

					•	Mode: Select a blending mode from this drop-down list to choose how you want the selected object to interact with the objects underneath it. The default is Multiply, which works well — the effect is similar to coloring with a magic marker.

					•	Opacity: Enter a value or use the drop-down list to determine how opaque or transparent the drop shadow should be. If it’s too strong, choose a lower amount.

					•	Offset: Enter a value to determine how close the shadow is to the object. If you’re working with text or small artwork, smaller values (and shorter shadows) look best. Otherwise, the drop shadow may look like one big, indefinable glob.

						The X Offset shifts the shadow from left to right, and the Y Offset shifts it up or down. You can enter negative or positive numbers.

					•	Blur: Use Blur to control how fuzzy the edges of the shadow are. A lower value makes the edge of the shadow more defined.

					•	Color and Darkness: Select the Color radio button to choose a custom color for the drop shadow. Select the Darkness radio button to add more black to the drop shadow. Zero percent is the lowest amount of black, and 100 percent is the highest.

						As a default, the color of the shadow is based on the color of your object, sort of — the Darkness option also has a play in this task. As a default, the shadow is made up of the color in the object if it’s solid. Multicolored objects have a gray shadow.

					6.	When you’re finished, click OK to close the dialog box.

				Saving Graphic Styles

				A graphic style is a combination of all settings you choose for a particular filter or effect in the Appearance panel. By saving this information in a graphic style, you store these attributes so that you can quickly and easily apply them to other objects later. If you have already created an object with effects in a previous section, you will have the opportunity to save those effects as a graphic style later in this section.

				To apply a saved graphic style, follow these steps:

					1.	Choose Window⇒Graphic Styles.

						In the panel that appears are thumbnails of a few of Adobe’s default styles. You must access a Graphic Style library to add more options.

					2.	Click on the Library icon in the lower-left of the Graphic Styles panel and select the Graphic Style library named Scribble Effects, as shown in Figure 12-4.

						A second window appears. It’s named Scribble Effects.

					

				
					Figure 12-4: Access additional Graphic Styles by selecting the Library icon.

				

					[image: 9781118168608-fg031204.eps]

					3.	Create a new shape, such as a simple rectangle or an ellipse, and click any graphic style in the Scribble Effects panel to apply it to an active object.

						Look at the Appearance panel while you click different styles to see that you’re applying combinations of attributes, including effects, fills, and strokes. (See Figure 12-5.)

					

				
					Figure 12-5: The Graphic Styles panel stores effects and other attributes.

				

					[image: 9781118168608-fg031205.tif]

				You can store attributes as a graphic style in several ways; we show you two easy methods. If you already applied a combination of attributes to an object, such as the rectangle border that you may have created in the previous section, you can store them by completing one of these tasks:

				[image: check.png] With the object selected, Alt-click (Windows) or Option-click (Mac) the New Graphic Style button at the bottom of the Graphic Styles panel. Alt-click (Windows) or Option-click (Mac) allows you to name the style when it’s added.

				[image: check.png] Drag the selected object directly into the Graphic Styles panel. The panel stores its attributes, but you have to double-click the new style to name it.

				After you store a graphic style, simply select the object you want to apply the style to and then click the saved style in the Graphic Styles panel.

				You can try this by creating another rectangle and then clicking on your saved Graphic Style in the Graphic Style panel.

				Creating 3D Artwork

				All Illustrator effects are excellent, but the 3D feature is even better. You can not only add dimension by using the 3D effect but also map artwork (wrap artwork around a 3D object) and apply lighting to the 3D object. You can then design a label for a jelly jar, for example, and adhere it to the jar to show a client.

				Here are the three choices for the 3D effect:

				[image: check.png] Extrude & Bevel: Uses the z-axis to extrude an object. For example, a square becomes a cube.

				[image: check.png] Revolve: Uses the z-axis and revolves a shape around it. You can use this option to change an arc into a ball.

				[image: check.png] Rotate: Rotates a 3D object created using the Extrude & Bevel or Revolve effects or rotates a 2D object in 3D space. You can also adjust the perspective of a 3D or 2D object.

				To apply a 3D effect, you need to create an object appropriate for the 3D effect. The Extrude & Bevel feature works well with shapes and text. If you want to edit an object that already has a 3D effect applied to it, double-click the 3D effect in the Appearance panel.

				To apply a 3D effect, follow these steps:

					1.	Select the object you want to apply the 3D effect to.

					2.	Choose Effect⇒3D⇒Extrude & Bevel.

						Options for your chosen 3D effect appear. To see the 3D Extrude & Bevel Options dialog box, see Figure 12-7.

					3.	Select the Preview check box so that you can see results as you experiment with these settings.

					4.	Click the Preview pane (which shows a cube in Figure 12-6) and drag to rotate the object in space.

						It makes selecting the proper angle (or positioning the object in space) fun to do, or you can choose the angle from the Position drop-down list above the preview.

				[image: warning_bomb.eps]		Never use the Rotate tool to rotate a 3D object, unless you want some funky results; use the Preview pane in the Extrude & Bevel Options dialog box instead.

					

				
					Figure 12-6: The Extrude & Bevel Options dialog box.

				

					[image: 9781118168608-fg031206.tif]

					5.	(Optional) Use the Perspective drop-down list to add perspective to your object.

					6.	In the Extrude & Bevel section of the dialog box, select a depth for your object and a cap.

						The cap determines whether your shape has a solid cap on it or is hollow, as shown in Figure 12-7.

					

				
					Figure 12-7: Cap on (left), cap off (right).

				

					[image: 9781118168608-fg031207.eps]

					7.	Select a bevel (edge shape) from the Bevel drop-down list and set the height using the Height drop-down list.

						You have a choice of two ways to apply the bevel:

					•	Bevel Extent Out: The bevel is added to the object.

					•	Bevel Extent In: The bevel is subtracted from the object.

					8.	Select a rendering style from the Surface drop-down list or click the More Options button for in-depth lighting options, such as changing the direction or adding lighting.

					9.	Click the Map Art button.

						The Map Art dialog box opens, as shown in Figure 12-8. Use this dialog box to apply artwork to a 3D object.

					

				
					Figure 12-8: In the Map Art dialog box, you can select a surface and apply a symbol to it.

				

					[image: 9781118168608-fg031208.tif]

					10.	Using the Surface arrow buttons, select the surface you want the  artwork applied to and then select a symbol from the Symbol drop-down list.

						The result is shown on the left in Figure 12-8.

					11.	Click OK to close the dialog box.

				[image: remember.eps]	Keep these points in mind when mapping artwork:

				[image: check.png] An object must be a symbol to be used as mapped artwork. You simply need to select and drag to the Symbols panel the artwork you want mapped. By doing so, you make it a selectable item in the Map Art  dialog box.

				[image: check.png] The light gray areas in the Preview pane are the visible areas based on the object’s present position. Drag and scale the artwork in this pane to place the artwork where you want it.

				[image: check.png] Shaded artwork (enabled by selecting the Shaded Artwork check box at the bottom of the Map Art dialog box) looks good but can take a long time to render.

				Note: All 3D effects are rendered at 72 dpi (dots per inch; low resolution) so as not to slow down the processing speed. You can determine the resolution by either choosing Effect⇒Document Raster Effects Settings or saving or exporting the file. You can also select the object and choose Object⇒Rasterize. After you rasterize the object, you can no longer use it as an Illustrator 3D object, so save the original!

				Adding Multiple Fills and Strokes

				Using the panel menu in the Appearance panel, you can add more fills and strokes. You can use this feature to put differently colored fills on top of each other and individually apply effects to each one, creating truly interesting and creative results.

				Just for fun, follow along to see what you can do to a single object from the Appearance panel:

					1.	Create a star shape.

						Neither the size of the shape nor its number of points matters — just make the shape large enough to work with.

					2.	Use the Swatches panel (choose Window⇒Swatches) to fill the shape with yellow and give it a black stroke.

					3.	Choose Window⇒Stroke to use the stroke panel to make the stroke 1 point; alternatively, select 1 from the Stroke drop-down list in the Control panel.

						Notice that the present fill and stroke are listed in the Appearance panel. Even in its simplest form, the Appearance panel helps track basic attributes. You can easily take advantage of the tracking to apply effects to just a fill or a stroke.

					4.	Click Stroke in the Appearance panel.

						If the Appearance panel isn’t visible, choose Window⇒Appearance.

					5.	Choose Effect⇒Path⇒Offset Path.

					6.	In the Offset Path dialog box that appears, enter –10 pt in the Offset text box and select the Preview check box, as you see in Figure 12-9.

						Notice that the stroke moves into the fill rather than on the edge.

					7.	Change the offset to a number that works with your star shape and click OK.

						Depending on the size of your star, you may want to adjust the amount of offset up or down.

					8.	From the panel menu of the Appearance panel, select Add New Fill to add a new fill to the star shape. Click the arrow to the right of the new fill color swatch to open the Swatches panel and change the new fill to a different color, as shown in Figure 12-10.

						This step may seem ridiculous, but you can create some super effects with multiple fills.

					

				
					Figure 12-9: Select to offset just the stroke of an object.

				

					[image: 9781118168608-fg031209.tif]

					

				
					Figure 12-10: Change the new fill to a different color right in the Appearance panel.

				

					[image: 9781118168608-fg031210.tif]

					9.	Make sure the new Fill is selected in the Appearance panel (the top one) and choose Effect⇒Distort and Transform⇒Twist.

					10.	In the Twist dialog box that appears, type 45 in the Angle text field and select the Preview check box, as you see in Figure 12-11.

						Notice how only the second fill is twisted. Neat, right?

					11.	Click OK to close the Twist dialog box.

					12.	Select the top fill from the Appearance panel again.

				[image: remember.eps]		Always be sure to select the fill or stroke you want before doing anything meant to change just that specific fill or stroke.

					13.	In the Transparency panel (choose Window⇒Transparency), select 50% from the Opacity drop-down list or simply type 50% in the Opacity text field.

						Now you can see your original shape through the new fill.

					14.	With the top fill still selected, change the color or choose a pattern in the Swatches panel for a truly different appearance.

						Continue playing with combinations of fills and strokes for hours if you want. We hope that this process “clicks” and that you can take it further on your own.

					

				
					Figure 12-11: Choose to twist one of the fills.

				

					[image: 9781118168608-fg031211.tif]

				Using the New Perspective Grid

				You can create and edit artwork based on the perspective grid feature (introduced in CS5), shown in Figure 12-12. The grid is a huge help in creating successful perspective illustrations.

					

				
					Figure 12-12:  Build and edit illustrations by using the Perspective Grid tool.

				

					[image: 9781118168608-fg031212.tif]

				To show or hide the default perspective grid, press Ctrl+Shift+I (Windows) or [image: maccmd]+Shift+I (Mac).

					[image: 9781118168608-ma029.tif]	You can use the Perspective Grid tool on the toolbar to fine-tune the grid.

				Here are some simple instructions to help you start using the perspective grid:

					1.	Create a new document and turn on the perspective grid by pressing Ctrl+Shift+I (Windows) or [image: maccmd]+Shift+I (Mac).

					2.	Select a shape tool, such as the Ellipse, and click and drag it to create the shape on the perspective grid.

						Notice that the shape’s perspective is controlled by the grid.

					3.	Select the Perspective Selection tool.

						It’s the hidden tool in the Perspective Grid tool.

					4.	Using the Perspective Selection tool, click and drag the shape to see that it’s adjusted in position and location using the perspective grid.

						Figure 12-13 shows the result of dragging an ellipse with the Perspective Selection tool.

						Note that you can also select and drag the grid itself by using the Perspective Selection tool.

					

				
					Figure 12-13:  Click and drag to change the perspective using the Perspective Selection tool.

				

					[image: 9781118168608-fg031213.tif]

					5.	Choose View⇒Perspective Grid, as shown in Figure 12-14, and then select the type of perspective to apply.

						In this step, you further customize your grid and choose other options to make your illustrations more precise.

					

				
					Figure 12-14: Customize settings for the perspective grid by using the View menu.
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				Chapter 13: Using Your  Illustrator Images

				In This Chapter

				[image: check.png] Saving Illustrator files

				[image: check.png] Exporting files for use in other applications

				[image: check.png] Preparing art for the web

				[image: check.png] Flattening your transparency

				[image: check.png] Printing in Illustrator

				So you have beautiful artwork but aren’t sure how to remove it from your screen. You could have a party and invite all interested clients to stand around your monitor and admire it or share or sell your artwork by posting it on the Internet or printing it.

				In this chapter, we show you how to use your illustrations in a variety of workflows, from using Illustrator files in page layout programs to exporting files for Photoshop (and other programs) and the web. This chapter helps you use your artwork effectively and understand the saving and flattening choices available in Adobe Illustrator.

				Saving and Exporting Illustrator Files

				In this section, we show you how general choices differ in the Save As dialog box (choose File⇒Save As) and describe their benefits.

				When you choose File⇒Save or File⇒Save As, you save your file in one of these formats: Adobe Illustrator, EPS, FXG (a vector-based file format that describes graphical elements), PDF, SVG, SVG Compressed, or Template. We discuss all these formats throughout this chapter.

				[image: tip.eps]	If you need a file format not listed in the regular Save As dialog box, choose File⇒Export to see additional choices. Using the File Export command, you can choose to save your files in any format listed in Table 13-1.

				Table 13-1	Available File Formats

				
					
						
								
								File Format

							
								
								Extension

							
						

						
								
								AutoCAD Drawing

							
								
								.dwg

							
						

						
								
								AutoCAD Interchange File

							
								
								.dxf

							
						

						
								
								BMP

							
								
								.bmp

							
						

						
								
								Enhanced Metafile

							
								
								.emf

							
						

						
								
								Flash

							
								
								.swf

							
						

						
								
								JPEG

							
								
								.jpg

							
						

						
								
								Macintosh PICT

							
								
								.pct

							
						

						
								
								Photoshop

							
								
								.psd

							
						

						
								
								PNG

							
								
								.png

							
						

						
								
								Targa

							
								
								.tga

							
						

						
								
								Text Format

							
								
								.txt

							
						

						
								
								TIFF

							
								
								.tif

							
						

						
								
								Windows Metafile

							
								
								.wmf

							
						

					
				

				[image: warning_bomb.eps]	Many formats rasterize artwork, so they no longer maintain vector paths and the benefits of being vector. Scalability isn’t limited, for example. If you think that you may want to edit your image again later, be sure to save a copy of the file and keep the original in the .ai format.

				The native Adobe Illustrator file format

				If you’re working with the programs in the Creative Suite, the best way to save a file is as a native Illustrator .ai file. For instance, the .ai format works with Adobe applications such as Adobe InDesign for page layout, Adobe Dreamweaver for web page creation, Adobe Photoshop for photo retouching, and Adobe Acrobat for cross-platform documents.

				Understanding when it’s best to use the .ai format is important. Saving your illustration as an .ai file ensures that it’s editable; it also ensures that any transparency is retained, even if you use the file in another application.

				To save and use a file in native Illustrator format, follow these steps:

					1.	Make an illustration with transparency (50 percent transparent, for example) in Adobe Illustrator and choose File⇒Save As.

					2.	Select Adobe Illustrator Document (.ai) from the Save As Type drop-down list, give the file a name, and click Save.

					3.	Leave the Illustrator Native options at their defaults and click OK.

				[image: tip.eps]	After you follow the preceding step list to prepare your Illustrator file, you can use the illustration in other Adobe applications:

				[image: check.png] Adobe Acrobat: Open the Acrobat application and choose File⇒Open. Locate the .ai file. The native Illustrator file opens within the Acrobat application.

				[image: check.png] Adobe InDesign: Choose File⇒Place. This method supports transparency created in Adobe Illustrator, as shown in Figure 13-1. (However, copying and pasting from Illustrator to InDesign does not support  transparency.)

					

				
					Figure 13-1: InDesign supports transparency, even over text.

				

					[image: 9781118168608-fg031301.eps]

				[image: check.png] Adobe Photoshop: Choose File⇒Place. By placing an Illustrator file into Adobe Photoshop, you automatically create a Photoshop smart object. You can scale, rotate, and even apply effects to the Illustrator file and return to the original illustration at any time. Read more about smart objects in Photoshop in Book IV, Chapter 9.

						If you want to go crazy with an Illustrator file in Photoshop, when you save the file in Illustrator, choose File⇒Export and select the Photoshop (.psd) format from the Save As Type drop-down list. Choose a resolution from the Options window. If you used layers, leave the Write Layers option selected.

						In Photoshop, choose File⇒Open, select the file you just saved in Illustrator in .psd format, and click Open. The file opens in Photoshop with its layers intact.

				[image: check.png] Adobe Flash: Use the integration features built into Adobe Illustrator to cut and paste directly into Adobe Flash. If you choose Edit⇒Copy from Adobe Illustrator, you can then switch to Adobe Flash and choose Edit⇒Paste. The Paste dialog box appears.

						You can also choose File⇒Import in Flash for additional import choices. When a native Illustrator file was selected to import to the Stage, the Import to Stage dialog box appears (directly in Flash!) so that you can import only certain layers or sublayers and respond to warning messages about incompatible objects.

				[image: check.png] Adobe Dreamweaver: By choosing File⇒Save for Web & Devices, you can choose to save your Illustrator document in .gif, .jpg, .png, .svg, .swf, or .wbmp format. You can then insert images in those file formats into Dreamweaver by choosing Insert⇒Image in Adobe Dreamweaver.

						Click the Image button in the Insert panel in Dreamweaver. When the Select Image Source dialog box appears, navigate to the location where you saved your optimized file. Select it and click OK. If your file is located out of the root folder for the site you’re working on, an alert window appears, offering the opportunity to save the file with your other site assets. See Book VI, Chapter 4 for more information about importing images in Dreamweaver.

				Saving Illustrator files back to previous versions

				When saving an .ai or .eps file, you can choose File⇒Save As, choose an Illustrator format, and then click OK.

				When the Illustrator Options dialog box appears, choose a version from the Version drop-down list. Keep in mind that any features specific to newer versions of Illustrator aren’t supported in older file formats, so make sure that you save a copy and keep the original file intact. Adobe helps you understand the risk of saving to older versions by putting a warning sign next to the Version drop-down list and showing you specific issues with the version you selected in the Warnings window.

				The EPS file format

				Encapsulated PostScript File (EPS) is the file format that most text editing and page layout applications accept; EPS supports vector data and is completely scalable. Because the Illustrator .eps format is based on PostScript, you can reopen an EPS file and edit it in Illustrator at any time.

				To save a file in Illustrator as an EPS, follow these steps:

					1.	Choose File⇒Save As and select EPS from the Save As Type drop- down list.

					2.	From the Version drop-down list, select the Illustrator version you’re saving to.

					3.	In the EPS Options dialog box that appears (shown in Figure 13-2), select the preview from the Format drop-down list:

					•	(8-Bit Color): A color preview for either Mac or PC

					•	(Black & White): A low-resolution, black-and-white preview

					

				
					Figure 13-2: Select a preview and other important settings in the EPS Options dialog box.

				

					[image: 9781118168608-fg031302.eps]

					4.	Select either the Transparent or Opaque radio button, depending on whether you want the non-image areas in your artwork to be transparent or opaque.

					5.	Specify your transparency settings.

						These settings are grayed out if you haven’t used transparency in the file. (See the “Flattening Transparency” section, later in this chapter, for more about this setting.)

					6.	Leave the Embed Fonts (for other applications) check box selected to leave fonts you used embedded in the EPS file format.

					7.	In the Options section, leave the Include CMYK PostScript in RGB Files check box selected.

						If you don’t know which Adobe Postscript level you want to save to, leave it at the default.

					8.	Click OK to save your file in EPS format.

				The PDF file format

				If you want to save your file in a format that supports more than a dozen platforms and requires only Acrobat Reader, available as a free download at www.adobe.com, choose to save your file as a PDF (Portable Document Format) file.

				If you can open an Illustrator file in Acrobat, why would you need to save a file in PDF format? For one thing, you can compress a PDF to a smaller size; also, the receiver can double-click the file and then Acrobat or Acrobat Reader launches automatically.

				Depending on how you save the PDF, you can allow some level of editability in Adobe Illustrator. To save a file as a PDF, follow these steps:

					1.	Choose File⇒Save As, select Illustrator PDF (.pdf) from the Save As Type drop-down list, and then click Save.

					2.	In the Adobe PDF Options dialog box that appears, choose one of these options from the Preset drop-down list:

					•	Illustrator Default: Creates a PDF file in which all Illustrator data is preserved. PDF files created using this preset can be reopened in Illustrator with no loss of data.

					•	High Quality Print: Creates PDF files for desktop printers and  proofers.

					•	PDF/X-1a:2001: The least flexible, but quite powerful, delivery method for PDF content data; requires that the color of all objects be CMYK (Cyan, Magenta, Yellow, Black) or spot colors. Elements in RGB (Red, Green Blue) or Lab color spaces or tagged with International Color Consortium (ICC) profiles are prohibited. All fonts used in the job must be embedded in the supplied PDF file.

					•	PDF/X-3:2002: Has slightly more flexibility than the X-1a:2001 method (see preceding bullet) in that color managed workflows are supported elements in Lab and attached ICC source profiles may also be used.

					•	PDF/X-4:2008: Based on PDF 1.4, which includes support for live transparency and has the same color management and ICC color specifications as PDF/X-3. You can open PDF files created for PDF/X-4 compliance in Acrobat 7.0 and Reader 7.0 and later.

					•	Press Quality: Creates a PDF file that can be printed to a high-resolution output device. The file will be large but maintain all information that a commercial printer or service provider needs in order to print files correctly. This option automatically converts the color mode to CMYK, embeds all fonts used in the file, prints at a higher resolution, and uses other settings to preserve the maximum amount of information contained in the original document.

				[image: tip.eps]		Before creating an Adobe PDF file by using the Press Quality preset, check with your commercial printer to determine the output resolution and other settings.

					•	Smallest File Size: Creates a low-resolution PDF suitable for posting on the Internet or sending by e-mail.

					•	Standard: Lets you select, from the Standard drop-down list, the type of PDF/X file you want to create. Avoid picking a PDF/X standard unless you have a specific need or are filling a request.

					•	Compatibility: Makes different features available for different versions, such as the ability to support layers in Version 6 or higher. For the most compatible file type, choose Acrobat 5 (PDF 1.4). To take advantage of layers or to preserve spot colors, you must choose Acrobat 6 or higher.

					3.	Click Save PDF to save your file in PDF format.

				[image: remember.eps]		If you want to be able to reopen the PDF file and edit it in Illustrator, make sure that you leave the Preserve Illustrator Editing Capabilities check box selected in the Adobe PDF Options dialog box.

				In the Adobe PDF Options dialog box, to the left of the preset choices, are options you can change to customize your settings. Skim the options to see how to change resolution settings and even add printer’s marks. Take a look at Book V to find out more about the additional Acrobat PDF options.

				[image: tip.eps]	Want a press-quality PDF but don’t want to convert all your colors to CMYK? Choose the Press setting and then click the Output options. In the Color Conversion drop-down list, select No Conversion.

				Saving Your Artwork for the Web

				If you need to save artwork for the web, no feature is better than Save for Web. This dialog box opens a preview pane where you can test different file formats before you save the file.

				[image: tip.eps]	Before going through the steps to save a graphic for the web, make sure that the artboard is resized to the bounds of the graphic; otherwise, you’ll have extra space surrounding your graphic.

				To save an Illustrator file that you intend to use in a web page, just follow these steps:

					1.	Choose File⇒Save for Web.

						The Save for Web dialog box appears, showing your artwork on the Optimized tab. (See Figure 13-3.)

					

				
					Figure 13-3: Use Save for the Web to optimize your images for the web.

				

					[image: 9781118168608-fg031303.eps]

					2.	Select a tabbed view: Original, Optimized, or 2-Up.

						You see as a default the artwork in Optimized view, which previews the artwork as it will appear based on the settings to the right. The best choice is 2-Up view because it shows your original image versus the optimized version.

					3.	Select a setting for your file from the options on the right.

						If you want to make it easy on yourself, select a preset from the Preset drop-down list. Keep these points in mind:

					•	Graphics Interchange Format (GIF) is generally used for artwork with spans of solid color. GIF isn’t a lossy format. You can make your artwork smaller by reducing the number of colors in the image — hence the choices, such as GIF 64 No Dither (64 colors). The lower the number of colors, the smaller the file size. You can also increase or decrease the number of colors in the file by changing the preset values in the Color text field or by clicking the arrows to the left of the Color text field.

					•	Dithering tries to make your artwork look like it has more colors by creating a pattern in the colors. It looks like a checkerboard pattern up close and even far away, as shown in Figure 13-4. It also makes a larger file size, so why use it? Most designers don’t like the effect and choose the No Dither option.

					

				
					Figure 13-4: An example of dithering.

				

					[image: 9781118168608-fg031304.tif]

					•	Joint Photographic Experts Group (JPEG) is used for artwork that has subtle gradations from one shade to another. Photographs are often saved in this format. If you have drop shadows or blends in your artwork, select this format. JPEG is a lossy file format — it reduces an image to a lesser quality and can create odd artifacts in your artwork. You have choices, such as High, Medium, and Low in the Settings drop-down list — make sure to choose wisely. You can also use the Quality slider to tweak the compression.

					•	PNG-8 is quite similar to the GIF file format. Unless you have a certain reason for saving as PNG-8, stick with the GIF file format.

					•	PNG-24 supports the best of two formats (GIF and JPEG). The Portable Network Graphics (PNG) format supports not only the nice gradients from one tonal value to another (such as JPEGs) but also transparency (such as GIFs). It isn’t just any old transparency: If you make an object 50 percent transparent in Adobe Illustrator and then save it by selecting Save for Web & Devices as a PNG-24 file with the Transparency check box selected, the image shows through to any other objects underneath it on its destination page.

					4.	When you’re satisfied with your chosen settings, click Save.

				[image: tip.eps]	When saving illustrations for the web, keep these points in mind — they make the whole process much easier for you and anyone who uses your illustrations:

				[image: check.png] Keep file sizes small. Don’t forget that if you’re saving illustrations for a web page, many other elements will also be on that page. Try to conserve on file size to make downloading the page quicker for viewers with dial-up connections. Most visitors don’t wait more than ten seconds for a page to download before giving up and moving to another website.

						When you make your choices, keep an eye on the file size and the optimized artwork in the lower-left corner of the preview window. A GIF should be around 10K on average, and a JPEG around 15K. (Though these rules aren’t written in stone, please don’t try to slap a 100K JPEG on a web page.)

				[image: tip.eps]		You can change the download time by clicking the panel menu in the upper right corner of the Save for Web & Devices dialog box and choosing Optimize to File Size. Then you can enter a final file size and have Illustrator create your settings in the Save for Web & Devices dialog box.

				[image: check.png] Preview the file before saving it. If you want to see the artwork in a web browser before saving it, click the Preview button at the bottom-left corner of the Save for Web dialog box. The browser of choice appears with your artwork in the quality level and size in which it will appear. If no browser is selected, click the Select Browser Menu icon (to the right of the Preview button) to choose Other and then browse to locate a browser you want to use for previewing. Close the browser to return to the Save for Web dialog box.

				[image: check.png] Change the size. Many misconceptions abound about the size of web artwork. Most people generally view their browser windows in an area measuring approximately 700 x 500 pixels. Depending on the screen resolution, this setting may cover the entire screen on a 14-inch monitor. Even viewers with 21-inch, high-resolution monitors often don’t want to have their entire screens covered by a browser window, however, so their areas still measure approximately 700 x 500 pixels. When choosing a size for your artwork, choose one with proportions similar to these. For example, if you want an illustration to occupy about a quarter of  the browser window’s width, make your image about 175 pixels wide  (700 ÷ 4 = 175). If you notice that the height of your image is more than 500 pixels, whittle the height in size as well or else viewers have to scroll to see the whole image (and it will probably take too long to download).

						Use the Image Size tab to enter new sizes. As long as the Constrain Proportions check box is selected, both the height and width of the image change proportionally. Click the Apply button to change the size, but don’t close the Save for Web dialog box.

				[image: check.png] Finish the save. If you aren’t finished with the artwork but want to save your settings, hold down the Alt (Windows) or Option (Mac) key and click the Remember button. (When you aren’t holding down the Alt or Option key, the Remember button is the Done button.) When you’re finished, click the Save button and save your file in the appropriate  location.

				Flattening Transparency

				You may find that all those cool effects you added to your illustration don’t print correctly. When you print a file that has effects, such as drop shadows, cool gradient blends, and feathering, Illustrator flattens them by turning into pixels any transparent areas that overlap other objects and leaving what it can as vectors.

				To understand flattening, look at Figure 13-5 to see the difference between the original artwork (on the left) and the flattened artwork (on the right). Notice that in the figure, when the artwork was flattened, some areas turned into pixels. But at what resolution? Flattening helps you determine the quality of art — before receiving an unpleasant surprise at the outcome.

					

				
					Figure 13-5: Artwork before and after flattening is applied.

				

					[image: 9781118168608-fg031305.tif]

				Flattening a file

				If you’ve taken advantage of transparency or effects using transparency (which we discussed in Chapter 11 of this minibook), follow these steps to produce the highest-quality artwork in your file:

					1.	Make sure that the artwork you created is in CMYK mode.

						You can change the document’s color mode by choosing File⇒Document Color Mode.

					2.	Choose Effect⇒Document Raster Effects Settings.

						The Document Raster Effects Settings dialog box appears, as shown in Figure 13-6.

					

				
					Figure 13-6: Choosing the quality of rasterized artwork.

				

					[image: 9781118168608-fg031306.eps]

					3.	Choose the resolution you want to use by selecting an option in the Resolution area.

						Select the Screen (72 ppi) option for web graphics, Medium (150 ppi) for desktop printers and copiers, and High (300 ppi) for graphics to be printed on a press.

					4.	Choose whether you want a white or transparent background.

						If you select the Transparent option, you create an alpha channel that’s retained if the artwork is exported into Photoshop.

					5.	You can generally leave the items in the Options section deselected:

					•	The Anti-Alias check box applies antialiasing to reduce the appearance of jagged edges in the rasterized image. Deselect this option to maintain the crispness of fine lines and small text.

					•	The Create Clipping Mask check box creates a mask that makes the background of the rasterized image appear transparent. You don’t need to create a clipping mask if you select the Transparent option for your background.

					•	The Add __ Around Object text field adds the specified number of pixels around the rasterized image.

					•	The Preserve Spot Colors check box keeps any spot colors you have defined intact. Leave this selected.

					6.	Click OK.

						The next step is to set the transparency options in the Document Setup dialog box.

					7.	Choose File⇒Document Setup.

						From the Transparency section in the middle of the dialog box, click the Preset drop-down list and select the Low, Medium, High, or Custom option. Select the Low option for onscreen viewing, the Medium option for printers and copiers, or the High option for press quality. To control more settings, click the Custom button to the right of the drop-down list.

					8.	Click OK.

				[image: tip.eps]	If you customize settings regularly, choose Edit⇒Transparency Flattener Presets to create and store your own presets.

				You can apply the flattening in several ways. Here are three simple methods:

				[image: check.png] Select the objects that require flattening and choose Object⇒Flatten Transparency. Select a default setting or a custom preset (that you created) from the Preset drop-down list and click OK.

				[image: check.png] Choose File⇒Print and select Advanced from the list of print options on the left. Select a preset from the Overprint and Transparency Flattener options. If you used the Attributes panel to create overprints (for trapping used in high-end printing), make sure to preserve the overprints.

				
					
				
				[image: remember.eps]		Overprints aren’t preserved in areas that use transparency.

				[image: check.png] Choose File⇒Save As and choose Illustrator EPS. In the Transparency section of the EPS Options dialog box, choose a flattening setting from the Preset drop-down list. If your transparency options are grayed out, your file has no transparency.

				Using the Flattener Preview panel

				If you want to preview your flattening, open the Flattener Preview panel by choosing Window⇒Flattener Preview.

				The Flattener Preview panel doesn’t apply flattening, but it shows you a preview based on your settings. Click the Refresh button and choose Show Options from the panel menu. Test various settings without flattening the file. Experiment with different settings and then save your presets by selecting Save Transparency Flattener Preset from the panel menu. You can access the saved settings in the Preset drop-down list in the Options dialog boxes that appear when you save a file in EPS format or in the Document Setup dialog box.

				To update the preview, click the Refresh button after making changes.

				[image: tip.eps]	Zoom in on artwork by clicking in the Preview pane. Scroll the artwork in the Preview pane by holding down the spacebar and dragging. Zoom out by Alt-clicking (Windows) or Option-clicking (Mac).

				Printing from Illustrator

				Printing from Illustrator gives you lots of capabilities, such as printing composites to separations and adding printer’s marks.

				To print your illustration, follow these steps:

					1.	Choose File⇒Print.

					2.	In the Print dialog box that appears, select a printer if one isn’t already selected.

					3.	If the PPD isn’t selected, select one from the PPD (Postscript Printer Description) drop-down list.

						A PPD is a printer description file. Illustrator needs one in order to determine the specifics of the PostScript printer you’re sending your file to. This setting lets Illustrator know whether the printer can print in color, the paper size it can handle, and its resolution, as well as many other important details.

					4.	Choose from other options.

						For example, use the General options section to pick pages to print. In the Media area, select the size of the media you’re printing to. In the Options area, choose whether you want layers to print and any options specific to printing layers.

					5.	Click the Print button to print your illustration.

				That’s it. Although printing illustrations can be quite simple, the following list highlights some basic points to keep in mind as you prepare one for printing:

				[image: check.png] Print a composite: A composite is a full-color image, where all inks are applied to the page (and not separated onto individual pages — one apiece for cyan, magenta, yellow, and black). To ensure that your settings are correct, click Output in the print options pane on the left  side of the Print dialog box and select Composite from the Mode drop-down list.

				[image: check.png] Print separations: To separate colors, click Output in the print options pane on the left side of the Print dialog box; from the Mode drop-down list, choose the Separations (Host-Based) option. Select the In-RIP Separations option only if your service provider or printer asks you to. Other options to select from are described in this list:

					•	The resolution is determined by your PPD, based on the dots per inch (dpi) in the printer description. You may have only one option available in the Printer Resolution drop-down list.

					•	Select the Convert Spot Colors to Process check box to make your file 4-color.

					•	Click the printer icons to the left of the listed colors to turn off or on the colors you want to print.

				[image: check.png] Printer’s marks and bleeds: Click Marks and Bleeds in the print options pane on the left side of the Print dialog box to turn on all printer’s marks, or just select the ones that you want to appear.

						Specify a bleed area if you’re extending images beyond the trim area of a page. If you don’t specify a bleed, the artwork stops at the edge of the page and doesn’t leave a trim area for the printer.

				[image: tip.eps]	After you create a good set of options specific to your needs, click the Save Preset button (which is the disk icon to the right of the Print Preset drop-down list). Name your presets appropriately; when you want to use a particular preset, select it from the Print Preset drop-down list at the top of the Print dialog box for future print jobs.
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				Chapter 1: Exploring New Features in Photoshop CS6

				In This Chapter

				[image: check.png] Using the new, darker interface

				[image: check.png] Taking advantage of text styles

				[image: check.png] Getting creative with new brush tools

				[image: check.png] Discovering new layer organizational features

				[image: check.png] Exploring new and improved 3D features

				Adobe developers added numerous new features to Photoshop CS6. Many of these features are obvious as soon as you launch the product, but some are performance improvements that make certain tasks — such as warp, blur, and lighting effects — much faster. Two features, the Contact Sheet and the PDF presentation functionality, have returned after being absent (and missed greatly) in previous versions. Some of the new features are covered in this chapter, but many are integrated throughout the other chapters in this minibook.

				Keep in mind that probably over 50 new features and production improvements have been added to Photoshop CS6. Look throughout this minibook for other references to these new features, or find them easily by choosing Window⇒Workspace⇒New in CS6. When you open this workspace, new features are highlighted throughout the menu applications to help you to identify them quickly.

				Using the New Darker Interface

				If you’re presently a Photoshop user, you only have to launch Photoshop CS6 to know that it’s very different. Don’t let the dark interface that you see in Figure 1-1 confuse you; this is Adobe’s way of creating consistency between Photoshop and Adobe’s other image-editing applications, such as Lightroom and After Effects. Almost all the tools and features are exactly where you expect them to be, along with some new ones.

					

				
					Figure 1-1:  The new dark interface in Adobe Photoshop CS6.

				

					[image: 9781118168608-fg040101.tif]

				[image: tip.eps]	If you would like to change the workspace color, you can choose Edit⇒Preferences⇒Interface (Windows) or Photoshop⇒Preferences⇒Interface (Mac OS), and change the Color and Appearance options in the Preference window. Although your color choices are relatively limited for the workspace — grey, grey, or a different shade of grey — you do have a little more customization control in the options for Standard Screen Mode, Full Screen with Menus, and Full Screen. Using these options, you can change the screen area between the image area and the start of the tools and panels. (See Figure 1-2.)

					

				
					Figure 1-2: You can change the color of your workspace as well as the screen area behind your image.

				

					[image: 9781118168608-fg040102.eps]

				Getting in Style with Text

				The Photoshop text controls have taken a while to catch up to other applications such as InDesign and Illustrator, but now you have the ability to create and manage paragraph and character styles like never before right in Adobe Photoshop. Follow the steps defined in the next section carefully to take advantage of the style controls.

				Creating a paragraph style in Photoshop

				Paragraph styles save the attributes of the text, such as font style, size, and color, and also paragraph attributes, such as leading and the space before and after paragraphs, to name a few.

				Most people find it easier to create styles by first taking a line or paragraph of text and experimenting with the text font, size, spacing, and so on. When they’re happy with the look and feel of the text, they can then save the attributes as a style. To create a new paragraph style, follow these steps:

					1.	Open any image, and then select the Type tool from the Tools panel.

					2.	Click and drag a new text area on the Photoshop artboard.

					3.	Create a paragraph of text. 

						If you don’t know what to type, you can find some samples of text in Photoshop files at the CS6 For Dummies website at www.agitraining.com/dummies. Use the text options at the top of the workspace if you want to change the text size, color font, and more. You can read more about changing text attributes in Chapter 9 of this minibook.

					4.	With the Text tool still selected, click and drag to select the text, or place the active cursor anywhere in the text.

					5.	From the Window menu, choose Paragraph Styles.

						The Paragraph Styles panel appears.

					6.	From the Panel menu, choose New Paragraph Style, as shown in Figure 1-3. You can also click the Add New Style button at the bottom of the Paragraph Styles panel.

						A new style is added to the Paragraph Styles panel.

					7.	Double-click the style that you added to the Paragraph Styles panel.

						The Paragraph Style Options dialog box appears. Notice that the  attributes that you applied to your text are recognized in the saved style.

					

				
					Figure 1-3:  Click the Panel menu in the Paragraph Styles panel and choose New Paragraph Style.

				

					[image: 9781118168608-fg040103.eps]

					8.	In the Paragraph Style Options dialog box, change the name to Header.

					9.	Click the Color swatch at the bottom, as shown in Figure 1-4, and then change the color by using the Color Picker that appears and click OK. 

					10.	Click OK again to close the Paragraph Style Options window.

					

				
					Figure 1-4: Change style attributes by using the Paragraph Style Options dialog box.

				

					[image: 9781118168608-fg040104.eps]

				Creating a character style in Photoshop

				By creating a character style, you can save the attributes of the text only, leaving out attributes for paragraphs such as leading and paragraph space before and after, indents, and so on. Character styles are useful when you want to make only selected words boldface or italic.

				To create a character style, follow these steps:

					1.	Using the Type tool, select a word in the text that you created in the previous section.

					2.	Modify some of the attributes of the text — change the text to bold or italic — by using the Options bar at the top of the workspace.

					3.	Choose Windows⇒Character Styles to open the Character Style panel.

					4.	Click the Create New Character Style button at the bottom of the Character Style panel.

					5.	Double-click the Character Style 1 that was created. 

						The Character Style Options dialog box appears, as shown in Figure 1-5.

					

				
					Figure 1-5: Double-click a character style in the Character Style panel to see and change its options.
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					6.	Change the Style name to Bold and click OK.

				Keep in mind that after you associate text with a paragraph style or a character style, you can apply that style to other text by highlighting that text and clicking the style name in the panel. When you want to make changes to the styles themselves, double-click the Paragraph or Character style to open the style options, make changes, and all instances will be automatically updated.

				Overriding and redefining styles

				If you look at the Paragraph Style and Character Style panels, as shown in Figure 1-6, you see the following options at the bottom:

				[image: check.png] Clear Override: By clicking the Override button, you can eliminate all the manual attributes that you may have applied intentionally or otherwise to the selected text. This would include attributes that are different than those specified in the style that has been applied to this text.

				[image: check.png] Redefine Style: By clicking the Redefine Style button, you can merge the manual attribute changes that you’ve made with the existing style. This feature is helpful when you decide that the spacing just isn’t working out or you quickly want to change colors.

				[image: check.png] Create New Style: Creates a new style. If you select this button when you have text selected, a new style named Paragraph Style is created. The attributes that have applied to the selected text are automatically recorded as part of that style. If you would like to see the Create New Style dialog box, so that you can more easily rename and investigate text attributes, hold down the Alt (Windows) or Option (Mac OS) key when you press this button.

				[image: check.png] Delete Style: Deletes the selected style.

					

				
					Figure 1-6: You can override manually applied styles or redefine your present style to update a saved style with new attributes.
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				When you select text, a plus sign (+) to the right of the style name in the Paragraph Style or Character Style panel indicates that you manually applied an attribute to the text. To eliminate that override, simply click the Clear Override button.

				If you want to merge your manual attribute changes with the current Paragraph or Character style, click the Redefine (Paragraph or Character) Style button.

				Working with the New and Improved Painting Features

				With each version, Photoshop adds more tools and features that allow you to paint and create with more flexibility.

				In Photoshop CS6, several new brush tips were added — the Erodible, Airbrush, and Static tips are accessible in the Brush panel, as shown in Figure 1-7.

					

				
					Figure 1-7: New brush tips add to your painting capabilities.
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				You can use these new brush tips by following these steps:

					1.	Experiment with a new blank document by choosing File⇒New and selecting Default Photoshop Size from the Preset drop-down window. Then press OK. Leave as is.

					2.	When the artboard appears, select the Brush tool from the Tools panel, and then choose Window⇒Brushes.

					3.	Make sure that Brush Tip Shape is selected in the top-left side of the panel. Then scroll to the bottom of the Brush Tip window and select one of the Erodible brushes.

						Erodible brushes let you wear your tip down as you use it, just like a pencil! If you want the effect to soften, or erode more, keep the softness down at a lower value. If you want to go back to the uneroded tip, press the Sharpen Tip button at any time.

					4.	Experiment with the Erodible brush and its settings by sketching with an erodible brush tip selected from the Brushes panel. Once in a while, press the Sharpen Tip button to resharpen the brush tip and start painting again. Change the softness to see how that setting can affect the tip, as well as the tip size.

						If you want to try additional tips such as Airbrush and Static, simply hover over the brush tips to identify those brush tips. Unfortunately you cannot view brush tips in a list. Find out more about painting and editing tools in Chapter 8 of this minibook.

				Discovering New Layer Features

				Whether or not you’re a power Photoshop user, you’ll be happy to see the layer improvements that have been added to Photoshop CS6. Now you can search for layers by using the new filter capabilities and apply styles to entire groups of layers. Also, shape layers are now called Vector layers.

				Applying styles to groups

				You can now simultaneously apply drop shadows, beveled edges, glows, and more to multiple layers by applying styles to layer groups. Follow these steps to give this a try:

					1.	Start with a new file by choosing File⇒New. Select the Preset for the Default Photoshop Size, and then click OK.

					2.	Click and hold on the Shape tool and select the hidden Custom Shape tool.

					3.	From the Options bar, click and hold on the Shape drop-down list, as shown in Figure 1-8, and select any shape.

						In this example, we selected the Flower 5.

					

				
					Figure 1-8: Click and hold on the Shape drop-down list to select a custom shape.

				

					[image: 9781118168608-fg040108.tif]

					4.	Click and drag the flower shape anywhere out on the artboard.

						This step creates a layer. In the next few steps, you duplicate the new layer. In Photoshop CS6, a layer created from a vector shape is called a Vector layer and is designated by a little icon in the lower-right corner of the layer thumbnail, as shown in Figure 1-9.

					

				
					Figure 1-9: Note that Shape layers are now referred to as Vector layers.
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					5.	Select the Move tool and hold down your Alt (Windows) or Option (Mac OS) key and click the flower shape that you created on the artboard.

					6.	With the Alt/Option key still pressed, drag the flower to another location on the artboard.

						You have duplicated the Vector layer. 

					7.	Repeat the steps so that you have three Vector layers, as shown in Figure 1-10.

						Don’t worry about the position for this exercise — you can find out much more about working with layers in Chapter 9 of this minibook.

						Note: Keep in mind that if you make a mistake at any time that you can step backward (Undo) multiple times in Photoshop by pressing Alt+Ctrl+Z (Windows) or Option+Command+Z (Mac OS).

					8.	Select the topmost layer in the Layers panel by clicking it in the Layers panel, and then hold down the Shift key and click the bottom Vector layer (do not shift-click on the Background layer) to select all three of the Vector layers.

					9.	Press Ctrl+G (Windows) or [image: maccmd]+G (Mac OS) to Group all three layers into one folder.

					

				
					Figure 1-10: Duplicate the shape layer so that you have three vector layers.
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					10.	Click and hold on the Add a Layer Style button (fx) at the bottom of the layers panel and select Drop Shadow, as shown in Figure 1-11.

					11.	When the Layer Style window appears, click the artboard to move the drop shadow visually behind the shapes that you created.

						You can change any other options that you want, too, but the point of this exercise is to show you how you can now apply a layer style to an entire group of layers, saving you lots of time and helping you keep your layers consistent.

					

				
					Figure 1-11:  With the group selected select the Drop Shadow layer style.
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					12.	When you’re finished positioning the drop shadow, click OK.

						Notice that Effects now appears underneath your group. You can now turn off and on the visibility by clicking the Eyeball icon to the left of Effects, or double-click Drop Shadow to edit the style further.

				Filters to help you search layers

				After you start working with layers, you may discover that you have so many that you can’t find the layer that you need when you want it. Fortunately Adobe has provided you help by adding a filter option to the layers panel. You can see it in Figure 1-12.

				To use this filter, simply click on Kind. Note that you can find a layer based upon several properties:

				[image: check.png] Kind: Options for the types of layers are selectable to the right of the drop-down list.

				[image: check.png] Name: Enter a name for the layer in the text box that appears when you select this option.

				[image: check.png] Effect: Select the effect applied to the layer from the drop-down list that appears when this option is selected.

				[image: check.png] Mode: This option allows you to select a layer based upon its blending mode.

				[image: check.png] Attribute: This option allows you to find a layer based upon its attributes, such as whether it is a layer mask, whether it is locked or unlocked, and more.

				[image: check.png] Color: If you add color to a layer (to help you organize your layers), you can find all colored layers by using this option.

					

				
					Figure 1-12: There is no excuse for not finding your layers with the new layer filter feature.
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				You can find out more about layers in Chapter 9 of this minibook.

				Exploring the New and Improved 3D Features

				Adobe developers recognized that many new users weren’t quite sure how to take advantage of the incredible 3D features available in Photoshop. They addressed this dilemma by adding functionality that automatically converts the workspace to the 3D workspace as soon as a user opens any 3D file. This feature helps you find the tools easily and get right to work.

				In this section, you find out about some of the new 3D features. However,  be aware that the scope of this book doesn’t leave room to look into all  the capabilities that you can use. Look at the For Dummies site at www. agitraining.com/dummies to find online tutorials and references that will help you maximize this feature.

				Adobe developers have made many improvements to the Photoshop CS6 3D capabilities. Keep in mind that you cannot only create 3D objects in Photoshop, but by choosing File⇒Open, you can also open many existing 3D files right in Photoshop, including: .obj, .dae, .3Ds, .U3d, and more.

				The following steps show you how to convert a 2D object to 3D so that you can see the new and improved workspace that has been added to Photoshop CS6. Keep in mind that you must have a video card and driver capable of using 3D in order to experiment in this section. If you want the latest requirements, go to www.adobe.com and type adobe +3d +“video card” into the Search text box. At this time of writing, the online requirements haven’t been updated for Photoshop CS6.

					1.	Choose Edit⇒Preferences⇒Performance (Windows) or Photoshop⇒Preferences⇒Performance (Mac OS) and select the Use Graphics Processor check box in the Graphics Processor Settings section. 

						If this check box is grayed out, you can’t go into the 3D workspace at this time.

					2.	Open any image in Photoshop CS6. Make sure that the image is made up of a layer, not a Background. If you see Background in the Layers panel, double-click it and click OK to convert it into Layer 0.

						Note: You can also find images to use at the For Dummies site located at www.agitraining.com/dummies.

					3.	Choose 3D from the Windows menu.

						The 3D panel appears.

					4.	Select the Mesh from Preset radio button, and then select a shape from the drop-down list.

						In this example, we selected Cube.

					5.	Click Create to see your image wrapped around a cube shape.

					6.	Experiment with the 3D tools!

						You can now take advantage of the 3D tools available on the Options bar, as shown in Figure 1-13. Using these tools, you can reposition your 3D object, spin it, and change the camera view by using the 3D tools available in the Photoshop 3D Workspace. Note that if you do not see the 3D options, switch to the Move tool.

					

				
					Figure 1-13:  Use the tools in the 3D workspace to reposition the 3D object or change its camera view.
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				Chapter 2: Getting Into  Photoshop CS6 Basics

				In This Chapter

				[image: check.png] Discovering the Photoshop tools

				[image: check.png] Navigating your work area

				[image: check.png] Changing screen modes

				[image: check.png] Performing basic tasks in Photoshop CS6

				Navigating the work area in Photoshop can be slightly overwhelming, especially if you’ve never worked in a program that relies so heavily on panels. In this chapter, we introduce you to the Photoshop CS6 work area and tools. You also find out how to neatly organize and hide panels. To top it all off, you also discover how to do basic tasks, such as open, crop, and save an image.

				Getting to Know the Tools

				You use tools to create, select, and manipulate objects in Photoshop CS6. When you open Photoshop, the Tools panel appears along the left edge  of the workspace (see Figure 2-1), and panels appear on the right side of  the screen. (We discuss panels in the later section “Navigating the Work Area.”)

				[image: tip.eps]	In the Tools panel, look for a tooltip when you hover the cursor over any one of the tools. Following the tool name is a letter in parentheses, which is the keyboard shortcut you can use to access that tool. Simply press the Shift key along with the key command you see to access any hidden tools. In other words, pressing P activates the Pen tool, and pressing Shift+P rotates through the hidden tools under the Pen tool. When you see a small triangle in the lower-right corner of the tool icon, you know that the tool contains hidden tools.

				Table 2-1 lists the Photoshop tools, describes what each one is used for, and specifies in which chapter you can find more information about each one.

					

				
					Figure 2-1:  The Photoshop CS6 workspace includes the Tools panel.
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		[image: /Table tb040201a]

		[image: /Table tb040201b]

				
				
				[image: tip.eps]	Looking for the Magic Wand tool? Click and hold the Quick Selection tool in the Tools panel to access it.

				Navigating the Work Area

				Navigating in Photoshop isn’t much different from getting around in  other Adobe applications. All Adobe applications make extensive use of panels. In the following sections, we cover the highlights of navigating in Photoshop.

				Docking and saving panels

				Panels, panels everywhere — do you really need them all? Maybe not just yet, but as you increase your skill level, you’ll start to take advantage of more of those Photoshop panels. Panels give you easy access to important functions. Book I, Chapter 3 provides a lot of basic information about using panels in the Adobe Creative Suite, so check out that chapter if you need a refresher on using panels. We add only a few topics here that are specific to using the panels in Photoshop.

				[image: remember.eps]	When you work in Photoshop, keep in mind these two key commands:

				[image: check.png] Press Tab to switch between hiding and showing the tools and panels.

				[image: check.png] Press Shift+Tab to hide the panels, leaving only the Tools panel visible.

				If you find that you’re always using the same panels, hide the panels you don’t need and arrange the others onscreen where you want them. Then follow these steps to save that panel configuration:

					1.	Choose Window⇒Workspace⇒New Workspace.

						The New Workspace dialog box appears.

					2.	Name your workspace and click Save.

					3.	Any time you want the panels to return to your saved locations, choose Window⇒Workspace⇒Name of Workspace.

						Name of Workspace is the name you supplied in Step 2.

				[image: tip.eps]	Choose Window⇒Workspace⇒Reset Essentials to restore the panels to the order they were in after the initial installation.

				Taking advantage of workspace features

				Photoshop includes default workspaces that you can take advantage of to streamline workspaces and open the panels you need for specific tasks. You can use some of these workspaces for photography, painting, or design, for example.

				Increase your work area by turning panels into icons, as shown in Figure 2-2. Do so by either right-clicking the tab of a panel and selecting Collapse to Icons or clicking double arrows.

					

				
					Figure 2-2: Turn panels into icons.
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				Zooming in to get a better look

				Images that look fine at one zoom level may look extremely bad at another. You’ll zoom in and out quite often while working on images in Photoshop. You can find menu choices for zooming on the View menu; a quicker way to zoom is to use the keyboard commands listed in Table 2-2.

				Table 2-2	Zooming and Navigation Keyboard Shortcuts

				
					
						
								
								Command

							
								
								Windows Shortcut

							
								
								Mac Shortcut

							
						

						
								
								Actual size

							
								
								Alt+Ctrl+0 (zero)

							
								
								[image: maccmd]+1

							
						

						
								
								Fit in window

							
								
								Ctrl+0 (zero)

							
								
								[image: maccmd]+0 (zero)

							
						

						
								
								Zoom in

							
								
								Ctrl++ (plus sign) or Ctrl+spacebar

							
								
								[image: maccmd]++ (plus sign) or [image: maccmd]+spacebar

							
						

						
								
								Zoom out

							
								
								Ctrl+– (minus) or Alt+spacebar

							
								
								[image: maccmd]+– (minus) or Option+spacebar

							
						

						
								
								Hand tool

							
								
								Spacebar

							
								
								Spacebar

							
						

					
				

				This list describes a few advantages of working with the Zoom tool to get a better look at your work:

				[image: check.png] 100 percent view: Double-clicking the Zoom tool in the Tools panel gives you a 100 percent view. Do it before using filters to see a more realistic result of making changes.

				[image: check.png] Zoom marquee: Drag from the upper-left corner to the lower-right corner of the area you want to zoom to. While you drag, a marquee appears; when you release the mouse button, the marqueed area zooms to fill the image window. The Zoom marquee gives you much more control than just clicking the image with the Zoom tool. Zoom out again to see the entire image by pressing Ctrl+0 (Windows) or [image: maccmd]+0 (Mac). Doing so fits the entire image in the viewing area.

				[image: tip.eps]	✦	Keyboard shortcuts: If a dialog box is open and you need to reposition or zoom to a new location on an image, you can use the keyboard commands without closing the dialog box.

				[image: check.png] A new window for a different look: Choose Window⇒Arrange⇒New Window to create an additional window for the frontmost image. This technique is helpful when you want to see the entire image (say, at actual size) to see the results as a whole yet zoom in to focus on a small area of the image to do some fine-tuning. The new window is linked dynamically to the original window so that when you make changes, the original and any other new windows created from the original are immediately updated.

				[image: check.png] Cycle through images: Press Ctrl+Tab (Windows) or [image: maccmd]+Tab (Mac) to cycle through open images.

				Choosing Your Screen Mode

				You have a choice of three screen modes in which to work. Most users start and stay in the default (standard screen) mode until they inadvertently end up in another. The modes are accessible by clicking and holding Screen Mode, located at the bottom of the Tools panel, as shown in Figure 2-3.

					

				
					Figure 2-3: Change your screen mode.
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				[image: check.png] Standard Screen Mode: In this typical view, an image window is open, but you can see your desktop and other images open behind it.

				[image: check.png] Full Screen Mode with Menu Bar: In this view, the image is surrounded, to the edge of the work area, with neutral gray. Working in this mode prevents you not only from accidentally clicking out of an image and leaving Photoshop but also from seeing other images behind the working image. 

				[image: check.png] Full Screen Mode: A maximized document window fills all available space between docks and resizes when dock widths change.

				Getting Started with Basic Tasks in Photoshop CS6

				Unless you use Photoshop as a blank canvas for painting, you may rarely create a new file in Photoshop. The reason is that you usually have a source image you start with that may have been generated by a scanner, digital camera, or stock image library.

				The following sections show you how to open an existing image file in Photoshop, create a new image (if you want to use Photoshop to paint, for example), crop an image, and save an edited image.

				Opening an image

				You can open an existing Photoshop image in one of several ways:

				[image: check.png] Choose File⇒Open, select the file in the Open dialog box, and then click the Open button.

				[image: check.png] Choose File⇒Browse in Bridge. By selecting Browse in Bridge instead of Open, you launch the Adobe Bridge application. Read more about Adobe Bridge later in this section and also in Book I, Chapter 5.

				[image: check.png] Double-click an image in the Mini Bridge panel. 

				[image: remember.eps]	Photoshop can open a multitude of file formats, even if the image was created in another application, such as Illustrator or another image-editing program. However, you have to open the image in Photoshop by choosing File⇒Open or, using Adobe Bridge, by selecting an image and dragging it to the Photoshop icon on the taskbar (Windows) or Dock (Mac). If you double-click an image file (one that wasn’t originally created in Photoshop, or from different versions) in a folder, the image may open only in a preview application.

				If you’re opening a folder of images that you want to investigate first, choose File⇒Browse to open Adobe Bridge, the control center for Adobe Creative Suite. You can use Adobe Bridge to organize, browse, and locate the assets you need to create your content. Adobe Bridge keeps available, for easy access, native AI, INDD, PSD, and Adobe PDF files as well as other Adobe and non-Adobe application files.

				You can access the standalone Adobe Bridge application from all applications in the Creative Suite by choosing File⇒Browse in Bridge. Use the Bridge interface to view images as thumbnails and look for metadata information. For a condensed version of Bridge, click the MB icon on the Application bar.

				Discover Camera Raw

				If you haven’t discovered the Camera Raw capabilities in Adobe Photoshop, you’ll want to give them a try. The Camera Raw format is available for image capture in many cameras. Simply choose the format in your camera’s settings as Raw instead of JPEG or TIFF. These Raw files are a bit larger than standard JPEG files, but you capture an enormous amount of data with the image that you can retrieve after opening. (See www.adobe.com for a complete list of cameras that support Camera Raw.)

				A Camera Raw file contains unprocessed picture data from a digital camera’s image sensor, along with information about how the image was captured, such as camera and lens type, exposure settings, and white balance setting. When you open the file in Adobe Photoshop CS6, the built-in Camera Raw plug-in interprets the Raw file on your computer, making adjustments for image color and tonal scale.

				When you shoot JPEG images with your camera, you’re locked into the processing done by your camera, but working with Camera Raw files gives you maximum control over images, such as controlling their white balance, tonal range, contrast, color saturation, and image sharpening. Cameras that can shoot in Raw format have a setting on the camera that changes its capture mode to Raw. Rather than write a final JPEG file, a Raw data file is written, which consists of black-and-white brightness levels from each of the several million pixel sites on the imaging sensor. The actual image hasn’t yet been produced, and unless you have specific software, such as the plug-in built into Adobe Photoshop, opening the file can be difficult, if not impossible.

				To open a Camera Raw file, simply choose File⇒Browse. Adobe Bridge opens, and you see several panels, including the Folders, Content, Preview, and Metadata panels. In the Folders panel, navigate to the location on your computer where you’ve saved Camera Raw images; thumbnail previews appear in the Content panel. Think of Camera Raw files as photo negatives. You can reprocess them at any time to achieve the results you want.

				Right-click (Windows) or Control-click (Mac) a JPEG or TIFF file and choose Open in Camera Raw from the contextual menu. This is a great way to experiment with all the cool features available with this plug-in, but your results aren’t as good as if you used an actual Raw file.

				If Adobe Photoshop CS6 doesn’t open your Raw file, you may need to update the Raw plug-in. (See www.adobe.com for the latest plug-in.) The plug-in should be downloaded and placed in this location in Windows: C:\Program Files\Common Files\Adobe\Plug-Ins\CS6\File Formats. On the Macintosh, place the plug-in here: Library\Application Support\Adobe\Plug-Ins\CS6\File Formats.



				Creating a new file

				If you’re creating a new file, you may be doing so to create a composite of existing files or to start with a blank canvas because you’re supercreative.

				For whatever reason, note that when you choose File⇒New, you can choose from a multitude of basic format choices on the Preset menu. They range from basic sizes and resolutions, such as U.S. Paper or Photo, to other final output options such as Web, Mobile Devices, or Film.

				Keep in mind that you’re determining not only size but also resolution in the new file. If it will contain images from other files, make sure that the new file is the same resolution. Otherwise, you may see unexpected size results when cutting and pasting or dragging images into the new file. Choose Image⇒Image Size to see the document dimensions.

				Cropping an image

				A simple but essential task is to crop an image. Cropping means to eliminate all parts of the image that aren’t important to its composition.

				Cropping is especially important in Photoshop. Each pixel, no matter what color, takes up the same amount of information, so cropping eliminates unneeded pixels and saves on file size and processing time. For that reason, you should crop images before you start working on them.

				You can crop an image in Photoshop CS6 in two ways:

					[image: check.png] [image: 9781118168608-ma080.tif] Use the Crop tool.

				[image: check.png] Select an area with the Marquee tool and choose Image⇒Crop.

				To crop an image by using the Crop tool, follow these steps:

					1.	Press C to access the Crop tool.

						Make sure that the preset (in the upper-left corner of the control panel) is set to Unconstrained or to a specific size in the Presets drop-down list, as shown in Figure 2-4.

					

				
					Figure 2-4: Select the Crop tool preset before you click and drag.

				

					[image: 9781118168608-fg040204.tif]

					2.	Click and drag over the area of the image you want to keep.

					3.	If you need to adjust the crop area, drag the handles in the crop-bounding area.

					4.	When you’re satisfied with the crop-bounding area, double-click in the center of the crop area or press the Return or Enter key to crop the image.

					5.	If you want to cancel the crop, press the Esc key.

				[image: tip.eps]	Ever scan in an image that ends up crooked? When using the Crop tool, if you position the cursor outside any handle, a rotate symbol appears. Drag the crop-bounding area to rotate it and line it up the way you want it cropped. When you press Return or Enter, the image straightens out.

				Using grids as you crop

				As a default, a three-row and three-column grid appears after you click  and drag over an area with your Crop tool. This grid can be used as a guide to help you create more dynamically cropped images. Images whose points of interest appear on the intersections of this grid, or divide an image into the sections of the grid are generally considered to be more interesting. (This is the called the Rule of Thirds.) See the before (top) and after (bottom) images in Figure 2-5, and decide yourself whether you like the use of the grid.

				If you prefer to change or turn off the overlay, select the Never Show Overlay from the View drop-down list, as shown in Figure 2-6. Keep in mind that you must have already clicked and dragged out your crop area before you can make changes to the overlay.

				Saving images

				Save an image file by choosing File⇒Save. If you’re saving the file for the first time, the Save As dialog box appears. Notice in the Format drop-down list that you have plenty of choices for file formats. (File formats are discussed in more detail in Chapter 10 of this minibook.) You can always play it safe by choosing the native Photoshop (PSD) file format, which supports all Photoshop features. Choosing certain other formats may eliminate layers, channels, and other special features.

				Many users choose to save a native Photoshop file as a backup to any other file format. Be sure to have a backup or an original file saved as a native Photoshop (PSD) file when you start taking advantage of layers and other outstanding Photoshop elements. As a Creative Suite user, keep in mind that you can use the native file format for Photoshop in all other Creative Suite applications.

					

				
					Figure 2-5:  Use of the Rule of Thirds overlay in the Crop tool.

				

					[image: 9781118168608-fg040205.eps]

					

				
					Figure 2-6: Select from a multitude of overlays to use as guides, or turn the overlay off.

				

					[image: 9781118168608-fg040206.tif]

			

			
		

	
		
			
				Chapter 3: Messing  with Mode Matters

				In This Chapter

				[image: check.png] Editing pixels in bitmap images

				[image: check.png] Understanding Photoshop image modes

				[image: check.png] Working in black and white, RGB, or CMYK

				Before diving into Photoshop, it helps if you understand color modes and the importance of color settings. No matter whether you’re producing a one-color newsletter, a full-color image, a website, or a video, this chapter can help you create much better imagery for all mediums.

				Working with Bitmap Images

				You may have already discovered that Photoshop works a little differently from most other applications. To create those smooth gradations from one color to the next, Photoshop takes advantage of pixels and anti-aliasing. Bitmap images (or raster images) are based on a grid of pixels. The grid is smaller or larger depending on the resolution you’re using. The number of pixels along the height and width of a bitmap image are the pixel dimensions of an image, measured in pixels per inch (ppi). The more pixels per inch, the more detail in the image.

				Unlike vector graphics (mathematically created paths), bitmap images can’t be scaled without losing detail. (See Figure 3-1 for an example of a bitmap image and a vector graphic.) Generally, you should use bitmap images at or close to the size you need. If you resize a bitmap image, it can become jagged on the edges of sharp objects. On the other hand, you can scale vector graphics and edit them without degrading sharp edges.

					

				
					Figure 3-1: Bitmap versus vector.

				

					[image: 9781118168608-fg040301.eps]

				Photoshop can work on both bitmap and vector art. (See the path line around the vector shape layer and notice that the path isn’t pixelated or broken down into a step pattern created by the pixels.) It gives you, as a designer, incredible opportunities when combining the two technologies.

				[image: tip.eps]	For information on changing and adjusting image resolution, see Chapter 6 of this minibook.

				Choosing the Correct Photoshop Mode

				Choose Image⇒Mode to view the image mode choices you can choose from. Selecting the right one for an image is important because each mode offers different capabilities and results. For example, if you choose Bitmap mode, you can work only in black and white. That’s it — no shades of color, not even gray. Most features are disabled in Bitmap mode, which is fine if you’re working on art for a black-and-white logo, but not for most images. If, instead, you work in RGB (Red, Green, Blue) mode, you have full access to Photoshop’s capabilities.

				Read on to see which image mode is best for your needs. When you’re ready to make your mode selection, open a file and choose Image⇒Mode to make a selection. You can read descriptions of each image mode in the following sections.

				[image: remember.eps]	Along with a description of each image mode, we include a figure showing the Channels panel set to that mode. A channel simply contains the color information in an image. The number of default color channels in an image depends on its color mode. For example, a CMYK image has at least four channels — one each for cyan, magenta, yellow, and black information. Grayscale has one channel. If you understand the printing process, think of each channel representing a plate (color) that, when combined, creates the final image.

				Bitmap

				Bitmap mode offers little more than the ability to work in black and white. Many tools are unusable, and most menu options are grayed out in this mode. If you’re converting an image to bitmap, you must convert it to grayscale first.

				Grayscale

				Use Grayscale mode, shown in Figure 3-2, if you’re creating black-and-white images with tonal values, specifically for printing to one color. Grayscale mode supports 256 shades of gray in 8-bit color mode. Photoshop can work with grayscale in 16-bit mode, which provides more information but may limit your capabilities when working in Photoshop.

					

				
					Figure 3-2: Grayscale supports  256 shades of gray.

				

					[image: 9781118168608-fg040302.tif]

				When you choose Image⇒Mode⇒Grayscale to convert to Grayscale mode, a warning message asks you to confirm that you want to discard all color information. If you don’t want to see this warning every time you convert an image to grayscale, select the option not to show the dialog box again before you click Discard.

				[image: tip.eps]	Using the Black & White adjustment is the best way to create a good grayscale image. Simply click and hold the Create New Fill or Adjustment Layer button at the bottom of the Layers panel and choose Black & White. Set the sliders to achieve the best black-and-white image, and then choose Image⇒Mode⇒Grayscale.

				Duotone

				Use Duotone mode when you’re creating a one- to four-color image created from spot colors (solid ink, such as Pantone colors). You can also use Duotone mode to create monotones, tritones, and quadtones. If you’re producing a two-color job, duotones create a beautiful solution to not having full color.

				[image: remember.eps]	The Pantone Matching System (PMS) helps keep printing inks consistent from one job to the next. By assigning a numbered Pantone color, such as 485 for red, you eliminate the risk of one vendor (printer) using fire engine red and the next using orange-red for your company logo.

				To create a duotone, follow these steps:

					1.	Choose Image⇒Mode⇒Grayscale.

					2.	Choose Image⇒Mode⇒Duotone.

					3.	In the Duotone dialog box, select Duotone from the Type drop-down list.

						Your choices range from monotone (one-color) up to quadtone (four-color). Black is assigned automatically as the first ink, but you can change it, if you like.

					4.	To assign a second ink color, click the white swatch immediately under the black swatch.

						The Color Picker appears, as shown in Figure 3-3.

					

				
					Figure 3-3:  Click the white swatch to open the Color Picker dialog box.

				

					[image: 9781118168608-fg040303.tif]

					5.	Click the Color Libraries button, and then select Pantone solid coated as the library.

					6.	Now comes the fun part: Type (quickly!) the Pantone or PMS number you want to access, and then click OK. If you type too slowly the incorrect number will appear.

						There’s no text field for you to enter the number, so don’t look for one. Just type the number while the Color Libraries dialog box is open.

						Try entering 300 to select PMS 300. You can already see that you’ve created a tone curve.

					7.	Click the Curve button to the left of the ink color to further tweak the colors.

					8.	Click and drag the curve to adjust the black in the shadow areas, perhaps to bring down the color overall. Then experiment with the results.

					9.	(Optional) If you like your duotone settings, store them by clicking the small Preset Options button to the right of the Preset drop-down list, as shown in Figure 3-4. Type a name into the Name text box, browse to a location on your computer, and then click Save.

					

				
					Figure 3-4: Save your duotone by clicking the Preset Options button.

					
				

					[image: 9781118168608-fg040304.tif]

				[image: tip.eps]		You can also use one of the presets that Adobe provides. Do this by selecting an option from the Presets drop-down menu at the top of the Duotone dialog box.

					10.	Click the Preset Options button to find your saved presets.

						Duotone images must be saved in the Photoshop Encapsulated PostScript (EPS) format in order to support the spot colors. If you choose another format, you risk the possibility of converting colors into a build of CMYK (Cyan, Magenta, Yellow, and Black).

					11.	Click OK when you’re finished.

				Index color

				Even if you don’t work in Index color, you probably have saved a file in this mode. Indexed Color mode (see Figure 3-5) uses a color lookup table (CLUT) to create the image.

					

				
					Figure 3-5:  Index color uses a limited number of colors to create an image.

				

					[image: 9781118168608-fg040305.eps]

				A CLUT contains all colors that make up an image, such as a box of crayons used to create artwork. If you have a box of only eight crayons that are used to color an image, you have a CLUT of only eight colors. Of course, your image would look much better if you used the 64-count box of crayons with the sharpener on the back, but those additional colors increase the size of the CLUT and the file size.

				The highest number of colors that can be in Indexed Color mode is 256. When saving web images, you often have to define a color table. We discuss the Save for Web feature (which helps you more accurately save an Index color image) in Chapter 10 of this minibook.

				[image: tip.eps]	Choose Image⇒Mode⇒Color Table to see the color table making up an image.

				RGB

				RGB (Red, Green, Blue) mode, shown in Figure 3-6, is the standard format you work in if you import images from a digital camera or scan images on a scanner. For complete access to features, RGB is probably the best color mode to work in. If you’re working on images for use on the web, color copiers, desktop color printers, and onscreen presentations, stay in RGB mode.

					

				
					Figure 3-6: RGB creates the image from red, green, and blue.

				

					[image: 9781118168608-fg040306.tif]

				[image: remember.eps]	If you’re having an image printed on a press (for example, if you’re having it professionally printed), it must be separated. Don’t convert images to CMYK mode until you’ve finished the color correction and you know that your color settings are accurate. A good print service may want the RGB file so that it can complete an accurate conversion.

				CMYK

				CMYK (Cyan, Magenta, Yellow, Black) mode is used for final separations for the press. Use a good magnifying glass to look closely at anything printed in color and you may see the CMYK colors that created it. A typical four-color printing press has a plate for each color and runs the colors in the order of cyan, magenta, yellow, and then black.

				[image: warning_bomb.eps]	Don’t take lightly the task of converting an image into this mode. You need to make decisions when you convert an image to CMYK, such as where to print the file and on which paper stock, so that the resulting image is the best it can be. Talk to your print provider for specifications that are important when converting to CMYK mode.

				LAB color

				The LAB (Lightness, A channel, and B channel) color mode is used by many high-end color professionals because of its wide color range. Using LAB, you can make adjustments to luminosity (lightness) without affecting color. In this mode, you can select and change an L (lightness or luminosity) channel without affecting the A channel (green and red) and the B channel (blue and yellow).

				LAB mode is also good to use if you’re in a color-managed environment and want to easily move from one color system to another with no loss of color.

				[image: tip.eps]	Some professionals prefer to sharpen images in LAB mode because they can select just the Lightness channel and choose Filter⇒Sharpen⇒Unsharp Mask to sharpen only the gray matter of the image, leaving the color noise-free.

				Multichannel

				Multichannel is used for many things; you can end up in this mode and not know how you got there. Deleting a channel from an RGB, a CMYK, or a LAB image automatically converts the image to Multichannel mode. This mode supports multiple spot colors.

				Bit depth

				You have more functionality in 16-bit and even 32-bit mode. Depending on your needs, you may spend most of your time in 8-bit mode, which is more than likely all you need.

				Bit depth, or pixel depth or color depth, measures how much color information is available to display or print each pixel in an image. Greater bit depth means more available colors and more accurate color representation in the digital image. In Photoshop, this increase in accuracy also limits some available features, so don’t use it unless you have a specific request or need for it.

				To use 16-bit or 32-bit color mode, you also must have a source to provide you with that information, such as a scanner or camera that offers a choice to scan in either mode.

			

			
		

	
		
			
				Chapter 4: Creating a Selection

				In This Chapter

				[image: check.png] Discovering the selection tools

				[image: check.png] Painting selections the easy way

				[image: check.png] Refining your selections

				[image: check.png] Keeping selections for later use

				[image: check.png] Using the Vanishing Point feature

				Photoshop is well known for its ability to create compositions and for its retouching capabilities. What you don’t want to see in a finished product is obvious retouching or a composition that looks contrived. (The exception is if you intend an image to be humorous, such as putting baby Joey’s head on Daddy’s body.)

				This is where a solid knowledge of the selection tools pays off. In this chapter, you try out several selection methods and see how to use the selection tools to make images look as though you haven’t retouched or edited them. Even if you’re an experienced Photoshop user, this chapter provides a plethora of tips and tricks that can save you time and help make your images look absolutely convincing.

				Getting to Know the Selection Tools

				You create selections by using selection tools. Think of selections as windows in which you can make changes to pixels. Areas not selected are masked, which means that they’re unaffected by changes, much like when you tape window and door frames before painting the walls. In this section, we briefly describe the selection tools and show you how to use them. You must be familiar with these tools in order to do anything in Photoshop.

				[image: remember.eps]	As with all Photoshop tools, the Options bar (viewed across the top of the Photoshop window) changes when you choose different selection tools. The keyboard commands you read about in this section exist on the tool Options bar and appear as buttons across the top.

					[image: 9781118168608-ma076.tif]	If you move a selection with the Move tool, pixels move as you drag, leaving a blank spot in the image. To clone a selection (to copy and move the selection at the same time), Alt+drag (Windows) or Option+drag (Mac) the selection with the Move tool.

				The Marquee tool

					[image: 9781118168608-ma077.tif]	The Marquee tool is the main selection tool; by that, we mean that you use it most often for creating selections. The exception, of course, is when a special situation calls for a special tool — the Lasso, Magic Wand, Quick Selection, or Refine Radius tool (located in the Refine Edge dialog box). Throughout this section, we describe creating (and then deselecting) an active selection area; we also provide you with tips for working with selections.

				The Marquee tool includes the Rectangular Marquee (for creating rectangular selections), Elliptical Marquee (for creating round or elliptical selections), and Single Row Marquee or Single Column Marquee tools (for creating a selection of a single row or column of pixels). You can access these other Marquee tools by holding down the default Rectangle Marquee tool in the Tools panel.

				To create a selection, select one of the Marquee tools (remember that you can press M), and then drag anywhere on your image. When you release the mouse button, you create an active selection area. When you’re working on an active selection area, whichever effects you choose are applied to the whole selection.

				To deselect an area, you have three choices:

				[image: check.png] Choose Select⇒Deselect.

				[image: check.png] Press Ctrl+D (Windows) or [image: maccmd]+D (Mac).

				[image: check.png] While using a selection tool, click outside the selection area.

				Creating rectangular and elliptical selections

				How you make a selection is important because it determines how realistic your edits appear on the image. You can use the following tips and tricks when creating both rectangular and elliptical selections:

				[image: check.png] Add to a selection by holding down the Shift key; drag to create a second selection that intersects the original selection (see the left image in Figure 4-1). The two selections become one big selection.

					

				
					Figure 4-1: You can add to and delete from selections.

				

					[image: 9781118168608-fg040401.eps]

				[image: check.png] Delete from an existing selection by holding down the Alt (Windows) or Option (Mac) key, and then drag to create a second selection that intersects the original selection where you want to take away from the original selection (shown on the right in Figure 4-1).

				[image: check.png] Constrain a rectangle or an ellipse to a square or circle by Shift+dragging; make sure that you release the mouse button before you release the Shift key. Holding down the Shift key makes a square or circle only when there are no other selections. (Otherwise, it adds to the selection.)

				[image: check.png] Make the selection from the center by Alt+dragging (Windows) or Option+dragging (Mac); make sure that you release the mouse button before releasing the Alt (Windows) or Option (Mac) key.

				[image: check.png] Create a square or circle from the center outward by Alt+Shift+dragging (Windows) or Option+Shift+dragging (Mac). Again, make sure that you always release the mouse button before releasing the modifier keys.

				[image: check.png] When making a selection, hold down the spacebar before releasing the mouse button to drag the selection to another location.

				Setting a fixed size

				If you’ve created an effect that you particularly like — say, changing a block of color in your image — and you want to apply it multiple times throughout, you can do so. To make the same selection multiple times, follow these steps:

					1.	With the Marquee tool selected, select Fixed Size from the Style drop-down list on the Options bar.

						You can also select Fixed Ratio from the Style drop-down list to create a proportionally correct selection not fixed to an exact size.

					2.	On the Options bar, type the Width and Height values into the appropriate text fields.

						You can change ruler increments by choosing Edit⇒Preferences⇒Units and Rulers (Windows) or Photoshop⇒Preferences⇒Units and Rulers (Mac).

					3.	Click the image.

						A selection sized to your values appears.

					4.	With the selection tool, drag the selection to the location you want selected.

				[image: tip.eps]	Shift+drag a selection to keep it aligned to a 45-degree or 90-degree angle.

				Making floating and nonfloating selections

				When you’re using a selection tool, such as the Marquee tool, your selections are floating by default, which means that you can drag them to another location without affecting the underlying pixels. You know that your selection is floating by the little rectangle that appears on the cursor. (See the left image in Figure 4-2.)

					

				
					Figure 4-2: The Float icon is used on the left, and the Move icon is used on the right.

				

					[image: 9781118168608-fg040402.eps]

				If you want to, however, you can move the underlying pixels. Using the selection tool of your choice, just hold down the Ctrl (Windows) or [image: maccmd] (Mac) key to temporarily access the Move tool; the cursor changes to a pointer with scissors, denoting that your selection is nonfloating. Now, when you drag, the pixel data comes with the selection (as shown on the right in Figure 4-2).

				[image: tip.eps]	Hold down Alt+Ctrl (Windows) or Option+[image: maccmd] (Mac) while using a selection tool and drag to clone (copy) pixels from one location to another. Add the Shift key, and the cloned copy is constrained to a straight, 45-degree, or 90-degree angle.

				The Lasso tool

					[image: 9781118168608-ma015.tif]	Use the Lasso tool for freeform selections (selections of an irregular shape). To use the Lasso tool, click and drag to create a path surrounding the area that you want to select. Be careful! If you don’t return to the starting point to close the selection before you release the mouse button, Photoshop completes the path by finding the most direct route back to your starting point.

				[image: tip.eps]	As with the Marquee tool, you can press the Shift key to add to a lasso selection and press the Alt (Windows) or Option (Mac) key to delete from a lasso selection.

				Hold down the Lasso tool to show the hidden Lasso tools:

				[image: check.png] Polygonal Lasso tool: Click a start point, and then click and release from point to point until you come back to close the selection.

				[image: check.png] Magnetic Lasso tool: Click to create a starting point, and then hover the cursor near an edge in your image. The Magnetic Lasso tool is magnetically attracted to edges; as you move the cursor near an edge, the Magnetic Lasso tool creates a selection along that edge. Click to manually set points in the selection; when you return to the starting point, click to close the selection.

				You may find that the Polygonal Lasso and the Magnetic Lasso tools make less-than-ideal selections. Take a look at the later section “Painting with the Quick Mask tool” for tips on making finer selections.

				The Quick Selection tool

					[image: 9781118168608-ma079.tif]	The Quick Selection tool lets you quickly “paint” a selection with a round brush tip of adjustable size. Click and drag, and then watch as the selection expands outward and automatically follows defined edges in the image. A Refine Edge command lets you improve the quality of the selection edges and visualize the selection in different ways for easy editing.

				Follow these steps to find out how you can take advantage of this tool:

					1.	Open a file that requires a selection.

						You can find sample images for Windows at C:\Program Files\Adobe\Adobe Photoshop CS6\Extras\Samples and for the Mac at Applications\Adobe\Adobe Photoshop CS6\Samples.

					2.	Select the Quick Selection tool.

					3.	Position the cursor over the area you want to select. Notice the brush size displayed with the cursor; click and drag to start painting the selection.

				[image: tip.eps]		You can adjust the size of the painting selection by pressing the left bracket key ([) to make the brush size smaller or the right bracket key (]) to make the brush size larger.

						By using the Add to Selection or Subtract from Selection buttons on the Options bar, you can paint more of the selection or deselect active areas. (See Figure 4-3.)

					

				
					Figure 4-3:  Use the Quick Selection tool to paint your selection.

				

					[image: 9781118168608-fg040403.tif]

				The Magic Wand tool

					[image: 9781118168608-ma014.tif]	The Magic Wand tool is particularly helpful when you’re working on an image of high contrast or with a limited number of colors. This tool selects individual pixels of similar shades and colors. Select the Magic Wand tool, click anywhere on an image, and hope for the best — the Magic Wand tool isn’t magic. You decide how successful this tool is. What we mean is that you control how closely matched each pixel must be in order for the Magic Wand tool to include it in the selection. You do so by setting the tolerance level on the Options bar.

				When you select the Magic Wand tool, a Tolerance text field appears on the Options bar. As a default, the tolerance is set to 32. When you click with a setting of 32, the Magic Wand tool selects all pixels within 32 shades (steps) of the color you clicked. If it didn’t select as much as you want, increase the value in the Tolerance text field (all the way up to 255). The number you enter varies with each individual selection. If you’re selecting white napkins on an off-white tablecloth, you can set the number as low as 5 so that the selection doesn’t leak into other areas. For colored fabric with lots of tonal values, you might increase the tolerance to 150.

				[image: tip.eps]	Don’t fret if you miss the entire selection when using the Magic Wand tool. Hold down the Shift key and click in the missed areas. If the tool selects too much, choose Edit⇒Undo (step backward) or press Ctrl+Z (Windows) or [image: maccmd]+Z (Mac), reduce the value in the Tolerance text field, and try again.

				Painting with the Quick Mask tool

				If you have fuzzy selections (fur, hair, or leaves, for example) or you’re having difficulty using the selection tools, the Quick Mask tool can be a huge help because it allows you to paint your selection uniformly in one fell swoop.

					[image: 9781118168608-ma098.tif]	To enter Quick Mask mode, create a selection, and then press Q. (Pressing Q again exits you from Quick Mask mode.) You can also click the Quick Mask button at the bottom of the Tools panel. If you have a printing background, you’ll notice that the Quick Mask mode, set at its default color (red), resembles something that you may want to forget: rubylith and amberlith. (Remember slicing up those lovely films with Exacto blades before computer masking came along?) In Quick Mask mode, Photoshop shows your image as it appears through the mask. The clear part is selected; what’s covered in the mask isn’t selected.

				[image: tip.eps]	Change the default red color of the mask by double-clicking the Edit in Quick Mask Mode button (at the bottom of the Tools panel). The tooltip says Edit in Standard Mode if you’re already in Quick Mask Mode. This opens the Quick Mask Options dialog box, shown in Figure 4-4.

					

				
					Figure 4-4: Change the color of the Quick Mask.

				

					[image: 9781118168608-fg040404.eps]

				To create and implement a quick mask, follow these steps:

					1.	Press Q to enter Quick Mask mode.

					2.	Press D to change the foreground and background color boxes to the default colors of black and white.

						3.	[image: 9781118168608-ma083.tif] Select the Brush tool and start painting with black in the clear area of the image in Quick Mask mode.

						It doesn’t have to be pretty; just get a stroke or two in there.

					4.	Press Q to return to Selection mode.

						You’re now out of Quick Mask mode. Notice that where you painted with black (it turned red in Quick Mask mode), the pixels are no longer selected.

					5.	Press Q again to reenter Quick Mask mode, and then press X.

						This step switches the foreground and background colors, giving you white in the foreground and black in the background.

					6.	With the Brush tool, paint several white strokes in the red mask area.

						The white strokes turn clear in Quick Mask mode.

					7.	Press Q to return to Selection mode.

						The area you painted white in Quick Mask mode is now selected.

				When you’re in Quick Mask mode, you can paint white over areas you want selected and black over areas you don’t want selected. When painting in Quick Mask mode, increase the brush size by pressing the ] key. Decrease the brush size by pressing the [ key.

				In Selection mode, your selection seems to have a hard edge; you can soften those hard edges by using a softer brush in Quick Mask mode. To make a brush softer, press Shift+[. To make a brush harder, press Shift+].

				Because Quick Mask mode makes selections based on the mask’s values, you can create a mask by selecting the Gradient tool and dragging it across the image in Quick Mask mode. When you exit Quick Mask mode, it looks as though there’s a straight-line selection, but the selection transitions the same as your gradient did. Choose any filter from the Filters menu and notice how the filter transitions into the untouched part of the image to which you applied the gradient.

				If you’re working in Quick Mask mode, choose Window⇒Channels to see that what you’re working on is a temporary alpha channel. See the later section “Saving Selections” for more about alpha channels.

				Manipulating Selections with Refine Selection

				After you master creating selections, you’ll find that working with the  selections — painting, transforming, and feathering them — can be easy and fun.

				Transforming selections

				Don’t deselect and start over again if you can just nudge or resize a selection. You can scale, rotate, and even distort an existing selection. Follow these steps to transform a selection:

					1.	Create a selection, and then choose Select⇒Transform Selection.

						You can use the bounding box to resize and rotate your selection:

					•	Drag the handles to make the selection larger or smaller. Drag a corner handle to adjust width and height simultaneously. Shift+drag a corner handle to size proportionally.

					•	Position the cursor outside the bounding box to see the Rotate icon; drag when it appears to rotate the selection. Shift+drag to constrain to straight, 45-degree, or 90-degree angles.

					•	Ctrl+drag (Windows) or [image: maccmd]+drag (Mac) a corner point to distort the selection, as shown in Figure 4-5.

					

				
					Figure 4-5: Distort, resize, and rotate a selection with the Transform Selection feature.

				

					[image: 9781118168608-fg040405.tif]

					2.	Press Enter or Return or double-click in the center of the selection area to confirm the transformation; press Esc to release the transformation and return to the original selection.

				Feathering

				Knowing how to retouch an image means little if you don’t know how to make the retouching discreet. If you boost the color using curves to the CEO’s face, do you want it to look like a pancake has been attached to his cheek? Of course not — that isn’t discreet (or wise). If you feather a selection (blur its edges) instead, you create a natural-looking transition between the selection and the background of the image.

				To feather an image, follow these steps:

					1.	Create a selection.

						For the nonfeathered image shown on top in Figure 4-6, we used the Elliptical Marquee tool to make a selection. We then copied the selection; created a new, blank image; and pasted the selection into the new image.

						To create the feathered image on the bottom in Figure 4-6, we used the Elliptical Marquee tool to select the same area on the original image and went on to Step 2.

					2.	Choose Select⇒Modify⇒Feather.

					3.	In the Feather dialog box that appears, type a value in the Feather Radius text field, and then click OK.

						For example, we entered 20 in the Feather Radius text field. (We then copied the selection, created a new image, and pasted the feathered selection into the new image to create the image on the bottom of  Figure 4-6.) Voilà! The edges of the image are softened over a 20-pixel area, as shown on the bottom of Figure 4-6. This technique is also referred to as a vignette in the printing industry.

				[image: technicalstuff.eps]	The results of the feathering depend on the resolution of the image. A feather of 20 pixels in a 72 ppi (pixels per inch) image is a much larger area than a feather of 20 pixels in a 300 ppi image. Typical amounts for a nice vignette on an edge of an image are 20 to 50 pixels. Experiment with images to find what works best for you.

					

				
					Figure 4-6: No feather-ing (top); feathering applied (bottom).

				

					[image: 9781118168608-fg040406.eps]

				This feathering effect created a nice, soft edge to your image, but it’s also useful when retouching images. Follow these steps:

					1.	Using any selection method, create a selection around the part of an image you want to lighten.

					2.	Choose Select⇒Modify⇒Feather; in the Feather dialog box that appears, enter 25 in the Feather Radius text field and click OK.

						If an error message, say “No pixels are more than 50% selected,” click OK and create a larger selection.

					3.	Choose Image⇒Adjustments⇒Curves.

					4.	Click in the center of the curve to add an anchor point and drag up to lighten the image.

						This step lightens the midtones of the image.

				Notice how the lightening fades out so that the correction has no definite edge. You can have more fun like this in Chapter 7 of this minibook, where we cover color correction.

				Tweaking the edges of a selection  with the Refine Edge feature

				If you like to experiment but also want a preview of exactly what your selection changes look like, you’ll love the new and improved Refine Edge feature. It’s available on the Options bar across the top of the Photoshop window whenever a selection tool is active.

				To use the Refine Edge feature, follow these steps:

					1.	Make a selection.

					2.	With any selection tool active, click the Refine Edge button on the Options bar at the top of the Photoshop window.

						The Refine Edge dialog box appears, as shown in Figure 4-7.

					

				
					Figure 4-7: Tweak the edges of a selection with the Refine Edge dialog box.

				

					[image: 9781118168608-fg040407.eps]

				Read on to find out more about the options available in this dialog box.

				Choosing a preview method

				Choose a preview method by selecting the View drop-down list at the top of the Refine Edge dialog box. On White is the default setting, and it shows your selection as it would appear on a white background. Don’t worry! The rest of your image hasn’t been removed; this preview helps you better see the effects of this feature.

				This list describes the other selections you can choose from the View drop-down list of the Refine Edge dialog box:

				[image: check.png] Marching Ants: Shows the marquee selection with no image masked.

				[image: check.png] Overlay: Shows the default, slightly transparent mask. It’s typically red unless you have changed the mask color. 

				[image: check.png] On Black: Reveals black around the masked area.

				[image: check.png] Black and White: Reveals the masked area as black and the nonmasked area as white. This option is helpful if you want to see only the mask and not the image area.

				[image: check.png] On Layers: Bound to be the most popular view if you’re creating composites. From this view, you can see the layers and how they’re affected by your selection.

				[image: check.png] Reveal Layer: Reveals the entire layer, with no indication where the selection is. Take advantage of this view if you think you might be cutting out important content.

				[image: tip.eps]	You can cycle through views by pressing F or disable the view by pressing X.

				Making adjustments with Edge Detection

				The Edge Detection section of the Refine Edge dialog box offers you the opportunity to make refinements to the selection edge. To see it in action, follow these steps:

					1.	Select the Smart Radius check box, as shown in Figure 4-8.

						The Smart Radius feature automatically adjusts the radius for hard and soft edges found in the border region.

					2.	Increase the radius by dragging the slider to the right.

						The Radius slider lets you precisely adjust the border area in which edge refinement occurs. Depending on the content, you will increase or decrease the radius.

						In Figure 4-8, the hair selection is improved in this image by increasing the radius to a value of 3.7 pixels.

					3.	If you’re interested in seeing the radius, select the Show Radius check box in the upper-right corner of the Refine Edge dialog box.

					

				
					Figure 4-8: Refining the edge of a selection.

				

					[image: 9781118168608-fg040408.eps]

				Using the Refine Radius tool

				To further improve the selection, click the Refine Radius tool, shown in Figure 4-9. By pressing either the right (]) or left bracket ([) key, you can increase or decrease the size of the Refine Radius tool and edit your edge selection by painting the edge of it. If your results are a little too drastic, hold down the Alt or Option key while painting over the area with the Refine Radius tool again. This technique is especially helpful for creating selections of hair or fur.

					

				
					Figure 4-9:  Use the Refine Radius tool to make difficult selections, like hair, easier to create.

				

					[image: 9781118168608-fg040409.eps]

				Making additional refinements

				But wait — there’s more! You can find additional refinements in the Adjust Edge section of the Refine Edge dialog box:

				[image: check.png] Smooth: Reduces irregular areas in the selection boundary.

				[image: check.png] Feather: Creates a soft-edged transition between the selection and its surrounding pixels.

				[image: check.png] Contrast: Sharpens selection edges and removes fuzzy artifacts.

				[image: check.png] Shift Edge: Contracts or expands to shrink or enlarge the selection boundary.

				Selecting color decontamination

				Color decontamination can create unwanted artifacts, and when this option is selected, the output option is set to create a new layer, which helps avoid overwriting the original color pixels.

				Choosing output settings

				Choose how you want selections implemented: only selection edges, a new layer, or a layer mask, for example. If you’re like most professionals, you want to make sure not to affect the original imagery unless you’re certain that you have the selection nailed down.

				Here are your output options on the Output To drop-down list:

				[image: check.png] Selection: The typical selection of a dashed selection, referred to as marching ants.

				[image: check.png] Layer Mask: Creates a mask on the active layer.

				[image: check.png] New Layer: Duplicates the active layer and applies the refined selection to the transparency of the layer.

				[image: check.png] New Layer with Mask: Duplicates the active layer and uses the refined selection or mask as the layer mask.

				[image: check.png] New Document: The same as the New Layer option but creates the new layer in a new document.

				[image: check.png] New Document with Mask: The same as the New Layer with Mask option but creates the new layer in a new document.

				If you want to play it safe, select Layer Mask from the Output To drop-down list. This option offers you the opportunity to edit the layer mask, using the painting tools just as you did with the Quick Mask tool, or to turn off the mask (by Shift-clicking the mask in the Layers panel). Read more about how to work with layer masks in Chapter 9 of this minibook.

				[image: tip.eps]	If you worked hard to make the perfect selection, don’t forget to select the Remember Settings check box so that your settings apply the next time you open the Refine Edge dialog box.

				Saving Selections

				The term alpha channel sounds complicated, but it’s simply a saved selection. Depending on the mode you’re in, you already have several channels  to contend with. A selection is just an extra channel that you can call on at any time.

				To create an alpha channel, follow these steps:

					1.	Create a selection that you want to save.

					2.	Choose Select⇒Save Selection.

					3.	Name the selection and click OK.

						An additional named channel that contains your selection appears in the Channels panel.

				To load a saved selection, follow these steps:

					1.	Choose Select⇒Load Selection.

						The Load Selection dialog box appears.

					2.	Select a named channel from the Channel drop-down list.

						If you have an active selection and then choose to load a selection, you have additional options. With an active selection, you can select one of the following options:

					•	New Selection: Eliminate the existing selection and create a new selection based on the channel you select.

					•	Add to Selection: Add the channel to the existing selection.

					•	Subtract from Selection: Subtract the channel from the existing  selection.

					•	Intersect with Selection: Intersect the channel with the existing  selection.

					3.	Click OK.

				[image: technicalstuff.eps]	Other Adobe applications, such as InDesign, Illustrator, Premiere, and After Effects, also recognize alpha channels.

				Preserving Corrective Perspective  with the Vanishing Point Feature

				The incredible Vanishing Point feature lets you preserve correct perspective in edits of images that contain perspective planes, such as the sides of a building. You can do much with this feature, and we provide you with a simple introduction. Try experimenting with multiple planes and copying and pasting items into the Vanishing Point window for even more effects. Follow these steps:

					1.	Open a file that you want to apply a perspective filter to.

						If you don’t have an appropriate image handy, try using a Vanishing Point.psd file. You can find it in Windows at C:\Program Files\Adobe\Adobe Photoshop CS6\Extras\Samples and on the Mac at Applications\Adobe\Adobe Photoshop CS5\Samples.

					2.	Create a new, blank layer by clicking the Create a New Layer button at the bottom of the Layers panel.

						If you create a new layer every time you use Vanishing Point, the results appear on a separate layer, preserving your original image, because you can delete the result of the vanishing point filter and still retain the original layer.

					3.	Choose Filter⇒Vanishing Point.

						A separate Vanishing Point window appears. If you see an error message about an existing plane, click OK.

						If you’re using a sample file from Photoshop, it will have a perspective plane already created for you. To help you understand this feature better, delete the existing plane by pressing the Delete or Backspace key.

					4.	Select the Create Plane tool and define the four corner nodes of the plane surface. If necessary, press Ctrl+– (Windows) or [image: maccmd]+– (Mac) to zoom back to see the entire image.

				[image: tip.eps]		Try to use objects in the image to help create the plane. In Figure 4-10, the planks of wood were used to make the perspective plane.

						After the four corner nodes of the plane are created, the tool automatically is switched to the Edit Plane tool.

					5.	Select and drag the corner nodes to make an accurate plane.

						The plane grid should appear blue, not yellow or red, if it’s accurate.

						After creating the plane, you can move, scale, or reshape the plane. Keep in mind that your results depend on how accurately the plane lines up with the perspective of the image.

				[image: tip.eps]		You can use your first Vanishing Point session to simply create perspective planes and then click OK. The planes appear in subsequent Vanishing Point sessions when you choose Filter⇒Vanishing Point. Saving perspective planes is especially useful if you plan to copy and paste an image into Vanishing Point and need to have a ready-made plane to target.

					6.	Choose the Stamp tool in the Vanishing Point window and then select On from the Heal drop-down list on the Options bar.

						(You’ll love this one.) In the sample image Vanishing Point.psd, we simply cloned the blue broom, but it should start you thinking about all the ways you can apply this greatly improved feature.

					7.	With the Stamp tool still selected, cross over part of the area or part of the image you want to clone and Alt-click (Windows) or Option-click (Mac) to define it as the source to be cloned.

						In the image Vanishing Point.psd, we clicked the middle part of the blue broom.

					

				
					Figure 4-10: Use objects in an image to build a perspective plane.

				

					[image: 9781118168608-fg040410.tif]

					8.	Without clicking, move toward the back of the perspective plane (you can even clone outside the plane), and then click and drag to reproduce the cloned part of the image.

						Notice in Figure 4-11 that it’s cloned as a smaller version, in the correct perspective for its new location.

					

				
					Figure 4-11: Cloning in perspective.
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					9.	Start from Step 7 and clone any region of an image closer to the front of the perspective pane.

						The cloned region is now cloned as a larger version of itself.

						You can use the Marquee tool options (Feather, Opacity, Heal, and Move Mode) at any time, either before or after making the selection. When you move the Marquee tool, the Stamp tool, or the Brush tool into a plane, the bounding box is highlighted, indicating that the plane is active.

					10.	Click OK.

						To preserve the perspective plane information in an image, save your document in JPEG, PSD, or TIFF format.

			

		

	
		
			
				Chapter 5: Using the  Photoshop Pen Tool

				In This Chapter

				[image: check.png] Putting shape layers to work

				[image: check.png] Working with a path as a selection

				[image: check.png] Creating clipping paths

				The Pen tool is the ultimate method to make precise selections. You can also use it to create vector shapes and clipping paths (silhouettes). In this chapter, you see how to take advantage of this super multitasking tool. This chapter also shows you how to apply paths made with the Pen tool as shapes, selections, and clipping paths. If you’re interested in the fundamental principles of creating paths with the Pen tool in Illustrator, check out Book III, Chapter 5, where we cover the Pen tool in more detail.

				We recommend that you use the Pen tool as much as you can to truly master its capabilities. If you don’t use it regularly, it will seem awkward, though it gets easier! Knowing how to effectively use the Pen tool puts you a grade above the average Photoshop user, and the quality of your selections will show it. Read Chapter 9 of this minibook to find out how to use the Pen tool, and look in Chapter 7 to find out how to create layer masks and adjustment layers.

				Using Shape Layers

				When you start creating with the Pen tool, Photoshop automatically, as a default, creates a path. But you can also choose to make a vector shape or, in the rare instance that you might need it, a fill (which essentially creates pixeled, nonvector shapes and paths). Select the Pen tool and note the default setting on the left side of the Options bar. You can select the following options from the Pick Tool Mode drop-down list: 

				[image: check.png] Shape: Creates a new shape layer, a filled layer that contains the vector path.

				[image: check.png] Path: Creates a path only; no layer is created.

				[image: check.png] Pixels: Creates pixels directly on the image. No editable path or layer is created. This option may not be useful to new users, but some existing users prefer to use this method because it’s the only way to access the Line tool from earlier versions.

				Shape layers can be very useful when the goal of your design is to seamlessly integrate vector shapes and pixel data. A shape layer can contain vector shapes that you can then modify with the same features of any other layer. You can adjust the opacity of the shape layer, change the blending mode, and even apply layer effects to add drop shadows and dimension. Find out how to do this in Chapter 9 of this minibook.

				Create a shape layer with any of these methods:

					[image: check.png] [image: 9781118168608-ma090.tif] Create a shape with the Pen tool. With the Pen tool, you can create interesting custom shapes and even store them for future use. We show you how in the following section.

				[image: check.png] Use a Vector Shape tool, as shown in Figure 5-1. Vector shapes are premade shapes (you can even create your own) that you can create by dragging the image area with a shape tool.

				[image: check.png] Import a shape from Illustrator. Choose File⇒Place and choose an .ai file; when the Options window appears, choose to place the file as a shape layer or a path. This action imports an Illustrator file as a shape layer or path into Photoshop.

					

				
					Figure 5-1: The Vector Shape tools.

				

					[image: 9781118168608-fg040501.tif]

				In Photoshop CS6, you can access the Vector shape and path tool options directly from the Options bar, as shown in Figure 5-2, when either the Pen tool or a vector shape tool is selected.

					

				
					Figure 5-2: You can switch to the Vector shape tool with the Options bar.
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				Creating and using a custom shape

				Perhaps you like the wave shape (see Figure 5-3) that’s been cropping up in design pieces all over the place.

					

				
					Figure 5-3: A custom wave shape integrated with an image in Photoshop.
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				[image: tip.eps]	You can copy and paste shapes directly from Illustrator CS6 into Photoshop CS6. Simply select a shape in Adobe Illustrator; choose Edit⇒Copy; switch to the Photoshop application; and, with a document open, choose Edit⇒Paste.

				A dialog box appears, offering you the opportunity to place your path as a shape layer (vector shape), a path, or pixels.

				You can create a wavy shape like that, too. With an image or blank document open, just follow these steps:

					1.	Select the Pen tool, and then select Shape from the Pick Tool Mode drop-down list on the Options bar. (Refer to Figure 5-2.)

					2.	Click and drag with the Pen tool to create a wavy shape.

						Don’t worry about the size of the shape. The shape is a vector, so you can scale it up or down to whatever size you need without worrying about making jagged edges. Just make sure to close the shape (that is, return to the original point with the end point).

						When you create the shape, it fills in with your foreground color. Try to ignore it if you can; the next section shows you how to change the fill color, and Chapter 8 of this minibook covers how to change it to a transparent fill.

					3.	With the shape still selected, choose Edit⇒Define Custom Shape, name the shape, and click OK.

						After you save your custom shape, you can re-create it at any time. If you don’t like the shape, choose Windows⇒Layers to open the Layers panel, and then drag the shape layer you just created to the Trash Can in the lower-right corner of the panel. If you want to experiment with your custom shape now, continue with these steps.

					4.	Click and hold the Rectangle tool to access the other hidden vector tools; select the last tool, the Custom Shape tool.

						When the Custom Shape tool is selected, a Shape drop-down list appears on the Options bar at the top of the screen, as shown in Figure 5-4.

						You have lots of custom shapes to choose from, including the one you’ve just created. If you just saved a shape, yours is in the last square; you may have to scroll down to select it.

					

				
					Figure 5-4: A Shape drop-down list appears on the Options bar.

				

					[image: 9781118168608-fg040504.tif]

					5.	Click to select your custom shape; click and drag in the image area to create your shape.

						You can make the shape any size you want.

					6.	To resize the shape, choose Edit⇒Free Transform Path, press Ctrl+T (Windows) or [image: maccmd]+T (Mac), grab a bounding box handle, and drag.

						Shift+drag a corner handle to keep the shape proportional as you resize it.

				[image: tip.eps]	Because a shape is created on its own layer, you can experiment with different levels of transparency and blending modes in the Layers panel. Figure 5-5 shows shapes that are partially transparent. Discover lots of other features you can use with shape layers in Chapter 9 of this minibook.

					

				
					Figure 5-5: Experiment with blending modes and opacity changes on shape layers.
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				Changing the color of the shape

				When you create a shape with a shape tool, the shape takes the color of the present foreground color. To change the color of an existing shape, open the Layers panel by choosing Window⇒Layers; notice that the Vector Shape tool creates a new layer for every shape you make. Creating a new layer is a benefit when it comes to creating special effects because the shape layer is independent of the rest of your image. (Read more about using layers in Chapter 9 of this minibook.)

				To change a shape’s color, double-click the color thumbnail in the shape layer, as shown in Figure 5-6, or click the Fill color box on the Options bar across the top of the Document window. The Color Picker appears. To select a new color, drag the Hue slider up or down or click in the large color pane to select a color with the saturation and lightness you want to use. Click OK when you’re done.

					

				
					Figure 5-6: Double-click the Layer thumbnail to open the Color Picker.
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				[image: tip.eps]	With the Color Picker open, you can also move outside the picker dialog box and sample colors from other open images and objects.

				Editing a shape

				
					[image: 9781118168608-ma092.tif] [image: 9781118168608-ma093.tif]	Like Adobe Illustrator, Photoshop provides both a Path Selection tool and a Direct Selection tool. The Direct Selection tool is hidden under the Path Selection tool. To move an entire shape on a layer, choose the Path Selection tool and drag the shape.

				To edit the shape, deselect the shape. (While using the Path Selection or Direct Selection tool, click outside the shape.) Then select the Direct Selection tool. With the Direct Selection tool, click individual anchor points and handles to edit and fine-tune the shape, as shown in Figure 5-7.

					

				
					Figure 5-7:  Edit individual anchor points with the Direct Selection tool.
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				Removing a shape layer

				Because the Pen tool now has multiple options, you may unexpectedly create a shape layer. Delete a shape layer by dragging the layer thumbnail to the Trash Can in the lower-right corner of the Layers panel.

				If you want to keep your path but throw away the shape layer, choose Window⇒Paths. Then drag the shape vector mask to the Create New Path icon, shown in Figure 5-8, which creates a saved path. Now you can throw away the shape layer.

					

				
					Figure 5-8:  Drag the shape path to the Create New Path icon.
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				Using a Path as a Selection

				You can use the Pen tool to create precise selections that would be difficult to create using other selection methods. The Pen tool produces clean edges that print well and can be edited using the Direct Selection tool. Before using the Pen tool, make sure that you select Path from the Pick Tool Mode drop-down list on the Options bar.

				To use a path as a selection (which is extremely helpful when you’re trying to make a precise selection), follow these steps:

					1.	Open any file or create a new, blank file.

					2.	With the Pen tool (make sure that Path is selected from the Pick Tool Mode drop-down list on the Options bar or else you’ll create a shape layer), click to place anchor points.

					3.	Drag to create a curved path around the image area you want selected and completely close the path by returning to the starting point. (See Figure 5-9.)

						Use the techniques we discuss in Book III, Chapter 5 to perform this step. A circle appears before you click to close the path.

					

				
					Figure 5-9: Make sure that you select the Paths button to create only the path, not a shape layer.
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					4.	Choose Window⇒Paths.

						In the Paths panel, you can create new paths and activate existing paths, apply a stroke, or turn paths into selections by clicking the icons at the bottom of the panel. (See Figure 5-10.)

					5.	Click and drag the Work Path down to the Create New Path icon at the bottom of the Paths panel.

						The path is now named Path 1 and is saved. You can also double-click to rename the file if you like.

					

				
					Figure 5-10: The Paths panel and its options.

				

					[image: 9781118168608-fg040510.eps]

					6.	Click the Load Path as Selection icon.

						The path is converted into a selection.

				[image: tip.eps]	Use this quick and easy method for turning an existing path into a selection: Ctrl-click (Windows) or [image: maccmd]-click (Mac) the path thumbnail in the Paths panel.

				Clipping Paths

				If you want to create a beautiful silhouette that transfers well to other applications for text wrapping (see Figure 5-11), create a clipping path. A clipping path is essentially a vector path that defines what part of the image is visible and what part is transparent. Typically a path is created around an object that you want to silhouette.

					

				
					Figure 5-11: Clipping paths allow you to create silhouettes in other applications.
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				To create a clipping path follow these steps:

					1.	Use the Pen tool to create a path around the image area that will become the silhouette.

					2.	In the Paths panel, choose Save Path from the panel menu (click the triangle in the upper-right corner of the panel), as shown in Figure 5-12, and then name the path.

					

				
					Figure 5-12: Convert your work path to a saved path.

				

					[image: 9781118168608-fg040512.eps]

						If Save Path is not visible, your path has already been saved; skip to Step 3.

					3.	From the same panel menu, choose Clipping Path.

					4.	In the Clipping Path dialog box, select your path from the drop-down list, if it’s not already selected; click OK.

						Leave the Flatness Device Pixels text field blank unless you need to change it. The flatness value determines how many device pixels are used to create your silhouette. The higher the amount, the fewer points are created, thereby allowing for faster processing time. This speed comes at a cost, though: If you set the flatness value too high, you may see (if you look close) straight edges instead of curved edges.

					5.	Choose File⇒Save As and, from the Format drop-down list, select Photoshop EPS; in the EPS Options dialog box that appears, accept the defaults and click OK.

						If you see PostScript errors when printing, choose Clipping Path from the panel menu and increase the value to 2 pixels in the Flatness Device Pixels text field. Keep returning to this text field and increasing the value until the file prints, or give up and try printing your document on another printer.

				[image: tip.eps]		If you’re placing this file in other Adobe applications, such as InDesign, you don’t need to save the file as EPS; you can leave it as a Photoshop (.psd) file.

				Here’s an even faster method you can use to create a clipping path that you can use in other Adobe applications, such as InDesign and Illustrator:

					1.	Create a path around the item you want to keep when you create the clipping path.

						Make sure that you’re working on a layer and not on the Background layer. To convert the Background to a layer, hold down the Alt key (Windows) or the Option key (Mac) and double-click the Background layer. The Background layer is now Layer 0.

						2.	[image: 9781118168608-ma098.tif] In the Layers panel, click the Add Layer Mask button, and then click the Add Layer Mask button again.

						A layer vector mask is created, and everything outside the path becomes transparent, as shown in Figure 5-13.

					

				
					Figure 5-13: Creating a clipping path the easy way, with layers.
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						You can still edit the path by using the Direct Selection tool.

					3.	Save the file in the .psd format.

					4.	Choose File⇒Place to put the image, with its clipping path included, into other Adobe applications.

				

			

		

	
		
			
				Chapter 6: Thinking about Resolution Basics

				In This Chapter

				[image: check.png] Understanding resolution basics

				[image: check.png] Adjusting file size

				[image: check.png] Applying the Unsharp Mask filter to your image

				Something as important as setting the right resolution for your images deserves its own chapter, but fortunately, the topic isn’t all that complex. In this chapter, you discover the necessary resolution for various uses of Photoshop imagery (from printing a high-resolution graphic to e-mailing a picture of your kids to Mom) and how to properly increase resolution and how to adjust image size.

				Having the proper resolution is important to the final outcome of an image, especially if you plan to print it. Combine the information here with using the correction tools we show you in Chapter 7 of this minibook, and you should be ready to roll with great imagery.

				Creating Images for Print

				To see and make changes to the present size and resolution of an image in Photoshop, choose Image⇒Image Size. The Image Size dialog box appears.

				[image: tip.eps]	The Width and Height text fields in the Pixel Dimensions area of the Image Size dialog box are used for onscreen resizing, such as for the web and e-mail. The Width and Height text fields in the Document Size area show the size at which the image will print. The Resolution text field determines the resolution of the printed image; a higher value means a smaller, more finely detailed printed image.

				Before you decide on a resolution, you should understand what some of the resolution jargon means:

				[image: check.png] dpi (dots per inch): The resolution of an image when printed.

				[image: check.png] lpi (lines per inch): The varying dot pattern that printers and presses use to create images. (See Figure 6-1.) This dot pattern is referred to as the lines per inch, even though it represents rows of dots. The higher the lpi, the finer the detail and the less dot pattern or line screen you see.

				[image: check.png] Dot gain: The spread of ink as it’s applied to paper. Certain types of paper spread a dot of ink farther than others. For example, newsprint has a high dot gain and typically prints at 85 lpi; a coated stock paper has a lower dot gain and can be printed at 133–150 lpi and even higher.

				Human eyes typically can’t detect a dot pattern in a printed image at 133 dpi or higher.

					

				
					Figure 6-1: The dot pattern used to print images is referred to as lpi (lines per inch).

				

					[image: 9781118168608-fg040601.tif]

				[image: tip.eps]	Deciding the resolution or dpi of an image requires backward planning. If you want to create the best possible image, you should know where it’ll print before deciding its resolution. Communicate with your printer service if the image is going to press. If you’re sending an image to a high-speed copier, you can estimate that it will handle 100 lpi; a desktop printer handles 85 lpi to 100 lpi.

				The resolution formula

				When creating an image for print, keep this formula in mind:

				2 × lpi = dpi (dots per inch)

				This formula means that if your image is going to press using 150 lpi, have your image at 300 dpi. To save space, many people in production use 1.5 × lpi because it reduces the file size significantly and you get similar results; you can decide which one works best for you.

				Changing the resolution

				Using the Image Size dialog box is only one way that you can control the resolution in Photoshop. Even though you can increase the resolution, do so sparingly and avoid it, if you can. The exception is when you have an image that’s large in dimension size but low in resolution, like those you typically get from a digital camera. You may have a top-of-the-line digital camera that produces 72 dpi images, but at that resolution, the pictures are 28 x 21 inches (or larger)!

				To increase the resolution of an image without sacrificing quality, follow these steps:

					1.	Choose Image⇒Image Size.

						The Image Size dialog box appears, as shown in Figure 6-2.

					

				
					Figure 6-2: The Image Size dialog box.

				

					[image: 9781118168608-fg040602.eps]

					2.	Deselect the Resample Image check box.

						This way, Photoshop doesn’t add any pixels.

					3.	Enter a resolution in the Resolution text field.

						Photoshop keeps the pixel size (the size of the image onscreen) the same, but the document size (the size of the image when printed) decreases when you enter a higher resolution.

					4.	If the image isn’t the size you need, select the Resample Image check box and type the size in the Width and Height text fields in the Document Size section.

						It’s best to reduce the size of a bitmap image, such as a digital photo, rather than increase it.

				[image: remember.eps]		You can also deselect the Resample Image check box and essentially play a game of give-and-take to see what the resolution will be when you enter the intended size of your printed image in the Width and Height text fields in the Document Size area.

						Images can typically be scaled from 50 to 120 percent before looking jagged. (To scale by a percentage, select Percent from the drop-down lists beside the Width and Height text fields.) Keep these numbers in mind when placing and resizing images in a page layout application such as InDesign.

						5.	[image: 9781118168608-ma096.tif] Click OK when you’re finished; double-click the Zoom tool in the Tools panel to see the image at its onscreen size.

				[image: tip.eps]	To increase the resolution without changing the image size, follow these steps. (This situation isn’t perfect because pixels that don’t presently exist are created by Photoshop and may not be totally accurate. Photoshop tries to give you the best image, but you may see some loss of detail.)

					1.	Choose Image⇒Image Size.

					2.	When the Image Size dialog box appears, make sure that the Resample Image check box is selected.

						Note that Bicubic is selected in the Method drop-down list. This method is the best, but slowest, way to reinterpret pixels when you resize an image. With this method, Photoshop essentially looks at all pixels and takes a good guess about how the newly created pixels should look, based on surrounding pixels.

					3.	Enter the resolution you need in the Resolution text field, click OK, and then double-click the Zoom tool to see the image at its actual size.

				Determining the Resolution for Web Images

				Have you ever received an image via e-mail, and, after spending ten minutes downloading it, discovered that the image is so huge that all you can see on the monitor is your nephew’s left eye? Many people are under the misconception that if an image is 72 dpi, it’s ready for the web. Actually, pixel dimension is all that matters for viewing images on the web; this section helps you make sense of this concept.

				Most people view web pages in their browser windows in an area of about 640 x 480 pixels. You can use this figure as a basis for any images you create for the web, whether the viewer is using a 14-inch or a 21-inch monitor. (Remember that people who have large monitors set to high screen resolutions don’t necessarily want a web page taking up the whole screen.) If you’re creating images for a web page or to attach to an e-mail message, you may want to pick a standard size to design by, such as 600 x 400 pixels at 72 dpi.

				To use the Image Size dialog box to determine the resolution and size for onscreen images, follow these steps:

					1.	Have an image open and choose Image⇒Image Size.

						The Image Size dialog box appears.

					2.	To make the image occupy half the width of a typical browser window, type 300 (half of 600) in the top Width text field.

						If a little chain link is visible to the right, the Constrain Proportions check box is selected, and Photoshop automatically determines the height from the width you entered.

					3.	Click OK and double-click the Zoom tool to see the image at its actual onscreen size.

						That’s it! Whether your image is 3,000 or 30 pixels wide doesn’t matter; as long as you enter the correct dimensions in the Pixel Dimension area, the image works beautifully.

				Applying the Unsharp Mask Filter to an Image

				When you resample an image in Photoshop, it can become blurry. A good practice is to apply the Unsharp Mask filter. You can see the difference in detail in the images shown in Figure 6-3. This feature sharpens the image based on levels of contrast while keeping smooth the areas that have no contrasting pixels. You have to set up this feature correctly to get good results.

					

				
					Figure 6-3: The image without (left) and with (right) unsharp masking applied.

				

					[image: 9781118168608-fg040603.eps]

				Here’s the down-and-dirty method of using the Unsharp Mask filter:

					1.	Choose View⇒Actual Pixels or double-click the Zoom tool.

				[image: remember.eps]		When you’re using a filter, view your image at its actual size to best see the effect.

					2.	Choose Filter⇒Sharpen⇒Unsharp Mask.

						In the Unsharp Mask dialog box that appears, set these three options:

					•	Amount: The Amount value ranges from 0 to 500. The amount you choose has a lot to do with the subject matter. Sharpening a car or appliance at 300 to 400 is fine, but if you do this to the CEO’s 75-year-old wife, you may suffer an untimely death because every wrinkle, mole, or hair will magically become more defined. If you’re not sure which amount to use, start with 150 and play around until you find an Amount value that looks good.

					•	Radius: The Unsharp Mask filter creates a halo around the areas that have enough contrast to be considered an edge. Typically, leaving the amount between 1 and 2 is fine for print, but if you’re creating a billboard or poster, increase the size.

					•	Threshold: This option is the most important one in the Unsharp Mask dialog box. The Threshold setting determines what should be sharpened. If you leave it at zero, you see noise throughout the image, much like the grain you see in high-speed film. Increase the setting to 10 and it triggers the Unsharp Mask filter to apply only the sharpening when the pixels are ten shades or more away from each other. The amount of tolerance ranges from 1 to 255. Apply too much and no sharpening appears; apply too little and the image becomes grainy. A good number to start with is 10.

				[image: tip.eps]		To compare the original state of the image with the preview of the Unsharp Mask filter’s effect in the Preview pane of the Unsharp Mask dialog box, click and hold the image in the Preview pane; this shows the original state of the image. When you release the mouse button, the Unsharp Mask filter is previewed again.

					3.	When you’ve made your choice, click OK.

						The image appears to have more detail.

				Once in a while, stray colored pixels may appear after you apply the Unsharp Mask filter. If you feel this is a problem with your image, choose Edit⇒Fade Unsharp Mask immediately after applying the Unsharp Mask filter. In the Fade dialog box, select the Luminosity blend mode from the Mode drop-down list and then click OK. This step applies the Unsharp Mask filter to the grays in the image only, thereby eliminating the sharpening of colored pixels.

				[image: tip.eps]	You can also choose Filter⇒Convert for Smart Filters before you apply the Unsharp Mask filter. Smart filters let you undo all or some of any filter, including sharpening filters you apply to a layer. Find out how by reading Chapter 9 in this minibook.

				

			

		

	
		
			
				Chapter 7: Creating a Good Image

				In This Chapter

				[image: check.png] Understanding the histogram

				[image: check.png] Getting ready to correct an image

				[image: check.png] Making a good tone curve

				[image: check.png] Editing adjustment layers

				[image: check.png] Testing your printer

				When discovering all the incredible things you can do in Photoshop, you can easily forget the basics. Yes, you can create incredible compositions with special effects, but if the people in your image look greenish, their alien skin tone can detract from the final result. Make it part of your image editing process to create clean images before adding the artsy filters and complex compositions. Color correction isn’t complicated, and by following the steps in this chapter you can produce almost magical results. In this chapter, you see how to use the values you read in the Info panel and use the Curves panel to produce quality image corrections.

				Reading a Histogram

				Before making adjustments, look at the image’s histogram, which displays an image’s tonal values, to evaluate whether the image has sufficient detail to produce a high-quality image. In Photoshop CS6, choose Window⇒Histogram to display the Histogram panel.

				[image: remember.eps]	The greater the range of values in the histogram, the greater the detail. Poor images without much information can be difficult, if not impossible, to correct. The Histogram panel also displays the overall distribution of shadows, midtones, and highlights to help you determine which tonal corrections are needed.

				Figure 7-1 shows a good, full histogram that indicates a smooth transition from one shade to another in the image. Figure 7-2 shows that when a histogram is spread out and has gaps in it, the image is jumping too quickly from one shade to another, producing a posterized effect. Posterization is an effect that reduces tonal values to a limited amount, creating a more defined range of values from one shade to another. It’s great if you want it but yucky if you want a smooth tonal change from one shadow to another.

					

				
					Figure 7-1: A histogram showing smooth transitions from one color to another.

				

					[image: 9781118168608-fg040701.tif]

					

				
					Figure 7-2: A histogram showing a lack of smoothness in the gradation  of color.

				

					[image: 9781118168608-fg040702.tif]

				So how do you create a good histogram? If you’re scanning, make sure that your scanner is set for the maximum number of colors. Scanning at 16 shades of gray gives you 16 lines in your histogram — not good.

				[image: tip.eps]	If you have a bad histogram, we recommend that you rescan or reshoot the image. If you have a good histogram to start with, keep it that way by not messing around with multiple tone correction tools. Most professionals use the Curves feature — and that’s it. Curves (choose Image⇒Adjustments⇒Curves), if used properly, do all the adjusting of levels (brightness and contrast) and color balance, all in one step. You can read more about curves in the section “Creating a Good Tone Curve,” later in this chapter.

				Figure 7-3 shows what happens to a perfectly good histogram when someone gets too zealous and uses the entire plethora of color correction controls in Photoshop. Just because the controls are there doesn’t mean that you have to use them.

					

				
					Figure 7-3:  Tonal information is broken up.

					
				

					[image: 9781118168608-fg040703.eps]

				[image: warning_bomb.eps]	If a Warning icon appears while you’re making adjustments, double-click anywhere on the histogram to refresh the display.

				Breaking into key types

				Don’t panic if your histogram is smashed all the way to the left or right. The bars of the histogram represent tonal values. You can break down the types of images, based on their values, into three key types that are defined below:

				[image: check.png] High key: An extremely light-colored image, such as the image shown in Figure 7-4. Information is pushed toward the right in the histogram. Color correction has to be handled a little differently for these images to keep the light appearance to them.

					

				
					Figure 7-4: A high key image is a light image.
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				[image: check.png] Low key: An extremely dark image, such as the one shown in Figure 7-5. Information is pushed to the left in the histogram. This type of image is difficult to scan on low-end scanners because the dark areas tend to blend together with little definition.

				[image: check.png] Mid key: A typical image with a full range of shades, such as the image shown in Figure 7-6. These images are the most common and easiest to work with. In this chapter, we deal with images that are considered mid key.

					

				
					Figure 7-5: A low key image is a dark image.
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					Figure 7-6: A typical image with a full range of values is a mid key image.
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				Setting up the correction

				To produce the best possible image, try to avoid correcting in CMYK (Cyan, Magenta, Yellow, Black) mode. If your images are typically in RGB (Red, Green, Blue) or LAB mode (L for lightness, and A and B for the color- opponent dimensions), keep them in that mode throughout the process. Convert them to CMYK only when you’re finished manipulating the image.

				[image: tip.eps]	Don’t forget! Press Ctrl+Y (Windows) or [image: maccmd]+Y (Mac) to toggle on and off the CMYK preview so that you can see what your image will look like in CMYK mode without converting it.

				Set up these items before starting any color correction:

					1.	Select the Eyedropper tool (the keyboard shortcut is I); on the Options bar, select the 3 by 3 Average setting from the Sample Size drop-down list.

						The 3 by 3 Average setting gives you more accurate readings than the Point Sample setting.

					2.	If the Histogram panel isn’t already visible, choose Window⇒Histogram.

					3.	If the Info panel isn’t already visible, choose Window⇒Info to show the Info panel so that you can check values.

					4.	Make sure that your color settings are correct.

						If you’re not sure how to check or set up color settings, see Chapter 3 of this minibook.

				Creating a Good Tone Curve

				A tone curve represents the density of an image. To produce the best image, you must first find the highlight and shadow points in it. An image created in less-than-perfect lighting conditions may be washed out or have odd color casts. See Figure 7-7 for an example of an image with no set highlight and shadow. Check out Figure 7-8 to see an image that went through the process of setting a highlight and shadow.

					

				
					Figure 7-7: The image is murky before defining a highlight and shadow.

					
				

					[image: 9781118168608-fg040707.tif]

					

				
					Figure 7-8: The tonal values are opened after highlight and shadow have been set.
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				To make the process of creating a good tone curve more manageable, we’ve broken the process into four parts:

				[image: check.png] Find the highlight and shadow

				[image: check.png] Set the highlight and shadow values

				[image: check.png] Adjust the midtone

				[image: check.png] Find a neutral

				Even though each part has its own set of steps, you must complete all four parts to accomplish the task of creating a good tone curve (unless you’re working with grayscale images, in which case you can skip the neutral part). In this example, an adjustment layer is used for the curve adjustments. The benefit is that you can turn off the visibility of the adjustment later or double-click the adjustment layer thumbnail to make ongoing edits without destroying your image.

				Finding the highlight and the shadow

				In the noncomputer world, you’d spend a fair amount of time trying to locate the lightest and darkest parts of an image. Fortunately, you can cheat in Photoshop by using some features in the Curves panel. Here’s how to access the panel:

					1.	With an image worthy of adjustment — one that isn’t perfect already — choose Window⇒Layer (if the Layers panel isn’t already open).

					2.	Click and hold the Create New Fill or Adjustment Layer button at the bottom of the Layers panel and select Curves.

						The Adjustments panel appears with the Curves panel active, as shown in Figure 7-9. 

					

				
					Figure 7-9: Access Curves using the Create New Fill or Adjustment Layer button on the Layers panel.

				

					[image: 9781118168608-fg040709.tif]

				Notice the grayed-out histogram behind the image in the Curves panel. The histogram helps you determine where you need to adjust the image’s curve.

				[image: technicalstuff.eps]	If you’re correcting in RGB (as you should be), the tone curve may be the opposite of what you expect. Instead of light to dark displaying as you expect, RGB displays dark to light. Think about it: RGB is generated with light, and no RGB means that there’s no light and you therefore have black. If you turn on all RGB full force, you create white. Try pointing three filtered lights — one red, one green, and one blue. The three lights pointed in one direction create white.

				If working with RGB confuses you, simply select Curves Display Options from the panel menu in the upper-right corner of the Adjustments panel. When the Curves Display Options dialog box appears, as shown in Figure 7-10, select the Pigment/Ink % radio button and click OK.

					

				
					Figure 7-10: View the curve using light or pigment.
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				Note that in the Curves panel, you see a Preset drop-down list that offers quick fixes using standard curves for certain corrections. These settings are great for quick fixes, but for the best image, create a custom curve.

				The first thing you need to do in the Curves panel is determine the lightest and darkest parts of the image — referred to as locating the highlight and shadow:

					1.	Before starting the correction, click the Set Black Point eyedropper once (labeled in Figure 7-11).

					2.	Hold down the Alt (Windows) or Option (Mac) key and click the Shadow input slider (labeled in Figure 7-11). 

						If you did not change your Curve Display Options to display Pigment/Ink %, your highlight and shadow sliders will be opposite of what appears in Figure 7-11.

						When you Alt-click (Windows) or Option-click (Mac), the clipping preview turns on, revealing the darkest area of the image.

						If you don’t immediately see a dark area in the clipping preview, you can drag the shadow input slider to the left while holding down the Alt key or Option key. Note where the darkest area of the image appears.

					

				
					Figure 7-11: The critical tools on the Curves panel.

				

					[image: 9781118168608-fg040711.eps]

					3.	Hold down the Shift key and click directly on the image in that dark region.

						This step drops a color sampler on the image that helps you reference that point later.

					4.	Repeat Steps 1 through 3 with the Highlight input slider. Select the Set White Point eyedropper (labeled in Figure 7-11) in the Curves panel.

					5.	Hold down the Alt key or Option key and click the highlight input slider.

						Again, you can drag the slider toward the right if the lightest point doesn’t immediately show up.

						When you locate the lightest point, as indicated by the lightest point in the clipping preview, you can Shift-click to drop a second color sampler, as shown in Figure 7-12.

					

				
					Figure 7-12: You can Alt-click or Option+ Shift-click to drop a color sampler.
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				Setting the highlight and shadow values

				After you determine the lightest and darkest points in an image, you can set their values. Follow these steps:

					1.	To activate the eyedropper tools, click the Click and Drag button, shown in Figure 7-13.

					

				
					Figure 7-13: Click the Click and Drag button.
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					2.	Double-click the Set White Point eyedropper, the white eyedropper on the left side of the Curves panel.

						When you double-click the Set White Point eyedropper, the Color Picker dialog box appears.

					3.	Enter a generic value for the lightest point in your image: Type 5 in the Cyan text box, type 3 in the Magenta text box, type 3 in the Yellow text box, leave the Black text box at 0 (zero), and then click OK.

						The Black value helps to correct most images for print and online.

					4.	When you receive an alert message asking whether you want to save the new target colors as defaults, click Yes.

					5.	With the Set White Point eyedropper still selected, click the color sampler you dropped on the image, indicating the lightest point in the image.

						Now, set the shadow point.

					6.	Double-click the Set Black Point eyedropper.

						The Color Picker dialog box appears.

					7.	Type 65 in the Cyan text box, type 53 in the Magenta text box, type 51 in the Yellow text box, type 95 into the Black text box, and then click OK.

						As with the highlight value, the Black value is a generic value that works for most print and online images. Keep in mind that if you set your Color Settings up correctly, you don’t have to change the Set Black point value.

					8.	With the Set Black Point eyedropper still selected, click the color  sampler you dropped on the image, indicating the darkest point in  the image.

				Adjusting the midtone

				You may have heard the statement, “Open up the midtones.” This phrase essentially means that you’re lightening the midtonal values of an image. In many cases, opening up the midtones is necessary to add contrast and bring out detail in an image.

				To adjust the midtones, follow these steps:

					1.	In the Curves panel, click the middle of the curve ramp to create an anchor point; drag up slightly.

						The image lightens. (If you’re in Pigment/Ink % mode, drag down to lighten the image.) Move only a reasonable amount and be careful to observe what’s happening in the Histogram panel (which you should always have open when making color corrections).

						Because you set highlight and shadow (see the preceding section) and are now making a midtone correction, you see the bars in the histogram spreading out.

					2.	To adjust the three-quarter tones (the shades around 75 percent), click halfway between the bottom of the curve ramp and the midpoint to set an anchor point.

						Use the grid in the Curves panel to find it easily. (In Pigment/Ink %, the three-quarter point is in the upper section of the color ramp.) Adjust the three-quarter area of the tone curve up or down slightly to create contrast in the image. Again, keep an eye on your histogram!

						If you’re working on a grayscale image, the tonal correction is done.

						If you’re working on a color image, keep the Curves panel open for the final steps, which are outlined in the next section.

				Finding a neutral

				The last steps in creating a tone curve apply only if you’re working on a color image. The key to understanding color is knowing that equal amounts of color create gray. By positioning the mouse cursor over gray areas in an image and reading the values in the Info panel, you can determine which colors you need to adjust.

					1.	With the Curves panel open, position it so that you can see the Info panel.

						If the Info panel is buried under another panel or a dialog box, choose Window⇒Info to bring it to the front or undock it from its current  location.

					2.	Position the cursor over an image and, in the Info panel, look for the RGB values in the upper-left section.

						You see color values and then forward slashes and more color values. The numbers before the slash indicate the values in the image before you opened the Curves panel; the numbers after the slash show the values now that you’ve made changes in the Curves panel. Pay attention to the values after the slashes.

					3.	Position the cursor over something gray in your image.

						It can be a shadow on a white shirt, a countertop, a road — anything that’s a shade of gray. Look at the Info panel. If your image is perfectly color balanced, the RGB values following the forward slashes should all be the same.

					4.	If the color isn’t balanced, click the Set Gray Point eyedropper in the Curves panel and click the neutral or gray area of the image.

						The middle eyedropper (Set Gray Point) is a handy way of bringing the location you click closer together in RGB values, thereby balancing the colors.

				Curves can be as complex or as simple as you make them. As you gain more confidence in using them, you can check neutrals throughout an image to ensure that all unwanted color casts are eliminated. You can even individually adjust each color’s curve by selecting it from the Channel drop-down list in the Curves panel.

				When you’re finished with color correction, using the Unsharp Mask filter on your image is a good idea. Chapter 6 of this minibook shows you how to use this filter.

				Editing an Adjustment Layer

				You may make a curve adjustment only to discover that some areas of the image are still too dark or too light. Because you used an adjustment layer, you can turn off the correction or change it repeatedly with no degradation to the quality of the image.

				Here are the steps to take if you still have additional adjustments to make to an image, such as lightening or darkening other parts of the image:

					1.	Select the area of the image that needs adjustments.

						See Chapter 4 of this minibook for a refresher on how to make selections in Photoshop.

					2.	Choose Select⇒Modify⇒Feather to soften the selection.

						The Feather dialog box appears.

					3.	Enter a value into the Feather dialog box.

						If you’re not sure what value will work best, enter 15 in the Feather Radius text field and click OK.

				[image: tip.eps]		You can also click the Refine Edge button in the Options panel (when you have a selection tool active) to preview the feather amount.

					4.	If the Layers panel isn’t visible, choose Windows⇒Layers; click and hold the Create New Fill or Adjustment Layer icon and select Curves.

					5.	In the Curves panel, click the middle of the curve ramp to create an anchor point; drag up or down to lighten or darken the selected area.

						Notice in the Layers panel (see Figure 7-14) that the adjustment layer, Curves 1 by default, has a mask to the right of it. This mask was automatically created from your selection. The selected area is white; unselected areas are black.

					

				
					Figure 7-14: Paint on the adjustment layer mask.
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					6.	With the adjustment layer selected in the Layers panel, use the Brush tool to paint white to apply the correction to other areas of the image; paint with black to exclude areas from the correction.

						You can even change the opacity with the Brush tool in the Options bar at the top to apply only some of the correction!

				Testing a Printer

				If you go to all the trouble of making color corrections to images and you still see printed images that look hot pink, it may not be your fault. Test your printer by following these steps:

					1.	Create a neutral gray out of equal RGB values. (Double-click the Fill Color swatch in the Tools panel.)

					2.	Create a shape, using neutral gray as the fill color.

						For example, you can use the Ellipse tool to create a circle or oval.

					3.	Choose File⇒Print and click OK to print the image from a color printer.

				If you’re seeing heavy color casts, adjust the printer; cleaning or replacing the ink cartridge may fix the problem. Check out Chapter 10 of this minibook for more about printing Photoshop files.

				

			

			
		

	
		
			
				Chapter 8: Working with Painting and Retouching Tools

				In This Chapter

				[image: check.png] Working in the Swatches panel

				[image: check.png] Getting to know foreground and background colors

				[image: check.png] Introducing painting and retouching tools

				[image: check.png] Using the Content-Aware feature

				[image: check.png] Discovering blending modes

				[image: check.png] Saving presets for tools

				This chapter shows you how to use the painting and retouching tools in Photoshop. Have fun and be creative! Because Photoshop is pixel based, you can retouch your images and also create incredible imagery with the painting tools. Smooth gradations from one color to the next, integrated with blending modes and transparency, can lead from super-artsy to super-realistic effects. In this chapter, you discover fundamental painting concepts, and we show you how to use retouching tools to eliminate wrinkles, blemishes, and scratches. Don’t you wish you could do that in real life?

				Using the Swatches Panel

				Use the Swatches panel to store and retrieve frequently used colors. The Swatches panel lets you quickly select colors and gives you access to many other color options. By using the panel menu, where you see the cursor in Figure 8-1, you can select from a multitude of color schemes, such as Pantone or web-safe color sets. These color systems are converted to the color mode in which you’re working.

					

				
					Figure 8-1: Click the panel menu to access additional color options.

				

					[image: 9781118168608-fg040801.eps]

				To sample and store a color for later use, follow these steps:

					1.	To sample a color from an image, select the Eyedropper tool in the Tools panel and click a color in the image.

						Alternatively, you can use any of the paint tools (the Brush tool, for example) and Alt-click (Windows) or Option-click (Mac).

						The color you click becomes the foreground color.

					2.	If the Swatches panel isn’t already open, choose Window⇒Swatches.

					3.	Store the color in the Swatches panel by clicking the New Swatch button at the bottom of the Swatches panel.

				Anytime you want to use that color again, simply click it in the Swatches panel to make it the foreground color.

				Choosing Foreground and Background Colors

				At the bottom of the Tools panel you can find the foreground and background color swatches. The foreground color is the color you apply when using any of the painting tools. The background color is the color you see if you erase or delete pixels from the image.

				Choose a foreground or background color by clicking the swatch, which then opens the Color Picker dialog box, shown in Figure 8-2. To use the Color Picker, you can either enter values in the text fields on the right or slide the hue slider.

				Pick the hue (color) you want to start with and then click in the color panel to the left to choose the amount of light and saturation (grayness or brightness) you want in the color. Select the Only Web Colors check box to choose one of the 216 colors in the web-safe color palette. The hexadecimal value used in HTML documents appears in the text field in the lower right corner of the Color Picker.

				To quickly save a color, click the Add to Swatches button directly in the Color Picker.

					

				
					Figure 8-2: Use the Color Picker or enter numeric values to select color in the color panel.

				

					[image: 9781118168608-fg040802.eps]

				The Painting and Retouching Tools

				Grouped together in the Tools panel are the tools used for painting and retouching. The arrow in the lower right area of a tool icon indicates that the tool has more related hidden tools; simply click and hold the tool icon to see additional painting and retouching tools. In this chapter, we show you how to use the Brush, Clone Stamp, Eraser, Gradient, Healing Brush, History Brush, Patch, Red Eye, and Spot Healing Brush tools. You also discover ways to fill shapes with colors and patterns.

				Changing the brush

				As you click to select different painting tools, you can change the size and diameter of the tool. You can do this by accessing the Brush menu (second from the left) on the Options bar, as shown in Figure 8-3. Click the arrow to open the Brushes Preset picker. You can use the Master Diameter slider to make the brush size larger or smaller and to change the hardness of the brush.

					

				
					Figure 8-3: The Brushes Preset picker.

				

					[image: 9781118168608-fg040803.tif]

				[image: tip.eps]	The hardness refers to the fuzziness of the edges; a softer brush is more feathered and soft around the edges, whereas a harder edge is more definite. (See Figure 8-4.)

					

				
					Figure 8-4: The lines on the left have a soft edge; the lines on the right have a hard-edged brush stroke.

				

					[image: 9781118168608-fg040804.tif]

				[image: tip.eps]	If you don’t feel like accessing the Brushes Preset picker every time you want to make a change, press the right bracket (]) several times to make the brush diameter larger or press the left bracket ([) to make the brush diameter smaller. Press Shift+] to make the brush harder or Shift+[ to make the brush softer.

				Choose Window⇒Brushes to see a list of brush presets, plus more brush options you can use to create custom brushes. You can also choose other brush libraries from the panel menu. When you select an additional library, a dialog box appears, asking whether you want to replace the current brushes with the brushes in the selected library. Click the Append button to keep existing brushes and add the library to the list, or click OK to replace existing brushes.

				[image: tip.eps]	Access the Brushes Preset picker while you’re painting by right-clicking (Windows) or Control-clicking (Mac) anywhere in the image area. Double-click a brush to select it; press Esc to hide the Brushes Preset picker.

				The Spot Healing Brush tool and  Content-Aware feature

					[image: 9781118168608-ma082.tif]	The Spot Healing Brush tool was a great tool to begin with, but now, with the Content-Aware feature, it’s even better. No matter what level of Photoshop user you are, you’ll appreciate the magic in this tool option.

				In its default settings, the Spot Healing Brush tool quickly removes blemishes and other imperfections in images. Click a blemish and watch it paint matching texture, lighting, transparency, and shading to the pixels being healed. The Spot Healing Brush tool doesn’t require you to specify a sample spot — it automatically samples from around the retouched area.

				Now take this concept a step further by selecting the Content-Aware option on the Options bar. The concept is the same, but if you look at Figure 8-5, you can see that painting with the Spot Healing Brush sets into action an incredible number of calculations that attempt to render pixels similar in detail to its surroundings.

					

				
					Figure 8-5:  Using the Spot Healing Brush tool with the Content-Aware option enabled.

				

					[image: 9781118168608-fg040805.eps]

				Does this work every time? Of course not. Does it work often enough to save you hours of work? Yes!

				You can also take advantage of the Content-Aware feature by using the Fill feature. Simply follow these steps:

					1.	Select the area to be replaced by the new content.

					2.	Choose Edit⇒Fill and, in the Fill dialog box, select Content-Aware from the Use drop-down list, shown in Figure 8-6.

						The content is replaced.

					

				
					Figure 8-6: Use the Content-Aware feature in the Fill dialog box.

				

					[image: 9781118168608-fg040806.eps]

				The Healing Brush tool

					[image: 9781118168608-ma099.tif]	You can use the Healing Brush tool for repairs, such as eliminating scratches and dust from scanned images. The difference between the Spot Healing Brush tool and the Healing Brush tool is that a sample spot is required before applying the Healing Brush. Follow these steps to use this tool:

					1.	Select the Healing Brush tool in the Tools panel. 

						It’s a hidden tool of the Spot Healing Brush tool.

					2.	Find an area in the image that looks good and then Alt-click (Windows) or Option-click (Mac) to sample that area.

						For example, if you want to eliminate a tear in an image, such as the one in Figure 8-7, choose a tear-free area of image near the tear.

					3.	Position the mouse cursor over the area to be repaired and start  painting.

					

				
					Figure 8-7: Position the cursor over the area that you want to use as a source for the Healing Brush tool and Alt-click or Option-click.

				

					[image: 9781118168608-fg040807.eps]

						The Healing Brush tool goes into action, blending and softening to create a realistic repair of the area.

					4.	Repeat Steps 2 and 3 as necessary to repair the additional tears, scratches, blemishes, and wrinkles.

				The Patch tool

					[image: 9781118168608-ma100.tif]	Hidden behind the Healing Brush tool in the Tools panel is the Patch tool. Use it to repair larger areas, such as a big scratch or a large area of skin, by following these steps:

					1.	Click and hold the Healing Brush tool to select the Patch tool; on the Options bar, select the Destination radio button.

						You can patch either the source area or the destination — it’s up to you. We recommend dragging a good source over the area that needs repaired.

					2.	With the Patch tool still selected, drag to create a marquee around the source you want to use as the patch.

						The source is an unscratched or wrinkle-free area.

					3.	After you create the marquee, drag the selected source area to the destination to be repaired.

						The Patch tool clones the selected source area while you drag it to the destination (the scratched area); when you release the mouse button, the tool blends in the source selection and repairs the scratched area!

				[image: tip.eps]	Make the patch look better by choosing Edit⇒Fade Patch Selection immediately after you apply the patch. Adjust the opacity until no telltale signs show that you made a change.

				The Red Eye tool

					[image: 9781118168608-ma101.tif]	So you finally got the group together and shot the perfect image, but red eye took over! Red eye is caused by a reflection of the camera’s flash in the retina of your photo’s subject or subjects. You see this effect more often when taking pictures in a dark room, because the subject’s irises are wide open. If you can, use your camera’s red-eye-reduction feature. Or, use a separate flash unit that you can mount on the camera farther from the camera’s lens.

				You’ll love the fact that red eye is extremely easy to fix in Photoshop. Just follow these steps:

					1.	Select the Red Eye tool (hidden behind the Spot Healing Brush tool).

					2.	Click and drag to surround the red-eye area.

						You should see a change immediately, but if you need to make adjustments to the size or the darkness amount, you can change options on the Options bar.

				The Brush tool

					[image: 9781118168608-ma083.tif]	Painting with the Brush tool in Photoshop is much like painting in the real world. However, unlike a real brush, the Brush tool offers you nifty keyboard shortcuts that can be much more productive when painting. These shortcuts are truly outstanding, so make sure that you try them while you read about them. By the way, the keyboard commands you see in Table 8-1 work on all the painting tools.

				Table 8-1	Brush Keyboard Shortcuts

				
					
						
								
								Task

							
								
								Windows

							
								
								Mac

							
						

						
								
								Choose the Brush tool

							
								
								B

							
								
								B

							
						

						
								
								Increase the brush size

							
								
								]

							
								
								]

							
						

						
								
								Decrease the brush size

							
								
								[

							
								
								[

							
						

						
								
								Harden the brush

							
								
								Shift+]

							
								
								Shift+]

							
						

						
								
								Soften the brush

							
								
								Shift+[

							
								
								Shift+[

							
						

						
								
								Sample the color

							
								
								Alt-click

							
								
								Option-click

							
						

						
								
								Switch the foreground and background colors

							
								
								X

							
								
								X

							
						

						
								
								Change the opacity by a given percentage

							
								
								Type a number between 1 and 100

							
								
								Type a number between 1 and 100

							
						

					
				

				If you’re really into brushes, don’t miss out on the many useful options available in the Brushes panel (choose Window⇒Brushes to open it), as shown in Figure 8-8.

					

				
					Figure 8-8: Additional options are available for painting in the Brushes panel.

				

					[image: 9781118168608-fg040808.tif]

				You have several attribute choices, most of which have dynamic controls in the menu option. These options allow you to vary brush characteristics by tilting or applying more pressure to a stylus pen (if you’re using a pressure-sensitive drawing tablet), among other things.

				[image: remember.eps]	A warning sign indicates that you don’t have the appropriate device attached to use the selected feature, such as a pressure-sensitive drawing tablet.

				The following options are available in the Brushes panel:

				[image: check.png] Brush Tip Shape: Select from these standard controls for determining brush dimensions and spacing.

				[image: check.png] Shape Dynamics: Change the size of the brush as you paint.

				[image: check.png] Scattering: Scatter the brush strokes and control the brush tip count.

				[image: check.png] Texture: Choose from preexisting patterns or your own.

				[image: tip.eps]		Create a pattern by selecting an image area with the Rectangular Marquee tool. Choose Edit⇒Define Pattern, name the pattern, and then click OK. The pattern is now available in the Brushes panel’s Texture choices.

				[image: check.png] Dual Brush: Use two brushes at the same time.

				[image: check.png] Color Dynamics: Change the color as you paint.

				[image: check.png] Transfer: Adjusts the dynamics for the build-up of the paint.

				[image: check.png] Brush Pose: Adjusts the tilt of the brush. You won’t notice a difference when you have a regular rounded brush selected. Activate Pose when you use a beveled brush and change the X and Y tilt using the sliders to see how the angle of the brush is changed.

				[image: check.png] Noise: Adds a grainy texture to the brush stroke.

				[image: check.png] Wet Edges: Makes the brush stroke appear to be wet by creating a heavier amount of color on the edges of the brush strokes.

				[image: check.png] Airbrush: Gives airbrush features to the Brush tools. Enable the Airbrush feature by clicking the Airbrush button and adjusting the pressure and flow on the Options bar.

				[image: tip.eps]		If you click and hold the Brush tool on the image area, the paint stops spreading. Turn on the Airbrush feature and notice that when you click and hold, the paint keeps spreading, just like using a can of spray paint. You can use the Flow slider on the Options bar to control the pressure.

				[image: check.png] Smoothing: Smoothes the path created with the mouse.

				[image: check.png] Protect Texture: Preserves the texture pattern when applying brush  presets.

				In addition to the preceding options, you can adjust the jitter of the brush. The jitter specifies the randomness of the brush attribute. At 0 percent, an element doesn’t change over the course of a stroke; at 100 percent, a stroke totally varies from one attribute to another.

				After reviewing all the available brush options, you may want to start thinking about how you’ll apply the same attributes later. Saving the Brush tool attributes is important as you increase your skill level. See the Saving Presets section later in this chapter to see how.

				The Clone Stamp tool

					[image: 9781118168608-ma084.tif]	The Clone Stamp tool is used for pixel-to-pixel cloning. The Clone Stamp tool is different from the Healing Brush tool in that it does no automatic blending into the target area. You can use the Clone Stamp tool for removing a product name from an image, replacing a telephone wire that’s crossing in front of a building, or duplicating an item.

				Here’s how to use the Clone Stamp tool:

					1.	With the Clone Stamp tool selected, position the cursor over the area you want to clone and then Alt-click (Windows) or Option-click (Mac) to define the clone source.

					2.	Position the cursor over the area where you want to paint the cloned pixels and then start painting.

						Note the cross hair at the original sampled area, as shown in Figure 8-9. While you’re painting, the cross hair follows the pixels you’re cloning.

					

				
					Figure 8-9: A cross hair over the source shows what you’re cloning.

				

					[image: 9781118168608-fg040809.eps]

				[image: tip.eps]	When using the Clone Stamp tool for touching up images, you should resample many times so as to not leave a seam where you replaced pixels. A good clone stamper Alt-clicks (Windows) or Option-clicks (Mac) and paints many times over until the retouching is complete.

				Choose Window⇒Clone Source to open the Clone Source panel, shown in Figure 8-10. With this handy little panel, you can save multiple clone sources to refer to while working. Even better, you can scale, preview, and rotate your clone source — before you start cloning.

					

				
					Figure 8-10: Additional options in the Clone Source panel. In this example the apple rotates 180 degrees while being cloned.

					
				

					[image: 9781118168608-fg040810.eps]

				[image: tip.eps]	The Clone Source panel can be extremely helpful with difficult retouching projects that involve a little more precision.

				Follow these steps to experiment with this fun and interactive panel:

					1.	If the Clone Source panel isn’t visible, choose Window⇒Clone Source.

						The Clone Source icons across the top have yet to be defined. The first stamp is selected as a default.

					2.	Alt-click (Windows) or Option-click (Mac) in the image area to record the first clone source.

					3.	Click the second Clone Source icon at the top of the Clone Source panel and then Alt-click (Windows) or Option-click (Mac) somewhere else on the page to define a second clone source.

						Repeat as needed to define more clone sources. You can click the Clone Source icons at any time to retrieve the clone source and start cloning.

					4.	Enter any numbers you want in the Offset X and Y, W and H, and Angle text boxes in the center section of the Clone Source panel to set up transformations before you clone.

					5.	Select the Show Overlay check box to see a preview of your clone source.

						Whatever you plan to do, it’s much easier to see a preview before you start cloning. If you don’t use the Clone Source panel for anything else, use it to see a preview of your clone source before you start painting. If it helps to see the clone source better, select the Invert check box.

						You see an overlay (or preview) before cloning begins. This overlay helps you better align your image, which is helpful for precision work. If you want the preview to go away after you start cloning, select the Auto Hide check box.

				The History Brush tool

				Choose Window⇒History to see the History panel. You could play around for weeks in the History panel, this section gives you only the basic concepts.

				At the top of the History panel is a snapshot of the last-saved version of the image. Beside the snapshot is an icon noting that it’s the present History state, as shown in Figure 8-11.

					

				
					Figure 8-11: The History panel helps you see and select different states in your workflow to revert to.

				

					[image: 9781118168608-fg040811.eps]

					[image: 9781118168608-ma085.tif]	When you paint with the History Brush tool, it reverts by default back to the way the image looked in the last saved version. You can click the empty square to the left of any state in the History panel (see Figure 8-11) to make it the source for the History Brush tool. Use the History Brush tool to fix errors and add pizzazz to images.

				The Eraser tool

					[image: 9781118168608-ma086.tif]	You may not think of the Eraser tool as a painting tool, but it can be! When you drag the image with the Eraser tool, it rubs out pixels to the background color. (Basically, it paints with the background color.) If you’re dragging with the Eraser tool on a layer, it rubs out pixels to reveal the layer’s transparent background. (You can also think of using the Eraser tool as painting with transparency.)

				The Eraser tool uses all the same commands as the Brush tool. You can make an eraser larger or softer or more or less opaque. Even better, follow these steps to use the Eraser tool creatively:

					1.	Open any color image and apply a filter.

						For example, we chose Filter⇒Blur⇒Gaussian Blur. In the Gaussian Blur dialog box that appears, we changed the blur to 5 and then clicked OK to apply the Gaussian Blur filter.

					2.	Select the Eraser tool and press 5 to change it to 50 percent opacity.

						You can also use the Opacity slider on the Options bar.

					3.	Hold down the Alt (Windows) or Option (Mac) key to repaint 50 percent of the original image’s state before applying the filter.

					4.	Continue painting in the same area to bring the image back to its original state.

						The original sharpness of the image returns where you painted.

				[image: remember.eps]	Holding down the Alt (Windows) or Option (Mac) key is the key to erasing the last saved version (or history state). This tool is incredible for fixing mistakes or removing applied filters.

				The Gradient tool

					[image: 9781118168608-ma087.tif]	Choose the Gradient tool and click and drag across an image area to create a gradient in the direction and length of the mouse motion. A short drag creates a short gradient; a long drag produces a smoother, longer gradient.

				From the Options bar, you also can choose the type of gradient you want: Linear, Radial, Angle, Reflected, or Diamond.

				As a default, gradients are created using the current foreground and background colors. Click the arrow on the Gradient button on the Options bar to assign a different preset gradient.

				To create a gradient, follow these steps:

					1.	Choose the Gradient tool and click the Gradient Editor button on the Options bar.

						The Gradient Editor dialog box appears. At the bottom of the gradient preview, you see two or more stops, which is where new colors are inserted into the gradient. They look like little house icons. Use the stops on top of the gradient slider to determine the opacity.

					2.	Click a stop and click the color swatch to the right of the word Color to open the Color Picker and assign a different color to the stop.

					3.	Click anywhere below the gradient preview to add more color stops.

					4.	Drag a color stop off the Gradient Editor dialog box to delete it.

					5.	Click the top of the gradient preview to assign different stops with varying opacity, as shown in Figure 8-12.

					

				
					Figure 8-12: Assigning varying amounts of opacity using the stops on top of the gradient slider.

				

					[image: 9781118168608-fg040812.eps]

					6.	When you’re finished editing the gradient, name it and then click the New button.

						The new gradient is added to the preset gradient choices.

					7.	To apply your gradient, drag across a selection or image with the Gradient tool.

				Blending Modes

				You can use blending modes to add flair to the traditional opaque paint. Use blending modes to paint highlights or shadows that allow details to show through from the underlying image or to colorize a desaturated image. You access the blending modes for paint tools from the Options bar.

				You can’t get an accurate idea of how the blending mode works with the paint color and the underlying color until you experiment. (That’s what multiple undos are for!) Alternatively, you can copy to a new layer the image you want to experiment with and hide the original layer; see Chapter 9 of this minibook for more about layers.

				This list describes the available blending modes:

				[image: check.png] Normal: Paints normally, with no interaction with underlying colors.

				[image: check.png] Dissolve: Gives a random replacement of the pixels, depending on the opacity at any pixel location.

				[image: check.png] Behind: Edits or paints only on the transparent part of a layer.

				[image: check.png] Darken: Replaces only the areas that are lighter than the blend color. Areas darker than the blend color don’t change.

				[image: check.png] Multiply: Creates an effect similar to drawing on the page with magic markers. Also looks like colored film that you see on theater lights.

				[image: check.png] Color Burn: Darkens the base color to reflect the blend color. If you’re using white, no change occurs.

				[image: check.png] Linear Burn: Looks at the color information in each channel and darkens the base color to reflect the blending color by decreasing the brightness.

				[image: check.png] Darker Color: Compares the total of all channel values for the blend and base color and displays the lower value color.

				[image: check.png] Lighten: Replaces only the areas darker than the blend color. Areas lighter than the blend color don’t change.

				[image: check.png] Screen: Multiplies the inverse of the underlying colors. The resulting color is always a lighter color.

				[image: check.png] Color Dodge: Brightens the underlying color to reflect the blend color. If you’re using black, there’s no change.

				[image: check.png] Linear Dodge: Looks at the color information in each channel and brightens the base color to reflect the blending color by increasing the brightness.

				[image: check.png] Lighter Color: Compares the total of all channel values for the blend and base color and displays the higher-value color.

				[image: check.png] Overlay: Multiplies or screens the colors, depending on the base color.

				[image: check.png] Soft Light: Darkens or lightens colors, depending on the blend color. The effect is similar to shining a diffused spotlight on the artwork.

				[image: check.png] Hard Light: Multiplies or screens colors, depending on the blend color. The effect is similar to shining a harsh spotlight on the artwork.

				[image: check.png] Vivid Light: Burns or dodges colors by increasing or decreasing the  contrast.

				[image: check.png] Linear Light: Burns or dodges colors by decreasing or increasing the brightness.

				[image: check.png] Pin Light: Replaces colors, depending on the blend color.

				[image: check.png] Hard Mix: Paints strokes that have no effect with other Hard Mix paint strokes. Use this mode when you want no interaction between the colors.

				[image: check.png] Difference: Subtracts either the blend color from the base color or the base color from the blend color, depending on which one has the greater brightness value. The effect is similar to a color negative.

				[image: check.png] Exclusion: Creates an effect similar to, but with less contrast than, Difference mode.

				[image: check.png] Subtract: Subtracts pixel values of one layer with the other. In case of negative values, black is displayed.

				[image: check.png] Divide: Divides pixel values of one layer with the other.

				[image: check.png] Hue: Applies the hue (color) of the blend object to underlying objects but keeps the underlying shading or luminosity intact.

				[image: check.png] Saturation: Applies the saturation of the blend color but uses the luminance and hue of the base color.

				[image: check.png] Color: Applies the blend object’s color to underlying objects but preserves the gray levels in the artwork. This mode is helpful for tinting objects or changing their colors.

				[image: check.png] Luminosity: Creates a resulting color with the hue and saturation of the base color and the luminance of the blend color. This mode is the opposite of Color mode.

				Painting with color

				This section provides an example of using blending modes to change and add color to an image. An example of using a blending mode is tinting a black-and-white (grayscale) image with color. You can’t paint color in Grayscale mode, so follow these steps to add color to a black-and-white image:

					1.	Open an image in any color mode and choose Image⇒Mode⇒RGB.

					2.	If the image isn’t already a grayscale image, choose Image⇒Adjustments⇒Desaturate.

						This feature makes it appear as though the image is black-and-white, but you’re still in a color mode and can apply color.

					3.	Choose a painting tool (the Brush tool, for example) and, from the Swatches panel, choose the first color you want to paint with.

					4.	On the Options bar, select Color from the Mode drop-down list and then use the Opacity slider to change the opacity to 50 percent.

						You can also just type 5.

					5.	Start painting!

						Color Blending mode is used to change the color of pixels while keeping intact the underlying grayscale (shading).

				[image: tip.eps]	Another way to bring attention to a certain item in an RGB image (such as those cute greeting cards that have the single rose in color and everything else in black and white) is to select the item you want to bring attention to. Choose Select⇒Modify⇒Feather to soften the selection a bit — 5 pixels is a good number to enter in the Feather Radius text field. Then choose Select⇒Inverse. With everything else selected, choose Image⇒Adjustments⇒Desaturate. Everything in the image looks black and white, except for the original item you selected.

				Filling selections

				If you have a definite shape that doesn’t lend itself to being painted, you can fill it with color instead. Make a selection and choose Edit⇒Fill to access the Fill dialog box. From the Use drop-down list, you can select from the following options to fill the selection: Foreground Color, Background Color, Color (to open the Color Picker while in the Fill dialog box), Content-Aware, Pattern, History, Black, 50% Gray, or White.

				If you want to use an existing or saved pattern from the Brushes panel, you can retrieve a pattern by selecting Pattern in the Fill dialog box as well. Select History from the Use drop-down list to fill with the last version saved or the history state.

					[image: 9781118168608-ma102.tif]	If you’d rather use the Paint Bucket tool, which fills based on the tolerance specified on the Options bar, it’s hidden in the Gradient tool. To use the Paint Bucket tool to fill with the foreground color, simply click the item you want to fill.

				Saving Presets

				All Photoshop tools allow you to save presets so that you can retrieve them from a list of presets. The following steps show you an example of saving a Brush tool preset, but you can use the same method for all other tools as well:

					1.	Choose a brush size, color, softness, or any other characteristic.

					2.	Click the Tool Preset Picker button on the left side of the Options bar.

					3.	Click the Gear icon in the upper right corner to access the fly-out menu and then choose New Tool Preset.

						The New Tool Preset dialog box appears.

					4.	Type a descriptive name in the Name text field (leave the Include Color check box selected if you want the preset to also remember the present color) and then click OK.

					5.	Access the preset by clicking the tool’s Preset Picker button and choosing it from the tool’s Preset Picker list.

				Each preset you create is specific to the tool it was created in, so you can have a crop preset and an eraser preset, for example. After you get in the habit of saving presets, you’ll wonder how you ever got along without them.

			

			
		

	
		
			
				Chapter 9: Using Layers

				In This Chapter

				[image: check.png] Discovering layers

				[image: check.png] Using text as a layer

				[image: check.png] Implementing layer masks

				[image: check.png] Organizing layers

				[image: check.png] Using Smart Objects

				[image: check.png] Using 3D layers to create 3D objects

				[image: check.png] Merging and flattening a layered image

				Knowledge of layers can be incredibly helpful when producing images in Photoshop. By using layers, you can make realistic additions to an image that can later be removed, edited, and changed with blending modes and transparency settings. This chapter shows you how to create composite images using helpful layer features. Even if you’re an experienced Photoshop user, read this chapter to discover all sorts of great key commands that can help you improve your workflow.

				If you’re a video professional, you can open videos in Photoshop. Photoshop Extended automatically creates a Movie layer, and with the Timeline, you can do pixel editing frame by frame!

				The Creative Suite Design Premium includes the extended version of Photoshop, which means that you can convert layers into 3D files. Though many 3D features are beyond the scope of this book, you can still discover enough to be dangerous by reviewing the section “Experimenting with 3D Files,” later in this chapter.

				Creating and Working with Layers

				Layers make creating composite images (images pieced together from other, individual images) easy because you can separate individual elements of the composite onto their own layers. Much like creating collages by cutting pictures from magazines, you can mask out selections on one image and place them on a layer in another image. When pixel information is on its own layer, you can move it, transform it, correct its color, or apply filters only to that layer, without disturbing pixel information on other layers.

				The best way to understand how to create and use layers is to, well, create and use layers. The following steps show you how to create a new, layered image:

					1.	Choose File⇒New to create a new document.

						The New dialog box appears.

					2.	Select Default Photoshop Size from the Preset Sizes drop-down list, select the Transparent option from the Background Contents area, and then click OK.

						Because you selected the Transparent option, the layer appears as a checkerboard pattern, which signifies that it’s transparent, versus a white background layer.

				[image: tip.eps]		If you don’t like to see the default checkerboard pattern where there’s transparency, choose Edit⇒Preferences⇒Transparency and Gamut (Windows) or Photoshop⇒Preferences⇒Transparency and Gamut (Mac). In the Preferences dialog box that appears, you can change the Grid Size drop-down list to None to remove the checkerboard pattern entirely. If you don’t want to remove the transparency grid, you can change the size of the checkerboard pattern or change the color of the checkerboard.

				[image: remember.eps]		When you open an existing document (say, a photograph), this image is the background layer.

					3.	Create a square with the Rectangular Marquee tool on the new layer.

						For example, we created a green square by using the Rectangular Marquee tool to create a square selection; we then filled the selection with green by double-clicking the Foreground color swatch, selecting a green shade of color from the Color Picker, and clicking in the selection with the Paint Bucket tool (hidden under the Gradient tool).

				[image: tip.eps]		After you select a color, you can also use the key command Alt+Delete (Windows) or Option+Delete (Mac) to fill the selected area with your foreground color.

					4.	To rename the layer, double-click the layer name (Layer 1) in the Layers panel and type a short, descriptive name.

						A good practice is to name layers based on what they contain; for this example, we named the layer we created in Step 3 the catchy name square.

						5.	[image: 9781118168608-ma103.tif] Create a new layer by Alt-clicking (Windows) or Option-clicking (Mac) the New Layer button at the bottom of the Layers panel.

						The New Layer dialog box appears. By holding down Alt (Windows) or Option (Mac), you can name the layer while you create it.

					6.	In this example, you’ll add a circle, so name the layer Red circle.  Click OK.

					7.	Create a circle using the Elliptical Marquee tool on the new layer.

						In this example, we created a red circle by using the Elliptical Marquee tool and filled it with red.

				[image: tip.eps]		The keyboard shortcut for Edit⇒Fill is Shift+Delete. After the dialog box opens, you can choose Use⇒Color and select a red color from the Color Picker.

						The new shape can overlap the shape on the other layer, as shown in Figure 9-1.

					

				
					Figure 9-1: The circle overlaps the square.

				

					[image: 9781118168608-fg040901.tif]

				Duplicating a layer

				Perhaps you want to create a duplicate of a layer for your composite. This technique can be helpful for creating do-it-yourself drop shadows and for adding elements to an image, such as more apples in a bowl of fruit.

					[image: 9781118168608-ma103.tif]	Press Alt (Windows) or Option (Mac) and drag a layer to the New Layer button at the bottom of the Layers panel to duplicate it. Again, by holding down Alt (Windows) or Option (Mac), you can name the layer while you create it.

				Selecting a layer

				When you start working with layers, you may move or adjust pixels only to discover that you accidentally edited pixels on the wrong layer. Select the layer you plan to work on by clicking the layer name in the Layers panel.

				[image: remember.eps]	Photoshop CS6 represents a selected layer by simply highlighting the layer in the Layers panel. The indicator paintbrush icon is gone in this version.

				Here are some tips to help you select the correct layer:

				[image: check.png] Select the Move tool and then right-click (Windows) or Control-click (Mac) to see a contextual menu listing all layers that have pixel data at the point you clicked and to choose the layer you want to work with.

				[image: check.png] Get in the habit of holding down the Ctrl (Windows) or [image: maccmd] (Mac) key while using the Move tool and when selecting layers. This technique temporarily turns on the Auto Select feature, which automatically selects the topmost visible layer that contains the pixel data you clicked.

				[image: check.png] Press Alt+[ (Windows) or Option+[ (Mac) to select the next layer down from the selected layer in the stacking order.

				[image: check.png] Press Alt+] (Windows) or Option+] (Mac) to select the next layer up from the selected layer in the stacking order.

				Controlling the visibility of a layer

				Hide layers that you don’t immediately need by clicking the Eye icon in the Layers panel. To see only one layer, Alt-click (Windows) or Option-click (Mac) the eye icon of the layer you want to keep visible. Alt-click (Windows) or Option-click (Mac) the Eye icon again to show all layers.

				Rearranging the stacking order

				Layers are like clear pieces of film lying on top of each other. Change the stacking order of the layers in the Layers panel by dragging a layer until you see a black separator line appear, indicating that you’re dragging the layer to that location. You can also use these helpful commands to move a layer:

				
					
						
								
								Command

							
								
								Windows Shortcut

							
								
								Mac Shortcut

							
						

						
								
								Move selected layer up

							
								
								Ctrl+]

							
								
								[image: maccmd]+]

							
						

						
								
								Move selected layer down

							
								
								Ctrl+[

							
								
								[image: maccmd]+[

							
						

					
				

				Creating a Text Layer

				When you create text in Photoshop, the text is created on its own layer. By having the text separate from the rest of the image, applying different styles and blending modes to customize the type, as well as repositioning the text, is simplified.

					[image: 9781118168608-ma091.tif]	To create a text layer, choose the Type tool and click the image area. You can also click and drag to create a text area. The Options bar, shown in Figure 9-2, gives you the controls to change the font, size, blending mode, and color of the text.

					

				
					Figure 9-2: The Text tool options.

				

					[image: 9781118168608-fg040902.eps]

				[image: remember.eps]	When you’re finished typing, you must confirm your text entry by selecting the check box (on the right of the Options bar) or pressing Ctrl+Enter (Windows) or [image: maccmd]+Return (Mac).

				Warping text

					[image: 9781118168608-ma148.tif]	When you click the Create Warped Text button on the Options bar, the Warp Text dialog box appears. You can use it to apply different types of distortion to your text.

				You can still edit text that’s been warped. To remove a warp, click the Create Warp Text button again and select None from the Style drop-down list.

				Fine-tuning text

				For controls such as leading, baseline shift, and paragraph controls, click the Toggle Character and Paragraph Panels icon near the right end of the Options bar.

				Use the keyboard commands in Table 9-1 to fine-tune text in Photoshop. Make sure that you have text selected when you use these shortcuts.

				Table 9-1	Helpful Typesetting Key Commands

				
					
						
								
								Task

							
								
								Windows

							
								
								Mac

							
						

						
								
								Increase the font size

							
								
								Shift+Ctrl+>

							
								
								Shift+[image: maccmd]+>

							
						

						
								
								Decrease the font size

							
								
								Shift+Ctrl+<

							
								
								Shift+[image: maccmd]+<

							
						

						
						
								
								Increase the kerning (the cursor must be between two letters)

							
								
								Alt+→

							
								
								Option+→

							
						

						
								
								Decrease the kerning (the cursor must be between two letters)

							
								
								Alt+←

							
								
								Option+←

							
						

						
								
								Increase the tracking (on several selected letters)

							
								
								Alt+→

							
								
								Option+→

							
						

						
								
								Decrease the tracking (on several selected letters)

							
								
								Alt+←

							
								
								Option+←

							
						

						
								
								Increase or decrease the leading (on several selected lines)

							
								
								Alt+[image: uparrow] or Alt+[image: down]

							
								
								Option+[image: uparrow] or Option+[image: down]

							
						

					
				

				[image: tip.eps]	To change the font, drag over the font family name on the Options bar and then press the up-arrow key ([image: uparrow]) to move up in the font list or the down-arrow key ([image: down]) to move down in the font list.

				After you’re finished editing text, confirm or delete the changes by clicking the buttons on the right end of the Options bar.

				[image: tip.eps]	If you’d rather use key commands to confirm or delete changes, press the Esc key to cancel text changes; press Ctrl+Enter (Windows) or [image: maccmd]+Return (Mac) to commit text changes (or use the Enter key on the numeric keypad).

				Using Layer Masks

				In the following sections, we show you how to create a layer mask from a selection or a pen path. A layer mask covers areas of the image that you want to make transparent and exposes pixels that you want visible. Masks can be based on a selection you’ve created by painting on the mask itself. You can also take advantage of the Pen tool to create a path around the object you want to keep visible.

				Creating a layer mask from a selection

				You need to have two images open to follow these steps where we show you how to create layer masks from a selection:

					1.	When combining images, choose Image⇒Image Size to make sure  that the images are approximately the same resolution and pixel dimensions.

						Otherwise, you may be astonished by the disproportionate images in your composite.

					2.	Choose Window⇒Arrange⇒Tile Vertically or Horizontally to position the images in separate windows.

					3.	Using the Move tool, click one image and drag it to the other image window.

						A black border appears around the image area when you drop an image into another image window. By dragging and dropping an image, you automatically create a new layer on top of the active layer.

				[image: tip.eps]		Hold down the Shift key when dragging one image to another to perfectly center the new image layer in the document window.

						You can also drag a layer (background or regular layer) to another image file. First make sure that no selection is active. Then use the Move tool to drag the layer from the artboard right up to the tab of the image you want it to copy the image to.

					4.	Using any selection method, select a part of the image that you want to keep on the newly placed layer and choose Select⇒Modify⇒Feather to soften the selection. 

						Five pixels should be enough.

						5.	[image: 9781118168608-ma104.tif] Click the Add pixel Mask button at the bottom of the Layers panel.

							A mask is created to the right of the layer, leaving only your selection visible, as shown in Figure 9-3.

					

				
					Figure 9-3: Click the Layer Mask button while you have an active selection to create a custom layer mask.

				

					[image: 9781118168608-fg040903.tif]

					6.	If you click the Layer thumbnail in the Layers panel, the mask thumbnail shows corner edges, indicating that it’s activated.

						While the layer mask is active, you can paint on the mask.

					7.	Select the Brush tool and paint black while the mask thumbnail is selected to cover areas of the image that you don’t want to see; press X to switch to white and paint to expose areas on the image that you do want to see.

						You can even change the opacity while you paint to blend images with each other.

				[image: tip.eps]	To create a smooth transition from one image to another, drag the Gradient tool across the image while the layer mask is selected in the Layers panel.

				Creating a vector mask from a pen path

				A vector mask masks a selection, but it does so with the precision you can get only from using a path. The following steps show you another, slightly more precise, way to create a layer mask by using a pen path:

						1.	[image: 9781118168608-ma090.tif] Use the Pen tool and click from point to point to make a closed pen path.

						If you already have a path, choose Window⇒Paths and click a path to select it.

						See Chapter 5 of this minibook for more about working with the Pen tool.

						2.	[image: 9781118168608-ma104.tif] On the Layers panel, click the Layer Mask button and then click it again (see Figure 9-4).

						Wow — a mask from your pen path! Anything not contained within the path is now masked out. You can still adjust your path (and masked selection) by using the Direct Selection tool to click and drag the anchor points and directional lines in your path.

				If you no longer want a vector mask, drag the thumbnail to the Trash Can in the Layers panel. An Alert dialog box appears, asking whether you want to discard the mask or apply it. Click the Discard button to revert your image to the way it appeared before applying the mask or click the Apply button to apply the masked area.

					

				
					Figure 9-4: Create a mask from your pen path.

				

					[image: 9781118168608-fg040904.tif]

				Organizing Your Layers

				As you advance in layer skills, you’ll want to keep layers named, neat, and in order. In this section, we show you some tips to help you organize multiple layers.

				Activating multiple layers simultaneously

				Select multiple layers simultaneously by selecting one layer and then Shift-clicking to select additional layers. The selected layers are highlighted. Selected layers move and transform together, making repositioning and resizing easier than activating each layer independently.

				Select multiple layers to keep their relative positions to each other and take advantage of alignment features. When you select two or more layers and choose the Move tool, you can take advantage of alignment features on the Options bar (see Figure 9-5). Select three or more layers for distribution options.

					

				
					Figure 9-5:  Align layers with the Move tool align options.

				

					[image: 9781118168608-fg040905.eps]

				Auto-Align Layers tool

				Do you ever have multiple shots of a group, one with the guy’s eyes shut and the girl looking the other way? Or maybe you like the smile in one better than in another. With the auto-alignment feature, you can pull the best parts of multiple images into one “best” image.

				To use this tool, simply have the Move tool active, select multiple layers, and then click the Auto-Align Layers button to the right of the alignment tools. The Auto-Align Layers dialog box appears, as shown in Figure 9-6; make your selection and click OK.

					

				
					Figure 9-6: The Auto-Align Layers feature can help create a better composite.

				

					[image: 9781118168608-fg040906.eps]

				Layer groups

				After you start using layers, you’ll likely use lots of them, and your Layers panel will become huge. If you often scroll to navigate from one layer to another, take advantage of layer groups, which essentially act as folders that hold layers you choose, as shown in Figure 9-7. Just as with a folder you use for paper, you can add, remove, and shuffle around the layers within a layer group. Use layer groups to organize layers and make the job of duplicating multiple layers easier.

					

				
					Figure 9-7: Select the layers that you want to group together and then choose New Group from Layers.

				

					[image: 9781118168608-fg040907.tif]

				To create a layer group, follow these steps:

					1.	After creating several layers, Shift-click to select the layers you want to group together in a set.

					2.	Choose New Group from Layers from the Layers panel menu, name the group, and then click OK.

						That’s it. You’ve created a layer group from your selected layers.

				[image: tip.eps]	With the Blending Mode drop-down list in the Layers panel, you can change all layers within a group to a specific blending mode, or you can use the Opacity slider to change the opacity of all layers in a group at one time. Pass through in the blending mode indicates that no individual blending modes are changed.

				After you create a layer group, you can still reorganize layers within the group or even drag additional layers in or out. You can open and close a layer group with the arrow to the left of the group name.

				Duplicating a layer group

				After you create a layer group, you may want to copy it. For example, you may want to copy an image, such as a button created from several layers topped off with a text layer. The most efficient way to make a copy of that button is to create a layer group and copy the entire group. To copy an image made up of several layers that aren’t in a layer group would require you to individually duplicate each layer — how time-consuming!

				To duplicate a layer group, follow these steps:

					1.	Select a group from the Layers panel.

					2.	From the panel menu, choose Duplicate Group.

						The Duplicate Group dialog box appears.

					3.	For the destination, choose the present document or any open document or create a new document.

						Be sure to give the duplicated set a distinctive name!

					4.	Click OK.

				Using Layer Styles

				Layer styles are wonderful little extra effects that you can apply to layers to create drop shadows and bevel and emboss effects and to apply color overlays, gradients, patterns and strokes, and more.

				Applying a style

				To apply a layer style (for example, the drop shadow style, one of the most popular effects) to an image, follow these steps:

					1.	Create a layer on any image.

						For example, you can create a text layer to see the effects of the layer styles.

					2.	With the layer selected, click and hold the Add a Layer Style button at the bottom of the Layers panel; from the menu options, choose Drop Shadow.

						In the Layer Style dialog box that appears, you can choose to change the blending mode, color, distance spread, and size of a drop shadow. You should see that the style has already applied to your text. Position the cursor on the image area and drag to visually adjust the position of the drop shadow.

					3.	When you’re happy with the drop shadow, click OK to apply it.

				[image: tip.eps]	To apply another effect and change its options, click on the Layer Style button in the Layers panel and choose the name of the layer style from the menu that appears — Bevel and Emboss, for example. In the dialog box that appears, change the settings to customize the layer style and click OK to apply it to your image. For example, if you choose Bevel and Emboss from the Layer Styles menu, you can choose from several emboss styles and adjust the depth, size, and softness.

				Here are some consistent items you see in the Layer Style dialog box:

				[image: check.png] Contour: Use contours to control the shape and appearance of an effect. Click the arrow to open the Contour fly-out menu to choose a contour preset or click the preview of the contour to open the Contour Editor and create your own edge.

				[image: check.png] Angle: Drag the cross hair in the angle circle or enter a value in the Angle text field to control where the light source comes from.

				[image: check.png] Global light: If you aren’t smart about lighting effects on multiple objects, global light makes it seem as though you are. Select the Use Global Light check box to keep the angle consistent from one layer style to another.

				[image: check.png] Color: Whenever you see a color box, you can click it to select a color. This color can be for the drop shadow, highlight, shadow of an emboss, or for a color overlay.

				Creating and saving a style

				If you come up with a combination of attributes you like, click the New Style button in the upper-right area of the Layer Style dialog box. After you name the style, it’s stored in the Styles panel. After you click OK, you can retrieve the style at any time by choosing Window⇒Styles. If it helps, click the panel menu button and choose either Small or Large List to change the Styles panel to show only the name of the styles.

				After you apply a layer style to a layer, the style is listed in the Layers panel. You can turn off the visibility of the style by turning off the Eye icon or even throw away the layer style by dragging it to the Layers panel’s Trash Can.

				Thinking about opacity versus fill

				In the Layers panel, you have two transparency options: one for opacity and one for fill. Opacity affects the opacity of the entire layer, including effects. Fill, on the other hand, affects only the layer itself, but not layer styles. Figure 9-8 shows what happens when the Drop Shadow and Inner Glow effects are applied to text and the fill is reduced to 0 percent. This technique gives you the opportunity to make it look like text is chiseled into rock, wood, or even plastic for the look of a personalized credit card.

					

				
					Figure 9-8: A text layer with styles applied and the fill reduced to 0 percent.

				

					[image: 9781118168608-fg040908.tif]

				Smart, Really Smart! Smart Objects

				Choose File⇒Place and place an image, an illustration, or even a movie into a Photoshop document. A new layer is created and — even better — a Smart Object is created. The double square icon in the lower-right corner of the layer thumbnail indicates that a layer is a Smart Object. This means that you have much more flexibility in the placement of your images because the original pixel information has essentially been embedded into your image.

				Have you ever placed a logo only to find out later that you need it to be three times its size? Resizing is no longer an issue, because the Photoshop Smart Object is linked to an embedded original. If the original is vector, you can freely resize the image repeatedly without worrying about poor resolution. Want to change the spelling of the Illustrator logo you placed? Just double-click the Smart Object and the embedded original is opened directly in Adobe Illustrator. Make your changes, save the file, and — voilà — the file is automatically updated in the Photoshop file.

				What could be better? Smart Filters, of course. You can apply Smart Filters to any Smart Object layer, or even convert a layer to use Smart Filters, by selecting Filters⇒Convert for Smart Filters. After a layer has been converted to a Smart Object, you can choose filters, any filters, and apply them to the layer. If you want to paint out the effects of the filter on the layer, simply paint with black on the Filter Effects thumbnail. Paint with different opacities of black and white to give an artistic feel to the filter effect, as shown in Figure 9-9. You can even turn off filters by turning off the visibility on the Filter Effects thumbnail by clicking the Eye icon to the left of the thumbnail.

					

				
					Figure 9-9: Cover the filter effects by painting on the Filter Effects thumbnail.

				

					[image: 9781118168608-fg040909.tif]

				Experimenting with 3D Files

				As we mention earlier in this chapter, working with 3D files is beyond the scope of this book, but even a 3D novice can experiment with the 3D features implemented in Photoshop CS6. Follow these steps to try out some 3D features on your own:

					1.	Open an existing Photoshop document.

						To eliminate any confusion, it’s best if this document simply has a Background layer and no additional layers.

					2.	If you have an image open with multiple layers, select a layer to which you want to apply 3D perspective.

						3.	[image: 9781118168608-ma076.tif] Select the Move tool.

						4.	Choose 3D⇒New Mesh from Layer⇒Postcard.

						If a warning dialog box appears asking if you want to enter the 3D workspace, click OK.

						The image hasn’t changed, but you can see that you’ve entered the 3D workspace that includes a perspective plane. Also, note that the type layer now has a 3D icon on the layer thumbnail in the Layers panel, as shown in Figure 9-10, indicating that it’s now a 3D layer.

					5.	Experiment with angle and positioning by clicking and dragging on the 3D layer, as shown in Figure 9-11. 

					6.	Use the Object Rotate, Roll, Drag, Slide, and Scale tools located in the Options pane, and shown in Figure 9-12, to change the positioning of the 3D layer.

						Notice that these tools have additional options available on the Options bar across the top of your Photoshop document.

					

				
					Figure 9-10: Creating a 3D layer in Photoshop CS6.

				

					[image: 9781118168608-fg040910.eps]

					

				
					Figure 9-11: Click and drag with the Rotate the 3D Object tool to reposition the 3D layer.

				

					[image: 9781118168608-fg040911.tif]

					

				
					Figure 9-12: The 3D tools appear when you are in the 3D workspace.

				

					[image: 9781118168608-fg040912.eps]

				Filter Capabilities in the Layers Panel

				Now in Photoshop CS6, you can filter the display of layers in the Layers Panel, as shown in Figure 9-13. Filter categories include Kind, Name, Effect, Mode, Attribute, and Color. 

					

				
					Figure 9-13: Filter the Layers in the Layers panel to help you view only the layers you need.

				

					[image: 9781118168608-fg040913.eps]

				If you would rather not use the filters, you can click the Turn Layer Filtering On/Off toggle switch to the right of the filters.

				Merging and Flattening the Image

				Merging layers combines several selected layers into one layer. Flattening occurs when you reduce all layers to one background layer. Layers can increase file size, thereby also tying up valuable processing resources. To keep down file size, you may choose to merge some layers or even flatten the entire image to one background layer.

				Merging

				Merging layers is helpful when you no longer need every layer to be independent, such as when you have a separate shadow layer aligned to another layer and don’t plan to move it again or when you combine many layers to create a composite and want to consolidate it to one layer.

				To merge layers (in a visual and easy way), follow these steps:

					1.	Turn on the visibility of only the layers you want merged.

					2.	Choose Merge Visible from the Layers panel menu.

						That’s it. The entire image isn’t flattened, but the visible layers are now reduced to one layer.

				[image: tip.eps]	To merge visible layers on a target (selected) layer that you create while keeping the visible layers independent, create a blank layer and select it. Then hold down Alt (Windows) or Option (Mac) when choosing Merge Visible from the panel menu.

				Flattening

				[image: warning_bomb.eps]	If you don’t have to flatten your image, don’t! Flattening an image reduces all layers to one background layer, which is necessary for certain file formats. After you flatten an image, you can’t take advantage of blending options or reposition layered items. (Read more about saving files in Chapter 10 of this minibook.)

				If you absolutely must flatten layers, keep a copy of the original, unflattened document for additional edits later.

				To flatten all layers in an image, choose Layer⇒Flatten Image or choose Flatten Image from the panel menu on the Layers panel.

				

			

		

	
		
			
				Chapter 10: Saving Photoshop Images for Print and the Web

				In This Chapter

				[image: check.png] Determining the correct file formats for saving

				[image: check.png] Preparing images for the web

				[image: check.png] Discovering the color table

				[image: check.png] Saving your settings

				It may seem like a minor task, saving your image, but you have to make many decisions at this stage. Where will the image be viewed, onscreen or print? Will the image be large, or will it be the size of your thumbnail? Without selecting the correct settings and format, you may not be able to import your file or place it into other applications. If you save the file in the wrong format, you could delete valuable components, such as layers or saved selections. This chapter provides you with the necessary information to save the file correctly for both print and onscreen displays. Here you discover what the file format choices are and then progress into the Save for Web feature (for saving in the GIF, JPEG, PNG, and WBMP file formats).

				[image: tip.eps]	Saving files in the correct file format is important not only for file size, but also in support of different Photoshop features. If you’re unsure about saving in the right format, save a copy of the file, keeping the original in the PSD format (the native Photoshop format). Photoshop alerts you automatically when you choose a format in the Save As or the Save for Web dialog box that doesn’t support Photoshop features. When you choose a format that doesn’t support some of the features you’ve used, such as channels or layers, a yield sign appears when a copy is being made. With the capability of all Adobe applications (and even non-Adobe applications) to read native Photoshop (.psd) files, be wise and keep files in this native file format unless you have a compelling reason not to.

				Choosing a File Format for Saving

				When you choose File⇒Save for the first time (or you choose File⇒Save As to save a different version of a file), you see at least 18 different file formats to choose from in the Save As Type drop-down list. We don’t cover every format in this chapter (some are specific to proprietary workflows), but we show you which formats are best for the typical workflow you may face.

				Wonderful and easy Photoshop PSD

				If you’re in an Adobe workflow (you’re using any Adobe product), you can keep the image in the native Photoshop PSD format. By selecting this format, transparency, layers, channels, and paths are all maintained and left intact when placed in the other applications.

				If compatibility with older versions of Photoshop is an issue, choose Edit⇒Preferences⇒File Handling (Windows) or Photoshop⇒Preferences⇒File Handling (Mac). Select Always from the Maximize PSD and PSB File Compatibility drop-down list. This choice saves a composite (flattened) image along with the layers of your document. (The PSB format is used for saving large Photoshop documents — in this case, large means they measure more than 30,000 x 30,000 pixels.)

				[image: remember.eps]	Leaving the Maximize PSD and PSB File Compatibility drop-down list set to Always creates a larger file. If file size is an issue, leave the drop-down list set to Ask and use the feature only when you need to open the Photoshop file in older versions of Photoshop.

				Photoshop EPS

				Many applications accept the Encapsulated PostScript (EPS) file format. It’s used to transfer PostScript-language artwork between various applications. It supports vector data, duotones, and clipping paths. This means that text layers and other vector-based artwork will remain scalable.

				When you choose to save in the EPS format, an EPS Options dialog box appears. Leave the defaults alone and click OK.

				[image: warning_bomb.eps]	Alter the settings in the EPS Options dialog box only if you’re familiar with custom printer calibration or if you need to save your image to a specific screen ruling. Screen rulings (lpi, or lines per inch) are usually set in a page layout application, such as Adobe InDesign or QuarkXPress.

				[image: tip.eps]	Even though PowerPoint accepts files saved from Photoshop in the EPS format, it is better to use the PNG format. The PNG format is designed for a better onscreen presentation and produces clearer results. Find out more in the later “PNG” section.

				Photoshop PDF

				If compatibility is an issue, save your file in the Photoshop PDF (Portable Document Format) format. PDF files are supported by more than a dozen platforms when viewers use Acrobat or Adobe Reader. (Adobe Reader is available for free at www.adobe.com.) What a perfect way to send pictures to friends and family! Saving a file in the Photoshop PDF format supports your ability to edit the image when you open the file by choosing File⇒Open in Photoshop.

				[image: tip.eps]	If you’re planning to send a layered file by e-mail, choose Layer⇒Flatten Layers before choosing to save the file as a PDF. This command cuts the file size considerably.

				TIFF

				The Tagged Image File Format (TIFF) is a flexible bitmap image format that’s supported by most image-editing and page-layout applications widely supported by all printers. TIFF supports layers and channels but has a maximum size of 4GB. We hope your files aren’t that large!

				DCS

				The Photoshop Desktop Color Separation (DCS) 1.0 and 2.0 formats are versions of EPS that enable you to save color separations of CMYK (Cyan, Magenta, Yellow, Black) or multichannel files. Some workflows require this format, but if you’ve implemented spot color channels in an image, using the DCS file format is required to maintain them.

				Choose the DCS 2.0 format unless you receive specific instructions to use the DCS 1.0 format — for example, for reasons of incompatibility in certain workflows.

				Saving for the Web

				To access the maximum number of options for the GIF, JPEG, PNG, and WBMP file formats, save your image by choosing File⇒Save for Web. The Save for Web dialog box appears, and you can optimize the image as you save it. This procedure may sound like a big deal, but it’s just the process of making the image file size as small as possible while keeping it visually  pleasing.

				Saving images for the web is a give-and-take experience. You may sacrifice perfect imagery to make the image file size small enough that users can quickly download and view it. Read the upcoming sections on the GIF and JPEG formats to see how to best handle creating web images.

				The following sections describe the differences in the GIF, JPEG, PNG, and WBMP formats. Choose the appropriate format based on the type of image you’re saving.

				[image: tip.eps]	Ensuring that the image size is correct before you save the file for the web is a good practice. If you need to read up on resizing images, see Chapter 6 of this minibook. Generally speaking, you should resize the image to the right pixel dimensions. Choose Filter⇒Sharpen⇒Unsharp Mask to regain some of the detail that was lost in resizing the image, and then save the image for the web.

				GIF

				Supposedly, the way you pronounce GIF (Graphics Interchange Format) is based on the brand of peanut butter you eat. Is it pronounced like the peanut butter brand (Jif) or with a hard g, as in gift? Most people seem to pronounce it as “gift” (minus the T).

				Use the GIF format if you have large areas of solid color, such as a logo like the one shown in Figure 10-1.

					

				
					Figure 10-1: An image with lots of solid color makes a good GIF.

				

					[image: 9781118168608-fg041001.tif]

				The GIF format isn’t lossy (it doesn’t lose data when the file is compressed in this format), but it reduces file size by using a limited number of colors in a color table. The lower the number of colors, the smaller the file size. If you’ve ever worked in Index Color mode, you’re familiar with this process.

				Transparency is supported by the GIF file format. Generally, GIF files don’t do a good job on anything that needs smooth transitions from one color to another because of the format’s poor support of anti-aliasing, which is the method Photoshop uses to smooth jagged edges. When an image transitions from one color to another, Photoshop produces multiple colors of pixels to create an even blend between the two colors.

				Because anti-aliasing needs to create multiple colors for this effect, GIF files generally aren’t recommended. In fact, when you reduce the size of a GIF, you’re more apt to see banding (an artifact that appears as streaks in the image) because the anti-aliasing can’t take place with the limited number of colors available in the GIF format.

				You can, of course, dramatically increase the number of colors to create a smoother transition, but then you risk creating monster files that take forever to download.

				Saving a GIF

				When you choose File⇒Save for Web, you first see the available GIF format options. They may be clearer to you if you have an image open (with lots of solid color in it).

				To save a file for the web as a GIF, follow these steps:

					1.	Choose File⇒Save for Web.

						The Save for Web dialog box appears.

					2.	At the top, click the 2-Up tab.

						You see the original image on the left and the optimized image on the right (or top and bottom, depending on the image proportions).

						In the lower portion of the display, you see the original file size compared with the optimized file size, as well as the approximate download time. The download time is important. Nobody wants to wait around for a web page to load; most people don’t wait more than ten seconds for an entire web page to appear, so try to keep an individual image’s download time to a few seconds at the most. Remember that waiting for all images on a page to load can add up to a monstrous wait time for the viewer!

				[image: tip.eps]		Change the estimated download speed by choosing the Select Download Speed drop-down menu to the right of the file size information in the lower-left of the preview window. The Select Download Speed menu is labeled in Figure 10-2.

					3.	Select GIF 32 No Dither from the Preset drop-down list.

						You may see a change already. As you can see in Figure 10-2, Photoshop supplies you with presets to choose from, or you can customize and save your own.

					

				
					Figure 10-2: Choose from presets, or create your own custom settings.

				

					[image: 9781118168608-fg041002.eps]

					4.	Choose whether you want dithering applied to the image by selecting an option from the Specify the Dither Algorithm drop-down list.

						This choice is purely personal. Because you may be limiting colors, Photoshop can use dithering to mix the pixels of available colors to simulate missing colors. Many designers choose the No Dither option because dithering can create unnatural color speckles in an image.

					5.	If your image is on a transparent layer and you want to maintain that transparency on a web page, select the Transparency check box.

				Using the color table in the Save for Web dialog box

				When you save an image in GIF format using the Save for Web feature, you see the color table. This color table displays the limited color palette used in the image and is located on the right side of the Save for Web window. The color table is important as it not only allows you to see the colors used in the image but also enables you to customize the color table by using the options at the bottom.

				You may want to customize your color table by selecting some colors to be web safe and locking colors so that they’re not bumped off as you reduce the number that’s used.

				To customize a color table, follow these steps:

					1.	If your image has only a few colors that you want to convert to web-safe colors, choose the Eyedropper tool from the left of the Save for Web window and click on the color (right on the image) in the Optimized view.

						The sampled color is highlighted in the color table.

					2.	Click the Web Safe button at the bottom of the color table, as shown in Figure 10-3.

						When you cross over this button, the tooltip Shifts/Unshifts Selected Colors to Web Palette appears.

						A diamond appears, indicating that the color is now web safe.

					3.	Lock colors that you don’t want to delete as you reduce the number of colors in the color table.

						Select a color with the Eyedropper tool, or select it in the color table, and then click the Lock Color button. A white square appears in the lower-right corner, indicating that the color is locked.

						Obviously, if you lock 32 colors and then reduce the color table to 24, some of your locked colors are deleted. If you choose to add colors, those locked colors are the first to return.

					

				
					Figure 10-3: Customize colors by using the color table in the Save for Web window.

				

					[image: 9781118168608-fg041003.eps]

				[image: technicalstuff.eps]		How is the color table created? Based on the color-reduction algorithm method you choose, the Save for Web feature samples the number of colors you indicate. If keeping colors web safe is important, select the Restrictive (Web) option for the method; if you want your image to look better on most monitors but not necessarily to be web safe, choose the Adaptive option.

					4.	Use the Colors drop-down list or enter a number to add or delete colors from the color table.

					5.	If your image uses transparency, select the Transparency check box near the top of the Save for Web dialog box.

				[image: remember.eps]		Remember that transparency is counted as one of your colors in the color table.

					6.	Select the Interlaced check box only if your GIF image is large (25K or larger).

						Selecting this option causes the image to build in several scans on the web page — a low-resolution image that pops up quickly and is then refreshed with the higher-resolution image when the download is complete. Interlacing gives the illusion of the download going faster but makes the file size larger, so use it only if necessary.

					7.	Click Save.

						Now the image is ready to be attached to an e-mail message or used in a web page.

				JPEG

				JPEG (Joint Photographic Experts Group) is a good format for continuous-tone images — those with smooth transitions from one color to another, as in photographs — like the image shown in Figure 10-4.

				[image: remember.eps]	The JPEG format is lossy, so you shouldn’t save a JPEG and then open it, edit it, and save it again as a JPEG. Because the JPEG compression causes data to be lost, your image will eventually look like it was printed on a paper towel. Save a copy of the file as a JPEG, keeping the original image in PSD format if you need to edit the image later, open the original PSD, make your changes, save the PSD, and then save a copy of the edited file as a JPEG.

				The JPEG format does not support transparency, but you can cheat the system a little by using matting.

					

				
					Figure 10-4: Images with smooth transitions from one color to another are good candidates for the JPEG file format.

				

					[image: 9781118168608-fg041004.tif]

				A good image to save in the JPEG format is a typical photograph or illustration with lots of smooth transitions from one color to the next; this includes graphics that use gradients. To save an image as a JPEG, follow these steps:

					1.	Choose File⇒Save for Web, and then click the 2-Up tab to view the original image (left) at the same time as the optimized image (right).

					2.	Select one of the JPEG preset settings from the Settings drop-down list.

						You can choose Low, Medium, or High or customize a level between the presets by using the Quality slider.

					3.	Leave the Optimized check box selected to build the best JPEG at the smallest size.

						The only issue with leaving this check box selected is that some very old browsers don’t read the JPEG correctly (not likely an issue for most viewers).

					4.	Leave the Embed Color Profile check box deselected unless you’re in a color-managed workflow and color accuracy is essential.

						Selecting this check box increases the file size, and most people aren’t looking for exact color matches from an image on the monitor.

					5.	If you have to have the file size even smaller, use the Blur slider to bring down some detail.

						It’s funny, but one JPEG that has exactly the same pixel dimensions as another may vary in file size because the more detailed an image is, the more information is needed. So, an image of lots of apples will be larger than an image of the same size that has one apple in it. The Blur feature blurs the image (surprise!), so you may want to use it for only a low source image in Dreamweaver.

					6.	(Optional) Select a matte color from the Matte drop-down list.

						Because JPEG doesn’t support transparency, you can flood the transparent area with a color you select from the Matte drop-down list. Select the color you’re using for the background of your web page by selecting Other and entering the hexadecimal color in the lower portion of the Color Picker.

					7.	Click Save.

				PNG

				PNG (Portable Network Graphics) offers the perfect combination of GIF and JPEG. Unfortunately, the PNG format creates a file that’s a little larger than a JPEG or GIF. A PNG-24 image may have file sizes that can be too large to use on the web.

				The great news is that PNG supports varying levels of transparency and anti-aliasing. This variation means that you can specify an image as being 50 percent transparent and it shows through to the underlying web page! 

				[image: warning_bomb.eps]	Older browsers do not support PNG files. Users with old browsers may require a plug-in in order to view your page. 

				If you’re saving a PNG file, you have a choice of PNG-8 or PNG-24. The PNG-8 options are essentially the same as the GIF options; see the “Saving a GIF” section, earlier in this chapter, for details.

				PNG-24 saves 24-bit images that support anti-aliasing (the smooth transition from one color to another). These images work beautifully for continuous-tone images but are much larger than a JPEG file. The truly awesome feature of a PNG file is that it supports 256 levels of transparency. In other words, you can apply varying amounts of transparency in an image, as shown in Figure 10-5, where the image shows through to the background.

					

				
					Figure 10-5: A PNG-24 file with varying amounts of trans-parency.

				

					[image: 9781118168608-fg041005.eps]

				WBMP

				The Wireless Application Protocol Bitmap (WBMP) format is optimized for mobile computing, has no compression, is one-bit color (just black and white — no shades), and is one bit deep. WBMP images aren’t necessarily pretty, but they’re functional (see Figure 10-6). You have dithering controls to show some level of tone value.

					

				
					Figure 10-6: The WBMP format supports black-and-white only.

				

					[image: 9781118168608-fg041006.eps]

				If you’re creating images for mobile devices, know that WBMP is part of the Wireless Application Protocol, Wireless Application Environment Specification Version 1.1.

				[image: tip.eps]	Click the Preview button at the bottom left of the Save for Web dialog box to launch your web browser and display the image as it will appear with its present settings. If you haven’t set up a browser, click the down arrow and select Other from the drop-down list. 

				Matte

				Matting appears as a choice in the GIF, JPEG, and PNG format options. Matting is useful if you don’t want ragged edges appearing around your images. Matting looks for pixels that are more than 50 percent transparent and makes them fully transparent; any pixels that are 50 percent or less transparent become fully opaque.

				Even though your image might be on a transparent layer, it will have some “iffy” pixels — the ones that aren’t sure what they want to be . . . to be transparent or not to be transparent. Choose a matte color to blend in with the transparent iffy pixels by selecting Eyedropper Color, Foreground Color, Background Color, White, Black, or Other (to open the Color Picker) from the Matte drop-down list in the Save for Web dialog box.

				Saving Settings

				Whether you’re saving a GIF, JPG, or PNG file, you probably spent some time experimenting with settings to find what works best for your needs. Save selected options to reload later by saving the settings. Do so by clicking the arrow to the right of the Preset drop-down list. Select Save Settings from the list that appears and name your settings. Your named, customized settings then appear in the Preset drop-down list.
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				Chapter 1: Discovering Essential Acrobat Information

				In This Chapter

				[image: check.png] Discovering Acrobat and PDF files

				[image: check.png] Understanding when to use PDF files

				[image: check.png] Becoming familiar with the Acrobat workspace and tools

				Adobe Acrobat X provides a variety of tools for sharing and reviewing documents in the Portable Document Format (PDF). Adobe Creative Suite applications can create PDF files, and you can also use Acrobat to create PDF files from programs that aren’t part of the Creative Suite, such as Microsoft Word. After you create a PDF file, you can use Acrobat to enhance it by adding interactivity, merging it with several related documents into a single PDF, adding comments or annotations or applying security features that restrict document functions, such as printing, editing, or even opening the PDF file itself.

				In this chapter, you find out why you may want to create PDF files and acquaint yourself with the Adobe Acrobat tools and workspace. You see how easy it is to navigate through PDF files with the navigational tools, tabs, and viewing options in Acrobat. In the following chapters of this minibook, you explore how to use Acrobat to create PDF files from documents produced in a variety of programs and discover ways to enhance your PDF files with Acrobat.

				Working with PDF Files

				With Adobe Acrobat, you can create, review, and modify PDF files. Because PDF is a common file format, you can use it to share Creative Suite files for review, approval, or final publication, even with users who don’t have access to Creative Suite programs. When you use a program in the Creative Suite, such as Illustrator or InDesign, to create a document, others would need the same software to open or edit the original program files. By converting your documents to PDF, they can easily be shared with others who might not have the same software as you. PDF files can be viewed by users on virtually all types of computers, tablets, mobile phones, and operating systems.

				PDF provides a common file format for viewing files, regardless of what software program was used to create them. Additionally, Acrobat provides extensive tools for reviewing, commenting, and marking files so that you can easily collaborate on a project without modifying the original document, along with tools to make PDF files interactive, merge related documents together, and secure files to restrict viewing or editing.

				Because the software to view PDF files is free, you can be assured that those receiving your files don’t need to purchase any special software. In fact, the odds are quite good that most users already have some type of free PDF viewing software, such as Adobe Reader, on their smart phone, tablet, or computer.

				PDF has become a popular way to share files because it provides a true reproduction of an original document, which can be important for forms, financial documents, brochures, catalogs, and other items sent to a printing vendor. Many businesses also use PDF documents because the electronic documents can be secured, and they accurately represent documents that have been approved for distribution. Even scanned documents can be saved in the PDF format and secured using Acrobat. Graphic artists even use PDF files to send books, such as the one you’re reading now, to the printing plant.

				Although PDF files provide a high-quality representation of an original file, they’re more than just a picture of a document. PDF files retain the high-quality appearance of text while keeping the text searchable. Logos and illustrations created with Adobe Illustrator retain a high-quality appearance when converted to PDF, and intricate details from bitmap images, such as those edited with Adobe Photoshop, can also be maintained. PDF files allow you to distribute a high-fidelity electronic document. When creating a PDF file, you can choose settings that make the file suitable for high-quality printing or make the file smaller and more suitable for posting to a website or sharing as an e-mail attachment. PDF documents can also be used to create enhanced electronic documents and portfolios. Acrobat lets you combine multiple PDF files together into a single portfolio for sharing.

				Although Acrobat is part of the Creative Suite, it’s not a design tool — rather, it’s a tool for distributing documents created in other software programs and enhancing these documents for online distribution. You generally don’t use Acrobat to build new documents. Acrobat is a medium for sharing files, not for creating or designing documents. With Acrobat, you can

				[image: check.png] Share documents with users who don’t have the same software or fonts that you use.

				[image: check.png] Review and mark PDF files that others send you. With Adobe Acrobat, you can enable a PDF file to be reviewed by users with the free Adobe Reader software.

				[image: check.png] Combine documents created in other programs. You can use Acrobat to merge PDF files together into one document, even files that may have been originally created in different programs.

				[image: check.png] Create a PDF portfolio. You can combine various file formats into a single PDF package and yet retain the files in their original file formats.

				[image: check.png] Edit Adobe PDF files to make minor changes to text or graphics.

				[image: check.png] Apply security to PDF files when you don’t want them changed or you want to restrict viewing to certain individuals.

				[image: check.png] Add interactivity to PDF files by enhancing them with sounds, movies, animations, and buttons.

				[image: check.png] Create interactive forms to collect information electronically, avoiding the need for manual data collection.

				We cover these capabilities throughout the rest of this minibook.

				Knowing When to Use Adobe PDF Files

				So when does it make sense to use Adobe PDF files? Here are some examples:

				[image: check.png] When you want to review a document quickly and efficiently: When documents need to be reviewed or approved, Acrobat really shines. The reviewers don’t need to have the Creative Suite software — or whatever you used to create the document. They need only a program to view PDF files, such as the free Adobe Reader or the Apple Preview application. Recipients can then use commenting, markup, and annotation tools to add suggestions and edits to a file. You can even combine comments from multiple reviewers into a single document and manage the review process online or via e-mail. 

				[image: check.png] When you’ve created a document that you don’t want others to edit: Your recipients may have the same software you used to build the document, but you can keep them from editing the original file by distributing it as a PDF file. Whether you want to secure a spreadsheet from editing or an InDesign document from modification, Acrobat includes security options that allow you to protect your original content.

				[image: check.png] When you’ve created a presentation that includes files from different programs: By converting the documents to PDF, you can combine them into a single file. For example, you can merge PowerPoint, Excel, and InDesign files into a single PDF document. Whether you need to protect your brand and identity by keeping documents from being edited or simply want to ease the process of sharing files, PDF makes it easy to share your ideas.

				[image: check.png] When you have a sensitive document: If you have a document containing information that you don’t want unauthorized persons viewing or you don’t want printed, you can enhance the file with security with the Adobe Acrobat security tools. With the security options, you can require users to enter a password to view the file, or you can limit other features, such as the ability to print or edit the document.

				Introducing the Adobe Acrobat Workspace and Tools

				To take advantage of all that Acrobat has to offer, take some time to discover the workspace and tools so you can get around within a PDF file. Acrobat opens with a blank workspace, and most tools and capabilities aren’t available until you open a document. If you already have a PDF file you want to open, you can open the document by clicking the folder icon with the green arrow in the upper-left corner of the Document window or choosing File⇒Open.

				You can also open recently viewed PDF files right from the Acrobat start screen, which also makes it easy to create a new PDF document or combine PDF files into a single file. (See Figure 1-1.)

					

				
					Figure 1-1: Use the Acrobat Start screen to open recent files or create new PDF documents.

				

					[image: 9781118168608-fg050101.tif]

				When you open a document, you see the Acrobat workspace, which is divided into three areas. The largest portion of the workspace is the Document window, which displays the document you have opened. Across the top, the tools are stored in the toolbar well. Along the left side of the window, you find the navigation panels that help you find your way through the document. When you open a PDF document with Acrobat, you can use the toolbars and buttons in the toolbar well to navigate a file, and you can use the navigation panel to move through a PDF file. For example, a PDF file may contain multiple pages. You can use the navigational buttons or the Pages panel to move among pages and then use a tool to manipulate the file, such as the commenting tools.

				In the upper-right corner of the toolbar well, you can access additional tools, commenting and review features, and sharing capabilities. Clicking any of these buttons causes the additional tools to be displayed along the right side of the Document window. (See Figure 1-2.)

					

				
					Figure 1-2: Access additional Acrobat features by clicking the Tools button in the upper-right corner.

				

					[image: 9781118168608-fg050102.tif]

				In the toolbar well, you find useful information for navigating through your document, including

				[image: check.png] Current page and total pages: To move to a specific page, click in the area showing the current page, type a different page number, and press Enter (Windows) or Return (Mac).

				[image: check.png] Previous Page and Next Page buttons: Use these navigational buttons to skip forward or backward one page at a time.

				Toolbars

				The toolbars in Acrobat X are customizable, so you can display different toolbars or change the location of existing toolbars to meet your needs.

				Less than half the toolbars and Quick Tools are visible in the default Acrobat display. You can add more tools to the toolbar well along the top of the Document window by positioning your cursor over the toolbar well and then right-clicking (Windows) or Ctrl+clicking (Mac) to display a list of available tools. For example, to add the Marquee Zoom tool to the toolbar well, right-click (Windows) or Ctrl+click (Mac) and then choose Select & Zoom⇒Marquee Zoom to add this tool to the toolbar well.

				Toolbars contain both tools for working on parts of your document and Quick Tools for performing actions which generally impact the entire document. Quick Tools were called buttons in previous versions of Acrobat. Quick Tools perform an immediate task, such as printing, saving, or applying security to a PDF document. In general, most of the task buttons are on the top row of the toolbar well, immediately below the menu bar, and most of the tools are on the bottom row — but you can move these toolbars.

				To add Quick Tools to the toolbar well, right-click (Windows) or Ctrl+click (Mac) and then select Quick Tools. From the Customize Quick Tools window that appears, select from the available choices on the left side of the Document window and click the right-facing arrow to add the function to the list on the right side of the window. Quick Tools listed on the right side of the window are displayed in the toolbar well. (See Figure 1-3.)

				[image: tip.eps]	You can also add Quick Tools by clicking the Quick Tools button in the toolbar well. This button looks like a Gear icon.  

					

				
					Figure 1-3: Add more tools to the toolbarQuick Tools.

				

					[image: 9781118168608-fg050103.tif]

				To access additional tools and commands, click the Tools button at the top-right corner of the Document window; then choose the category of the tool you’d like to use. Within the appropriate category, select the desired tool. For example, to encrypt a PDF using a password, choose Tools⇒Protection⇒Encrypt.

				Changing page magnification

				Sometimes you want to see the entire page of a document; other times, you may only need to read the text or examine a small portion of a page. Acrobat provides several preset viewing options to help you with this, and you can also customize the magnification to zoom in on the page.

				If things are a bit too small for you to see clearly, increase the magnification used for viewing pages with the Zoom drop-down list on the toolbar. Preset magnification choices are available in this drop-down list. In the drop-down list, you can also select options to fit the page in the window by choosing the Zoom to Page Level option from the magnification drop-down list. Use the additional choices to fit the width of the page within the Document window or to view the document at its actual size. You can also use the minus (–) and plus (+) symbols to the left of the current magnification level to decrease or increase the zoom level.

				In the previous section, “Toolbars,” you discover how to add the Marquee Zoom tool to the toolbar. You can use this tool to identify specific portions of a page that you want to magnify. Select this tool and then click and drag around a portion of the page to increase the magnification. You can also click multiple times on an area with this tool to increase the page magnification, but clicking and dragging a box with the Marquee Zoom tool is generally a much faster way to focus on a portion of a page you want to view.

				Viewing modes

				Acrobat provides several viewing modes that control how the document is displayed. For example, you can choose to display the pages of a book or magazine side by side, or view only one page at a time. You can choose which viewing mode is used by choosing View⇒Page Display and selecting the viewing option you want.

				The viewing modes are

				[image: check.png] Single Page View: This mode displays only the current document page onscreen and doesn’t show any adjoining pages. When you scroll to the top or bottom of the current page, other pages aren’t visible at the same time as the current page.

				[image: check.png] Enable Scrolling: With this mode, you can see the current document page, and if you scroll to the top (or bottom) of the current page, the adjoining page is also visible. If you reduce your page viewing magnification, many document pages are visible.

				[image: check.png] Two-Page View: Use this mode to see pages as a spread, where you can view both the left and right sides of adjoining pages at the same time. When you have documents with pictures or text that spans a pair of pages, use this option to see the pages presented side by side in Acrobat. As with the Single Page mode, other pages that go before or fall after the spread aren’t visible — only the one pair of pages is visible onscreen, regardless of the magnification or scrolling.

				[image: check.png] Two-Page Scrolling: If you have a document with many pages containing text or pictures on their adjoining pages, you can use this mode to scroll from one pair of visible pages to the next. When the Two-Up Continuous view is selected, you can see adjoining page spreads. This option is identical to the Two-Up option, but it also shows pages above or below the spread you’re presently viewing.

				If you have pages where images or text goes across pages, the Two-Page View is useful. When displaying a magazine or catalog, the two-page pairs often display incorrectly. For example, a magazine will display the cover (page 1) and page 2 together, instead of displaying the cover on its own and then pages 2 and 3 together. To correct this, choose View⇒Page Display⇒Show Cover Page in Two Page View. Additionally, the default option is for Acrobat to display a space between pages that are displayed together in the Two-Up mode. You can replace the space with a dotted line to divide the adjoining pages by choosing View⇒Page Display⇒Show Gaps between Pages.

				Additional viewing options

				Acrobat has some additional options for changing your document display:

				[image: check.png] Full Screen mode (View⇒Full Screen Mode): Use the Full Screen mode if you’d like to hide all menus, toolbars, and other parts of the Acrobat interface. This option is useful if you want to focus on the document being displayed, not the program being used to view it. Use this mode, for example, when you’ve converted a PowerPoint file to a PDF document and want to deliver the presentation with Acrobat. If you’re viewing a document in the Full Screen mode, press the Esc key to return to the regular viewing mode.

						When using the Full Screen mode, you can select Edit⇒Preferences and choose Full Screen to define attributes that change the way all files display when using the Full Screen mode. You can set the display to advance automatically from one page to the next at a certain interval, choose from many page transition types, and define the background color.

				[image: tip.eps]		You can set a document to automatically open in Full Screen mode. To do so, choose File⇒Properties and then select the Open in Full Screen mode check box in the Initial View panel of the Document Properties dialog box.

				[image: check.png] Read mode (View⇒Read Mode): The many toolbars and buttons of Acrobat can get in the way of the document you want to review. Use Read mode to temporarily hide all the toolbars and buttons, making it easier to focus on the content of the PDF file.

				Navigation panels

				Acrobat offers a variety of panels that are helpful when navigating through PDF documents. The navigation panels appear along the left side of your Document window as small icons. Click an icon to make its panel visible. For example, click the Pages icon to display thumbnail-size representations of each page. 

				In the Page Thumbnails panel, click a thumbnail page to display that page in the Document window. There are 11 panels: Articles, Attachments, Bookmarks, Content, Destinations, Layers, Model Tree, Order, Page Thumbnails, Signatures, and Tags. You can access any of these by choosing View⇒Show/Hide⇒Navigation Panes.

				Many panels have more advanced uses that are covered in later chapters of this minibook. Here, we provide you with a brief understanding of how you can use the Page Thumbnails panel to more easily navigate through a PDF document. Follow these steps:

					1.	Make sure that the Page Thumbnails panel is visible by clicking its panel icon.

					2.	In the Page Thumbnails panel, click any page thumbnail to navigate directly to that page.

						A border appears around the selected page, and a box within the Page Thumbnails panel indicates what portion of the page is being viewed in the Document window.

						You can click the black square icon in the right corner of the small box in the Page Thumbnails panel and drag diagonally upward to increase the magnification on the section of the page contained within the box. Alternatively, make the box larger by clicking and dragging down and out to expand the size of the area being viewed. Changing the size of the black box displayed on the page in the Page Thumbnails panel changes the area being viewed as well as the amount it’s magnified.

				

			

		

	
		
			
				Chapter 2: Creating PDF Files

				In This Chapter

				[image: check.png] Creating PDF files from Microsoft Office documents

				[image: check.png] Creating PDF files from Creative Suite applications

				[image: check.png] Creating PDF files from all other electronic formats

				[image: check.png] Creating PDF files from the web and paper documents

				[image: check.png] Creating PDF portfolios

				Converting documents to the Portable Document Format (PDF) is a great way to share files when readers don’t have the same software as you or when you want to consolidate multiple file types into a single document. Adobe Acrobat lets you create files from all software programs and scanned documents and even pages from the web. Although you can also create PDF files from Adobe Creative Suite 6 (CS6) documents, you don’t need Acrobat for this because the ability to create PDF files is built into the individual Creative Suite programs, such as Photoshop, Illustrator, and InDesign. In this chapter, you find out how to create Adobe PDF files from a variety of programs.

				Creating PDF Files from Microsoft Office

				Adobe Acrobat includes tools that make it easy to convert Microsoft Word, Excel, and PowerPoint files to PDF.

				[image: warning_bomb.eps]	These capabilities are much more robust for the Windows versions of these programs, so Macintosh users may discover that not all these options are available.

				When you install Acrobat on your computer, it looks for Microsoft Office programs. If Acrobat locates Word, Excel, PowerPoint, or Outlook, it installs an add-in — the PDF Maker — to these programs that helps convert Microsoft Office documents to PDF in a single click.

				You can tell whether the PDF Maker add-in has been installed in your Microsoft Office programs by looking for the Acrobat toolbar or the Acrobat tab, depending upon which version of Microsoft Office you use. In Office 2010, the Acrobat tab appears to the right of the View tab. In earlier versions of Microsoft Office, the toolbar appears at the top of the Document window. If the toolbar isn’t visible, choose View⇒Toolbars to see whether the Acrobat toolbar is available in the Toolbars submenu. If it remains unavailable, you may need to reinstall Adobe Acrobat to gain access to the PDF Maker tools.

				[image: remember.eps]	When you convert documents to PDF, the original file remains unchanged, so you have both the original file and a separate PDF document. The original document and the PDF file aren’t linked, so changes to the original source file aren’t reflected in the PDF file. When you edit the PDF document, the changes don’t update in the original file.

				PDF conversion options

				PDF Maker is installed within Microsoft Office at the time you install Acrobat. PDF Maker provides a variety of controls over how PDF files are created from Microsoft Office programs, such as Word and Excel. For example, you can have PDF Maker create PDF files from your Microsoft Office documents each time you click the Create PDF button, without asking you to confirm the location and name of the file. Acrobat simply saves the file in the same location as the original document. Similarly, you can choose to create PDF files that balance your need for quality and file size.

				PDF Maker also provides controls over the type of PDF file you create because some PDF files may need to be of a higher quality for printing and others may need to be smaller to allow for fast electronic distribution. For example, you may want to post a PDF document to a website, where you want to make the file small so that it can be downloaded quickly.

				When working in Microsoft Word, Excel, or PowerPoint, you can access the PDF Maker controls by clicking the Acrobat tab and then clicking the Preferences button (Office 2010) or by choosing Adobe PDF⇒Change Conversion Settings (earlier versions of Microsoft Office). In the Acrobat PDF Maker dialog box that appears, you can then choose from a variety of settings that control how the PDF file is created. In this section, we focus on the most useful options for Microsoft Office users.

				After you click the Preferences button, the Acrobat PDF Maker dialog box opens. In this dialog box, use the Conversion Settings drop-down list to control how the PDF file is generated:

				[image: check.png] Standard: Select this option to create PDF files that will be printed on an office laser printer or distributed via e-mail. This setting meets the needs of most users — it provides some compression of graphics, but they remain clear onscreen and look reasonably good when printed. In addition, this setting builds the fonts into the PDF file to maintain an exact representation of the document, regardless of where the file is viewed.

				[image: check.png] Smallest File Size: With this setting, you can control the file size of the PDF documents you create. This setting provides significant compression of images and also reduces resolution, which causes graphics within the files to lose some clarity and perhaps appear jagged.

						In addition, fonts aren’t embedded in PDF files created with this setting. If the fonts used in the document aren’t available on a computer where a PDF created with the Smallest File Size setting is viewed, Acrobat uses a font substitution technology to replicate the size and shape of the fonts used in the document. This feature typically provides a similar appearance to the original document, but it’s not always an exact match of the original file.

						Because this setting is so lossy, use it only if you need to compress a large file to a small enough size to send as an e-mail attachment. Make certain the recipient has the fonts used in the document installed on his or her computer. Otherwise, Adobe uses font substitution.

				[image: check.png] High Quality Print and Press Quality: If you need to provide PDF files to your commercial printer or copy shop, use these settings to create a PDF file that’s designed for high-quality print reproduction. Along with including fonts in the PDF file, the graphics aren’t significantly compressed, and they maintain a much higher resolution. Overall, these files tend to be larger than similar PDF files created with different settings, but the quality of the PDF file is more important than the file size when you’re having the PDF professionally printed. High Quality Print is suitable for a color copier or high quality laser printer, whereas Press Quality is suitable for a PDF that is sent to a commercial printer.

				Several other highly technical options might be useful for you if you have a specialized profession. For example, if you archive items with PDF, the PDF/A options are designed for this. Additionally, the PDF/X options are useful if you’re submitting advertisements to publications that require the PDF advertisements to adhere to the PDF/X standard.

				PDF conversion options from Microsoft Word and Excel

				Although Microsoft Word and Excel are widely used, they aren’t always the best choice for distributing documents. Formatting of Microsoft Word documents and Excel spreadsheets changes depending on the fonts available on users’ computer or even the printer with which they print. PDF files, on the other hand, are able to maintain a consistent appearance on various computer types, regardless of fonts installed or printers being used. Microsoft Word and Excel files can be easily edited, and users can also copy and extract information from these files with few limitations. This differs from PDF files that are more difficult to copy from, and offer robust security options.

				Converting a Word or Excel file to a PDF file lets you distribute the file to a wide audience, even to people who don’t have Word or Excel, and you don’t need to worry about the document format or layout changing. There are two methods for converting Word or Excel documents to PDF, and the method you use depends on which version of Microsoft Office you’re using:

				[image: check.png] With Office 2010, convert your document from inside Microsoft Word or Excel — make sure that the document you want to convert to a PDF file is open and then click the Create PDF button in the Acrobat portion of the main toolbar.

				[image: check.png] With Office 2003 or earlier, choose Adobe PDF⇒Convert to Adobe PDF.

				After you choose to create a PDF file from your Microsoft Office document, you must specify the location of the PDF file that’s created and name the file.

				[image: tip.eps]	In Office 2010, click the Preferences button on the Acrobat tab, or with earlier versions of Office, choose Acrobat⇒Change Conversion Settings. In the Adobe PDF Maker dialog box, deselect the Prompt for PDF Filename option so that PDF files are generated in one step, without inputting the PDF filename. This saves you the step of naming the PDF file each time you create a PDF document.

				You can also add more functionality into the PDF documents you create. Click the Preference tab if you’re working in Office 2010 or choose Acrobat⇒Change Conversion Settings in earlier versions of Office. In the dialog box that appears, review the following settings:

				[image: check.png] Attach Source File: Causes the original Office document to become embedded within the PDF file as an attachment. When the PDF file is distributed, the original source file is included within the PDF file.

				[image: check.png] Create Bookmarks: Adds interactive bookmarks that make navigating the PDF file easy. Bookmarks are added based on Microsoft Word styles, such as text that’s styled as Heading 1. The bookmarks appear in the Bookmarks panel when viewing the PDF.

				[image: check.png] Add Links: Automatically converts Word links, such as web addresses, into PDF links that you can use when viewing the file in Acrobat or Adobe Reader. Within the PDF Maker preferences dialog box, click the Word tab to access additional link options that can be built into PDF files created from Word.

				Converting PowerPoint files to PDF

				You can convert your PowerPoint presentations to Adobe PDF documents with the PDF Maker add-in that installs with Adobe Acrobat. You can then distribute PDF versions of your PowerPoint presentations, avoiding concerns about your presentation file being edited or concerns that the recipient may not have the same fonts that you used. Distributing the presentation as a PDF ensures the document will look consistent on all computers.

				From PowerPoint, click the Acrobat tab on the Ribbon and then click the Create PDF button to save the file as a PDF file. In older versions of Office, you can also choose Acrobat⇒Convert to Adobe PDF from PowerPoint’s main menu. If you’re working with a new PowerPoint file or one that you’ve edited, you must save it before PDF Maker will convert the file.

				As with Word and Excel, you can select options relating to the conversion of your PowerPoint documents to PDF. To access the preferences, click the Preference button in the Acrobat tab, or if you’re using an older version of Office, choose Adobe PDF⇒Change Conversion Settings. Along with the conversion settings that impact the quality of the resulting PDF file, two additional options can enhance your presentation as a PDF:

				[image: check.png] Preserve Slide Transitions: With this option, you can convert the slide transitions created in PowerPoint into PDF transitions that will be used when the presentation is delivered using the Adobe Acrobat Full Screen mode option.

				[image: check.png] Convert Multimedia: Because Adobe PDF files can contain integrated sound and movie files, you can choose this option to have sounds and movies used in a PowerPoint file converted into the PDF document.

				[image: tip.eps]	After you create the PDF, you can use Acrobat as the tool for delivering your presentations that have been created using PowerPoint. After you convert the file to PDF, open it in Acrobat and choose View⇒Full Screen Mode. Press Esc to stop viewing a document in the Full Screen mode. You can even distribute the document to users with the free Adobe Reader, and they can use the free Adobe Reader software to view and display the PowerPoint presentation file. To distribute a document so that it always opens in Full Screen mode, open the document, choose File⇒ Properties, and select the Open in Full Screen Mode check box under the Initial View tab.

				Creating PDF Files from Adobe  Creative Suite Applications

				You can also convert Photoshop files, Illustrator files, or InDesign documents to the PDF format. In the following sections, we show you how.

				Converting Photoshop and Illustrator files to PDF

				Both Adobe Photoshop CS6 and Adobe Illustrator CS6 can save documents directly in the Adobe PDF file format. To do so, simply choose File⇒Save or File⇒Save As. Then, from the File Type drop-down list, choose Adobe PDF (Illustrator) or Photoshop PDF (Photoshop). In these programs, you can create PDF files without Adobe Acrobat or Acrobat Distiller because they’ve integrated PDF creation capabilities right into them.

				You can use Adobe Reader or Acrobat to view PDF files created from Photoshop or Illustrator. You can also open and edit PDF files using the same program in which they were created — so Photoshop PDF files can be reopened and edited using Photoshop, and the same is true for Illustrator PDF files.

				Converting InDesign documents to PDF

				Like Photoshop and Illustrator, the ability to convert InDesign documents to PDF is integrated into the application. With Adobe InDesign, you can choose File⇒Export and select either Adobe PDF (Interactive) or Adobe PDF (Print) from the File Type drop-down list. Interactive PDF documents are suitable for sharing on-line, such as by posting the file to a website, and are designed primarily to incorporate interactive PDF features such as buttons, page transitions, and multimedia elements. If you’re creating a PDF document that will be printed, your best option is to select Adobe PDF (Print), even if it will be posted to a website.

				If you choose Adobe PDF (Print) when exporting from InDesign, you will find many options for controlling the size and quality of the resulting PDF file. Many of these options are similar to those available for PDF Maker for Microsoft Office.

				In the Export PDF dialog box from Adobe InDesign, you can choose from the Preset drop-down list at the top of the dialog box. The choices are many, but we list and describe here the most commonly used settings:

				[image: check.png] Smallest File Size: Creates compact Adobe PDF files that are intended for display on the Internet or to be distributed via e-mail. Use this setting to create PDF files that will be viewed primarily onscreen.

				[image: check.png] High Quality Print: Creates Adobe PDF files that are intended for desktop printers and digital copiers.

				[image: check.png] Press Quality: Use this setting to create PDF files that will be delivered to a commercial printer for high-quality, offset print reproduction.

				[image: tip.eps]	When creating PDF files to be used for high-resolution printing, here are some settings you should use. Select Marks and Bleeds in the list on the left of the Export PDF dialog box, as shown in Figure 2-1, and specify the amount of space items need to extend off the page, referred to as bleed. If you’re delivering the file to a printing firm, they can provide you with guidance as to the required value. A good rule to follow is to use at least 0.125 inches if you have any items in your layout that extend to the edge of your document pages and beyond. Specify the value you want by entering the number in the Bleed and Slug section of the Marks and Bleeds tab. If the amount of bleed needs to be the same on all four sides, type the value in the Top text box and then click the link icon to the right of the Top and Bottom Bleed text boxes.

					

				
					Figure 2-1: Setting the bleed values in the Export Adobe PDF dialog box.

				

					[image: 9781118168608-fg050201.eps]

				Converting Other Electronic Documents to PDF

				As described earlier in this chapter, creating PDF files from Creative Suite applications and Microsoft Office programs is simple. But you aren’t limited to creating PDF files from these programs. This section explains how you can create PDF files from many other programs. When you installed the Adobe Creative Suite on your computer, you also installed a new printer — the Adobe PDF printer — which is used to convert electronic documents to PDF files. The Adobe PDF printer captures all the same information that’s normally sent to your printer, and, instead of printing on paper, the information is converted into an Adobe PDF file.

				To create a PDF file from any program, choose File⇒Print. In the Print dialog box, select Adobe PDF as the printer and click OK (Windows) or Print (Mac).

				To change the type of PDF file that’s created, such as a smaller file for web posting or a higher-quality file for delivery to a commercial printer, do this:

				[image: check.png] Windows: Click the Printer Properties button in the Print dialog box to open the Adobe PDF Document Properties dialog box, as shown in Figure 2-2. Here, you can choose the settings you want to use to control the quality and size of the resulting PDF file.

				[image: check.png] Mac: Select PDF Options from the Copies and Pages drop-down list in the Print dialog box and then select the PDF settings you want to use.

					

				
					Figure 2-2: You can change conversion settings when printing to the Adobe PDF printer.

				

					[image: 9781118168608-fg050202.eps]

				We discuss the PDF conversion settings earlier in this chapter, in the “PDF conversion options” section.

				Using the Print menu to control the quality of PDF files created from non-Adobe programs may appear strange, but it’s the easiest way for Adobe to capture all the same information that you’d expect to see when you print your files. This is an easy and standard method for generating PDF files from any program. It’s useful to have this method available as an option, and you can use it even if you’re having difficulty with the Export command from an Adobe Creative Suite application. Because the Print and Export commands use different processes for creating PDF files, you can use one option if you have difficulty with the other when creating PDF files from Creative Suite programs.

				[image: technicalstuff.eps]	Bookmarks, links, page transitions, and multimedia aren’t included if a PDF is generated with the Print menu option. You must use the Export or Save As option to have these items included in PDF files.

				Creating PDF Files from Paper Documents and the Web

				Adobe Acrobat provides options for converting paper documents and even web pages into PDF format. PDF can be a great way to share documents that you’ve scanned into your computer, or web pages that may change or that you want to review when you aren’t connected to the Internet.

				Converting paper documents to PDF

				To convert paper documents into PDF, you need a scanner to digitize the information. If you expect to scan a large number of pages into PDF, consider purchasing a scanner with an automatic document feeder. Some scanners can scan both the front and backside of a document at the same time. Some scanners now fit easily on your desktop and let you convert a large number of paper documents to PDF in a short period of time, and many printers now include scanners. If a scanner is already hooked to the computer on which you use Acrobat, follow these steps to scan in a paper document and then convert it to PDF format:

					1.	From the Acrobat main menu, choose File⇒Create⇒PDF From Scanner.

						Then choose the type of PDF document you want to create. For pages with text, choose one of the Document options: Black and White for line art or text that contains no shades of gray; Grayscale for documents that contain varying shades of gray; or Color for documents that contain color. For photographs, choose the Color Image option.

					2.	Make sure that your scanner is turned on, put the document to be scanned into the scanner, and then click the Scan button.

						If necessary, continue to scan multiple pages into a single document. When you’re done scanning, the scanned page appears in Acrobat.

						If you have a PDF open and choose Create PDF from Scanner, a window appears, giving you the opportunity to append the file (add to the existing file) or create a new PDF file.

						The scanned document opens in Acrobat.

				[image: tip.eps]		If the pages need to be rotated, choose View⇒Rotate View and select the option to rotate the view either clockwise or counterclockwise.

					3.	Choose File⇒Save to save the finished document as a PDF.

				[image: tip.eps]	If the document you scanned contains text, the text will be fully searchable if you use one of the Document preset choices because Acrobat uses Optical Character Recognition (OCR) to convert the image to text. However, if you use one of the Image preset choices, you must manually tell Acrobat to detect the text before it will be searchable. To do this, open a previously scanned file and use the Tools button to access the commands. Choose Tools⇒Content⇒Recognize Text⇒In This File. This command makes previously scanned text searchable.

				Converting web pages to PDFs

				By converting online content to Adobe PDF, you can capture content from a website. Because web content can change rapidly, you can capture something that may not remain online for a long period of time. You can convert things, such as news stories or business information, from a website into PDF. Because PDF files can easily be combined together, you can merge a PDF from a website with other PDF files, such as spreadsheets, word- processing documents, and brochures.

				If you want to convert only a single page and are using Internet Explorer, click the Convert Web Page to PDF button. This step converts the current web page to a PDF. At the time of writing, Convert Web Page to PDF was not compatible with the current version of other major web browsers other than Internet Explorer.

				If you want to convert more than a single web page to a PDF, follow these steps from within Acrobat (not your web browser):

					1.	From the Acrobat main menu, choose File⇒Create⇒PDF From Web Page.

						The Create PDF from Web Page dialog box opens.

					2.	In the URL text box, enter the URL for the website you’re converting to PDF.

					3.	To capture additional pages that are linked from the main page you’re capturing, click the Capture Multiple Levels button and then select one of the following:

					•	Select the Stay On Same Path check box if you want only pages from the entered URL converted to PDF.

					•	Select the Stay On Same Server check box to download only pages that are on the same server as the entered URL.

				[image: warning_bomb.eps]		Be cautious about selecting the Get Entire Site radio button instead of the Get Only radio button. The Get Entire Site option may take an enormous amount of time and not have any relevance to what you need.

					4.	Click the Settings button to open the Web Page Conversion Settings dialog box and see accepted file types and change PDF settings (on the General tab).

					5.	On the Page Layout tab of the Web Page Conversion Settings dialog box, make changes to page size, orientation, and margins if the web page requires a wider or longer layout. See Figure 2-3.

					

				
					Figure 2-3: Changing the layout of web pages converted to PDF.

				

					[image: 9781118168608-fg050203.eps]

					6.	When you’re done making changes in the Web Page Conversion Settings dialog box, click OK.

					7.	In the Create PDF from Web Page dialog box, click the Create button to generate a PDF.

						The Downloading Status window opens, showing the rate of download.

				When the download is complete, the web page (for the entered URL) selected appears as a PDF document, with hyperlinks (links to other pages within the site) intact. When you select links on the converted web page, you can open the linked page either in Acrobat or the web browser by making your choice after clicking on a link.

				

			

			
		

	
		
			
				Chapter 3: Adding Interactivity to PDF Files

				In This Chapter

				[image: check.png] Adding interactive bookmarks

				[image: check.png] Creating and editing links

				[image: check.png] Using buttons for easy navigation

				Because many PDF documents are viewed online, you should make them easy for readers to navigate. With Acrobat, you can design documents that are easier to navigate than their printed counterparts and that include rich interactive features that simply aren’t available with paper documents.

				Rather than making readers scroll through a document to find what they want, you can add links within an index or a table of contents, or you can add links to websites and e-mail addresses. Acrobat also includes bookmarks, which are an interactive table of contents. You can even add buttons that link to specific pages within a PDF document or that cause an action to occur when clicked, such as printing the document. We discuss all these features in this chapter.

				Adding Bookmarks to Create Easy PDF Navigation

				Users have come to expect documents that involve easy-to-use navigation and ways to quickly find what they need. You can make your PDF documents more user-friendly by adding bookmarks, which are the equivalent of a table of contents that’s always available, no matter what page the user is viewing in the Document window.

				Bookmarks provide a listing of contents within a PDF file or links to relevant external content. Bookmarks sit within a panel, and when you click one, you’re taken to a specific destination in the PDF document (or possibly to an external file), much like a hyperlink. You can create bookmarks from existing text, or you can use your own text to describe the content, which is useful if the destination of the bookmark is a figure, chart, or graphic.

				By default, the Bookmarks icon resides along the left side of the Acrobat Document window in the navigation panel. Click the Bookmarks icon to make the panel appear; click the Bookmarks icon a second time to hide it. If the icon isn’t visible, choose View⇒Show/Hide⇒Navigation Panes⇒Bookmarks to make it appear.

				Creating bookmarks that link to a page

				By navigating to a page, and to a specific view on a page, you can establish the destination of a bookmark link. With a PDF document open, follow these steps:

					1.	If the Bookmark icon isn’t visible choose View⇒Show/Hide⇒Navigation Panes⇒Bookmarks.

						The Bookmarks panel appears on the left of the Document window.

					2.	In the Document window, navigate to the page that you want as the bookmark’s destination.

					3.	Set the magnification of the view that you want viewers to see when they click the bookmark by using the Marquee Zoom tool to either zoom in or zoom out.

						The zoom level that you’re at when you create the bookmark is the view that viewers see when they click the bookmark.

						4.	[image: 9781118168608-ma142.tif] In the Bookmarks panel, click the New Bookmark icon. (It shows a ribbon with a starburst.)

						The new bookmark appears in the Bookmarks panel as Untitled.

					5.	Change the name by typing something more descriptive.

				[image: tip.eps]		If you leave the bookmark as Untitled but want to rename it later, you must right-click the bookmark and then choose Rename, or you can click the Bookmark panel menu in the upper-left corner of the panel and choose Rename Bookmark.

					6.	Test your bookmark by scrolling to another page and viewing it in the Document window; then click your saved bookmark in the Bookmark panel.

						The Document window shows the exact location and zoom that you selected when you created the bookmark.

					[image: 9781118168608-ma006.tif]	Use the Selection tool to highlight text, such as a headline or a caption, that’s part of the bookmark destination. Then choose New Bookmark, and the selected text becomes the title of the new bookmark. You can use this shortcut to avoid entering a new name for new bookmark titles. You can also press Ctrl+B (Windows) or [image: maccmd]+B (Mac) to quickly create a bookmark, and any selected text becomes the bookmark title.

				Creating bookmarks that link to a website

				Although bookmarks are most commonly used to link to content within a PDF file, you can also use bookmarks to create links to other websites or even other documents. To create a link to an external website, follow these steps:

					1.	Choose Options⇒New Bookmark in the Bookmarks panel. 

						The Options menu looks like two circles on top of each other, found in the upper-left corner of the Bookmarks window.

					2.	Replace the Untitled bookmark entry that appears in the Bookmarks panel with an appropriate name for the bookmark.

					3.	Choose Options⇒Properties from the Bookmarks panel menu. 

						The Bookmark Properties dialog box appears. With this dialog box, you can change a bookmark so that it links to any web address or even another file. In this example, we use a web address, but the bookmark could be a link to another PDF file, a Photoshop file, or even a Microsoft Excel file. Just remember that this bookmark creates a relative link. The linked file must travel with the PDF document in order for the link to work.

					4.	In the Bookmark Properties dialog box, click the Actions tab, select Open a Web Link from the Select Action drop-down list, and then click the Add button.

						The Edit URL dialog box appears. 

					5.	Enter the web address to which the users should be taken when they click this bookmark. Then click OK.

						The bookmarked link is created.

				[image: remember.eps]	You can use bookmarks to choose different actions, such as opening another file or even playing a sound or movie.

				Using bookmarks

				Bookmarks are intuitive to use, which makes them an attractive option to add to PDF files. After you click a bookmark, the action associated with it is performed, which typically navigates you to a certain page within the PDF file.

				Unfortunately, the Bookmarks panel doesn’t open automatically with a document, even when bookmarks are present within a file. To display the Bookmarks panel when a file is opened, follow these steps:

					1.	Choose File⇒Properties.

					2.	In the Document Properties dialog box that opens, select the Initial View tab, as shown in Figure 3-1.

					

				
					Figure 3-1:  The Documents Properties dialog box in Adobe Acrobat.

				

					[image: 9781118168608-fg050301.eps]

					3.	From the Navigation drop-down list, select Bookmarks Panel and Page and then click OK.

						After you save and reopen the file, the Bookmarks panel displays whenever the document is opened.

				Editing bookmarks

				You can change the attributes of bookmarks so that they have a different color, a different text style, or a link to another location. Make these changes by selecting a bookmark and then choosing Options⇒Properties in the Bookmarks panel. (Remember the Options button appears in the upper-left corner of the panel, and it’s the icon with two circles.) In the Bookmark Properties dialog box that opens, choose the color and font style of the bookmark on the Appearance tab: To change the bookmark’s font style, select a style from the Style drop-down list; to change the bookmark’s color, click the Color box and choose a color from the Color Picker.

				On the Actions tab of the Bookmark Properties dialog box, you can delete existing actions (in the Actions section of the Actions tab) by clicking to select an action and then clicking the Delete button. Also, you can add actions by choosing another action from the Add Action section and then clicking the Add button. You can add more than one action to a bookmark.

				Adding Interactive Links

				When viewing a PDF file electronically, you can add links for e-mail addresses, web addresses, and references to other pages. Unlike bookmarks which are neatly organized in a panel, links are attached to a region of a page, which you identify with the Link tool.

				To add an interactive link to your PDF document, follow these steps:

					1.	Locate an area of a page where you want to add a link and then choose Tools⇒Content⇒Link.

						2.	[image: 9781118168608-ma144.tif] Using the Link tool, click and drag to select the region where the user will click to activate the link.

						The Create Link dialog box appears.

					3.	In the Link Action section of the Create Link dialog box, choose an action that the link will perform:

					•	Go to a Page View: This option is the default, where you can scroll to the page that is the destination of the link.

					•	Open a File: Alternatively, you can choose to link to another file; click the Browse button to locate the file.

					•	Open a Web Page: If you choose this option, you’re choosing to link to a web address. In the Address text box, enter the complete address of the website to which the link should direct viewers. To create a link to an e-mail address, type mailto: followed by an e-mail address. (Note that mailto: is all one word.)

					•	Custom Link: Use this option to choose from other types of links in the Link Properties dialog box.

					4.	Set the appearance of the link, such as visible or invisible.

					5.	Click Next and follow the instructions in the next dialog box before clicking OK. 

						The instructions have you navigate to the intended destination of the link, which you should do before clicking OK.

				[image: tip.eps]	Although the Link tool is relatively simple to use, you may prefer to create links from text using the Selection tool. To do so, click and drag to select the text that will become a link, then right-click (Windows) or Ctrl-click (Mac), and choose Create Link from the contextual menu that appears.

				[image: remember.eps]	You can also have links transferred automatically from your original Microsoft Office documents when using PDF Maker, or from Adobe InDesign if you use the hyperlinks panel within InDesign to create the links.

				You can edit links by choosing the Link tool and double-clicking the existing link to open the Link Properties dialog box. While editing a link, you can change how it’s presented in the Appearance tab. Make a link invisible or add a border to the link, such as a blue border that commonly is used to define hyperlinks. On the Actions tab of the Link Properties dialog box, you can add, edit, or delete actions, just as you can with bookmarks (see the preceding section).

				Adding Buttons to Simplify Your PDF Files

				Along with links and bookmarks, buttons provide another way to make your files more useful when they’re viewed online. You can create interactive buttons entirely within Acrobat — designing their appearance and adding text to them. Or you can import buttons created in other Adobe Creative Suite applications, such as Photoshop and Illustrator, and add actions to them within Acrobat. For example, within Acrobat, a button that advances the viewer to the next page in a document will be a simple button with text. However, if you want an arrow icon, you can create it in Photoshop or Illustrator and import the button icon into your PDF page using Acrobat.

				[image: remember.eps]	You can also create interactive buttons for a PDF document by using InDesign. Buttons created using InDesign carry through to a PDF when you export an interactive PDF document.

					[image: 9781118168608-ma143.tif]	You can add buttons directly within Acrobat by using the Button tool.

				To add a button to your PDF document, follow these steps:

					1.	Choose Tools⇒Content⇒Add or Edit Interactive Object⇒Button.

						The cursor changes to a cross hair, which you can then use to draw the location of the button on your PDF document.

					2.	Click and drag to specify the location where you want the button to appear in the document.

					3.	Type in an appropriate name for your button in the Field Name dialog box that appears.

					4.	Click the All Properties button to see the Button Properties  dialog box.

					5.	In the General tab, you can enter a name for the button in the Name text box and provide a tooltip in the ToolTip text box. You can also specify whether the button is visible only onscreen or when printing under the Common Properties section.

						A tooltip is the text that appears whenever the mouse cursor is positioned over the button.

					6.	In the Appearance tab, establish how your button will look by setting the following options:

					•	Border Color/Fill Color: Click the square to the right of the appropriate attribute in the Borders and Colors section of the Appearance tab and then choose a color from the Color Picker.

					•	Line Thickness and Style: These options don’t appear unless you change the border color from None (red diagonal line) to another selection.

					•	Font Size/Font: Change the size and font of the button text by making a selection from the Font Size and the Font drop-down lists.

					•	Text Color: Change the color of the text by clicking the color square and choosing a color from the Color Picker.

					7.	In the Options tab, make these selections:

					•	Layout: Use the Layout drop-down list to specify whether you want to use a label (text that you enter in Acrobat that appears on the face of the button) or whether you want an icon (an imported button graphic that you may have designed in Photoshop or Illustrator).

					•	Behavior: Select Push from the Behavior drop-down list to create different appearances for a button so that it changes based upon whether the mouse cursor is positioned over the button. The button appearance can also change when clicked.

					•	State: To specify the different appearances (see Behavior, discussed in the preceding paragraph), click the State on the left side of the Options tab and then choose the Label or Icon status for each state.

					•	Label: If you choose to use a label, enter the text for it in the Label text field.

					•	Icon: If you choose to use an icon, specify the location of the graphic file by clicking the Choose Icon button. You can create button icons in either Photoshop or Illustrator and save them in the PDF format for importing as a button icon.

					8.	In the Actions tab, select an action from the Select Action drop-down list and then click the Add button.

						Actions are applied to buttons similar to the way in which they’re applied to links and bookmarks:

					•	To specify when the action occurs, click the Select Trigger drop-down list and choose whether the mouse clicking, being released, or being moved over an area causes the action to occur. The default trigger is Mouse Up, which causes the action to occur when the mouse button is depressed and then released. You can choose other actions, such as the mouse cursor merely rolling over the button without the need to click it.

					•	To choose actions that are a part of the menu commands, such as printing a document, closing a file, or navigating to the next or preceding page, click the Select Action drop-down list and then specify the command to be accessed.

					9.	After you make all your changes in the Button Properties dialog box, click Close.

				

			

		

	
		
			
				Chapter 4: Editing and Extracting Text and Graphics

				In This Chapter

				[image: check.png] Manipulating text with the Edit Document Text tool

				[image: check.png] Modifying graphics and page objects with the Edit Object tools

				[image: check.png] Pulling text and graphics out of PDFs for use in other documents

				You may assume that PDF files are mere pictures of your documents and can’t be edited, but nothing is further from the truth. Adobe Acrobat includes a variety of tools for editing both text and graphics. You can use these tools as long as the file hasn’t been secured to prohibit editing. We introduce you to the tools for modifying PDF documents in this chapter. We discuss security, which allows you to limit access to these tools, in Chapter 6 of this minibook.

				Editing Text

				You can access the tools for editing text and graphics by clicking Tools⇒Content, and then you can find them in the Edit Text & Object section. (See Figure 4-1.)

					

				
					Figure 4-1:  The Edit Text & Objects tools

					
				

					[image: 9781118168608-fg050401.tif]

				[image: tip.eps]	For editing objects, you have three choices:

				[image: check.png] Edit Document Text tool: Used to manipulate text.

				[image: check.png] Edit Object tool: Used to manipulate objects and graphics.

				[image: check.png] Add or Edit Text Box tool: Used to add new text onto a document or to manipulate text previously applied using this same tool.

				Using the Edit Document Text tool to manipulate text

				The Edit Document Text tool is used for manipulating text. This can include changing actual text characters or the appearance of text. You can change cat to read dog, or you can change black text to blue, or you can even change the Helvetica font to the Times font. 

				[image: remember.eps]	When you change a PDF file, the original source document isn’t modified.

				You have a few ways to accomplish text edits:

				[image: check.png] Choose the Edit Document Text tool, click within the text that you want to change to obtain an insertion point, and then start typing the new text.

				[image: check.png] Click with the Edit Document tool in your text and press the Backspace or Delete key to delete text.

				[image: check.png] With the Edit Document tool, drag to highlight text and enter new text to replace the highlighted text.

				When changing text — whether you’re adding or deleting — Acrobat tries to use the font that was specified in the original document. Sometimes, this font is built into the PDF file, which means that it’s embedded in the file. Other times, the font may not be available either because it hasn’t been embedded or it’s been embedded as a subset where only some of the characters from the font are included in the PDF file. In these cases, Acrobat may provide the following warning message:

				Warning! Since the original font is not available, a substituted font for editing is used. Any changes to the text of the original font will place a new font dependency upon the document.

				Fortunately, you can change the font if you need to edit the text. However, when you change the font, the text may not retain the same appearance as the original document. In some instances, you may not have the exact same font on your computer as the font used in the PDF document, but you may have a similar font you can use without causing a noticeable change — most people won’t notice the difference between Helvetica and Arial or between Times and Times New Roman. Fonts with the same name but from different font designers often look very similar. For example, Adobe Garamond looks similar to ITC Garamond, even though they’re two different fonts.

				To change the font that’s used for a word or a range of words, follow these steps:

					1.	With the Edit Document Text tool, drag over the text you want to select.

						You may see a Loading System Fonts message followed by another Loading Document Fonts message. Depending on the number of fonts installed on your system, it may take a while for this message to disappear.

					2.	Right-click (Windows) or Control-click (Mac) the highlighted text and choose Properties from the contextual menu. The Edit Document Properties dialog box appears, as shown in Figure 4-2.

					

				
					Figure 4-2: The Edit Document Properties dialog box.

				

					[image: 9781118168608-fg050402.eps]

					3.	In the Text tab, choose the typeface you want to use from the Font drop-down list and make any other changes you want.

						In this dialog box, you can also change the size by selecting or typing a number into the Font Size drop-down list. In addition, you can modify the color by clicking the Fill color swatch.

					4.	When you’re satisfied with your changes, click the Close button to apply your changes to the selected text.

				Add or Edit Text Box: The Typewriter tool

				You can use the Typewriter tool to type anywhere on the document. Access the Typewriter tool by choosing Tools⇒Content⇒Add or Edit Text Box. Then position your cursor where you want to begin typing, click, and start to type, pressing the Enter or Return key whenever you want to add a line. The Typewriter toolbar appears after you click on a page. Use the toolbar to change the font or size of the text you’re adding to the page by clicking the increase or decrease type size buttons or by selecting a specific size from the drop-down list.

				Likewise, to change the space between the lines, click the Increase or Decrease Line Spacing buttons. You can move or resize the Typewriter block by selecting it with the Select tool and either moving or resizing the text box. Your text remains editable. So, if you’ve made a mistake and want to correct it, or want to add or delete text, you select the Typewriter tool again and double-click in the type box.



				Using the Edit Object tool to edit graphics

				You can use the Edit Object tool to access editing software for modifying graphics. For example, you can use the Edit Object tool to select a graphic, bring the graphic into Photoshop, and then save the modified version back into the PDF file. In other words, you can edit the graphics used in PDF documents, even if you don’t have access to the original graphic files.

				To edit a photographic file from Acrobat in Photoshop, follow these steps:

					1.	Select the image with the Edit Object tool, right-click (Windows) or Control-click (Mac) on a photographic image with the Edit Object tool, and then choose Edit Image from the contextual menu.

						The image file opens in Adobe Photoshop.

					2.	With the many tools of Photoshop, make the necessary changes to the graphic and then choose File⇒Save.

						When you return to the PDF file in Acrobat, the graphic is updated automatically in the PDF document.

				[image: remember.eps]	If you have the original graphic file, it remains untouched — only the version used within the PDF file is modified. It isn’t necessary to have the original graphic file to perform these steps.

				You can also use Acrobat to edit vector objects from within PDF files, such as those created with Adobe Illustrator. Just follow these steps:

					1.	Select a piece of vector artwork with the Edit Object tool, right-click (Windows) or Control-click (Mac) the vector artwork, and then choose Edit Object from the contextual menu.

						Note: Acrobat displays Edit Object in the contextual menu if it detects a vector object, and it displays Edit Image if it detects a bitmap image. Acrobat also displays Edit Objects (note the plural) if you have more than one object selected.

				[image: tip.eps]		If you’re editing a complex illustration, be sure to select all its components by holding down the Ctrl (Windows) or [image: maccmd] (Mac) key while clicking them with the Edit Object tool.

						After choosing Edit Object, the object opens for editing in Adobe Illustrator.

					2.	After you make the necessary changes in Illustrator, choose File⇒Save.

						The graphic is updated in the PDF document.

				[image: tip.eps]	If Acrobat doesn’t start Photoshop or Illustrator after choosing the Edit Image or Edit Object command, you may need to access preferences by choosing Edit⇒Preferences⇒Touch Up (Windows) or Acrobat⇒Preferences⇒Touch Up (Mac OS) and then specifying which programs should be used for editing images or objects.

				[image: tip.eps]	You can also use the Edit Object tool to edit the position of text or graphic objects on a page, which includes the ability to relocate individual lines of text or to change the position of a graphic on a page. After you select an object with the Edit Object tool, you can simply drag it to a new location on the page. Similarly, you can delete objects from a PDF document by selecting them and then pressing the Delete key.

				Exporting Text and Graphics

				Although editing text and graphics is helpful, you may need to take text or images from a PDF document and use them in another file. Fortunately, Acrobat also includes tools to make this a breeze. Of course, you should always make certain that you have the permission of the owner of a document before reusing content that isn’t your original work.

				You can export text, images, or charts from Acrobat by copying and pasting, or by saving as a specific file type. These methods are discussed in detail in the following sections.

				Exporting text with Select, Copy, and Paste

				Follow these steps to select, copy, and paste text from a PDF file:

					1.	With the Select tool, highlight the text you want to export.

						The Select tool is the I-bar/black arrow in the toolbar. When you hold the arrow over a section of your document, it turns into an I-bar cursor, which you can drag to select the text you want to copy.

				[image: tip.eps]		If the Cut, Copy, and Paste commands are unavailable after you’ve selected some text, the author of the document may have set the security settings to disallow copying. If you can’t select the text, you may be trying to copy text that’s part of an image. If you’re trying to select text that’s in a single column, a sidebar, or table, press and hold the Ctrl key (Windows) or Command key (Mac) and then click and drag over the area with text to be selected.

					2.	Right-click (Windows) or Control-click (Mac) the selected text. Then, from the contextual menu, either choose Copy to copy only the text  or choose Copy with Formatting to retain the font, size, and color characteristics.

						Being able to extract the text out of a PDF document by selecting and copying it is useful if you don’t have access to the original source document, but you need to use the text from a PDF file in another document.

					3.	Open another text-editing program, such as Adobe InDesign or Microsoft Word.

						You can paste the copied text into a new document or a preexisting file.

					4.	Insert your cursor in the document at the appropriate spot and choose Edit⇒Paste.

						The text is pasted into the document, ready for you to use.

				Exporting text with Save As

				Use the File⇒Save As⇒Microsoft Word or File⇒Save As⇒Spreadsheet commands to export all the text in your PDF file. After choosing the location where you want the file saved, click Save to save the Microsoft word or Spreadsheet file. 

				You can also choose File⇒Save As⇒More Options to save the document with no formatting as a plain text document. The More Options choice includes several other formats you can use for exporting your PDF documents:

				[image: check.png] Encapsulated PostScript and PostScript: These formats are generally used by commercial printers or IT professionals who need PostScript output.

				[image: check.png] Various Adobe PDF option formats, such as PDF/E for engineering or PDF/A for archiving: These formats are used to switch to a specific subset of the PDF file format used for a particular industry or line of work.

				[image: check.png] HTML and XML: These are used to attempt to convert the PDF to another file format that can be used for viewing on the web without a PDF plug-in. PDF files do not always convert well to HTML, so be sure to test this option if you want to use it for any important documents.

				[image: check.png] Graphics: To save your PDF document as an image, use the File⇒Save As⇒Image command and choose from any of the various graphics formats, including JPEG, JPEG2000, PNG, and TIFF. If you choose one of these options, your text will no longer be editable because all of the PDF pages will be converted to images, with each page in the PDF becoming a  separate image file.

				[image: remember.eps]	Text that’s copied from a PDF file is no longer linked to the original document. Edits made to the extracted text aren’t reflected within the PDF file, and it’s extremely difficult to have the extracted text reinserted into the PDF document, as the Add or Edit Text Box tool and Typewriter tool are rather limited in their ability to add any significant amount of text onto a page. Think of the extraction process as a one-way trip for the text, which can be extracted but not reinserted.

				You can also export portions of text and tables so you can edit them later using a spreadsheet program, such as Microsoft Excel, or a word processing program such as Microsoft Word. Just follow these steps:

					1.	Click the Select tool and click and drag to select the text in the table.

						Depending upon how the table was created, you may also be able to position your cursor just outside the edge of the table and then draw a box around a table. Remember you can Ctrl-click (Windows) or Command-click (Mac) and then drag around a table to select it.

						A border appears around the selected table.

					2.	Right-click (Windows) or Control-click (Mac) and choose Export Selection As from the contextual menu.

						Alternatively, you can save the table directly to a file or copy to the Clipboard to be pasted later: If Acrobat has trouble identifying the text in the table, it may be saved as an image file, which is not editable text.

					•	Choose Export Selection As from the contextual menu to save the text directly to a file.

					•	To copy the table to the Clipboard so that you can paste it into other documents, choose Copy with Formatting from the contextual menu.

						After opening Excel or whatever spreadsheet program you have installed on your computer, you can paste the table into the spreadsheet.

						And that’s it. You can now use that table in another program.

				Extracting graphics

				You can also extract graphics from PDF files, but extracting graphics is very different from editing them. We discuss editing graphics and vector objects earlier in this chapter. When editing graphics, you open the original graphic file at its highest possible quality. Extracting graphics is different because they’re removed at the quality of the screen display resolution, which may be of much lower quality than the original, embedded graphics.

				With the Select tool, right-click (Windows) or Control-click (Mac) an image, or drag with the Select tool to select a part of the image. Then you can either drag and drop the selection into an open document or choose Copy Image from the contextual menu. The image is now available to be pasted into other applications. Your other option is to choose Save Image As from the contextual menu and then save the selected area as a BMP graphics file.



				

			

			
		

	
		
			
				Chapter 5: Using Commenting and Annotation Tools

				In This Chapter

				[image: check.png] Adding comments and annotations to PDF files

				[image: check.png] Working with comments

				One of the fantastic features of Acrobat is the capability to mark up PDF documents with virtual sticky notes, mark up text to indicate changes as well as add annotations and drawing comments to a PDF file. The Acrobat commenting tools don’t change the original file, and you can remove the comments at any time, which means you can disable comments for printing or viewing at any time. In this chapter, we describe these capabilities and show you how to put them to work for you.

				Creating Comments with the  Comment & Markup Toolbar

				You can easily add annotations to PDF files, including stamps, text highlights, callouts, and electronic sticky notes by using the Comment panel, which you can access by clicking the Comment option on the Tasks toolbar. You can then choose to show the Annotation, Drawing Markups, and Review tools.

				The Comment & Markup toolbar, as shown in Figure 5-1, provides several tools for adding comments to PDF documents. It also includes a comment list to help manage and review comments. We discuss these tools in the following sections.

				The Add Sticky Note tool

				Use the Add Sticky Note tool to add electronic sticky notes to your files. Just click the location where you want the note to appear within a PDF document, and an icon, representing the note, appears, along with a window where you can enter text. After entering text in the sticky note, close the window so that the document isn’t hidden beneath it.

					

				
					Figure 5-1: The Acrobat Commenting tools.

				

					[image: 9781118168608-fg050501.eps]

				You can change the icon and color used to represent the note by right-clicking (Windows) or Control-clicking (Mac) the note and choosing Properties from the contextual menu. In the Properties dialog box that appears, make the changes to the note icon or color and then click OK to have the changes apply to the note.

				The Text Edit tools

				The Text Edit tools are five separate text commenting tools. Use these tools to indicate that selected text should be replaced or to highlight or underline selected text, calling attention to it in the PDF file. You can also add a note to selected text, or indicate that text should be inserted at a specific location, and mark text for deletion.

				To use Text Edit tools, follow these steps:

					1.	Choose the text edits tool you want to use from the Annotations section of the Comment panel.

					2.	Click and drag the selected tool over the text you want to change, comment on, or highlight.

						Your selected text edits are displayed on the PDF file.

				[image: tip.eps]	If you’ve selected the Insert Text tool, click where you want to insert the type. Then, after Acrobat creates an insertion point, start to type the new text to add a comment showing the text you want added to the document.

				The Stamp tool

				You can use stamps to identify documents or to highlight a certain part of a document. Common stamps include Confidential, Draft, Sign Here, and Approved.

				The stamps are grouped into sections, and you can access them from the Annotations section of the Comment panel. Some stamps automatically add your default username along with the date and time you applied them to the document; these stamps are available under the Dynamic category in the Stamps menu. The more traditional business stamps, such as Confidential, appear under the Standard Business category. You can access each of the categories by clicking the arrow to the right of the Stamp tool in the Comment & Markup toolbar, as shown in Figure 5-2.

				To apply a stamp to your document, follow these steps:

					1.	Select the Stamp tool by selecting Comment⇒Annotations then clicking the Stamp tool.

					2.	Click the arrow to the right of the Stamp tool and from the menu, choose either the Dynamic or Standard Business stamp.

						The first time you use the stamps, you may be asked to input your information so Acrobat can include your identity as the user applying the stamps. If you click the Don’t Show Again option when asked to enter your identity, you won’t need to do this again.

					3.	Click within your document at the location where you want the stamp to appear.

					

				
					Figure 5-2: Access the categories of stamps by clicking the Stamp tool in the Annotations panel.

				

					[image: 9781118168608-fg050502.tif]

				The Highlight Text tool

				The Highlight Text tool works similarly to the Text Edits tools. To highlight text, follow these steps:

					1.	Select the Highlight Text tool from the Comment & Markup toolbar.

					2.	Click and drag over the text that you want highlighted.

						The text is now highlighted.

				The Attach File tool

				With the Attach File tool, you can attach any existing file from your computer or computer network to a PDF document. For example, if you have an Excel spreadsheet that relates to the PDF document, and you want to allow users to work with the data, you could attach the Excel file to the PDF document.

				Follow these steps to attach a file to your PDF document:

					1.	Select the Attach File tool from the Comment⇒Annotations toolbar then place your cursor over the location in the document where you want the attachment icon to be visible.

						A pushpin icon appears.

					2.	Click where you want the attachment noted.

						The Add Attachment dialog box appears.

					3.	In the Add Attachment dialog box, browse to the file that you want to attach and click the Select button (Mac OS) or Open button (Windows).

						You can attach text, graphic, or sound files.

					4.	The File Attachment Properties window appears. 

					5.	In the File Attachment Properties window, select the icon you want to use to represent the file attachment. Then click OK.

						You can choose from a paperclip, graph, pushpin, or tag. Whatever icon you select appears on your document to denote that another file is attached. When you roll over the icon, a little annotation appears telling you the filename. 

				[image: tip.eps]		You can use the Record Audio tool to share a verbal comment by using the built-in microphone on your computer or laptop (if you have one) to record a message directly into the PDF. The sound is added as a comment. Follow the preceding Steps 1–5 for adding an attachment, except use the Record Audio tool located next to the Attach File tool.

				[image: remember.eps]	The file(s) that you attach with the Attach File and Record Audio tools becomes embedded within the PDF file, and the size of the file increases. When using attached files, they remain in their original file format, even if the attached file isn’t a PDF file. For example, you can attach an Excel spreadsheet to a PDF document, and the recipient will need to use Excel to view or edit the attachment. Attaching a file to a PDF document doesn’t convert the attachment to PDF.

				The Drawing Markup tools

				The Drawing Markups panel contains shape tools, line tools, pencil tools and other drawing tools. Use the drawing tools to add lines, ovals, rectangles, and other shapes to your PDF file to provide feedback and comments on a PDF document. These shapes can call attention to specific portions of a document and make it easy to provide visual feedback on PDF documents you are reviewing. The steps in this section show you how to work with some of the more useful Drawing Markup tools.

				To use the Cloud Shape tool, follow these steps:

					1.	Select the Cloud Shape tool from the Drawing Markups section of the Comment panel.

					2.	Click in your document to begin the shape.

					3.	Click again in another position to set the length of the first part of the cloud and then click again to begin shaping your cloud.

						Click as often as you like to create your shape.

					4.	When you’re finished with your shape, double-click to close the cloud shape, or click back at the starting point of the cloud.

				[image: tip.eps]		Use the Selection tool found in the Toolbar well to click the shape you created and drag the corner points to resize, if necessary. You can also use the Selection tool after creating a cloud shape to change the color and thickness of the line values. To make these changes, using the Selection tool, right-click (Windows) or Control-click (Mac) the shape and choose Properties from the contextual menu. In the Polygon Properties window that opens, make the desired changes to the appearance. For example, you can use the Style drop-down list in the Properties dialog box to change the appearance of a selected comment. Instead of the cloud edges, you can change them to dotted lines, dashed lines, and so on. When you’re finished changing the appearance, click OK.

				To use the rectangle- and oval-shaped Drawing Markup tools, follow these steps:

					1.	Select either the Rectangle or Oval Shape tool from the Drawing Markups toolbar.

					2.	Click and drag in your document to draw the shape.

					3.	While the drawing tool you chose is selected, click the shape you created and drag the corner points to resize, if necessary. 

						You can also use the Selection tool if you’re having difficulty adjusting the shape or size of a previously created shape.

					4.	After creating the shape, right-click (Windows) or Control-click (Mac) the shape and choose Properties from the contextual menu to change the color and thickness of the line values.

					5.	When you’re finished, click OK.

						As with the cloud polygon, you can also use the Style drop-down list in the Properties dialog box to change the appearance of the shape.

				The Add Text Box tool

				When creating notes that you want to prominently display on a document, you can use the Add Text Box tool to add text annotations directly onto a PDF document. Text added using the Add Text Box tool is clearly visible on the document without needing to open any dialog boxes or windows.

				Follow these steps to add a text box containing comments:

					1.	Select the Add Text Box tool from the Drawing Markups section of the Comment & Markup toolbar. Then click and drag on the PDF document in the location where you want to place the comment.

						A text field is placed directly on the document.

					2.	Add your text comment by typing directly into the text box.

					3.	To change the appearance of the text box, right-click (Windows) or Control-click (Mac) and choose Properties from the contextual menu to set the color of the text box that contains the note.

					4.	After making your choices to modify the appearance of the text box, click OK.

				[image: tip.eps]	You can select the text box and move it to another position using the Selection tool. You can resize the text itself using the Properties Bar, which you access by right-clicking (Windows) or Control-clicking (Mac) in a blank area on the toolbar, across the top of the Acrobat document window, and then selecting Properties Bar.

				The Add Text Callout tool

				The Add Text Callout tool creates a callout text box that points to a section of your document with an arrow. The callout text box is made up of three parts: the text box, the knee line, and the end point line. You can resize each part individually to customize the callout area of your document.

				To use the Callout tool, follow these steps:

					1.	Select the Add Text Callout tool from the Comment & Markup toolbar.

					2.	Click where you want the arrowhead point to be located.

					3.	Move the cursor to the location where you want the text box to be positioned and then click again. Begin typing your comment.

						As with the other Drawing Markup tools, you can use the Selection tool to relocate the text box or use the anchor points to resize the box.

					4.	If you want to change the color of the callout text box, right-click (Windows) or Control-click (Mac) the callout text box (not the text) and choose Properties from the contextual menu. 

						The Callout Properties window opens. You can change the size, color, and font characteristics of the text in the callout text box using the Callout Properties window.

					5.	After modifying the appearance of the callout text box, click OK to close the Callout Properties window.

				[image: tip.eps]	You can select the callout text box and move it to another position any time you want. You can resize the text box by dragging an anchor point.

				The Pencil tool

				With the Pencil tool, you can create freeform lines on your documents. These lines can be useful when you’re trying to attract attention to a specific portion of a page. Just follow these steps:

					1.	Select the Pencil tool from the Drawing Markups toolbar.

					2.	Click and drag to draw on your document.

					3.	You can edit the color and thickness of lines created with the Pencil tool by right-clicking (Windows) or Control-clicking (Mac) the line and choosing Properties from the contextual menu.

						Alternatively, you can press Ctrl+E (Windows) or [image: maccmd]+E (Mac) to access the Properties toolbar.

					4.	Make your choices and click OK.

				[image: tip.eps]	You can use the Eraser tool to to remove portions of lines that had previously been created with the Pencil tool.

				Managing Comments

				One of the most powerful features of PDF commenting is the ability to easily manage and share comments and annotations among reviewers. For example, you can determine which comments are displayed at any time, and you can filter the comments by author or by the type of commenting tool used to create the comment. In addition, you can indicate a response to a comment and track the changes that may have been made to a document based upon a comment. Also, you can consolidate comments from multiple reviewers into a single document.

				Viewing comments

				Choose Comment⇒Comments List to display the list of comments that have been placed in your PDF document. The Comments List shows all the comments in the document, and appears along the right side of the Document window. You can see the author of each comment and any notes entered by reviewers.

				To the right of the comment is a check box that you can use to indicate that the comment has been reviewed or to indicate that a certain comment needs further attention. Use these check boxes for your own purposes; their status doesn’t export with the document if you send the file to others, so they’re for your personal use only.

				Changing a comment’s review status

				Acrobat makes it easy to indicate whether a comment has been reviewed, accepted, or has additional comments attached to it.

				To change the status of a comment, follow these steps:

					1.	Choose Comment⇒Comments List to see the entire list of comments and the status of each one.

					2.	In the Comments List, click the downward-pointing arrow to the right of the author of the comment for which you want to set the status. 

					3.	Click Set Status and then select Accepted, Cancelled, Completed, or Rejected, depending on what’s appropriate to your situation.

						The comment you modified appears in the list, showing the new status you assigned to it.

				Replying to a comment

				You can click the downward-pointing arrow to the right of a comment author’s name in the Comment List and choose Reply to add a follow-up note to the comment. This way, new comments can be tied to existing comments. If your documents go through multiple rounds of review, adding a reply allows a secondary or final reviewer to expand on the comments from an initial reviewer. This method also allows an author or designer to clearly respond to the suggestions from an editor.

				[image: tip.eps]	You can also right-click (Windows) or Control-click (Mac) on a comment located on a document to add a reply. The reply will also be placed in the Comments List.

				Showing and hiding comments

				Because the Comments List can become rather large, you can choose to display only some comments in the list. To do so, click the Filter Comments button in the upper right of the Comments List window; it uses a comment icon of a yellow talk bubble. To hide all comments, choose the Hide All Comments option from the Filter Comments menu in the Comments List.

				To show all the comments within a document, click the Show All Comments option from the Filter Comments menu in the Comments List. You can then choose to display only certain types of comments such as the following: 

				[image: check.png] Type of comment, such as note, line, or cross out

				[image: check.png] Reviewer, such as Bob or Jane

				[image: check.png] Status, such as accepted or rejected

				[image: check.png] Checked State, which can be checked or unchecked

				Use these filtering options to view only those comments that are relevant to your specific review situation. 

				[image: tip.eps]	If you have filtered comments, you can always display all comments again by choosing Show All Comments from the Filter Comments menu in the Comments List.

				Sharing comments

				You can share your comments with other reviewers who have access to the same PDF document by following these steps:

					1.	Make sure that the Comments List is visible by choosing Comment⇒Comments List.

					2.	From the Comments List panel, click the Options icon in the upper right corner of the Comments List panel, and choose Export All to Data File.

						The Export Comments dialog box appears. If you want to share only selected comments, choose the comments from the Comments List and then choose Export Selected to Data File.

					3.	Browse to the location where you want the comments to be saved and give the saved file a new name.

						You now have a file that includes only the comments’ information, and not the entire PDF file. 

				You can share your comments data file with reviewers who have the same PDF file, and they can choose Import Data File from the Comments List window while viewing the same PDF document. You can use this method to avoid sending entire PDF files to those who already have the document.

				Summarizing comments

				You can compile a list of all the comments from a PDF file into a new, separate document. To summarize comments, follow these steps:

					1.	From the Comments List panel, click the Options icon in the upper-right corner of the Comments List and choose Create Comment Summary.

						The Create Comment Summary dialog box appears.

					2.	Create a listing of the comments with lines connecting them to their locations on the page by selecting the radio button from the top — Document and Comments with Connector Lines on Single Pages.

						In the Include section, you can choose which comments should be summarized. If you prefer to create a different summary type, such as a list of the comments, select the option you prefer.

					3.	Click the Create Comment Summary button.

						This step creates a new PDF document that simply lists all the comments, as shown in Figure 5-3.

					

				
					Figure 5-3: A new PDF document is created, listing all the comments.

				

					[image: 9781118168608-fg050503.tif]

				Enabling commenting in Adobe Reader

				Acrobat X Professional makes it easy to include users of the free Adobe Reader in a review process. To include Adobe Reader users in a review, choose File⇒Save As⇒Reader Extended PDF⇒Enable Commenting and Measuring. After saving the file, you can share it with users of the free Adobe Reader, who can then use commenting and markup tools and save their comments into the file. A user of Adobe Acrobat X Professional must enable commenting in a PDF file before users of Adobe Reader can add comments to a PDF file.

				Reviewing PDF Documents

				You can use Acrobat to help manage the PDF review process. Acrobat supports two types of review options:

				[image: check.png] Shared Reviews let you post a PDF file on Adobe’s Acrobat.com servers and allow users to add comments. You can allow anyone with access to the URL to add comments, or you can restrict commenting to specific users.

				[image: check.png] Email Reviews work with some e-mail software applications, such as Microsoft Outlook, and allow you to send a PDF document to recipients, asking them to add comments and then reply.

				Using Shared Reviews

				You can use Shared Reviews to collaborate and share comments quickly without needing to save files and attach them to an e-mail message or upload them to a server. When you use Shared Reviews, comments are uploaded to a central location and shared with other users, who can access them while working on the same document. You will need an Adobe ID and an Internet connection to complete this section. You can obtain an Adobe ID (if you do not already have one) when you are asked to sign-in to the Acrobat.com site.

				To initiate a shared review using Acrobat X, follow these steps:

					1.	Open the document you want to share with reviewers.

						If the document is already open, make certain it’s saved before proceeding so any comments or edits you’ve made to the PDF are captured before the document is shared.

					2.	Choose Comment⇒Review⇒Send for Shared Review.

						The Send for Shared Review dialog box opens.

					3.	In the Send for Shared Review dialog box, choose the Automatically Download & Track Comments with Acrobat.com option, then click Next. 

						You will be requested to log-in to Acrobat.com with an Adobe ID. If you do not have an Adobe ID, you can create one at this time.

						By choosing to have comments stored on Acrobat.com, you won’t need to set up a server at your home or office, and you can avoid any of the technical configuration.

					4.	Enter the following information:

					•	In the To and Cc sections, enter the e-mail addresses of the people you want to invite to participate in the review of your document.

					•	In the Subject field, specify the subject line of the e-mail that will invite reviewers to participate in the review process for this document.

					•	In the Message field, enter text that will be included in the e-mail message inviting reviewers to participate in the review process.

					•	From the Access Level drop-down list, choose the Limited Access or Open Access option to define the level of access you want to provide to the recipient of the document.

					5.	Click Send to initiate the review.

						The PDF is uploaded to the Acrobat.com server, and users you’ve invited to participate in the review receive their invitation to add comments and annotations to the PDF.

					6.	If you have comments to add, place them in the PDF by using the Comment and Annotation tools. Then click the Publish Comments button that was added to the top of the document window at the time the document was shared for review.

					7.	To review comments added by others, open the document and click the Check for New Comments button located at the top of the document window.

						This option is available only after a document has been uploaded for a shared review. Users who receive the PDF as part of the shared review also need to check for comments and publish comments using similar buttons at the top of their document window.

				[image: tip.eps]	If you disconnect from the Internet or put your computer to sleep, the connection to the Acrobat.com server is lost. If this occurs, click the Reconnect to Server button at the top of the document window. This button appears only within a document that has been shared for review.

				[image: tip.eps]	PDF documents shared using shared reviews can be downloaded and shared with other users, so share only with users you trust, and don’t send sensitive information if you are concerned it should not be shared.

				Using Email Reviews

				Email reviews are a means of sharing comments in a PDF by attaching them to an e-mail message. By using this feature you can share comments without needing to upload the file to a server or to sign-in to any service. When you use Email reviews, comments are added to individual PDF files, and then consolidated back into a single PDF when they are returned to the originator. To initiate an Email review:

					1.	Open the document you wish to share with reviewers. 

						If the document is already open, make certain it is saved before proceeding so any comments or edits you have made to the PDF are captured before the document is shared.

					2.	Choose Comment⇒Review⇒Send for Email Review.

						If this is the first time you have initiated an e-mail review, Acrobat will ask you to enter identifying information, then the Getting Started dialog box opens. 

					3.	Confirm the document to be shared and then click Next.

					4.	Enter the e-mail address of those you want to invite to review the document and then click Next.

						The Preview Invitation dialog box opens. Confirm the subject and message of the e-mail invitation are appropriate to send. 

					5.	Click the Send Invitation button.

						An invitation to join the document review is sent using your e-mail application. When they open the PDF file that you send, the recipient will be asked to click the Send Comments button that appears at the top of the PDF he or she receives. This information is also contained in the e-mail message sent to the reviewer.

					6.	When comments on the PDF document are returned to you, open the file you receive and click the Merge Comments button at the top of the document window to combine the comments you received with any comments you may have entered.

				[image: tip.eps]	If you receive comments on a PDF document and Acrobat is unable to locate the original file because it has moved or been renamed, Acrobat will ask you to browse to locate the file at the time you merge comments. 

				

			

		

	
		
			
				Chapter 6: Securing Your PDF Files

				In This Chapter

				[image: check.png] Finding out about security in Acrobat

				[image: check.png] Using passwords

				[image: check.png] Setting limits for editing and printing

				[image: check.png] Removing sensitive data from PDF files

				You may think that because you’ve converted your documents to PDF (Portable Document Format) that they’re secure. This isn’t quite true because Adobe Acrobat includes tools for changing text and images, as well as extracting them for use in other files. For example, you can use several tools to modify text and graphics (see Chapter 4 of this minibook) or copy a passage of text.

				Applying security provides you with control over who can view, edit, or print the PDF documents you create and distribute. You can restrict access to files so that users need a password to view them, or you can restrict certain features of Acrobat, which stops most users from manipulating your files. All Adobe applications recognize and honor security settings applied in Acrobat, but some software ignores Adobe’s security settings or can bypass them altogether. For this reason, you should be careful with whom you share your most sensitive PDF documents because even secure PDF files can be accessed by skilled or determined hackers.

				In this chapter, we discuss using security protection to limit access to PDF files and show you how to limit what users can do to the contents of your PDF documents.

				Understanding Password Security

				By requiring users to enter a password to open and view your PDF files, you limit access to those files so that only certain users can view them. You can also apply security to limit access to certain Acrobat and Adobe Reader features, such as copying text or graphics, editing the file, and printing. Adobe calls this type of security password security because it requires a password to either open the document or to change the security that’s been applied to the document.

				Apply security options to limit the opening or editing of your PDF document, restricting these capabilities to users who have been provided the proper password. You do this by clicking the Tools button on the Tasks toolbar and then choosing Protection⇒Encrypt⇒Encrypt with Password to access the Password Security Settings dialog box.

				In the Password Security – Settings dialog box, choose an Acrobat version from the Compatibility drop-down list. The higher the version of Acrobat, the greater the level of security, but the more limited the compatibility.

				Remember, not everyone has Acrobat X. If you intend to share your file with a broad group or if you’re uncertain which versions of Acrobat or Adobe Reader your audience is using, you should allow everyone with Acrobat 7 and later to access your file. Your choice here is based on your needs for security and also the version of Acrobat or Adobe Reader that your audience uses. Lower versions of Acrobat provide more compatibility with the widest number of viewers because they support much older versions of the free Adobe Reader. In the following list, we explain the compatibility choices before showing you how to enable security in later sections:

				[image: check.png] Acrobat 3 and Later: If the users who receive your PDF files have older versions of the software, you can select Acrobat 3 and Later from the Compatibility drop-down list to ensure that the recipients can view the PDF file you’re securing. This option provides compatibility for users who may not have updated their software in many years, but the level of security is limited to 40-bit encryption. Although this amount keeps the average user from gaining access to your files, it won’t deter a determined hacker from accessing them and can be easily circumvented by a sophisticated user.

				[image: check.png] Acrobat 5 and Later: When sharing files with users who have access to Adobe Reader or Adobe Acrobat Version 5 or 6, this option provides expanded security, increasing the security level to 128-bit, which makes the resulting PDF files more difficult to access. Along with the enhanced security, you can also secure the files while still allowing access to the file for visually impaired users. Earlier versions of security don’t provide this option, but it’s included when you choose either Acrobat 5- or 6-compatible security.

				[image: check.png] Acrobat 6 and Later: Along with the enhanced security offered with Acrobat 5 compatibility, this setting adds the ability to maintain plain text metadata. In short, this option allows for information about the file, such as its author, title, or creation date, to remain visible while the remainder of the file remains secure.

				[image: check.png] Acrobat 7 and Later: This choice includes all security options of Acrobat 6 compatibility and also allows you to encrypt file attachments that are part of a PDF file. It uses the Advanced Encryption Standard, which is a very high level of encryption, making it unlikely that an unauthorized user can decrypt the file without the password.

				[image: check.png] Acrobat X: Choose this option if your audience is using the latest version of Acrobat and you need more advanced security. The encryption improves to 256-bit AES, making the file much more difficult for even the most determined hacker to access.

				Applying Password Security to Your PDF Documents

				Selecting the Encrypt with Password option from the Encrypt button in the Protection section of the Tools panel limits access to the PDF file. Only those who know the password can open the file. However, documents are only as secure as the passwords that protect them. To guard against discovery of a password, use passwords that are eight or more characters in length and include at least one number or symbol and vary the case of the characters. Avoid using words in the dictionary and short passwords. For example, the password Minneapolis is less secure than M1nneap0lis, which mixes numbers, letters, and includes an uppercase character along with lowercase characters.

				To apply password security to a file, follow these steps:

					1.	With a PDF file open, choose Tools⇒Protection⇒Encrypt⇒Encrypt with Password.

					2.	Click Yes when the Applying New Security Settings dialog box appears, verifying that you want to apply security to this PDF. 

						The Password Security – Settings dialog box appears, as shown in Figure 6-1. You can click the Do Not Show This Message Again checkbox if you do not want this message to appear every time you are securing a PDF file using Acrobat.

					3.	Select Acrobat 7 and Later from the Compatibility drop-down list.

						Although Acrobat X provides more robust security, few people are using version X of Acrobat, making it difficult to distribute the file with this high level of security.

					4.	Select the Require a Password to Open the Document check box.

					5.	Enter a password in the Document Open Password text box.

						Acrobat provides you with guidance as to the strength of the password you select, letting you know whether the password can easily be bypassed. You can also add more security settings, which we outline in the next section. Or you can use this setting as the only security to be applied to the document.

				[image: remember.eps]		If password protection is the only security measure you apply to the document, authorized users can access the document by entering a password. Users with the password may also be able to edit or print the document unless you apply additional security measures. We discuss ways to limit the editing and printing of PDF files in the next section.

					6.	Click OK.

					7.	Confirm the password and click OK again. Acrobat warns you that Adobe software honors the security settings, but other tools may allow you to bypass the security. Click OK again and the dialog box closes.

					8.	Save, close, and then reopen the PDF file.

						A password dialog box appears asking for the password to access the secured file. Every time a user accesses the file, he or she will be required to enter a password.

				Limiting Editing and Printing

				In addition to restricting viewing of a PDF file, you can also limit editing and printing, restricting users from making changes to your document. This allows users to view a file but not change it.

				To limit editing and printing of your PDF document, follow these steps:

					1.	With a PDF file open, click Tools⇒Protection⇒Encrypt⇒Encrypt with Password.

						The Password Security – Settings dialog box opens.

					2.	In the Permissions area, select the check box labeled Restrict Editing and Printing of the document.

						You can now specify a password that will be required for readers to edit the file or change the security settings. (See the previous section.)

						With this option selected, you can apply a password for access to features, such as printing or editing. This password can be different than the password used to open the document — in fact, you don’t even need to use a document open password if you don’t want to, but it’s a good idea to use both of these passwords for sensitive data. If you apply a document open password without a permissions password, it’s easy for an experienced user to bypass the security in the PDF file.

					3.	In the Change Permissions Password text box, enter a password.

						Users that enter this permissions password when opening the document can change the file or the security settings. The permissions password can also be used to open the file, and it provides more privileges than the open password.

					4.	Choose whether users can print the document by selecting an option from the Printing Allowed drop-down list.

						The choices include Low Resolution or High Resolution, or you can prohibit printing by choosing None. The settings you choose here apply to anyone who accesses the document and doesn’t know the permissions password.

					5.	Select an option from the Changes Allowed drop-down list (see Figure 6-1) to restrict editing.

						For the most security, choose None.

					

				
					Figure 6-1: Restrict what users can edit.

				

					[image: 9781118168608-fg050601.eps]

					6.	Select the last two check boxes if desired:

					•	Enable Copying of Text, Images, and Other Content: When deselected, this option restricts copying and pasting of text and graphics from  a PDF file into other documents. Selecting this option lets users extract text and images from a file by using the simple Copy and Paste commands.

					•	Enable Text Access for Screen Reader Devices for the Visually Impaired: When you choose Acrobat 5 or Later from the Compatibility drop-down list at the top of the dialog box, you can also select this check box to allow visually impaired users to have the PDF file read aloud to them.

					7.	When you’re satisfied with the settings, click OK.

				[image: warning_bomb.eps]	Choosing more advanced security settings, and choosing the latest version of compatibility, runs the risk of your file not being visible to many users that may not have upgraded to the most recent version of the Adobe Reader or Acrobat. Always understand your audience members and the software versions they’re using before distributing files.

				Removing Sensitive Data

				Sometimes you may want to make a PDF file accessible, but you may want to remove certain sets of information. For example, you may want to remove a person’s name or personal information from a PDF document. You can do this through the process known as redaction.

				To redact information in your PDF document, follow these steps:

					1.	With a PDF file open, choose Tools⇒Protection ⇒Encrypt⇒Black Out & Remove Content⇒Mark for Redaction. Click OK.

					2.	Use the Mark for Redaction tool to highlight all text to be removed from the document.

					3.	After marking all text to be removed from the file, choose Tools⇒Protection ⇒Encrypt⇒Black Out & Remove Content⇒Apply Redactions. Click OK.

						The redacted text is removed from the document.

				[image: warning_bomb.eps]		Note that this permanently removes all content marked for redaction. This cannot be undone. If you are testing this capability, you should first perform a Save As to create a copy of the document so that you do not permanently remove content from a document unintentionally.

					4.	Click Yes to then remove any hidden information in the file, such as the name of the author or the original document name.

						You can also remove this later by clicking the Remove Hidden Information option under the Protection section of the tools panel.

				[image: tip.eps]	You can remove specific phrases or words by using the Search & Remove text option found in the Black Out & Remove Content section of the Tools panel.
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				Chapter 1: Getting Familiar with New Features in Dreamweaver

				In This Chapter

				[image: check.png] Exploring the improved Dreamweaver workspace

				[image: check.png] Previewing a page in multiscreen mode

				[image: check.png] Using the new HTML5 and CSS3 support

				[image: check.png] Working with CSS transitions

				[image: check.png] Building adaptable pages with fluid grids

				[image: check.png] Surveying the new mobile authoring options and tools

				Dreamweaver CS6 lets you create and manage websites and applications across a variety of screens, including desktops, mobile phones, and tablet devices. Depending on their needs, users can use Dreamweaver to create all kinds of websites, from basic sites that consist only of simple links from one page to another to highly interactive websites that feature animation or drag-and-drop functionality. Dreamweaver users can even create more complex web and mobile applications capable of pulling data from databases, XML, or other sources.

				As part of the Adobe Creative Suite, Dreamweaver CS6 works seamlessly with several other Adobe applications, such as Photoshop CS6, Illustrator CS6, and Bridge. Even if you’ve never used Dreamweaver, you’ll be impressed by its many tools, panels, and powerful features that make building desktop and mobile-ready sites and applications easy and intuitive. If you’re familiar with the layout of other Adobe applications, you may feel right at home the first time you open Dreamweaver CS6.

				Dreamweaver’s new features speak to the evolution of the web, with heavy emphasis on mobile web and multiscreen development, extensive support for HTML5 and CSS3, and integration with popular frameworks such as jQuery that define today’s standard web languages. 

				It’s important to note that some of the features you’ll see made their introduction in CS5.5, although many have been polished and improved in CS6.

				Exploring the New Additions to the CS6 Interface

				Dreamweaver CS6 includes a number of subtle but useful enhancements to its workspace, building on the abilities and features introduced in CS 5.5. The most noticeable of these additions include the Multiscreen preview and W3C Validation buttons on the toolbar shown in Figure 1-1.

					

				
					Figure 1-1: The Dream-weaver Designer workspace.

				

					[image: 9781118168608-fg060101.eps]

				The bottom of the Document window (where you’ll be doing most of your work), contains additional options and toggles that allow you to view your page as it will appear in different desktop and mobile screen resolutions, as shown in Figure 1-2. This is one of many subtle additions that reinforce Dreamweaver’s commitment to development for the mobile web.

				In the workspace, panels and panel groups appear tabbed, and you can separate them by dragging a tab to another location, as in other Adobe applications. Later in this minibook, you find out how to customize the workspace for different tasks and projects.

				Previewing Pages in the Multiscreen Preview Window

				Because there are so many different types of devices to design for these days, it’s necessary to know how your work will appear in a variety of screen sizes and resolutions. This information enables you to evolve and modify your design to give users the best experience possible regardless of whether they’re viewing on a desktop, smart phone, or tablet.

				Dreamweaver’s new Multiscreen Preview window can be launched from the top of the Document window so that you can view and compare your page in a number of different viewports, which represent the viewable areas of certain devices and screen sizes. You can customize the viewports based on prefixed device sizes, or even specify your own. You can also use the drop-down arrow next to the Multiscreen button to tailor the viewport of the Document window itself.

				Using Media Query Options

				Even with the new and extensive preview capabilities in Dreamweaver, designing for multiple screens can be a challenge. The old approach of designing for the lowest common denominator has become far less useful now that the differences in size and behavior among mobile, desktop, and emerging platforms (such as set top boxes) can be vast. When you need to tailor your web experience to a specific screen, media queries allow you to target specific devices and to deliver style sheets created with those devices in mind.

				Media query options can be found as part of the Multiscreen Preview window, and allow you to create layout and style variations between specific target devices and style sheets (CSS) within your project.

				Taking Advantage of New HTML5 and CSS3 Support

				The last couple of years have proved to be a revolution for the web; combined efforts to embrace open standards and pull away from plugin- based content has meant rapid adoption for HTML5 (the markup used to construct pages) and CSS3 (the language used to apply styling to pages). These web languages give you more creative and behavioral control than ever, enabling you to create sites that adapt to multiple screens without using plug-ins — which means they work with more consistency.

				Dreamweaver includes new HTML5 layouts out of the box, so you can create a ready-to-modify HTML5-and-CSS3–based page in seconds that leverages new semantic markup elements (such as <header>), as shown in Figure 1-2. In addition, you’ll be able to make use of new CSS3 capabilities such as rounded corners, multicolumn text, and even animation.

				Several views (such as the Code view) now recognize and auto-complete the new HTML5 elements, and panels, such as the CSS Properties panel, include new CSS3 properties and suggested values, as shown in Figure 1-3.

				[image: remember.eps]	Although a number of HTML5 and CSS3 features have been adopted consistently in the latest versions of Firefox, Safari, Chrome, and Internet Explorer, the HTML5 spec still isn’t final, and support for many CSS3 properties still varies. This means certain features will be available only in certain browsers, and that success may vary. In certain cases, it may still be necessary  to do a little hand-coding or tweaking to make sure things are backwards-compatible — or work at all, for that matter.

					

				
					Figure 1-2: Create HTML5-based pages easier with support for new HTML5 tags in the Code view. 

				

					[image: 9781118168608-fg060102.eps]

					

				
					Figure 1-3: New CSS3 properties, such as border-radius, are recognized and can be added within the CSS Properties panel.
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				Exploiting the New, Enhanced jQuery Support

				In addition to HTML and CSS, the jQuery JavaScript library has become one of the staple languages of the web, heavily utilized by countless sites for cool interactive behavior (such as animation and drag-and-drop), AJAX capabilities, and animation. Dreamweaver’s Code view recognizes and auto-completes jQuery commands, making it easier than ever to work with jQuery. (See Figure 1-4.)

					

				
					Figure 1-4: Built-in jQuery support means easier coding and more cool stuff for your pages!
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				Bringing Your Pages to Life with CSS Transitions

				Traditionally, if you wanted to create cool fades, slides, and sizing effects without Flash you’d need some help from JavaScript or a JavaScript library such as Spry or jQuery. Although these are still very viable and common options, CSS3 now provides native transition properties that allow you to create these same effects without depending on JavaScript. The CSS Transitions panel has been added to allow you to design interesting interactive behavior and transitions using only CSS3.

				Much like the Behaviors panel, which Dreamweaver has included for a long time and which now uses Adobe’s own Spry JavaScript framework, the CSS Transitions panel allows you to select an element in the Document window and apply transition behavior to any number of that element’s properties, including width, height, and opacity. You can trigger this transition on hover, focus, and other behaviors, as shown in Figure 1-5.

					

				
					Figure 1-5:  Add dynamic, interesting visual effects using pure CSS.
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				Working with Fluid Grids

				Many of the new features in Dreamweaver are designed to make authoring across many different screens easier. Creating several versions of a website or application to suit specific devices can be time consuming and difficult to maintain. A great way to overcome this is the use of fluid grids, which are pages designed on a single grid system that can easily adapt to multiple screen sizes.

				When working with fluid grids, Dreamweaver opens up a number of visual aids to help you build your page. In conjunction with the new Multiscreen Preview window, fluid grids allow you to easily design flexible pages that render well in most any screen or device setting, as shown in Figure 1-6.

					

				
					Figure 1-6: Create new Fluid Grid layouts easily from the New Document window. 
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				To create a new page based on a fluid grid, choose File⇒New Fluid Grid Layout as shown in Figure 1-7, or New⇒Fluid Grid Layout.

				Exploring the New Mobile Authoring Options and Tools

				Mobile-ready websites are no longer considered a luxury or novelty. Some experts predict that the use of mobile devices for online activity will soon surpass fixed desktop computer usage. This means that when creating a website you must think of smart phones, tablets, and other portable Internet-ready devices (such as Amazon’s Kindle Fire) as likely venues. Dreamweaver gets you off to a great start toward mobile site and application development with some exciting new features, including the following:

				[image: check.png] jQuery Mobile Projects: You can now create mobile projects in Dreamweaver using the increasingly popular jQuery Mobile framework, which allows for rapid development of cross-device mobile apps that look and feel like native apps. This is a great addition for new or experienced web designers looking to create mobile-ready sites without the overhead of complex coding, and using standard web languages such as HTML, CSS, and JavaScript. To create a new jQuery Mobile project, you can choose File⇒New⇒Page From Sample⇒Mobile Starters, as shown in Figure 1-7.

				[image: check.png] jQuery Mobile PhoneGap Projects: This new feature is much like the new jQuery Mobile project, but with the additional files and support necessary to make your mobile project ready for use with PhoneGap. PhoneGap is an open-source HTML5 framework that allows you to author native mobile applications with standard web languages, and to deploy them to iPhone, Android, and Blackberry platforms as native applications. Another huge advantage is PhoneGap’s ability to leverage native device APIs, so your applications can take advantage of hardware features, such as the accelerometer and GPS. To find out more about PhoneGap, visit www.phonegap.com.

				[image: check.png] Mobile device sizes and rendering: Several areas within Dreamweaver, such as the Document window, Multiscreen Preview, and Live view allow you to take advantage of common device screen sizes and presets, as shown in Figure 1-8.

					

				
					Figure 1-7: Create rich mobile applications by using integrated jQuery Mobile projects.

				

					[image: 9781118168608-fg060107.eps]

					

				
					Figure 1-8:  The various view options and Multiscreen Preview are great for seeing your work in context of smart phone and tablet devices. 

				

					[image: 9781118168608-fg060108.tif]

				

			

			
		

	
		
			
				Chapter 2: Introducing Dreamweaver CS6

				In This Chapter

				[image: check.png] Familiarizing yourself with the workspace

				[image: check.png] Finding out about panels

				[image: check.png] Creating a new website

				[image: check.png] Discovering the Property inspector

				[image: check.png] Previewing your page

				[image: check.png] Understanding the Dreamweaver preferences

				Dreamweaver CS6 lets you create and manage web pages and complete websites for desktop, mobile, and tablet devices. In this chapter, you find out how to start a website and build pages within it. A website is simply a group of linked pages that contain text and images and can also contain media, such as video, audio, Flash movies, transitions, and animations.

				Getting to Know the Workspace

				Dreamweaver comes with a number of workspaces, which are arrangements of different panels and toolbars. A workspace consists of panels, toolbars, and inspectors and puts most all the tools you need within close reach. The Designer workspace is what you see by default. (See Figure 2-1.) The Dreamweaver workspace is slightly different from ones you may see in other Adobe applications, but their premise is the same: You can open panels, panel groups, toolbars, and dialog boxes to do the work you need. Whichever document you’re editing appears in the Document window, which occupies most of the workspace — with top and bottom toolbars and lots of options to choose from. You can customize your workspace with only the panels, toolbars, and arrangement of windows you need, or choose from a number of additional workspace presets included with Dreamweaver.

				When Dreamweaver is first launched, you see a Welcome screen. This screen provides the option to open any recent items (if you’ve created pages already) or to create new HTML, CSS, XML, sites, and many other types of files. 

					

				
					Figure 2-1: The Dream-weaver workspace.

				

					[image: 9781118168608-fg060201.eps]

				The Insert panel

				The Dreamweaver CS6 Insert panel provides you with tools to insert common web page elements such as hyperlinks, e-mail links, tables, and images as well as additional text formatting options and widgets that enhance your page. Choose Window⇒Insert to reveal the panel in the upper-right corner of your workspace.

				The Insert panel is divided into eight categories that provide you with different elements to add to your page. You can switch between these categories by using the drop-down list at the top of the panel:

				[image: check.png] Common: Contains the most commonly used objects, such as images and tables.

				[image: check.png] Layout: Contains layout elements — such as tables and CSS elements like the DIV tag — that help you create a web page layout.

				[image: check.png] Forms: Contains the elements necessary to create a form in your Dreamweaver page.

				[image: check.png] Data: Contains elements related to dynamic content and some Spry data objects.

				[image: check.png] Spry: Contains Spry Framework objects, which are handy widgets used to enhance your web pages with cool navigation bars, layout panels, and real-time data components.

				[image: check.png] jQuery Mobile: Contains jQuery Mobile–specific objects (such as form and layout elements) for use with jQuery Mobile pages and projects.

				[image: check.png] InContext Editing: Creates editable regions for the Adobe InContext editing service, which allows content contributors to update website content remotely without the need to edit or disturb the original website files.

				[image: check.png] Text: Provides you with text formatting tags.

				[image: check.png] Favorites: Allows you to group and organize the Insert panel buttons you use the most within one common location.

				[image: tip.eps]		To bring up the Customize Favorite Objects dialog box, simply right-click (Windows) or Control-click (Mac) within the Insert panel and choose Customize Favorites from the contextual menu. The Customize Favorite Objects dialog box, shown in Figure 2-2, appears. Click an object in the Available Objects list and then click the double arrow to add the object to your Favorites category.

					

				
					Figure 2-2: Customize the Insert panel’s Favorites category by adding frequently used objects from other categories.

					
				

					[image: 9781118168608-fg060202.eps]

				The Document toolbar

				The Document toolbar, shown in Figure 2-3, contains tools to help you view your document in different modes, such as Code and Design, as well as address such items as the document title and browser compatibility. In addition, you can preview your page in Live view to see how it may appear in an actual web browser. In addition, the new Multiscreen Preview drop-down list allows you to see how your page appears within different screen sizes, with presets for mobile phones and tablets.

					

				
					Figure 2-3: Control your view of the page from the Document toolbar.

				

					[image: 9781118168608-fg060203.eps]

				The tools here include the following:

				[image: check.png] Code view: Show the code and only the code using this view. Dreamweaver helps you to decipher code by color-coding tags, attributes, CSS, and other elements.

				[image: check.png] Split view: Selecting this option splits the Document window between Code and Design views. If you understand a little about code, this view can be extremely helpful because you see both the design and the code simultaneously.

				[image: check.png] Design view: This option displays your page in Design view in the Document window.

				[image: check.png] Live view: Live view renders your page as though it’s in a browser — free of borders, guides, and other visual aids. In Live view, you can’t edit the previewed content, but you can still jump to Code, Split, or Design view and modify your page content.

				[image: check.png] Live Code (Live view only): When Live view is enabled, you can view and inspect the source code of your document as a user would see it in a browser (via the View Source or Page Source menu options in most browsers). You can’t edit page code in this view.

				[image: check.png] Inspect (Live view only): The Inspect button works with Live view to reveal the CSS rules that format elements on your page. When you select an element on the page with Inspect enabled, the CSS Styles panel reveals the properties that format that element, and allows you to disable or modify specific properties and see the results in real time.

				[image: check.png] Previous Page, Next Page, Refresh, Home, Address (Live view only): These controls work very much like they do on a standard web browser, allowing you to navigate your page history while in Live view, refresh the current page, type in a new address, or return to the home (index) page of your site.

				[image: check.png] Live View Options: Click and select options from this menu to control how your document appears and works when Live view is enabled.

				[image: check.png] File Management: Click this button to display the File Management pop-up menu. Use this menu to check your document in or out (when Check In/Check Out is enabled for your site).

				[image: tip.eps]		A very cool but underestimated feature is the ability to type any website address in the Live view browser. You can type in the URL of a website that you’d like to browse, and then you can use the Related Documents toolbar to inspect the files (such as CSS and JavaScript) that comprise it and see how it’s built. You can even use the Multiscreen Preview drop-down list to see how it holds up at different screen sizes!

				[image: check.png] Preview/Debug in Browser: Click this button to preview or debug your document in one of your installed web browsers, Adobe’s BrowserLab, or Device Central.

				[image: check.png] Multiscreen Preview and Viewport options: Compare and contrast your page as it appears in different screen sizes, including common presets for mobile phone, tablet, and desktop. You can also adjust the Document window viewport size if you’d like to work in context of a specific screen size, as shown in Figure 2-4.

				[image: check.png] W3C Validation: Validate your page against current W3C standards for accessibility, HTML and XML markup standards, and more.

				[image: check.png] Check Browser Compatibility/Spelling: This menu shows options that let you check page integrity, such as accessibility, or whether your CSS rules are compatible across different browsers.

				[image: check.png] Visual Aids: Click this button to select different visual aids (such as borders and guides) to help you see various elements and make designing your pages easier.

				[image: check.png] Refresh Design View: Click this button to refresh the document’s Design view after you make changes in Code view. Changes you make in Code view don’t appear automatically in Design view until you perform certain actions, such as save the file or click this button.

				[image: check.png] Document Title: Enter the name of your document in this field.

				[image: check.png] Related Documents: Documents used by and attached to your page, such as external CSS and JavaScript files, are listed below (Mac) or above (Windows) the view selection (Code/Split/Design) buttons. You can click any listed document to edit the attached file in Split view without having to switch documents.

						Note: XML, JavaScript, CSS, and other code-based file types can be viewed and edited only in Code view; the Design and Split buttons appear dimmed out.

						Note: Refreshing also updates code features that are Document Object Model (DOM) dependent, such as the ability to select a code block’s opening or closing tags.

					

				
					Figure 2-4: Adjust the viewport size using the Multiscreen Preview drop-down list or the options on the bottom of the Document window.

				

					[image: 9781118168608-fg060204.tif]

				Using the panel groups

				Dreamweaver provides you with a panel docking area off to the right of the workspace. The panels in Dreamweaver appear grouped and tabbed, and you can easily access the appropriate panel for the job by either clicking the tab of the panel to bring it forward or by selecting the named panel from the Window menu.

				Close a panel by either selecting the name of the panel from the Window menu or by tearing the panel out of the group and clicking the Close icon.

				Saving your workspace

				Just as with the other Creative Suite 6 applications, you can organize your workspace by turning on the visibility of the panels and toolbars that you use regularly and closing the others. You can also save your workspace so that you can recall it at any time:

					1.	Choose Window⇒Workspace Layout⇒New Workspace.

						The New Workspace Layout dialog box appears.

					2.	Type an appropriate name in the Name text box.

					3.	Click OK to create the new workspace.

				To recall a workspace you’ve previously saved, you can use one of the following methods:

				[image: check.png] Select the workspace from the Workspace menu near the top of the screen (above the panel group).

				[image: check.png] Open the workspace by choosing Window⇒Workspace Layout⇒[your workspace name].

				Dreamweaver CS6 features several new workspaces geared toward different types of users as well as different tasks. You can recall any of these workspaces by using either of the ways described in the previous list or by selecting a workspace from the application bar, which appears at the top of your screen, as shown in Figure 2-5.

				[image: tip.eps]	You can hide the application toolbar by choosing Window⇒Application Bar.

					

				
					Figure 2-5:  The Work-space selector on the application toolbar allows you easy access to your saved workspaces.

				

					[image: 9781118168608-fg060205.eps]

				Creating a Site

				Sites are quite important to maintain the links and consistency and the general organization of your web pages. (See Chapter 3 of this minibook for more on creating sites.) Some good news is that the process of creating a new site has been simplified in Dreamweaver CS6.

				To create a site, follow these steps:

					1.	Choose Site⇒New Site.

						The Site Setup dialog box appears.

						This dialog box walks you through the steps to create a new site. In this chapter, you breeze through the steps, but you can find more details about them in Chapter 3 of this minibook.

					2.	In the Site Name box, type a name for your new site.

						For example, enter chapter2.

					3.	The Local Site Folder field shows you where the new site folder will be created. If you want to change it, you can click the Folder icon to select an existing folder. For now, leave the default folder path and click Save.

						The site now appears in the Files panel in the lower-right corner of your workspace.

				Checking Out the Property Inspector

				After you’ve created a site, you can begin to add new pages as well as assets, such as images, to that site. The Property inspector becomes one of your most useful panels because it provides you with information about any element you’ve selected in the Document window. This contextual panel, shown in Figure 2-6, displays text attributes when text is selected or image attributes when images are selected, and so on.

					

				
					Figure 2-6: The Property inspector as it will appear with text selected (top) and an image selected (bottom).

				

					[image: 9781118168608-fg060206.eps]

				To see this panel in action, you need to create a new page with some elements on it. You may not have any of your own pages yet, so you can use one of the CSS Starter pages that loaded with your Dreamweaver CS6 installation, and follow these steps:

					1.	Choose File⇒New to create a new page in Dreamweaver.

						The New Document dialog box appears.

					2.	Choose Blank Page⇒HTML⇒2 Column Fixed, Left Sidebar and then click Create.

					3.	Choose File⇒Save As.

						The Save As dialog box appears. 

					4.	Type a name in the Save As text box.

						The location is routed automatically to the site folder you created. See the earlier section “Creating a Site” to see how to create a site.

					5.	With your new page open in the Document window, click to select various elements, such as text, a table, or a hyperlink (linked text).

						With each selection, the Property inspector changes to provide you with specific information about that element. (Refer to Figure 2-6.)

				For more information on the Property inspector see Chapter 4, “Working With Images.”

				[image: tip.eps]	The Property inspector is analogous to the Option bar, which appears at the top of the Illustrator, InDesign, and Photoshop workspaces and the Property inspector in Flash. If you’re a former GoLive user, the concept of using the Property inspector is also quite familiar to you because this same feature existed in that application as well.

				Previewing Your Page in a Browser or with Live View

				Perhaps you’ve completed your page and you want to investigate how it looks in a browser. You can quickly preview your file by simply clicking the Preview/Debug in Browser button on the Document toolbar and selecting a browser to preview your page, as shown in Figure 2-7. You can also preview your page in Adobe’s BrowserLab or Adobe’s Device Central (which simulates several different mobile and PDA devices).

					

				
					Figure 2-7: The Preview/Debug in Browser button lets you select from your installed browsers or the online Adobe BrowserLab service. 

				

					[image: 9781118168608-fg060207.eps]

				You can always add browsers from the Preferences panel by choosing  Edit⇒Preferences⇒Preview in Browser (Windows) or Dreamweaver⇒Preferences⇒Preview in Browser (Mac).

				Previewing your page using Live view

				The Dreamweaver CS6 Live view displays your page as you would see it in a browser. This feature is a nice alternative to the Preview in Browser command because you don’t ever need to exit Dreamweaver.

				To view your page in Live view, follow these steps:

					1.	With a page open in the Document window, click the Live View button on the Document toolbar.

					2.	To see the resulting source code of your page, click the Live Code button that appears next to the Live View button.

						This step is equivalent to using the View Page Source or View Source options available in most every browser. In this mode, you can only view code, not edit it.

					3.	To edit your page code, switch to Split view or Code view on the Document toolbar.

				Previewing your page using Adobe BrowserLab

				Adobe BrowserLab is a unique service that is accessible from directly within the Dreamweaver environment. You can view and simulate your website in a number of different browsers, browser versions, and operating system environments from one single location. You can even preview different environments side by side, as shown in Figure 2-8, to see how different browsers render your site.

				[image: tip.eps]	Before you can use the BrowserLab service, you must make sure you have access. To get access, visit http://browserlab.adobe.com, or follow the login steps presented when you first try and use the service within Dreamweaver.

					

				
					Figure 2-8: The Dummies.com site shown in BrowserLab as it will appear in Internet Explorer 9. 

				

					[image: 9781118168608-fg060208.eps]

				To preview your site in Adobe BrowserLab, click the Preview/Debug in Browser button on the Document toolbar (refer to Figure 2-7) and choose Preview in Adobe BrowserLab or File⇒Preview In Browser⇒Adobe BrowserLab, or click the Preview button in the new Adobe BrowserLab panel located in the workspace on the right.

				Understanding Dreamweaver Preferences

				You can change many preferences in Dreamweaver CS6 for Mac OS X or Windows. You see categories, such as Accessibility, AP Elements, and General in the panel on the left, along with subcategories that appear in the panel to the right.

				To access general preferences, choose Edit⇒Preferences (Windows) or Dreamweaver⇒Preferences (Mac). The general rule for changing preferences is that if you don’t know what it means, don’t touch it. But if you want to tweak certain things, this is the place to go.

				[image: tip.eps]	Preferences are especially helpful to people who hand-code and want to enter their own code hints and highlight colors, or who want to change the font that appears in Code view.

				

			

		

	
		
			
				Chapter 3: Creating a Website

				In This Chapter

				[image: check.png] Creating a site

				[image: check.png] Adding pages to your site

				[image: check.png] Adding images to pages

				[image: check.png] Keeping track of your website files

				[image: check.png] Discovering HTML and HTML5

				In this chapter, you see the basic steps for putting a website together, from creating your first new, blank site to adding files to websites to playing (just a little) with HTML.

				Website Basics

				A website is a collection of related pages linked to one another, preferably in an organized manner. With the proper planning and a goal in sight, you can easily accomplish the task of creating an outstanding website. Figure 3-1 shows the general structure of a website. A website starts with a main page (or its home page), the central link to other pages in the site. The main page is also the page viewers see first when they type your URL in a browser. The main page is typically named index.html but may also be index.htm or even default.htm. Check with your service provider to find the correct name.

					

				
					Figure 3-1:  The structure of a website.

				

					[image: 9781118168608-fg060301.eps]

				Pages are linked by hyperlinks, or references that take viewers from one point in an HTML document to another or from one document to another. (Read more about hyperlinks and how to create them in Chapter 6 of this minibook.)

				Web applications are like websites, but they go beyond the simple delivery of text and images to include interaction with databases and other advanced functionality. For instance, websites that allow you to trade stocks, manage your diet, or book your travel arrangements can be considered web applications. These days, the line between websites and web applications is blurred, but it’s important to know that Dreamweaver allows you to create and manage both.

				[image: technicalstuff.eps]	You should understand the following terms when you forge through the steps to create a website:

				[image: check.png] FTP (File Transfer Protocol): Allows a user on one computer to transfer files to and from another computer over a TCP/IP network. FTP is also the client program the user executes to transfer files. You can use FTP to transfer web pages, images, and other types of files to a host web server when you publish your site.

				[image: check.png] HTTP (Hypertext Transfer Protocol): The client-server TCP/IP protocol used on the Internet for the exchange of HTML documents.

				[image: check.png] TCP/IP (Transmission Control Protocol/Internet Protocol): Underlying protocols that make communication possible between computers on the Internet. TCP/IP ensures that information being exchanged goes to the right place, in a form that can be used, and that it arrives there intact.

				[image: check.png] URL (Universal Resource Locator): A standard for specifying the location of an object, such as a file, on the Internet. You type the URL, such as www.dummies.com, into a web browser to visit a web page. A URL is also used in an HTML document (a web page) to specify the target of a link, which is often another web page.

				[image: tip.eps]	Plan your site: How websites are organized is important. Typically, the  purpose of a website is to convey a message, provide a service, or sell  something — a product, a service, or a thought. Without sound organization, a website may fail to fill its purpose. You’ll save an extraordinary amount of time if you just think ahead and plan your site’s organization. Think about the topics you want to cover and then organize your site as you would a high school essay project, by planning the topic sentence, subtopics, and other elements. This plan can be a tremendous aid when you start mapping pages to be linked to others.

				Starting a New Site

				Even if you’re creating only one page, be sure to create a site. A site gives you an organized method of keeping together images and other assets and offers additional options for managing those files.

				To create a new site, follow these steps:

					1.	In Dreamweaver CS6, choose Site⇒New Site.

						You can also choose Dreamweaver Site from the Create New column of the Welcome screen. The Site Setup dialog box appears, as shown in Figure 3-2.

					2.	In the Site Name text box, enter a name for the site.

						For example, if your site’s focus is on bikes, you might name the site biking.

					3.	To change the local site folder, click the Folder icon to the right of the Local Site Folder field and select a new location or choose an existing folder.

						The local site folder is the path where your new site folder will be created on your computer. It’s where your site files and pages will be stored from this point on.

					4.	Click Save to create your new site.

					

				
					Figure 3-2: Browse to your site folder (or have Dream-weaver create a new one for you).

				

					[image: 9781118168608-fg060302.eps]

				As soon as you create a site, your site folder is waiting in the Files panel, as shown in Figure 3-3. Think of the Files panel as the control center for all your files, folders, and other assets, such as images, sound, and video that you use to create your website.

				You can use the Files panel to view files and folders, whether or not they’re related to your Dreamweaver site. You can use the Files panel to do typical file operations, such as open and move files.

					

				
					Figure 3-3: The Files panel acts as a file browser and manager.

				

					[image: 9781118168608-fg060303.eps]

				Creating a New Page for Your Site

				After you create a site, you typically build a main page: the index.html or index.htm page. These reserved filenames are recognized by most every web server as the starting page for a website. In addition, default.html and default.htm are also commonly recognized as starting pages. Check with your website-hosting company or Internet service provider because in some instances your server may require a different name or may prefer one naming convention over another.

				The following steps walk you through creating a new page and placing an image on it:

					1.	Choose File⇒New.

						The New Document dialog box appears.

						You can create many types of new files, from blank pages to more advanced pages that include layouts already created in CSS.

					2.	To create a blank page, choose Blank Page⇒HTML⇒<none> and then click Create.

						A blank, untitled HTML page appears in the Document Window.

					3.	Choose File⇒Save.

						The Save As dialog box appears.

					4.	In the File Name text box, type index.html.

						Note that Dreamweaver should know to save the file to your new site folder. If you don’t see the site’s root directory (the main folder where all pages and assets are stored), click the Site Root button in the Save As dialog box to navigate directly to it.

					5.	Click Save.

				Note that when you save a file, it appears in the Files panel.

				Adding an Image to Your Page

				When you have a blank page, you can add an image to it, including native Photoshop (PSD) files and Fireworks (PNG) images. You can find out more about images in Chapter 4 of this minibook, but in this section, you can take a look at how placing images affects the Files panel.

				To place an image on a page, follow these steps:

					1.	Click somewhere on the page to place your cursor. 

						This is the location where the new image will be added.

					2.	Choose Insert⇒Image.

					[image: 9781118168608-ma198.tif]		Alternatively, click the Common tab of the Insert panel and click the Image button.

						The Select Image Source dialog box appears.

					3.	Navigate to the location of your image and click Choose (Mac) or OK (Windows).

						If you choose a native Photoshop (PSD) or Fireworks (PNG) file, the Image Optimization dialog box appears, allowing you to optimize your image directly in Dreamweaver.

				[image: tip.eps]		If you select a web-ready image, such as GIF, JPEG, or PNG and the image is outside your site folder, you see a warning. Dreamweaver alerts you that the image is outside the root folder, which causes issues when you copy pages to a web server. Click Yes to copy the file to your site’s root directory. Assign a new name there or just click Save to keep the same name and duplicate the image file into your site folder.

						The Image Tag Accessibility Attributes dialog box appears.

					4.	Add an appropriate description of the image in the Alternate Text  text box.

						All images should have alt (alternate) text — text that appears before the image has downloaded or if the viewer has turned off the option to see images.

						If the image is a logo, the description should include the company name as the alt text or, if it’s a photo or an illustration, describe the image in a few words as shown in Figure 3-4.

					

				
					Figure 3-4:  It’s important to add alt (alternate) text to images to improve accessibility as well as search engine optimization.

				

					[image: 9781118168608-fg060304.eps]

						From an accessibility standpoint, alt text aids screen readers (such as those used by the visually impaired) in identifying image content to users. In addition, alt text is a valuable tool in providing search engines a way of indexing image content included on your site.

					5.	Click OK.

						The image is added to the page. If this is a new image that didn’t exist in your site root already, the new image is added to the Files panel as well, as shown in Figure 3-5.

				[image: tip.eps]	You can edit an image by double-clicking it in the Files panel. You can also use the Property inspector to see details about the image, including its dimensions and file size. You can also modify image properties, including border, hyperlink, and vertical and horizontal padding.

				When you create a larger site with multiple pages linked to each other, you may want to change the view of the Files panel. By clicking the drop-down list (on the top-left side of the Files panel) where your site is located, you can locate folders and other sites you’ve used recently. By clicking the View drop-down list to the right, you can change the appearance of the Files panel. Refer to Figure 3-3 for an example of how a site appears in Local view.

					

				
					Figure 3-5:  Use the Image button on the Insert panel to add images to your page.

				

					[image: 9781118168608-fg060305.eps]

				[image: tip.eps]	You can also place images by selecting them in the Files panel and dragging them to the desired location on your page.

				Naming files

				Start the habit of naming files and folders correctly. Follow these rules to make sure that links and pages appear when they’re supposed to:

				[image: check.png] Use lowercase for all filenames. If possible, using all lowercase letters in filenames is an easy way to ensure that you have no broken links because you couldn’t remember whether you initial-capped a filename. Some web servers (such as those based on Unix or Mac OS X) are case sensitive. Although a Windows server may be more forgiving of case, you don’t want to count on it in the event your files are moved to a different type of server. If it’s necessary to use capitalization, stick to one style and keep it consistent.

				[image: check.png] Avoid using spaces in filenames. If you need to separate words in a filename, use the underscore character instead of a space. For example, rather than use file new.html, use file_new.html or just filenew.html.

				[image: check.png] Use only one dot, followed by the extension. Macintosh users are used to having few naming restrictions, so this rule can be the toughest to adhere to. Don’t name your files finally.done.feb.9.jpg , for example — it can be problematic in certain cases. Examples of dot extensions are .jpg, .gif, .png, .htm, .html, .cgi, .swf, and so on.

				[image: check.png] Avoid odd characters. Characters to avoid include ampersands (&) and forward slashes (/) within a filename. These characters can have other meanings to the web server and create errors on the site.



				Managing Your Website Files

				You can find out more about uploading your site to a web server in Chapter 9 of this minibook, but for now, understand that you can go back and open the Site Setup dialog box at any time by choosing Site⇒Manage Sites. The Manage Sites dialog box that appears offers options for editing, duplicating, removing, exporting, and importing sites. Click Edit to add an FTP server  or change the name of your site as well as add or change any original site settings.

				Delving into HTML Basics

				The web page itself is a collection of text, images, links, and possibly media and scripts. The web page can be as complex or simple as you want — both types are equally effective if created properly. In this section, we show you how to create a page in Dreamweaver and then investigate the HTML that creates it.

				To create a blank page, choose File⇒New⇒Blank Page⇒HTML⇒<none> and then click Create. A blank, untitled HTML page appears. It has no formatting until you add tables or layers. (See Chapter 7 of this minibook.) When you type on the page in the document, text appears on the web page. But there’s much more to it than that: Type some text (say, your name) on the page and click the Code button on the Document toolbar.

				Dreamweaver works in the background to ensure that your page works in most all-recent versions of common web browsers, such as Firefox, Internet Explorer, and Safari. Lots of code is created to help the web browser recognize that this is HTML and which version of HTML it uses.

				[image: tip.eps]	By default, Dreamweaver uses the XHTML 1.0 Transitional standard every time you create a new HTML page. XHTML combines the strictness of XML (eXtensible Markup Language) with HTML tags to create a language that works dependably and consistently across web browsers and new devices (such as cellphones and PDAs) alike.

				Select Split view by clicking the Split button on the Document toolbar; this action displays both Design and Code views simultaneously, as shown in Figure 3-6, so that you can see how your changes affect HTML behind the scenes. Select the text; then select the Text option from the Common drop-down list on the Insert panel. Suppose you then choose B (for bold) to bold the selected text. In the code view of your page, you would see that the <strong> tag was added before the text and the </strong> tag was added after the text.

				[image: tip.eps]	You can change the orientation and arrangement of the views in Split view. To switch the Design view from the right to the left, choose View⇒Design View on Left. To arrange the views vertically, choose View⇒Split Vertically. Note: You can reverse these options just as easily from the same options on the View menu.

					

				
					Figure 3-6: Working in Split view. The H1 tag makes a headline bolder and larger than other text on the page.

				

					[image: 9781118168608-fg060306.eps]

				HTML code, though fairly straightforward, is just like any other language, in that you must figure out the syntax (the proper sequence and formation of the code) and vocabulary (memorize some common tags). You don’t have to have gobs of tape on your glasses to build good, clean web pages, but you do have to review the following HTML basics.

				[image: tip.eps]	If you’re an experienced user, you know that you can figure out a lot about HTML code by analyzing it and modifying it. If you’re a new user, copying, pasting and modifying code can help you understand the code that others have implemented on their pages and perhaps give you some ideas. Working in Split view also helps you understand how the items you add from the toolbars and panels translate into code.

				In general, HTML tags are composed of three parts:

				[image: check.png] The tag is the main part of the HTML information — for example, <strong> for strong or bold, <div> for the div tag, or <table> for an HTML table. A tag is always constructed of a keyword enclosed in a set of brackets, such as <p>, or <blockquote>.

						Because most tags come in pairs, you must enter an opening tag (<p>) and a closing tag (</p>). In XHTML 1.0 Transitional (the standard used for all new pages created in Dreamweaver), all tags must be closed. You can either close a tag or create a self-closing tag by including the slash before the closing bracket: <br/>.

						For example, if you make text bold by adding the tag <strong>, tell the text where to stop applying boldface by inserting a closing tag </strong>. Otherwise, the text continues to appear bold throughout the remainder of the page.

				[image: check.png] The attribute gives you a way to further fine-tune the appearance of a specific HTML tag. An attribute is always added to an opening tag and can take different values to control attributes such as the link color, size, and destination. For example, align is an attribute of the <p> (paragraph) tag that specifies how text inside of the paragraph should horizontally align. You may also see that many HTML tags share the same attributes.

						Here’s an example of a paragraph (<p>) tag with a class attribute added:

				<p class=”bigparagraph”>This is styled text</p>

				[image: check.png] The value is the color, size, and link destination specified in an attribute. For example, you can specify a hexadecimal number as the value for a color attribute. An example of a value for the bgcolor attribute of the <body> tag (which controls overall page appearance) could be “red” or “#CC0000”.

				One last thing: Nesting is the order in which tags appear. If a <strong> tag is applied, it looks like this: <strong>This text is bold</strong>. Add an italic tag, and you see <strong><em>This text is bold and italic.</em></strong>. Notice the in-to-out placement of the tags: You work your way from the inside to the outside when closing tags.

				What Is HTML5?

				HTML5 is the fifth and latest proposed specification of the HTML standard, and at the time of this writing it’s still under development. Some of the proposed goals of HTML5 are to improve semantic structure of HTML documents, or web pages, and to provide more capabilities to designers and developers with less reliance on plug-ins or add-ons to create useful web applications.

				Despite varying browser support and continued review, HTML5 became somewhat of a phenomenon thanks to huge support within the web community as well as from manufacturers such as Apple, who abandoned support for plug-ins (including Adobe’s own Flash player) on their iOS based devices in favor of open web standards such as HTML5, CSS3, and JavaScript.

				At the time of this writing, many of the latest browsers, including IE9,  Firefox 7, Safari, and Chrome, have implemented support for many of the most common HTML5 features. Many mobile application frameworks (such as Query mobile) rely on these standards to create rich, interactive mobile applications that look and behave like native applications.

				Although the HTML5 spec is wide (and beyond the scope of this book), some notable changes and additions include:

				[image: check.png] New tags: The addition of highly descriptive tags such as <header>, <nav>, <aside>, <footer>, and <article> add a new level of semantics that was previously unachievable with heading and div tags alone. 

				[image: check.png] Canvas: The <canvas> tag allows for immediate 2D drawing within a web page via the Canvas 2D API. This opens up new worlds around real-time graphics, data visualization, and more, previously achievable only with plug-ins or third-party JavaScript APIs.

				[image: check.png] Native media playback: Plug-in–free embed and playback of video and audio content via the (you guessed it) <video> and <audio> tags.

				[image: check.png] Drag and Drop: Although drag and drop has been achievable for some time with JavaScript, native drag and drop is now implemented in HTML5.

				[image: check.png] Offline storage: Websites and applications can now make data available for offline use via local and session storage or a more robust SQLLite database, allowing them to provide storage capabilities without an Internet connection.

				[image: tip.eps]		Dreamweaver CS6 includes new HTML5 page presets, including two- and three-column layouts. These are great starting points for learning HTML5. In addition, HTML5 elements are now recognized in several views. Choose File⇒New⇒Blank Page and select one of the HTML5 layouts shown. (See Figure 3-7.)

					

				
					Figure 3-7: New HTML5 tags such as <header> and <nav>, shown in one of the new HTML5 sample pages included in Dream-weaver.
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				Chapter 4: Working with Images

				In This Chapter

				[image: check.png] Making images work for the web

				[image: check.png] Touring the Property inspector

				[image: check.png] Inserting Photoshop files and working with Smart Objects

				[image: check.png] Aligning images and adding space around them

				[image: check.png] Creating backgrounds from images

				[image: check.png] Creating a rollover

				[image: check.png] Inserting a Flash movie on a page

				Placing images that are interesting and informative is one of the most exciting parts of building a web page. In this chapter, you see how to insert and optimize native Photoshop (PSD) files directly in Dreamweaver and how to take care of basic needs such as resizing, cropping, and positioning an image. You also find out how to create interesting backgrounds and create easy rollovers.

				[image: tip.eps]	If you plan to follow any steps in this chapter, you need to create a site or have a practice site already open. Images are much-needed linked assets  on your page — you don’t want to lose track of them in your filing system. If you don’t know how to create a site, read Chapter 3 of this minibook.

				Creating Images for the Web

				Placing images isn’t difficult, but you must consider the formats they’re saved in and their file sizes. (See Book IV, Chapter 10 for details on selecting the correct format and using the Save for Web feature in Photoshop.)

				Putting images on a web page requires planning to make sure that sizes are exactly what you want. You also need to make sure that you don’t prevent a page from loading quickly by having too many images. This is especially true when considering mobile or tablet devices that may be loading a great deal of data over a 3G or 4G network.

				If you look in the lower-right corner of the Document window, you see the page file size and its approximate download time. In Figure 4-1, the page file size is 37k (kilobytes), and the download time is 1 second, based on the assumed connection speed of 56K (kilobits) per second. You can change the download speed by choosing Edit⇒Preferences (Windows) or Dreamweaver⇒Preferences (Mac), selecting the Status Bar category, and clicking the Connection Speed drop-down list.

					

				
					Figure 4-1: Check the Document window for current page size and estimated download time.

				

					[image: 9781118168608-fg060401.eps]

				[image: tip.eps]	The jury is always out when you want to know how fast a page should download, but 5 seconds or less is a good target. Unless you have truly compelling content, you’ll probably lose viewers if they have to wait too long. If your page requires more time, consider distributing its content across several pages or optimizing images and files to reduce file size. If your page links to unnecessary files (for instance, a large JavaScript file that powers a slideshow on a completely different page), consider omitting those links.

				Putting Images on a Page

				Putting images on a web page in Dreamweaver is easier than ever, mostly because of its integration with other Adobe products. You can use menu items, copy and paste, and even drag and drop images on your Dreamweaver page. In the following sections, you not only find out how to place images, but also receive some helpful general tips related to putting graphics on the web.

				Inserting an image

				If you’re preparing images ahead of time, save or move the optimized images into your site folder. You can select an image from anywhere in your directory — it just adds the extra step of copying the image into your site folder.

				After you open a page, you can insert an image by following these steps:

					1.	Click somewhere on the page to position the cursor wherever you want to place the image.

						2.	[image: 9781118168608-ma198.tif] Select the Common category from the drop-down list at the top of the Insert panel and click the Image button or choose Insert⇒Image.

						If Image isn’t the default for your Insert Image button, click and hold the arrow to the right of the button and choose Image from the drop-down list.

						The Select Image Source dialog box appears.

					3.	Navigate to the spot where your image is located and click OK (Windows) or Choose (Mac) to place the selected image.

				[image: tip.eps]		If your images are in your site folder, you can click the Site Root button in the Select Image Source dialog box to navigate there quickly. If an image isn’t in your site folder, an alert box asks whether you want to copy the file there now. (This is recommended.)

					4.	If you’re prompted to copy the image to your site’s root folder, click Yes. When the Copy File As dialog box opens, verify that the name is correct and click Save.

						The Image Tag Accessibility Attributes dialog box requests that you enter alt text. (For more on alt text, see the nearby sidebar, “Gotta have that alt text.”)

					5.	Type a word or three that best describes your image (such as Our Family Photo) in the Alt text field and click OK.

						The image is placed.

				Gotta have that alt text

				You’ve probably seen the term alt text a gazillion times: It’s the text that appears before an image does while a web page is loading. Alt text also appears as a tooltip when you hover the mouse cursor over an image in a web page in certain browsers.

				Alt text is helpful because it tells viewers something about an image before it appears, but it’s also necessary for viewers who have turned off the option to view graphics (which is necessary for certain e-mail applications) or for users with visual impairments who rely on screen-readers. In certain cases, there are strict regulations requiring alt text for any work completed for federal and non-profit websites.

				In addition, alt text is a valuable tool for indexing image content for search engines: Search engines such as Google, Bing, and Yahoo! all use alt text as a key method of indexing images for their respective image search listings.

				To assign or change alt text to an image that has been placed already, type some descriptive copy in the Alt text field in the Property inspector.



				Dragging and dropping an image

				In addition to inserting images from the Insert panel or application menus, you can drag and place images directly from the Files panel to the page. If you’re dragging an image, the cursor follows it while you move it around the document; release the mouse button when the cursor marks the correct spot where you’d like to drop the image.

				If the image is a native Photoshop (PSD) or Fireworks (PNG) file, the Image Optimization dialog box appears, giving you the opportunity to optimize the image before placing it.

				You can also drag and drop an optimized image from your desktop or any other folder into a Dreamweaver page. If an image is not in your site folder, you have the opportunity to copy that image to your site folder when it’s placed.

				[image: tip.eps]	If you’re taking advantage of the Adobe Bridge workflow, you can leave Bridge running and drag images as you need them directly from the Bridge window into your Dreamweaver page. You can access Bridge by choosing File⇒Browse in Bridge.

				Getting to Know the Property Inspector

				Many of the tools you use when working with images are located in the Property inspector. (See Figure 4-2.)

					

				
					Figure 4-2: The Property inspector’s image-editing options.

				

					[image: 9781118168608-fg060402.eps]

				You can choose from these properties when an image is selected:

					[image: check.png] [image: 9781118168608-ma149.tif] Editing the original (in Photoshop): If you want to make a quick change, it shouldn’t have to involve a lot of directory navigation on your operating system. To edit your original image file, select it and click the Edit in Photoshop button on the Property inspector. The image is launched in Photoshop, where you can make changes and save the image again.

				[image: tip.eps]		You can select the default image-editing application for different image file types by choosing Edit⇒Preferences (Windows) or Dreamweaver⇒Preferences (Mac)⇒Files Types/Editors. Photoshop CS6 is the primary editor for almost every image type by default.

				[image: check.png] Edit Image Settings: Choose how you want the image optimized by selecting quality settings here.

						Note: You can optimize images directly from the Property inspector, but this method doesn’t provide quite the same abilities as when you place a native Photoshop or Fireworks file, because the image you’re selecting has already been optimized.

				[image: check.png] Update from Original: If you placed your image from a PSD or Fireworks original, this button becomes active when Dreamweaver detects that you’ve modified and saved the original file. Click this button to update the image on your page with the latest changes from the original. (Pretty handy!)

				[image: check.png] Cropping an image: This feature is sure to become a favorite because you can make cropping decisions right on your Dreamweaver page. Simply click the Crop tool, acknowledge the warning message that you’re editing the image, and then click and drag the handles to the size you want. Press the Enter key and you’re done!

				[image: check.png] Resampling an image: You may have heard that you shouldn’t resize an image placed on a Dreamweaver page because if you were making the image larger, it would become pixilated, and if you were making the image smaller, you were wasting lots of bandwidth downloading the file. Fortunately, you can now use the Resample button on the Property inspector after you resize the image. Just keep in mind that making the image larger still causes some quality issues, so you should reduce the file size before clicking the Resample button. If you need to make an image considerably larger, find the original and optimize it to the proper size.

						To resize an image, you can either click and drag out the lower right handle of the image or type a pixel value in the W (Width) and H (Height) text fields in the Property inspector.

				[image: check.png] Brightness and contrast: If high quality is important to you, open your original image in Photoshop and make tonal corrections with professional digital imaging tools. If volume and quickly getting lots of images and pages posted are important, take advantage of the Brightness and Contrast controls built into Adobe Dreamweaver. Simply click the Brightness and Contrast button in the Property inspector, acknowledge the Dreamweaver dialog box, and adjust the sliders to create the best image.

				[image: check.png] Sharpen: Add crispness to images by applying the Sharpness controls available in Dreamweaver. As with some of the other image-editing features in Dreamweaver, you’re better off using the Unsharp mask filter in Photoshop; in a pinch, this feature is a quick and useful tool to take advantage of. To use the Sharpening feature, click the Sharpen button, acknowledge the warning that you’re changing the image, and use the slider to sharpen the image.

				Placing Photoshop Files

				If you’ve created artwork or prepared images in Photoshop, you can place original PSD files directly in your pages. The Image Optimization window lets you save Photoshop files into web-ready image formats such as GIF, JPEG, and PNG and scale and crop artwork before it’s placed on the page.

				Photoshop Smart Objects

				The ability to work with Photoshop files is useful for most designers who depend on Photoshop as part of their workflow. When you place Photoshop files on a page, Dreamweaver creates a Smart Object, an image that maintains a connection to the original Photoshop file from which it was created.

				The image displays an icon that lets you know whether the original file was updated, and you can apply the changes in the original file to the image in one click.

				To place a Photoshop file in your page, follow these steps:

					1.	Click wherever you want to place the new image and then click the Image button in the Insert panel’s Common category.

					2.	When the Select Image Source dialog box appears, browse and select a Photoshop PSD file and then click Choose/OK to select the image.

						The Image Optimization dialog box appears. This dialog box lets you save your image in the web-friendly GIF, JPEG, or PNG formats, as shown in Figure 4-3.

					

				
					Figure 4-3:  From the Image Optimization dialog box, you can optimize and save a web-ready image from a placed Photoshop file.

					
				

					[image: 9781118168608-fg060403.eps]

					3.	In the Preset drop-down list, select the JPEG High for Maximum Compatibility option.

				
					
				
				[image: tip.eps]	4.	Click OK to save the image.

					5.	When the Save Web Image dialog box appears, navigate to your site’s root folder and click OK/Save to save the image in the appropriate folder (such as your default images folder).

					6.	When the Image Tag Accessibility Attributes dialog box appears, type in a concise, short description for your image (such as Man on Bike).

						The new image is placed and a small icon appears in its upper left corner. This Smart Object indicator shows two green arrows, indicating that the image is up-to-date.

				Select the image you placed in the preceding step list and locate the Original text field in the Property inspector — this field displays the location of the original Photoshop file. To edit the image, you can simply click the Edit in Photoshop button in the center of the Property inspector to open the source file in Photoshop.

				Updating Photoshop Smart Objects

				If you make changes to the original Photoshop file, the image you placed in the page displays a red-and-green arrow icon to let you know that it isn’t up-to-date.

					[image: 9781118168608-ma150.tif]	To update a Smart Object when you see the icon (displayed as a set of circular arrows), shown in Figure 4-4, select the image and click the Update from Original button on the Property inspector to apply the new changes to the placed image.

					

				
					Figure 4-4: The red and green arrows indicate the original file has been modified.

				

					[image: 9781118168608-fg060404.eps]

				[image: warning_bomb.eps]	Moving the original PSD file connected to a page image displays an alert icon on the image and disables the link between the two. Keep original PSD files in a set location and be sure to revise the location of your source file by selecting the image and updating the original in the Property inspector.

				Aligning an Image

				Images and their adjacent text sit on the same baseline as a default, forcing text to run in one line to the right of the image. To control the wrapping of the text around the image, change the alignment of the image by selecting the image and then choosing an option from the Align drop-down list at the bottom of the Property inspector (make sure your Property Inspector is fully expanded).

				The Align drop-down list provides these options:

				[image: check.png] Default: Baseline alignment is used (described in the second Bullet1).

				[image: check.png] Baseline (Default): The bottom of the image aligns with the baseline of the current line of text.

				[image: check.png] Top: The image aligns with the top of the tallest item in the line of text.

				[image: check.png] Middle: The baseline of the current line of text aligns with the middle of the image.

				[image: check.png] Bottom: The bottom of the image aligns with the baseline of the current line of text.

				[image: check.png] Text Top: The image aligns with the top of the tallest text in the line, usually (but not always) the same as ALIGN=top.

				[image: check.png] Absolute Middle: The middle of the current line aligns with the middle of the image.

				[image: check.png] Absolute Bottom: The bottom of the image aligns with the bottom of the current line of text.

				[image: check.png] Left: The image aligns to the left, and text flushes to the right of the image.

				[image: check.png] Right: The image aligns to the right, and text flushes to the left of the image.

				[image: tip.eps]	As an alternative to the Align property, you may also use CSS (Cascading Style Sheets) to align an image relative to text. See Chapter 5 of this minibook for more information on using CSS to format text and page elements.

				Adding Space around the Image

				You may want to add space around an image to keep the text from butting up to it. To create a space around an image, select the image and enter values into the H Space and V Space text fields in the Property inspector. These values add space (in pixels) to the horizontal and vertical sides of the image, respectively.

				[image: tip.eps]	If you want to add space to only one side of the image, CSS (Cascading Style Sheets) provides the ability to add margins to only one side of an image. See Chapter 5 of this minibook for more information on using CSS to format text and page elements.

				In addition, you can open the image in Photoshop and choose Image⇒Canvas Size. In the Canvas Size dialog box that appears, click the middle- left square in the Anchor section and add a value in pixels to the total  image size. Click the middle-right square to add the size to the left side  of the image.

				Using an Image as a Background

				Creating backgrounds for web pages is fun and can be pursued in more ways than most people would imagine. You can create a repeating pattern with a single small image, create a watermark, or use a large image to fill an entire background. As a default, an HTML background repeats the selected image until it fills the screen. In conjunction with CSS properties, you can control or eliminate repeating behavior and even set precise positioning for a single background image.

				If you’re filling a background with a pattern, be sure to create a pattern image that has no discernable edges. 

				To use to your advantage the default, repeated tiling for a background image, follow these steps:

					1.	In Photoshop, choose File⇒New to create a new image.

					2.	In the New dialog box that appears, create an image that’s much wider than it is high, choose RGB, choose 72 dpi, and then click OK.

						For example, enter 1000 in the Width text field and 20 in the Height text field.

					3.	Select a foreground and background color to create a blend; then use the Gradient tool to Shift+drag from the top to the bottom of the image area to create a gradient fill.

					4.	Choose File⇒Save for Web, save the image as a JPEG file in your site’s web content folder, and then close the image.

						See Book IV, Chapter 10 for more about the Save for Web feature.

					5.	In Dreamweaver, choose Modify⇒Page Properties or click the Page Properties button in the Property inspector to place the image as a background image on your web page.

				[image: tip.eps]		If the Page Properties button isn’t visible, click the page — be sure not to select another element, such as an image.

						The Page Properties dialog box appears. (See Figure 4-5.)

					

				
					Figure 4-5: Modify global page properties, such as font and background image, from the Page Properties dialog box.

				

					[image: 9781118168608-fg060405.tif]

					6.	In the Page Properties dialog box, click the Browse button to the right of the background image. In the window that appears, navigate to the location of your saved background image, and then click OK. 

					7.	Back in the Page Properties dialog box, click OK.

						The image appears in the background, repeating and creating a cool background gradient across the page!

				Depending on the size and resolution of a user’s monitor, your background image may be forced to repeat. Repeating a background image can yield some creative results, as shown in Figure 4-6.

					

				
					Figure 4-6: An image set as a background repeats horizontally and vertically by default.

				

					[image: 9781118168608-fg060406.tif]

				
					
				
				[image: technicalstuff.eps]	In certain cases, you may not see your background until you click the Preview/Debug in Browser button and preview the page in your default browser.

				Creating Rollovers

				In Dreamweaver, you can insert image objects, including image placeholders, rollover images (images that change when a viewer rolls the mouse over the image), navigation bars, and Fireworks HTML. You access these image objects by choosing Insert⇒Image Objects.

				To create a rollover image, follow these steps:

					1.	Create the images to be used as the rollover.

						You can generate these images in Fireworks, Illustrator, Photoshop, or any other application capable of saving images optimized for the web. For best results, create images that are the exact same width and height.

						2.	[image: 9781118168608-ma099.tif] Place the cursor on the page wherever you want the rollover to appear and choose Insert⇒Image Objects⇒Rollover Image or click the Rollover Image button in the Insert panel.

						The Insert Rollover Image dialog box, shown in Figure 4-7, appears.

					

				
					Figure 4-7: The Insert Rollover Image dialog box.

				

					[image: 9781118168608-fg060407.eps]

					3.	Type an image name without spaces in the Image Name text field.

						This name is used in the script creating the rollover.

					4.	Click the Browse buttons to the right of the Original Image and Rollover Image text fields to locate the image that you want to appear as a default on the page and the image that appears only when someone hovers the mouse pointer over the image.

						Figure 4-8 shows an example of original and rollover images.

					

				
					Figure 4-8:  Image rollovers are made easy in Dream-weaver.

				

					[image: 9781118168608-fg060408.eps]

					5.	Leave the Preload Rollover Image check box selected.

						This option downloads the rollover image when the page is downloaded to avoid delays in rollovers.

					6.	Type appropriately descriptive alt text in the Alt text field.

					7.	In the When Clicked, Go to URL text field, tell Dreamweaver where viewers are directed when they click your rollover image.

						You can either click the Browse button to locate another page in your site or enter a URL. Note: If you are linking to a different website, you need to include the http:// prefix at the beginning of the URL. If you leave this blank, Dreamweaver will add a dead link (#) automatically.

					8.	Click OK.

						The rollover image is created on the page.

					9.	To preview the new rollover image, choose File⇒Preview in Browser or click the Live View button on the Document toolbar.

				[image: tip.eps]	If you don’t yet have a real link to use for a button or hyperlink, you can enter a pound sign (#) to create a dead link. The link or button appears clickable but doesn’t go anywhere when clicked. This option is better than pressing the space bar to create an empty space as a link, because that link will display a Page Not Found error when clicked.

				Inserting Flash Content

				Dreamweaver makes it easy to enhance web pages by allowing you to insert interactive content such as Flash (SWF) and Flash Video (F4V/FLV).

				[image: remember.eps]	Think carefully about the placement of your Flash content because many devices (namely those running the Apple iOS) don’t play Flash content. However, as of this writing, a number of Android and Blackberry devices (such as the Galaxy Tablet and Playbook, respectively) still support Flash-based content. Consider providing alternate or supplemental content for non-Flash devices, or using a JavaScript or CSS-based animation behavior, if possible.

				Follow these steps to place a Flash file on your Dreamweaver page:

					1.	Put the cursor on the page wherever you want to insert the Flash file.

					2.	Choose Insert⇒Media⇒SWF.

						The Select SWF dialog box appears.

					3.	Navigate to the SWF file that you want to place and click OK (Windows) or Choose (Mac) to select the file.

					4.	In the Object Tag Accessibility Attributes dialog box, type a descriptive title for the movie in the Title field and click OK.

						The Flash file is placed on the page.

					5.	On the Property inspector, click the Play button to preview your new Flash movie.

						You can also adjust settings for your movie, as shown in Figure 4-9.

					

				
					Figure 4-9: Use the Property inspector to adjust and preview Flash movies.
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				Chapter 5: Adding and  Formatting Text

				In This Chapter

				[image: check.png] Adding text to a page

				[image: check.png] Choosing and editing fonts

				[image: check.png] Using the Property inspector to style text

				[image: check.png] Understanding CSS

				[image: check.png] Creating an external style sheet

				Adding text to a web page requires more than just typing on the page. You must carefully plan your web pages so that search engines (and viewers) can easily find relevant content on your website. In this chapter, you read about the fundamentals of text formatting for web pages, from the basic principles of choosing a font size and font family to spell checking text and implementing Cascading Style Sheets (CSS).

				The various menus and panels in Dreamweaver enable you to assign type properties quickly and to update several instances in a few easy steps with CSS. From a content perspective, when you add text to your pages, make it relevant to and descriptive of your site’s business and purpose. This strategy makes your page more relevant to search engines and viewers.

				[image: technicalstuff.eps]	Text formatting in CS6 can be accomplished in two ways: by adding special HTML tags (such as those to bold or italicize text) or by marrying text to CSS rules (styles), for color, size, font family, or line spacing. Note that in certain cases HTML tags and CSS properties can do the same thing; however, you discover later in this chapter why you should choose one method over another.

				Adding Text

				To add text to your web page, simply click the page wherever you want the text to appear; an insertion point appears where you can start typing. You can add text right to the page and inside almost any page element (such as a div or table).

				Formatting text

				Formatting text in Dreamweaver can be as simple as formatting text in any word processing application or even applications such as Illustrator and InDesign. By using the Property inspector or Insert panel, you can easily apply basic font attributes, such as color, typeface, size, and alignment options. Clicking the Text category of the Insert panel gives you several different HTML text tags to apply to selected text. (See Figure 5-1.)

					

				
					Figure 5-1: You can use the Text category of the Insert panel to apply basic text formatting with HTML tags.

				

					[image: 9781118168608-fg060501.eps]

				Many options in the Text category are apparent, but here’s a breakdown of some text tags that may be unfamiliar to you. To use these tags, simply select the text that you want the tag to be applied to and then click the tag on the Insert panel. Here’s a description of a few options on this panel:

				[image: check.png] Strong: Choosing this option bolds the selected text. Note that this does the exact same thing that the Bold button does, applying the <strong> tag around selected text.

				[image: check.png] Emphasis: Choose this option to indicate emphasis; it looks like italic. Note that this applies the <em> tag, identical to the I button.

				[image: tip.eps]		For several versions now, Dreamweaver has favored the semantically friendly <strong> and <em> tags over <b> and <i>. Although both methods bold and italicize text, <strong> and <em> are used in almost all cases, even when you click the B and I buttons. (See Figure 5-2.)However, the current draft of the HTML5 specification re-introduces the use of <b> and <i> with new semantic meaning. If you need to place these tags specifically, you either have to do so by hand or by choosing Insert⇒Tag⇒HTML Tags⇒Formatting and Layout⇒b.

					

				
					Figure 5-2: A selection of text with the I or em button applied; both produce the <em> tag that instructs the browser to italicize text.

				

					[image: 9781118168608-fg060502.eps]

				[image: check.png] h1/h2/h3: These heading tags create three heading levels; h1 is the largest.

				[image: check.png] UL (unordered list): This setting creates a Bullet1ed list from the selected text.

				[image: check.png] OL (ordered list): Use this option to create an ordered (numbered) list from the selected text.

				[image: check.png] DL (definition list): The definition list creates a structured, nonbulleted list best suited for term and definition style formatting.

				[image: tip.eps]	When you press the Enter or Return key, a <p> tag is created automatically in the HTML source code. This tag may create more space than you like between lines and create new list items. Pressing Shift+Enter (Windows) or Shift+Return (Mac) creates a <br> tag, which is essentially a line break or soft return. See Figure 5-3.

				Using the Property inspector to style text

				Use the Property inspector, shown in Figure 5-4, to apply HTML tags and build CSS classes to format text color, face, size, and other characteristics. The Property inspector is divided into two views: HTML and CSS. You can toggle them by using the buttons on the left side of the panel.

					

				
					Figure 5-3:  A new paragraph (hard return) and line break (soft return).

				

					[image: 9781118168608-fg060503.eps]

					

				
					Figure 5-4: Use the CSS view of the Property inspector to apply or change text attributes such as color and font.

				

					[image: 9781118168608-fg060504.eps]

				Here’s what all the buttons on the Property inspector mean:

				[image: check.png] Format (HTML): Use the Format drop-down list to apply HTML tags that format an entire paragraph, including heading tags (Heading 1 through Heading 6) that are generally applied to headers and titles, the paragraph tag, and the preformatted text tag. You can easily fine-tune each of these tags’ attributes (color, size, and font family, for example) later by using CSS.

						Note that Heading 1 is the largest format size (on average, 24-point text), and Heading 6 is the smallest. These headings should be used carefully to apply semantic structure to your document, where text contained in Heading 1 should be treated as categorically higher than text in Heading 2 or Heading 3. For example, the name of your company might be formatted with the Heading 1 tag, and the service categories arranged below it might be formatted using Heading 2 tags.

						The last choice in the Format drop-down list is Preformatted. Sometimes you want the browser to display text exactly the way you composed it — with indents, line breaks, and extra spaces. You can line up text this way if you choose Preformatted; it’s not pretty, but for down-and-dirty lists and columns, it can work well.

				[image: check.png] ID (HTML): This setting applies an ID style to an element. IDs can be associated with CSS styles to apply unique formatting to this item (for instance, positioning information for a div).

				[image: check.png] Class (HTML): This drop-down list applies an existing CSS class style to a selection on the page. Class styles can apply the same formatting to multiple items on a page, and can be created with the Property inspector (discussed later in this chapter) or directly from the CSS styles panel. 

				[image: check.png] Link (HTML): Type a hyperlink (such as http://www.wiley.com) or click the folder icon to browse and link to another page within your website. The selected text becomes linked. (Preview your page in a browser or enable Live view to see it work.)

				[image: check.png] Target (HTML): Choose where the linked target will appear. (You can read about targets in Chapter 6 of this minibook.)

				[image: check.png] Bold (HTML/CSS): Bold selected text. 

				[image: check.png] Italic (HTML/CSS): Italicize selected text.

				[image: check.png] Alignment (CSS): You can click the alignment buttons on the toolbar to apply left, center, and right alignment to a paragraph. To revert to the default left alignment, click the selected alignment button again.

				[image: check.png] Unordered List (HTML): Creates a Bullet1ed list from selected items. As you advance in the use of Cascading Style Sheets, you can apply many more attributes to lists, including customizing the Bullet1s.

				[image: check.png] Ordered List (HTML): Creates a numbered list from selected items. 

				[image: tip.eps]		Every time you press the Enter (Windows) or Return (Mac) key within an unordered or ordered list, a new list item is created. To force text within a list item to another line without adding a new list item, press Shift+Enter (Windows) or Shift+Return (Mac).

				[image: check.png] Text Outdent (HTML): Undo pressing the Indent with the Text Outdent button. This option removes the <blockquote> tag that the Text Indent button creates.

				[image: check.png] Text Indent (HTML): Use this option to indent text. Simply put the cursor in the paragraph of text that you want to indent and press the Text Indent button. A <blockquote> tag is applied. You can apply this tag multiple times to a paragraph to indent it even further.

				[image: check.png] Targeted Rule (CSS): Modify an existing CSS rule or create a new one. This drop-down list makes it clear whether you are creating a new rule or modifying an existing one in the Property inspector.

				[image: check.png] Edit Rule / CSS Panel buttons (CSS): For the rule shown in the Targeted Rule drop-down list, you can either edit the properties and values for that rule in the CSS Rule Definition dialog box or view it in the CSS Styles panel on the right, respectively.

				[image: check.png] Font (CSS): Use this drop-down list to select a font family. The font is the typeface you choose for displaying text. The lack of typeface selection isn’t a restriction in Dreamweaver, but rather in web design as a whole. Keep in mind that what font the viewer sees on your web page is based on the availability of the fonts on that user’s computer. For this reason, font sets are limited to basic system fonts that are installed on most every computer, regardless of operating system.

				[image: tip.eps]		The viewer may not have fonts that you load in your font sets, so try to stick to such common typefaces as the ones already included in the existing Dreamweaver font sets.

				[image: check.png] Size (CSS): Using the Font Size drop-down list, you can apply a fixed font size from 9 to 36 (pixels) or enter a value by entering it directly. You can use the relative sizes shown (x-small and small, for example), which resize the font relatively larger or smaller according to the user’s browser font size preferences. If you don’t change the font size, it defaults to 12 pixels (px). By default, the unit of measurement is set to pixels, but you can use the neighboring drop-down list to set other units of measurement, including points, picas, ems, and more. Pixels, ems, or percentage-based values are recommended for web use.

				[image: warning_bomb.eps]		Keep in mind that the user can set browser preferences to override the size settings you’ve chosen, especially for em or percentage-based font size values. On the other hand, be careful about where and when you use fixed-size fonts (pixels), because a user may have difficulty reading a small font and be unable to override it if necessary.

				[image: check.png] Color (CSS): Assign a color to your selection by clicking the swatch icon and selecting a swatch from the panel that appears. Colors are represented in HTML and CSS by hexadecimal codes, 6-character codes that represent the RGB (Red, Green, Blue) values which form that color. This code is shown at the top of the Swatches panel whenever you select a color.

				Spell-checking your text

				You can spell-check only the file you have open or multiple files by choosing Commands⇒Check Spelling. From the Check Spelling dialog box, shown in Figure 5-5, you can choose to add words to your personal dictionary, ignore words, or change the spelling of words.

				Assigning and editing fonts

				When a viewer opens a page referencing a font set, the text is displayed using the first available font in the font family. The user must have that same font installed on their machine in order for it to display as intended. If the first font face on the list isn’t available, the next font face is referenced, continuing down the list in the font family until a font in the font set is found on the viewer’s computer. If you choose Edit Font List from the Font drop-down list, the Edit Font List dialog box appears. (See the figure.)

				Click the existing font lists to see which fonts are included in each set. You can add new fonts to the sets by clicking the double arrow pointing from the Available Fonts panel into the Chosen Fonts panel. Delete a font from an existing font list by clicking the font in the Chosen Fonts panel and clicking the double arrow pointing toward the Available Fonts panel. You can even create an entirely new list yourself by clicking the plus sign (+) in the upper-left corner of the Edit Font List dialog box.

				[image: 9781118168608-sb060501.eps]



					

				
					Figure 5-5: Make a habit of checking spelling on your pages.

				

					[image: 9781118168608-fg060505.eps]

				Understanding Cascading Style Sheets

				Cascading Style Sheets (CSS) is the standard method for styling web pages. Think of CSS as a series of formatting instructions that works hand in hand with HTML to apply visual properties (including layout and positioning) to text and other elements on a page. The Dreamweaver workspace allows you to assign properties to type and other page elements quickly and update several instances in a few easy steps. 

				Although some HTML tags and attributes offer some formatting functionality (such as bold, italic, and paragraph alignment), in modern web design it’s standard practice to leave all such formatting up to CSS and to use HTML for content and semantic structure only. Generally, you create a CSS rule (sometimes referred to as a style) and apply it to an element on the page, such as a paragraph or table cell. In Figure 5-6, you can see how CSS rules are created to format certain types of HTML elements, or elements on a page that match a specific assigned ID.

				[image: remember.eps]	Although many CSS properties and features are consistent across most modern browser versions, some older browsers may not provide consistent support for CSS. Always preview pages in multiple browsers (the Adobe BrowserLab lets you do this easily without the need to install multiple browsers) or use the Check Browser Compatibility button on the Document toolbar to point out any potential CSS incompatibilities. This is especially true if you’re using newer CSS3 properties.

				In this chapter (and in Chapter 8), we offer the quick-and-dirty course on CSS, but if you’re interested in finding out more, check out HTML, XHTML & CSS For Dummies by Ed Tittel and Jeff Noble.

				[image: tip.eps]	Dreamweaver offers several CSS starter pages that can get you up and running quickly. (See Figure 5-7.) Find the CSS starter pages by choosing File⇒New⇒Blank Page⇒HTML Template. (See Figure 5-7.)

					

				
					Figure 5-6: A peek at a typical style sheet, as well as the CSS language itself.

				

					[image: 9781118168608-fg060506.tif]

				Introducing CSS3

				You’ve likely heard a lot about CSS3, and for good reason. The newest proposed specification of CSS includes some amazing new capabilities that give both designers and developers the ability to do more with their web pages. With the addition of gradients, native CSS animations, rounded corners, and drop shadows, CSS can do a lot without the need for JavaScript or workarounds using images.

				As of this writing, the CSS3 spec is not finalized; however, modern browser versions such as Firefox 7+, Safari 5, Chrome, and Internet Explorer 9 have already included support for many popular CSS3 features. The Dreamweaver CSS Rules panel and other views have already added support for many common CSS3 properties as well.



					

				
					Figure 5-7: Get up and running quickly with CSS starter pages.

				

					[image: 9781118168608-fg060507.eps]

				Using CSS for text

				Using Cascading Style Sheets in Dreamweaver is extremely intuitive; simply select some text on your page and begin styling your selection directly in the Property inspector CSS view by selecting properties for color, size, typeface, and more.

				Assigning formatting to a selection opens the New CSS Rule dialog box, allowing you to save choices you’ve made into a new CSS rule (or style). You can choose a name, selector type, and location for the new rule.

				Several types of selectors determine which style properties should be applied and where. When Dreamweaver finds a selector, it applies the properties and values you’ve chosen. In many cases, you can make formatting choices once and reapply them repeatedly in a single click!

				You can find out how to use CSS to create entire page layouts in Chapter 8 of this minibook.

				Creating a new tag style (type selector)

				Creating a tag style (or type selector) is a simple and safe route for new users to understand CSS because it targets existing HTML tags, such as P, H1, and H2. Using existing tags on your page, you can choose to apply automatic formatting wherever certain HTML tags are used. For instance, you can make any text inside of an <h1> (Heading 1) <strong> tag automatically bold, 36 pixels, and red.

				To create a tag style with the Property inspector, follow these steps:

					1.	Open an HTML page that contains text.

					2.	On the Property inspector, click the HTML button on the left side of the panel to display the Property inspector in HTML view.

					3.	Select a line of text and bold it by clicking the B button located in the Property inspector.

					4.	Switch to CSS view of the Property inspector by clicking the CSS button on the far left side of the panel.

						The goal is to assign definitive style information to the tag that bolds text, so any bold text on the page also appears red.

					5.	Leave the bolded text selected, and in the Property Inspector select <New CSS Rule> from the Targeted Rule drop-down list.

					6.	With the text still selected, use the color selector on the right side of the Property inspector (located below the B and I buttons) to select a red color to apply to the selected, bold text.

						The New CSS Rule dialog box appears, as shown in Figure 5-8.

					7.	From the Selector Type drop-down list, choose Tag (Redefines an HTML Element); choose Strong from the Selector Name drop-down list; choose (This Document Only) from the Rule Definition drop-down list.

						The selector type determines how the formatting will be applied to a selected HTML tag on the page. Tag styles automatically are applied wherever that element appears on the page.

					8.	Click OK to create the new tag style and close the panel.

						Now, every time you apply the <strong> tag to make bold text (using the B button or other shortcuts), that bold text also appears red. You’ve created a tag style that determines how bold text appears any time it appears in a document.

					

				
					Figure 5-8: The New CSS Rule dialog box.

				

					[image: 9781118168608-fg060508.eps]

				[image: tip.eps]	You can further refine this new tag style by selecting any bold text and continuing to modify text properties from the Property inspector, as shown in Figure 5-9.

					

				
					Figure 5-9: Further fine-tune your tag style by modifying properties in the Property inspector.

				

					[image: 9781118168608-fg060509.eps]

				If you’d like to edit and fine-tune the rule you’ve created, you can click the Edit Rule button below the Targeted Rule drop-down list to open the CSS Rule Definition dialog box. This dialog box opens by default to the Type category, where you can modify type-related properties. Some common type properties you can find in this category are as follows:

				[image: check.png] Font family: You can apply a font family by using the Font drop-down list. Generally these are font sets with multiple fonts specified.

				[image: check.png] Font size: Enter a text size and then, with the Unit drop-down list to the right of the size, enter it in pixels, points, inches, centimeters, and other units of measurement. For web use, it’s recommended to stick with pixels, ems, or percentage-based values.

				[image: check.png] Line height: By assigning a size in any unit, you can define the space between lines of text. If you come from the typesetting or design world, it works much like leading.

				[image: check.png] Text decoration: Text decoration refers to text modifiers such as underlines and strikethroughs. And while you may be tempted, avoid using Blink. The effect will give your users a headache.

				[image: tip.eps]		Don’t like underlines under links? Create a tag style for the <a> tag (this HTML tag is the one used to create a link) and select None in the Decoration drop-down list to remove the underline that appears under hyperlinks by default.

				[image: check.png] Font-Weight: Make text lighter or heavier with this drop-down list. Just so you know, a value of 700 is the typical boldness of bold text; any heavier is bolder than bold.

				[image: check.png] Font-Variant: Use this drop-down list to choose small caps.

				[image: tip.eps]		You may be wondering why Normal is a choice in the Style drop-down list. It’s because you may have defined small caps, for example, as the variant for all instances of the <strong> tag but then decided that on one page you want to override that attribute. By creating a style defined in the document only with Normal selected in variant, you can override the style (small caps) definition on the external style sheet.

				[image: check.png] Text-Transform: Choose from Capitalize, Uppercase, Lowercase, or None.

				[image: check.png] Color: Assign a color to your selector by clicking the arrow in the lower-right corner of the Color definition swatch or type a number in the Color text box.

				When you’re finished fine-tuning your tag style, click Apply at the bottom of the dialog box to see your changes. You can also click OK to apply your changes and exit the dialog box.

				What is a style sheet?

				The term style sheet refers to a collection of CSS rules. Style sheets can be defined within a single page using the <style> tag, or externally in a plain text file with a .css extension. A page can have multiple style sheets applied, although depending on the order and rules you’ve defined, one may override or complement another. If you have not defined an external style sheet, most of your CSS rules you’ve created so far have likely been written in to the page itself. Switch to Code view and look for the <style> tag at the top of your page to see what was created, as shown in Figure 5-10. Embedded style sheets such as the one in the figure appear within <style> tags at the top of the page.

					

				
					Figure 5-10: A typical style sheet, which contains multiple CSS rules. 

				

					[image: 9781118168608-fg060510.tif]

				External style sheets are generally considered a better practice as they can be shared across multiple pages, reducing duplication and work.

				Creating a new class selector

				For more styling control over pages, you can create class selectors, which are named styles that you can apply to a number of elements across a page. Unlike styles, you can name a class style just about anything you want and apply it selectively to several items.

				If you choose properties that work on a variety of elements, you can get a lot of mileage from a single class selector in many places throughout your site. Essentially, class styles are like creating your own character or paragraph styles, in applications such as Word or InDesign, and are just as easy to update.

				This time, you can also make your new rule available to more than one page in your site by defining a new external style sheet. This method saves your rules in an external file that can be attached to several pages at a time.

				Block versus inline elements

				You may find that when you assign certain properties, you see varying results because some properties you select affect only block elements as compared to inline elements. Block-level elements apply to elements that take up their own horizontal space on a page, such as an entire paragraph, a table or an unordered list. If you create a P element style and change the line spacing, the space takes effect within the block-level element.

				An inline element is one that flows with other elements on the page or within text, such as the <span>, <a>, and <strong> tags. If you choose to apply line spacing to the b element, the leading in paragraphs that contain the <strong> tag aren’t affected.

				You’ll eventually figure out which properties work with which tags. Just keep this point in mind so that you’re not dumbfounded when some properties don’t work as expected!



				Follow these steps to create a class style from the CSS Styles panel:

					1.	Locate the CSS panel, off to the right, and click the New CSS Rule button at the bottom or choose Format⇒CSS Styles⇒New.

						The New CSS Rule dialog box appears. (Refer to Figure 5-8.)

					2.	From the Selector Type drop-down list, select Class (Can Apply to Any HTML Element).

					3.	In the Selector Name text box, enter a name for your new class.

						You can enter any name you want, but make sure that it has no spaces and is descriptive of how you’ll use it. Reallycoolstyle is a bad name; headlinestyle is a better name. Dreamweaver inserts the period at the front of the style name because it’s a necessary naming convention.

					4.	From the Rule Definition drop-down list at the bottom, select (New Stylesheet File).

					5.	Click OK.

						The Save Style Sheet File As dialog box appears. Locate your site folder. If you haven’t defined a site, locate a folder where you’ll keep all relevant information, such as image files and pages for your site.

					6.	Enter a name for the style sheet.

						Enter an appropriate name, such as styles.css or main.css if it’s the main set of styles you’re creating for your website. (Dreamweaver will add the mandatory .css extension at the end of the filename.)

					7.	Leave the URL as is and the Relative To drop-down list set to Document.

					8.	Click Save.

						You’ve created a new .css file, or an external stylesheet. The CSS Rule Definition dialog box appears.

						In this dialog box, you can create the set of attributes that you want included in the CSS definition for the style you’re creating. As you might notice, this dialog box is the same one you work with when you edit an existing CSS style. (See the previous section.) The difference with the tag and class styles lies only in the fact that you must choose to apply a class style to a selected element using the Property inspector for it to take effect (via the Class or Style drop-down lists).

					9.	Apply a font, size, style, line height (leading), color, and any other attributes that you’d like to include.

					10.	After you select attributes for your class style, click OK to close the dialog box and return to your page.

				Now you can apply the CSS class style to some text. When applying a class style, you can choose to apply it to only some text or to an entire paragraph of text. Follow these steps to apply a class style to an entire paragraph:

					1.	Place the cursor in a paragraph of text or click and drag to select a line of text.

					2.	If the Property inspector isn’t visible, choose Window⇒Properties. Click the HTML button on the left side of the Property inspector to toggle to HTML view.

					3.	From the Class drop-down list in the Property inspector, select a new style, as shown in Figure 5-11.

						The new style is applied to the selection.

					

				
					Figure 5-11:  Apply a class style to a selected piece of text by using the Class drop-down list on the Property inspector.

				

					[image: 9781118168608-fg060511.tif]

				

			

			
				
						
					
			
			
			
		

	
		
			
				Chapter 6: Linking It Together

				In This Chapter

				[image: check.png] Creating hyperlinks

				[image: check.png] Discovering how to use anchors

				[image: check.png] Linking to external documents, e-mail messages, and PDF files

				[image: check.png] Making sure that your links work

				Links are a major and necessary mechanism of any website. You must incorporate links on your website; this way, viewers can easily navigate between pages and areas of your site to find the information they’re seeking. In this chapter, we show you how to add links easily and effectively in Dreamweaver.

				The Basics of Linking

				Links, or hyperlinks are navigational aids; viewers click links to visit other web pages, to download a file, to open an e-mail address, or jump to a specific spot on a web page (known more accurately as an anchor). As you create the first link from one of your web pages to another, you’ve essentially created a  website — it may be a small site, but it’s a start. While you’re still in the small site stage, here are a couple of recommendations to keep in mind as you add more pages and create more links, making your site even bigger:

				[image: check.png] Two kinds of links exist:

					•	Internal links connect viewers to other parts of your website.

					•	External links connect viewers to other pages or content outside your site.

						We show you how to create both kinds of links in this chapter. A link almost always points to a URL (Uniform Resource Locator), which  represents a page or file on your site or on a completely different site altogether.

				[image: check.png] Before you start working with any pages to be linked, make sure that you’ve created a Dreamweaver site (see Chapter 3 of this minibook for details); the site helps you locate local files to link to, and later you can check and validate links between pages in your site.

				Creating Internal Links

				Internal links, an essential part of any user-friendly site, help viewers easily and quickly navigate to other pages on your website.

				[image: warning_bomb.eps]	If you need to change page and filenames after they’ve been linked somewhere, do so only within the Files panel in Dreamweaver. Otherwise, you end up with broken links. Take a look at the “Resolving Link Errors” section, later in this chapter, to find out how to change the names of linked files without breaking the links.

				You can create a link from text or an image (such as a button graphic). The following sections outline several methods you can use for creating links.

				Using the Hyperlink dialog box to create a link

				To create a hyperlink with text as the link, you can use the Hyperlink command:

						1.	[image: 9781118168608-ma200.tif] Select some text on the page and make sure that the Common category of the Insert panel is forward. Click the Hyperlink button.

						You can also choose Insert⇒Hyperlink. The Hyperlink dialog box appears with your selected text already entered in the Text field, as shown in Figure 6-1. 

					

				
					Figure 6-1: Create a link from selected text with the Hyperlink button.

				

					[image: 9781118168608-fg060601.eps]

					2.	You can either enter a URL manually (such as the location of a page or file) or click the Browse folder icon to the right of the Link drop-down list and browse to the file you want to link to within your site’s root folder.

						You can also enter an external link here; see how to link to external locations a little later, in the “Linking to Pages and Files Outside Your Website” section.

					3.	Choose how the page will appear when the user clicks the link:

					•	If you want the page to appear in the same Document window, essentially replacing the existing page, leave the Target drop-down list blank or choose _self. (This is the recommended behavior.)

					•	If you want to force the link to create its own new browser window, choose _blank.

					4.	Click OK to create your link.

						The selected text should appear with an underline or another visual indicator to let you know it’s now a hyperlink.

				Using the Property inspector to create a link

				You can also link text and images from the Property inspector HTML view.

					1.	Select text or an image on your page that you want to link up.

					2.	Click the HTML button on the left side of the Property inspector to switch to HTML view and then type the link location into the Link  text box.

					3.	To locate the destination file, click the folder icon (Browse) to the right of the Point to File button.

						The Select File dialog box opens.

					4.	Navigate to the folder containing the file you want to link to, select it, and click OK (Windows) or Choose (Mac).

				Creating hyperlinks with Point to File

				If you’re in a hurry and want a more visual way of linking up your pages, you’ll love this quick method for creating hyperlinks:

					1.	Select the text you want to use as a link on your page.

						2.	[image: 9781118168608-ma201.tif] In the Property inspector, find the Point to File icon next to the Link field; click and drag the icon and pull it toward the Files panel — an arrow follows your movement.

					3.	Move the arrow pointer over the file in the Files panel that you want to link to and release the mouse button. (See Figure 6-2.)

						Voilà! The connection is made, the filename appears in the Hyperlink text box, and the selection is now hyperlinked to your selected file.

					

				
					Figure 6-2: Creating a hyperlink from the Property inspector using Point to File.

				

					[image: 9781118168608-fg060602.tif]

				Creating Anchors

				An anchor is a link to a specific section of a page, on either the same page as the link or another page entirely. Anchors are especially handy for long pages that have a lot of text. You’ve probably seen and used anchors, for example, when clicking a Back to Top button or when navigating within a long page using a table of contents. Anchors are extremely helpful to viewers and should be implemented when possible to enhance usability.

				To create an anchor in Dreamweaver, follow these steps:

					1.	Insert the cursor in a location on the page that you want to link to.

						The anchor may be placed before a line of text or on its own line.

					2.	Click the Named Anchor button in the Common category of the Insert panel.

						The Named Anchor dialog box, shown in Figure 6-3, appears.

				[image: tip.eps]		You can avoid clicking the Anchor button by using the keyboard shortcut Ctrl+Alt+A (Windows) or [image: maccmd]+Option+A (Mac).

					3.	Type a short name that’s relevant to the content or location on the page (for example, TopOfPage or headline).

						In Figure 6-3, you see that the text TopOfPage was entered because this anchor returns the viewer to the top of the page. Anchors are case sensitive, so keep this in mind when deciding on a name.

					4.	Click OK.

						The new anchor appears in your page, as shown in Figure 6-3.

					

				
					Figure 6-3: Top: Create the anchor name in the Named Anchor dialog box. Bottom: The completed anchor shown in Design view.

				

					[image: 9781118168608-fg060603.eps]

				You’ve created the anchor but have no links directed to it yet. You can define an anchor as a link manually or by using the Point to File tool, as described in the following two sections.

				Linking to an anchor manually

				Here’s one reason why a short, appropriate name is useful for anchors: You may end up having to type it! By manually linking to an anchor, you can link within the page you’re working on or direct the link to an anchor on a completely different page.

				You can manually define an anchor as a link by following these steps:

					1.	If the Property inspector isn’t open, choose Window⇒Properties.

					2.	Select the text that you want to link to your new named anchor and click the Hyperlink button located on the Insert panel.

					3.	In the Hyperlink dialog box, locate the Link field and click the drop-down list directly next to it.

						Your named anchor appears as a selection, as shown in Figure 6-4.

					4.	Select your anchor to apply it and then click OK.

					

				
					Figure 6-4: Select the anchor name in the Hyperlink dialog box.

				

					[image: 9781118168608-fg060604.eps]

				You can also link to a page and add an anchor reference to it from the Property inspector. For example, if you want to link to this spot from another page, you select an element on that page and, in the Link text box (in HTML view), type the name of the page, a pound sign (#), and the name of the anchor — for example, birds.html#canary. This action directs the browser to the birds page and then to the canary anchor within that page.

				Frequently, you see anchors separated by the pipe sign (|). You can create this type character by pressing Shift+\. The backslash key is directly above the Enter (Windows) or Return (Mac) key.

				Linking to anchors with Point to File

				You can use the same cool Point to File icon you used earlier to create hyperlinks for creating anchors. The Point to File icon in the Property inspector can also target anchors you’ve created on your page. Follow these steps:

					1.	Select the text you want to use as a link on your page.

						2.	[image: 9781118168608-ma201.tif] In the Property inspector, find the Point to File icon located next to the Link field, click and drag over the icon, and release the arrow directly over an anchor icon on your page.

						The text is now linked to the anchor, and the anchor’s name appears in the Property inspector’s Link text field preceded by a pound sign (such as #canary).

				Linking to Pages and Files Outside Your Website

				You can link to pages anywhere, in your site or out. An internal link (sometimes referred to as a relative URL) is one within your site. The link to another page in your site may appear as contact.html in the Link text box in the Property inspector. But if you’re directing people to a contact page posted on another site, you have a link that looks more like this: http://www.aquent.com/contact. By typing the http:// and the address of the external link (sometimes referred to as an absolute URL) in the Property inspector, you’re essentially directing the browser to a site and page on the Internet that’s not part of your site.

				[image: technicalstuff.eps]	You must include the http:// prefix in front of a web address. Omitting this prefix results in a Page Not Found error in your browser because it may interpret www.dummies.com, for example, as a local filename rather than as an outside web address.

				Linking to E-Mail

				Linking to an e-mail address opens the viewer’s default mail program (for example, Outlook for Mac Mail) with a new mail message that’s pre-addressed to the e-mail you specify in the link (as long as the viewer has set up an e-mail program on the machine, of course).

				Linking to an e-mail address is easy and extremely helpful if you want to give users an easy way to contact you through your website. To create an e-mail link, follow these steps:

					1.	Select the element that will be the link to an e-mail.

						The element can be either text or an image.

					2.	In the Property inspector, locate the Link text box, type mailto:<address>, and then press Enter or Return.

						For example, type mailto:info@agitraining.com and press the Enter or Return key. The mailto: directive tells the browser that the link is to an e-mail address so that the default e-mail application on the user’s computer opens with a new, preaddressed message.

				Linking to a PDF File

				To link to a PDF file instead of a web page, you link to the name and location of the PDF file. If you link to a PDF file and the Acrobat PDF plug-in is loaded in the viewer’s browser, the PDF is opened in the browser window. If the viewer doesn’t have the Acrobat plug-in (free from www.adobe.com), the browser prompts the viewer to save the file to the computer. You can then view this file later on using Adobe Acrobat Reader or another compatible program, if available.

				Resolving Link Errors

				Page names can change, and pages can be deleted (intentionally or not), so you should periodically check for broken links. You can ensure that links are working correctly in several ways. The most cumbersome, to preview a page and click every link, would take a long time and wouldn’t be much fun. To check local links more efficiently and quickly, follow these steps:

					1.	Choose Site⇒Check Links Sitewide.

						The Results panel appears, with the Link Checker tab active.

						Any broken links appear, including page, scripts, and images, as shown in Figure 6-5.

					2.	Use the Show drop-down list in the top-left corner to sort the link results by broken link, external link, or orphaned file.

						To focus only on broken links, leave Broken Links selected.

						If you don’t have broken links — congratulations! If you do, you can fix them directly in the Results panel. The page that has the broken link is listed in the Files column on the left. The broken link appears under the Broken Link column on the right.

					

				
					Figure 6-5: Use the Check Links Sitewide menu option to make sure that no links are broken, and correct them if necessary.

				

				
					[image: 9781118168608-fg060605.tif]

				

				

				
					3.	Click the name of the broken link and correct the filename, if it’s a problem, or click the Browse folder icon to locate the correct location or file.

					4.	Click OK (Windows) or Choose (Mac).

						The broken link is repaired.

				[image: tip.eps]	Orphaned files are pages or images that are not in use or linked to from any place within your site. Although having orphaned files isn’t necessarily a problem, to ensure that you don’t have important files that are orphaned, choose Orphaned Files from the Show menu under the Link Checker section of the Results panel.

				

			

			
		

	
		
			
				Chapter 7: Creating Tables

				In This Chapter

				[image: check.png] Creating tables

				[image: check.png] Manipulating rows, columns, and cells

				[image: check.png] Selecting tables and cells

				[image: check.png] Changing the color and alignment of table cells

				[image: check.png] Styling tables with CSS

				[image: check.png] Adding and importing content

				Tables are useful for presenting data and can be helpful when you’re arranging elements in a tabular format. You can use tables to display data (such as pricing information or a schedule of events) much like you would a spreadsheet.

				In this chapter, you find out how to create a table and apply formatting with CSS. Note: Although tables have been used as a method of creating page layouts in the past, this is considered bad practice, so we don’t cover it in this minibook.

				Working with Tables

				When you think of a table, think of a grid that has multiple cells in it, much like a spreadsheet. Tables are used in HTML pages so that elements and data can be contained and positioned within specific cells in a series of rows and columns. You can change the colors of cells in tables, divide or span the cells (combine them with other cells), and apply borders to them.

				When you create a table, you can determine how many rows and columns it contains, as well as set fixed or scalable widths for rows and columns where necessary. You can also choose to merge rows and columns to create unique tables, as shown in Figure 7-1.

					

				
					Figure 7-1: A table with columns merged.

				

					[image: 9781118168608-fg060701.tif]

				To create a table in Dreamweaver, follow these steps:

						1.	[image: 9781118168608-ma202.tif] Put the cursor where you want the table to appear, make sure that the Common tab on the Insert panel is visible, and then click the Table button.

						Alternatively, you can choose Insert⇒Table. Whichever method you use, the Table dialog box appears, as shown in Figure 7-2.

					

				
					Figure 7-2: Set table speci-fications in the Table dialog box.

				

					[image: 9781118168608-fg060702.eps]

					2.	Enter or select the attributes of the table you want to create:

					•	Rows: In the Rows text box, enter the number of rows you want in the table. Rows stack vertically and can be added or deleted after you create the table.

					•	Columns: In the Columns text box, enter the number of columns you want in the table. Columns are created horizontally across a table and can be added or deleted after you create them.

					•	Table Width: Enter a width measurement in the Table Width text box and then select a measurement (Pixels or Percent) from the drop-down list to the right. Table width is an important attribute because it sets the default size for the table. If you leave this setting at 100 percent, the table occupies 100 percent of its container. You can change the width to a different percentage, such as 50 percent, to have the table occupy half the width of its container (shown in Figure 7-1), or you can enter a pixel value to ensure that the table always stays the same size.

					•	Border Thickness: Enter (in pixels) the thickness you want for the width of the border surrounding the cells and outside the table. If you want to see no table formatting, type 0 in the Border Thickness text box. Note: In Design view, you still see a dashed table border — it’s only a visual aid. You see true borders when you view the page in a browser or in Live view.

					•	Cell Padding: Enter a number in the Cell Padding text box if you want to use padding to create a margin around all content inside the cell.

					•	Cell Spacing: Enter a number in the Cell Spacing text box if you want to change the spacing to push cells apart.

					•	Header: The Header check box converts the top row of the table from a standard row to a defined header (using the <th> tag). This reinforces that the first row and its contents define the header of the table.

					•	Accessibility options: You can provide additional information to help visually impaired users understand the contents of your table. Add a caption that’s relevant to your table in the Caption text box. In the Summary area, include several lines of text to provide more information about the purpose of the table and its contents.

					3.	Click OK.

						Your table is created.

				[image: tip.eps]	When working with tables, try to take advantage of the Expanded table feature in Dreamweaver. (Find the Expanded button in the Layout section of the Insert panel.) Expanded view adds cell padding and spacing in a table and increases the size of the border to make selecting cells and content easier. For an accurate preview, return to Standard view (click the Standard button in the Layout section of the Insert panel) after you finish editing.

				Editing table attributes

				Even if you’ve already created a table, you can go back and edit its attributes by selecting the table and entering changes in the Property inspector, as shown in Figure 7-3.

				If the Property inspector isn’t expanded (refer to Figure 7-3), click the arrow in the lower-right corner of the inspector. The inspector then expands, offering additional options.

				[image: tip.eps]	When a table is selected, you can use the handles that appear in the lower-right corner as well as the bottom and left sides to resize the table manually.

				Adding and deleting rows and columns

				You can use the Property inspector to add or delete rows and columns as fast as your client’s (or boss’s) needs require, but the Modify menu gives you a little more control over which rows and columns are deleted and where new ones are added.

					

				
					Figure 7-3:  Make changes to your table with the Property inspector.

				

					[image: 9781118168608-fg060703.eps]

				To add a row, follow these steps:

					1.	Insert the cursor in a cell in the row that you want to add a new row above or below.

					2.	Choose Insert⇒Table Objects⇒Insert Row Above or Insert Row Below.

						Alternatively, press Ctrl+M (Windows) or [image: maccmd]+M (Mac).

						The new row appears.

				[image: tip.eps]	To add more rows to the bottom of the table, place the cursor in the last current row and press the Tab key.

				Follow these steps to delete a row:

					1.	Insert the cursor in a cell of the row you want to delete.

					2.	Choose Modify⇒Table⇒Delete Row.

				[image: tip.eps]		Alternatively, press Ctrl+Shift+M (Windows) or Shift+[image: maccmd]+M (Mac).

						The row is deleted.

				To add a column, follow these steps:

					1.	Insert the cursor in a cell.

						Insert the cursor in the cell in the column that you want a new column added to the left or right of.

					2.	Choose Insert⇒Table Objects⇒Insert Column to the Left or Insert Column to the Right.

						The new column appears.

				Follow these steps to delete a column:

					1.	Insert the cursor in a cell of the column you want to delete.

					2.	Choose Modify⇒Table⇒Delete Column.

				[image: tip.eps]		Alternatively, press Ctrl+Shift+– (minus) (Windows) or Shift+[image: maccmd]+– (minus) (Mac).

						The column is deleted.

				Merging and splitting cells

				Often, you may need to merge or split cells. You can combine cells with other cells horizontally or vertically. By merging cells, you can create more interesting and useful tables or accommodate different types and amounts of content. Figure 7-4 contains a table with one large, merged cell across the top.

					

				
					Figure 7-4: In the top row, two columns of cells have been merged.

				

					[image: 9781118168608-fg060704.eps]

				Follow these steps to merge cells in a row or column:

					1.	Click within a cell and then drag across to select neighboring cells in the row or drag down to select neighboring cells in the column.

					2.	Choose Modify⇒Table⇒Merge Cells.

						The cells are merged.

				To split a merged cell back into separate cells, follow these steps:

					1.	Put the cursor in the merged cell or column.

					2.	Choose Modify⇒Table⇒Split Cell.

						The Split Cell dialog box appears, as shown in Figure 7-5.

					3.	Choose whether you want to split into rows or columns by selecting either the Rows or Columns radio button.

					

				
					Figure 7-5: Split cells as easily as you merge them.

				

					[image: 9781118168608-fg060705.eps]

					4.	Enter the number of rows or columns you want to create by splitting the cell in the Number of Rows/Columns text box.

					5.	Click OK.

						The merged cell is now split into the number of cells you specified.

				Selecting a Table and a Cell

				You can use several methods to select a cell or the whole table. After a cell or table is selected, you can change all sorts of attributes for the selected cell or table, including the color, size, and format of its contents.

				To select a table or cell, follow these steps:

					1.	In Design view, select the Layout category from the Insert panel and select Expanded to put your table in Expanded view.

						You can more easily select and make changes in this view. (Remember to click the Standard button to see a more realistic preview of your table.)

					2.	While holding Ctrl (Windows) or [image: maccmd] (Mac), move your cursor over a cell and click to select it.

						You can select multiple cells by using this technique.

				[image: tip.eps]	The tag selector is an incredible tool to use to select any page element, though it’s especially helpful when selecting individual components of a table or a nested table. The tag selector is in the lower-left corner of the Document window, as shown in Figure 7-6.

				To use the tag selector, just put the cursor inside a cell. The tag selector shows the tags that apply to the insertion point’s location. Then select <td> to select the cell that holds the cursor, <tr> to select the entire row, or <table> to select the entire table.

				[image: tip.eps]	The table tag is <table> (it’s a difficult one to remember, right?), and each row is in a <tr> (table row) tag. Each cell is in a <td> (table data) tag. Tables created with headers also make use of the <th> (table header) tag.

					

				
					Figure 7-6: Use the tag selector to select cells and tables.

				

					[image: 9781118168608-fg060706.eps]

				Changing the Color and Alignment of Table Cells

				You can change colors of a single cell, multiple cells, or an entire row in Dreamweaver. You can also choose to vertically and horizontally align cell contents. You can use either standard HTML attributes (via the Property inspector) or create CSS rules to apply formatting to any portion of a table.

				To change the color of a cell or multiple cells in a table, follow these steps:

					1.	Ctrl-click (Windows) or [image: maccmd]-click (Mac) anywhere within a cell to select that cell.

						You can continue to add cells to your selection by keeping the key pressed and clicking more cells.

					2.	In the Property inspector, make sure that HTML view is selected (click the HTML tab on the left edge of the panel) and locate the Bg Color Picker.

					3.	Assign color to cells by following one of these methods:

					•	Click the swatch to the right of Bg and select a color from the Color Picker that appears. Remember that you can choose from additional color models by clicking the palette menu in the upper-right corner of the Color Picker.

					•	If you know the hexadecimal number of your color, you can type it in the text field next to the Bg color swatch.

					•	Select a color from any element you can see onscreen by clicking the color fill box to the right of Bg and then moving the Eyedropper tool over any color on your screen that you want the cell color to pick up. Click when the color appears in the Color Picker preview window.

					4.	The color is applied as a background to the selected cells.

					5.	With the cell still selected, locate the Horz and Vert drop-down menus at the bottom of the Property inspector. 

						These control the horizontal and vertical alignment of cell contents, respectively. 

					6.	Select “Center” from the Horz menu, and “Middle” from the Vert menu.

						This step positions the contents in the middle of the table cell.

				[image: tip.eps]		When the table cell is not much taller than its contents, vertical alignment is not as obvious as horizontal alignment. Try vertical alignment on cells with a taller height or on multiple cells merged across two or more rows.

				Applying Table Formatting with CSS

				In addition to using the Property inspector, you can format entire tables or individual table cells (and their contents) by using CSS. In most cases, this is considered a better practice, as it maintains a separation between markup, content, and the actual styling used to make it aesthetically pleasing.

				You can use CSS to format a table as follows:

					1.	Create a CSS Class rule from either the Property inspector or the CSS Styles panel (as discussed in Chapter 5 of this minibook).

					2.	Under the Type category, select a size and color for your table’s text.

					3.	Under the Background category in the CSS Rule Definition dialog box, assign a background color to your table by using the Background color property and then click OK.

					4.	Select the table you want to apply the new Class style to.

					5.	Assign the class by using the Class drop-down list in the Property inspector.

						Your entire table takes on the new formatting, as shown in Figure 7-7.

					

				
					Figure 7-7: A table before and after a new CSS class is applied.

				

					[image: 9781118168608-fg060707.eps]

				Similar to the way you can use the Property inspector to color and align individual cells, you can create and apply CSS rules to table cells. In most cases, this is considered a better practice than relying on HTML attributes. To do this, just follow these steps:

					1.	Create a CSS Class rule from either the Property inspector or the CSS Styles panel (as discussed in Chapter 5 of this minibook).

					2.	Under the Background category, select a Background color.

					3.	Under the Block category, select Middle from the Vertical-Align drop-down list, select Center from the Text-Align drop-down list, and then click OK.

					4.	Select the table cell that you’d like to apply the new class to.

					5.	From the Property inspector, locate the Class drop-down list and select your new class.

						Your formatting choices are applied to the table cell, as shown in Figure 7-8.

					

				
					Figure 7-8:  Apply color, text formatting, and alignment to table cells by using CSS rules.

				

					[image: 9781118168608-fg060708.eps]

				Adding and Importing Content

				Adding content to a table is easy: You can type or insert content within table cells just as you would within the page itself. (You can even include other tables!) You can also cut, copy, and paste content from documents and other web pages directly into table cells.

				If you already have spreadsheet-style data in text form, you don’t have to retype it into a Dreamweaver table. Dreamweaver has an incredibly useful feature you can use to bring in tabular data as a formatted table: Import Tabular Data.

				CSV (comma-separated values) and tab-delimited files are plain text files that can be generated from a number of popular programs, such as Microsoft Excel. You can use these files to save spreadsheet data in a way that lets it be exchanged with other applications such as Dreamweaver.

				In CSV files, columns are noted by commas between values, and each line return indicates a new row. In tab-delimited files, a tab between values indicates a new column and a line return forces a new row.

				To import tabular data, follow these steps:

					1.	Using Microsoft Excel or a similar program, create a spreadsheet of data, and save it as .csv (comma-separated values). 

						You can save this wherever you’d like, as long as you can easily locate it.

					2.	Return to Dreamweaver and open a page where you’d like to add a table.

					3.	Put the cursor on the page where you want the table to be created.

					4.	Choose File⇒Import⇒Tabular Data.

						The Import Tabular Data dialog box appears.

					5.	Use the Browse button to browse to the location of a CSV (.csv) file or a tab-delimited (.txt) plain-text file.

					6.	Verify or select the delimiter that your file uses.

						Typically, the delimiter (where a new column will be created) is a comma or tab; however, you can also instruct Dreamweaver to create a new column from other delimiters, such as Comma, Semicolon, Colon, or other options, by using the Delimited drop-down list.

					7.	Determine the table width.

						You can choose to have the table automatically sized to fit the data by leaving the Fit to Data radio button selected, or you can enter a number in the Set To text box to set a percentage or pixel value.

					8.	Enter numbers in the Padding, Spacing, and Border text boxes and specify top-row formatting in the Format Top Row drop-down list at the bottom of the dialog box.

					9.	When you’re finished with these settings, click OK.

						Your table is created!

				[image: tip.eps]	You can export table data from Dreamweaver just as easily as you can import it, by selecting a table and choosing File⇒Export⇒Table. When the Export Table dialog box appears, choose an element to be the delimiter and choose the type of line break. Click Export, determine where you want to save the file, and click Save.

				If you select every cell in a row, you also have the opportunity to change the alignment of an entire row. In the Property inspector, you find a horizontal alignment drop-down list that changes the alignment of an entire row or selected cell. Choose from Left (default), Center, or Right. Note that any changes you make in the individual cell alignment override the row alignment.

				You can also change the vertical alignment in the Property inspector when you have a row selected. Click the Vert drop-down list and select Default, Top, Middle, Bottom, or Baseline.

				[image: tip.eps]	To select an entire row at once, position the cursor on the left side of the row you want to select. When the black arrow appears, simply click. You can also use this method of selecting an entire column by positioning the cursor on top of the column you want to select until the black arrow appears.

				

			

			
		

	
		
			
				Chapter 8: Creating CSS Layouts

				In This Chapter

				[image: check.png] Getting started with CSS starter pages

				[image: check.png] Modifying layouts

				[image: check.png] Positioning content with the AP Div tool

				[image: check.png] Using behaviors with DIVs 

				[image: check.png] Using the new CSS Transitions

				Creating a proper page layout often requires more precision than standard HTML tags are capable of. Although most elements (such as lists and tables) have some level of layout control, creating real page layouts requires the use of CSS. Not just for text, CSS rules have the power to position elements on the page, set width and height properties, and so much more.

				Creating CSS rules for layouts is done in very much the same way as those for text and image formatting (as discussed in Chapter 5 of this minibook). However, you have some new properties to explore that are more relevant to this task. We discuss those in this chapter.

				Dreamweaver provides you with an extensive gallery of CSS-based layouts to help you get started, or you can build your own using the Insert panel’s Layout tools, including the Insert DIV and AP Div objects.

				Using CSS Starter Pages

				Dreamweaver provides you with a library of sample pages with CSS-based layouts as an alternative to starting from scratch. These CSS sample pages feature useful and common layout ideas, and because they’re created with CSS positioning, they’re highly flexible. You can modify them directly from the CSS Styles panel or the Property inspector. Just add your content and go!

				Follow these steps to create a new document from a CSS starter page:

					1.	Choose File⇒New.

						The New Document panel appears.

					2.	Choose Blank Page from the left, select a layout from the Layout column on the right (for example, the 2 Column Fixed, Left Sidebar, Header and Footer layout, as shown in Figure 8-1), and click Create.

					

				
					Figure 8-1: Create a CSS-based layout using the built-in CSS Starter pages.

				

					[image: 9781118168608-fg060801.eps]

						A new, untitled page opens, based on the layout you chose.

				[image: tip.eps]		By default, new CSS starter pages place all of their CSS rules in an embedded style sheet. To use an external (linked) style sheet instead, choose Create New File from the Layout CSS drop-down list on the New Document dialog box. You’ll be prompted to save the file in your site’s root directory.

					3.	Choose File⇒Save to name and save the document.

					4.	Replace the placeholder text in each column with your own content, as shown in Figure 8-2.

					

				
					Figure 8-2: Use a CSS starter page as a guide for creating CSS-based layouts.

				

					[image: 9781118168608-fg060802.eps]

				Modifying a New Layout

				A CSS layout, as its name indicates, is controlled completely by style sheet rules, so you can modify the look and feel of the page directly from the CSS Styles panel and the Property inspector. Each column, box, and space on your new page is positioned and sized using CSS rules and properties, all of which you can adjust from either the Property inspector (on the CSS Styles panel) or the CSS Rule Definition panel.

				You can modify the layout by following these steps:

					1.	If the CSS Styles panel isn’t already open, choose Window⇒CSS Styles to open it.

					2.	Select the All tab to display the style sheet and its rules.

						The internal style sheet is shown as <style> at the top. Click the arrow to its left to expand it and show all the rules it contains. Note: Layouts using an attached (external) style sheet display the style sheet name (such as styles.css) instead of the <style> tag.

					3.	Select the body rule.

						This tag-based style controls the general formatting of the entire page (everything inside the <body> tag).

					4.	Click the field next to the background-color rule to edit it; rather than keep the #4E5869 (medium gray) setting, type a hexadecimal color (such as #CC0000 for red) to change the page’s background color.

					5.	Click the swatch next to the color rule to open the Swatches panel; pick a new default type color for the text on your page.

					6.	At the top of the CSS Styles panel, select another style (for example, the .twoColElstHdr #container style) to view its properties.

						The .twoColHybLtHdr #container style controls the size and appearance of the main layout container on the page.

					7.	In the Property inspector, edit the properties to change the appearance of the style.

						For example, you can change the width of the rule by entering a new number in the Width Rule text box. If you enter 95%, for example, you make the entire layout wider.

				Controlling Elements with ID Styles

				Each column and section that comprises your layout is controlled by one of the ID styles listed in the CSS Styles panel. Most every ID style features a width property you can use to change the size of different areas on the page.

				Continue to modify different styles listed in the CSS Styles panel and see how they affect different elements on your page. Try changing the type color, font family, and other properties, such as padding and background color.

				[image: tip.eps]	To figure out exactly which ID controls which column or section, click within the page area and look at the tag selector at the bottom of the Document window. The last <div> tag at the end of the chain shows you which container you’re in and its corresponding ID in the CSS Styles panel (for example, <div#mainBox>).

				Creating AP (Absolute-Positioned) Divs

				Dreamweaver uses CSS-controlled virtual containers, or boxes, created by the DIV tag to freely position content on a page. The DIV tag is a basic tag used to create areas for content on your page. You can create DIV tags from several places in Dreamweaver, including the Layout section of the Insert panel. Each DIV tag can have a unique ID style assigned to it to control its position, appearance, and size. The process of placing content often requires two steps: creating the DIV tag and then creating its corresponding style.

				Dreamweaver makes this task easy with the AP Div tool, which enables you to draw boxes freely on the page and place content inside.

				[image: technicalstuff.eps]	AP Div is short for absolute-positioned DIV; an item with an absolute position is fixed at a specific location on the page. When you draw an AP Div, its position is commonly set using the top and left CSS properties, with the top-left corner of the page as its reference point.

				[image: technicalstuff.eps]	If you’ve worked with text frames in Adobe InDesign or Adobe Illustrator, you may find some similarities with AP Divs in Dreamweaver. However, AP Divs can contain mixed content of any kind, including other DIVs, text, images, and tables.

				CSS treats most container elements on a page as boxes; this approach, referred to as the CSS Box model, enables these elements to share uniform properties such as padding, margins, width, height, and borders. Although CSS can regard most any containing element on a page as a box (such as a table or a list), DIV tags are most commonly used to create virtual boxes that you can use to position text, images, and even nested boxes.

				Each box can have its own width, height, position (via the top and left properties), border, margins, and padding; each one is set using the appropriate CSS properties.

				To create AP Divs, follow these steps:

					1.	Create a new page or open an existing page from your site.

					2.	On the Insert panel, select the Layout category.

					3.	Select the Draw AP Div tool.

					[image: 9781118168608-ma900.tif]		The cursor appears as a cross hair when you move it back over the page.

					4.	Click anywhere on the page and drag to draw a new AP Div, as shown at the left in Figure 8-3; release the mouse button.

					

				
					Figure 8-3: Click and drag on the page with the Draw AP Div tool to draw a new box.

				

					[image: 9781118168608-fg060803.eps]

					5.	Move the mouse pointer over the edge of the box until it changes to a 4-way arrow; click once and handles appear on all sides.

					6.	Click and drag any of these handles to resize the box vertically or horizontally.

					7.	To move the box, click and drag it by the tab that sits on its top-left edge and place the box where you want it on the page.

						Take a look at the Property inspector, and you see the name as well as many DIV properties listed.

					8.	If the CSS Styles panel isn’t open, choose Window⇒CSS Styles to open it; under the All panel, click to the left of the style sheet (<style>) to expand it.

						You see a new #apDiv1 ID style (as shown in Figure 8-4) that’s attached to the new AP Div you created. For each new DIV created, Dreamweaver assigns apDiv with a corresponding number in order of creation.

					9.	Click inside the new box to type, paste, or insert new content.

				When you draw an AP Div on the page, two things occur: Dreamweaver inserts a tag to create the box and creates a CSS ID selector that stores the DIV’s position, width, height, and other properties. After you create an AP Div, you can type, paste, or insert content directly inside it. You can also assign a class rule to any DIV from the Property inspector — most often for handling content formatting, leaving the ID selector to control positioning and dimensions.

					

				
					Figure 8-4: Each new box drawn with the AP Div tool is attached to a unique ID style that controls its position, width, and height.

				

					[image: 9781118168608-fg060804.tif]

				Each AP Div you draw is listed automatically in the AP Elements panel (choose Window⇒AP Elements to display it), as shown in Figure 8-5. The AP Elements panel can help you select, hide, and show any AP Divs on the page. This panel is handy when you have lots of AP Divs on the page and want to navigate among them accurately. Most of all, because you can modify the properties for any AP Div from its corresponding ID style, the panel helps you figure out which ID style belongs to an AP Div.

					

				
					Figure 8-5: Use the AP Elements panel to select, hide, and rearrange AP Divs in your page.

				

					[image: 9781118168608-fg060805.eps]

				[image: tip.eps]	The AP Elements panel is often grouped with the CSS Styles panel, just in case you’re looking for it.

				To modify a box (AP Div), follow these steps:

					1.	Choose Window⇒AP Elements to open the AP Elements panel.

					2.	In the panel (refer to Figure 8-5), locate and select apDiv1 to highlight it on the page.

						The Property inspector displays its size and position in addition to other properties.

					3.	Using the text boxes in the Property inspector, change the box width by entering a number into the W field and change the box height by entering a number in the H field.

					4.	Click the swatch next to Bg Color and choose a color from the pop-up Swatches panel to set a background color for the box.

						For additional properties, such as border or padding, add them in the CSS Styles panel.

					5.	If the CSS Styles panel isn’t already visible, open it by choosing Window⇒CSS Styles.

					6.	Double-click the #apDiv1 ID style that controls the box.

						The CSS Rule Definition dialog box appears, as shown in Figure 8-6.

					

				
					Figure 8-6: Add CSS properties across a variety of categories to build rules.

				

					[image: 9781118168608-fg060806.eps]

					7.	Select the Border category from the left to change the border.

					8.	In the Style column, use the Top drop-down list to set a border style (such as Solid) to all four sides.

						Use the Top drop-down list under the Width category to select a border thickness (for example, medium) for all four sides. Use the topmost Color Picker under the Color column to assign a border color to all four sides.

				[image: tip.eps]		To assign different values to any or all sides for style, width, or color, deselect the Same for All check box under their respective columns.

					9.	In the Box category on the left, under Padding, set the padding for all four sides of the box to the thickness you want (for example, enter 5 px in the text boxes).

					10.	Click OK to exit the panel and apply the changes.

						You see how the CSS properties you applied affect the apDiv1 box on the page.

				[image: tip.eps]	To hide a box shown under the AP Elements panel, click the column to the left of its name (under the Eye icon) until a closed Eye icon appears. To make the box reappear, click the Eye icon until the box opens again.

				[image: tip.eps]	You may notice the Prevent Overlaps check box, deselected by default, at the top of the AP Elements panel. Because AP Divs can easily overlap each other, selecting this check box overrides that behavior by forcing boxes next to each other and preventing the creation of new boxes on top of each other.

				Creating Relatively Positioned DIVs

				The precision and to-the-pixel positioning of AP Divs can be quite liberating for designers, especially those who like the flexibility of print-based layouts. However, on certain occasions, you may want boxes to flow inline with other content on the page. AP Divs literally float above other elements, so shifting other page content has no effect on their position, which can be a good or a bad thing.

				For more traditional inline behavior, you can create DIVs that use relative positioning. This allows an element to be shifted along with content surrounding it, making for a more liquid layout. This type of positioning is important for nested content or any situation where items should fall in line with other page content. For this task, use the Insert Div Tag tool, which you can find within the Insert panel’s Common and Layout categories.

				Follow these steps to create a relatively positioned DIV:

					1.	Click within your page to position the cursor within an existing AP Div and then click the Insert Div Tag tool under the Insert panel’s Common and Layout categories.

					2.	When the Insert Div Tag dialog box appears, fine-tune the location of your new DIV by selecting a location from the Insert drop-down list, shown in Figure 8-7.

						For example, choose After Start of Tag to place it within an existing DIV tag in your page.

				[image: tip.eps]		You can also use the Insert Div Tag dialog box’s drop-down list to place the DIV before, after, or inside existing elements on the page. Leave the Insert drop-down list set to At Insertion Point to leave the box where you drew it or choose another location where you want the DIV created.

					

				
					Figure 8-7: Choose a specific location to create and place the new DIV. Create a new ID style to control its position and appearance.

				

					[image: 9781118168608-fg060807.eps]

					3.	If you have an existing class selector you want to apply, select it from the Class drop-down list; otherwise, leave it blank.

					4.	If an existing ID isn’t available, enter a new name in the ID field and click the New CSS Rule button to create one. (Refer to Figure 8-7.)

					5.	When the New CSS Rule dialog box appears, be sure that your new selector is set to ID and that the name has a pound sign (#) in front of it. Click OK.

					6.	When the CSS Rule Definition dialog box appears, click and select Positioning from the Category list on the left to view CSS positioning properties.

					7.	In the Positioning area, select Relative from the Position menu, enter a width and height value in the Width and Height text boxes, and enter a Top and Left value under the Positioning properties. Click OK.

					8.	Click OK to close the Insert Div Tag dialog box.

						A new, relatively positioned DIV appears with placeholder text, as shown in Figure 8-8.

					

				
					Figure 8-8: You can create a new relatively positioned DIV within an AP Div.

				

					[image: 9781118168608-fg060808.eps]

				[image: tip.eps]	The Top and Left values behave slightly differently for absolute versus relatively positioned DIVs. In the case of relative positioning, these values indicate an offset from surrounding content, as opposed to a set position within the page.

				Using Behaviors with Boxes

				To add cool effects and interactivity, you can use the built-in Dreamweaver behaviors, a collection of ready-to-use scripts that you can apply to nearly any element on a page. When used with DIVs or other containers, behaviors can enhance them with special effects or mouse interaction (such as clicks and rollovers) to make the page more exciting.

				The Behaviors panel features a whole new set of effects, such as Fade/Appear, Shrink, Highlight, Slide, and more — all of which you can apply to the AP Divs you create.

				You can add behaviors by following these steps:

					1.	Choose Window⇒Behaviors to open the Behaviors panel.

					2.	Select a DIV by using the AP Elements panel or select an element directly on the page.

					3.	In the Behaviors panel, click the plus sign.

						The menu of available behaviors appears.

					4.	From the menu, choose the behavior you want to apply.

						For example, to apply a fade effect, choose Effects⇒Appear/Fade, as shown in Figure 8-9.

						The Appear/Fade dialog box opens.

					

				
					Figure 8-9: Add a cool Appear/Fade effect to a DIV on your page.

				

					[image: 9781118168608-fg060809.eps]

					5.	Make sure the effect is set to Fade and select the Toggle Effect check box to make sure the box reappears when it’s clicked a second time. Then click OK.

						The behavior is added to the list. The phrase onClick to its left indicates that this action occurs when the box is clicked.

					6.	Choose File⇒Save to save the page.

						To see the effect in action, preview the page in a browser.

					7.	Choose File⇒Preview in Browser and pick a browser to launch the page.

				When you test the page, clicking the box makes it disappear or reappear — lots of fun for you and highly interactive for users!

				[image: warning_bomb.eps]	If your browser is restricting the web page from running scripts or ActiveX controls, click the message at the top of the browser window and select Allow Blocked Content to properly test the new behaviors.

				[image: remember.eps]	When effects behaviors are used, Dreamweaver needs to copy to your local site several files that make the effects possible.

				Using CSS Transitions

				You can use the new CSS Transitions in Dreamweaver as a JavaScript-free alternative to Behaviors. Much like Behaviors, CSS Transitions allow you to add cool interactive behavior to elements on your page. However, CSS Transitions use only the power of new CSS3 properties to create these effects.

				To apply a CSS Transition, follow these steps:

					1.	Select an element on the page (preferably a DIV) that you’d like to apply a transition to.

					2.	Open the CSS Transitions panel by choosing Window⇒ CSS Transitions.

					3.	Click the New (plus sign) button to open the New Transition  dialog box.

						Here you can set the element (by ID) duration and property you want to create a transition on. For instance, to create a fade in or fade out, you could set a transition on the opacity property as shown in Figure 8-10.

					

				
					Figure 8-10: Create pure CSS Transition effects using CSS properties such as width, opacity, and background-color.

				

					[image: 9781118168608-fg060810.eps]

					4.	From the Target Rule drop-down list, select the ID of an element you’d like to create a transition on. 

					5.	From the Transition On drop-down list, select the action (such as active or hover) that triggers the transition.

					6.	Set values for Duration, Delay, and Timing Function.

						For example, set Duration at 1 second, Delay at 0, and the Timing Function to Ease-out.

					7.	Use the plus sign at the bottom to add a CSS property to the list.

						This is the property you will transition, or change the value of, over time. For example, select opacity. Set the end value (for example, 0 for a full fade out).

					8.	Click Create Transition.

					9.	Preview the page in a browser or using Live view to see the animation in action!

				

				

			

		

	
		
			
				Chapter 9: Publishing  Your Website

				In This Chapter

				[image: check.png] Checking for broken links and missing files

				[image: check.png] Running your site reports

				[image: check.png] Checking browser compatibility

				[image: check.png] Publishing to a web server

				[image: check.png] Making site improvements

				Nothing is better than posting your site to the world for the first time, and Dreamweaver helps you not only to build great sites, but also to manage and transfer them to their final destinations.

				Before you launch your website, you want to take lots of steps to ensure that it looks and works its best. The Dreamweaver validation and reporting tools streamline the process of testing and fixing any problems so that you can present visitors with a favorable first impression.

				Clean Up after Yourself!

				The first step toward getting your website ready for the world is making sure that everything works as expected. Dreamweaver is packed full of tools that let you know exactly what’s broken and what can be done better and how your site will perform across a spectrum of different browsers.

				A key benefit of a Dreamweaver site is its ability to see relationships among various pages and files and detect any broken links or missing images before you publish your website for public viewing. Choose Site⇒Check Links Sitewide to comb your entire site to find broken links or missing or orphaned (unlinked) files.

				To use the Check Links Sitewide feature, follow these steps:

					1.	Choose Window⇒Files to open the Files panel.

						You can also use the F8 shortcut key (Windows or Mac).

					2.	Open the Files panel menu (it’s in the upper-right corner) and choose Site⇒Check Links Sitewide.

						The Link Checker panel appears and displays any results. Each listing shows the broken link and the name of the page that contains it to the left, as shown in Figure 9-1.

					

				
					Figure 9-1: The Link Checker lists the filenames and broken links.

				

					[image: 9781118168608-fg060901.tif]

					3.	To open and edit the page to correct the link, double-click the filename that’s shown.

						You can then edit the broken link directly from the Link Checker panel without opening the file. Click the broken link that’s displayed, and a folder icon appears next to it, on the right.

					4.	Double-click the folder to open the Select File dialog box and choose an available file to correct the link or relink it to a different file.

					5.	Click OK (Windows) or Choose (Mac).

				[image: tip.eps]	If you want to change a link that appears across several pages, open the Files panel menu and choose Site⇒Change Links Sitewide. When the panel appears, you’re asked which file the original link points to and you can specify a new file to link to instead. Warning: Your answer changes all links to that file sitewide, so don’t use this command if you want to change that link on only certain pages.

				Running Site Reports

				The Dreamweaver site reports provide a detailed look at potential issues lurking within your site as well as assistance in cleaning out redundant or empty tags from your pages.

				Reports are in two categories:

				[image: check.png] Workflow: Shows you currently checked out files, which ones have been recently modified and any design notes you’ve attached to individual files. This report is useful if you make heavy use of the Check In/Check Out feature in the Files panel.

				[image: check.png] HTML: Points out design and accessibility issues, such as missing ALT tags for images, improperly nested tags, empty tags, or pages that are missing titles that you can clean up.

				You can run a site report by following these steps:

					1.	Choose Site⇒Reports.

						The Reports dialog box appears, as shown in Figure 9-2.

					

				
					Figure 9-2: Use the Reports dialog box to choose reports you want to run.

				

					[image: 9781118168608-fg060902.eps]

					2.	Choose each report you want to see by selecting the check box next to the report name.

						As shown in Figure 9-2, we chose all the reports in the HTML Reports category.

					3.	At the top of the Reports dialog box, use the drop-down list to select what aspect of the website you would like to run the reports on. 

						You can choose the Current Document, Entire Current Local Site, Selected Files in Site or a specific folder of your choice. If you are unsure, choose the Entire Current Local Site option.

					4.	Click the Run button to run the selected reports.

						The Results panel appears and displays the results of each report.

						Each report result displays the file and line number and a description of the problem.

					5.	To address a problem that’s shown, double-click the filename to open the page.

						The page opens for editing, and the section in which the problem occurs appears highlighted in Split view.

				Checking CSS Compatibility

				It’s important to make sure that your site appears properly and consistently across all popular browsers, such as Internet Explorer, Firefox, Chrome, and Safari. Although most modern browsers have adopted fairly uniform support for CSS2 (and some CSS3) properties, designers should still test their pages in a variety of browsers and browser versions.

				To eliminate this time-consuming task, Dreamweaver provides the Browser Compatibility Check, which works hand in hand with the Adobe website to discover and report any CSS-related display issues that may occur in selected browsers and versions. The Browser Compatibility Check checks CSS compatibility by default in these browsers: Firefox 1–3; Internet Explorer (Windows) 6.0–8.0; Internet Explorer (Macintosh) 5.2; Netscape Navigator 7.0–8.0; Opera 7.0–9.0; and Safari 1.0–3.0.

				For any problem that the Browser Compatibility Check discovers, the Results panel displays a description of the problem along with a direct link to the CSS Advisor section of the Adobe website. The CSS Advisor reports on known browser-display issues and possible solutions for fixing them.

				Follow these steps to test a page with the Browser Compatibility Check:

					1.	Open a page for editing by choosing File⇒Open or by selecting it from the Files panel.

					2.	In the Document window (next to the Live Code button), click and hold the Check Browser Compatibility button and then choose Check Browser Compatibility from the menu that appears.

						The Results panel appears, with the Browser Compatibility tab forward. Any results are displayed on this tab.

					3.	To view details and possible solutions for any results that may appear, select the result. (See Figure 9-3.)

					

				
					Figure 9-3: The Browser Compatibility Check displays any problems.

					
				

					[image: 9781118168608-fg060903.eps]

						The description, as well as a link to the Adobe website, appears on the right side of the panel.

						Possible compatibility issues are listed along with the filename, line number, and description of the problem.

					4.	Click the link below the detail panel to jump to the Adobe website for solutions.

				Getting Connected

				When you’re ready to publish your site for the world to see, set up a remote server in your site definition so that you can connect and copy files to your web-hosting account or dedicated server.

				Typical remote server information consists of an ID and a password, an FTP (File Transfer Protocol) or network address, and the name of the specific directory where your files need to go. This information is available from the company your hosting account was purchased from or from your network administrator.

				To set up a remote connection, follow these steps:

					1.	Choose Site⇒Manage Sites.

						The Manage Sites panel appears.

					2.	Select your site from the list and click the Edit button, which appears as a pencil icon below the list.

					3.	When the Site Setup dialog box appears, select the Servers category on the left.

						Here you can add connection information to a web server where you can store and publish your website.

				[image: tip.eps]		The term servers typically refers to a web-hosting account: space on a server purchased from a web-hosting provider. Your web-hosting account is essentially a folder on a remote computer, where you can store your files and point your users so they can view your site from any computer or device. There are tons of hosting providers (such as GoDaddy, FatCow, 1 and 1) from which you can purchase these services.

					4.	Below the listing of servers (which is likely empty right now), click the Add new Server button. 

						This step opens a dialog box where you can enter your connection  information.

					5.	Enter a name for your connection in the Server Name text box.

					6.	From the Connect Using drop-down list, select the type of connection you’re going to create. 

						In most cases this is FTP, but check with your IT Administrator if you’re unsure. If you’re connecting to a web-hosting account, FTP is the most common way in which you’ll connect.

					7.	Enter your FTP address, Username, and Password in their respective text fields (as shown in Figure 9-4).

						This information is provided to you when you set up a web hosting account. If you are unsure of this information, contact your web hosting provider or IT Administrator.

					8.	Enter your Root Directory in the appropriate text field.

						This is the name or location of the folder where your website files will  be kept on the remote server. If you are unsure of this information, leave it blank.

					9.	Enter your web URL in the text field shown.

						This is the actual web address where users will find your website (for example, http://www.mycoolwebsite.com).

					

				
					Figure 9-4: Enter your connection information when adding a new server.

				

					[image: 9781118168608-fg060904.tif]

					10.	Click the Test button to test your connection.

						If the connection is made successfully, Dreamweaver will let you know. If not, you may need to double-check the information you entered and try again.

				[image: tip.eps]		If you experience difficulty connecting to your remote server or the connection is taking unusually long, select the Use Passive FTP check box under the More Options section at the bottom. (You need to expand this by clicking the arrow next to More Options.) Passive FTP can also be a workaround if you’re trying to connect from behind a firewall.

					11.	If your settings are correct, click Save to create the Server connection.

					12.	Click Save again to exit the Site Setup dialog box.

				Your website — live!

				After your connection is up and running, you’re ready to upload files and present your website to the world. You can transfer files to and from your remote web server by using the built-in FTP functionality of the Files panel. It displays files in your local directory and the remote server, and between them, you can put, get, or synchronize site files.

				Follow these steps to upload your website to a remote web server:

					1.	Choose Window⇒Files to open the Files panel.

						2.	[image: 9781118168608-ma305.tif] Click the Expand to Show Local and Remote Sites icon.

							The panel expands so that you see both the local site and the remote site to which you want to copy (upload) the files.

					3.	Make sure that the correct site definition is selected in the Show drop-down list in the upper-left corner of the panel.

						Your local files appear on the right.

					4.	To connect to and display files on the remote web server, click the Connect button at the top of the panel.

						When the connection is made, all files (if any) are displayed on the left side of the panel.

					5.	To copy files, select and drag them from the local files on the right to the remote files on the left, or use the Put button, as shown in Figure 9-5.

						Alternatively, select the files you want to copy on the right and click the Put button at the top of the Files panel.

					

				
					Figure 9-5: Drag and drop or put files from your local machine to your web server to copy and update them.

				

					[image: 9781118168608-fg060905.eps]

				[image: tip.eps]		You can put all of the files within your site on your web server at once by selecting the root folder at the top of the local files panel and clicking the Put button.

					6.	After you copy all files to the remote web server, test your site by opening a browser and typing the website’s URL.

						The URL is a full address, such as www.mywebsite.com, or an IP address, such as http://192.1.1.1.

						If you notice broken images or files, return to Dreamweaver to double-check whether all files were copied to the server and then run the Link Checker by choosing Site⇒Check Links Sitewide.

				To retrieve files from a remote web server, follow these steps:

					1.	Select the files you want to retrieve from the remote files on the left side of the Files panel.

					2.	Click the Get button (which appears as a green, downward-pointing arrow) at the top of the panel or drag the files to the local root folder on the right.

				
					
				
				[image: tip.eps]	To return the Files panel to its original position on the right side of the  workspace, click the Expand button in the upper right corner of the panel to deselect it. The Files panel minimizes and docks back with the panel group on the right.

				Synchronizing your site

				The handy Dreamweaver site synchronization feature compares files between your local and remote sites to ensure that both are using the same, and most recent, versions of your site files. This check is essential if there’s a chance that files on the remote server may be more up-to-date or if you’re unsure which files have been updated since the last time you worked on a website.

				Follow these steps to synchronize your local and remote directories:

					1.	If the Files panel isn’t already visible, choose Window⇒Files to open it.

					2.	Select the site you want to synchronize from the Show drop-down list in the upper-left corner of the panel.

						Your local files appear on the right.

					3.	Click the Connect button at the top of the panel to connect to the remote server.

						If you’re not viewing your Files panel in Expanded view, select Remote Server from the drop-down list at the top to display your remote files.

					4.	Click the Synchronize button at the top of the Files panel.

						The Synchronize Files dialog box appears.

					5.	From the Synchronize drop-down list, select whether you want to synchronize the whole local site or only files selected in the Files panel  (if any).

					6.	From the Direction drop-down list, select whether you want newer files put on the remote server, retrieved from the remote sever, or both.

					7.	To clean up unused or old files on the remote server, select the Delete Remote Files Not on Local Drive check box.

					8.	Click the Preview button to begin the process.

						This step may take a while, depending on the number of files in your site.

						The Synchronize Files dialog box appears and displays all changes that will be made between the local and remote folders.

					9.	Select, change, or delete any actions as necessary.

					10.	Click OK to have Dreamweaver complete the synchronization process.

				[image: warning_bomb.eps]	Be careful when using the Delete Remote Files Not on Local Drive option; some files on the remote server are installed by the web hosting company and are necessary for the operation of your site.

				Improving Your Site

				Remember that a site is like a living organism: It continues to grow and will still need care after it’s live. As you add to your site, find new and innovative ways to present information to site visitors; after all, it’s all about giving them what they came looking for.

				To improve your site and keep visitors coming back, try these tips:

				[image: check.png] Solicit feedback from focus groups or colleagues in different fields. Let them tell you the best and worst features of your site and then use the feedback to assist in design, layout, and content decisions.

				[image: check.png] Use web statistics to your advantage. Use these statistics, often provided for free by web-hosting companies, to see where users are spending the most time and where they leave your site.

				[image: check.png] Provide a feedback form. Site visitors can then comment on the service and information they receive, with the opportunity to provide comments and suggestions.

				[image: check.png] Always keep your content fresh. Stale information and features can deter return visits and ruin first impressions.

				[image: check.png] Respond immediately to problems that surface. Don’t ignore or put off broken links, images, or misspellings.
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				Chapter 1: Getting Started  in Flash CS6

				In This Chapter

				[image: check.png] Creating, saving, and opening documents

				[image: check.png] Getting familiar with the workspace and tools

				[image: check.png] Creating and saving workspaces

				[image: check.png] Introducing Flash Player

				[image: check.png] Understanding layers

				[image: check.png] Importing and exporting files

				[image: check.png] Understanding the publishing process

				Flash has been the staple application for developing highly interactive motion graphics and interactive content for the web for over a decade. With a familiar CS interface, robust drawing and animation tools and a powerful built-in scripting language, Flash is capable of building full websites, complex games, and highly functional, rich Internet applications. Many of the most popular websites have been built and defined on Flash technology.

				Although previous versions of Flash have focused primarily on authoring for the Flash platform, Flash CS6 allows for the publishing of content as desktop, native iOS and Android mobile applications using the AIR (Adobe Integrated Runtime) platform.

				Creating Your First Flash Document

				You can create new documents for a few different types of projects in Flash, but the most common will be Flash (ActionScript 3.0) .You can create a new, blank document and set up your workspace in one of two ways:

				[image: check.png] From the start page, choose Flash File (ActionScript 3.0) under the Create New column.

				[image: check.png] Choose File⇒New⇒Flash File (ActionScript 3.0).

				Your new document is created and the workspace appears. Before you get to work, specify some important settings, such as width and height, for your file by using the Document Properties dialog box.

				To open the Document Properties dialog box, choose Modify⇒Document and set these options:

				[image: check.png] Frame Rate: Because Flash files behave like movies, the frame rate is an important setting that affects the performance and playback speed of your movie. The default setting of 24 frames per second (fps) should work well.

				[image: check.png] Dimensions: The width and height you specify determine the size of your stage and in turn, the visible area of your finished movie. For now, leave the default setting of 550 pixels wide by 400 pixels high.

				[image: check.png] Background Color: Click the swatch to pick a background color for your stage from the web-safe color palette. This setting also determines the background color of any web pages created by Flash when you publish your movie to the web.

				[image: check.png] Ruler Units: Select from this drop-down list the unit of measurement used for all measurement values in your document, including document size, width and height values, and ruler increments when rules are  visible in the workspace.

				[image: check.png] Auto-Save: Select this check box to enable auto-save at an interval you specify. 

				When you’re done fine-tuning your document’s properties, click OK.

				Getting Familiar with the Workspace

				On the Flash workspace, shown in Figure 1-1, you create your Flash movies. The most prominent item you’ll notice is at the top of your screen: The stage is where the action happens — where you draw, build, or import graphics, create text, and construct layouts.

				The gray area surrounding the stage is the pasteboard. Items placed on it aren’t visible in your finished movie because they’re outside the bounds of the stage. However, it helps to think of this area as the backstage — where text, artwork, and images can make their entrances or exits or be placed until they’re ready to appear in your movie.

					

				
					Figure 1-1: The Flash workspace.

				

					[image: 9781118168608-fg070101.eps]

				The Tools panel

				What CS6 application would be complete without a fancy toolbar? Flash has a comprehensive set of tools for just about any drawing task you need to wrap your hands around. Table 1-1 gives you a rundown and description of the tools you’ll find. The Tools panel has been redesigned to make your work area flow more smoothly. A double arrow at the top lets you toggle between expanded and icon views to maximize your work area.

				[image: tip.eps]	Click and hold down your mouse on a tool to reveal other tools underneath. For example, hold down your mouse button on the Rectangle tool to reveal the Oval, Rectangle Primitive, and Oval Primitive tools.

				Table 1-1	The Tools Panel

				
					
						
								
								Button

							
								
								Tool Name/Keyboard Command

							
								
								What You Can Do with It

							
						

						
								
								[image: 9781118168608-ma206.tif]

							
								
								Selection (V)

							
								
								Select and move objects on the stage and work area

							
						

						
								
								[image: 9781118168608-ma104.tif]

							
								
								Subselection (A)

							
								
								Select and move specific points on a path or a shape

							
						

						
								
								[image: 9781118168608-ma008.tif]

							
								
								Free Transform (Q)

							
								
								Change an object’s dimensions,  rotation, or proportions

							
						

						
								
								[image: 9781118168608-ma179.tif]

							
								
								Gradient Transform (F)

							
								
								Change the size, intensity, and  direction of a gradient fill

							
						

						
								
								[image: 9781118168608-ma140.tif]

							
								
								3D Rotation (W)

							
								
								Translate 2D artwork into the 3D plane and rotate it around an x, y, and z axis

							
						

						
								
								[image: 9781118168608-ma141.tif]

							
								
								3D Translation (G)

							
								
								Click and drag artwork along the x, y, or z axis to illustrate depth and distance

							
						

						
								
								[image: 9781118168608-ma215.tif]

							
								
								Lasso (L)

							
								
								Create freehand selections around one or more points

							
						

						
								
								[image: 9781118168608-ma216.tif]

							
								
								Pen (P)

							
								
								Create accurate, point-by-point straight and curved paths

							
						

						
								
								[image: 9781118168608-ma154.tif]

							
								
								Add Anchor Point (=)

							
								
								Add anchor points along an existing path

							
						

						
								
								[image: 9781118168608-ma155.tif]

							
								
								Delete Anchor  Point (-)

							
								
								Remove anchor points from an existing path

							
						

						
								
								[image: 9781118168608-ma156.tif]

							
								
								Convert Anchor  Point (C)

							
								
								Change the curve orientation of an existing point

							
						

						
								
								[image: 9781118168608-ma217.tif]

							
								
								Text (T)

							
								
								Create text on the stage

							
						

						
								
								[image: 9781118168608-ma131.tif]

							
								
								Line (N)

							
								
								Draw straight lines

							
						

						
								
								[image: 9781118168608-ma257.tif]

							
								
								Shape Tools (R, O)

							
								
								Create rectangular, oval, or multisided shapes on the stage

							
						

						
								
								[image: 9781118168608-ma258.tif]

							
								
								Primitive Tools (R, O)

							
								
								Create rounded rectangles and multi­radiused ovals that can be modified

							
						

						
						
								
								[image: 9781118168608-ma221.tif]

							
								
								Pencil (Y)

							
								
								Draw freehand paths

							
						

						
								
								[image: 9781118168608-ma220.tif]

							
								
								Brush (B)

							
								
								Draw broad, freehand fill areas

							
						

						
								
								[image: 9781118168608-ma159.tif]

							
								
								Spray Brush (B)

							
								
								Create a spattered, airbrush-like painting with symbols from the library

							
						

						
								
								[image: 9781118168608-ma133.tif]

							
								
								Deco (U)

							
								
								Create animated or non-animated flower-and-leaf style fills or symmetrical artwork with symbols

							
						

						
								
								[image: 9781118168608-ma135.tif]

							
								
								Bone (M)

							
								
								Join shapes or symbols with virtual “bones” for creating posable inverse kinematics (IK) objects

							
						

						
								
								[image: 9781118168608-ma136.tif]

							
								
								Bind (M)

							
								
								Edit connections between objects  created using the Bone tool

							
						

						
								
								[image: 9781118168608-ma294.tif]

							
								
								Paint Bucket (K)

							
								
								Apply or modify the fill color of an area

							
						

						
								
								[image: 9781118168608-ma161.tif]

							
								
								Ink Bottle (S)

							
								
								Apply or modify the stroke color and style of a shape or path

							
						

						
								
								[image: 9781118168608-ma004.tif]

							
								
								Eyedropper (I)

							
								
								Sample the color property from an object

							
						

						
								
								[image: 9781118168608-ma235.tif]

							
								
								Eraser (E)

							
								
								Erase parts of a fill or path

							
						

						
								
								[image: 9781118168608-ma237.tif]

							
								
								Hand (H)

							
								
								Reposition the stage and work area within the workspace

							
						

						
								
								[image: 9781118168608-ma238.tif]

							
								
								Zoom (Z)

							
								
								Zoom in or out of a selected area of the stage

							
						

					
				

				The Timeline

				Below the stage sits the Timeline, where you bring your artwork to life through animation. The Timeline is composed of frames, each one representing a point in time moving from left to right. The Timeline is further broken out into layers; new documents automatically contain one new layer labeled Layer 1. Each layer on the Timeline is composed of frames that span horizontally from left to right, each one representing a point in time, just like frames in a movie reel. (See Figure 1-2.)

					

				
					Figure 1-2:  The Timeline contains frames, and layers.

				

					[image: 9781118168608-fg070102.eps]

				The Motion Editor

				The Motion Editor lets you see and modify all properties of an animation in a graph-style format. All properties that can be animated are displayed in rows, each of which contains a value line that can be manipulated to change the behavior of a selected tween. You can also add complex forces, such as gravity and inertia, and even add to or subtract from your tween without using the Timeline or stage.

				The Property inspector

				Sitting at the right side of your workspace, the Property inspector lets you get (and set) attributes, such as height and width, for a selected item on the stage or work area. (See Figure 1-3.) The contextual Property Inspector displays adjustable options for any item you select on the stage, such as width and height for a selected shape or fill and stroke color. When you don’t have any objects on the stage selected, the Property inspector will display global document properties such as frame rate.

				[image: tip.eps]	To modify a document’s properties, such as frame rate and dimensions, at any time, either use the Property inspector when no items on the stage are selected (try clicking the pasteboard area) or choose Modify⇒Document.

				Panels (right side)

				The numerous panels included in Flash give you total control over most aspects of your movie, from creating and managing colors to exploring the structure of your project and adding code to frames.

					

				
					Figure 1-3:  The Property inspector shows options for selected graphics, symbols, frames, or tools.

				

					[image: 9781118168608-fg070103.eps]

				The default (Essentials) workspace launches with the Property inspector and Library panel in full view, as well as a minimized group of eight panels that include

				[image: check.png] Color

				[image: check.png] Swatches

				[image: check.png] Align

				[image: check.png] Info

				[image: check.png] Transform

				[image: check.png] Code Snippets

				[image: check.png] Components

				[image: check.png] Motion Presets

				[image: check.png] Project

				Get familiar with panel behaviors and features so that you can manage their appearance and make organizing your workspace a snap.

				Taking a look at the panel group

				The panel group sits on the right side of the workspace and features multiple grouped panels. Panels can be added to or removed from the panel group on the right.

				While docked, you can’t freely reposition the panel group in the workspace. However, you can resize or collapse it to icon view with the double arrows found in its upper-right corner.

				You can remove and float panels from the panel group. Simply click and drag a panel away from the group by its title tab. To add a panel to the group, drag it into the panel group on the right.

				Managing individual panels

				You can position each panel individually anywhere in the workspace by dragging it by its title tab. You can find additional appearance options under each panel’s menu, accessible from the icon in its upper-right corner. (See Figure 1-4.) This panel menu also provides another way of reaching that panel’s primary tasks.

					

				
					Figure 1-4: Anatomy of a panel.

				

					[image: 9781118168608-fg070104.eps]

				To group panels, simply drag one on top of the other; after they’re grouped, you can move and minimize several panels as one unit. This technique is handy for keeping commonly used or related panels together.

				You can save panel groups and panel positions as part of custom workspaces. (See the next section, “Creating and Saving Workspaces.”)

				
					
				
				[image: tip.eps]	Panels can always be toggled on or off from the Window menu. If you don’t see a panel you need or have accidentally closed one, look for it on the Window menu. Many panels have shortcut keys; if you use a panel often,  use its shortcut key combination for easy access.

				Creating and Saving Workspaces

				One of the most useful additions in recent versions of Flash is its ability to save your workspaces, or the appearance and layout of workspace items such as the toolbar, Timeline, Property inspector, and panels.

				Saving workspaces is essential if you’re sharing a computer workstation with other people and want to recall your favorite panels and setup instantly. However, a workspace can also be useful for maintaining different views for different projects, even if you’re the only person working on your computer.

				To create and save your workspace layout, follow these steps:

					1.	Open and position any panels you want to make available, including the Tools panel, Timeline, Motion Editor, and Property inspector.

						You can toggle panels on or off from the Window menu.

					2.	Choose Window⇒Workspace⇒New Workspace.

					3.	Enter a new name for your workspace and click OK.

				[image: tip.eps]	To recall a workspace, choose Window⇒Workspace⇒Your Workspace Name or select a workspace from the Workspace selector in the upper-right corner of your screen. The current workspace rebuilds and appears exactly as you saved it.

				You can view all saved workspaces at any time by choosing Window⇒Workspace⇒Manage Workspaces. From this dialog box, you can also choose to delete or rename existing workspaces.

				[image: remember.eps]	You can’t modify, delete, or rename built-in workspaces, such as Default, Classic, and Designer.

				Saving and Opening Documents

				Always save a document after you make significant changes or additions to it, and always save (though it isn’t necessary) a new document immediately after you create it. To save a document, choose File⇒Save. Enter a name for the file and choose a location on your hard drive to save it. You can save Flash work files in .fla format or the new .xfl file format.

				To open an existing document, choose File⇒Open and locate the Flash file on your hard drive. Flash files are saved using the .fla extension, and published Flash movies are saved using the .swf extension.

				You may need at some point to save a copy of your document under a new name, to either create an alternative version or perhaps make it compatible with an older version of Flash. Flash CS6 can save .fla files in CS5 format to make it compatible with the previous version of Flash.

				Like many applications, Flash CS6 now includes an auto-save function, which can be enabled for any document. You can specify an interval (for instance, every 10 minutes) at which your document is automatically saved. This is essential to avoid loss of work in the event your computer experiences a crash, the Flash application crashes, or you accidentally turn off the machine.

				To enable Auto-Save, choose Modify⇒Document and select the Auto-Save check box. Specify an interval in minutes (as shown in Figure 1-5) and click OK.

					

				
					Figure 1-5: The new Auto-Save feature can be set for any document.

				

					[image: 9781118168608-fg070105.eps]

				[image: remember.eps]	Flash CS5 can’t open CS6 .xfl or Flash CS6–format .fla files. To share a file with someone using Flash CS5, choose File⇒Save As⇒Flash CS5 Document (*.fla).

				To save a copy of your document under a new name, choose File⇒Save As. Choose a location on your hard drive and enter a new filename. The drop-down list at the bottom of the Save As dialog box lets you choose which version of Flash in which to save the file. For example, you can save files into Flash CS5 format (a format one version earlier than CS6).

				FLA versus XFL File Format

				The XFL file format (introduced in CS5) is an uncompressed file format that results in a project folder containing a number of .xml files and any original assets (such as images and audio files) that you may have imported into your project’s library. Because of this open file format, resources in your project can be exchanged with and opened in other applications. The XFL file format enables exchange between Flash and other Creative Suite applications, and opens up the possibility of Flash files eventually being editable in other applications.

				The traditional FLA file format combines all your project’s vital information and resource files into a single file, making it more portable but less likely to exchange with other applications. You don’t have direct access to assets you’ve imported into your project; for most purposes, however, the standard FLA file format is suitable, especially if Flash CS6 Professional is your sole editor for Flash applications.

				[image: warning_bomb.eps]	Saving a document in an older version of Flash may make some newer features unavailable. Avoid saving files in an older file format unless you absolutely need to open them in an older version of Flash.

				Getting to Know Flash Player

				Flash Player is at the heart of Flash technology. The player, which you can find as a plug-in to web browsers or as a standalone application, runs and plays completed Flash movies, known as SWF (“swiff”) files.

				Beyond simple playback, Flash Player is also responsible for deciphering and carrying out instructions written in ActionScript, the powerful, built-in Flash scripting language. ActionScript, discussed in Chapter 7 in this minibook, gives your Flash movies many more capabilities, including playback control, real-time user interaction, and complex effects.

				Users must have Flash Player installed in order to view movies, unless you are publishing as HTML or AIR (including AIR for iOS and Android). If you don’t have it installed, you can get the free download from the Adobe website at www.adobe.com. Fortunately, the Flash Player is installed on over 90 percent of Internet-enabled PCs on average worldwide.

				Talking about Layers

				If you’ve worked with other programs that use layers (such as Photoshop or Illustrator), the concept is much the same as using layers to arrange and stack artwork in these applications. If you’re new to layers, think of them as clear pieces of film stacked on top of each other. Each layer can contain its own artwork and animations.

				In Flash, you use layers to stack artwork and animations on the stage, allowing them to exist together visually but to be edited or moved independently from one another. You can reorder layers to position artwork in front of or behind artwork on other layers.

					[image: 9781118168608-ma195.tif]	To create a new layer, click the New Layer icon at the bottom of the Timeline. The layer is automatically assigned a name; you can rename any layer by double-clicking its name and typing a new name.

				To delete a layer, follow these steps:

					1.	In the Timeline window below the stage, select the layer you want to delete.

						Hold down Command (Mac) or Ctrl (Windows) to select multiple layers. You can then click the Trash icon to delete all selected layers at one time.

						2.	[image: 9781118168608-ma228.tif] Click the Delete Layer icon below the Timeline.

				The beauty of working with layers is that you can easily change the stacking order and appearance of artwork and animations distributed across those layers. To reorder layers, simply select a layer by clicking its label on the Timeline and then click and drag the layer up or down in the stacking order and release it to its new position. (See Figure 1-6.) Layers at the top of the list appear in front of other objects in lower layers; in contrast, layers at the bottom of the list appear below or behind items on higher layers.

					

				
					Figure 1-6: Shuffling layers is easy — just drag and release.

				

					[image: 9781118168608-fg070106.eps]

				Two additional aspects of managing layers include toggling a layer and its contents to be visible or invisible and locking layers to prevent their contents from being accidentally moved or modified.

					[image: 9781118168608-ma129.tif]	To toggle a layer’s visibility on or off, click any layer in the column below the Eye icon (an X will appear, indicating the layer’s visibility is off). To toggle all layers on or off, click the Eye icon at the top of the column.

					[image: 9781118168608-ma130.tif]	To prevent layer contents from being modified, click any layer in the column below the Padlock icon. To unlock it, click the Padlock icon again. To lock or unlock all layers, click the Padlock icon at the top of the column.

				Locking layers ensures that you don’t accidentally move or delete the artwork it contains. Make a habit of locking layers whenever you aren’t working with them.

				
					
				
				[image: remember.eps]	Layer visibility affects only what you see inside the authoring environment and has no effect on the finished SWF file. By default, layers whose visibility is toggled off in your document still appear when published. You can, however, override this behavior in your document’s publish settings, discussed in Chapter 9 of this minibook.

				Importing Files

				Sometimes you need to use assets — such as artwork or photo files created in Adobe Photoshop or Illustrator, MP3 sound files, and even video files —  that weren’t created in Flash. Here are some of the file formats you can import into your Flash movie:

				[image: check.png] Images: EPS, GIF, JPEG, PNG, TIFF

				[image: check.png] Flash SWF

				[image: check.png] Layered artwork files: AI (Adobe Illustrator) and PSD (Photoshop)

				[image: check.png] Audio files: AIFF, MP3, and WAV

				[image: check.png] Video files: DV, F4V, FLV, MOV, MPEG, QuickTime

				You can import these types of files directly to the stage for immediate use or to your document’s library (see Chapter 3 of this minibook) for storage until you’re ready to place them on the stage.

				Follow these steps to import files to the stage:

					1.	Choose File⇒Import⇒Import to Stage.

					2.	Select from your hard drive the file or files you want to import.

						Imported items are placed on the stage on the selected layer and frame.

				Follow these steps to import files directly to the library:

					1.	Choose File⇒Import⇒Import to Library.

					2.	Select the files from your hard drive that you want to import and click the Open button.

						Imported files don’t appear on the stage but are available in the Library panel for later use.

				[image: tip.eps]	To select multiple files for import, hold down Ctrl (Windows) or Command (Mac) when prompted to select files from your hard drive. You can bring several files to the stage or library in one step.

				FLA and XFL files

				The life of a Flash project involves at least two types of files: your authoring (FLA or XFL) file, in which all your work is created, and the final product, your compressed movie or SWF file.

				FLA and XFL are used only during the authoring process. When you’re ready to distribute your finished movie, publish a SWF file that can be displayed by Flash Player.

				These SWF files can be created from either  the Publish or Export menu options and are compressed movie files (typically smaller than their FLA and XFL counterparts) that contain all the graphics and information necessary to display your movie.

				Flash Player can’t read FLA or XFL files, and SWF files can’t be deconstructed into usable FLA files. Changes to your Flash movie are always made in the original FLA or XFL file and must be exported to a new SWF file again if you want to view them in Flash Player.



				Exporting Files from Flash

				In contrast to the Import menu, the Export menu is used to generate files from your current document out of Flash, most often to create a compressed SWF file (movie) for final delivery. Additionally, you can use the menu to generate static (such as JPEG or GIF) images from specific frames in your movie.

				Publishing Your Movie

				The final step in preparing your movie to be posted on the web, or distributed as a mobile or desktop application is the publishing process, which includes these important tasks:

				[image: check.png] For web publishing: Export the final SWF or HTML file that’s playable by Flash Player and create all additional files (such as web pages and JavaScript) necessary to display your movie.

				[image: check.png] For desktop applications: Create an AIR application that’s viewable in the AIR runtime that runs on the desktop.

				[image: check.png] For distribution as a mobile application: Create AIR applications for iOS or Android platforms.

				[image: check.png] Other: Publish to OS-specific projectors for standalone playback, or other file types such as SWC and Flash Lite.

				Publish Settings (File⇒Publish Settings) handles the setup and publication of your movie.

				Flash can create all these file types at publish-time:

				[image: check.png] SWF: This is the most common format in which you’ll publish your Flash movies. SWF files are playable in the Flash player/plug-in and are compressed, ready-to-view versions of your original file.

				[image: check.png] SWC: For sharing and distributing your movie as a library.

				[image: check.png] HTML Wrapper: Formerly just “HTML” in previous versions, this now refers to the HTML page generated to contain SWF movies for web viewing.

				[image: check.png] JPG, GIF, or PNG: You can create static images from the first frame of your Flash movie in these web-friendly image formats. These are useful for a number of purposes, including previews or stand-ins when the Flash plug-in is not available.

				[image: check.png] Projector: If you want to distribute your movie as a standalone file, you can create a Mac or PC compatible projector that includes Flash Player. Projectors are good in situations where you want to distribute a movie offline and not require your users to download the Flash player.

				Chapter 9 of this minibook explores publishing in more detail.

				

			

			
		

	
		
			
				Chapter 2: Drawing in Flash CS6

				In This Chapter

				[image: check.png] Creating shapes and lines

				[image: check.png] Editing and selecting shapes

				[image: check.png] Tweaking and splicing shapes and lines

				[image: check.png] Transforming shapes and artwork

				[image: check.png] Creating and modifying text

				[image: check.png] Working with colors and gradients

				[image: check.png] Using the Brush tool

				Many great creations start with the most basic shapes and build from there. In this chapter, you discover the secrets of drawing shapes and lines and working with colors in Flash. If you’re accustomed to drawing in other Adobe applications such as Illustrator, you’ll find a lot of the same tools and principles apply here.

				Drawing Shapes and Lines

				To get your creation started, become familiar with the Shape and Line tools on the Tools panel and use them as the starting point for everything from basic buttons to complex illustrations.

				When you’re ready to create more complex artwork beyond the capabilities offered by the Shape and Line tools, the Pen and Pencil tools are standing by. These tools work quite differently, and for that reason should be chosen based on the kind of artwork you want to create.

				The following sections show you how to get started creating basic shapes and lines.

				Drawing basic shapes with the shape tools

					[image: 9781118168608-ma094.tif]	On the Tools panel, locate the Rectangle tool; also notice a small arrow in the lower-right corner of the icon, which means that more tools are hidden underneath. Click and hold the Rectangle tool to reveal the Oval and Polystar tools; select the shape tool you want to use.

				Before you draw the shape, set some colors for it by using the two swatches at the bottom of the Tools panel. The Fill color swatch (indicated by the paint bucket icon) lets you specify a color to fill your shape. The Stroke Color swatch (indicated by the pencil icon) controls the outline color.

				Flash lets you choose colors from the Swatches panel. You can add your own colors to this panel, but for now, choose one of the available colors for your shape’s fill and stroke.

				[image: tip.eps]	Click and drag on the stage to create a shape. Notice that shapes are drawn by default from the left corner outward. You can draw shapes from the center (which is sometimes easier) by holding down the Option (Mac)  or Alt (Windows) key while drawing the shape.

				To constrain a shape proportionally, hold down the Shift key while drawing or resizing.

				Merging shapes

				If you overlap two or more shapes in Flash, they automatically merge, or become one complete shape. You can take advantage of this behavior by using an overlapping shape to knock out another, or you can make more complex shapes by combining simpler ones.

				You may also find that using overlapping strokes results in divided fill areas, which can be a desirable effect. Experiment by drawing and overlapping shapes and using the Selection tool to select parts of the resulting object.

				Creating perfect lines with the Line tool

					[image: 9781118168608-ma131.tif]	The Line tool makes constructing perfect, straight lines quick and easy. To create a straight line, choose the Line tool from the Tools panel, click and drag on your stage where you want the line to start and release the mouse button where you want the line to end.

				To modify your line’s color or appearance, select it with the Selection tool and use the Property inspector to change the stroke color and size. You also find a Style drop-down list, which lets you choose among straight, dotted, dashed, and artistic stroke styles.

				[image: tip.eps]	To create perfectly vertical or horizontal lines, hold down the Shift key while using the Line tool. You can also create diagonal lines in 45-degree increments by using this same method.

				Creating lines and curves with the Pen tool

				Using the Pen tool may be a bit different from tools you’re used to, unless, of course, you’ve used the Pen tool in applications such as Illustrator or Photoshop. The Pen tool isn’t a freehand drawing tool; rather, you use it to create paths, or outlines, composed by connecting anchor points. When you click and create new points, lines are automatically drawn to connect those points. You can then either bend those lines into precise curves or leave them straight.

				The best way to understand the Pen tool is to practice working with it. Visualize a shape you want to draw (for example, a leaf) and try to create it with the Pen tool.

				To get started, follow these steps:

					1.	Select the Pen tool from the Tools panel.

					2.	Use the Color swatch on the bottom of the Tools panel to set a stroke color.

					3.	Click to set the first point on the stage and then construct a line by clicking again to set a second point where you want the line to end.

					4.	Click to set a new point and before releasing the mouse button, drag to the left or right to bend the new line into a curve.

						The more you drag in a particular direction, the more extreme the curve you create.

					5.	Continue creating new points and experimenting with different curves.

					6.	Move your mouse pointer over the first point you created (a loop appears above the icon) and click to close the path and complete the shape.

				[image: tip.eps]	The Pen tool attempts to continue a curve in the same direction even after a new point is set. To reset the last point drawn back to a straight line, hold down the Option (Mac) or Alt (Windows) key and click the last point created before setting a new one.

				Drawing freehand with the Pencil tool

				The precise nature of the Pen tool is great for certain situations, but if you prefer the intuitive feel of freehand drawing or want to create more natural or rough artwork, consider using the Pencil tool.

				An attractive feature of the Pencil tool is that it has three different modes to choose from. Each mode provides a different level of smoothing, so even if your hand isn’t the steadiest, the Pencil tool compensates by automatically smoothing out lines or curves while you create them.

					[image: 9781118168608-ma221.tif]	Select the Pencil tool and choose the appropriate smoothing mode using the selector in the lower-right corner of the Tools panel:

				[image: check.png] Straighten: Forces lines to the nearest straight line; perfect for drawing or tracing straight edges or boxy outlines.

				[image: check.png] Smooth: Smoothes out lines or curves to the next closest perfect curve.

				[image: check.png] Ink: Provides less smoothing and keeps lines and curves as natural as possible.

				[image: remember.eps]	The mode you select depends completely on what type of shapes and lines you’re trying to draw. If your shape is more diverse than one mode can handle, you can switch modes from line to line as needed.

				Selecting and Editing Shapes

					[image: 9781118168608-ma206.tif]	After you create a shape, you can select and move it by using the Selection tool at the top of the Tools panel. Flash shapes are easy to edit because you can select the stroke and fill independently to separate one from the other.

				To select and move the stroke or fill only, follow these steps:

					1.	From the bottom of the Tools panel, choose a Stroke and Fill color using the color swatches.

					2.	Choose either the Rectangle or Oval tool, and click and drag on the stage to draw a new shape.

					3.	Select the Selection tool from the Tools panel.

					4.	Click either your shape’s stroke or fill once to activate it.

						To select the entire shape, double-click the fill of your shape or use the Selection tool to drag around it on the stage. (See Figure 2-1.)

					

				
					Figure 2-1: A selected fill (left) and stroke (right).

				

					[image: 9781118168608-fg070201.eps]

					5.	Click and drag the selected stroke or fill or use the arrow keys to separate it from the rest of the shape.

				Modifying fill and stroke colors

				You can choose your fill and stroke colors ahead of time before you start drawing, but if you change your mind, modifying colors is easy to do.

				You can modify either the fill or stroke colors of a preexisting shape in these three ways:

				[image: check.png] Select the entire shape and change its fill and stroke colors from the swatches in the Property inspector. (See Figure 2-2.)

					

				
					Figure 2-2: Use the Property inspector to change the shape’s fill or stroke color.

				

					[image: 9781118168608-fg070202.eps]

				[image: check.png] Select the entire shape and change the fill and/or stroke colors by using the Fill and Stroke swatches on the Tools panel.

				[image: check.png] Specify colors on the Tools panel and use the Ink Bottle tool by clicking the stroke or use the Paint Bucket tool by clicking the fill.

				To apply a fill color to your shape, select it on the stage and choose a color from the Fill swatch at the bottom of the Tools panel. To apply a stroke color, select the stroke on your shape and choose a color from the Stroke swatch at the bottom of the Tools panel. Alternately, you can choose the Paint Bucket tool and click on the fill of your shape to change the fill color, or select the Ink Bottle tool and click the edge of your shape once to set a stroke with the selected color.

				[image: tip.eps]	You can also set Fill or Stroke colors from the Fill and Stroke section of the Property inspector when the Ink Bottle or Paint Bucket tools are selected.

					[image: 9781118168608-ma117.tif]	To remove a fill or stroke completely, select a shape and select None from either the Fill or Stroke color swatch.

				Merge versus Object Drawing mode

				Being able to freely tear apart shapes can be quite flexible and useful, though some people prefer to work with shapes as single objects (similar to how shapes in Illustrator CS6 behave). For this reason, Object Drawing mode was created; this optional mode automatically combines the stroke and fill of a shape into a single object, which you can move and resize as a whole. A shape drawn in Object Drawing mode has a bounding box around it; the stroke and fill are moved together as one object.

					[image: 9781118168608-ma132.tif]	You can enable Object Drawing mode when any drawing or shape tool is selected, as shown in Figure 2-3, by clicking the Object Drawing mode button at the bottom of the Tools panel. Try drawing a shape on the stage — notice that the shape appears with a bounding box around it and that the stroke and fill can no longer be individually selected and separated.

					

				
					Figure 2-3: A shape drawn in Object Drawing mode.

				

					[image: 9781118168608-fg070203.eps]

				To break apart a shape drawn in Object Drawing mode to a separate stroke and fill, select the shape and choose Modify⇒Break Apart. You can also double-click the shape to edit it within the Drawing Object itself.

				[image: warning_bomb.eps]	Unlike shapes drawn in Standard mode, drawing objects can’t be merged simply by overlapping them; break apart any drawing objects first or choose Modify⇒Combine Objects⇒Union to merge them.

				Splicing and Tweaking Shapes and Lines

				You can easily dissect mergeable shapes (not drawing objects) by selecting only certain portions with the Selection or Lasso tools, as shown in Figure 2-4. Try drawing a marquee around only half the shape with the Selection or Subselection arrow; notice that only half the shape or line becomes selected, and you can then separate it.

					

				
					Figure 2-4: To reshape, use the Selection tool to grab an edge or a corner.

				

					[image: 9781118168608-fg070204.eps]

				Tweaking a shape with the Selection  and Subselection tools

				If you need to tweak the shape beyond its original form, you can use Selection or Subselection tools to tweak, distort, and reshape. To tweak or reshape with the Selection tool, move it outside and close to an edge or corner of your shape; notice that a small curved or angled line icon appears next to your pointer. Click and drag to bend, reshape, or distort the outline of your shape, as shown in Figure 2-5.

					

				
					Figure 2-5: To modify a curve with the Selection tool, drag  an edge.

				

					[image: 9781118168608-fg070205.eps]

				[image: tip.eps]	You can use the Selection tool to bend straight edges into curves. Try it on a line or straight edge from a rectangle, and you’ll see that you can easily pull the line into a curve!

				To tweak or reshape with the Subselection tool, click the outside edge or stroke of a shape to activate its path. Each point is represented by a hollow box. Click any point to activate it; click and drag it or move it using the arrow keys to reshape. (See Figure 2-6.)

					

				
					Figure 2-6: Use the Subselection tool to modify specific points.

					
				

					[image: 9781118168608-fg070206.eps]

				Editing a shape with the Lasso tool

				When you need to create a selection with more precision than the Selection tool allows (for example, around an odd shape or a tricky area), use the Lasso tool. The Lasso tool draws freehand selections around specific areas of your artwork. To draw a selection with the Lasso tool, select it from the Tools panel and click and drag to draw a selection around the target area, as shown in Figure 2-7. Be sure to close the selection by overlapping the starting and ending points.

					

				
					Figure 2-7: Select areas with the Lasso tool; close the path for best results.

				

					[image: 9781118168608-fg070207.eps]

				You can perform partial selections only with raw (broken apart) shapes and lines. Artwork drawn in Object Drawing mode needs to be broken apart first (choose Modify⇒Break Apart) or modified in Edit mode. To enter a drawing object’s Edit mode, double-click it with the Selection tool.

				Modifying artwork created by using  the Pen and Pencil tools

				Interestingly enough, although the Pen and Pencil tools behave in completely different ways, both ultimately create the same element: a path. A path can be filled (if closed) or modified on a point-by-point basis, or you can apply a stroke to it.

				To fine-tune a path, choose the Subselection tool (the white arrow) from the Tools panel. Click the path; it becomes highlighted, and the points show up as hollow boxes. You can now select any individual point and selectively drag it or move it with the arrow keys to reshape the path.

				To adjust a curve by using the Subselection tool, highlight the point adjacent to the curve you want to modify. A handle appears; you can grab and move this handle to adjust the curve.

				To add or subtract points, click and hold down on the Pen tool to select the Add Anchor Point or Subtract Anchor Point tools. Click exactly on the path where you want to add an anchor point or click a point directly to remove it.

				Transforming Artwork and Shapes

				After you have some drawing done, you may want to adjust the width, height, or rotation of your artwork. Depending on the level of precision you’re looking for, you can do this in two ways: manually by using the Transform tool or by dialing in exact values on the Transform panel.

				Using the Free Transform tool

					[image: 9781118168608-ma008.tif]	Select a shape or some artwork on your stage and then choose the Free Transform tool from the Tools panel. A bounding box with handles at all four sides and corners appears, as shown in Figure 2-8. You can drag any of the side handles to resize the width and height.

					

				
					Figure 2-8:  Using the Free Transform tool to rotate and resize.

				

					[image: 9781118168608-fg070208.eps]

				To rotate your artwork, hover over any corner handle until you see the rotation icon (a circular arrow) and then click and drag to rotate the artwork freely.

				To resize your art proportionally, hold down the Shift key while dragging a handle. If you hold down the Shift key while in Rotation mode, it limits your movements to precise 45-degree increments.

				Using the Transform panel

				For those times when you need to dial in exact transformation values,  you can use the Transform panel (shown in Figure 2-9); choose Window⇒Transform to open it. The Transform panel displays text boxes you can use to enter exact transformation values for width and height or a specific rotation angle in degrees.

					

				
					Figure 2-9:  Enter precise amounts of scaling, rotation, and skewing.

				

					[image: 9781118168608-fg070209.eps]

				Follow these steps to transform artwork by using the Transform panel:

					1.	Select the object you want to transform on the stage and open the Transform panel by choosing Window⇒Transform.

					2.	To increase the size of the artwork, enter width and height percentage values higher than 100 percent; to decrease the size, enter values less than 100 percent. To keep the sizes proportional, select the Constrain icon.

					3.	To rotate your artwork, select the Rotate radio button, click the number to activate the text box, type a value higher than 0 degrees, and press Enter.

						Rotation is performed clockwise; to rotate counterclockwise, enter a negative number.

				Skewing your artwork

				Skewing transforms your artwork on a 3D plane and can add interesting perspective to shapes. You can perform skewing from the Transform panel by selecting the Skew radio button and entering values for horizontal and vertical skew amounts.

				Give it a try: Select your shape, type some skew values, and press Enter to see the transformation applied. If you’re not happy, don’t fret; simply click the Remove Transform button in the lower-right corner of the Transform panel to restore your normal settings.

				Working with Type

					[image: 9781118168608-ma217.tif]	If you’re looking to display important information in your Flash movie or you simply want to add creative text elements to your design, the flexible Text tool in Flash can create attractive type for design elements, buttons, titles, and informational text areas.

				TLF versus classic text

				Flash CS6 features several new typesetting improvements in the new TLF (Text Layout Framework) text engine, bringing to the table many abilities already found in applications such as Illustrator and InDesign.

				Here are the new Flash TLF text features:

				[image: check.png] Vertical and Vertical Left-to-Right orientation

				[image: check.png] Multicolumn text areas

				[image: check.png] Threaded text across several type areas

				Though TLF text is the default when you work with the Text tool, you still have the option to set text areas as classic text, providing support for older movies and projects.

				Follow these steps to create basic type on the stage:

					1.	In a new or existing file, add a new layer to the Timeline by choosing Insert⇒Timeline⇒ Layer.

					2.	Choose the Text tool from the Tools panel.

					3.	Click anywhere on the stage to create a text box and then enter some text.

					4.	Click and drag within the text box to select all the text you just entered, as shown in Figure 2-10.

					5.	Fine-tune the appearance of your text by selecting character, color, size, and other options in the Character section of the Property inspector.

					

				
					Figure 2-10: Use the Property inspector to modify typeface, style, size, and color.

				

					[image: 9781118168608-fg070210.eps]

				Creating multicolumn and threaded text

				Like many existing Adobe applications, Flash now lets you split single text areas into multiple columns as well as thread text across several individual text boxes at once. This capability is especially handy if the amount of text in a box is too large for that area alone; using threaded text, you can make text that originates in one box flow into a different box elsewhere in your movie.

				To create multicolumn text, follow these steps:

					1.	In a new or existing file, add a new layer to the timeline by choosing Insert⇒Timeline⇒Layer.

					2.	Select the Text tool from the Tools panel. Make sure that the text drop-down list at the top of the Property Inspector (below the <Instance Name> field) is set to TLF Text.

					3.	Click and drag on the stage to create a text box that has a fixed width and height.

						The text box appears with a bounding box and handles on all four sides and corners, as shown in Figure 2-11.

					4.	To adjust the size of the box, hover the mouse pointer over a handle on any corner or side until a double arrow appears. Click and drag the handle to resize the box.

					5.	Click within the box and either type or paste some text into the box.

						For best results, enter enough text until you eventually see a red plus sign appear on the out port (see Figure 2-11) of the box.

					

				
					Figure 2-11: Anatomy of a text box (left). The new text box ruler guide (right).

				

					[image: 9781118168608-fg070211.eps]

				[image: remember.eps]		Typing too much text in a fixed-size text box creates an overrun, indicated by a red plus sign in the out port of the text box.

					6.	With the Text tool still active, locate and expand the Container and Flow options in the Property inspector.

						You should see a Columns option, already set to 1.

					7.	Click and drag over the 1 to set it to 2, or double-click the 1 and enter 2 instead.

						This step creates two columns in the text box and reformats your text appropriately, as shown in Figure 2-12.

						Next, you add a second text box and thread it to the first so that any text that overruns the first box automatically appears in the second.

					8.	On the same layer and with the Text tool selected, click the stage to deselect the first text box and then click and drag to draw a second text box somewhere next to it.

					9.	Use the bounding box handles to adjust the size of this new box on the stage.

					10.	Click the first text box on the stage to make it active, and click the out port directly (where the red plus sign appears).

					[image: 9781118168608-ma901.tif]		The icon changes to indicate that you’re carrying overrun text from  that box. 

					11.	Hover the mouse pointer over the new box you created, and click it to make it active.

						A line appears between the two boxes, and the overrun text from the first box continues into the second, as shown in Figure 2-13. The two boxes are now threaded.

					

				
					Figure 2-12: Set multiple columns for a text box in the Property inspector’s Container and Flow section.

				

					[image: 9781118168608-fg070212.eps]

					

				
					Figure 2-13:  Two text areas threaded together on the stage.

				

					[image: 9781118168608-fg070213.tif]

				Transforming type

				You can transform type just like shapes and artwork by using either the Transform tool or the Transform panel. Regardless of any transformations your type undergoes, it remains editable.

				To transform a line of type, make sure that it’s active by first selecting it using the Selection or Text tools. To transform, choose the Transform tool or open the Transform panel.

				Distorting and modifying character shapes

				You can distort and modify type outlines just like any other shape or path. However, type is created on a special type path so that it can be edited at any point. You need to break your type characters off a path first in order to tweak any of their outlines.

				To modify or distort type outlines, follow these steps:

					1.	Select the type you want to modify and choose Modify⇒Break Apart.

					2.	If your type is longer than a single character, repeat Step 1 until the bounding box disappears from around the characters, and you see the stippled fill pattern within each character.

					3.	Use the Selection or Subselection tool to modify the outlines (as we demonstrate with shapes earlier in this chapter).

					4.	(Optional) Use the Ink Bottle tool to apply a stroke to the type.

				[image: tip.eps]	If you’re familiar with Adobe Illustrator, think of Break Apart as the Flash equivalent of the Create Outlines command.

				Creating Colors and Gradients

				You’ve undoubtedly (or not) seen and made use of the built-in color swatches in Flash, but suppose that you want to use colors that are not included in the Swatches panel. Here’s where the Color panel comes into play. From this panel, you can mix and create your own color swatches, make gradients, and even apply transparency effects to existing colors on the stage.

				You may have already seen the Swatches panel in action if you used it to select fill and stroke colors from the Tools panel and Property inspector. The Swatches panel exists on its own free-floating panel as well, which you can open by choosing Window⇒Swatches.

				The 256 colors on this panel represent the web-safe color spectrum, which is optimized to ensure that all users, even those with monitors using lower color depth settings, can enjoy your creations.

				You can add colors to the Swatches panel from the Color panel, which means that you have access to your own, custom colors from anywhere the Swatches panel appears.

				Creating and adding colors from the Color panel

				The Color panel features two ways to select a precise color, and can be opened by choosing Window ⇒ Color. Select a color using the color wheel on the right or the sliders on the left, or combine the two methods to hone in on just the right shade. After you choose the color you want, you can easily add it as a swatch to the Swatches panel by choosing Add Swatch from the panel menu.

				To apply a color choice automatically to the stroke or fill swatches, click either the Fill or Stroke color swatch in the upper-left corner of the Color panel. Any changes made using the color wheel or sliders are applied automatically to the selected swatch.

				To select a color on the color wheel, click and drag the cross hair inside the color wheel until you find the right hue (for example, greens). Use the slider to the right to select the exact shade of that color. You may also select a specific color channel (RGB or HSB) and affect only the selected channel.

				To save your new color as a swatch, find the color you want and choose Add Swatch from the panel menu. Your new color appears as a new swatch on the Swatches panel, and you can select the color anywhere that the Swatches panel appears.

				Creating gradients

				Gradients are blends between two or more colors that you can use to fill any area or shape, just like a solid color. If you look at the Swatches panel, you see some gradient presets you can use right away. You can also use the Color panel to create your own gradients and add them to the Swatches panel.

				Follow these steps to create a gradient:

					1.	Open the Color panel by choosing Window⇒Color and choose Linear Gradient from the Color Type drop-down list.

						Linear is one of two gradient types you can create.

					2.	Double-click one of the horizontal sliders that appears below the gradient ramp at the bottom to see the Swatches panel; pick a color to apply to that slider.

						To add more colors to your gradient, click anywhere on the gradient ramp to add a slider. You can then double-click this slider to set the color.

					3.	Adjust the color blends of the gradient by moving the sliders closer together or farther apart.

						To remove colors or sliders, click the slider you want to remove and drag it off the panel to the left or right.

					4.	Choose Add Swatch from the panel menu to save your new gradient.

						The gradient swatch is added to the Swatches panel alongside the existing gradients.

				In addition to being able to create linear gradients, which blend colors evenly in a straight line, you can create radial gradients, a special type of gradient shape where colors blend from the center outward in a circular motion. To set a gradient as a radial gradient, choose Radial Gradient from the Type drop-down list on the Color panel. 

				Both gradient types are created and added to the Swatches panel in the exact same manner, as described in the preceding step list.

				Applying and transforming gradients

				After you create a gradient, you can use it to fill a shape the same way you set a solid fill color. After you apply a gradient to a shape on the stage, you can use the Gradient tool to modify the gradient’s direction, size, and  intensity.

				To modify a Linear gradient fill, follow these steps:

					1.	Create a shape and fill it with a linear gradient from the Swatches panel or Fill color selector on the Tools panel.

						2.[image: 9781118168608-ma008.tif] 	Click and hold down your mouse pointer on the Free Transform tool to select the Gradient Transform tool. Select a shape with a gradient fill.

						Handles appear on the right and left sides of the shape.

					3.	Use the bounding box’s center point to move the transition point of the gradient.

					4.	Use the handle on the right side to modify the intensity of the gradient.

					5.	Change the direction of the gradient by using the rotating arrow icon in the upper-right corner of the selection area.

				If you’re working with a radial gradient, notice that the Gradient Transform tool behaves slightly differently. An extra round handle appears and lets you scale the gradient, and the rotating-arrow icon (which rotates the gradient area) is located in the lower-right corner. Experiment with both linear and radial gradients to see their differences.

				Working with the Brush Tool

					[image: 9781118168608-ma220.tif]	Tools, such as the Pen and Pencil, offer you different ways of creating stroked paths. In contrast, the Brush tool paints with fills. Much like a good old-fashioned paintbrush, this tool can create thick, broad strokes with solid colors or gradients for excellent artistic effects.

				The Brush tool features several brush sizes and tips as well as five modes for controlling how (and where) the Brush tool works its magic.

				Follow these steps to use the Brush tool:

					1.	With the Brush tool selected, choose a brush size and tip shape from the bottom of the Tools panel.

					2.	Choose a fill color from the Fill color swatch on the Tools panel, Property inspector, or Color panel.

					3.	Freely paint on the stage to see the Brush tool in action.

				The different Brush modes change where and how the tool works against different objects on the stage. A good way to see these modes in action is to draw a shape on the stage and make sure that the shape has both a stroke and fill set. Experiment by changing modes and trying to paint over the shape. In Figure 2-14, the selected object was painted over with the Brush tool in Paint Selection mode. This mode affects only the area of the selected shape.

				Because the strokes left behind by the Brush tool are simply filled shapes, you can apply a stroke to this tool, change its fill color, or use it to create interesting shapes that you can tweak by using the same methods we demonstrate in the earlier section “Transforming Artwork and Shapes.”

					

				
					Figure 2-14: Painting in Paint Selection mode affects only the selected shape.

				

					[image: 9781118168608-fg070214.eps]

				To apply an outline to a painted area, set a color by using the Stroke color swatch on the Tools panel, select the Ink Bottle tool, and click the outer edge of the fill. You can now use the Property inspector to change the width, color, and style of the stroke as well.

				

			

			
		

	
		
			
				Chapter 3: Symbols and Animation

				In This Chapter

				[image: check.png] Understanding symbols and the library

				[image: check.png] Creating and editing symbols

				[image: check.png] Using the Spray Brush and Deco tools

				[image: check.png] Working with frames and keyframes in the Timeline

				[image: check.png] Creating animations with tweens

				[image: check.png] Understanding frame-by-frame animation

				[image: check.png] Working with the frame rate

				After you get familiar with the Flash drawing tools, you’ll want to dive into what Flash is best known for: animation. In this chapter, you bring your creations to life with movement, interactivity, and sounds. In an effort to bring motion to the mobile masses, Flash CS6 introduces new options for publishing your movies as mobile applications for IOS and Android, taking Flash in a new direction as a multi-platform animation and rich media tool.

				Before beginning with animation, it’s essential to explore two central concepts in Flash: symbols and the library. Because the symbol is an essential part of creating animation in Flash, we show you how to create and modify symbols before you dive into your first animation tasks.

				Visiting the Library

				Each Flash document contains a library, a repository of reusable graphics, animations, buttons, sounds, video, and even fonts. As you build your Flash movie, you can add any piece of artwork you’ve imported or created on the stage to the library, where it’s stored as a symbol, as shown in Figure 3-1. You manage your library from the Library panel, which is visible in the default workspace. If you don’t see your Library panel, choose Window⇒Library to open it.

					

				
					Figure 3-1: The Library panel houses symbols that you create from graphics you’ve created as well as sounds, images, and font files that you import into your movie.

				

					[image: 9781118168608-fg070301.eps]

				What makes symbols powerful is that you can reuse them as many times as necessary. Simply drag and drop a copy (an instance) from the Library panel onto the stage anywhere in your movie. Most importantly, each instance remains linked to the original in your library. Any changes made to the original (or master) automatically updates any instances of the same symbol used throughout the movie.

				Symbols are broken down into three main categories: graphics, buttons, and movie clips. You can find out more about button and movie clip symbols in Chapters 6 and 7 of this minibook.

				Creating and Modifying Graphic Symbols

				Most common animation sequences in Flash require the use of symbols, so you should become familiar with the most basic symbol type: graphics. You can convert any object on the stage into a graphic symbol, which allows you to take advantage of additional features that are unique to symbols. You can also create empty graphic symbols from the Library panel or by choosing Insert⇒New Symbol and adding content to them afterward.

				Follow these steps to create a graphic symbol:

					1.	Choose Insert⇒New Symbol or choose New Symbol from the Panel menu in the upper-right corner of the Library panel.

						The Create New Symbol dialog box appears.

					2.	Assign a name to the symbol, select Graphic from the Type drop-down list, and click OK.

						You see a blank slate on the stage, where you can add to your symbol.

					3.	Within the new symbol, use your drawing or type tools to create some interesting artwork.

					4.	Choose Scene 1 from the navigation bar above the stage to exit the symbol and return to the main Timeline.

						You see your new symbol listed in the Library panel. Note: The symbol won’t appear on the stage until you place it from the Library (discussed later in this chapter).

				Follow these steps to create a graphic symbol from existing artwork on the stage:

					1.	Create some interesting artwork by using the drawing tools.

					2.	Using the Selection tool, select the new artwork on the stage.

					3.	Choose Modify⇒Convert to Symbol.

						The Convert to Symbol dialog box appears.

					4.	Enter a name for the symbol, choose Graphic from the Type drop-down list, and click OK.

						Your new symbol is now listed in the Library panel.

					[image: 9781118168608-ma299.tif]	Whenever you convert existing graphics to a symbol, the graphics remain  on the stage, enclosed inside a blue bounding box. (See Figure 3-2.) The Property inspector confirms that the selection is now a graphic symbol (indicated by the icon), and this is your first instance of that symbol ready for use.

				[image: warning_bomb.eps]	Don’t confuse symbols with drawing objects: Both display artwork inside a bounding box, but drawing objects don’t have the same abilities as symbols, nor are they stored automatically in your library. Use the Property inspector to determine whether an object is a symbol or a drawing object if you’re unsure — a distinctive icon and description appear for each one at the top of the Property inspector.

					

				
					Figure 3-2: A symbol appears enclosed in a bounding box and the Property inspector (right) shows the symbol’s name and type.

				

					[image: 9781118168608-fg070302.eps]

				Adding symbols to the stage

				If you need to reuse a symbol after you add it to your library, you can simply drag a copy from the Library panel and drop it on the stage. (See Figure 3-3.) Each copy of a symbol is referred to as an instance in Flash. Although all instances of a symbol remain linked back to the original in the Library, you have the flexibility to scale, transform, and rotate each instance individually.

				Follow these steps to add symbols to the stage:

					1.	Locate in your library a symbol that you want to add to the stage.

					2.	Drag a copy from the Library panel to the stage; repeat this step a few times so that you have several instances on the stage.

					3.	Select each instance individually and experiment with different scaling, transforming, and rotating for each one.

				Modifying symbols

				After you create symbols, you can modify them from within the library or directly on the stage. Changes made to a symbol are applied to all instances of that symbol throughout the movie.

					

				
					Figure 3-3:  Drag and drop a symbol from your library to the stage to add as many instances as you want.

				

					[image: 9781118168608-fg070303.eps]

				To edit a symbol from within the library, follow these steps:

					1.	Select a symbol in the Library panel and choose Edit from the panel menu, or double-click any symbol in the Library panel.

						To see the true effect of editing the master symbol, use a symbol you dragged previously to the stage.

						The symbol appears on the stage in Edit mode.

					2.	Make some changes in color, shape, or size.

					3.	Exit the symbol by selecting Scene 1 from the navigation bar above the stage to return to the main Timeline.

						Instances of this symbol on the stage reflect the changes you’ve made to the symbol in the library.

				Editing a symbol in place on the stage can be more intuitive, and you may want to modify it to work better with other artwork on the stage. You can directly edit a symbol from any of its instances on the stage (as shown in Figure 3-4), but keep in mind that regardless of which instance you edit, all instances are affected.

				A closer look at the Library panel

				The Library panel is the main storage location for all your symbols, and much like any library, it has essential organizational tools that make managing your symbols easy.

				The most basic and common functions are made easy by using several icons found along the bottom of the panel, as shown in the sidebar figure:

			[image: 9781118168608-sb070301.eps]
	
				
				[image: check.png] Panel menu: All panels have panel menus, which offer additional options or modify the view of the panel itself. The Library panel’s panel menu carries out additional symbol and library-related tasks.

				[image: check.png] Pin Library: Clicking this icon ensures that the current library stays active even when you switch between other open documents. Normal behavior (unpinned) is for library views to switch automatically when moving between open documents.

				[image: check.png] New Library Panel: Click this icon to create a duplicate Library panel in case you want multiple, distinctive views of your current library. You can also open a new Library panel to view libraries from other documents that are open in your workspace.

				[image: check.png] Search: The text box and magnifying glass under the preview panel can help you search for symbols by name in the Library panel, which is especially helpful for large libraries. Simply type a full or partial name, and the panel displays matches, if any exist.

				[image: check.png] New Symbol: Create a new symbol, identical to the command found by choosing Insert⇒New Symbol.

				[image: check.png] New Folder: Create folders you can sort your symbols into for easy categorization. You can create folders within folders for even finer sorting capabilities.

				[image: check.png] Properties: If a symbol is highlighted in your library, clicking the Properties icon opens the Symbol Properties window. From there, you can redefine the symbol’s name, type, or registration point.

				[image: check.png] Trash Can: Yes, you guessed it — this symbol deletes (trashes) the highlighted symbol in the library. Be careful: No warning is given before the deed is done. However, you can choose Edit⇒Undo to reverse this action, if necessary.



					

				
					Figure 3-4: Double-click a symbol instance to edit the symbol in place on the stage.

				

					[image: 9781118168608-fg070304.eps]

				To edit a symbol in place, follow these steps:

					1.	Select and double-click any symbol instance on the stage.

						You’re now in the symbol’s Edit mode, but you can still see other objects on the stage in the background. Flash dims objects in the background so that you can see your changes in context.

					2.	Make changes and exit the symbol’s Edit mode by selecting Scene 1 on the navigation bar above the stage.

				Sorting symbols

				Symbols in a library can be sorted using any of the column headers at the top of the symbol list. You may be able to see only the Name and Linkage columns at first glance, but if you use the horizontal scroll bar at the bottom of the panel, you can see additional columns labeled Use Count, Date Modified, and Type.

				To sort by any column, click the column name. If the arrow next to the column name is pointing up, the sort is ascending, with the highest value at the bottom. If the arrow is pointing down, the sort is descending, with the highest value at the top.

				Organizing symbols with folders

				As with any workspace, folders can help sort an otherwise large and unwieldy group of items. You can create folders within the Library panel to sort symbols, imported images, sounds, and other assets as you see fit.

				You have a number of ways to group symbols into a folder:

					1.	At the bottom of the Library panel, click the New Folder icon to create a new folder.

					2.	Inside the Library panel, click to select a symbol to move into a folder.

						Shift-click to select several symbols at a time.

					3.	Drag the selected symbols into the new folder.

				Or, follow these steps instead:

					1.	In the Library panel, click to select the symbol(s) you want to group into a folder.

						Shift-click to select several symbols at a time.

					2.	Right-click or Control-click (Mac) and choose Move To from the contextual menu that appears, as shown on the left in Figure 3-5.

					3.	When the Move to Folder dialog box appears, select New Folder and enter a name for the new folder in the text field.

					4.	Click Select to create a folder and group selected symbols into it.

				[image: tip.eps]	You can also sort symbols into folders as you create them. The Convert to Symbol and New Symbol dialog boxes provide an option to sort new symbols into existing folders or to create new ones as you go. The default destination for new symbols is always “Library root,” which means the top level of the library and outside of any existing folders.

					

				
					Figure 3-5: Keep your library organized by grouping symbols into folders by using the Library panel’s Move To command.

					
				

					[image: 9781118168608-fg070305.eps]

				Duplicating symbols

				You may want to create a variation of one of your symbols that goes beyond what you can do on an instance-by-instance basis. A good example is two birds that are similar in appearance, but one has different-shaped wings or a different base color. This instance is a good case for duplicating an existing symbol so that any changes can be made to the copy and treated as a new symbol.

				To duplicate a symbol, select from the Library panel the symbol you want to copy and choose Duplicate from the panel menu in the upper-right corner of the panel. You’re given a chance to name the new version of the symbol when the Duplicate Symbol dialog box appears.

				[image: tip.eps]	You can rename any symbol directly from the Library panel. Select the symbol and choose Rename from the panel menu.

				Painting with Symbols

				Flash CS6 features two unique tools that enable you to get truly creative with symbols: Spray Brush and Deco. These tools can use symbols from your library, allowing you to paint random textures or fill areas with complex patterns. You can even easily draw symmetrical artwork with the Deco tool’s included Symmetry Brush mode or use some of its included presets to create a variety of interesting patterns and graphics on the stage.

				The Spray Brush tool

				The Spray Brush tool paints with instances of a single symbol from your library. You can use the Property inspector to dial in settings for scaling, rotation, and brush angle.

				Follow these steps to paint with the Spray Brush tool:

					1.	Click the New Layer button, found below the Timeline, to create a new, empty layer to paint on.

					2.	Select the Spray Brush tool from the Tools panel. (Click and hold the Brush tool to find the Spray Brush tool.)

						The Property inspector displays options for the Spray Brush tool.

					3.	In the Property inspector, click the Edit button in the Symbol  options area.

						The Select Symbol dialog box appears, prompting you to select a symbol from your library.

					4.	Choose a symbol and click OK to close the dialog box.

					5.	In the Symbol options area, use the Scale Width and Scale Height  sliders to reduce or increase the scaling for each instance painted on the stage.

					6.	In the Brush options area, enter values for the width and height of the brush as well as the brush angle, if you want.

					7.	Click and drag on the stage to begin painting.

						The Spray Brush paints with the symbol you selected using the settings you chose in the Property inspector, as shown in Figure 3-6. You control the size, scatter, and scaling.

				[image: tip.eps]	The Spray Brush tool creates groups from all the paint droplets it leaves behind. You can break apart these groups by choosing Modify⇒Break Apart or edit its contents by double-clicking the group on the stage.

				The Deco tool

					[image: 9781118168608-ma133.tif]	The Deco tool features 13 distinctive modes you can use to create interesting textures, patterns, and symmetrical drawings from symbols in your library or from preset patterns. In the following steps, we show you how to experiment with the Deco tool’s drawing modes by using symbols from your library. First, we show you how to use the Vine Fill:

					1.	Open or create a new Flash document and add at least two graphic symbols to your library by using the methods described earlier in this chapter.

					

				
					Figure 3-6: The Spray Brush paints with symbols from your library.

				

					[image: 9781118168608-fg070306.eps]

					2.	Select the Deco tool from the Tools panel.

						The Property inspector changes to reflect the current drawing effect, set to Vine Fill.

						Vine Fill mode creates a vine-style pattern between two symbols, using one as the leaf (that decorates the vine path) and one as the flower (that appears at the end of each vine).

					3.	In the Leaf section of the Property inspector, click the Edit button to select a symbol from your library to serve as the leaf.

					4.	From the dialog box that appears, choose a symbol from your library and click OK to set that symbol.

					5.	In the Flower section of the Property inspector, click the Edit button to select a symbol from your library to serve as the flower.

					6.	From the dialog box that appears, select a symbol from your library and click OK to set that symbol.

					7.	In the Advanced Options section of the Property inspector, click the color swatch and choose the vine color that will interconnect the two symbols you’ve chosen when the pattern is created.

					8.	Click the New Layer button below the timeline to create a new, empty layer to paint on.

					9.	Click the stage, and the Deco tool begins to draw a new vine pattern using the symbols you’ve chosen.

						The Deco tool draws a vine and caps the vine with the flower symbol you chose. Continue to click and release to draw new vines.

				To give the Grid Fill drawing effect a try, follow these steps:

					1.	Click the New Layer button below the timeline to create a new, empty layer to use with the Grid Fill.

					2.	If the Deco tool isn’t active, select Deco tool from the Tools panel.

					3.	Change the drawing effect from Vine Fill to Grid Fill by using the drop-down list at the top of the Property inspector.

						Grid Fill creates a uniform grid-style pattern within a selected area. You can use Grid Fill to fill either a specific shape on the stage or the entire stage itself.

					4.	Click the Tile 1 Edit button to select a fill symbol.

					5.	When the Select Symbol dialog box appears, choose a symbol from your library to use as a pattern and click OK.

					6.	In the Property inspector, click and drag over the Horizontal Spacing and Vertical Spacing values to specify a distance in pixels between each row and column.

					7.	(Optional) Use the Pattern Scale slider to reduce or increase the size of the symbol used to create the pattern.

					8.	Click the stage with the Deco tool, and the stage fills up with a grid pattern using the symbol and settings you chose, as shown in Figure 3-7.

					

				
					Figure 3-7: Fill shapes or the stage itself with Vine and Grid Fills using the Deco tool and symbols from your library.

				

					[image: 9781118168608-fg070307.eps]

				The last drawing effect we show you how to use is the Symmetry Brush, which lets you draw cool symmetrical artwork with symbols. Follow these steps to use the Symmetry Brush:

					1.	Click the New Layer button to insert a new layer on the timeline.

					2.	If the Deco tool isn’t active, select it from the Tools panel.

					3.	In the Property inspector, select the Symmetry Brush from the Drawing Effect drop-down list.

					4.	To the right of Module, click the Edit button.

					5.	From the Select Symbol dialog box that appears, select a symbol from your library to use with the Symmetry Brush and then click OK.

					6.	On the stage, click and drag to begin drawing with the Symmetry Brush.

						The symbol you chose is duplicated in a rotating pattern around the brush point. Release the mouse button to stop drawing.

						The new pattern displays two handles — one to adjust pattern size and one to adjust the distance between each symbol.

					7.	Move the cursor over the top of the vertical handle until you see a black arrow; click and drag to readjust the size of the pattern.

					8.	Move the cursor over the end of the horizontal handle until you see a black arrow; click and drag clockwise or counterclockwise to reduce or increase the distance between symbol instances, respectively.

				If you look at the advanced options for the Symmetry Brush (at the bottom of the Property inspector), you see quite a few other interesting modes that let you reflect symbols or reconfigure them into a grid. Experiment with them and try different symbols from your library for contrast.

				Getting Started with Animation:  Frames and Keyframes

				One of Flash’s most beloved staple features is the ability to create fluid, fun, and eye-catching motion graphics. Whether it’s making things fade or glide across the stage, or morphing between distinctively different shapes, Flash can do it with ease.

				The Timeline, located below the stage, is where your animation is created. Be sure to take a detailed look at the components that make the Timeline tick: frames, keyframes, and the playhead.

				The Timeline is composed of a series of consecutive frames (see Figure 3-8), each of which represents a point in time (much like a historical timeline). When Flash Player plays your movie, the playhead moves from left to right across the Timeline. The playhead is represented by a red, vertical line in the Timeline window. The numbers above the Timeline represent specific frame numbers.

					

				
					Figure 3-8:  The Timeline is composed of frames and keyframes.

				

					[image: 9781118168608-fg070308.eps]

				Think of historical milestones represented at specific points on a timeline with prominent markers. On a Flash timeline, significant events (such as the beginning and end of an animation sequence) are represented as keyframes.

				Every time you want to place a graphic, an animation, or a sound, first create a keyframe at the specific point on the Timeline where you want it to occur. When you create a new document, a single keyframe is automatically created on Frame 1. Keyframes look like standard frames, except with a hollow or black circle inside.

				Add more keyframes as necessary to create animations or have graphics appear and disappear at specific points along the Timeline. Each layer can have its own keyframes.

				Creating Animation with Motion and Shape Tweens

				When you understand the basics of the Timeline, as we describe in the preceding section, you’re ready to create your first animation. The good news is that Flash does a lot of the hard work for you.

				Flash can automatically create animation sequences from nothing more than a starting point and an ending point, figuring out everything else between them. This method of creating animation is known as tweening. Motion and shape tweens are the two types of tweens you work with on the Flash timeline.

				Creating a motion tween

				A motion tween is a type of Flash-generated animation that requires the use of symbols and is best for creating movement, size, and rotation changes, fades, and color effects. All you need to do is tell Flash where to change the appearance of a symbol instance, and it fills in the blanks in between key changes in the symbol’s appearance to create an animation sequence.

				[image: tip.eps]	Only one object at a time can be tweened on a layer. If you want to tween several objects simultaneously, each object needs to live on its own layer and have its own tween applied.

				To create a motion tween, follow these steps:

					1.	Drag a symbol from your library to the stage to a new layer.

						The symbol is added to Frame 1. For example, we positioned the symbol in the upper-right corner of the stage, which is where the motion will begin.

					2.	Right-click the first frame of the layer your symbol is on and choose Create Motion Tween from the contextual menu that appears.

						A shaded span of frames — a tween span — appears on the Timeline, and the layer is converted to a tween layer. A tween layer, as the name suggests, is a layer that contains one or more motion tweens. Tween layers become dedicated to animation and can’t hold other items that aren’t related to that animation.

						To create animation, you can move the playhead to different points along the tween span and make changes to your object’s appearance or position.

					3.	Drag the playhead to a new frame and then reposition your symbol.

						For this example, we dragged it to Frame 15 and repositioned the symbol in the middle of the stage, slightly toward the bottom.

						A new keyframe (which appears as a bullet point) has been created automatically at this frame to mark the change.

					4.	Drag the playhead to another frame and move the symbol instance to another location on the stage, as shown in Figure 3-9.

						For this example, we dragged it to Frame 24 and repositioned the symbol in the upper-left corner of the stage.

						In addition to another keyframe, a motion path is created on the stage to show the path of animation the symbol will take.

					5.	Press Enter or Return to play the Timeline and preview your animation.

						For the motion tween we created, the symbol moves from right to left.

					

				
					Figure 3-9: A motion path is created to show the trajectory of your tweened object.

				

					[image: 9781118168608-fg070309.eps]

					[image: 9781118168608-ma134.tif]	To see all frames of your animation at one time, select the Onion Skin option underneath the Timeline. This option lets you select and show several frames at once so that you see the frames that the Flash tween created for you.

				You’re just scratching the surface of what Flash can do. Feel free to experiment further with different symbols and positions and to alter the length of your animations by placing starting and ending keyframes closer together or farther apart.

				Resizing tween spans

				If you want a tween to play out longer or shorter or have more time for additional keyframes and motion, you can expand the number of frames in a tween span. By default, the length of each new tween span is based on the frame rate. A frame rate of 24 frames per second (fps) creates a 24-frame tween span every time, a frame rate of 30 fps creates a 30-frame tween span, and so on.

				To expand or trim a tween span, follow these steps:

					1.	Locate and select a tween span on the Timeline and select the last frame in the span.

					2.	Move the cursor over the last frame of the span until a double-arrow icon appears.

					3.	Click and drag left or right to trim or lengthen the span, respectively.

				[image: warning_bomb.eps]	If you resize a tween span after animation already has been created, existing keyframes shift from their original positions on the Timeline, which causes certain animations to begin or end at different times than you originally intended.

				Using the Motion Editor panel

				The Motion Editor panel gives you precise control over each aspect of a motion tween. The Motion Editor displays the various properties of a motion tween (such as position, scale, and transparency) in a graph-style format that you can use to edit or add to animations. You can use the Motion Editor only on motion tween spans, not to modify shape tweens or classic tweens (or tweens created in Flash CS3 or earlier).

				The Motion Editor can be found behind the Timeline panel at the bottom of the default workspace.

				Follow these steps to modify a motion tween with the Motion Editor:

					1.	Click the Motion Editor tab (you can find it behind the Timeline panel) to bring forward the Motion Editor panel.

					2.	Select a tweened object on the stage; you can click either the object or the motion path to select the tween.

						The Motion Editor displays each property as a row with a graph line running through it, as shown in Figure 3-10. The graph line represents the changes in a property value (such as scaling percentage) throughout the course of a tween span.

					

				
					Figure 3-10: Editing properties with precision in the Motion Editor panel.

					
				

					[image: 9781118168608-fg070310.eps]

					3.	Locate a property that your tween is using, such as Alpha, X, or Y, and click the row’s title to expand it.

						Along each line, you find points, or keyframes, that mark changes in the value of that property at different times.

					4.	Select a keyframe and drag it up or down to change the value of the current property.

					5.	Move the pointer over a different portion of the line. While holding down the Ctrl key (Windows) or the [image: maccmd] key (Mac), click directly on the line to create a new point (or keyframe).

						Drag this point up or down to change the property’s value at this position.

					6.	Press the Enter or Return key to play back the Timeline and see how your modifications have affected the current tween.

				Creating a Shape Tween

				You can easily see how Flash can open up new worlds for creating quick, sleek animation without much effort. After experimenting with motion tweens (see the preceding sections), you may find working with symbols a bit limiting, especially if your goal is to modify the shape of an object from start to finish, such as morphing a star into a circle. In this case, you should take advantage of shape tweens.

				For the most part, shape tweens are created in quite a similar manner to motion tweens. However, unlike motion tweens, shape tweens must use raw shapes instead of symbols.

				In addition to morphing between distinctively different shapes, shape tweens can morph color. As with motion tweens, you can tween only one shape at a time on a single layer. If you want to create multiple shape tweens simultaneously, isolate each one on its own layer.

				Follow these steps to create a shape tween:

					1.	Create a new Flash document. At the bottom of the workspace, click the Timeline panel’s tab to bring it forward.

					2.	On an empty layer, draw a shape (for example, a star or polygon with the Polystar tool) on Frame 1.

						You can include a stroke and a fill, because the shape tween can  handle both.

					3.	Click on Frame 25 and choose Insert⇒Timeline⇒Blank Keyframe.

						Rather than choose the motion tween, we choose a blank keyframe because we don’t want a copy of the shape drawn on Frame 1 to be carried over to the new keyframe.

					4.	Draw a distinctively different shape on the new, blank keyframe on Frame 25.

					5.	Select Frame 1 and choose Insert⇒Shape Tween.

						You see an arrow and a green shaded area appear between the starting and ending keyframes, indicating that you’ve successfully created a shape tween.

					6.	Turn on the Onion Skin Outlines option below the Timeline (see Figure 3-11) to see the frames that Flash has created for you.

					7.	If necessary, use the sliders that appear on the timeline ruler to show Onion Skin Outlines across the entire range of frames from beginning to end.

					8.	Press Enter or Return to play back your animation.

						The original shape transforms into the final shape.

					

				
					Figure 3-11: A shape tween with Onion Skin Outlines (for visual aids).

				

					[image: 9781118168608-fg070311.eps]

				Try using these steps to create a tween between two type characters. Create the letters using the Text tool. Break the characters into their raw forms before creating a shape tween by choosing Modify⇒Break Apart.

				Tweened versus Frame-by-Frame Animation

				If you come from a traditional animation background, you may want to create animation the old-fashioned way: frame by frame. Flash easily supports this method, but you should decide which method you want to use based on the type of animation you want to create.

				Both methods have advantages: Although motion and shape tweens give  you the power to create sleek animations quickly and easily, you may find that they’re limited. Frame-by-frame animation is significantly more time-consuming and complex to create but can afford some detail and flexibility that you can’t otherwise achieve.

				To create a frame-by-frame animation, follow these steps:

					1.	Create a new Flash document to work in.

					2.	Create a blank keyframe for each frame you want to include in your animation. You can do this easily by clicking a frame and using the F7 shortcut key.

						Frames don’t have to be consecutive; you can leave space between keyframes to control the time that elapses between each one.

					3.	Draw (or insert) a graphic for each state of your animation on the appropriate keyframes.

					4.	Play back your animation by pressing Enter or Return.

				In Chapter 4 of this minibook, you explore advanced animation techniques using the IK and Armature features in Flash — they let you create sophisticated animation with the ease of tweens and the complexity of frame-by-frame animation.

				[image: tip.eps]	If your goal is simply to move an object from one location to another, to create fades, or to transform size and rotation, it makes sense to use motion tweens and let Flash do the thinking for you. If you’re trying to create highly complex animations that tweens can’t handle (for example, a person running), you may want to try the more traditional frame-by-frame approach.

				In some cases, you can break artwork into individual moving parts (like wheels on a bicycle) across several layers to achieve effects similar to frame-by-frame by using motion tweens. You can explore these effects in Chapter 4 of this minibook.

				Understanding Frame Rate

				The frame rate, which plays an important part in the performance and appearance of Flash movies, dictates how many frames are played back per second by Flash Player, in turn affecting the speed and smoothness of your animations.

				You can modify the frame rate in one of these three ways:

				[image: check.png] Choose Modify⇒Document.

				[image: check.png] With nothing on the stage selected, use the Property inspector. You see your document properties.

				[image: check.png] Click and drag over the frame rate value displayed at the bottom of the Timeline panel.

				[image: tip.eps]	The frame rate is based completely on the result you’re trying to achieve. Although the default frame rate in Flash is 24 frames per second (fps), you may also want to consider a rate of 30 fps. It’s consistent with broadcast and digital video frame rates and should provide a good starting point for smooth, consistent animation. To keep this topic in perspective, remember that a film projector (like the one at your local movie theater) runs at 24 fps.

				If you want to increase the overall speed and smoothness of an animation, you can try increasing the frame rate gradually until you find one that’s right for you. Flash can support frame rates of as much as 120 fps.

				[image: remember.eps]	Changing the frame rate affects the playback of your entire movie. If you’re trying to adjust the speed of a specific animation, consider modifying the tween itself.

				

			

			
			
					
				
			
		

	
		
			
				Chapter 4: Applying  Advanced Animation

				In This Chapter

				[image: check.png] Creating zoom and fade effects

				[image: check.png] Creating a custom motion path

				[image: check.png] Creating fade-outs and fade-ins

				[image: check.png] Copying and pasting motion

				[image: check.png] Creating Motion Presets

				[image: check.png] Creating gravity and inertia effects with easing

				[image: check.png] Morphing graphics with shape tweens

				[image: check.png] Animating poses with the IK and Armature tools

				[image: check.png] Masking artwork and animation

				[image: check.png] Previewing a movie

				With motion and shape tweens, creative animation possibilities are limited only by your imagination. You no doubt want to explore what’s possible, and in this chapter, you get started with some popular  animation effects, such as fades and transformations. In addition, we show you how to use features, such as Inverse Kinematics (IK), which give you new and unprecedented abilities to create sophisticated animation with  less effort.

				Creating Transformations

				Some of the most common effects — such as zoom, flip, lean, and spin — are all different types of transformations, or changes to a symbol’s dimensions, rotation, or skew. You can perform transformations on a symbol from the Tools panel, Transform panel, or Modify menu and combine transformations for many animation possibilities.

				Follow these steps to create a zoom-in effect:

					1.	On the first frame of a new layer, use one of the Shape tools to create an interesting shape on the stage.

					2.	With the shape selected, choose Modify⇒Convert to Symbol.

						The Convert to Symbol dialog box appears.

					3.	Enter a name for the symbol in the Name text box, (for example, type Zoom Shape), select Graphic from the Type drop-down list, and click OK.

						The symbol is added to your library and is ready to be used as part of a motion tween.

					4.	Select the first keyframe; right-click and choose Create Motion Tween from the contextual menu that appears.

						A new tween span is created on the layer. If you’re working with the default frame rate of 24 fps, the tween span should be exactly 24 frames long, as shown in Figure 4-1.

					5.	Click the frame ruler above the Timeline at Frame 24 to reposition the playhead at this point.

					6.	Choose Window⇒Transform to open the Transform panel. From the panel, enter 300% in the Scale Width and Scale Height text boxes.

						The new keyframe that’s created automatically at Frame 24 within the tween span marks the change in scaling you’ve just made.

					7.	Press Enter or Return to play your movie.

						The instance slowly increases in scale, creating the illusion that you’re zooming in closer to the object.

					

				
					Figure 4-1: Create a motion tween span for your new symbol and increase its scale over the course of 24 frames.

				

					[image: 9781118168608-fg070401.eps]

				The zoom-out effect is identical to the animation you just created — but in reverse. Rather than start with the smaller symbol instance, you start with the larger one and gradually pull away by tweening into the smaller one. Rather than create a new animation, you can copy and reverse the existing one by using a few handy shortcuts from the Timeline menu, which appears when you right-click (Windows) or Control-click (Mac) a frame.

				To continue the existing tween and reverse the zoom effect, follow these steps:

					1.	On the same layer as the existing tween, right-click Frame 48 and choose Insert Frame to add frames and extend the current “zoom-in” tween.

				[image: tip.eps]		Inserting frames after a motion tween span is an effective way of extending that tween without shifting existing keyframes.

					2.	Select the next empty frame on the same layer.

						If your tween span is 24 frames long, it’s Frame 25.

					3.	Right-click and choose Paste Frames from the contextual menu that appears.

						A copy of the tween span is pasted back-to-back with the existing one.

					4.	Right-click the new tween span and choose Reverse Keyframes from the contextual menu that appears.

					5.	Click Frame 1 and then press Enter or Return to play back your  animation.

						The zoom-in effect plays, followed immediately by the exact reverse (zoom-out).

				Joining Motion

				The beauty of the new tween engine is that you no longer need to create several tweens or keyframes to have lots of different motion changes. You can create several different movements, transformations, and color effects sequentially within a single tween span.

				You may, on occasion, end up with two or more tween spans back-to-back, especially if you copy and paste tween spans, as described in the previous section. You can, however, easily join tweens into a single span for easier editing and tweaking.

				Follow these steps to join multiple tween spans:

					1.	While holding down the Shift key, click and select two or more consecutive tween spans on a single layer.

					2.	Right-click (Windows) or Control-click (Mac) any selected tween and then choose Join Motions from the contextual menu that appears.

						The tween spans are joined as one. You can now edit the tween span as a whole directly on the Timeline or by using the Motion Editor.

				[image: tip.eps]	You can undo joined motion by choosing Split Motion from the Timeline’s contextual menu.

				Creating Fade-Ins and Fade-Outs

				Fade effects are quite popular because they can add a cinematic feel and smooth transitions between images, text, and graphics. You can see fades used in familiar media, such as photo slide shows or film, where images or scenes fade from one to another.

				In Flash, a fade is a type of basic color transformation that you can apply to any symbol by modifying its transparency, or alpha.

				To create a fade-in, follow these steps:

					1.	Create a new Flash document. Select the Type tool and create some text on the stage.

						Use no more than two words with a font size of 24 points. You can set the type size and style from the Property inspector’s Character options when the Type tool is active, so make sure that the panel is visible by choosing Window⇒Properties.

					2.	Select the type with the Selection tool and convert it to a graphic symbol by choosing Modify⇒Convert to Symbol. Name the symbol and click OK.

						This step adds the type to the library as a symbol and makes it available for tweening.

					3.	Right-click (Windows) or Control-click (Mac) the first keyframe of the current layer and choose Create Motion Tween from the contextual menu that appears.

						A new tween span is created, and the playhead moves ahead to the end of the tween span.

					4.	Grab the playhead and drag it back to Frame 1. Using the Selection tool, click the new symbol once to select it.

					5.	In the Property inspector’s Color Effects section, select Alpha from the Style drop-down list.

					6.	Use the slider or text box to set the alpha of the symbol instance to  0 percent.

						The symbol becomes fully transparent and seems to disappear. (Don’t worry: It’s still there.)

					7.	Click Frame 24 in the Timeline; with the Selection tool, select the symbol.

					8.	In the Property inspector, select Alpha from the Style drop-down list and then use the slider or text box to set the alpha to 100 percent.

					9.	Press Enter or Return to play the movie.

						The text appears to fade in from nowhere to the stage.

				Much like the zoom-out effect, the fade-out is simply the reverse of a fade-in. You can use the Timeline menu’s Reverse Frames command to turn a fade-in into a fade-out. Follow these steps:

					1.	Select the tween span that contains your fade-in.

					2.	Right-click (Windows) or Control-click (Mac) anywhere on the  selected frames to open the contextual menu and then choose  Reverse Keyframes.

						This action reverses the animation so that the symbol starts out fully opaque.

					3.	Press Enter or Return to play the movie.

						The text you created fades out on the stage.

				[image: tip.eps]	Try duplicating and then reversing the fade-in tween to have the text fade in and then out.

				Copying and Pasting Motion

				A recent addition to Flash is its capability to copy the behavior of a motion tween that you then paste into a completely different symbol instance. This technique is handy if you need to have multiple objects follow exactly the same animation behavior, such as birds of different colors and sizes all following the same flight pattern.

				To copy and paste motion, you need an existing tween to copy from and then a symbol instance on a different layer to copy to. The following steps show you how to copy animation behavior from one tween that you can paste and apply to a different symbol afterward:

					1.	Select an existing tween span on the Timeline, right-click (Windows) or Control-click (Mac), and then choose Copy Motion from the contextual menu that appears.

					2.	On a new layer, place an instance of a symbol from your library.

						It can be the same symbol you’ve already tweened or a completely  different symbol.

					3.	Right-click (Windows) or Control-click (Mac) the first keyframe of the new layer and choose Paste Motion from the contextual menu that appears.

						A new tween span is created.

					4.	Press Enter or Return to play your movie.

						The new symbol instance animates in the same way as the original object from which its motion was copied.

				[image: tip.eps]	You can work with two instances of the same symbol, but the beauty of this feature is that you can copy and paste animation between completely nonrelated symbol instances. You can also paste motion between symbol instances that have drastically different size, color, and rotation properties.

				Creating and Using Motion Presets

				In the earlier section “Copying and Pasting Motion,” you see the power of duplicating animation behavior across a number of symbols. However, what happens if you want to reuse animation behavior across several movies, even at a different time?

				Motion Presets take to a new level the concept of reusing animation behavior, by allowing you to take a “snapshot” of an animation’s behavior and save it as a handy preset that can be applied anywhere and at any time for any project. As with Copy and Paste Motion, Motion Presets store behavior, not specific symbols.

				Motion Presets are especially useful if you’ve taken the time to design a particularly complex animation sequence, such as a bouncing ball complete with eases and loss of inertia, and want to use it within another project later. You can use the Motion Presets panel to save, manage, and apply Motion Presets.

				
					
				
				[image: tip.eps]	Motion Presets are saved within the application, not the project file, so you can access all your created presets from within any project.

				Creating a Motion Preset

				To create a Motion Preset, follow these steps:

					1.	Open the Motion Presets panel by choosing Window⇒Motion Presets.

					2.	Select on your Timeline the Motion Tween span you want to save as a preset.

						You can generally select the entire span by clicking it once directly in the Timeline panel.

					3.	In the lower-left corner of the Motion Presets, click the Save Selection As Preset icon.

					4.	When the Save Preset As dialog box appears, enter a preset name in the text field, as shown in Figure 4-2, and then click OK.

						The new preset appears in your Motion Presets panel.

					

				
					Figure 4-2:  Select a tween span on the Timeline and create a new motion preset.

				

					[image: 9781118168608-fg070402.eps]

				Applying a Motion Preset

				After you’ve created a Motion Preset, you can apply the animation behavior stored in that preset to any symbols on the stage. To apply a Motion Preset, follow these steps:

					1.	Click to select on the Timeline a layer containing a symbol instance that you want to apply a motion preset to.

						For the best result, make sure that the layer has no other animation on it and that it contains a single instance of a symbol.

					2.	If the Motion Presets panel isn’t already visible in your workspace, open it by choosing Window⇒Motion Presets.

					3.	Locate the Motion Preset you want to apply.

						If you have none of your own presets, you can choose from a number of precreated presets in the Default Presets folder.

					4.	Click to select the preset you want to apply, and click the Apply button in the lower-right corner of the Motion Presets panel, as shown in Figure 4-3.

						Your selected layer and symbol now have a new animation applied.

					5.	Press Enter (Windows) or Return (Mac) to preview the animation on the Timeline.

					

				
					Figure 4-3: Select a symbol on the stage and apply a Motion Preset to animate it.

				

					[image: 9781118168608-fg070403.eps]

				[image: tip.eps]		Though you should target an existing symbol instance on the stage with Motion Presets, if you attempt to apply a Motion Preset to nonsymbol graphics, Flash converts the selected graphics to a symbol on the fly.

				Animating along a Path with Motion Guides

				The motion tweens described earlier in this chapter involve simple animation from one location to another. For some tweens, you’ll want to have your symbol follow a more elaborate path of motion, such as a race car following a track. In these cases, you can give your tween a specific path to follow by creating a custom motion path.

				Starting in Flash CS4, experienced Flash users may have noticed the absence of the Add Motion Guide button below the Timeline. Because the animation engine has been completely revised, the process of creating motion guides no longer requires a separate layer. You can now modify or replace the motion paths that are created automatically with each new tween span.

				Motion guides are especially useful when you work with a shape that has an obvious orientation (or direction, such as the nose of a car or an airplane). For this reason, make sure to use a symbol with an obvious orientation (such as a triangle) as your tweened object in these steps:

					1.	Create a new Flash document, and create some interesting graphics on the stage.

					2.	Using the Selection tool, select the graphics you created and press the F8 shortcut key to convert the graphic to a symbol.

					3.	When the Convert to Symbol dialog box appears, select Graphic from the Type drop-down list and enter a name for the symbol in the Name text box.

					4.	Create another new layer on the Timeline, select the Pencil tool in the Tools panel, and select a stroke color from the Property inspector on the right.

				[image: remember.eps]		Make sure that Object Drawing mode is turned off. This button appears at the bottom of the Tools panel when the Pencil tool is selected.

					5.	Draw a path on the stage with the Pencil tool, as shown in Figure 4-4.

					6.	Switch to the Selection tool and double-click the path you just created.

					7.	Choose Edit⇒Cut to remove the path from the stage temporarily.

					8.	Right-click (Windows) or Control-click (Mac) Frame 1 of the layer that contains your symbol and choose Create Motion Tween from the contextual menu that appears.

						A new tween span is created for your triangle symbol.

					

				
					Figure 4-4: Use the Pencil tool to create a unique path for your symbol to follow.

				

					[image: 9781118168608-fg070404.tif]

					Logo and illustration courtesy of Jambone Creative (www.jambonecreative.com).

					9.	Choose Edit⇒Paste in Place to paste the path you created earlier.

						Flash automatically converts the path to a motion path, and your symbol snaps to the path, as shown in Figure 4-5.

					10.	Press Enter or Return to play your movie.

						The symbol follows the path you created. Next, you can tweak the tween so that the symbol follows the exact orientation of the path.

					11.	Select Frame 1 of your tween span; in the Property inspector, locate and select the Orient to Path check box, which is located under the Rotation options.

					12.	Press Enter or Return again to play your movie. 

						The symbol changes rotation to match the direction of the path.

				Starting off your symbol on the right foot often helps produce better results when using Orient to Path. If the symbol orientation isn’t what you expect, try rotating the symbol in the right direction at both the beginning and ending frames of the tween span.

					

				
					Figure 4-5: Pasting a complete path to a tween layer converts it to a motion path.

				

					[image: 9781118168608-fg070405.eps]

					Logo and illustration courtesy of Jambone Creative (www.jambonecreative.com).

				[image: warning_bomb.eps]	Watch out for paths that overlap themselves — the results may not be what you expect.

				Snap to it: The importance of snapping

				Snapping, which is an essential part of your workflow, can often make positioning items on the stage much easier and more accurate. Snapping is similar to turning on a magnet: When you drag an object, it jumps to the closest guide, path, or object that it finds on the stage, depending on which type of snapping you’ve enabled. Snapping is useful for lining up objects uniformly, for positioning artwork on a ruler guide, and especially for positioning a symbol at the beginning or end of a motion guide path.

				By default, snapping is enabled for alignment, guides, and objects. Additionally, you can choose View⇒Snapping⇒Snap to Grid (when working with a grid) or View⇒Snapping⇒Snap to Pixels, which ensures that objects are positioned to the nearest whole pixel on the stage.

				You can find snapping options by choosing View⇒Snapping, and you can fine-tune snapping behavior by choosing View⇒Snapping⇒Edit Snapping.



				Creating Inertia and Gravity with Easing

				When objects take motion in real life, several factors affect their speed as they move. Picture a ball bouncing on a sidewalk: When the ball hits the ground and bounces, it loses speed as it moves upward because gravity pulls it back toward the ground. When the ball changes direction and moves back downward, increased gravity makes it pick up speed as it nears the ground again.

				You can reproduce inertia and gravity, by adding eases to your existing tweens. Flash’s animation engine makes lots of easing behaviors available, including Bounce, Spring, Ease In (speed up), Ease Out (slow down), and more. You can assign easing to any tween span with the Motion Editor.

				To create an easing behavior, follow these steps:

					1.	Create a new Flash document. Select the Oval tool and create a perfect circle at the bottom of the stage.

				[image: tip.eps]		Hold down the Shift key to constrain the circle while you draw it.

					2.	With the new circle selected, press the F8 keyboard shortcut; when the Convert to Symbol dialog box appears, select Graphic from the Type drop-down list and enter a name for the symbol in the Name  text box.

						In this example, we named the circle Ball.

					3.	Right-click (Windows) or Control-click (Mac) the first frame of the layer and choose Create Motion Tween from the contextual menu that appears.

						A new tween span is created, and the playhead advances to the last frame of the tween span.

					4.	Using the Selection tool, select and move the symbol straight to the top of the stage while preserving its horizontal position.

				[image: tip.eps]		Drag the symbol slowly toward the top of the stage to keep it from shifting left or right. The Snap to Objects behavior keeps the symbol aligned with its original horizontal position until you release it.

					5.	Press Enter or Return to preview the animation.

						The ball should now move from the bottom to the top of the stage.

					6.	Click directly on the tween span on the Timeline to select it and then click the Motion Editor’s panel tab to bring it forward.

						You see the various properties of your tween represented on the Motion Editor panel.

					7.	Scroll to the bottom of the Motion Editor, locate the Eases row, and change the Simple (slow) value from 0 to 100, as shown in Figure 4-6.

						You can click and drag over the value to change it, or double-click and enter a value by hand.

						You see that the default Simple (slow) ease is already listed. You can add other types of eases to use later, but for now the default works fine.

						Changing the value creates an ease out, which slows the animation as it comes to completion.

					8.	Scroll to the top of the Motion Editor and locate the Basic Motion row; directly to the right, choose Simple (slow) from the drop-down list.

						This step applies the ease to the motion properties of your tween.

					

				
					Figure 4-6: Apply an ease to your tween from the Motion Editor; the ease slows down the ball when it reaches the top of the stage.

				

					[image: 9781118168608-fg070406.eps]

					9.	Press Enter or Return to play back and preview your animation.

						The animation slows down gradually as it reaches completion.

				You can see how easing affects the speed of the tween as it progresses, and now a simple animation becomes much more lifelike. However, what goes up must come down, so the following steps walk you through making the ball return to the ground:

					1.	Click the Timeline tab and then click directly on the layer anywhere within the tween span to select the entire motion tween.

					2.	Right-click (Windows) or Control-click (Mac) the selected frames to open the contextual menu and then choose Copy Frames.

					3.	On the same layer, select the next empty frame immediately after the tween span ends.

					4.	To paste the tween you copied in Step 2, make sure that the frame is selected, right-click (Windows) or Control-click (Mac), and choose Paste Frames from the contextual menu that appears.

					5.	Click the newly pasted tween span to select it.

					6.	To flip the tween backward, right-click (Windows) or Control-click (Mac) the selected frames and choose Reverse Keyframes from the contextual menu that appears.

					7.	Press Enter or Return to preview your animation.

						The ball goes up and then down, and conveniently the animation is not only reversed but is also easing.

				Fine-Tuning Shape Tweens with Shape Hinting

				Chapter 3 of this minibook explores the possibilities of morphing shape and color with shape tweens. Flash does a great job of recalculating shapes during a tween, but sometimes you need to give it a little help, especially when two shapes have common features. Flash may overthink things and perform more shape morphing than it has to. In these cases, you can use shape hints — sets of matched markers that can tell Flash that two points on two different shapes are related. You can attach shape hints to the outlines of shapes on the starting and ending frames of a shape tween to let Flash know which common points exist between the two.

				Two good examples of related shapes are the letters F and T. The two letters have many common angles. A shape tween between the two is a great way to make use of shape hints.

				Before you get started, create a new document. Select the Type tool and, using the Property inspector, set the font style to Arial Black (or its equivalent), and set the font size to 200. Then follow these steps:

					1.	On the first frame of a new layer, type F in the middle of the stage.

					2.	Select the letter with the Selection tool and choose Modify⇒Break Apart to break down the type to its raw outlines.

					3.	On Frame 20 of the same layer, create a new, blank keyframe by using the F7 keyboard shortcut.

					4.	Type T on the new keyframe and position it in the same place as the F on the first frame.

						You can use the Property inspector to match the X and Y positions, if necessary.

					5.	Break apart the T by choosing Modify⇒Break Apart.

					6.	Create a shape tween by right-clicking (Windows) or Control-clicking (Mac) the first frame and choosing Create Shape Tween from the contextual menu that appears.

						An arrow and green shaded area appear, indicating that the tween was created successfully.

					7.	Press Enter or Return to preview your movie.

						The F morphs into the T.

				Even though the shape tween was successful, the outcome may not have been what you expected. Chances are good that the F seems to get mashed up (instead of completing a smooth transition) before being completely reconstructed into the T because Flash can’t see the common angles between the two shapes (even though you can). That’s where shape hints come in: You can add them to suggest common points to Flash and smooth out the tween.

				Before you get started, make sure that Snap to Objects is enabled by choosing View⇒Snapping⇒Snap to Objects. Then follow these steps:

					1.	Select Frame 1 of your shape tween and choose View⇒Show Shape Hints to turn on shape hinting.

					2.	Choose Modify⇒Shape⇒Add Shape Hint to create a new shape hint on the stage.

						A red button, labeled with the letter a, appears.

					3.	Repeat Step 2 to add another shape hint.

						This time, the shape hint appears labeled with the letter b.

				[image: tip.eps]		Sometimes, shape hints stack on top of each other; move one to reveal the others underneath if only one is visible.

					4.	Position the two shape hints on the outline of the F.

						To do so, move shape hint (b) over just a bit so that you can see shape hint (a). Then move (a) and snap it to the lower-left corner of the F. Position the second shape hint (b) in the upper-left corner of the F.

					5.	Select Frame 20.

						You see the companions to the shape hints you created, waiting to be positioned.

					6.	Position shape hints (a) and (b).

						This step matches the lower left and upper-left corners of the T to the ones in F, as shown in Figure 4-7. The buttons turn green to indicate a successful match.

				[image: tip.eps]		If you can’t get the hints to snap perfectly to the edge (the hints will appear red), make sure snapping is enabled by choosing View⇒Snapping⇒Snap to Objects.

					

				
					Figure 4-7: Keeping matching corners in place during the shape tween.

				

					[image: 9781118168608-fg070407.eps]

					7.	Press Enter or Return to preview your animation.

						If you watch carefully, you see that the shape hints are keeping those two corners anchored while the rest of the shape transforms, creating a smoother transition.

				Note: Much like motion guides, shape hints do their work without appearing in your final, published movie.

				[image: tip.eps]	Add Shape Hints with the shortcut key combination Shift+Ctrl+H (Windows) or Shift+[image: maccmd]+H (Mac).

				You can also add some remaining hints to finalize your tween by following these steps:

					1.	Select Frame 1 of your shape tween and make sure that shape hints are still visible by choosing View⇒Show Shape Hints.

						If they’re already enabled, you see a check mark.

					2.	Create one new shape hint with the keyboard shortcut Shift+Ctrl+H (Windows) or Shift+[image: maccmd]+H (Mac).

						The shape hint is automatically labeled with the letter c.

					3.	Position the (c) shape hint on the F, as shown in Figure 4-8, in the upper-right corner.

					

				
					Figure 4-8: Position the new shape hint as shown on both letters.

				

					[image: 9781118168608-fg070408.eps]

					4.	Select Frame 20 and you see the companion to the new shape hint waiting to be placed.

					5.	Position the shape hint on the T to match the angle you marked  on the F.

					6.	Press Enter or Return to play your animation.

						You see that the shape hints have provided a much smoother transition from what you started with.

				Shape hints have their own contextual menu that appears when you right-click (Windows) or Control-click (Mac) any shape hint on the first frame of a shape tween. To clear a selected shape hint, choose Remove Shape Hint or choose Remove All Hints to clear all hints on the stage and start over.

				[image: tip.eps]	Though it often isn’t necessary to add more than a handful of shape hints, you may be wondering: How many shape hints are allowed? The answer  is 26 — the exact amount of letters in the alphabet. After Flash runs out of letters to label shape hints, it doesn’t allow you to create more.

				Creating Inverse Kinematics Poses and Animation

				A significant feature for designers and animators is Inverse Kinematics (IK), a principle relied on in 3D and computer animation and modeling. Inverse Kinematics determines how jointed or connected objects position themselves relative to one another when moved.

				For example, when animating a human arm, if the forearm changes position, it ultimately affects the position of the connected hand and upper arm. These principles help create life-like animation and interaction.

				[image: 9781118168608-ma135.tif] [image: 9781118168608-ma136.tif]	Flash features two tools, Bone and Bind, that you use to connect objects and edit those connections. Connected objects can be posed, and changes between those poses can ultimately be animated. You can create IK relationships between symbol instances or shapes.

					To create and connect IK container objects, follow these steps:

					1.	Create a new Flash document and place two symbol instances on a new layer.

						They can be instances of the same symbol or of two different symbols.

					2.	Select the Bone tool from the Tools panel, move the pointer over the first object until a plus sign appears, drag until the cursor is over the second object, and release the mouse button. 

						This step draws a virtual bone between the two shapes, connecting them as shown in Figure 4-9.

					

				
					Figure 4-9: Drag the Bone tool to draw virtual bones that connect two shapes or symbols.

				

					[image: 9781118168608-fg070409.eps]

						You’ve now converted the two symbol instances to IK container objects, and the layer has been converted to an Armature layer.

					3.	Choose the Selection tool and drag either of the connected symbols to see how the connected objects will behave.

						The second symbol changes its position based on the position of the first.

				You can add more objects to the chain. Although you can’t add objects randomly to an Armature layer, you can connect existing IK container objects to artwork on other layers to add them to the chain.

				Follow these steps to add objects to an existing armature layer:

					1.	Create a new layer on the Timeline and drag a symbol instance to it from the Library panel.

						Position the symbol where you want it relative to the existing IK container objects on the stage.

					2.	Choose the Selection tool and select in the existing Armature layer the object you want to connect the new symbol to.

					3.	Choose the Bone tool, locate the joint (or connection point) on the selected IK container object, and click and drag from that point to the new symbol.

						A new bone is drawn to connect the two objects, and the symbol is removed from its original layer and added to the Armature layer.

					4.	Choose the Selection tool and drag the new symbol around to see how its motion affects the other objects in the chain.

				Creating animation with poses

				After you create a series of connected IK objects, you can put them into motion with poses. Poses capture different positions of your IK objects, and Flash can animate from pose to pose to create sophisticated animation sequences.

				After an Armature layer is created, poses can be inserted (much like keyframes) to note different points along the Timeline where a new pose will be created. This opens lots of possibilities for full-character animation and advanced animation behaviors, and is a handy way to animate connected objects.

				To create and animate poses, follow these steps:

					1.	Click and select an empty frame on an existing Armature layer (for example, Frame 15).

					2.	Right-click (Windows) or Control-click (Mac) the selected frame and choose Insert Pose from the contextual menu that appears, as shown in Figure 4-10.

						A new keyframe is created, where you can pose the IK objects again.

						Much like a keyframe, a pose lets you change the position of IK objects at a specific point on the Timeline.

					

				
					Figure 4-10: Right-click any frame on an Armature layer to insert a pose.

				

					[image: 9781118168608-fg070410.eps]

					3.	Choose the Selection tool and reposition the connected objects on the Armature layer to create a unique pose, as shown in Figure 4-11.

					

				
					Figure 4-11: Change the position of any of your IK objects when you insert a pose.

				

					[image: 9781118168608-fg070411.tif]

					4.	Press Enter or Return to play back the Timeline.

						Flash creates an animation to transition from one pose to the next.

				Adding easing to Armature layers

				Just as with motion tweens, you can mimic the forces of gravity and inertia using easing with IK animations. Although the Motion Editor isn’t available for posed animation, you can easily add easing behavior from the Property inspector to give your IK animation a more realistic look and feel.

				Follow these steps to add easing to an Armature layer:

					1.	Click and select the first frame of an existing IK Armature layer on the Timeline.

					2.	Locate the Ease options on the right side of the Property inspector — the default value is set to zero (no ease) — and then click and drag to change the value to 100 (Ease Out).

					3.	(Optional) Select another type of ease from the Type drop-down list.

					4.	Press Enter or Return to view the animation.

						You see the easing change the behavior of your animation.

				Using Mask Layers

				The concept of masking involves using a shape (or shapes) to hide or reveal portions of a piece of artwork — much like viewing the outside through a small window in your house. The window’s size limits what you can see when you’re inside. Flash features a special type of layer, known as a mask, and its contents are used to selectively reveal (or hide) artwork or animation on another layer.

				[image: tip.eps]	If you’ve worked with layer and selection masks in other Adobe applications such as Photoshop and Illustrator, the concept of masks should already be familiar to you. The technique for creating masks in Flash is a bit different, but the core concepts of masking are the same.

				[image: warning_bomb.eps]	Mask layers aren’t supported when your publish target is HTML. For new files, the Mask option will be disabled for Layers on the timeline. For existing documents using layer masks, they will be discarded at publish/preview.

				You can convert any layer into a mask by using the Layer contextual menu, launched by right-clicking (Windows) or Control-clicking (Mac) the layer’s name area. Artwork on a mask layer isn’t visible; the content of a mask layer always represents the visible area of the layer underneath.

				Animated text is a great candidate for masking. The following steps walk you through creating a tween to which you add a mask layer for added effect. Before you get started, create a new document and select the Type tool. Choose a fill color and then use the Property inspector to set the typeface to Arial Black (or similar) and the font size to 40. Then follow these steps:

					1.	On a new layer, select the Text tool and type a few words on the layer.

						For this example, we typed FLASH ROCKS in capital letters.

					2.	Switch to the Selection tool and select the text. Choose Modify⇒Convert to Symbol or press the F8 keyboard shortcut to convert the text to a new graphic symbol.

					3.	In the Convert to Symbol dialog box, select Graphic from the Type drop-down list and enter a name for the symbol in the Name text box.

					4.	Place the text off the stage to the left so that it’s sitting in the pasteboard area.

						You animate the text to bring it across the stage, entering from one side and exiting on the other.

					5.	To create a new tween span, right-click (Windows) or Control-click (Mac) the first keyframe on the layer that contains your text and choose Create Motion Tween from the contextual menu that appears.

						An instance of the text is created there as well.

					6.	Move the pointer over the last frame of the new tween span until you see the double arrows. Click and drag to extend the tween span to Frame 40.

					7.	On Frame 40, select the text and drag it all the way to the right side of the stage.

						A keyframe is created at Frame 40, and it creates a tween that moves the text from left to right across the stage.

					8.	Insert a new layer above the tween layer and name it Mask; create a shape to use as your mask on this layer. Make sure that the shape is at least as tall as the text symbol you created.

						For example, we used the Polystar tool to create a star in the center of the stage. The Star option for the Polystar tool is available in the Property inspector, under Options.

					9.	Right-click (Windows) or Control-click (Mac) the new layer name and choose Mask from the contextual menu that appears.

						The new layer is converted to a mask layer, and the tween layer appears indented underneath, as shown in Figure 4-12. Both layers are locked automatically.

					10.	Press Enter or Return to play your movie.

						The text animates, appearing through the shape (a star, in this example), much like you’re viewing the animation through a window.

					

				
					Figure 4-12: The text animation reveals itself partially behind the star shape you created.

				

					[image: 9781118168608-fg070412.eps]

				[image: tip.eps]	For the masking layer to take effect, both the mask layer and the layer being masked must be locked. To edit the contents of either layer, unlock the layers by clicking and removing the padlock icons on each layer.

				[image: tip.eps]	Mask layers can contain just about anything a standard layer can, including tweens. Try creating a motion tween on your mask layer and see what  happens!

				Previewing Your Movie

				Previewing a movie in the Flash Player or a browser is preferable to relying on the workspace preview. Previewing also allows you to check your movie’s speed and size and it gives you an accurate depiction of how your animation will look and perform in real life. In certain cases, such as when working with movie clips (discussed in detail in Chapter 6 of this minibook), previewing your movie is necessary to see a complete picture of your work.

				To view a movie in Preview mode, choose File⇒Publish Preview⇒Flash or use the keyboard shortcut Ctrl+Enter (Windows) or [image: maccmd]+Return (Mac).

				This step creates a .swf file from your current authoring file and displays it immediately in Flash Player. If you’re working in a new HTML document or your publish target is set to HTML, this step creates a folder with the necessary HTML, CSS, JavaScript, and supporting files necessary to recreate your movie. Previewing is a helpful way to see how your movie will appear to users and can highlight any potential snags.

				[image: remember.eps]	The final viewing environment for most Flash content will be either in a desktop or mobile browser. At publish time, Flash creates either a finished .swf plus a container HTML (Hypertext Markup Language) page, or for HTML publishing will create a folder with a primary HTML file and supporting CSS, JS, and graphics files. To see how your movie looks as viewed in a browser, choose File⇒Publish Preview⇒Default (HTML). Your default system browser launches and presents your movie in a web page, just as users will see it.

				

			

			
				

			

		

	
		
			
				Chapter 5: Adding Graphics, Audio, and Video

				In This Chapter

				[image: check.png] Importing bitmap images and vector artwork

				[image: check.png] Importing Illustrator and Photoshop files

				[image: check.png] Importing audio files

				[image: check.png] Adding video to your movies

				You may decide to enhance your Flash movies with the addition of photos or graphics created in other applications, such as Photoshop CS6 and Illustrator CS6. Flash natively supports Photoshop and Illustrator file format imports as well as many popular image formats. Combine this feature with the ability to import and use most popular audio and video formats, and you can truly make your Flash movies an immersive multimedia experience.

				Bitmap versus Vector Artwork

				In computer-based design, you need to be aware of two graphic types: bitmap and vector. The drawing environment in Flash natively creates vector graphics, but you can use both bitmap and vector graphics in a  Flash movie.

				Vector graphics refer to scalable artwork consisting of points, paths, and fills that the computer creates based on mathematical formulas. Changing the size, shape or color of vector shape is simply a matter of recalculating the formula and redrawing the shape. As a result, vector graphics maintain crisp quality even when scaled far beyond their original size. Flash (like its cousin Illustrator CS6) can natively create detailed vector illustrations and typography that you can easily scale or modify.

				Bitmap graphics are created from a series of multicolored, tightly arranged pixels. The detail of the image can vary based on a number of factors, including how many pixels, or dots, are used per inch to create the image. This amount is referred to as pixels per inch, or ppi. 

				Importing Other File Formats

				Your choice of file formats is based on which applications you commonly work with. Flash supports many popular file formats and the industry standard Photoshop and Illustrator file formats, giving you lots of flexibility.

				Flash supports and imports a number of file formats, including the following:

				[image: check.png] Illustrator (.ai)

				[image: check.png] Photoshop (.psd)

				[image: check.png] Encapsulated PostScript (.eps)

				[image: check.png] Flash SWF (.swf)

				[image: check.png] JPEG

				[image: check.png] GIF

				[image: check.png] PNG (requires the QuickTime plug in)

				[image: warning_bomb.eps]	Layered PNG files from Fireworks will be flattened upon import.

				[image: technicalstuff.eps]	Flash, like many web-centric applications, works with images at 72 dpi (dots per inch). Images at higher (or lower) resolutions are conformed to screen resolution upon import, and their sizes on the Flash stage may be different from what you expect.

				Vector graphics, such as illustrations and typography, can be created in applications such as Adobe Illustrator CS6. Flash can import and re-create layered artwork from Adobe Illustrator and Photoshop via the Import menu command (File⇒Import to Stage/Import to Library). See the section, “Importing Photoshop and Illustrator Files,” later in this chapter for more details.

				Bitmap graphics, such as photos, can be saved and imported in a variety of formats. If you’re working with a layered Photoshop document, you can import and distribute layers into Flash maintaining most layer effects, such as drop shadows.

				Other popular formats include JPEG, GIF, and PNG:

				[image: check.png] JPEG (Joint Photographic Experts Group) can reproduce the wide range of color and detail necessary to reproduce photographs while keeping file size reasonable. For that reason, it’s the best choice for photocentric documents. (See Figure 5-1.)

					

				
					Figure 5-1: JPEG files have the color depth necessary to reproduce detailed photos.

					
				

					[image: 9781118168608-fg070501.tif]

				[image: check.png] GIF (Graphics Interchange Format; see Figure 5-2), a lightweight format with a limited color gamut (range) of 256 colors, is a good choice for reproducing crisp type, logos, and titling. GIF also supports transparency, so it’s a good choice when the graphics you need to import must be placed discretely against varying backgrounds.

				[image: check.png] The PNG (Portable Network Graphics) format has capabilities that cross over between those of JPEGs and GIFs. PNG also supports transparency and opacity. Between the two PNG types (PNG-8 and PNG-24), you can reproduce both simple graphics and photos with depth and accuracy.

					

				
					Figure 5-2: GIFs and PNGs are best for logos and crisp type.

				

					[image: 9781118168608-fg070502.eps]

				Ultimately, your choice of format depends on which type of graphics you’re working with and how they work in context with the rest of your Flash movie.

				Importing Bitmap Images

				When you need to make use of a photo or graphic file, such as JPEG, GIF, or PNG, import it into Flash by choosing File⇒Import.

				Imported bitmaps are added to your library as assets. Assets aren’t to be mistaken for symbols, which you can duplicate and manage from the library. Assets are simply non-Flash items that you import, store, and use throughout your movie. Although bitmap assets can be converted to symbols, they’re not automatically converted on import; you still need to add them  as symbols. (See Chapter 3 of this minibook.)

				To import a bitmap image, follow these steps:

					1.	In a new Flash document, choose File⇒Import⇒Import to Stage.

						The Import dialog box appears, asking you to find a file on your local computer.

				[image: tip.eps]		To import an image (or images) to the library for later use, such as a series of photos that will be used in a photo gallery, choose File⇒Import⇒Import to Library. This command places the chosen images directly in the library so that you can use them when you’re ready.

					2.	Locate on your hard drive a bitmap file such as JPEG or GIF, select it, and click Open (Windows) or Import (Mac).

						The file is imported and placed on your stage on the active layer.

					3.	Locate and open the Library panel (choose Window⇒Library), and you see that the bitmap has also been placed in your library.

				[image: warning_bomb.eps]	If you try to import an image to the stage and the active layer is locked, the Import to Stage option is unavailable (grayed out). In that case, choose a different, unlocked layer or unlock the active layer.

				Converting Bitmap Images to Symbols

				When a bitmap image is on the stage or in the library, it can be converted to a symbol just like any other graphic on the stage. The process is the same, and the image inherits the same abilities that graphic symbols do, including tween ability, tint, transparency, and management from a master symbol in the library. See Chapter 4 of this minibook for more details on how to create and add symbols to the library.

				[image: warning_bomb.eps]	Symbols created from imported bitmaps create dependencies because they continue to reference the original raw bitmaps in the library. Deleting raw bitmap assets from the library causes them to disappear from any symbols that use them.

				Applying motion tweens

				You can apply motion tweens to any bitmap that’s been converted to a symbol in exactly the same way you would with any other symbol. Working with symbols created from images opens up many new creative options, such as cinematic fades, moving slide shows, and unique presentation ideas.

				To apply a motion tween to an image-based symbol, refer to the coverage on creating motion tweens in Chapter 4 of this minibook.

				Importing Photoshop and Illustrator Files

				Flash offers the seamless import of Photoshop and Illustrator files with the Illustrator and Photoshop Import panels. Graphics created in these applications can be imported with ease and the highest quality possible, which is great news if Photoshop and Illustrator are already essential parts of your creative workflow.

				Using the Import panels, you can view, select, and convert Photoshop layers to symbols or keyframes or distribute them to Flash layers while maintaining common layer effects, such as drop shadows and blurs. The ability to select individual layers means that you can use specific elements from .psd and .ai files without the need to bring in lots of unnecessary art from complex files.

				Importing Photoshop (.psd) files

				Even with complex layered PSD files, Flash can import any .psd file while keeping individual layers editable, including type layers, most layer styles and even layer comps. You can distribute Photoshop layers to Flash layers, sequence them as keyframes, or individually convert layer contents to symbols to be added to the library.

				Before you begin, locate a Photoshop file that you want to import into Flash. A great example is a file that combines layers and type and the basic use of Photoshop layer styles, such as drop shadows.

				To import a Photoshop file, follow these steps:

					1.	Choose File⇒Import⇒Import to Stage.

					2.	When the Import dialog box appears, choose a Photoshop file from your hard drive and click Open (Windows) or Choose (Mac).

						The Import to Library dialog box appears (as shown in Figure 5-3) with full Photoshop file import options and a full view of all layers in your file.

					

				
					Figure 5-3: You can choose layers to import and even convert individual layers into symbols.

				

					[image: 9781118168608-fg070503.eps]

					3.	With the check boxes next to each layer, select the layers you want to import into Flash.

						Now you can set options for how to import the contents of each layer.

					4.	Highlight a layer you’ve chosen to import.

						You can choose from several options that appear on the right side of the panel. (See the nearby sidebar, “The Photoshop Import Options panel,” for a detailed explanation of each option.)

					5.	Click OK to import the file.

						The artwork you selected appears on the stage.

				[image: tip.eps]	Because you can selectively import layers and merge layers directly from the Import panel, consider using .psd files instead of importing flattened artwork (such as JPEG or GIF files). This panel allows you to extract specific elements and maintain transparency from Photoshop layers.

				Importing Illustrator (.ai) files

				Importing .ai files is nearly identical to importing .psd files, with a full layer view and lots of options for converting and distributing artwork and type from Illustrator layers. Because Illustrator is natively vector (just like Flash), you can often continue editing imported artwork in Flash using the Subselection and Pen tools. 

				The Photoshop Import Options panel

				The Photoshop Import Options panel gives you a detailed choice of what is imported, and how, from .psd files. You can send bitmap artwork directly to the library as assets or movie clips; type and vector layers can be converted or kept as editable paths or type layers.

				Here’s a detailed look at what you see in this panel:

				[image: check.png] Select Photoshop Layer Comp: If your document contains layer comps, you can select one from this drop-down list. The layers and positioning that make up the selected comp become active in Layer view.

				[image: check.png] Layers view: All layers in the .psd file appear listed on the left side of the Import to Library panel, and you can choose which layers to import by selecting the check boxes to the left. Highlighting a layer displays its import options on the right.

				[image: check.png] Merge Layers button: When more than one layer is highlighted, you can choose to merge the layers on import into a single layer, which has no effect on the original .psd file.

				[image: check.png] Convert Layers to Flash Layers or Convert Layers to Keyframes: Selecting the Flash Layers option maintains the layer structure (as well as layer groups) and distributes layer contents exactly as they are in your .psd file. Selecting the Keyframes option distributes layer contents across a sequence of keyframes on the Timeline.

				[image: check.png] Place Layers at Original Position: This check box (selected by default) positions layer contents exactly as they are in the original .psd.

				[image: check.png] Set Stage to Same Size As Photoshop Canvas: Selecting this option resizes your movie to match the original size of the .psd file.

				[image: check.png] Import This Image Layer As: The two options shown convert the layer contents to either a bitmap image with editable Flash filter effects (converted from Photoshop layer styles) or a flattened bitmap image, which merges any applied layer styles along with the bitmap image.

				[image: check.png] Editable Paths and Layer Styles (Shape Layers Only): You can keep shape layers and vector artwork editable in Flash by selecting this option, which places artwork on the stage as drawing objects.

				[image: check.png] Editable Text (Type Layers Only): Selecting this option keeps imported text layers editable, re-creating Photoshop type layers as Flash type layers.

				[image: check.png] Vector Outlines (Type Layers Only): Selecting this option converts type layers into raw vector graphics (drawing objects). Type is no longer editable, but its outline can be manipulated with tools, such as the Subselection tool and Pen tool.

				[image: check.png] Create Movie Clip for This Layer: Selecting this option converts the layer contents to a new movie clip symbol that’s also added to the library. You have the option of setting a registration point as well as an instance name. (See Chapter 7 of this minibook for more on instance names.)

				[image: check.png] Publish settings: For each layer, you can set individual compression and quality settings or choose to use the document’s publish settings instead. A handy Calculate Bitmap Size button lets you see how your selected compression and quality settings affect the resulting file size of the imported content.



				To import an Illustrator file, follow these steps:

					1.	In a new Flash document, choose File⇒Import⇒Import to Stage; choose an Illustrator file from your hard drive and choose Open (Windows) or Import (Mac).

						The Import to Stage dialog box appears with a full view of all layers in your Illustrator document.

					2.	Select the check boxes for the layers you want to import into your document.

					3.	Highlight each layer you’ve chosen for import to set options for each one, as shown in Figure 5-4.

						You can import each layer and individual path as either a bitmap or an editable path. You can import groups as bitmaps or movie clips.

					

				
					Figure 5-4:  You can bring Illustrator type paths into Flash as editable text.

				

					[image: 9781118168608-fg070504.eps]

					4.	Click OK to import the artwork to the Flash stage.

						Check out the stage and the Library panel to see how your artwork was placed in Flash. (See Figure 5-5.)

					

				
					Figure 5-5: A finished import, with all Illustrator layers converted to Flash layers.

				

					[image: 9781118168608-fg070505.tif]

				[image: warning_bomb.eps]	Look for the Incompatibility Report button at the bottom of the layer view in the Import panel. This button can indicate potential problems that can prevent the artwork from importing properly into Flash. If you see the Incompatibility Report button, click it and read the warnings to address any pending issues before import.

				A Note about Illustrator Symbol Libraries

				In recent versions of Adobe Creative Suite, the relationship between Illustrator and Flash has been significantly improved. Now, Illustrator symbols offer support for most Flash symbol properties, allowing you to easily develop symbol libraries in Illustrator and import them directly into Flash projects. This includes the ability to set registration points (new in CS6), 9-slice scaling options, and symbol types, all of which are carried over seamlessly into Flash.

				If you’re importing an Illustrator file that uses symbols on the artboard, those symbols are automatically added to your Library. However, if a document contains a symbol library but not all symbols are in use on the artboard, be sure to check the Import Unused Symbols option in the Illustrator Import Options panel so that all symbols from the document’s library are added to your Flash project’s library.

				A view of the Illustrator Import Options panel

				The Illustrator Import Options panel gives you a detailed choice of elements to import from .ai files. You can convert grouped artwork, compound paths, and type layers to movie clips or bitmaps or keep them as editable paths or type layers.

				Layer view: All layers in the .ai file appear in this panel, and you can choose which layers to import by selecting the check boxes to the left. Highlighting a layer displays its import options on the right.

				Incompatibility Report button: When this button is active, potential issues in your Illustrator file may need to be resolved for a clean, successful import. Click this button and review the report to resolve any problems before completing the import.

				Convert Layers to Flash Layers or Convert Layers to Keyframes: Selecting the Flash Layers option maintains the layer structure (as well as layer groups) and distributes layer contents exactly as they are in your .ai file. Selecting the Keyframes option distributes layer contents across a sequence of keyframes on the Timeline.

				Place Layers at Original Position: This check box (selected by default) positions layer contents exactly as they appear in the original Illustrator file.

				Set Stage to Same Size as Illustrator Canvas: Selecting this option resizes movie dimensions to match the original size of the .ai file.

				Import Unused Symbols: Illustrator CS6 files can contain their own symbol libraries, which work in a similar manner to Flash symbols. Symbols that exist in an imported .ai file but that aren’t being used on the canvas are added to the Flash library when you select this check box.

				Note: You can choose to import an Illustrator document’s entire symbol library without importing any visible artwork from its canvas.

				Import As a Single Bitmap Image: Selecting this option flattens and rasterizes the entire Illustrator document and places it as a bitmap image on the stage as well as a bitmap asset in your Flash document’s library.

				Import as

				[image: check.png] Bitmap Image: Selecting this option rasterizes (converts vector to bitmap) the selected artwork and imports it to the stage and library as a bitmap. Any vector artwork or type loses its editability.

				[image: check.png] Editable Path (Individual Paths Only): Selecting this option places vector paths in Illustrator as drawing objects that you can further modify on the Flash stage.

				[image: check.png] Editable Text (Type Layers Only): Selecting this option keeps imported text layers editable, re-creating Illustrator type paths as Flash type layers.

				[image: check.png] Vector Outlines (Type Layers Only): This converts type to vector outlines, which will no longer be editable as a type layer in Flash.

				Create Movie Clip for This Layer: Selecting this option converts the layer contents to a new movie clip symbol, which is also added to the library. You have the option of setting a registration point as well as an instance name. (See Chapter 7 of this minibook for more on instance names.) This option and Convert to Bitmap are the only available options for entire Illustrator layers and grouped artwork.



				Importing Sounds

				The best multimedia creations can be enhanced tremendously using sound effects and music. Flash fully supports the import, placement, and control of sounds in lots of different formats, so you can easily bring in loops, sound effect files, and even music from your .mp3 collection.

				You can enhance your movie with background music or narrative, and sound effects can make using buttons and menus more intuitive. Flash can stream longer sounds (such as soundtracks or long-form narration) to minimize loading time so that users get right to the good stuff.

				Flash imports the following audio file formats:

				[image: check.png] AIFF

				[image: check.png] MP3

				[image: check.png] Windows WAV

				Note: Additional file formats are available with the optional QuickTime plug-in installed.

				Follow these steps to import a sound into your library:

					1.	Create a new Flash document and choose File⇒Import⇒Import to Library.

					2.	Browse and choose an .mp3, .wav, or .aiff file from your hard drive and click Open (Windows) or Choose (Mac).

					3.	Choose Window⇒Library to launch the Library panel.

						The sound appears in the library with a speaker icon, as shown in  Figure 5-6.

					

				
					Figure 5-6: Imported sounds appear next to a speaker icon in your Library panel.

				

					[image: 9781118168608-fg070506.eps]

					4.	Select the sound and check out the Preview window.

						A waveform preview of your sound appears, and you can listen to the sound by using the Stop and Play buttons in the upper-right corner of the panel.

				Placing sounds on the Timeline

				After you have imported your favorite sounds into your Flash document, you can place them on keyframes along the Timeline to have them play at specific points in your movie.

				You can assign sounds with the Property inspector, which displays the Sound section when a keyframe is selected. Sounds can be combined across different layers and used inside buttons to create sound effects for controls and navigation menus.

				To place a sound on the Timeline, follow these steps:

					1.	On a new layer, create a blank keyframe along the Timeline and launch the Property inspector (if it’s not already visible).

					2.	On the right side of the Property inspector, locate the Sound section and select a sound from the Name drop-down list.

						This drop-down list shows all sounds in your library. (See Figure 5-7.)

						The sound is now placed on your Timeline.

					3.	Press Enter or Return to play your movie.

						The sound plays when the playhead reaches the keyframe. 

						Note: If you are placing a sound on Frame 1, you may not hear sound playback unless additional frames follow it. If you need to preview a sound on a single frame timeline, Press Ctrl+Enter (Windows) or Command+Enter (Mac) to test your movie and hear your sounds.

				[image: tip.eps]	Press the Esc key to stop sound playback when previewing (very helpful if you fire off too many sounds at once!).

				After you place a sound on your Timeline, you can use additional options in the Property inspector to control looping, repeating, and playback performance. The most common options to experiment with are the Repeat and Loop options, which control the number of times (if any) a sound should repeat when it’s played.

					

				
					Figure 5-7:  Place sounds on a keyframe from the Sound section in the Property inspector.

				

					[image: 9781118168608-fg070507.eps]

				To repeat the sound, follow these steps:

					1.	Select the keyframe where you already have a sound placed and locate the Sound options in the Property inspector.

					2.	Locate the Repeat drop-down list and enter the number of times you want the sound to repeat in the text box to the right.

						By default, the sound repeats at least once, but if you enter 2, for example, your sound repeats twice.

					3.	Press Enter or Return to play your movie.

						The sound you placed plays and then repeats the number of times you entered in Step 2.

				To loop the sound (repeat it endlessly), follow these steps:

					1.	Select the keyframe and, with the Sound options, click the arrow beside Repeat and choose Loop from the drop-down list.

						The sound is now set to loop continuously until the movie is shut down or another action turns it off.

					2.	Choose File⇒Publish Preview⇒Flash to preview your movie.

						The sound plays and then continues to repeat until you close the preview.

				Editing sounds

				Flash provides a useful way to do basic editing on placed sounds using the Edit Envelope dialog box. The Edit Envelope dialog box performs basic trims and volume effects and lets you adjust volume and pan settings for each sound placed in your movie. Although nothing quite replaces well-recorded and edited source files, you can do last-minute, nondestructive edits so that your sounds complement the rest of your movie.

				To edit a sound, select a keyframe that has a sound placed on it or add a sound to a new keyframe and then follow these steps:

					1.	Select the keyframe on which the sound is placed.

					2.	In the Property inspector, locate and click the Edit Sound Envelope button (the pencil icon to the right of the Effect drop-down list) in the Sound section.

						The Edit Envelope dialog box appears with a waveform preview. The center time ruler has two sliders on the far left and far right.

					3.	Move these sliders to edit the in and out points of the sound or to trim unnecessary silence, as shown in Figure 5-8.

						The lines above each waveform represent the volume envelope.

					

				
					Figure 5-8: Eliminate silence by sliding the starting trim point to the right and the ending trim point to the left.

				

					[image: 9781118168608-fg070508.eps]

					4.	Click the lines above each waveform and drag them up or down to adjust the overall volume of the sound or to add handles and vary the volume at different points during the sound.

				[image: tip.eps]		The higher the line or handle, the louder the sound.

					5.	Use the Effect drop-down list in the upper-left corner to choose from several preset volume and pan effects to enhance your sound.

					6.	When you’re done, click OK and then press Enter or Return to play your movie and hear the changes made to the sound.

				Adding Video to Your Flash Movie

				Video has become one of the most prominent types of web and mobile content, and users have come to expect nearly every site or mobile application to feature video in some way.

				Fortunately, Flash makes it easy to import and add video content to your movies, or simply to convert video for playback in the Flash player. As a matter of fact, Flash has become a choice platform for video delivery for many major video, social networking, and content portals. (YouTube, Hulu, and Facebook all rely heavily on Flash for video delivery.)

				The video import process requires an additional tool, the Adobe Media Encoder (AME), which is a utility application included with Creative Suite 6. AME converts video into a Flash-friendly format so it can be placed in your Flash movie.

				Using the AME, Flash can import, convert, and encode many common file formats for desktop, mobile, and other devices.

				To embed or not to embed?

				There are two primary ways to place video in a Flash document. You can either embed a video, which copies the contents of the video to the Timeline, or you can link to an external video file and have Flash play it back in a special video player component.

				The advantage of the first approach is that the content becomes part of your movie, so you can more easily synchronize it with other content (such as animations) in your movie. However, this approach also drastically increases the size of your published SWF.

				The second approach, linking to a video, creates a dependency to an external file, but it allows your movie to stream the video progressively when needed without adding the extra weight of the video to your final movie. 

				To import and link to a video into Flash, follow these steps:

					1.	In a new or existing Flash document, choose File⇒Import⇒Import Video. The Import Video dialog box appears.

				[image: warning_bomb.eps]		The Import Video option isn’t available for documents whose publish target is set as HTML.

						The Import Video dialog box gives you two ways to direct Flash to your video, as shown in Figure 5-9: On Your Computer and Already Deployed to a Web Server. The first (On Your Computer) is the most common. It indicates you have local a file on your computer that you’d like to use.

					2.	Leave the On Your Computer and the Load External Video with Playback Component radio buttons selected. Click the Browse button.

					

				
					Figure 5-9: Choose the type of file you’d like to import. Most commonly you’ll want to load video externally.

				

					[image: 9781118168608-fg070509.eps]

					3.	Locate your video and click OK.

						This can be an .mpg, an .mp4, a .mov, or other popular file format. If the selected file isn’t compatible for playback in Flash player (most won’t be), you’ll receive a warning and the option to encode the file in the AME. If this is the case, follow these steps:

					a.	Click the Launch Adobe Media Encoder button at the bottom of the dialog box to launch the AME.

						The Adobe Media Encoder application launches. On the left side of the window is the queue, where you’ll drag the videos you want to encode for Flash.

					b.	On your local file system, locate the file you tried to import and drag it into the queue window, as shown in Figure 5-10.

					

				
					Figure 5-10: Drag video files into the AME queue to get them ready for conversion.

				

					[image: 9781118168608-fg070510.tif]

					c.	In the queue, the target file format and settings are listed under the video file. For now, leave the default, which should be F4V, Match Source Attributes (High Quality). Click the Start Queue button or simply press the Return/Enter key to start encoding the video.

						A chime should sound when encoding is successfully completed. 

					d.	Switch back to Flash CS6.

						The Import Video dialog box should still be open. If not, repeat  Steps 1–3.

					e.	Once again, click Browse and locate the newly encoded file, which should be in the same directory as the original. It will appear with a .f4v extension. Click OK/Open and then click Next at the bottom of the dialog box.

				
					
				
				[image: warning_bomb.eps]		Because this is a linked video file, your published movie will continue to look for the video in its original location and will fail if either the video file or movie is relocated. It’s recommended that you copy or move the encoded version of the file to the same directory where you intend on publishing your final movie.

						You’re viewing the Skinning screen, where you can customize a skin for the player that displays your video.

					4.	From the Skin drop-down list, choose a skin that displays the style and type of controls you’d like to use.

						For example, the SkinUnderAllNoCaption option creates a toolbar that sits under the video window and features all common video playback controls except for the Closed Captioning option.

					5.	From the Color picker, choose the color tint for your skin.

					6.	Click Next to complete the process and click Finish to close the Import Video dialog box.

						After a moment, the new video (and its player) is placed on the stage, as shown in Figure 5-11.

					

				
					Figure 5-11:  After you import external video, it appears on the stage in an FLVPlayback component.
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					7.	Choose Control⇒Test Movie ⇒In Flash Professional to preview your movie with the new video added.

				Working with the FLVPlayback component

				After you’ve placed video on the stage, you can modify settings on the FLVPlayback component, which houses and controls linked video. Select the component on the stage and use the Component Parameters section of the Property Inspector to modify properties such as Volume, Autoplay, and Skin Color, and even change the source to point to a different F4V video file.

				Embedding Video on the Timeline

				For most purposes, linking to a video file is the best way to place a video in your movie. However, on occasion you’d like your video to be more integrated with the rest of your content, such as when you’re timing an animation to match events in the video. In these cases, you can place video directly on the Timeline as a movie clip or sequence of frames. The approach is similar to linking video, but you don’t work with the FLVPlayback component.

				[image: warning_bomb.eps]	In this approach, video content is copied directly into your movie, which can add significant file size (and in turn loading time) to your final published SWF. 

				To import and embed video directly into your movie, follow these steps:

					1.	In a new or existing Flash document, choose File⇒Import⇒Import Video.

						The Import Video dialog box appears.

					2.	Within the Import Video dialog box, leave the On Your Computer option selected and choose Embed FLV in SWF and Play in Timeline.

					3.	Click Browse, locate the video file you’d like to import, and click OK.

						Just as with linked video, if you choose a non–Flash-compatible video file, you’ll be prompted to encode the file in the AME. If so, click the Launch Adobe Media Encoder button at the bottom of the dialog box to launch the AME and follow these steps:

						The Adobe Media Encoder application launches. On the left side is the queue, where you’ll drag videos you’d like to encode for Flash.

					a.	On your local file system, locate the file you’re trying to import and drag it into the queue window.

					b.	In the queue, the target file format and settings are listed under the video file. Select FLV as the file format in the Format drop-down list on the far left of the line. Leave the remaining settings, which should read Match Source Attributes (High Quality). Click the Start Queue button or simply press the Return/Enter key to start encoding the video.

				
					
				
				[image: tip.eps]		Unlike linked video, it’s necessary to encode video in FLV format for embedding on the Timeline, as shown in Figure 5-12.

					

				
					Figure 5-12: You’ll need to convert video to the FLV format if you want to embed it in your movie.

				

					[image: 9781118168608-fg070512.eps]

						A chime should sound when encoding is successfully completed.

					c.	Switch back to Flash CS6.

						The Import Video dialog box should still be open. If not, repeat  Steps 1–3.

					d.	Once again, click Browse and locate the newly encoded FLV file, which should be in the same directory as the original. Click OK/Open and then click Next at the bottom of the dialog box.

					4.	On the Embedding screen, leave all check boxes selected. Under the Symbol Type drop-down list, make sure Embedded Video is selected.

						Note: You can also select Movie Clip if you’d like to place this video in more than one location in your movie, but you won’t see the length of the video represented on the main Timeline.

					5.	Click Next to advance to the Finish Video Import screen and then click Finish to complete the import.

						You see the video spanned across the Timeline, much like a frame-by-frame animation, as shown in Figure 5-13. You can now insert layers on the Timeline and add more content, such as animations, if you’d like.

					

				
					Figure 5-13: Embedded video spans the Timeline. You can place content on other layers to sync it with events in the video.
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				Chapter 6: Lights, Camera,  Movie Clips!

				In This Chapter

				[image: check.png] Exploring movie clip uses and advantages

				[image: check.png] Creating and placing movie clips

				[image: check.png] Previewing movie clip animation

				[image: check.png] Transforming and tweening movie clip instances

				[image: check.png] Modifying movie clips

				[image: check.png] Using the 3D Translation and 3D Rotation tools

				Complicated machines, such as automobiles, are made from many smaller machines and moving parts. To build an automobile any other way just isn’t possible. Along those lines, you may find that some animations are too elaborate to create on the main Timeline alone. You can break them down into smaller animations that can be brought together as part of a larger animation.

				You’ll find that your movie may need to reuse several identical animations. (Think about the four spinning wheels on a car.) In these cases, you have movie clips.

				Discovering Movie Clips

				The powerful and versatile movie clip symbol type can include entire, independent animations yet be placed and maintained in your movie just as easily as graphic symbols. The movie clip is one of three symbol types in Flash, and as with all symbols (see Chapter 3 of this minibook), they can be easily duplicated and maintained from a single master symbol in the library.

				Movie clips are unique in that each one contains its own Timeline that looks and works just like the main one. This Timeline is completely self-contained, so animations in movie clips don’t depend on the length of the main Timeline. Movie clips can almost be thought of as movies within a movie. Movie clips behave just like other symbols, so several instances of the same movie clip can be dragged to the main stage to easily duplicate animations. If you need to change an animation that appears several times throughout a movie, you need to modify only the original movie clip in the library that contains it.

				Movie clips have all the same features as graphic symbols: You can easily drag multiple instances to the stage, and each instance can have its own scaling, tint, alpha, and rotation applied.

				Because a movie clip can contain independent animations, it’s a useful way to break down complex animations into smaller, more manageable pieces. Trying to coordinate too many animations across the main Timeline may be not only quite difficult, but also in some cases impossible, depending on what you’re trying to create.

				Movie clips can also be nested inside other movie clips, giving you virtually unlimited levels of depth and complexity.

				[image: tip.eps]	The frame rate, a global setting for your movie, sets the rate for all movie clips as well as for the main Timeline. To speed up or slow down individual movie clip animations, consider modifying the length of any included tweens before adjusting the overall frame rate.

				Unlike graphic symbols, movie clips provide 3D support, allowing you to rotate and position in the 3D realm the 2D artwork contained in movie clip symbols. In addition, all 3D properties can be animated, opening the door for stunning camera, rotation, and depth effects.

				Flash CS6 includes the 3D Rotation and 3D Translation tools, which let you transform movie clip instances along the x, y, and z axes. You can animate 3D properties as part of a standard motion tween and modify them from the Motion Editor panel. We explore these tools in detail later in this chapter.

				Creating and Placing Movie Clips

				Movie clips are created as new, empty symbols as well as from existing content on the stage. If you create a movie clip from scratch, you can add animation and graphics later by editing the symbol.

				Follow these steps to create a movie clip from existing graphics:

					1.	Create some interesting graphics on the stage by using the drawing tools.

					2.	Select the new artwork and choose Modify⇒Convert to Symbol.

						The Convert to Symbol dialog box appears. (See Figure 6-1.)

					

				
					Figure 6-1: Enter a name for your movie clip.

				

					[image: 9781118168608-fg070601.eps]

					3.	Enter a name for your new movie clip in the Name text box, select Movie Clip from the Type drop-down list, select a Folder (if it’s other than the main Library root), and click OK.

						The artwork now appears as a movie clip on the stage.

					4.	Choose Window⇒Library to check out your new symbol in the library with a special Movie Clip icon next to it, as shown in Figure 6-2.

					

				
					Figure 6-2: Add artwork to your library as a movie clip symbol.

				

					[image: 9781118168608-fg070602.eps]

				Nonanimated graphics converted to movie clips behave the same as graphic symbols, so you can place, tween, and modify instances on the stage. The difference, however, is that you can always add animated content later to the movie clip by editing it and creating tweens on its own Timeline.

				In most cases, you take full advantage of movie clips by adding animation in a new movie clip symbol. To do so, you can start with a new, empty movie clip symbol and add the animated content afterward.

				To create a new movie clip symbol and add animation, follow these steps:

					1.	Choose Insert⇒New Symbol.

						The Create New Symbol dialog box appears. (Refer to Figure 6-1.)

					2.	Enter a name for the movie clip in the Name text box, select Movie Clip from the Type drop-down list, choose a folder (if it’s other than the Library root) to sort the new symbol into and click OK to create the new symbol.

						You see a new timeline, shown in Figure 6-3, and the symbol is ready for you to add animation. This Timeline works just like the main one: You can add and reorder layers and create tweens. You still need to convert any artwork to graphic symbols before creating motion tweens.

					

				
					Figure 6-3:  The Timeline of your new movie clip symbol can contain tweens, just like the main Timeline.

				

					[image: 9781118168608-fg070603.eps]

					3.	Create some new graphics on Frame 1 of the existing layer 1, select the graphics, choose Modify⇒Convert to Symbol, name the symbol and select Graphic from the Type drop-down list, and then click OK.

					4.	Right-click Frame 1 and choose Create Motion Tween to create a new tween span on the layer; click and drag the last frame of the tween span to shorten it to 24 frames (only if the span is greater than 24 frames).

					5.	On Frame 24, change the position or rotation of your symbol to set it in motion.

					6.	Press Enter or Return to preview the new Movieclip Timeline and make sure your animation plays back properly.

					7.	Click the Scene 1 link above the stage to return to the main Timeline.

					8.	Locate your new movie clip symbol in the Library panel and drag two instances of it to the stage, as shown in Figure 6-4.

					

				
					Figure 6-4: Drag two instances of the new movie clip from the Library panel to the main stage.

				

					[image: 9781118168608-fg070604.eps]

				If you press Enter or Return to watch your movie clip play on the stage, you’ll probably be a little disappointed. Don’t worry: To see your movie clip in action, you just need to preview the movie in Flash Player.

				Previewing Movie Clip Animation

				Movie clips contain their own Timelines, and pressing Enter or Return while viewing the main Timeline doesn’t automatically playback any placed movie clips. To view movie clip animation, preview your movie in Flash Player using one of two methods:

				[image: check.png] Test Movie mode exports a compressed (.swf) Flash movie and immediately launches it in a Flash Player window. Test Movie is used to give you a quick look at how the finished movie will appear to users as you build. Test the new movie clip by choosing Control⇒Test Movie⇒In Flash Professional.

				[image: tip.eps]		You can preview your movie in Test Movie mode by using the shortcut key combination Ctrl+Enter (Windows) or [image: maccmd]+Return (Mac).

				[image: check.png] Publish Preview works similarly to Test Movie but exports the .swf (compressed Flash movie) using the final delivery settings you’ve already created by using File⇒Publish Settings. Publish Preview can also display your movie in an HTML (web) page in your system’s default browser. To preview a movie in Publish Preview, choose File⇒Publish Preview⇒HTML or File⇒Publish Preview⇒Flash.

				Chapter 9 of this minibook covers publish settings for your movie, but you should know how these seemingly identical methods differ. Both methods let you accurately preview movie clip animation while you create it in your movie.

				Modifying Movie Clip Instances

				You can modify each movie clip instance with its own size, transformation, and color settings. This type of flexibility lets you get lots of mileage from a single movie clip symbol before having to create a new version or variation of your symbol in the Library panel. Just like graphic symbols, these transformations don’t affect the master symbol or other instances on the stage.

				[image: technicalstuff.eps]	Although all instances of a movie clip share a Timeline with its master symbol in the library, each individual instance can be stopped, started, and controlled individually using ActionScript. For more on how to control movie clip instances with ActionScript, see Chapter 7 of this minibook.

				To transform any instance of a movie clip, you can use the Transform  tool, the Transform panel, or the Transform submenu. (Choose Modify⇒Transform.) Try dragging two more instances of your new movie clip on the stage and applying different transformations to each one.

				To apply a transformation to a movie clip instance, choose the Transform tool from the Tools panel and select an instance on the stage. Use the handles to resize, distort, and skew the instance or select an instance on the stage with the Selection tool and use the Transform panel (open it by choosing Window⇒Transform) to type exact amounts for horizontal and vertical scale, rotation, and skew.

				Use the Style drop-down list in the Color Effect section of the Property inspector with any selected movie clip instance to apply unique tints and alpha (transparency) effects and to change brightness. To apply a color effect to a movie clip instance, select an instance on the stage and choose an effect from the Style drop-down list. Use the option controls to dial in the exact amount and type of color effect you need.

				Combining Movie Clips

				To create a new animation from several smaller ones, you can create a new movie clip from other movie clip instances on the stage. This technique allows you to group several movie clips and drag them as one instance to the stage. Unlike standard groups (Modify⇒Group), however, you gain all the advantages of working with symbols, including the ability to duplicate, maintain, and tween the combined movie clips as one unit.

				The practice of including one movie clip inside another is sometimes referred to as nesting. Although movie clips can include other movie clips, graphic symbols, and buttons, graphic symbols shouldn’t include movie clip instances. Movie clips should always be included in other movie clips so that their animation plays back properly.

				Follow these steps to create a new movie clip from other movie clips on the stage:

					1.	Select two or more movie clip instances on the stage.

						These can be instances of different movie clip symbols in your library or of the same symbol.

					2.	Choose Modify⇒Convert to Symbol.

						The Convert to Symbol dialog box appears, as shown in Figure 6-5.

					3.	Enter a name for your new symbol in the Name text box, choose Movie Clip from the Type drop-down list, and set the registration point by clicking a point on the grid shown to the right. Click OK to create the new symbol.

				[image: remember.eps]		The registration point sets the location from which a symbol’s position is determined on the stage. This point can be any of the four corners or four sides or the center of the symbol.

						The symbol instances appear on the stage as a single movie clip, and a new movie clip appears in your library.

					

				
					Figure 6-5: You can combine multiple movie clip instances into a single movie clip.

				

					[image: 9781118168608-fg070605.eps]

				You can now drag and drop several instances of the new movie clip to the stage. Experiment by adding a few instances to the stage and applying different transformations or color effects to each one. Preview your movie by choosing Control⇒Test Movie⇒in Flash Professional. You see that the movie clips now are treated as one item, but still animate and behave as they did when they were separate instances on the stage.

				When you nest movie clips, you create dependencies between those symbols in your library. Movie clips that include other movie clip symbols do so by reference; the included movie clip symbols aren’t duplicated but are connected to the movie clip that includes them.

				Movie clips become dependent on any other symbols they’re created from. The smaller symbols remain in the library and are referenced by the movie clip that includes them, which means that you can’t remove included movie clips without destroying the symbols that they’re part of. For this reason, be sure not to trash any symbols in your Library panel until you’re sure that they’re not being used in your movie or by another movie clip symbol.

				
					
				
				[image: tip.eps]	A helpful way to see which symbols are in use is to choose Select Unused Items from the Library panel’s panel menu. This command highlights symbols in your Library panel that aren’t being used anywhere on the stage or by other symbols in the library. If a movie clip isn’t used on the stage but is included in another symbol, it isn’t highlighted, indicating that it’s “in use.”

				Rendering and Animating Movie  Clips in the 3D Realm

				The extensive drawing and animation capabilities of Flash can be greatly enhanced by the 3D Translation and 3D Rotation tools. You can use each of these tools to rotate and position 2D content in any movie clip instance around or along x, y, and z axes.

				Combined with the powerful Flash animation engine, you can animate these properties as part of a motion tween to add cool depth, camera panning, and perspective effects to your movies.

				Using the 3D Rotation tool

					[image: 9781118168608-ma140.tif]	This 3D Rotation tool can be used on any movie clip instance to rotate and transform the symbol around x, y, and z axes.

				To render a movie clip instance in 3D, follow these steps:

					1.	Place a movie clip instance on a new layer on the Timeline by dragging the clip from the Library panel.

					2.	Select the 3D Rotation tool from the Tools panel and click the new movie clip instance to select it.

						Color-coded circular handles appear, each one corresponding to an axis along which the movie clip can be rotated.

					3.	Rotate your movie clip (see Figure 6-6):

					•	Click and drag the green line that crosses your movie clip horizontally directly on the line to spin the clip around the y (vertical) axis.

					•	Click and drag the red line that crosses your movie clip vertically to rotate the clip around the x (horizontal) axis.

					•	Click and drag the blue circle that surrounds your movie clip to rotate it around the z axis (depth).

					•	Click and drag the outermost red circle in any direction to rotate multiple axes at one time.

					

				
					Figure 6-6: Use the handles in the 3D Rotation tool to rotate a movie clip around the x, y, and z axes, or all at one time.

				

					[image: 9781118168608-fg070606.eps]

				[image: tip.eps]	To reset all transformations performed with the 3D Rotation tool, select the movie clip and press Ctrl+Shift+Z (Windows) or [image: maccmd]+Shift+Z (Mac).

				Using the 3D Translation tool

					[image: 9781118168608-ma141.tif]	In contrast to the 3D Rotation tool, which rotates movie clips around an axis, the 3D Translation tool slides a movie clip along a specific axis to change its perceived distance and depth relative to other objects on the stage.

				Think of this concept as having three train tracks moving left and right, up and down, or forward and backward that your movie clip can ride along.

				To use the 3D Translation tool to position a movie clip in three dimensions, follow these steps:

					1.	Using the Selection tool, place a movie clip by dragging it from the Library panel or click to select an existing movie clip instance on the stage.

					2.	Choose the 3D Translation tool from the Tools panel, which you can find under the 3D Rotation tool.

						Three guides appear and correspond to the x, y, and z axes. You can slide your movie clip along any of these three guides by clicking and dragging the appropriate guide, as shown in Figure 6-7:

					•	To slide a movie clip from left to right along the x axis, click and drag the arrow connected to the red horizontal guide line.

					•	To slide a movie clip up or down along the y axis, click and drag the arrow connected to the green vertical guide line.

					•	To change the perceived distance of a movie clip on the stage, click and drag the center point to slide it along the z axis.

					

				
					Figure 6-7:  To change the perceived depth and distance, slide and position a movie clip along the x, y, and z axes.

				

					[image: 9781118168608-fg070607.eps]

				[image: tip.eps]	3D Translation and 3D Rotation transformations can be combined on the same movie clip for interesting perspective effects.

				Tweening 3D properties

				After you have a feel for how the 3D Rotation and 3D Translation tools  transform movie clips, you can incorporate these effects into a motion  tween to create stunning effects just as easily as you would with position and transparency.

				Follow these steps to create a tween with 3D properties:

					1.	Place a single movie clip instance on a new layer on the Timeline by dragging it from the Library panel.

					2.	Right-click (Windows) or Control-click (Mac) the first frame of the new layer and choose Create Motion Tween from the contextual menu that appears.

						A new tween span is created, and the playhead jumps to the end of the span.

					3.	Select the 3D Rotation tool and click the movie clip to make it active; circular handles appear around the instance.

					4.	Click and drag the axes to rotate the movie clip until you set an angle and a position.

					5.	Press the Enter or Return key to play back your Timeline and your movie clip tweens from its original 2D position to the 3D settings you applied, as shown in Figure 6-8.

					6.	Repeat Steps 3 through 5 with the 3D Translation tool to see your movie clip slide in three dimensions.

					

				
					Figure 6-8:  A 3D tween in Onion Skin Outlines mode.

				

					[image: 9781118168608-fg070608.tif]

				

			

		

	
		
			
				Chapter 7: Controlling Your  Movie with ActionScript

				In This Chapter

				[image: check.png] Discovering ActionScript

				[image: check.png] Adding actions to the timeline

				[image: check.png] Creating button symbols

				[image: check.png] Applying code snippets

				[image: check.png] Enabling buttons with ActionScript

				Whether you’re creating a website, mobile application, or game, you can’t create a truly interactive experience without giving your users total control of the action. If you want to take your movies to the next level, then, ActionScript can help. This powerful built-in scripting language can help you do everything from controlling basic movie playback to creating complex games and even loading dynamic content and data.

				This chapter introduces you to ActionScript and shows you how to use it to create interactive elements, such as clickable buttons, in your movies.

				Getting to Know ActionScript

				ActionScript is a powerful scripting language that you can use to control playback, navigation, and imported media, such as images, video, and audio. The ActionScript language comprises a vast series of commands that are placed on the timeline, within movie clips, or in external files using the Actions panel and the Code Snippets panel. Think of ActionScript as a set of instructions you can give your movie to tell it how to behave and add abilities.

				In its most basic form, ActionScript is used for Timeline control so that you can tell animations when and where to stop, loop, play, or jump to other points along a Timeline. You can also make highly interactive movies by adding controls to your movie, allowing users to drive the action.

				The Code Snippets panel

				A great tool for designers and code newbies is the Flash CS6 Code Snippets panel, shown in Figure 7-1. If you’ve never written ActionScript, the learning curve can be a bit daunting, and sometimes you just need to get the job done. The Code Snippets panel contains dozens of useful pieces of code  that you can easily apply in a single click. Whether you want to navigate  the Timeline, play sounds, or control video in your movie, a code snippet can help.

					

				
					Figure 7-1: The Code Snippets panel contains dozens of useful pieces of ActionScript you can use in your movies.

				

					[image: 9781118168608-fg070701.eps]

				The Actions panel

				If you are comfortable writing code by hand or have experience with other scripting languages (such as JavaScript), you can use the Actions panel to write your own code statements throughout your movie. The Actions panel, shown in Figure 7-2, acts as a wizard, reference book, and script editor all in one. You can also add actions from the Actions panel using a categorized tray, drop-down list or type them directly into the script editor. A handy Script Assist mode (see the next section) is available so that you can add and modify actions without having to type the code by hand. (We highly recommend the Script Assist mode for new users.)

				To launch the Actions panel, choose Window⇒Actions or use the F9 (Windows) or Option+F9 (Mac) shortcut key combination.

				To place an action on a frame, select the frame on the Timeline and launch the Actions panel.

					

				
					Figure 7-2: The Actions panel.

				

					[image: 9781118168608-fg070702.eps]

				Script Assist mode

				For users new to ActionScript, an alternative to using the Code Snippets panel or tackling hands-on coding is Script Assist mode. This mode acts as a wizard within the Actions panel to let you use a series of menus, buttons, and text boxes to build scripts without having to get into the nuts and bolts of writing code by hand. Script Assist mode helps prevent time-consuming errors so that you spend more time being creative and less time troubleshooting.

					[image: 9781118168608-ma180.tif]	To enable Script Assist mode, click the Script Assist icon in the upper-right corner of the Actions panel.

				Previewing ActionScript

				If you press the Enter or Return key to watch a movie clip play on the stage, you’ll probably be a little disappointed. Don’t worry: To see ActionScript in, well . . . action, you just need to preview the movie in Flash Player.

				ActionScript is understood and processed within Flash Player, so most scripted movies need to be tested by choosing Control⇒Test Movie.

				ActionScript 3.0 versus ActionScript 2.0

				Since its introduction in Flash Player 9, ActionScript version 3.0 has brought many major changes and improvements to the way ActionScript performs and to the way it’s created within movies.

				Previous versions of ActionScript (1.0+, 2.0) are still in use among some Flash projects, so you still have options for creating or saving movies with older ActionScript version settings, if necessary.

				If you’ve worked with older versions of ActionScript, you should be aware of some key differences:

				[image: check.png] ActionScript 3.0 can only be placed on keyframes in the Timeline or external (.as) files. You can’t place ActionScript 3 statements directly on symbol instances.

				[image: check.png] ActionScript 3.0 is stricter about a number of coding practices. Practices that Flash would normally let slide in ActionScript 2.0 may cause errors in ActionScript 3.0.

				[image: check.png] ActionScript 3.0 projects can be published only to Flash Player 9 or later. This consideration is important if the requirements of your project limit the use of Flash Player to version 8 or earlier.

				[image: warning_bomb.eps]	If you’re a first-time coder or have never worked with scripting or programming languages, some concepts in ActionScript 3.0 may present a significant learning curve.

				In the interest of keeping with best practices and taking advantage of the latest tools in Flash CS6, this chapter covers only ActionScript 3.0.

				Specifying the correct publish settings

				When you choose to create a new Flash file, you can select an ActionScript 2.0 or 3.0 version file. If you’re adding ActionScript to an existing Flash file, you should verify and adjust the ActionScript version in your Publish Settings to match the version you’ve chosen to work in.

				ActionScript versions are matched to specific versions of Flash Player, and 3.0 scripts don’t work in a version 2.0 movie, and vice versa.

				To verify and select the appropriate ActionScript version, choose File⇒Publish Settings; click the Target tab and choose ActionScript Version 2.0  or ActionScript Version 3.0 from the Script drop-down list.

				The Flash Player and ActionScript version shows in the Property inspector panel when no tools or objects are selected.

				Creating ActionScript with the Actions Panel

				The Code Snippets panel is a helpful way to get up and running, but when you’re ready to venture out on your own, you’ll find that coding using the Actions panel’s Code Editor window may give you more flexibility for certain tasks.

				All ActionScript code is added to keyframes on the timeline, and here you’ll add some common ActionScript statements within the Code Editor (the top of Figure 7-3) and with the assistance of the Actions panel’s Script Assist mode (the bottom of Figure 7-3).

					

				
					Figure 7-3: Create code by typing in the Code Editor window (top) or building scripts by using the Script Assist mode (bottom).

				

					[image: 9781118168608-fg070703.eps]

				Adding a stop()

				The stop() statement does exactly what it sounds like: It stops the timeline at whatever frames it’s placed on. A common use of stop() is to keep a movie from looping, which is the default behavior for Flash Player.

				Follow these steps to create a stop action in your movie:

					1.	On a new layer, create a motion or shape tween from frames 1 through 24 and press Enter or Return to play back and preview the animation.

						For more information on creating tweens, see Chapter 3 of this minibook.

					2.	Click the New Layer button below the timeline to create a new layer and name it Actions. If necessary, drag the layer upward so that it’s the topmost layer in the stack.

						This dedicated layer is where you add ActionScript to control your new motion tween.

					3.	Add a keyframe on frame 24 of the new Actions layer with the F6 shortcut key.

					4.	Select the keyframe and choose Window⇒Actions to launch the Actions panel.

					5.	In the Actions panel, locate the Script Assist button and click it.

						The top panel expands, and you’re now working in Script Assist mode.

				[image: tip.eps]		You can add ActionScript to keyframes with existing content, but it’s always a good practice to separate scripts from visual elements on the stage by creating a dedicated layer for your ActionScript.

					6.	Click the plus sign at the top of the Actions panel and choose flash.display⇒MovieClip⇒Methods⇒Stop.

					7.	Specify in the Object text box the name of the object you want to control. Because you’re stopping the current (main) Timeline, enter the word this in place of the not_set_yet text in the Object text box, as shown at the top of Figure 7-4.

						The actions panel reads

				import flash.display.MovieClip;

				this.stop();

					[image: 9781118168608-ma166.tif]		Take a look at your Timeline (refer to the bottom of Figure 7-4), and you’ll notice that a lowercase a now appears inside the keyframe, which indicates that there is ActionScript on the keyframe. These scripts run when the playhead passes that keyframe.

					

				
					Figure 7-4: The Actions panel view, showing a stop() action (top). A lowercase a indicates that ActionScript was added to frame 24 of the Actions layer (bottom).

				

					[image: 9781118168608-fg070704.eps]

					8.	Choose Control⇒Test Movie to preview your movie.

						The animation plays until frame 24 and then stops.

				Using goto: gotoAndPlay() and gotoAndStop()

				To loop a movie or to send the playhead to a different point on the Timeline, you can tell your movie to jump forward or backward to a specific frame with one of two variations of the goto statement: gotoAndPlay() and gotoAndStop().

				Each of these two statements requires a frame name or number so that Flash Player knows where to send the playhead. When placed on a frame, these actions send the playhead forward or backward to the specified frame and stop, or they resume playback from that point.

				To use gotoAndStop, follow these steps:

					1.	On the Actions layer, select and create a new keyframe at frame 23.

					2.	Choose Window⇒Actions to open the Actions panel.

					3.	Click the plus sign and choose flash.display⇒MovieClip⇒Methods⇒gotoAndStop.

					4.	In the Object field, target the current Timeline by typing this in the Object text box. Enter 1 in the Frame text box and make sure the Scene text box is empty.

						The statements should now read

				import flash.display.MovieClip;

				this.gotoAndStop(1);

					5.	Choose Control⇒Test Movie to preview your movie.

						The tween plays and jumps to the first frame, where it stops.

				Follow these steps to use gotoAndPlay():

					1.	Create a new keyframe at frame 22 on the Actions layer and launch the Actions panel with the new keyframe selected.

					2.	Click the plus sign and choose flash.display⇒MovieClip⇒Methods⇒gotoAndPlay. 

						In the Object text box, have the timeline refer to itself by typing this. 

					3.	Enter 5 in the Frame text box and make sure the Scene text box is empty. (See Figure 7-5.)

						The actions should now read

				import flash.display.MovieClip;

				this.gotoAndPlay(5);

					

				
					Figure 7-5:  The goto AndPlay() action, placed in Action Script 3.0.

				

					[image: 9781118168608-fg070705.eps]

					4.	Choose Control⇒Test Movie to preview your movie.

						The animation plays until frame 22 and loops between frames 5 and 22.

				Using frame labels

				Many statements (like the goto statements described in the preceding section) reference exact frame numbers to navigate the Timeline. If you happen to change the placement of something on your Timeline (such as the start or end of an animation), frame numbers may become inaccurate. For cases like these, you can assign names directly to keyframes on the Timeline that you can call directly from ActionScript.

				Frame labels are familiar names you can assign to any keyframe (such as start, end, or big_finale). You can then tell ActionScript to jump to these frames by name as an alternative to using a frame number. If the location of the named frame changes, scripts still function as long as the label name is the same. When you move a keyframe, the label you assign to it moves with it.

				Here’s how to modify a button to use a frame label instead of a frame number:

					1.	Create a new layer on the Timeline and assign it the name Labels.

						This name is arbitrary, but it’s always a good idea to name layers as intuitively as possible.

					2.	Select frame 5 of your new layer.

					3.	Enter top in the text box shown in the Label area of the Property inspector. (See Figure 7-6.)

						For example, we assigned this keyframe the label name top.

					

				
					Figure 7-6: Assign any keyframe a label name with the Property inspector.

				

					[image: 9781118168608-fg070706.eps]

					4.	Select frame 22 of your Actions layer and choose Window⇒Actions to open the Actions panel (if it’s not already open).

						If you haven’t already, follow the steps in the previous section, “Using goto,” to add a gotoAndPlay() statement.

					5.	Locate the line that reads gotoAndPlay(5). Replace 5 with the name of the new frame label (top) in double quotes, as shown in Figure 7-7.

						The code now reads

				gotoAndPlay (“top”);

					

				
					Figure 7-7: Replace the frame number with the frame label you assigned.

				

					[image: 9781118168608-fg070707.eps]

					6.	Choose Control⇒Test Movie to preview your changes.

						Click the Rewind button and you see the animation jump to frame 5 and stop just as it did earlier. This time, however, the code uses a frame label instead of an absolute frame number.

						Now, no matter where you move the keyframe, the script follows automatically as long as the frame label remains the same.

				Creating Button Symbols

				In everyday life, buttons give you control over your world, whether it’s switching on a light or your TV at home or navigating web pages and e-mail messages online. To make your movies better, you can use buttons to give users control over the action with timeline control and navigation.

				In Flash, buttons are special symbol types built to respond to mouse or keyboard interaction such as clicks, rollovers, and specific key presses. When paired with ActionScript, buttons can be used for just about any navigation or control task. Buttons are created in the same way as other symbol types, and you can easily drag instances to the stage from your library to create more buttons.

				Buttons truly come to life after ActionScript is added, but you must understand how to create proper buttons before wiring them up.

				Creating a new button

				As with graphical symbols, you can create buttons from existing content on the stage or as new empty symbols to which you can add content later.

				Follow these steps to create a new button symbol from existing content:

					1.	On a new layer in your document, create a new, solid shape on the stage that you want to use as a button and select the shape with the Selection tool.

					2.	Choose Modify⇒Convert to Symbol.

						The Convert to Symbol dialog box appears.

					3.	Enter a name for your new button in the Name text box and select Button from the Type drop-down list.

					4.	Click OK to create the button.

				Choose Window⇒Library to launch the Library panel, and you see the new symbol with the special button icon next to it.

				Understanding button states

				Take a look inside your button by double-clicking it on the stage or in the Library panel; its unique timeline contains four specially marked frames: Up, Over, Down, and Hit. Each frame represents a button state, or the appearance of a button, as it interacts with a mouse in different ways.

				Each frame, or state, can contain unique artwork so that your button can change appearance as it’s clicked, pressed, or released. You can even add layers inside your button to stack artwork for more creative flexibility. This list describes the states and what they represent:

				[image: check.png] Up: The appearance of your button when it’s not pressed or rolled over. This state is the one you see most of the time as the button sits on the stage.

				[image: check.png] Over: The appearance of the button when the mouse pointer rolls over it. Adding unique content to this frame creates the rollover effect that many people know and love from using web buttons.

				[image: check.png] Down: The appearance of the button when it’s clicked and the mouse button is held down.

				[image: check.png] Hit: Contents aren’t visible, but this state sets the hot spot, or clickable area, of your button. If the Hit frame is empty, it uses the shape on the last available state by default. You can create a more specific clickable area if you want to give users more or less area to work with or you want to simplify usability for odd-shaped buttons.

				[image: tip.eps]		Use a filled shape in the Hit frame so that the user has no problem interacting with your button.

				Adding content to button states

				You can add content to each frame of your button to make it complete:

					1.	If it’s not already open, edit your new button by double-clicking it on the stage or in the Library panel.

						You should have some content on the Up state from when you created the button. Now you can define content for remaining states as well.

					2.	Select the Over frame on the button’s timeline and add a new keyframe with the F6 shortcut key.

					3.	Use the Selection tool or Property inspector or another drawing tool to modify the artwork on the Over frame. (See Figure 7-8.)

					4.	Select the Down frame and insert a new keyframe by using the F6 shortcut key.

					5.	Modify or add content to the Down frame.

						This step determines how the button appears when the user clicks and holds down the mouse button.

					6.	Select the Hit frame and create a new keyframe by pressing the F6 shortcut key.

					7.	Use existing artwork that’s copied to this keyframe or one of the shape tools to fill this frame with a large, filled Hit area.

					8.	Exit the button by clicking Scene 1 above the stage.

					9.	Choose Control⇒Test Movie to preview your movie.

						Rollover and click your new button to see the different states in action.

					

				
					Figure 7-8: Modified content for the Over frame appears when the user rolls the mouse over the button.

				

					[image: 9781118168608-fg070708.eps]

				Enabling simple buttons

				Although choosing Control⇒Test Movie to preview your work is the best way to preview buttons, you may want to see how certain elements of your movie behave in real time on the stage. To see buttons in action on the stage as you build your movie, you can choose Control⇒Enable Simple Buttons. You then see buttons as they would appear and respond to a user in Flash Player.

				[image: remember.eps]	Buttons can’t be selected or modified on the stage with Enable Simple Buttons mode active; you must disable Enable Simple Buttons to apply actions or transformations or to edit the button in place.

				Modifying button instances

				Individual button instances can have unique transformations and color effects applied, just like graphic symbol instances. In addition, each button can have a unique ActionScript applied to it, so you can use several instances of a single button symbol to create an entire menu or control bar.

				Here’s how to add and modify additional instances of your button on the stage:

					1.	Choose Window⇒Library to make sure that the Library panel is  visible.

					2.	Drag two more instances of your button symbol to the same layer as your existing button instance.

						If necessary, position the buttons so that they’re spread apart from each other.

					3.	Select one of the button instances and choose Window⇒Properties.

						The Property inspector opens.

					4.	Choose Tint from the Style drop-down list in the Color Effect section.

					5.	Select a color and set the tint percentage to 100 percent.

						The button becomes tinted with the chosen color.

					6.	Select a different button instance, choose the Transform tool from the Tools panel, and use the Transform tool to resize or rotate the selected button.

				Preview buttons by choosing Control⇒Test Movie or Control⇒Enable Simple Buttons.

				Putting It All Together: Creating a  Simple Photo Viewer

				After you’ve created buttons and gotten a taste of adding ActionScript to the timeline, you put it all together by “wiring up” a photo viewer on the main timeline with ActionScript. The Code Snippets panel does most of the heavy lifting here, but your understanding of the Actions panel and modifying statements will prove quite handy.

				For this photo viewer example, create a new Flash file and follow these steps:

					1.	Import five unique photos or graphics to your Library.

						For more information on importing images, refer to Chapter 5 of this minibook.

					2.	Create a button symbol that can represent both Forward and Backward buttons.

						For instance, create a right-pointing arrow that can be flipped over.

					3.	On the main Timeline, create a new layer and add four keyframes back to back (totaling five); on each of those keyframes, place a unique image or graphic from your Library so that you have five images on consecutive keyframes.

					4.	Create a new layer and add two button instances to it.

						One button should represent a Previous button on the left side of the stage; the other one, a Next button on the right side of the stage.

					5.	Create a new layer and use the Text tool to create a piece of type that reads “Made with Adobe Flash CS6” on the stage. Place it in the lower-right corner of the stage.

						For more information on creating text on the stage, refer to Chapter 2 of this minibook.

						Your photo viewer should look similar to the one in Figure 7-9.

					

				
					Figure 7-9:  Set up your photo viewer movie as shown here: one layer for the five photos and images, one for buttons, and one for text.

				

					[image: 9781118168608-fg070709.eps]

					Poster images designed by and courtesy of Jambone Creative (www.jambonecreative.com)

				Applying Code Snippets

				The Code Snippets panel brings ActionScript within reach for many more Flash users, and it provides ready-to-use code fragments for most every common need.

				For designers and developers who are experienced in writing their own ActionScript code, the Code Snippets panel can be a valuable tool for creating and managing your own, custom fragments of code that are applied in one click to save typing time.

				In the following section, you can explore how to use the Code Snippets panel to carry out common scripting tasks and bring your photo viewer movie to life.

				Stopping the main timeline

				If you follow the photo viewer example in the earlier section, “Putting It All Together: Creating a Simple Photo Viewer,” and then attempt to preview that movie, the Timeline runs on its own, causing it to rapidly flip through the images you’ve placed on the main timeline (five of them, if you’re following along from the previous section).

				Because the idea was to create a photo viewer, a user should be able to determine when the next photo is viewed, so you need to stop the timeline at each photo to give them a chance to view it.

				To stop the Timeline at specific points, follow these steps:

					1.	Preview your movie by choosing Control⇒Test Movie (Windows) or Command⇒Test Movie (Mac).

						Notice that the Timeline plays through continuously. The stop actions you add soon will fix this problem.

					2.	Close Flash Player and return to your Flash document.

					3.	In the Timeline panel, drag the playhead to the beginning of the Timeline (Frame 1).

					4.	Choose Window⇒Code Snippets to open the Code Snippets panel, or expand it from its icon view in the panel group on the right. (See Figure 7-10.)

				[image: tip.eps]		You can undock the Code Snippets panel for easier access by dragging the panel out of its group on the right side.

					5.	Locate and expand the Timeline Navigation folder in the Code Snippets panel.

					6.	Double-click the snippet labeled Stop at this Frame.

						A new layer (named Actions) is added to the Timeline, and a stop action is added at frame 1.

					

				
					Figure 7-10: Expand the Code Snippets panel from the collapsed panel group in the default (Essentials) workspace.

				

					[image: 9781118168608-fg070710.eps]

					[image: 9781118168608-ma167.tif]		Every time a code snippet is added, the Actions panel opens to show you the code that was created. A quick and easy way to return to the Code Snippets panel is to use the Code Snippets button at the top of the Actions panel.

					7.	Repeat Step 6 for Frames 2, 3, 4, and 5, respectively, so that you have a stop on each of the five frames.

						When you complete this step, your movie should resemble Figure 7-11.

					8.	Preview your movie by choosing Control⇒Test Movie (PC) or Command⇒Test Movie (Mac).

						This time, you remain stopped at frame 1.

				Creating the previous and next buttons

				After your Timeline is under control, you need to give users the ability to move back and forth between the images you’ve placed across the Timeline.

				As suggested by the movie setup described earlier in the “Putting It All Together” section, you should have a layer on the main Timeline with two button instances — one that represents the Previous button and another that represents the Next button.

				You can use two instances of the same button symbol or instances of two unique symbols in the library. Follow these steps to create the buttons:

					1.	Drag the playhead to Frame 1.

				[image: remember.eps]		The code you add for your buttons must be added at the beginning of the movie.

					

				
					Figure 7-11:  Use the Code Snippets panel to stop the timeline at each of the five frames of your movie.

				

					[image: 9781118168608-fg070711.eps]

				Poster images designed by and courtesy of Jambone Creative (www.jambonecreative.com)

					2.	Click and select a button to use for the Previous button on the stage.

					3.	If the Code Snippets panel isn’t already visible, choose Window⇒Code Snippets to open it, or expand it from its icon view in the panel group on the right.

					4.	In the Code Snippets panel, click to expand the Timeline Navigation category.

					5.	Locate and double-click the Click to Go to Previous Frame and Stop code snippet.

						This step adds some new ActionScript to the existing Actions layer, which is tied to your selected button.

					6.	A prompt lets you know that Flash will create an instance name for the new button automatically; click OK.

					7.	Click to select the button you’ll use for the Next button on the stage.

					8.	Within the Code Snippets panel, you should already have expanded the Timeline Navigation category. Locate and double-click the Click to Go to Next Frame and Stop code snippet. Click OK in the Set Instance Name that appears.

						This step adds code to the Actions layer, as shown in Figure 7-12.

					

				
					Figure 7-12: On Frame 1 of the timeline, use the Code Snippets panel to add the code that makes your button advance the slide show.

				

					[image: 9781118168608-fg070712.eps]

					9.	Save your movie by choosing File⇒Save. 

						Next, you test it to see your new code in action.

					10.	Choose Control⇒Test Movie.

						When your movie launches in Flash Player, click the Next button a couple of times to advance through your images. Click the Previous button to navigate backward.

				About instance names

				Every time you need to add ActionScript to control a button (or a movie clip), you first need to create an instance name for the button. An instance name is a unique ID that tells ActionScript which object on the stage to control or work with. The Code Snippets panel automatically assigns an instance name to a selected button or movie clip when you apply a snippet. You can also add your own instance name by selecting the symbol instance and entering an instance name in the Property inspector.

				Instance names can be assigned to buttons, movie clips, and certain text fields. Each instance name needs to be unique, even across several instances of the same symbol.



				Linking to a Website or Web page

				Users move around the web by using buttons or hyperlinks to navigate to web pages within a site or to other websites.

				You can easily link to a website or web page within Flash movies by using a button or piece of text and a bit of code help from the Code Snippets panel. For your photo viewer, you link the text you placed on the stage to the Adobe website to let users know just how cool Flash is!

				To create a clickable link to a website or web page, follow these steps:

					1.	Drag the playhead to Frame 1 on the Timeline.

				[image: remember.eps]		As with buttons, you add code for a text box at the beginning of the Timeline.

					2.	Use the Selection tool to click and select the text box you created on the stage when you set up your movie.

					3.	If the Code Snippets panel isn’t already visible, choose Window⇒Code Snippets to open it, or expand it from its icon view in the panel group on the right.

					4.	In the Code Snippets panel, click to expand the Actions category.

					5.	Locate and double-click the Click to Go to Web Page code snippet, shown in Figure 7-13.

						This step adds some new ActionScript to the existing Actions layer, which is tied to your selected button.

						You see a prompt that lets you know Flash will create an instance name for your text field automatically.

					6.	Click OK. When the Actions panel opens to show you the new code that has been created, as shown in Figure 7-14, take a moment to review it.

						Notice that the Adobe website (www.adobe.com) has automatically been inserted as the default. Keep in mind, however, that you can edit this web address to make your text link to any site you want.

					7.	Save your movie and choose Control⇒Test Movie to preview it.

						Click the text field. Your default system browser opens to the Adobe website.

					

				
					Figure 7-13:  Use the Code Snippets panel to open a browser and go to a web page when clicked.

				

					[image: 9781118168608-fg070713.eps]

					

				
					Figure 7-14:  You can modify the web address placed by the Code Snippets panel in the Actions panel. 
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				Chapter 8: Getting Into  the (Work)Flow

				In This Chapter

				[image: check.png] Creating and managing workspace layouts

				[image: check.png] Setting up grids and guides

				[image: check.png] Using snap options and the Align panel

				[image: check.png] Using animation helpers

				[image: check.png] Creating custom keyboard shortcuts

				[image: check.png] Using the Movie Explorer panel

				Sometimes the difference between a good project and a great project is having a seamless workflow. Visual aids (such as guides and grids), alignment aids, and proper placement of tools and panels are essential parts of creating better movies in less time. The Flash workspace is highly custom­izable so that you can work in the most efficient way possible and spend more time being creative. Flash CS6 includes a new, easy-to-use interface as well as some helpful workspace presets for most every type of user.

				Using Workspace Layouts

				Your Flash workspace consists of all the panels and tools you rely on, so why not take some time to customize it? You can save the position and appearance of these essential components by creating custom workspace layouts.

				Workspace layouts take a snapshot of the appearance and position of panels you’re using so that you can recall that same configuration at any time. You can save as many workspace layouts as you want for different projects or different designers who may share the same computer with you.

				Choose Window⇒Workspace to recall, save, reset, or manage your workspace layouts.

				[image: tip.eps]	Flash CS6 comes with several layout presets: Animator, Classic, Debug, Designer, Developer, Essentials, and Small Screen. You can select and use these layouts as a starting point for a new workspace layout or to reset the workspace. The default layouts can’t be deleted or overwritten (even by saving a layout under the same name).

				Creating new layouts

				Before creating a new workspace layout, open any panels you need, close any panels you don’t use often, and position and size them exactly how you think is best. All panels can be toggled on or off from the Window menu. Grouping options for each panel are available under their respective panel menus, or you can drag and drop panels on top of one another to group them.

				To create a new workspace layout, follow these steps:

					1.	Position all panels and toolbars as you want to see them.

					2.	Group any panels or resize individual panels and groups.

						You can also collapse any panels or groups to Icon mode to maximize the screen area.

					3.	Choose Window⇒Workspace⇒New Workspace.

						A dialog box appears, prompting you to name the new layout.

					4.	Enter a name for the new layout in the Name text box and click OK.

						The new workspace is created.

					5.	Choose Window⇒Workspace.

						You see the new workspace as an available selection.

				Managing layouts

				After you create workspace layouts, you can rename, delete, or update them as needed. Deleting layouts you no longer use is good practice so that you can keep the list manageable. Also rename layouts to indicate when they were created (for example, MyLayoutFeb2010). You can manage layouts by using the Manage panel.

				To delete a layout, choose Window⇒Workspace⇒Manage Workspaces. Select the layout you want to delete and click the Delete button. Click OK to close the Manage Workspaces dialog box. Note: You can’t undo this action, but a dialog box gives you the same warning and a chance to change your mind.

				To rename a layout, choose Window⇒Workspace⇒Manage Workspaces. Select the layout you want to rename and click the Rename button. Enter the new name in the Name text box, click OK, and then click OK again to close the dialog box.

				To update (or overwrite) an existing layout, recall the layout by choosing it from the Workspace menu. Make any adjustments to your workspace and choose Window⇒Workspace⇒New Workspace. When prompted, assign it the name of the layout you’re trying to update. A warning alerts you that you’re about to replace an existing layout by the same name; click OK to overwrite the layout with the new changes.

				
					
				
				[image: tip.eps]	To condense right-side panels to Icon view, collapse the entire panel group by using the double arrows in the upper-right corner of the screen. To hide the labels and view the icons alone, hover over the edge of the panel group until you see the double arrows. Click and drag the panel to resize it to be as narrow as possible.

				Fine-Tuning with Grids and Guides

				Having lots of visual aides at your fingertips is indispensable when you need to line up, arrange, or measure objects on the stage with absolute accuracy. You’ll want some designs to take advantage of the place-it-anywhere flexibility that Flash provides, but other designs demand more precise control over placement and sizing. In these cases, you can take advantage of the large array of Flash visual aids and helpers, many of which you can enable and  set from the View menu.

				These visual aids don’t appear in any way in your final movie; they’re strictly for your benefit during the design and building process.

				Enabling rulers and guides

				The Flash built-in rulers appear on the top and left edges of the stage and are used to position and measure objects on the stage. You also use the rulers to create vertical and horizontal guides by dragging them off the ruler bars. Ruler units are in pixels by default, but you can choose Modify⇒Document to change to other measurement units, such as inches, centimeters, or  millimeters.

				The top ruler represents the X, or horizontal axis, and the left ruler represents the Y, or vertical axis. The upper-left corner of the stage represents absolute 0 for both X and Y, with X increasing as you move right and Y increasing as you move down.

				To set up and use rulers and guides, follow these steps:

					1.	In a new document, choose View⇒Rulers.

						The rulers appear on the top and left edges of your stage.

					2.	Click and drag anywhere on the stage.

						Markers on both rulers follow to indicate your X and Y positions and the width of your selection area. Now you can create guides that you can use to position artwork on the stage.

					3.	Click the top ruler bar and drag down.

						You’re carrying a guide with you while you drag.

					4.	Watch the ruler on the left and drop the guide where you want it. (See Figure 8-1.)

						Use the left ruler for reference so that you know exactly how far down you’re placing the new guide — for example, at 120 pixels.

					

				
					Figure 8-1: To create a new, horizontal guide, click and drag from the top ruler and release a guide on the stage.

				

					[image: 9781118168608-fg070801.tif]

					5.	Click and drag on the top ruler again to place another guide.

						Position this one slightly above the one you previously created — for example, place it at 100 pixels.

					6.	Use the Type tool to create a single line of type on the stage, as shown in Figure 8-2.

						Use a large enough font that you can easily see and drag the new text.

					7.	Choose the Selection tool; grab the text with it and drag until the bottom of the text snaps in place on the lower guide you’ve created.

					

				
					Figure 8-2: Create a line of type and position it with the help of guides.

				

					[image: 9781118168608-fg070802.tif]

				Your text snaps easily to the new guides because of a built-in mechanism —  snapping. Think of snapping as turning on a magnetic force that allows objects to adhere to each other or to visual helpers (such as guides) to make positioning easier. By default, Snap Align, Snap to Guides, and Snap to Objects are enabled. (Choose View⇒Snapping.) You can also enable Snap to Pixels and Snap to Grid.

				Enabling the grid

				If you’ve ever drawn on graph paper, you know how fun it can be to follow the lines and create perfect shapes and drawings. As with good old graph paper, you can enable and use the Flash grid to draw and position objects and create precise layouts by just following the lines. As with guides, you can snap type, drawing objects, and symbols to gridlines. You can also draw along gridlines to easily measure and match shapes.

				To enable the grid, choose View⇒Grid⇒Show Grid. (See Figure 8-3.) To take full advantage of the grid, choose View⇒Snapping⇒Snap to Grid to make it magnetic.

					

				
					Figure 8-3: You can position objects and draw on top of the grid.

				

					[image: 9781118168608-fg070803.tif]

				Follow these steps to draw and position objects with the grid:

					1.	Choose View⇒Grid⇒Show Grid to make sure the grid is enabled  and choose View⇒Snapping⇒Snap to Grid to turn on snapping for  the grid.

					2.	Grab the Rectangle tool, choose a stroke color, and set the fill color  to None.

					3.	Draw a rectangle with the gridlines as a guide.

						The shape snaps to the nearest gridline while you draw.

					4.	Use the Selection tool to click and drag the new shape and snap it into place.

					5.	If you’d like, disable the grid before moving on to a new task by choosing Choose View⇒Grid⇒Show Grid to uncheck this option on the menu.

						When you move objects along the grid, they snap by their registration point to the gridlines. You can use the gridlines to snap objects (including type) to the exact position you want, as shown in Figure 8-4.

					

				
					Figure 8-4:  With snapping enabled, objects snap to the grid while you move them.

				

					[image: 9781118168608-fg070804.tif]

				[image: tip.eps]	To customize the appearance of your grid, choose View⇒Grid⇒Edit Grid. From this dialog box, you can specify the grid’s size and color and the snapping accuracy.

				Aligning Artwork

				If you need to line up or space out several graphics on the stage, you can use the handy Align panel to assist you. The Align panel lets you line up, distribute, or space two or more objects relative to each other or the stage.

				To experiment with the Align options, create a new layer, draw a shape on the stage, and place it on the bottom below any graphics you already have on the stage. Then follow these steps to align and distribute two or more graphics:

					1.	Select a graphic on the stage and duplicate it two to three times by choosing Edit⇒Copy and then choosing Edit⇒Paste.

					2.	Loosely position the graphics across the stage from left to right.

					3.	Select all the new copies you created with the Selection tool and launch the Align panel by choosing Window⇒Align.

						The first row contains all the Align buttons, broken down into two groups: vertical and horizontal.

					4.	Locate the Align to Stage check box at the bottom of the Align panel and uncheck it, if necessary.

						You can see in the next section what effect this step has.

					5.	Click the Align Vertical Center button to align the selected graphics horizontally by their top edge.

						The graphics reposition themselves so that they’re all flush by the top edge. Align selected graphics horizontally with each other with the buttons under the Align row. The second row contains buttons that evenly distribute graphics vertically or horizontally by their center, top, or bottom edges.

					6.	Click the middle button of the second group (Distribute Horizontal Center) to distribute graphics based on their center points, as shown in Figure 8-5.

					

				
					Figure 8-5: Distribute graphics horizontally across the stage.

				

					[image: 9781118168608-fg070805.tif]

				Distributing to the stage

				The Align to Stage check box (located on the bottom of the Align panel) can be selected so that any distribution uses the stage as a point of reference. The distribute options are useful if you want to distribute objects across the full width of the stage regardless of their distance from each other.

				To distribute objects across the stage, follow these steps:

					1.	Leave selected the graphics you just distributed on the stage. If they aren’t selected, use the Selection tool to reselect them by dragging a selection area around them on the stage.

					2.	Locate and select the Align to Stage check box on the Align panel.

					3.	Click the Distribute Horizontal Center button in the Distribute row.

						The graphics redistribute and spread across the full width of the stage, as shown in Figure 8-6.

					

				
					Figure 8-6: Selecting the Align to Stage check box spreads graphics across the full width of the stage.
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				Using Match Size options

				If you need to resize two or more objects on the stage so that they’re all the same width and height, you can take advantage of the Match Size options in the Align panel. Match Size options can conform two objects to the same width or height, or both.

				To match two objects in size, follow these steps:

					1.	Select two or more different-size graphics, symbols, or drawing objects on the stage.

					2.	Choose Window⇒Align to launch the Align panel (if it’s not already open).

					3.	If it’s selected, deselect the Align to Stage check box at the bottom of the Align panel.

					4.	Locate the Match Size button group on the bottom of the panel and click the last button of the three (Match Width and Height).

						The objects resize to the same width and height, as shown in Figure 8-7.

						Note: You can also match only width or height by clicking either the first or second buttons of the group, respectively.

					

				
					Figure 8-7: Match the width and height of two or more graphics.
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				[image: tip.eps]	With the Stage button enabled, Match Size resizes any selected objects to the full width and height of your stage. Using this feature is an easy way to create a full-size background or to stretch a graphic to fit the entire stage.

				
					
				
				[image: remember.eps]	When you use Match Size, the largest of the selected objects always dictates the resizing. All other objects are resized to match the largest selected object.

				Experimenting with Animation Helpers

				Sitting discretely below the Timeline are some highly useful icons that can be a big help while you’re developing and fine-tuning animations. The Onion Skin, Onion Skin Outlines, and Edit Multiple Frames options let you view, move, and manipulate entire animations at a time to save time and guarantee better results.

				When creating animation, you can enable onion skinning to view several frames at a time. With tweened animation, onion skinning can reveal all frames created between the starting and ending keyframes to help you make adjustments and see them in action. You can choose between two types of onion skinning, depending on whether you want to view frames as outlines or full-color previews.

				Before you get started, create a new motion tween or open a document with an existing tween that you can use for this example.

				To enable onion skinning, follow these steps:

					1.	Select the Onion Skin icon underneath the Timeline.

						A set of brackets appears above the Timeline.

					2.	Adjust the brackets so that all frames in your tween are selected.

						You see a full preview of all frames generated by your tween.

				You can’t select the frames shown in between, but you can move the instances on the starting and ending keyframe. Select the symbol instance on the starting keyframe of your tween and move it. The onion skin reveals how the frames in between change when you shift starting or ending instances.

				As an alternative to seeing frames in your tween in full color, you can preview them as outlines by using the Onion Skin Outlines option. (See Figure 8-8.) This option works exactly like the Onion Skin option but shows selected frames using a wire-frame-style outline view. The Onion Skin Outlines option can be a better choice if the full-color preview looks cluttered.

					

				
					Figure 8-8:  An animation shown in Onion Skin Outlines mode.
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				Using Keyboard Shortcuts

				Part of creating a smooth and fast work environment is having your favorite commands, panels, and tools at your fingertips. Most Flash menu items and panels are equipped with shortcut key combinations that provide easy access without having to comb through several menus. If you need your own, custom keyboard shortcuts, Flash lets you create and save keyboard shortcut sets that you can fully customize to speed your workflow.

				To view the default keyboard shortcuts and create your own, choose Edit⇒Keyboard Shortcuts (Windows) or Flash⇒Keyboard Shortcuts (Mac).

				You can map almost any available tool, command, or panel to a keyboard shortcut. You can choose to memorize existing keyboard shortcuts for commonly used items or create custom keyboard shortcuts that are more intuitive for you.

				To create a new keyboard shortcut, follow these steps:

					1.	Choose Edit⇒Keyboard Shortcuts (Windows) or Flash⇒Keyboard Shortcuts (Mac).

						The Keyboard Shortcuts dialog box launches. (See Figure 8-9.)

					

				
					Figure 8-9: Drill down through the menus to select the command you want to create a shortcut for.

				

					[image: 9781118168608-fg070809.eps]

					2.	Scroll down and click the plus sign (Windows) or triangle) to the left of where it reads Control.

						You see all menu items on the Control menu and any keyboard shortcuts assigned to them.

					3.	Locate and select the menu command you want to create a shortcut for. (Refer to Figure 8-9.)

						For this example, we selected Insert⇒New Symbol.

				[image: remember.eps]		The default set can’t be modified, so you need to duplicate the default set and make changes to the new copy.

					4.	Click the Duplicate Set icon at the top of the dialog box and type My Custom Set in the Name text box when prompted; click OK to create the new set.

					5.	With the current menu item selected, locate and click the plus sign beside Shortcuts to add a new shortcut for the menu item.

						The word <empty> appears, ready for you to enter a keyboard shortcut.

					6.	Hold down Ctrl+Shift (Windows) or [image: maccmd]+Shift (Mac) plus the key you want to assign as the keyboard shortcut (for example, Ctrl+Shift+M or [image: maccmd]+Shift+M).

				[image: remember.eps]		Use a letter or a number for a keyboard shortcut. You can also use the Shift, Ctrl, and Alt keys (Windows) or Shift, [image: maccmd], and Option keys (Mac) in combination with a letter or a number to create keyboard shortcuts.

				
					
				
				[image: warning_bomb.eps]		You may receive a warning if the keyboard shortcut you’ve selected is already in use. Make sure the shortcut isn’t assigned to a crucial menu command before you decide to overwrite it.

						The Shortcuts text box fills in the keyboard shortcut as you hold it. Note that if the keyboard shortcut already exists, a warning appears.

					7.	To confirm the shortcut, click the Change button.

					8.	Click OK to close the dialog box and save the shortcut to your new set.

				[image: tip.eps]	At any time, you can return to your custom set in the Keyboard Shortcuts dialog box to add new shortcuts or modify existing ones. If at any point you want to switch sets, return to the Keyboard Shortcuts dialog box and select a different set from the Current Set menu.

				Working with the Movie Explorer

				As a Flash project grows and becomes more complex, moving around the document can be a bit of a guessing game. As you add movie clips, ActionScript, media files, and other elements, the project’s inner workings can overwhelm even the most organized designer.

				For these cases, the Movie Explorer panel (see Figure 8-10) offers an at-a-glance view of your movie. From this panel, you see exactly what’s being used and where, and you can navigate directly to any item on the list. You can filter the panel to show only the types of items you want, whether it’s ActionScript, movie clips, sounds, or type, by clicking and selecting the icon buttons at the top of the panel. To launch Movie Explorer, choose Window⇒Movie Explorer.

					

				
					Figure 8-10: The Movie Explorer panel allows you to navigate your movie by symbols, scripts, and other views.

				

					[image: 9781118168608-fg070810.eps]

			

		

	
		
			
				Chapter 9: Publishing  and Final Delivery

				In This Chapter

				[image: check.png] Getting familiar with the publish process

				[image: check.png] Picking a publish format

				[image: check.png] Previewing your work

				[image: check.png] Publishing for the web

				[image: check.png] Publishing for mobile devices

				[image: check.png] Publishing Adobe AIR applications for the desktop

				[image: check.png] Creating custom publish profiles

				To share your creations with the world, you need to publish your final movie with the Publish command. Before publishing, you can use the Publish Settings option to specify important settings for your final movie, including quality and version settings as well as your choice of file formats. Flash can publish to the web (as SWF and HTML), desktop applications, and now to native mobile platforms such as iOS and Android with the help of Adobe AIR.

				Getting Familiar with the Publish Process

				The .fla or .xfl files you use to build your movie are intended only for the Flash authoring environment. When you’re ready to deliver a final product, you need to use the Publish command (File⇒Publish) to create a final compressed file that can display in a web browser or device.

				The Publish command (File⇒Publish) creates final files for deployment to the web, mobile, or desktop applications. The result can be a finished SWF file, HTML and JavaScript files, or an application installer. For movies intended for the web (such as SWF and HTML files), when the Publish process is complete you can upload completed files to a web server. 

				Before publishing your movie, use the Publish Settings dialog box to tell Flash exactly what type of files you want to generate and which settings to use for each file type. You can specify settings for every file format you choose.

				Selecting Your Formats

				Depending on where and how you plan to distribute your movie, you can have Flash create a variety of different formats at publish time. Although the most common deployment for the web will be a SWF file, Flash can also create standalone players (projectors) or installation packages for desktop and mobile platforms.

				To choose file formats, choose File⇒Publish Settings to open the Publish Settings dialog box. (See Figure 9-1.) You’ll be able to select formats and file types on the left (under Publish and Other Formats), as well as use the Target drop-down list to choose the platform you want to publish for.

					

				
					Figure 9-1: Choose file types and a target to determine what you’ll create during the publish process.

				

					[image: 9781118168608-fg070901.eps]

				Take a look at the different file formats you can publish and where  they’re used:

				[image: check.png] Flash (.swf): SWF is one of the most common file types you’ll publish; it’s the one you need for websites, ad banners and certain mobile browsers (specifically, Android device and Blackberry Playbook browsers). Think about Flash Player as a movie projector and the SWF file as a movie reel you load on it. When publishing for the web, this file type is the one to choose, most often accompanied by an HTML Wrapper to contain it.

				[image: check.png] SWC: SWC files are special library and archive files often used when a developer wants to distribute elements or code to be used by another movie. For instance, with SWC files you can create a symbol library or ActionScript code library to distribute across projects, or to other developers. SWC files are considered an intermediate to advanced topic and aren’t within the scope of this minibook.

				[image: check.png] HTML Wrapper (.html): An HTML file, or a web page, is used as a container for your Flash movie when the target venue is a web browser. HTML files also provide an extra level of control over a SWF, such as enabling looping or setting background color.

				[image: check.png] GIF Image (.gif), JPEG Image (.jpg), and PNG Image (.png): These selections create static images from your movie in the web-friendly GIF, JPEG, and PNG formats (depending on which check boxes you selected). You can use these images as placeholders (in case the user doesn’t have Flash Player or its plug-in) or as elements you can use if you’re creating a non-Flash version of your site.

				[image: warning_bomb.eps]		Keep in mind, however, that images are generated only from the first frame of your movie, so exporting an image from it may not yield much  if your movie starts out blank or with minimal content.

				[image: check.png] Windows Projector (.exe) or Macintosh Projector: A projector is a package that includes your movie and Flash Player all in one. Projectors are useful if you want to present a Flash movie locally (such as within an intranet or distributed as a file) without the need to use a web browser. Because the projector contains Flash Player, a user doesn’t need to install a program to view your movie. Projectors are created as EXE files for Windows or APP files for the Mac. If you’re delivering to users on both platforms, publish a projector for each one.

				[image: warning_bomb.eps]		A projector is not a substitute for a desktop application, and has a number of security restrictions. If you’re interested in creating a desktop application, you should use the Adobe AIR document type or Publish target. 

				Previewing Your Settings

				Before you publish, always use Publish Preview to test the settings you created in the Publish Settings dialog box. Publish Preview creates a preview for any file formats you choose in the Publish Settings dialog box, including web pages, images, and projectors. The preview lets you see how these files will look before you complete your final publish task and gives you a chance to adjust your publish settings for the best results possible.

				To preview any selected publish formats, choose File⇒Publish Preview and select the format you want to preview. The default is based on the type of Flash document you created and the Publish target type you’ve set in Publish Settings.

				[image: tip.eps]	Press the Publish Preview shortcut key combination Ctrl+F12 (Windows) or [image: maccmd]+F12 (Mac) to create a preview from the default selection at any time.

				[image: technicalstuff.eps]	Certain formats may require a bit more setup and information. For example, desktop and mobile applications may require more details to be entered in the Publish Settings dialog box.

				When previewing a movie with either the Test Movie or Publish Preview (SWF publishing only) command, you can use the Bandwidth Profiler. This graph, shown in Figure 9-2, appears at the top of the preview window and shows the total file size of your movie, as well as where and how data is loaded as the movie plays. This step can be important in gauging whether the file size may be too much for users to download or whether you should distribute data-intensive items (such as large sound files or images) more effectively across the Timeline.

				The bars across the graph appear at frames where data is loaded, and the height of the bar indicates how much data was loaded when the playhead reached that frame.

				To view your movie with the Bandwidth Profiler, choose File⇒Publish Preview⇒Flash. When the movie appears in Flash Player, choose View⇒Bandwidth Profiler.

				Publishing for the Web

				If your movie’s final destination is the web you can choose to publish a SWF and HTML Wrapper to contain your new movie and display it in a browser. 

					

				
					Figure 9-2: View the file size and download rate and see how data loads as your movie plays.

				

					[image: 9781118168608-fg070902.tif]

				When you publish files for the web, you can upload those files to your web-hosting account or company server or wherever your movie needs to go to make it available for public viewing. Keep in mind that you may need to upload additional files as well (for example, FLV or F4V video files that accompany your movie).

				To publish the necessary files for web viewing, choose File⇒Publish Settings and select the Flash (.swf) and HTML Wrapper (.html) check boxes from the formats list on the left side of the dialog box. Click the Publish button to create the final files that you’ll upload to your web server of choice.

				Selecting Publish Settings

				After you pick the file types you want to publish, you can specify settings for each selected format in the Publish Settings dialog box. Take time to familiarize yourself with the available options and experiment with different settings until your finished movie is just right.

				[image: tip.eps]	Flash stores publish settings as part of your document, so you need to set them only once for each Flash movie. Be sure to save your movie after you choose your publish settings so that your settings are available the next time you open the document.

				Uploading your files to the web with FTP

				File Transfer Protocol (FTP) is the method used to connect and transfer files between your local computer and a remote web server and is the most common way of posting finished files to the web for the public to see.

				FTP connections occur between your computer and a server that opens the connection to receive the files. Servers often are maintained by a hosting company that provides you with an account and a space for your website files. You may also be posting your work to a network machine or a dedicated server maintained by your company. Flash doesn’t have FTP capabilities, but there are many FTP clients available that you can install on your computer. The FTP clients vary in price and features.

				Adobe Dreamweaver CS6 includes full FTP functionality and can create and store  connections to several different servers or hosting accounts. If you want a more basic (and free) option, you can connect to a web server via FTP by using applications such as Transmit (for Mac OS X) or WSFTP (for Windows). Alternatively, browsers such as Firefox support cool, free add-ons such as FireFTP. In most applications, copying files to and from the server is as simple as dragging and dropping from one window to another.

				Remember: To connect to a server, you need to purchase or have access to a web-hosting account, network computer, or dedicated server. Most FTP connections require a user ID and password; check with your server administrator or hosting company to find information for your specific account.



				Publishing for Desktop and Flash-enabled  Mobile Browsers

				One of the most common venues for Flash content is the web, where your Flash content is displayed in a web browser, such as Internet Explorer, Firefox, Safari, or Chrome, or in mobile device browsers, such as the Android OS browser or the Blackberry Playbook tablet. For the web, you should publish a compressed Flash movie (.swf) as well as an HTML wrapper (.html) which contains the movie.

				Choosing settings for Flash (.swf) files

				SWF files are compressed movies used by Flash Player for display on the web or directly on a user’s computer. When you choose to publish a SWF file, you have the opportunity to specify settings that determine version, security, and quality.

				SWF settings are available when you select Flash (.swf) under the Publish formats on the left side of the Publish Settings dialog box. (See Figure 9-3.) 

					

				
					Figure 9-3: Choose options for your SWF file when you select the Flash (.swf) Publish format from the Publish Settings dialog box.

				

					[image: 9781118168608-fg070903.tif]

				The following list takes a look at some of the settings you’ll work with and how each one affects the performance and quality of your SWF file:

				[image: check.png] Target (global settings): This is used to determine which Flash player version or device you intend on publishing for. This is a general option that affects all settings in the Publish Settings dialog box, but in the context of publishing a SWF, can be used to target a specific version of the Flash Player. You can target earlier versions of the Flash Player for backwards compatibility. 

				[image: tip.eps]		Be aware that publishing to older versions of Flash Player may result in a loss of functionality. Only do this when you absolutely have to. If you’re unsure, leave the default Flash Player version (which at the time of this writing is 11.2).

				[image: check.png] Script (global settings): What you choose in this drop-down list is completely dependent on which version of ActionScript (if any) you’re working with. Because each version contains differences in both features and structure (particularly between ActionScript 3.0 and previous versions), publish in the version you’ve used throughout your movie. If your movie doesn’t use any ActionScript, leave the default setting for the Flash Player version you choose.

						Chapter 7 of this minibook discusses ActionScript and the differences between versions 2.0 and 3.0.

				[image: check.png] Output File: This sets the name and location of the SWF file that will be published. By default, the file will be published under the same name and in the same folder as your FLA or XFL authoring file. You can type in a different name or use the Browse icon to choose a different publish directory.

				[image: check.png] JPEG Quality: Flash performs a certain amount of compression on bitmap graphics in your movie (such as imported photos) to reduce file size and increase performance. Use this slider to determine the amount of compression applied and, in turn, the resulting file size and quality of your movie. The higher the quality, the less compression applied and the larger the resulting file size.

				[image: check.png] Audio Stream and Audio Event: If your movie includes sound, you can set its quality in your final SWF file by clicking the settings beside either Audio Streams or Audio Events. By default, sound is converted to 16 Kbps, Mono and MP3 format, but you can change both compression and quality settings as needed. Keep in mind that, like the JPEG quality settings, using higher-quality settings for sound likely increases the overall file size of your movie.

						Chapter 5 of this minibook discusses working with sounds in your movie.

				[image: check.png] Advanced area: The Flash authoring software can’t open or decompile SWF files for editing, but it can import them as frame-by-frame movies into a FLA document. This strategy opens the door for artwork and graphic resources to be extracted, perhaps against your will. Selecting the Protect from Import check box prevents SWF files from being imported into the Flash authoring environment. The Password text box below the check boxes becomes active when the Protect from Import check box is selected so that you can assign a password to allow only certain parties (a colleague or client, for example) to import the SWF file if they need to.

						The Compress Movie check box, which is selected by default, compresses your SWF file to reduce the file size and, in turn, the download time. Leave this check box selected, especially if your file is ActionScript or text-intensive.

				[image: tip.eps]		Because the Include Hidden Layers check box is selected by default, any layers that are turned off on the Timeline appear in your final movie. Be sure to deselect this option if you want to ensure that hidden content isn’t included.

				Choosing settings for HTML Wrapper files

				For presenting Flash movies on the web, you can publish an HTML Wrapper file that contains your SWF file. This HTML file not only displays your movie, but also includes all code necessary to control dimensions, appearance, and runtime options (such as telling your movie to loop). You’re not required to publish an HTML Wrapper in Flash, but you will be responsible for placing the SWF in an existing HTML file or creating your own wrapper.

				Select the HTML Wrapper (.html) check box in Other Formats section of the Publish Settings dialog box. On the right side of the dialog box, you can set the following options for your published HTML file:

				[image: check.png] Template: This setting determines how the HTML wrapper file will be created, including additional options for special devices or full-screen support.

				[image: check.png] Detect Flash Version check box: This option adds code in your HTML wrapper file to display alternative content if the user doesn’t have Flash Player installed. You can customize this content in any HTML editor. The default content provides a link for the user to download and install the latest version of Flash Player.

				[image: check.png] Dimensions: The code in your HTML wrapper file specifies a size for your Flash movie, which, by default, matches your movie’s dimensions. You can override this setting and force your movie to a different size in either pixels or percentage by typing values in the Width and Height  text boxes. 

				[image: check.png] Playback: Check boxes in this area set runtime options for your Flash movie. By default, Flash Player is directed to loop movies and to make the contextual menu available to the user. You can disable either of these features, force the movie to pause at the start, or use device fonts (fonts from the user’s machine instead of embedded fonts).

				[image: check.png] Quality: Control the overall display quality of your movie by selecting a setting from the drop-down list.

				[image: check.png] Window Mode: This drop-down list lets you choose how Flash appears in the context of your web page. You can set Flash movies to be opaque or transparent to reveal the background of the page.

				[image: check.png] Scale (Scale & Alignment): This drop-down list lets you choose whether the HTML page scales the Flash movie to a size other than its default size.

				[image: check.png] HTML Alignment (Scale & Alignment): Select a left, right, top, or bottom alignment of your movie as determined by the HTML code using the provided drop-down list.

				[image: check.png] Flash Horizontal/ Flash Vertical alignment (Scale & Alignment): This option controls the horizontal and vertical positioning of your Flash movie on the page. Use the drop-down lists to select vertical and horizontal alignment values.

				Publishing your movie

				After you select the correct settings for your target file formats, you can publish your movie in one of two ways:

				[image: check.png] At the bottom of the Publish Settings panel, click the Publish button.

				[image: check.png] Choose File⇒Publish.

				In many cases, you’ll publish a SWF and HTML wrapper file or HTML page so you can view your movie in a web browser, as shown in Figure 9-4.

					

				
					Figure 9-4: A published Flash movie for the web generates a .swf and an HTML wrapper file (shown here in a browser).

				

					[image: 9781118168608-fg070904.eps]

				Publishing Desktop Applications with Adobe AIR

				The AIR (Adobe Integrated Runtime) platform, in version 3 at the time of this writing, gives designers and developers a way to use their existing skills to create cross-platform desktop applications.

				Users can download the AIR runtime for free and install it to manage and play AIR applications directly from their desktops. AIR also provides a platform for creating and deploying native mobile applications to iOS and Android mobile devices directly from Flash. The best news for designers and developers is that AIR applications can be created from standard FLA files in Flash by making a few simple changes to your publish settings.

				AIR applications have several advantages over the use of standard Flash projectors; AIR applications can work with the operating system, files, and other applications without the restrictions faced by projectors in the past.

				[image: tip.eps]	Because AIR applications publish in their own unique format, it’s not necessary to create installers for both Windows and Mac; an AIR application installs and runs on both operating systems!

				Many features unique to AIR applications are beyond the scope of this minibook, so this section covers only the basics of publishing AIR applications from any Flash movie.

				Publishing an AIR application

				Before you get started, download and install the Adobe AIR runtime from the Adobe website at www.adobe.com/products/air. The following steps are based on the Adobe AIR 3.2 release candidate installer, which was the newest available version at the time of this writing.

				Follow these steps to publish your movie as an AIR application:

					1.	Open a document in Flash CS6 that you want to publish as an AIR application.

					2.	Choose File⇒Publish Settings. In the dialog box, locate the Target drop-down list and select Adobe AIR 3.2 for Desktop as the target type, as shown in Figure 9-5.

					3.	Click the Settings icon directly next to the Target drop-down list.

					[image: 9781118168608-ma350.tif]		The AIR Settings dialog box opens, as shown in Figure 9-6.

							A number of options and settings are available:

					•	Output file/Output as: Select a filename and location for your published AIR application. The Mac Installer /Windows Installer option provides an alternative installation file type for the Mac and Windows platforms. If you’re unsure which one to use, leave this option deselected.

					•	App Name: Your application displays this name (Super Picture Viewer, for example) when it’s installed and when it’s running on your desktop.

					

				
					Figure 9-5: To publish your Flash movie as an AIR application, select AIR 3.2 as the target in the Publish Settings dialog box.

				

					[image: 9781118168608-fg070905.eps]

					•	Version: This option indicates which version of an application is installed or running. Attach a version number so that users can distinguish between versions as you create updated releases of your application.

					•	App ID: This identifier is often used to distinguish one company’s applications from another, or even several applications from the same publisher. A common naming scheme is the “reverse DNS” scheme, such as com.mycompany.mycoolapp. If your company is at coolwidgets.com and your app is The Picture Widget, for example, your app ID might be com.coolwidgets.picturewidget.

					•	Description: In this area, you can provide a description of your  application — for example, “The Picture Widget lets you view and organize your mobile phone snapshots quickly and easily.”

					•	Copyright: Enter your copyright information here (for example, 2012 CoolWidgets.com).

					

				
					Figure 9-6: The AIR Settings dialog box.

				

					[image: 9781118168608-fg070906.eps]

					•	Window Style: This setting determines how your application is “framed” within the operating system environment. You can use the default system windows (System Chrome); your own, custom frame; or even no frame (Custom Chrome — opaque or transparent).

					•	Render Mode: Determines whether or not AIR should render the application with your graphics processing unit (GPU) or the main central processing unit (CPU).

					•	Included Files: This panel shows all files to be packaged and included in the AIR application, typically a .swf file and an application manifest (.xml) file. If your application depends on other files (such as external audio or video files), you can add them here as necessary.

					4.	After you finalize your settings, click the Publish button at the bottom of the AIR settings dialog box.

						The Certificate tab of the Settings dialog box will appear, prompting you to choose or create a digital certificate for signing your application.

					5.	Click the New (Mac) or Create (Windows) button on the right side and, in the dialog box that opens, fill in the information necessary to create your own self-signed certificate.

						For more information on digital certificates, see the nearby sidebar named “What’s a digital certificate?”

					6.	Enter information for the publisher name, organization unit, organization name, country, and password, and then click Browse to choose a save location, as shown in Figure 9-7.

					

				
					Figure 9-7: Create your self-signed digital certificate for the purpose of testing and distributing your application.

				

					[image: 9781118168608-fg070907.eps]

					7.	Click OK to create and save your certificate.

						This step returns you to the digital signature dialog box, where your new certificate is already selected.

					8.	Reenter the password you chose when you created your certificate and click Publish.

						A dialog box notifies you that your AIR file has been created.

					9.	Click OK to exit the Application & Installer Settings dialog box and then click OK to close the Publish Settings dialog box.

				Installing and running your new AIR application

				Before giving your new desktop application a test run, make sure that you’ve installed the latest version of the Adobe AIR Runtime from www.adobe.com/products/air.html.

				What’s a digital certificate?

				A digital certificate is a verification of the publisher’s authenticity (that’s you!). You can create a digital certificate yourself, or Flash creates a temporary AIRI file until you do. Certificates are necessary to publish working AIR applications or applications for mobile devices.

				Because an AIR application (much like any other desktop application) has access to many aspects of the user’s computer, a certificate is necessary for AIR to trust an application before installing it. Though you can create your own certificate for publishing purposes, you should obtain a certificate from globally trusted third-party providers such as GeoTrust, Thawte, or VeriSign if you intend to distribute your application commercially. This principle also applies to mobile applications.



				Any user who needs to run your application needs to also install the Adobe AIR Runtime by using the same URL in the preceding paragraph. The good news is that many users already have AIR installed, and if not, it’s a fast, free download from the Adobe website.

				To install and run the AIR application, locate and double-click the .air file you published. The Adobe AIR Runtime launches, and a dialog box prompts you to install the new application, as shown in Figure 9-8. Click Install. Your application is now installed!

					

				
					Figure 9-8:  The Adobe AIR application installer.

				

					[image: 9781118168608-fg070908.eps]

				Publishing for Mobile Devices

				With hundreds of thousands of apps (and climbing) available in both the Apple App Store and Android Marketplace alone, it’s clear that the mobile landscape shows no signs of slowing down. Although a great deal of rich content can be delivered through a mobile device browser, there is no match for the convenience, integration, and processing power available  with a native mobile application.

				With the new AIR for iOS and AIR for Android publishing options, developers can now use Flash as a development platform for apps and games on the iPhone, iPad, and Android devices.

				The processes of setting yourself up as a developer, and of creating a viable testing and publishing setup for iOS and Android are beyond the scope of this book. A number of options set during this publishing process require an understanding of the particular tools and setups necessary for each individual platform. This section touches on the basics for selecting these options in Flash CS6, but for more information we recommend the following:

				[image: check.png] For development on the Apple iOS platform, visit the iOS Developer center on Apple.com (http://developer.apple.com/devcenter/ ios/index.action) to set up a new developer account and get started.

				[image: check.png] For development on the Android OS, visit the Android Developer center at http://developer.android.com/index.html to get started.

				[image: check.png] Consult with your development team, IT department, or employer to find out about the available test devices, simulators, and existing developer accounts needed for your platform of choice.

				[image: tip.eps]	Before starting or publishing an application, make sure it meets the guidelines suggested by the respective SDK or Developer Center. You can get started in the right direction by using one of the pre-sized AIR for iOS or  AIR for Android document types. 

				To publish an application for iOS, follow these steps:

					1.	Choose File⇒Publish Settings and make sure the Target is set as  AIR 3.2 for iOS.

					2.	Click the Player Settings button to the right of the Target drop-down list to open the AIR for iOS settings dialog box.

					3.	Under the General settings tab, fill in the appropriate name and output file for your app. Make sure that settings for Aspect Ratio, Render Mode and Device are correct for your application, as shown  in Figure 9-9.

					

				
					Figure 9-9: The AIR for iOS Settings dialog box. 

				

					[image: 9781118168608-fg070909.eps]

					4.	Under the Deployment tab, select the certificate provided to you for iOS development as part of your developer account and provisioning profile. Also, specify your provisioning profile.

				[image: tip.eps]		A provisioning profile is created as part of your iOS developer account, and ties you (as well as other developers) to a set of test devices and an authorized development group. If you are a designer/developer within an organization, it’s possible that you can obtain this profile from your IT department, development manager, or whoever manages your company’s developer account with Apple.

					5.	Select your Deployment type, which determines how the app is packaged. You can package it for final App Store delivery or specifically for local testing and debugging.

					6.	Under the Icons tab, specify an icon graphic file for each of the required icon sizes as shown.

						For specs and guidelines on preparing icons for an iPhone or iPad application, refer to the iOS developer center or this article at http://developer.apple.com/library/ios/#documentation/user experience/conceptual/mobilehig/IconsImages/Icons Images.html.

					7.	Under the Languages tab, select the languages your application  is targeting.

						If you’re focused only on North American and English-speaking users, select English for now. If you’re working as part of a team, make sure to consult with your development team or employer to make sure this setting is correct.

					8.	Click OK to close the AIR for iOS Settings dialog box. Click OK to close the Publish Settings dialog box and save your options, or click Publish to publish your application right away.

				[image: tip.eps]		To avoid re-entering similar publishing information for other applications, refer to the section, “Creating Publish Profiles,” later in this  chapter, to find out how save your Publish Settings for later use.

				To publish an application for Android OS, follow these steps:

					1.	Choose File⇒Publish Settings to open the Publish Settings dialog box.

					2.	Make sure AIR 3.2 for Android is selected in the Target drop-down list. Click the Target Settings button next to the Target drop-down list to open the AIR for Android settings dialog box.

					3.	Under the General settings tab, fill in the appropriate name and output file for your app. Make sure that settings for Aspect Ratio, Render Mode, and Device are correct for your application.

					4.	Under the Deployment tab, select an .apk certificate provided to you for development. You can also create a self-signed certificate for temporary use and debugging by clicking the Create button. 

						Certificates are necessary for distribution in the Android Marketplace as well as installation on a device. For more information, read about app signing at http://developer.android.com/guide/publishing/app-signing.html.

					5.	Choose your deployment type — the type depends on whether you’re creating a final release for distribution or a local build for debugging on a test device or emulator.

					6.	Under the Icons tab, specify the icon graphic files to use for each required size.

					7.	Under the Permissions tab, select the permissions necessary for your application to run.

						For instance, if your application requires the use of the device camera, select Camera.

					8.	Under the Languages tab, select the languages your application is  targeting.

						If you’re focused only on North American and English-speaking users, select English for now. If you’re working as part of a team, consult with your development team or employer to make sure this setting is correct.

					9.	Click OK to close the AIR for Android Settings dialog box. Click OK to close the Publish Settings dialog box and save your options, or Publish to publish your application right away.

				Creating Publish Profiles

				If you want to use the same publish settings across multiple movies, you  can capture your settings as a profile that you can recall and use in other documents.

				To create a new publish profile, follow these steps:

					1.	Choose File⇒Publish Settings to open the Publish Settings dialog box. (Refer to Figure 9-1.)

					2.	Choose a target, publish formats and specify settings as described earlier in this chapter (“Selecting Publish Settings”).

						3.	[image: 9781118168608-ma137.tif] Locate and click the Profile Options icon next to the Profile drop-down list, and select Create Profile from the menu that appears. A dialog box appears, prompting you to assign the new profile a name.

					4.	Enter the profile name in the Profile name text box and click OK.

						The profile is created and is an available option under the Profile drop-down list at the top of the Publish Settings dialog box.

				To make your profile available to other documents, export it:

					1.	Choose File⇒Publish Settings to open the Publish Settings dialog box.

					2.	Click the Profile Options icon next to the Profile drop-down list, and select Export Profile.

						You’re prompted to name and save your profile (stored as a separate .xml file). Although you can save the file anywhere, it’s best to keep  it in the Flash application’s Publish Profiles folder, which is the default location.

					3.	Assign the file a name by typing it in the File Name (Windows)/Save As (Mac) text box, choose a Save location, and click Save.

				To import a profile from another document, follow these steps:

					1.	Choose File⇒Publish Settings to open the Publish Settings dialog box.

					2.	Click the Profile Options icon next to the Profile drop-down list and then select Import Profile.

						The Import Profile dialog box appears, as shown in Figure 9-10

					

				
					Figure 9-10: Import profiles you’ve exported to locations on your hard drive.

				

					[image: 9781118168608-fg070911.eps]

					3.	Browse to and locate the XML file you created when you exported the profile and click Open.

						The profile is now available under the Current Profiles drop-down list at the top of the Publish Settings dialog box.

				Additional resources

				One outstanding element of working with Flash is the community that supports it. Countless websites are dedicated to Flash tutorials, training videos, inspiration, free resources (such as fonts and sounds), and forums to discuss and assist developers of all levels with a variety of Flash help topics.

				We don’t have room to list them all, but here’s a short list of established and highly visited sites that can get you started. (Note: This list isn’t complete, nor is it an endorsement of any specific website. These websites have been shown to be reputable and highly useful resources or inspiration for Flash developers. You’re encouraged to be a part of the Flash community by using and contributing to these and other online resources to further your own knowledge.)

				ActionScript.org, www.actionscript.org: A site dedicated to Flash and ActionScript development and tutorials. 

				Go To and Learn, www.gotoandlearn.com: A great tutorial resource with free videos. 

				Lee Brimelow’s Flash Blog, www.lee brimelow.com: A great blog from Adobe Evangelist Lee Brimelow. 

				Colin Moock, www.moock.org: A pioneer and expert in the world of ActionScript. 

				Favourite Web Site Awards, www.thefwa.com: - A showcase of innovative, cutting-edge and beautiful web sites.

				Kirupa.com, www.kirupa.com: A site  dedicated to Flash and ActionScript tutorials, and more. 

				Flash Developer Center, www.adobe.com/devnet/flash.html: The Adobe official Flash developer center. 
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				Chapter 1: Introducing  Fireworks CS6

				In This Chapter

				[image: check.png] Understanding when you should use Fireworks

				[image: check.png] Discovering the workspace

				[image: check.png] Finding out about the tools

				[image: check.png] Looking into the views

				[image: check.png] Using the basic selection tools

				Adobe Fireworks is an incredible application that offers solutions to meet the needs of designers creating onscreen presentations, including business presentations and presentations for the web or mobile devices. Using Fireworks, you can experiment with different optimization settings to preview your artwork and make sure it looks great no matter where it appears. You can also build prototypes (or wireframes) to make sure that your site is organized before investing lots of time in the nitty-gritty details.

				[image: remember.eps]	A wireframe is essentially a mock-up or rough draft created to demonstrate or test a website. In web design, wireframes are basic visual guides used to suggest the layout and placement of fundamental design elements.

				In this chapter, you’re introduced to the Fireworks software and its workspace. You also discover how to use selection tools so that you can start to manipulate graphics in Fireworks right away.

				Why Use Fireworks?

				Because you can use the Save for Web feature in Adobe Photoshop or Adobe Illustrator to create onscreen graphics, why do you need a separate application like Fireworks? Mostly because Fireworks offers several benefits that aren’t offered in Illustrator and Photoshop, including the following:

				[image: check.png] Live optimization preview: As you work and make changes in Fireworks, you can simultaneously view the effect of those changes on your final optimized artwork.

				[image: check.png] Easily create clickable regions: Using the image map feature, you can set up regions of your graphics to be clickable.

				[image: check.png] Create rollovers: You can demonstrate the effect of a user rolling over a graphic in order to demonstrate interactivity on the screen.

				[image: check.png] Work intuitively by taking advantage of its logical interface: This interface provides panels and features that relate to the web and that offer you the easiest way to optimize (make web-ready) graphics.

				[image: remember.eps]	Many of these features, such as image maps and rollovers, are used in the prototyping stage to show a client or team how the final site or application will work. Such features are useful, but they’re best used only during the prototyping stage. For the final product, most developers prefer to use standard coding methods, such as Cascading Style Sheets. If you’re the designer, you can use Fireworks to design and create your online experience, and then allow a developer (if it isn’t you) to build the site by using CSS or JavaScript.

				Working in Fireworks CS6

				One of Fireworks’s big advantages is that it’s built specifically for creating onscreen graphics. When working onscreen, you’re working strictly with pixels — not messy dpi (dots per inch) or lpi (lines per inch), which are typical printing concerns.

				Figure 1-1 shows the dialog box that appears when you choose File⇒Open to open a vector graphic that was created in Adobe Illustrator. The dialog box offers conversion choices but emphasizes pixel dimensions.

					

				
					Figure 1-1:  Pixel dimensions play an important role in Fireworks.

				

					[image: 9781118168608-fg080101.eps]

				
				[image: technicalstuff.eps]	Anytime you’re working with web images, you should know the approximate width, in pixels, of your final screen display. The width of a typical web page ranges from 650 to 1,000 pixels, but most designers stick with a screen built to span approximately 960 pixels. When you create images, you must think about how those images will fit within the context of the total screen. An image 600 pixels wide would fill three-quarters of a screen, whereas an image 1,200 pixels wide would force the viewer to scroll to see the entire image.

				When you launch Fireworks CS6, you notice right away that its workspace is similar to the workspaces in the other CS6 applications. Adobe has done a good job of organizing each application so that the learning curve from one application to another is quick and integration is easy.

				As you might expect, the toolbox is to the left of the workspace and the panels are to the right. The tools even look much like the tools in other CS6 applications.

				Using the tools

				The Tools panel is sorted into six categories: Select, Bitmap, Vector, Web, Colors, and View. Table 1-1 lists the tools by category and the keys you can press to access them.

		[image: /Table tb080101a]

		[image: /Table tb080101b]

		[image: /Table tb080101c]

				
				
				As you select each tool, the Properties panel displays additional options. (If your Properties panel isn’t visible, choose Window⇒Properties.)

				Understanding the views

				The tabs at the top of an image window give you the opportunity to view it in four ways:

				[image: check.png] Original displays your image as it appears before being optimized for the web.

				[image: check.png] Preview displays the image as it will appear when it’s saved for the web, based on your current settings. (You can find out more about those settings in Chapter 5 of this minibook.)

				[image: check.png] 2-Up offers the opportunity to see an image in two windows, with different settings applied in each one. Most users tend to compare the original and optimized images in this view. (See Figure 1-2.)

					

				
					Figure 1-2: Compare the original (left) and optimized (right) images in 2-Up view.

				

					[image: 9781118168608-fg080102.eps]

				[image: check.png] 4-Up offers you four separate views from which you can experiment with settings. You don’t necessarily need to compare different formats when you use this view; you can experiment with different options for one format, such as pushing the limit with the amount of colors you want to keep in a GIF file, as shown in Figure 1-3.

					

				
					Figure 1-3:  In 4-Up view, you can experiment with ways to optimize an image.

				

					[image: 9781118168608-fg080103.tif]

				Investigating the panels

				Not unlike the other CS6 applications, Fireworks allows you to detach panels from the docking area on the right side of the workspace. This procedure is similar to the methods you use to dock and undock panels in other CS6 applications. You can find out more about docking and undocking panels in Book I, Chapter 3.

				[image: remember.eps]	If you can’t locate a panel, choose its name from the Window menu.

				Working with Basic Selection Tools

				You can work in Fireworks using the same selection tools for both vector and bitmap images.

				Making a selection in a bitmap image

				If you’re familiar with Photoshop selection techniques, you’ll have no problem using the same tools in Fireworks. Here’s how to make selections with the Marquee and Lasso tools:

					[image: check.png] [image: 9781118168608-ma109.tif] Marquee: To make a selection with the Marquee tool, simply select it from the Tools panel and then click and drag to surround the area you want to select. You can add to the selection by holding down the Shift key and dragging another marquee region, or deselect a portion of the active selection by holding down the Alt (Windows) or Option (Mac) key while dragging with the Marquee tool.

					[image: check.png] [image: 9781118168608-ma110.tif] Lasso: To use the Lasso tool, select it from the Tools panel and click and drag to create a path that then becomes your selection. As mentioned in the Marquee bullet, you can add to the selection by holding down the Shift key and creating another selection region, or subtract from the selection by holding down the Alt (Windows) or Option (Mac) key while dragging a selection region with the Lasso tool.

				[image: tip.eps]	You can use both the Marquee and Lasso tools interchangeably when making a selection.

					[image: 9781118168608-ma103.tif]	By making a selection with the Marquee tool or Lasso tool and then clicking and dragging with the Pointer tool, you can move one part of an image to another, as shown in Figure 1-4. If you make no selection before you drag, everything on the existing layer is moved.

					

				
					Figure 1-4: Drag a selection to move it.

				

					[image: 9781118168608-fg080104.tif]

				Switch to the Subselection tool and notice that if you have an existing selection, the pointer changes to a double arrow, indicating that you will clone (copy) the selection when you click and drag it.

				Making a selection in a vector image

				By using the same tools you use to select bitmap images, you can adjust vector paths. Use the Pointer tool to move an entire vector shape, as shown in Figure 1-5.

				Use the Subselection tool to move the individual points on the path.

					

				
					Figure 1-5: The Pointer tool lets you move a vector shape.

				

					[image: 9781118168608-fg080105.tif]

			

		

	
		
			
				Chapter 2: Free to Create

				In This Chapter

				[image: check.png] Taking advantage of layers in Fireworks

				[image: check.png] Understanding the difference between vector and bitmap images

				[image: check.png] Using the bitmap and vector drawing tools

				[image: check.png] Discovering masking

				You can easily import graphics into Fireworks from the other Creative Suite 6 applications or create your own graphics. Fireworks comes with a full set of tools for creating both bitmap and vector images. This chapter briefly discusses bitmap and vector graphics; you can find out more by reading Book I, Chapter 6.

				Understanding What Happens in Layers

				Create a new document by choosing File⇒New. If the Layers panel isn’t  visible, choose Window⇒Layers. By default, the Layers panel contains two layers: Web Layer and Layer 1.

				Web Layer is reserved for web objects, such as hotspots, slices, and other interactive objects. You can’t delete, duplicate, or rename objects in this layer. You find out more about the Web Layer in Chapter 6 of this minibook.

				Layer 1 is also a default layer. Everything that you create or import, whether it’s a bitmap or a vector graphic, lands here, essentially becoming a sublayer of Layer 1.

				You can rename both main layers and sublayers. You can also reposition, delete, and duplicate them by using the tools at the bottom of the Layers panel. (See Figure 2-1.)

					

				
					Figure 2-1: The Layers panel includes Web Layer and Layer 1.

				

					[image: 9781118168608-fg080201.eps]

				Understanding this layer organization and how it relates to drawing in Fireworks is important. When you use bitmap tools to paint and create pixels, everything falls on one layer, much as you would expect. But when you start creating vector shapes, every new shape lands on a new layer. This arrangement makes it easier for you to move the shapes independently but can be confusing to new Fireworks users.

				Choosing Vector or Bitmap Graphics

				If you didn’t read enough about vector versus bitmap graphics before starting this minibook, you get even more information in this section.

				Fireworks lets you work in a painterly fashion with the bitmap tools. These tools work like the brush and retouching tools in Photoshop, in that they are pixel based. You can use the bitmap tools to create smoother transitions and more realistic contours and shapes.

				Why not use bitmap images for all your artwork? One drawback is that bitmap images tend to have a larger file size than vector images. Also, bitmap images aren’t scalable, as vector graphics are. Sometimes, it’s fairly clear when to use a bitmap instead of a vector image; see Figure 2-2 for an example.

				Most designers use bitmap images for more realistic artwork, such as photorealistic renderings, and vector images for more graphical artwork, such as stylized buttons and logos.

				[image: remember.eps]	No matter whether you use bitmap or vector drawing tools to create a graphic, it’s a bitmap image when it’s optimized (saved for the web). Even if you use vector drawing tools in Fireworks, you see the graphic broken into pixels in the preview windows.

					

				
					Figure 2-2: You can draw both bitmap (top) and vector (bottom) graphics in Fireworks.

				

					[image: 9781118168608-fg080202.tif]

				Creating with Bitmap Tools

				The first tools we investigate in this chapter are the bitmap tools: Blur, Brush, Eraser, Lasso, Magic Wand, Marquee, Pencil, and Rubber Stamp. We cover these tools briefly, focusing on the differences between using them in Fireworks and in other bitmap applications, such as Photoshop. If you don’t see the Tools panel, choose Window⇒Tools.

				Selecting pixels

				The selection tools let you grab hold of pixels. You use the Marquee tool, for example, to select a section of pixels that you want to move, clone, or change in some way. To experiment with the Marquee tool, follow these steps:

					1.	Choose File⇒New to create a new Fireworks document.

						The New dialog box appears.

					2.	Type 500 in both the Width and Height text boxes; leave Canvas set to White; then click OK.

						A new, blank document opens.

					3.	Use the Marquee tool to click and drag in the workspace from top left to bottom right to create a rectangular marquee.

					4.	Choose Window⇒Swatches to open the Swatches panel.

					5.	Click any color you want to use for the fill of your selection.

					6.	Click the Paint Bucket tool (in the Colors section of the Tools panel) and then click inside the selection marquee to fill it with your selected color.

				You’ve successfully created a bitmap graphic in Fireworks. In the next section, you use other bitmap tools to make changes in this artwork.

				Moving pixels

				In this section, you use the Marquee tool to move the pixels to another location. If you’re a Photoshop user, notice that the Marquee tool works just like the selection tools in Photoshop.

				To move the graphic you just selected, follow these steps:

					1.	With the Marquee tool, click and drag over the bottom of your bitmap rectangle.

					2.	Select the Pointer tool and then drag the marquee down, as shown in Figure 2-3.

					

				
					Figure 2-3: Move a selection with the Pointer tool.

				

					[image: 9781118168608-fg080203.eps]

				Changing the way pixels appear

				If you’ve followed along, you know how to select and move pixels and you’re ready to change the way selected pixels appear. To do that, follow these steps:

					1.	Choose Select⇒Deselect or use the keyboard shortcut Ctrl+D (Windows) or [image: maccmd]+D (Mac), to make sure you have no active selections.

					2.	Hold down the Marquee tool to select the hidden Oval Marquee tool.

					3.	While holding down the Alt (Windows) or Option (Mac) key, click and drag from the center of the rectangle you created. (See the top of Figure 2-4.)

				[image: tip.eps]		Many shortcuts you use in Illustrator and Photoshop also work in Fireworks — but not all. Finding compatible shortcuts is sort of hit-or-miss when you’re in the beginning stage with Fireworks. For details, choose Help⇒Fireworks Help and select Preferences and Keyboard Shortcuts from the list of topics on the left side of the Help window.

					

				
					Figure 2-4: Making a feathered, oval selection.

				

					[image: 9781118168608-fg080204.eps]

					4.	To feather (soften) the edges of the selection, choose Feather from the Edge drop-down list in the Properties panel and set a feathering value (10 pixels is the default) in the combo box to the right of the Edge drop-down list. (Refer to the middle of Figure 2-4.)

					5.	Press Ctrl+X (Windows) or [image: maccmd]+X (Mac) to delete your feather selection.

						The bottom of Figure 2-4 shows the result.

				Using additional bitmap tools

				Many bitmap tools are available for you to use in Fireworks, and here are some of these additional tools:

				[image: check.png] Brush: The Brush tool lets you paint just like you would in Photoshop, and you can mix it up with the selection tools to create interesting  artwork.

						Options for the Brush tool — such as size, softness, and transparency —  are located in the Properties panel at the bottom of the workspace. Unfortunately, not all the great brush shortcuts in Photoshop work in Fireworks, so you may have to access the Properties panel in Fireworks more often than you may be used to.

				[image: check.png] Editing tools: Because you’re working with pixels, you can edit those pixels rather easily. Choose a tool:

					•	Pencil: Use the Pencil tool to add detail.

					•	Blur: The Blur tool softens edges.

					•	Eraser: The Eraser tool eliminates pixels.

				[image: check.png] Rubber Stamp: The Rubber Stamp tool is similar to the one in Photoshop, and you use it the same way. Simply Alt-click (Windows) or Option-click (Mac) a bitmap source that you want to clone; then release the Alt or Option key and start painting somewhere else in the image area. The source is re-created or cloned as you paint with the Rubber Stamp tool.

				If you make a mistake, you can undo multiple steps in Fireworks by pressing Ctrl+Z (Windows) or [image: maccmd]+Z (Mac) repeatedly. If you want to redo a step (essentially undoing an undo), press Ctrl+Y (Windows) or [image: maccmd]+Y (Mac).

				Creating with Vector Tools

				The Vector tools in Fireworks are similar to the ones you may be used to in Illustrator or Photoshop. What you should notice right off the bat in Fireworks is that every time you create a new vector shape with one of the vector tools (such as Line, Pen, Shape, or Type), Fireworks creates a new sublayer automatically. This arrangement lets you move the shapes freely and independently.

				[image: warning_bomb.eps]	Before repositioning or making other transformations in vector images, confirm which sublayer is active by looking for the highlighted sublayer in the Layers panel. Otherwise, you may unexpectedly move the wrong image.

				Using shape tools

				To use a shape tool, simply click it and drag it in the workspace. A shape is created, and a new sublayer is added automatically in the Layers panel.

				In addition to the basic shape tools, Fireworks has more shapes that are useful for designing buttons, icons, and other web graphics. To find these shapes, click and hold the Rectangle tool in the Tools panel. Hidden shape tools appear such as stars, arrows, and beveled rectangles.

				After you create a shape using a shape tool, you can edit it by using the Pointer and Subselection tools:

				[image: check.png] Pointer: If you need to reposition the shape, select the Pointer tool and click and drag it to a new location. You can also grab the highlighted anchor points to resize the shape.

				[image: check.png] Subselection: If you need to make more defined shape changes (such as changing the corner radius, bevel, or overall shape of the vector graphic), switch to the Subselection tool. It works much like the Select and Direct Select tools in Illustrator and Photoshop.

				Creating a path

				The most popular vector tool in most applications is the Pen tool. Using this tool in a freeform manner, you can create any shape you want (including the type you need to make a button look like it has a reflection, for example) or create your own, custom graphics.

				Fireworks offers three types of path tools, shown in Figure 2-5:

				[image: check.png] The Pen tool works much like other Pen tools. You create a path by clicking from one location to another (creating anchor points) or by clicking and dragging to create curved sections of paths.

				[image: check.png] The Vector Path tool lets you click and drag in a painterly fashion to create a path.

				[image: check.png] The Redraw Path tool lets you reshape a path (by dragging it over an existing path) while maintaining the original stroke information.

					

				
					Figure 2-5: These three tools help you create paths in Fireworks.

				

					[image: 9781118168608-fg080205.eps]

				Changing an existing path

				If you have a hard time using the Pen tool or want to make freeform adjustments, you can get truly excellent results by using the Freeform tool.

				To use the Freeform tool with an existing path active (select it with the Pointer tool), follow these steps:

					1.	Click the Freeform tool to select it; then click and drag in the workspace to change the way the path looks.

						You can bend the path in different smooth directions.

					2.	In the Properties panel, set options to specify the width of the change.

				Another tool hidden in the Freeform tool is the Reshape Area tool, which is handy for reshaping existing paths. (See Figure 2-6.) This tool lets you set a reshape size area in the Properties panel and then edit selected paths by clicking and dragging over them.

					

				
					Figure 2-6: Change existing paths with the Reshape Area tool.

				

					[image: 9781118168608-fg080206.tif]

				The additional path-scrubber tools let you edit paths that have pressure-sensitive strokes. In fact if you do not have paths created using a pressure-sensitive device, you cannot use these tools.

				Working with type

				Feel free to scale your text to your heart’s delight; text is vector! To create text in an image area, simply select the Text tool, click to set the insertion point, and then start typing. Use the Properties panel to change the font and size as well as other text attributes. Chapter 4 in this minibook discusses text and its formatting capabilities.

				Masking: Going Beyond Tape

				You can mask in Fireworks, but you don’t use quite the same method as you use in Illustrator, InDesign, or Photoshop. The result is essentially the same, however.

				A mask lets you choose which part of a graphic is exposed and which part is covered (by the mask). See Figure 2-7 for an example of two vector graphics that have been masked with a gradient fill to fade the transparency from 100 percent to none.

					

				
					Figure 2-7: Two vector shapes with masks applied to them.

				

					[image: 9781118168608-fg080207.eps]

				To apply a gradient mask, follow these steps:

					1.	Create a vector shape (such as an arrow).

					2.	In the Layers panel, choose Add Mask from the panel menu.

						A blank mask appears to the right of the vector shape’s sublayer, as shown in Figure 2-8.

					

				
					Figure 2-8: Adding a mask to a sublayer.

				

					[image: 9781118168608-fg080208.tif]

					3.	With the new mask active, click and hold the Paint Bucket tool to select the hidden Gradient tool.

					4.	With the Gradient tool, click and drag across the shape to make the gradient on the mask and create the transparency effect on the vector shape.

						Notice that where the gradient is darker, the image is less visible, and where the gradient is lighter, the vector shape is more visible, as shown in Figure 2-9.

					

				
					Figure 2-9: The arrow shows through more where the gradient is lighter.

				

					[image: 9781118168608-fg080209.tif]

				You can experiment with this effect on other shapes. Also, you can try clicking and dragging the gradient until you get the depth and direction you want.

				[image: tip.eps]	A gradient tends to work better as a mask if you use its default colors: black and white.

				

			

		

	
		
			
				Chapter 3: Livening Up Your Artwork with Color

				In This Chapter

				[image: check.png] Defining colors for the web

				[image: check.png] Finding and applying colors to graphics

				[image: check.png] Creating your own colors in Fireworks

				[image: check.png] Using gradient fills

				Like most other Creative Suite applications, Fireworks lets you define an object’s fill and stroke. You can use some unique tools for that task. You can also take advantage of some hidden features that might be new to you.

				In this chapter, you find out how to apply a fill or stroke color to your artwork, and you also discover the basic steps for working with gradient fills.

				Choosing Web Colors

				Colors appear differently on a monitor from the way they do when you view them offscreen, but this issue isn’t as serious now as it was in the past. Years ago, you had to base your color selections on the lowest common denominator. Most viewers now have monitors that can display thousands, if not millions, of colors.

				[image: remember.eps]	When you’re choosing a color for the web, don’t fret over the exactness of a color viewed on different monitors unless precision is critical. Critical color can apply to your company logo or to fabrics (for clothing websites) that viewers might be comparing onscreen.

				In Fireworks, you can choose colors from several panels, with each panel offering a different model from which to create them. Even though you’re working in RGB (Red, Green, Blue), you can still enter CMYK (Cyan, Magenta, Yellow, Key or Black) or HSB (Hue, Saturation, Brightness) values.

				Finding Colors in Fireworks

				Perhaps you want to create a simple shape with a fill, which seems easy, but if you’re unfamiliar with Fireworks, you may need a little direction to get this task done.

				You can find most Fireworks color functions in the Colors section of the Tools panel. This section features an Eyedropper tool for sampling color, as well as color boxes that help you easily stroke and fill both bitmap and vector graphics.

				You can set additional attributes for color in the Properties panel, including textures you can apply from the Texture drop-down list.

				Applying Colors to Vector Objects

				To create and color a vector object, follow these steps:

					1.	Choose File⇒New to create a new blank document.

					2.	Create a path or a shape with the vector drawing tools and leave that object selected.

					3.	To apply a fill color, click the Fill Color box located in the Colors section of the Tools panel and then click the color you want to apply from the pop-up Swatches panel. (See Figure 3-1.)

					4.	To apply a stroke color, click the Stroke Color box in the Tools panel and then select the color you want to apply from the pop-up Swatches panel.

					

				
					Figure 3-1:  Take advantage of the Fill Color options.

				

					[image: 9781118168608-fg080301.tif]

				Adding Colors to Fireworks

				Assigning a fill or stroke color to graphics is relatively simple. But what if the color you want to use isn’t in the default Swatches panel? In that case, you need to create a color and add it to the panel. You can accomplish this task in several ways. In the following sections, we cover using the Eyedropper tool and the Color Palette panel.

				Adding a color with the Eyedropper tool

				The Eyedropper tool is useful when you have a color to sample. Just select the tool, click any color (in your working document or in any other open Fireworks document), and then choose Window⇒Swatches. When the Swatches panel pops up, as shown in Figure 3-2, click an empty area, and your sample color is added.

					

				
					Figure 3-2:  Select a color with the Eyedropper tool and then click the Swatches panel to save the color.

				

					[image: 9781118168608-fg080302.tif]

				[image: tip.eps]	To remove a color from the Swatches panel, position the mouse pointer over the color you want to delete and press Ctrl+Alt (Windows) or [image: maccmd]+Option (Mac). When the scissors pointer appears, click the mouse button; the color is deleted.

				Adding a color with the Color Palette panel

				The color palette is a dynamic and fun way to set color. Each of its three tabs offers the opportunity to choose a stroke or fill color and a different method of selecting that color.

				You can open the Color palette by choosing Windows⇒Others⇒Color Palette.

				The three color palette tabs are

				[image: check.png] Selector: The Selector tab (see Figure 3-3) lets you pick a color in any of four color models: HLS (Hue, Lightness, Saturation), HSV (Hue, Saturation, Value), CMYK, and RGB. Click the large color panel and then enter color values by using the sliders or text boxes at the bottom. To adjust the tonal value, use the slider to the right of the large color panel.

					

				
					Figure 3-3: The color palette’s Selector tab gives you a choice of four color models.

				

					[image: 9781118168608-fg080303.eps]

				[image: check.png] Mixers: The Mixers tab (see Figure 3-4) lets you assign multiple colors by using the color wheel. You can also create a tint build at the bottom of the window so that you can build combinations of colors. In addition, you can export the colors as a bitmap or a table using the Export buttons on the left side of the Mixer tab, which makes it easy to reference them later.

					

				
					Figure 3-4: On the Mixers tab, create colors with the color wheel or the tint builder.

				

					[image: 9781118168608-fg080304.eps]

				[image: check.png] Blender: The Blender tab (see Figure 3-5) lets you select two colors and then view and choose combinations of those colors.

					

				
					Figure 3-5:  Blend two colors using the Blender tab in the Color Palette panel.

				

					[image: 9781118168608-fg080305.eps]

				To blend colors, enter two color values in the text boxes at the bottom of the Blender tab and then use the slider to view various combinations of the two selected colors.

				Creating Gradients

				You can add some dimension to a graphic by filling it with a gradient. To create a gradient in Fireworks, follow these steps:

					1.	Create a shape that you want to fill with a gradient.

					2.	With the shape selected, click and hold the Paint Bucket tool in the Colors section of the Tools panel and then select the hidden Gradient tool, as shown in Figure 3-6.

					

				
					Figure 3-6: Select the Gradient tool.

				

					[image: 9781118168608-fg080306.tif]

					3.	Click the Fill Color box in the Tools panel to assign colors to the  gradient.

						The Fill Options window appears, as shown in Figure 3-7.

					

				
					Figure 3-7: Assign the gradient colors.

				

					[image: 9781118168608-fg080307.tif]

					4.	To assign colors to the gradient, simply click the existing color stops and choose a color from the pop-up palette.

					5.	Click anywhere on the gradient ramp to add a stop, and edit the color.

				[image: tip.eps]	If you don’t want to create your own gradient, use the Preset drop-down list to select from existing gradients, as shown in Figure 3-8.

					

				
					Figure 3-8:  Pick a preset gradient from this drop-down list.

				

					[image: 9781118168608-fg080308.eps]

				

			

		

	
		
			
				Chapter 4: Creating  Text in Fireworks

				In This Chapter

				[image: check.png] Creating and formatting text

				[image: check.png] Setting a text attribute

				[image: check.png] Working on spacing, alignment, and orientation

				[image: check.png] Applying effects

				[image: check.png] Styling text

				[image: check.png] Checking your spelling

				[image: check.png] Setting text on a path

				[image: check.png] Outlining your text

				Fireworks isn’t the application you want to use to create a four-page printed brochure, but it does offer you some pretty decent text capabilities anyway. Whether you’re working with paragraphs or single lines of text, you have many options that allow you to change fonts, switch styles, and add interesting effects. In this chapter, you find out where to find the features you need to make your text look good onscreen.

				Creating Text

				Using Fireworks, you can add text to your document in one of two ways:

				[image: check.png] Select the Type tool, click in the image area, and begin typing.

				[image: check.png] Copy (or cut) text from another application, select the Type tool, and paste it on the artboard.

				[image: tip.eps]	In a hurry? You can select text from one application and then click and drag it into the Firework workspace.

				Setting Text Attributes

				Text can create mood and feeling, so you have to make sure your message has the right font and style. You can apply text attributes by using one of two main methods: the Type menu or the Properties panel. 

				In this chapter, you use the Properties panel (see Figure 4-1) because it provides a simple method to locate many text attributes. If the Properties panel isn’t visible at the bottom of the Fireworks workspace, choose Window⇒Properties.

					

				
					Figure 4-1: Choose font, size, and other attributes.

				

					[image: 9781118168608-fg080401.eps]

				Whether you use the Type menu or Properties panel, you can set text attributes from the Properties panel either before or after you enter text.

				[image: remember.eps]	The same rule applies in Fireworks as in all other applications: You have to select it to affect it. Before you apply any attributes, use the Pointer or Text tool to select the text you want to format.

				To set text attributes with the Properties panel, follow these steps:

					1.	Select the text you want to format.

					2.	Select a font from the Font drop-down list and then select a style from the Style drop-down list.

				[image: tip.eps]		If you don’t see your favorite font in bold, you can take advantage of the Bold button to create faux bold text. (It isn’t the true bold font, but it’s close.) The same trick works with the Italic button.

					3.	To assign color, click the color selector box to the right of the Size drop-down list and then choose a color from the pop-up Swatches panel.

				Fine-Tuning Spacing, Alignment, and Orientation

				When you compare the text controls with those in other Creative Suite applications, you may find that the text controls in Fireworks leave much to be desired. But you can still fine-tune some of your text attributes. For instance, you adjust the spacing between characters or lines of text using the Properties panel.

				Sliders are available in the Properties panel for adjusting the kerning (spacing between two characters), tracking (spacing between multiple letters), and leading (spacing between lines of text). Select the text you want to format, adjust the slider as shown in Figure 4-2, and then click off the slider to confirm the change.

					

				
					Figure 4-2:  Adjust kerning, tracking, and leading.

				

					[image: 9781118168608-fg080402.eps]

				[image: remember.eps]	You control kerning and tracking by using the same Kerning tool. To kern between two letters, insert the cursor between the two letters before making a change. To adjust tracking, select multiple letters before making a change.

				To align selected text, click the Left, Center, Right, or Justified alignment button in the Properties panel.

				You can also change the orientation of selected text by clicking the Set Text Orientation button. (See Figure 4-2.)

				Adding Effects

				Spunk up your text by adding Live Effects from Photoshop. You can add drop shadows or 3D effects or even make your text look like wood!

				To add effects to your text, follow these steps:

					1.	With the Pointer tool, select some text and then click the Add Filters button in the Properties panel, shown in Figure 4-3.

					

				
					Figure 4-3:  Click the Filters button to apply additional effects.

				

					[image: 9781118168608-fg080403.eps]

					2.	Select Photoshop Live Effects from the pop-up window that appears.

						The Photoshop Live Effects dialog box appears. (See Figure 4-4.)

					

				
					Figure 4-4: Set text effects in the Photoshop Live Effects dialog box.

				

					[image: 9781118168608-fg080404.eps]

					3.	In the list on the left side of the dialog box, select the effect you want to apply.

					4.	Set the related options on the right side of the dialog box and click OK.

						The effects are applied to your text, as shown in Figure 4-5.

					

				
					Figure 4-5: Create interesting text effects.

				

					[image: 9781118168608-fg080405.tif]

				[image: tip.eps]	Don’t apply all these effects to your text at the same time. You’ve heard it before, but we have to say it again: Just because you can do something doesn’t mean that you always should.

				Giving Your Text Some Style

				You can choose among an array of interesting default styles to apply to both objects and text. You can also create your own styles — an extremely helpful capability when text needs to be consistent throughout an entire website.

				Styles are applied to the entire text area.

				Applying an existing style

				To apply an existing text style, follow these steps:

					1.	Create some text by typing, cutting, copying, and pasting or by dragging the text on the artboard.

					2.	Use the Pointer tool to select the text you want to affect.

					3.	Choose Window⇒Styles.

						The Styles panel appears. (See Figure 4-6.)

					4.	From the drop-down list, select a category of style that you want to apply.

						In Figure 4-6, the Chrome Styles category was selected.

					5.	Click the style preview that you want to apply to your selected text.

					

				
					Figure 4-6: Click a style to apply interesting attributes to your selection.

				

					[image: 9781118168608-fg080406.eps]

				Creating your own style

				Save yourself time by applying all the text attributes you need to make your text look just right.

				To create a custom style, follow these steps:

					1.	Select some text and apply all the formatting and effects you want to use, following the procedures described earlier in this chapter.

					2.	Choose Window⇒Styles to display the Styles panel.

					3.	From the Style Category drop-down list, choose a category for saving the style.

					4.	Click the New Style button in the lower-right corner of the Styles panel. (Refer to Figure 4-6.)

						The New Style dialog box appears.

					5.	Type an appropriate name for the style in the Name text box.

					6.	Select the attributes you want to save and click OK.

						You have a saved style that you can apply to selected text at any time.

				Spell-Checking Your Text

				Checking your spelling is simple, right? It certainly is simple in Fireworks, so you have no excuse for typographical errors.

				To check the spelling of your text in Fireworks, follow these steps:

					1.	Choose Text⇒Spelling Setup.

						The Spelling Setup dialog box appears.

					2.	Choose the language that you want to use for the spelling check.

					3.	Set any other options you want to use and click OK.

					4.	Choose Text⇒Check Spelling.

						The Check Spelling dialog box appears with the first questionable spelling highlighted.

				[image: tip.eps]	If you want to add unique words in your document to the spell-checking dictionary, click the Add to Personal button in the upper-right corner of the Check Spelling dialog box.

				Attaching Text to a Path

				Add some excitement by attaching text to a path. In Figure 4-7, the text is attached to a curvy path, but you can just as easily create angled text or text that follows a circle.

				Follow these steps to attach text to a path:

					1.	Select the text that you want to attach to the path.

					2.	Create a path with the Pen, Line, or Shape tool.

						See Book III, Chapter 5 for additional details on creating a path using the Pen tool. 

					

				
					Figure 4-7: You can make text curve by attaching the text to  a path.

				

					[image: 9781118168608-fg080407.tif]

					3.	Using the Pointer tool, select the text area and then Shift-click the path.

						Both the text and the path are selected.

					4.	Choose Text⇒Attach to Path.

				[image: tip.eps]		If you want the text to run inside a shape, such as a circle, choose Text⇒Attach in Path.

				To change the orientation of the attached text on the path, choose Text⇒Orientation and then choose an orientation option from the submenu. In Figure 4-8, the orientation has been changed to Skew Vertical.

					

				
					Figure 4-8: You can change the text orientation on the path.

				

					[image: 9781118168608-fg080408.tif]

				Outlining Text

				Creating interesting text with unique fonts can be fun. But what if you need to send the text to someone whose computer perhaps doesn’t have your funky Giddyup font installed? No problem — Fireworks lets you outline text, which means essentially to turn it into a vector path.

				[image: warning_bomb.eps]	You can’t edit the content of your text after you outline it.

				To outline your text, follow these steps:

					1.	Create some text with the attributes you want, including the font.

						The size doesn’t have to be exact, however; you can rescale even after outlining the text.

					2.	With the Pointer tool, select the text area.

				[image: remember.eps]		You can’t outline individual letters or words within a text area.

					3.	Choose Text⇒Convert to Paths.

						The text is outlined.

				To edit the new vector path, switch to the Subselection tool and click an individual letter, as shown in Figure 4-9.

				[image: tip.eps]	You can ungroup your text by selecting it then choosing Modify⇒UnGroup.

					

				
					Figure 4-9:  Turn your text into vector paths.

				

					[image: 9781118168608-fg080409.tif]

				

			

		

	
		
			
				Chapter 5: Getting Images  In and Out of Fireworks

				In This Chapter

				[image: check.png] Importing images

				[image: check.png] Editing images

				[image: check.png] Optimizing and exporting images

				Most often, you use Fireworks to optimize images for your web or mobile app. In this chapter, you find out how to work with images from various sources, discover the importance of optimizing, and learn how to export your images.

				Getting Images into Fireworks

				Besides making your own graphics and illustrations, you can use four main methods to import images into Fireworks:

				[image: check.png] Open: Fireworks isn’t picky. As long as you open images (vector or raster) by choosing File⇒Open, you can open pretty much anything in Fireworks.

						When you open a native Adobe Illustrator or Photoshop file, expect to see a dialog box, like what you see in Figure 5-1. This particular dialog box appears when you open a vector image from Adobe Illustrator. As you can see, you have to make some decisions as to what size the file should be, which artboards should be imported, and how you want to handle layers and groups. 

						When importing a Photoshop file, your choices are relatively similar, as shown in Figure 5-2. The integration between Fireworks and Photoshop is excellent; you can keep layers intact and continue your editing process in Fireworks.

				[image: check.png] Import: By choosing File⇒Import, you can place an image directly in an existing image. The imported image is placed as a sublayer in the selected layer, as shown in Figure 5-3. Note that to complete your import, you need to click on the image area.

					

				
					Figure 5-1: Importing a native Illustrator file into Fireworks.

				

					[image: 9781118168608-fg080501.eps]

					

				
					Figure 5-2: Importing a native Photoshop file into Fireworks.

				

					[image: 9781118168608-fg080502.eps]

					

				
					Figure 5-3: Choose the Import menu item to add an additional image as a layer in Fireworks.

				

					[image: 9781118168608-fg080503.eps]

				[image: check.png] Drag and drop: You can drag and drop an image from other applications, such as Adobe Illustrator and Adobe Photoshop, right into the Fireworks workspace.

				[image: remember.eps]		To drag and drop between Adobe applications on the Windows platform, you must drag your selection down to the application’s tab on the taskbar and wait for the application to come forward. Then you can drag into the work area.

				[image: check.png] Browse: Just as you can in the rest of the Creative Suite applications, you can take advantage of Adobe Bridge to preview, search, and  organize images before opening them in Fireworks. Because images  typically open in Photoshop by default, you should right-click the image  (in Bridge) and choose Open with Adobe Fireworks CS6 from the  contextual menu.

				To open a file in Bridge, you must click the Browse in Bridge button on the Application bar in Fireworks, as shown in Figure 5-4.

					

				
					Figure 5-4: Click this button to open Adobe Bridge.

				

					[image: 9781118168608-fg080504.tif]

				Editing Images

				After you have an image open in Fireworks, you can start editing it. The editing features in Fireworks are similar to those in Photoshop but aren’t as extensive. You can do many basic tasks in Fireworks — crop, paint, and even curve adjustments — but we suggest that you perform most of your in-depth retouching in Photoshop.

				The following sections explain five basic image-editing tasks that you typically perform when creating web graphics. We also discuss the Image Editing panel, which lets you choose among multiple editing tools.

				Scaling

				Making images the right size is important. If an image is too large, you waste valuable download time; if it’s too small, the image looks pixelated and blurry. The following sections cover three scaling methods.

				Proportional scaling

				To scale an image in Fireworks proportionally (keeping the same width and height ratio), follow these steps:

					1.	Select the layers you want to scale.

						If you have multiple layers, you can hold down the Ctrl (Windows) or [image: maccmd] (Mac) key and click the layers in the Layers panel to add them to the selection.

						2.	[image: 9781118168608-ma107.tif] Select the Scale tool in the Select section of the Tools panel.

							Anchor points surround your selection.

					3.	To make an image smaller, click and drag a corner anchor point toward the center; to make an image larger, click a corner anchor point and drag outward.

				[image: warning_bomb.eps]	Typically, you don’t scale a bitmap image to a dramatically larger size, because it may become pixelized. A fundamental rule to follow is to not make raster images more than 20 percent larger. This rule, of course, doesn’t apply to vector objects, as they’re scalable.

				Nonproportional scaling

				If you don’t want to scale proportionally, follow these steps:

					1.	Select the layers you want to scale.

					2.	Select the Pointer tool in the Select section of the Tools panel.

					3.	To resize an image, click and drag a corner anchor point without using the Shift key.

				Numeric scaling

				If you need to constrain scaling to an exact amount, you’re better off using the Image Editing panel. Follow these steps to perform numeric scaling:

					1.	Select the layers you want to scale.

					2.	Choose Window⇒Others⇒Image Editing.

						The Image Editing panel appears.

					3.	Click Transform Commands and select Numeric Transform from the drop-down list.

						The Numeric Transform dialog box appears, as shown in Figure 5-5.

					

				
					Figure 5-5:  You can scale numerically by using the Image Editing panel.

				

					[image: 9781118168608-fg080505.eps]

					4.	In the Width and Height text boxes, type the percentage by which you want to scale and click OK.

				Cropping

				Unwanted image data is a bad thing for web graphics because it takes up valuable space and also the user’s time when downloading. Follow these steps to eliminate unwanted image areas:

						1.	[image: 9781118168608-ma108.tif] Select the Crop tool from the Select area of the Tools panel or from the Image Editing panel.

							Refer to the preceding section, “Numeric scaling,” to see how to open the Image Editing panel.

					2.	Click and drag to select the area you want to keep when the crop is complete.

					3.	Press the Enter or Return key.

						The image is cropped to the selected area.

				If you’re working with a wireframe of a larger web page design, you may want to export only a small portion — for example, to export just the navigational tools, not the rest of the page. To crop only when exporting, follow these steps:

					1.	Click and hold the Crop tool to select the Export Area tool.

					2.	Click and drag to select the area you want to keep when the image is exported.

					3.	Double-click in the middle of the cropped area.

						The Image Preview window appears, as shown in Figure 5-6, offering you the opportunity to set export settings for this section of your image.

					

				
					Figure 5-6: Double-click in the area you created using the Export Area tool to open the Image Preview window.

				

					[image: 9781118168608-fg080506.eps]

					4.	Choose your export settings.

						You can select a Format GIF, JPEG, PNG, WBMP, or TIFF setting from the Format drop-down list in the upper-right area of the Image Preview dialog box or use the Options, File, and Animation tabs on the left to set up custom export options.

					5.	Click Export.

						The selected area is exported to a location you choose, and you return to your image, which is still intact.

				Painting

				Fireworks has many of the same painting capabilities as Photoshop, but the methods in which you use them can be quite different.

				For example, when you select the Brush tool from the Bitmap section of the Tools panel you make decisions about the size of the brush, paint color, and blending mode from the Properties panel (see Figure 5-7) rather than from the Options panel, as in Photoshop.

					

				
					Figure 5-7: Change your Brush tool settings.

				

					[image: 9781118168608-fg080507.eps]

				Cloning

				The Rubber Stamp tool works much like the Clone Stamp tool in Photoshop. Follow these steps to clone (copy) pixels in Fireworks:

						1.	[image: 9781118168608-ma116.tif] Select the Rubber Stamp tool in the Bitmap section of the Tools panel.

						2.	Hold down the Alt (Windows) or Option (Mac) key and click the part of the image you want to clone.

						In Figure 5-8, the crosshair on the boy’s left shoulder indicates the pixels that you’re cloning.

					

				
					Figure 5-8:  Select pixels for cloning and start painting.

				

					[image: 9781118168608-fg080508.tif]

					3.	Position the mouse pointer over the area where you want the cloned pixels to appear and start painting.

						The cloned pixels appear in the image area. (See the left side of Figure 5-8.)

				Red eye, be gone!

				Red eye typically occurs in your images when a camera is used that has a built-in flash. The flash reflects off the retinas of your subject’s eyes in the image. You can eliminate red eye easily by clicking and holding down on the Rubber Stamp tool to select the hidden Red Eye tool; then simply click and drag a marquee around each red-eye occurrence.



				As you paint, follow the marker for the source; it moves simultaneously  with the mouse pointer. You can use the Properties panel to change brush attributes.

				Filtering

				Filters offer you many opportunities to edit your images. You can choose to blur an image or adjust its colors by using the Curves or Hue Adjustment layer. To access your filters, you can choose them from the Filters menu or choose Window⇒Others⇒Image Editing.

				If you want to apply additional filters that you can change later or even delete, click the Add Filters button in the Properties panel, shown in Figure 5-9, and select Photoshop Live Effects from the drop-down list. The Photoshop Live Effects dialog box appears as shown in Figure 5-9.

				In the following example, you use the Hue/Saturation filter to add a color tint to an image. Follow these steps:

						1.	[image: 9781118168608-ma105.tif] Open an image and select it with the Pointer tool.

						2.	Click the Add Filter button in the Properties panel.

					3.	Choose Adjust Color and then Hue/Saturation.

						The Hue/Saturation dialog box appears. (See Figure 5-10.)

					4.	Select the Colorize check box to apply a color tint.

					5.	Adjust the Hue slider until you find a color you want and click OK.

				If you want to edit or delete a filter, follow these steps:

					1.	In the Filters list in the Properties panel double-click the listed filter to edit it.

						The Hue/Saturation Filter dialog box opens, where you can make changes to the filter.

					2.	Delete a filter by selecting it from the filter list and clicking the minus icon (–) located on top of the filter list.

					

				
					Figure 5-9:  Click the Add live filters plus sign and select Photoshop Live Effects to create nonde­struc­tive filter changes.

				

					[image: 9781118168608-fg080509.eps]

					

				
					Figure 5-10: Applying a color tint with the Hue/Saturation filter.

				

					[image: 9781118168608-fg080510.tif]

				Optimizing Images for the Web

				Now that you’ve created and edited your image, you’re ready to prepare it for the web. You must consider two major factors in web graphics: speed of download and appearance. Having the best of both worlds is difficult, however; usually, you opt to give up some appearance for better speed. This process is optimization.

				Previewing web settings

				Fireworks helps you with the optimization process from the beginning. By using the 2-Up preview in the upper-left section of the image window, you can easily compare your optimized image with the original, based on your settings in the Optimize panel.

				You can even use the preview windows to compare two to four web formats and see which one looks best but has the most reasonable file size. 

				If you want to go crazy, you can compare four settings by clicking 4-Up.  (See Figure 5-11.) Using the preview windows, you can quickly change various settings — such as format, number of colors, and quality — and see the effect immediately, without previewing the image on the web.

					

				
					Figure 5-11: Compare four web image formats by choosing 4-Up view.

				

					[image: 9781118168608-fg080511.eps]

				Working with the Optimize panel

				Now that you know how to compare images, where do you make the necessary optimization changes? In the Optimize panel, of course. (See Figure 5-12.) For a more thorough description of each file format, including its benefits and drawbacks, see Book IV, Chapter 10, which covers web optimization in Photoshop CS6.

				Choose Window⇒Optimize to open the Optimize panel; and apply settings that provide the best, most size-efficient image. If you aren’t sure what to pick, choose a default setting from the Saved settings drop-down list. Typically, line art and vector graphics (created with solid colors) are best to save as GIF files, whereas photographs or images with gradient tints should be saved as JPG or PNG files. After choosing the optimal settings, you can export the image, as the following section explains.

					

				
					Figure 5-12: Use the Optimize panel to find the best quality at the smallest file size.

				

					[image: 9781118168608-fg080512.eps]

				Exporting for the Web

				You can export individual images or entire web pages by using the Export feature of Fireworks. 

				To export a Fireworks document, follow these steps:

					1.	Choose File⇒Export.

						The Export dialog box opens, as shown in Figure 5-13.

					2.	Navigate to an appropriate location to save your file.

				[image: tip.eps]		If you intend to use this image on a website, the best practice is to save it in the folder you typically use for web images.

					3.	Type a name in the File Name text box.

					4.	Select Images Only from the Export drop-down list and click Save.

				In Chapter 6 in this minibook, you discover how to export entire pages with sliced images.

					

				
					Figure 5-13: After your document is optimized, you can export it for web use.

				

					[image: 9781118168608-fg080513.eps]

				

			

			
		

	
		
			
				Chapter 6: Hotspots, Slices,  and CSS Layouts

				In This Chapter

				[image: check.png] Getting familiar with Fireworks layers

				[image: check.png] Hyperlinking with hotspots and image maps

				[image: check.png] Creating slices

				[image: check.png] Exporting images and HTML as tables or CSS

				A simple method for organizing content and making a website dynamic is the use of hyperlinks, simple links from one location of a site to another. You can create a link by using a button, text, or even a move of the mouse pointer. By using layers in Fireworks, you can make those links dynamic and visually interesting.

				In this chapter, you find out how Fireworks uses layers and then create navigational links by using the Slice feature.

				Understanding Layers

				Even if you’re an Adobe Photoshop or Illustrator user, the Layers panel in Fireworks may be somewhat of a mystery because it works differently from the way you might expect. Read on to find out how to take advantage of Fireworks layers. To see the Layers panel, choose Window⇒Layers.

				Navigating the Layers panel

				Figure 6-1 shows the two main components of the Layers panel:

				[image: check.png] The Web Layer serves as a repository for anything code related, such as links and slices. In Figure 6-1, you see the links in the Web Layer  section.

				[image: check.png] The default Layer 1 includes sublayers that are created automatically for every object you add to the Fireworks canvas.

				Note that if you open an image from Photoshop that already has a Background layer, it carries through into Fireworks. (See Figure 6-1.)

					

				
					Figure 6-1: The Layers panel in Fireworks.

				

					[image: 9781118168608-fg080601.eps]

				Working with the Layers panel

				Here are just some of the things you can do in the Layers panel to organize your artwork better:

				[image: check.png] Hide and show layers: Click the Visibility (Eye) icon to hide or show a layer or sublayer.

				[image: check.png] Send objects forward and backward: Drag individual layers and sublayers to arrange objects on those layers in front of or behind each other.

				[image: check.png] Rename layers: By double-clicking the layer or sublayer name, you can rename the layer, which can be a huge help later when you’re trying to find a specific object.

				[image: check.png] Organize layers: Create appropriately named layers to house related sublayers, thereby gaining the ability to move, copy, or delete multiple layers at the same time.

				[image: check.png] Keep web components separate: Use the Web Layer to keep track of hotspots and slices as well as control the visibility of those items.

				Creating Hotspots

				Fireworks gives you lots of ways to take advantage of hyperlinks. In this section, you see how to create a hotspot — essentially, a simple link from text or a graphic to a URL (Universal Resource Locator) on the web. In Chapter 7 of this minibook, you find out how to create buttons that interact with the user.

				Defining a hotspot

				To link text or a graphic to a web URL, you must first define it as a hotspot. You can define a hotspot by using either of two methods:

				[image: check.png] Select the Hotspot tool in the Web section of the Tools panel and click and drag over the part of the image you want to create as the linked part of the image, as shown in Figure 6-2. Click and hold down the Rectangle Hotspot tool to see that you have a choice of creating a rectangular,  circular, or polygon hotspot.

					

				
					Figure 6-2: Click and drag over an area with the Hotspot tool to incorporate a hyperlink into your Fireworks document.

				

					[image: 9781118168608-fg080602.eps]

				[image: check.png] Select the item (text or graphics), right-click (Windows) or Control-click (Mac) the selected item, and choose Insert Hotspot from the contextual menu.

				Linking a hotspot

				After you define a hotspot, you can define the location (typically, a web page) that you want the hotspot to link to. Follow these steps:

					1.	Choose Window⇒URL.

						The URL panel appears. (See Figure 6-3.)

					

				
					Figure 6-3: Assign a link to a hotspot.

				

					[image: 9781118168608-fg080603.eps]

					2.	Type a URL address that you want the viewer to go to after selecting this region.

						In Figure 6-3, a link to a fictitious external website (http://www. uxbyarturot.com) is referenced. Note that you can add your URL  to a library for later use by clicking the plus sign to the right of the URL text box.

				[image: remember.eps]		When you reference pages beyond your website (external links), you must start the link with http://.

					3.	Choose Window⇒Layers to display the Layers panel if it isn’t already open.

						The hotspot you created appears as a separate sublayer of the Web Layer.

					4.	Double-click the name of this sublayer and give it a more appropriate name, as shown in Figure 6-4.

					

				
					Figure 6-4:  A new hotspot layer appears under the Web Layer.

				

					[image: 9781118168608-fg080604.eps]

				In the next section, you discover options for working with multiple hotspots.

				Working with Image Maps

				When you create a graphic and add multiple hotspots to it, it becomes an image map. In Figure 6-5, the image map was created with the Polygon Hotspot tool.

					

				
					Figure 6-5: Use an image map to define clickable regions in an image.

				

					[image: 9781118168608-fg080605.tif]

				Creating an image map

				To create an image map of your own, follow these steps:

					1.	Open a graphic file that you want to assign multiple hotspots to.

					2.	Click and hold the Rectangle Hot Spot tool in the Web section of the Tools panel and choose one of the three hidden hotspot tools: Rectangle, Circle, or Polygon.

					3.	If you chose the Rectangle or Circle tool in Step 2, simply click and drag to define the hotspot. To create a region with the Polygon tool, simply click and release from point to point to create a custom region.

				[image: tip.eps]	If you didn’t get the shapes just right, don’t fret. You can use the Pointer and Subselection tools to move and resize the hotspots.

				Linking an image map

				After you create an image map, you can define hotspots on it and link those hotspots to URLs. For directions on both procedures, refer to the “Creating Hotspots” section, earlier in this chapter.

				Here are some types of links other than URLs that you can use:

				[image: check.png] E-mail address: Type mailto:youremail address in the URL text box to create a link that opens a message window, with your address already entered and ready to go!

				[image: check.png] Link to another page in your Fireworks document: Many people like to create prototypes of their websites in Fireworks and demonstrate the link from one page to another. You can use the Pages panel to add a page to your document and then use the Link drop-down list in the Properties panel, shown in Figure 6-6, to link from one page to another.

				[image: tip.eps]		To export multiple pages from Fireworks, choose File⇒Export and then select All Pages from the Pages drop-down list. You can test your links by opening the newly created HTML file in a browser.

					

				
					Figure 6-6:  Link from one Fireworks page to another.

				

					[image: 9781118168608-fg080606.eps]

				[image: check.png] Non-HTML files on the server: You can type 2012/catalog.pdf, for example, to instruct the browser to open a PDF file named catalog that’s inside the 2012 folder.

				Repeat the process of defining hotspots and assigning URLs as many times as you like.

				Testing and exporting an image map

				After you’ve created and linked an image map, you’re ready to test and export it for use on your web page. Follow these steps:

					1.	Test your image map by choosing File⇒Preview in Browser.

					2.	If you’re happy with the results, close the browser window and return to Fireworks to export your file.

					3.	Choose File⇒Export.

						The Export dialog box appears.

					4.	Type a name in the Name text box.

					5.	Select HTML and Images from the Export drop-down list.

					6.	Select Export HTML File from the HTML drop-down list.

					7.	Select None from the Slices drop-down list and click Save.

					8.	If you’ve created multiple pages in your Fireworks file, don’t forget to select All Pages from the Pages drop-down list, as shown in Figure 6-7.

					

				
					Figure 6-7:  Export multiple pages from Fireworks by using the All Pages option.
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					9.	When you’re finished, click Save.

				That’s it! Now you can choose File⇒Open in your browser and locate the HTML file to test your finished project or choose File⇒Open in a web-editing program (such as Adobe Dreamweaver) to modify the HTML file.

				In Figure 6-8, you see the completed file in a web browser, along with the associated code that was created in Fireworks.

				Slicing Up Your Art

				Slicing is a technique for breaking large files into smaller packets so that they download faster on the web. It’s also a method for attaching URLs to different regions of an image, like image maps. Unlike image maps, however, slices are created in a grid pattern.

				You can even use slices to optimize different parts of an image with separate settings. Perhaps you can get away with having one section of an image be of lower quality than another section.

				A perfect candidate for sliced artwork is a navigation bar, such as the one shown in Figure 6-9. Each tab is an individual slice that, when clicked in a web browser, takes the viewer to a different location.

					

				
					Figure 6-8: The finished image map, as viewed in a web browser (top) and the HTML code created for the image map (bottom).
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					Figure 6-9: Use slices for navbars.
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				Creating the basic image

				First, you create the basic image — a rectangle, for this example. Follow these steps:

					1.	Choose File⇒New to open the New Document dialog box.

					2.	Type 500 in the Width text box and 200 in the Height text box; then click OK.

						The new, blank document opens. (Notice that it’s larger than the image you’re creating; you see how to modify it later in these steps.)

					3.	Select the Rectangle tool in the Vector section of the Tools panel and click and drag to create a rectangle.

						For this example, any size is fine.

					4.	With the rectangle selected, click Fill Color in the Colors section of the Tools panel and choose a color.

						For this example, we chose a light color (blue).

					5.	Choose Window⇒Info to open the Info panel.

					6.	Enter 300 in the W (Width) text box and 50 in the H (Height) text box, or use the Width and Height text boxes in the Properties panel to set this size.

						The rectangle is resized.

					7.	With the Pointer tool, click anywhere in the canvas outside the rectangle to deselect the rectangle.

					8.	Right-click (Windows) or Control-click (Mac) and choose Modify Canvas⇒Fit Canvas from the contextual menu. (See Figure 6-10.)

						The canvas adjusts to the size of the rectangle. (See Figure 6-11.)

					

				
					Figure 6-10: Choose the Fit Canvas command.
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					Figure 6-11: The canvas adjusts to fit your object.
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				[image: tip.eps]	When you have no objects selected, you may also click the Fit Canvas button in the Properties panel.

				Adding text

				You can add some text areas to the navbar. Follow these steps:

					1.	Select the Text tool in the Vector section of the Tools panel.

					2.	Click Fill Color in the Colors section of the Tools panel and choose a color.

						For this example, we chose a dark color (black).

					3.	Set the font and font size in the Properties panel.

						For this exercise, we changed the font to Arial and used the Font Size slider to change the size to 25.

					4.	Click the left half of the rectangle to position the insertion point wherever you want the text to begin, and type the text.

						For this example, we typed Home, as shown in Figure 6-12.

					

				
					Figure 6-12: Adding text to the navbar.
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					5.	Click twice to the right of the text area to deselect the active text area and create a new one.

				[image: tip.eps]		You can hold down the Alt+Shift (Windows) or Option+Shift (Mac) keys and drag the initial text box to the right to clone and align a new text box.

					6.	Type a word or two for your next navigation tab.

						For example, we typed About.

					7.	Use the Pointer tool to reposition the text.

				Doing the actual slicing and dicing

				After you’ve prepared a simple but efficient navbar, use the Slice tool to create a couple of slices and then export them. Follow these steps:

					1.	Select the Slice tool in the Web section of the Tools panel; then click and drag from the upper-left corner of the Home section of the rectangle toward the lower-right corner, as shown in Figure 6-13.

					

				
					Figure 6-13: Creating a slice.

				

					[image: 9781118168608-fg080613.eps]

						For this example, your drag doesn’t have to be exact.

				[image: tip.eps]		If you’re going for perfection, choose View⇒Rulers to display the rulers. When the rulers are visible, you can click and drag guides out of them.

						When you have an active slice, the Properties panel changes to offer you various slice options.

					2.	Change the format by making a choice from the Slice Export Settings drop-down list.

						Select the GIF format if the artwork has lots of solid color, or select JPEG for images with lots of gradation of color.

					3.	Enter a link in the Link text box. 

						For example, type http://www.agitraining.com.

					4.	Enter a brief description of the link in the Alt text box.

						Alt text is the text that appears while a page is downloading. It also appears in place of the graphic if a viewer has turned off the graphics display in his web browser.

						For example, type Training in the Alt text box, as shown in Figure 6-14.

					

				
					Figure 6-14: Enter the URL and  Alt text.
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					5.	With the Slice tool, click and drag to surround the second half of the navbar.

					6.	Type http://www.adobe.com into the Link text box and type Adobe, Inc. into the Alt text box.

				That is slicing in simple form. You can make the process as complicated as you want by creating entire sliced pages (because search engines like to search for text content) to navbars with many links and destinations.

				In the next section, you find out how to get your navbar out of Fireworks and on a web page.

				Exporting Slices

				You can export finished slices for use on a web page.

				Exporting slices as tables

				To export sliced artwork as tables (for these steps, your test navbar), follow these steps:

					1.	Choose File⇒Export.

						The Export dialog box appears.

					2.	Browse to the folder where you store your web files and make sure that you pick a file connected with the website you’re creating your images for.

					3.	In the File Name text box, enter a name.

						For this example, we typed navbar.htm.

					4.	Select Export HTML and Images from the Export drop-down list.

					5.	Select Export Slices from the Slices drop-down list and click Save.

				Now that you’ve exported the HTML code and the image, you can open the image in a web-editing program such as Dreamweaver and add elements or simply copy and paste it into an existing page or template. Find out more about Dreamweaver in Book VI.

				Changing the export format from table to CSS

				If you want more control of your slices, you can change the code that Fireworks creates upon output.

				In Figure 6-15, the selection for CSS and Images creates CSS (Cascading Style Sheets) rather than an HTML table when exported.

				Typically, creating a layout of a page using CSS code is beneficial because the information is more accessible and flexible for the user.

					

				
					Figure 6-15: You can choose to export slices as CSS.
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				Chapter 7: Using Buttons  and Symbols

				In This Chapter

				[image: check.png] Understanding states

				[image: check.png] Creating rollover buttons

				[image: check.png] Converting graphics to symbols

				Before you jump into creating buttons and animations, you need to understand states and how they work in Fireworks. States (a change in visibility) allow you to organize layers in such a way that you can create several versions of your artwork; these states can be used for rollovers or animations.

				Using States in Fireworks

				You may want to use states for two reasons:

				[image: check.png] Animation: You can build and edit animated GIFs with states like the one you see in Figure 7-1. One step of the animation goes into each frame. The states (sometimes referred to as frames) are played one after another to create the appearance of motion — an effect a little like a flip book you may have found in box of caramel corn. By using layers, you can specify which items are animated and which items remain static.

					

				
					Figure 7-1:  In this example, the astronaut fades to 0 percent opacity over three states.
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				[image: check.png] Rollovers: You can also use states to produce rollovers. By slicing an image (discussed in Chapter 6 of this minibook), you can trigger the different versions (or states) that appear when the user’s mouse pointer crosses over the artwork.

				Making a Rollover Button

				You can create interactive buttons in Fireworks to make rollovers, swap images, and react to other interactions with viewers. For all these effects, use the States panel.

				In this section, you find out how to use states to create a rollover button —  a button that changes when a mouse pointer passes over it.

				Creating the basic art

				First, you need to create the basic art for the button. (For this example, the button is a rounded rectangle, but you can substitute another shape.) Follow these steps:

					1.	Click and hold the Rectangle tool in the Vector section of the Tools panel and then select Rounded Rectangle from the list of hidden tools.

					2.	Click and drag in the workspace to create a shape.

						Any size is fine for this example.

					3.	Choose Window⇒Styles to open the Styles panel.

					4.	Select a style from the drop-down list.

						In Figure 7-2, Plastic Styles is selected.

						This basic button is what the viewer initially sees on your web page.

					

				
					Figure 7-2:  Using the Styles panel, apply any style to the shape.
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				Adding rollover behavior

				In this section, you add rollover behavior to the button and create the version of the button artwork that viewers will see when their mouse pointer passes over it. Follow these steps:

					1.	Select the rounded rectangle shape you created in the preceding section and then right-click to select Insert Rectangular Slice.

						The shape is highlighted, as shown in Figure 7-3, indicating that a hotspot has been created.

					

				
					Figure 7-3: Right-click to add a rectangular slice to a selected object.
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					2.	Right-click (Windows) or Control-click (Mac) the center of the slice and choose Add Simple Rollover Behavior from the contextual menu, as shown in Figure 7-4.

					

				
					Figure 7-4: Choose Add Simple Rollover Behavior to make your button a rollover.
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					3.	Choose Window⇒States to open the States panel.

					4.	From the States panel menu, choose Duplicate State, as shown in Figure 7-5.

					

				
					Figure 7-5: Choose to duplicate  a state.
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						The Duplicate State dialog box appears. Keep the settings at the default of State 1 being inserted after the current state, as shown on the left in Figure 7-6.

					

				
					Figure 7-6: Duplicate your original state before making changes that will occur on rollover.
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					5.	Click OK.

						A State 2 row appears in the States panel, as shown on the right in  Figure 7-6.

					6.	Click the Hide Slices and Hotspots tool in the Web section of the Tools panel, or turn the visibility of the Web layer off by clicking on the Visibility icon to the left of it in the Layers panel, as shown in Figure 7-7.

					

				
					Figure 7-7: Hide slices so that you can see your image.

				

					[image: 9781118168608-fg080707.eps]

					7.	With the Pointer tool, select the original shape you created.

					8.	Choose Window⇒Styles to open the Styles panel.

					9.	Select a new style from the drop-down list.

						This step creates the version of the button that appears when a viewer passes the mouse pointer over the button.

					10.	Save the file.

				Testing and exporting the button

				The rollover you created won’t work with the image file alone; unlike a .jpg, .gif, or .png file, the rollover needs supporting HTML and JavaScript code in order to make it work. To collect all the parts to make your rollover work, you need to export the rollover out of Fireworks. Follow these steps:

					1.	If the eye icon is turned off on the left side of the Web Layer in the Layers panel, turn it on now. 

						Your slices and hotspots are now visible. 

					2.	Choose File⇒Preview in Browser to test your button.

					3.	If you’re happy with the effect and want to use the button on a web page, choose File⇒Export to open the Export dialog box.

					4.	Name the file.

						Remember that you need to follow standard web-based naming  conventions.

					5.	Select HTML and Images from the Export drop-down list.

					6.	Make sure that Export HTML File is selected in the HTML drop-down list and that Export Slices is selected in the Slices drop-down list. Then click Save.

				Discovering Fireworks Symbols

				When you make web graphics, you may discover that you repeatedly create the same button or the same background image. To stay consistent and save lots of time, you can turn artwork into a symbol or use some of the precreated symbols in the Common Library panel.

				Symbols are simply elements you can store in the Common Library or Document Library panel. Use the Common Library to store symbols that you can access across Fireworks; the Document Library is for symbols to be accessed only within the associated document.

				Fireworks has three types of symbols: graphic, animation, and button. In this section, you find out how to use and modify symbols.

				Symbol instances refer to the placement of the symbols on the artboard. Symbol instances are dynamically linked back to the original symbol used to create them.

				[image: remember.eps]	If you convert artwork to a symbol, the new symbol object is linked dynamically to all instances of that symbol on the artboard. If you change the symbol object, all instances are updated automatically.

				Working with a precreated symbol

				To use a precreated symbol in Fireworks, follow these steps:

					1.	Choose Window⇒Common Library to open the Common Library panel.

						The precreated symbols in this library are organized in categories, such as Animations, Buttons, and Flex Components.

					2.	Double-click the category you want to use.

					3.	Select a symbol to see a preview in the preview pane at the top of the Common Library panel.

					4.	When you find a symbol you want to use, drag it out to the artboard.

						The symbol instance is placed on the artboard. (See Figure 7-8.)

					

				
					Figure 7-8: Creating a symbol instance.
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				If you’re creating a navigation bar with four buttons, for example, repeat Step 4 three times.

				Converting artwork to a symbol

				If you find yourself in the position of repeatedly creating the same button, animation, or graphic, follow these steps to convert that artwork to a symbol:

					1.	With the Pointer tool, select the artwork you want to convert.

					2.	Choose Modify⇒Symbol⇒Convert to Symbol.

						The Convert to Symbol dialog box opens.

					3.	Type a name for the symbol in the Name text box.

					4.	Select the symbol type: Graphic, Animation, or Button.

					5.	To scale the symbol without distorting it, select the Enable 9-Slice Scaling Guides check box. (See Figure 7-9.)

					

				
					Figure 7-9: Setting symbol options.
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					6.	To store the symbol so that it can be used in multiple documents, select the Save to Common Library check box.

					7.	Click OK to close the Convert to Symbol dialog box. Then click Save to save the symbol in the Custom Symbols folder.

						You can now find the saved symbol by choosing Window⇒Common Library. Double-click the Custom Symbols folder to locate any symbols created and saved to the Common Library.

				Scaling with 9-slice

				A helpful feature of Fireworks is 9-slice scaling, which lets you determine what part of a symbol will be scaled. This feature can be extremely helpful when you’re working with buttons that have rounded corners or other elements you don’t want to scale. To use this feature, simply select the Enable 9-Slice Scaling Guides check box in the Convert to Symbol dialog box.



				
					
				
				[image: tip.eps]	Adobe Illustrator has many symbols you can borrow from its symbol libraries. Simply drag a symbol from the Illustrator Symbols panel onto the artboard and then copy and paste the symbol into Fireworks. All components, such as vector shapes, are maintained. Find out more about Illustrator symbols in Book III, Chapter 11.

				Editing a symbol

				You can edit a symbol object or just one instance of it. You might want to edit the symbol object if you decide to change the color of all your buttons to orange at the same time, but you have to edit each symbol instance individually if you want each button to have a different word on it.

				To edit a symbol object or instance, right-click on it and choose Symbol⇒Edit Symbol, or choose Modify⇒Symbol⇒Edit Symbol. You are then entered into the Symbol editing mode. Here you can use your tools to reposition, recolor, retype, or make any other modifications that you’d make to any other graphic in Fireworks.

				Exit the editing mode by clicking the arrow in the breadcrumbs bar in the upper-left portion of the workspace, as shown in Figure 7-10.

					

				
					Figure 7-10:  Exit the Symbol editing mode by clicking the arrow.
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				If you no longer want an object to be a symbol, choose Modify⇒Symbol⇒Break Apart.

				Editing a symbol without breaking the link

				At times, you may want to change an instance but maintain its link to the symbol object. Perhaps you’re creating a cool graphic effect of butterflies and want to change one butterfly’s position and opacity, as shown in  Figure 7-11.

					

				
					Figure 7-11:  Edit properties of symbol instances without breaking the link to the original symbol.
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				You can use the Properties panel to modify the following instance properties without affecting the symbol object or other symbol instances:

				[image: check.png] Blending mode

				[image: check.png] Opacity

				[image: check.png] Filters

				[image: check.png] Width and height

				[image: check.png] X and Y coordinates

				Editing a symbol component

				At times, you need to break apart a symbol so that you can edit its components, perhaps to change their colors. To edit individual components of a symbol, follow these steps:

					1.	Select the symbol instance you want to modify.

					2.	Choose Modify⇒Symbol⇒Break Apart.

						The symbol instance is no longer linked to the symbol object.

					3.	With the Subselection tool, select the components of the artwork that you want to edit.

						They’re now ready for you to make any changes that you would make to regular (nonsymbol) objects on the artboard.

				[image: remember.eps]		When you modify the original symbol object, this instance is no longer affected.

				

			

			
				

			

		

	
		
			
				Chapter 8: Don’t Just Sit  There — Animate!

				In This Chapter

				[image: check.png] Creating and editing animations

				[image: check.png] Adjusting your playback

				[image: check.png] Working with tweening

				[image: check.png] Animating with masks

				[image: check.png] Exporting animations for the web

				Animations, used in moderation, can liven up a page. You can make simple animations to create effects of light and movement — or go to the max with dancing babies. The subtle approach probably is better because most folks are more intrigued by interesting content than by distracting animations. Still, you find animations being used every day, especially in rotating banner ads.

				The animations you produce in Fireworks aren’t quite the same as those in Flash. Fireworks animations typically are smaller and are saved in the GIF format, which doesn’t require a plug-in to view. You create them by using the States panel, which we cover in detail in Chapter 7 of this minibook.

				In this chapter, you use the States panel to create multiple versions of your artwork that play one after another to create an animation.

				[image: remember.eps]	You can use the terms states and frames interchangeably (though we generally prefer the term states).

				[image: tip.eps]	As you create images for animation, experiment to find out how many colors you can include without increasing the file size dramatically. If you’re working with size restrictions (as many advertising sites require), you may have to make the image files smaller by deleting states or adjusting color. Creating animations is a give-and-take process in which you’re trying to get the best effects from the smallest files.

				Getting Started with Animation

				Creating images is a simple process in Fireworks. Creating images for animations is also simple but slightly different, in that the images are created from several states that play one after another to create the illusion of movement. In the first two sections of this chapter, you create a simple manual animation of a bouncing ball. Later in the chapter, you find out how to automate the process.

				Creating an animation

				To create an image for animation, follow these steps:

					1.	Create or open the object you want to animate.

						For this example, create a circle with the Ellipse tool.

					2.	With the Pointer tool, select the circle.

					3.	Choose Window⇒States.

						The States panel appears, listing one state. (See Figure 8-1.)

					

				
					Figure 8-1: The States panel.
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					4.	From the panel menu in the upper-right corner, choose Duplicate State.

						The Duplicate State dialog box appears.

					5.	Use the Number slider to add three new states, as shown in Figure 8-2.

					6.	In the Insert New States section, select the After Current State radio button and then click OK.

						Because all the states are identical, you see no change. The objects are positioned on top of one another.

					

				
					Figure 8-2: Duplicating states to create an animation.
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				Onion skinning

				Onion skinning can be a huge help when you’re trying to create a good flow for an animation. Onion skinning gives you the opportunity to edit the selected state but view (in a dimmed view) the states that come before and after the selected state, as shown in Figure 8-3.

					

				
					Figure 8-3: Keep track of states with onion skinning.
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				To use onion skinning in an animation, follow these steps:

					1.	Select the State 2 row in the States panel.

					2.	Click the Onion Skinning button in the lower-left corner of the panel. (Refer to Figure 8-1.)

						A drop-down list appears.

					3.	Select Show All States to show all states. The states that are not active show up in a semi transparent form.

				Adding an object to multiple states

				Perhaps you created the perfect animation but then discovered that you forgot to include an element. You can copy or create the missing object in one state and then add it to all the other states. Follow these steps:

					1.	Select the state in which you want the new object to appear. 

						Make sure that you click the state’s name (in the States panel) in order to select it.

					2.	Copy and paste the artwork for the new object to the selected state or create the new object in that state.

					3.	Make sure that the new artwork is selected, right-click (Windows) or Control-click (Mac) the selected state in the States panel, and choose Copy to States from the contextual menu.

						The Copy to States dialog box appears.

					4.	Select the All States radio button (see the following figure) and click OK.

						The selected object is included in all the states.

				[image: 9781118168608-sb080801.eps]





				
				Making the animation move

				Creating the actual animation certainly isn’t rocket science, but you need to pay attention to the state you select before making your move.

				To put your animation in motion, follow these steps:

					1.	Select State 2 in the States panel to view the state 2 circle.

					2.	Using the Pointer tool, drag the circle slightly up and to the right.

					3.	Select State 3 to view the state 3 circle.

					4.	Drag the circle below and to the right of the state 2 circle.

					5.	Select State 4 to view the state 4 circle.

					6.	Drag the circle above and to the right of the state 3 circle.

						You should see a flow that — in a primitive way — represents a bouncing ball. (See Figure 8-4.)

					

				
					Figure 8-4: Creating an animation manually.
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				Testing the animation

				You can test an animation directly in the Fireworks artboard or on the web.

				Testing in Fireworks

				Fireworks provides several playback controls on the right side of the artboard window, as shown in Figure 8-5.

					

				
					Figure 8-5: Test the animation in Fireworks with the playback controls.
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				To use these controls to test an animation in Fireworks, follow these steps:

					1.	Click the Play button to start the animation.

						Notice that the Play button changes to the Stop button.

					2.	After playing the animation, click the Stop button to stop the animation.

				In the “Adjusting Playback” section, later in this chapter, you find out how to control the speed of each state (or frame) and discover where to turn looping (repeat) off and on.

				Testing on the web

				The Preview in Browser feature gives you a more accurate idea of how your animation will appear to the viewer. This procedure is so easy that no steps are necessary: Choose File⇒Preview in Browser and select the browser in which you want to preview the animation. If the animation doesn’t work in your browser, make sure that you have GIF selected as the Export File Format in the Optimize panel in Fireworks.

				If you are still having problems, you can choose File⇒Export Wizard, and follow the steps to save an animated GIF.

				Adjusting Playback

				You can speed or slow an entire animation or control the speed of each slide individually. Controlling the timing of individual states can be helpful in an advertising animation, for example, if you want to keep one state visible longer than the others. You can also loop an animation. This section describes both types of changes.

				Changing the frame rate

				The frame rate is the speed at which your animation will play. To change the frame rate, follow these steps:

					1.	Select the states for which you want to set the frame rate.

					2.	Choose Properties from the panel menu in the upper-right corner of the States panel.

						The State Delay pop-up appears, as shown in Figure 8-6.

					

				
					Figure 8-6: Change the frame rate.
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					3.	In the text box, enter a value (in 100ths of a second) to make the  animation go faster or slower.

						The lower the value you enter, the faster the animation plays. Make sure that the Include When Exporting check box is selected. Click anywhere on the artboard to close the drop-down window that you used to change the animation speed.

					4.	(Optional) To test the results of your frame rate change, click the Play button in the lower-right side of the artboard window.

				[image: tip.eps]	Want to display one state longer than the others? Select only that particular state and then change its frame rate to be slower than the other states’ frame rates.

				Playing it again: Looping

				You can choose to loop an animation into eternity or just a certain number of times. To do this, follow these steps:

					1.	Click the GIF Animation Looping button in the lower-left corner of the States panel. (Refer to Figure 8-1.)

						A menu drops down.

					2.	Choose the number of times you want the animation to loop. (See Figure 8-7.)

					

				
					Figure 8-7: Set the loop for the animation in the States panel.

				

					[image: 9781118168608-fg080807.eps]

					3.	Save and close the animation.

				You’ve completed a manual animation. In the next section, you find out  how to create an animation in which Fireworks creates the states for you automatically.

				Tweening in Fireworks

				Tweening is the process of creating a state between two others, usually as a start or stop point for the animation. Use tweening to simulate an object moving, like a ball bouncing, or fading an image in or out of an animation.

				Creating a symbol

				To use the tweening feature in Fireworks, you must have a symbol — for this example, an arrow. To create this symbol, follow these steps:

					1.	Choose File⇒New and create a new document large enough to contain your animation.

						For this example, create a document that measures 500 x 500 pixels.

					2.	Click and hold the Rectangle tool and select the Arrow tool from the Vector section of the Tools panel.

					3.	In the upper-left corner of the canvas, click and drag to create a small arrow.

					4.	Choose Modify⇒Symbol⇒Convert to Symbol.

						The Convert to Symbol dialog box appears.

					5.	Type an appropriate name (such as Arrow) for the symbol in the Name text box, select the Graphic radio button and click OK.

						Fireworks converts your arrow graphic to a symbol.

				Cloning the symbol

				After you create a symbol, you need to clone the symbol to create start and end points for the animation. Follow these steps:

					1.	Select the arrow symbol on the canvas.

					2.	Holding down the Alt (Windows) or Option (Mac) key, drag the arrow to the lower right corner of the canvas.

						As shown in Figure 8-8, by holding down the Alt or Option key while you drag, you’re cloning the arrow.

					3.	Choose the Scale tool in the Select section of the Tools panel and make the cloned arrow (in the lower-right corner) larger than the original.

					4.	Using the Pointer tool, position both arrow symbols on the canvas the way you want them.

						These symbols are the start and end points for your animation, so place them where you want the animation to begin and end.

					

				
					Figure 8-8: Create a start and end point for the animation by cloning the symbol.

				

					[image: 9781118168608-fg080808.eps]

				Tweening the symbols

				When you have two instances of the symbol on the artboard, you’re ready to tween the symbols to create an animation. Follow these steps:

					1.	Use the Pointer tool to select one of the arrow symbols and then Shift-click the other to select both at the same time.

					2.	Choose Modify⇒Symbol⇒Tween Instances.

						The Tween Instances dialog box appears.

					3.	Enter a value in the Steps text box.

						For this example, enter 5 (see Figure 8-9) to create five new states (or frames) for transforming the small arrow into the large arrow.

					

				
					Figure 8-9: Set the number of states.

				

					[image: 9781118168608-fg080809.eps]

					4.	If you want the symbols to appear one at a time, you want those states to be distributed to separate states in the States panel, so select the Distribute to States check box.

					5.	Click OK.

					6.	Test your animation by clicking the Play button in the lower-right section of the Fireworks workspace and then save the file.

				Animating with Masks

				If you’re a Photoshop user, you’re probably familiar with masks. Masks let you choose the viewable area of an image. The process is much like cutting a hole in a piece of paper and then placing an image under it. The hole in the paper shows only the area of the image below that you want to expose; the rest of the paper masks (covers) the parts of the image that you don’t want to expose.

				You can take this masking feature a step further in Fireworks by animating a mask. In the following sections, you create a simple object and mask and then animate the mask.

				Creating an image and a mask

				To create the image and mask for your animation, follow these steps:

					1.	Create a new document that measures 500 x 500 pixels.

					2.	With the Star tool (hidden in the Rectangle tool), create lots of stars close together.

						Use any colors and sizes you want for the stars. This step creates  multiple layers.

					3.	Choose Window⇒Layers to open the Layers panel.

					4.	Click the top layer listed in the Layers panel and then Shift-click the bottom layer to select all the layers you created.

					5.	From the panel menu in the Layers panel, choose Flatten Selection.

						The layers are flattened into one bitmap layer.

					6.	Select the Marquee tool in the Bitmap section of the Tools panel, make a narrow rectangular selection through the middle of the stars, and then click the Add Mask button at the bottom of the Layers panel. (See Figure 8-10.)

						Fireworks creates a mask based on the image area you selected.

					

				
					Figure 8-10: Select an area for masking (top) and the mask based on the selection (bottom).

				

					[image: 9781118168608-fg080810.eps]

				Animating the mask

				In this section, you animate the mask but not the stars. Follow these steps:

					1.	In the Layers panel, click the chain icon that appears between the stars layer and the mask, as shown in Figure 8-11.

					

				
					Figure 8-11:  Click the chain to unlock it from the image.

				

					[image: 9781118168608-fg080811.eps]

						This chain lets you move the layer and mask independently.

					2.	In the Layers panel, click the mask to select it.

					3.	From the panel menu in the States panel, choose Duplicate State.

						The Duplicate State dialog box appears.

					4.	Select the After Current State radio button and click OK.

						State 2 appears.

					5.	With the Pointer tool, select the mask and then drag the mask down slightly on the canvas.

						The stars stay in place; only the mask moves.

					6.	Repeat Steps 3–5 at least once.

					7.	Test your animation by clicking the Play button in the lower-right section of the Fireworks workspace.

				You can come up with some creative animations by using this technique, perhaps using a logo or other text as a mask.

				Exporting an Animation

				You created it, you tested it, you previewed it, and now you want to use it. To make an animation work, all you have to do is choose the GIF format in the Optimize panel, and choose File Export Wizard to verify the format is being saved as a GIF. (GIF is the web format that supports animation.) No HTML is needed.

				To export an animation, follow these steps:

					1.	Choose File⇒Export.

						The Export dialog box appears.

					2.	Choose Images Only from the Export drop-down list.

					3.	Name the file.

					4.	Put the file in your site location by navigating to the correct folder and clicking Export.

			

			
				

			

		

	
		
			
				Chapter 9: Building a Wireframe Using Fireworks

				In This Chapter

				[image: check.png] Introduction to wireframing

				[image: check.png] Creating a master page in Fireworks

				[image: check.png] Adding navigational items

				[image: check.png] Exporting your wireframe

				Many people don’t understand the concept of wireframing much less how to create a good wireframe. Essentially, a wireframe introduces others on your team, or perhaps clients, to functionality that you might want to use on a website or an application. Wireframes are sometimes referred to as simplified prototypes, which you make so that you and others can test a website before investing lots of time in it.

				The intent behind a wireframe is to create a simplified model of your finished website or application. Typically they follow these rules (see Figure 9-1):

				[image: check.png] No color! Use only black and white.

				[image: check.png] No shading, rounded corners, drop shadows, or any other kinds of decorative formatting that might take away attention from the basic structure.

				[image: check.png] Use basic fonts. Selecting a typeface is a design concern best dealt with later in the process.

				Starting a Wireframe

				Sketching out your ideas on paper is fine, but when you’re ready to show others those ideas you’ll want to produce a wireframe. Wireframes offer the best way to show how all your ideas will work and fit together. Wireframes can be made using many CS6 applications, but Fireworks has the unique ability to allow you to create navigational elements within your wireframe.

					

				
					Figure 9-1: A typical wireframe doesn’t include any details that might distract from testing navigation.

				

					[image: 9781118168608-fg080901.tif]

				Creating a Master Page

				The first step anyone should take before diving into the wireframing process in Fireworks is to create a site map. Put some thought into the pages that you want to have in your site. ID each page on sticky notes and stick them to a wall or whiteboard. By planning ahead, you can save yourself lots of aggravation later in the process.

				When you have a rough idea of what your site will look like you can use Fireworks to build simple navigational elements on a page, like the ones in Figure 9-2, and then define that page as a master for all additional pages. Master pages make it very easy for you to replicate your site in an interactive clickable document that can be used to demonstrate your site’s functionality.

					

				
					Figure 9-2: Create a sample page with a few navigational elements that can be used as buttons.

				

					[image: 9781118168608-fg080902.tif]

				If you’re interested in using the master page technique, create your site map and then follow these steps:

					1.	In Fireworks, choose File⇒New and set up a new document to define the size of your default website or application.

						For this example, shown in Figure 9-3, we used 960 x 600.

					

				
					Figure 9-3: Create a new blank document in Fireworks CS6.

				

					[image: 9781118168608-fg080903.eps]

					2.	Build your navigational elements (buttons). (Refer to Figure 9-2.) If you like, add logos or additional text to your page by using the Fireworks tools. 

						If you have already created assets in Photoshop or Illustrator you can open, place, or paste these graphics right in Fireworks. In this example, we created three text boxes. (See Figure 9-4.)

					3.	Choose Windows⇒Pages and then double-click to rename the initial page.

						If it is to be your start page, change the name to Index or Home to make it easy to identify.

					4.	When you’ve renamed the page, right-click (Windows) or Control-click (Mac OS) on the page in the Pages panel and choose Set As Master Page from the contextual menu, as you see in Figure 9-4.

						You can edit this page by accessing it in the Pages panel at any time.

					5.	Click the New Page icon, located in the lower-right area of the Pages panel.

					6.	Using your site map (sticky notes, sketches, and so on), create each of the pages in your site.

						Note that each new page you create comes preloaded with the master page elements you defined.

					

				
					Figure 9-4: Turn 01 Page 1 into a master page.

				

					[image: 9781118168608-fg080904.tif]

					7.	Double-click each page name to rename the page appropriately. 

						As you can see in Figure 9-5, the pages in this example were simply named Sales, Service, and About. Not a super creative website, maybe, but it gets us where we’re going.

				In the next section, you make the navigational elements clickable.

					

				
					Figure 9-5: Create new pages and name them. Each page contains the master page elements.

				

					[image: 9781118168608-fg080905.tif]

				Creating Clickable Regions

				To turn the navigational elements you defined in the previous section into clickable regions (buttons) and link them to the appropriate pages, follow these steps.

					1.	Select the Master Page in the Pages panel and then right-click one of your navigational elements.

						In this example, we chose the word Sales.

				[image: remember.eps]		A right-click on a Mac can be performed without the mouse by pressing Control-click.

					2.	Select Insert Hotspot. (See Figure 9-6.)

						A blue rectangle appears on top of the navigational element, as you see in Figure 9-7.

					

				
					Figure 9-6:  Add a hotspot to the page by selecting Insert Hotspot from the contextual menu.

				

					[image: 9781118168608-fg080906.tif]

					3.	In the Properties panel, open the Link drop-down list and select the page that you want your navigational element to link to, as shown in Figure 9-7.

						In this example we selected the Sales.htm link.

					4.	Continue to do this with all other links.

					5.	To test your site, choose File⇒Preview in Browser⇒Preview All Pages. When you click your links, you should be directed to the appropriate page.

					

				
					Figure 9-7:  Add a hotspot, and then add a link using the Properties panel for each of the navigational elements.

				

					[image: 9781118168608-fg080907.tif]

				[image: tip.eps]		If it helps, go back to Fireworks and add to each of your secondary pages a single word describing the future contents of the page. Place this word right in the middle of the page so that you can easily identify it. That way, you can see that you are navigating to the right page when you test your links.

				For further testing, you can send your wireframe to others, as described in the next section. From here you can take your wireframe further into the prototyping stage by adding colors, art, and images to create a more visual design.

				Sending Your Wireframe to Others

				If you want to send your completed wireframe to someone else, choose File⇒Export. In the Export dialog box, open the Export drop-down list and select HTML and Images. Then open the Pages drop-down list and select All Pages. (See Figure 9-8.) Keep your images separate by selecting the Put Images in Subfolder option.

				You can now send the folder with all pages to others to test your site. To start testing, your recipient needs only to click the main page (the home page). Your hotspots will work as hyperlinks in the browser, allowing users to navigate through the site.

					

				
					Figure 9-8: Export your document to create a site and to send to someone else.

				

					[image: 9781118168608-fg080908.eps]

				

			

			
		

	
		
			
				[image: IFC_top]

				To access the cheat sheet specifically for this book, go to www.dummies.com/cheatsheet/adobecs6designpremiumaio.

				[image: IFC_bottom]

				Find out "HOW" at Dummies.com
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